Troubleshooting
Problem
AIX daemnons managed by SRC may not start
Symptom
A daemon managed by the SRC (System Resource Controller) may fail to start if it is improperly configured in the SRC ODM (Object Data Manager) table. Generally, no error messages are logged, and truss and kernel traces don't show any indication of a problem.
Cause
The ODM entry for the daemon is incorrect or corrupt.
Diagnosing The Problem
Run the following command as root and check for an incorrect entry.
odmget SRCsubsys | grep -p <subsystem name>
For example,
odmget SRCsubsys | grep -p syslogd
Resolving The Problem
Use the chssys command to correct the entry.
https://www.ibm.com/support/knowledgecenter/en/ssw_aix_72/com.ibm.aix.cmds1/chssys.htm
Was this topic helpful?
Document Information
Modified date:
15 September 2021
UID
isg3T1027587