IBM Support

Agents/Integration servers throw java.lang.reflect.InvocationTargetException

Troubleshooting


Problem

Attempts to run agents/integration servers leads to the Error ErrorCode="java.lang.reflect.InvocationTargetException" in IBM Sterling Order Management.

Symptom

The complete error is:

<Error ErrorCode="java.lang.reflect.InvocationTargetException"
       ErrorDescription="Error_description_not_available"
       ErrorRelatedMoreInfo="" ErrorUniqueExceptionId="172.16.232.5514499400272980000000004827">
       <Attribute Name="ErrorCode" Value="java.lang.reflect.InvocationTargetException"/>
       <Attribute Name="ErrorDescription" Value="Error_description_not_available"/>
       <Error ErrorCode="java.lang.reflect.InvocationTargetException" ErrorDescription="" ErrorRelatedMoreInfo="">

Cause

This error is a symptom of jar mismatch or a potential deployment issue.

Resolving The Problem

Ensure that the Agent configuration file (AgentDynamicClassPath.cfg) does not have duplicate entries for jars containing the same class.

For example: 
The duplicate entry in this case was:VENDOR_JAR=/opt/IBM/Sterling93/jar/websphere/85/com.ibm.jaxrs.thinclient_8.5.0.jar

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management System Software"},"ARM Category":[{"code":"a8m0z000000cy01AAA","label":"Performance"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"10.0.0;9.0.0;9.1.0;9.2.0;9.2.1;9.3.0;9.4.0;9.5.0"}]

Document Information

Modified date:
25 October 2025

UID

swg21973927