Troubleshooting
Problem
After you upgrade a vCenter server used for VMWare within IBM Cloud, the connection status for vCenter shows as Down in the NSX-T Manager.
Symptom
You notice the following symptoms:
- In NSX-T Manager, the value under System -> Fabric -> Compute Managers, Registration Status is green, but the connection status shows as Down.
- When you click Down to view more details, you see a message such as follows:
Cause
This situation occurs when the thumbprint information for the vCenter changed and you need to update it.
Environment
NSX-T 3.1.0
vCenter Version 7.0.2 Build 18455184
Resolving The Problem
To resolve the problem, take these steps:
- Connect to the vCenter appliance by using SSH as root.
- Run the following command, then copy the SHA256 fingerprint values from its output:
openssl x509 -in /etc/vmware-vpx/ssl/rui.crt -fingerprint -sha256 -noout
Example output:
SHA256 Fingerprint=25:08:3F:70:F7:30:FE:58:50:4F:6C:DA:70:20:DB:46:B6:26:7E:44:69:CD:F2:7B:20:65:E4:B8:98:DD:B3:D5 - In the NSX-T Manager, edit the affected Compute Manager (vCenter), re-enter the username and password, and paste the value for the new SHA-256 Thumbprint. Then, click Save.
- Wait while the NSX-T connects again with the new thumbprint information.
- Verify that the connection status shows as UP after your changes.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"","label":""},"Business Unit":{"code":"BU053","label":"Cloud \u0026 Data Platform"},"Product":{"code":"SSCLB3","label":"VMware Solutions"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
17 November 2021
UID
ibm16506835