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After a certificate update to the IBM Cloud environments, IBM Cognos Command Center (CCC) processes using a Cloud agent fail with 'Task Disappeared'

Troubleshooting


Problem

CCC jobs that use a Cloud Agent to execute processes are failing with 'Task Disappeared'. The process itself completes its work but the result of the task is not sent back from the agent to the server successfully through the message queue

Symptom

Process run in CCC has a Status of Failed with Result text of 'Task disappeared'. The Output of task shows the process finished executing normally.

The agent queue log, log_server_activemq.log, found by default in "C:\Program Files\ibm\Cognos Command Center\Common\apache-activemq-5.15.4\data\" will have the following message:

Could not start network bridge between: vm://Server_xxxxxxxxxx and: https://xxxxxx.planning-analytics.ibmcloud.com:443/ccagentqueue/ due to: Failed to perform GET on: https://xxxxxx.planning-analytics.ibmcloud.com:443/ccagentqueue/ as response was: com.ibm.jsse2.util.h: PKIX path building failed: java.security.cert.CertPathBuilderException: PKIXCertPathBuilderImpl could not build a valid CertPath

Cause

The public SSL Certificates were update on the IBM Planning Analytics for Watson cloud environments. The certificate provided by Digicert has a different chain of trust and includes an immediate certificate. This change will cause all processes that use a Cloud Agent to fail. 

Environment

IBM Cognos Command Center 10.2.4 IF1
Planning Analytics with Watson 2.0.9.5

Resolving The Problem

1.  Unzip certs.zip and copy files to C:\Program Files\ibm\Cognos Command Center

image-20210718174943-1

2.  Close IBM Cognos Command Center and stop all 3 IBM Cognos Command Center services

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3.  Open a Command Prompt as Administrator and navigate to "C:\Program Files\ibm\Cognos Command Center\Common\java.8.0.0\jre\bin"

image-20210718174943-2

4.  Run the following command to import the certificate to cacerts:

keytool -import -alias DigitCertCA -keystore "C:\Program Files\ibm\Cognos Command Center\Common\java.8.0.0\jre\lib\security\cacerts" -file "C:\Program Files\ibm\Cognos Command Center\DigiCertCA.crt"

Keystore password = changeit

5.  Run the following command to import the root certificate to the broker truststore:

keytool -import -alias newroot -keystore "C:\Program Files\ibm\Cognos Command Center\Common\apache-activemq-5.15.4\conf\broker.ts" -file "C:\Program Files\ibm\Cognos Command Center\digi_root.cer"

Keystore password = password
Trust this certificate = Y

6.  Run the following command to import the intermediate certificate to the broker truststore:

keytool -import -alias newint -keystore "C:\Program Files\ibm\Cognos Command Center\Common\apache-activemq-5.15.4\conf\broker.ts" -file "C:\Program Files\ibm\Cognos Command Center\digi_int.cer"

Keystore password = password

7.  Restart all 3 IBM Cognos Command Center Services

image-20210718174943-4

8.  Launch IBM Cognos Command Center. The Cloud Agent tests successfully and all processes that use the Cloud Agent are successful.

Document Location

Worldwide

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Document Information

Modified date:
22 July 2021

UID

ibm16473419