IBM Support

Adapter not found error message with return code -99999 when using PUT() function with the FILE Adapter

Troubleshooting


Problem

An Adapter not found error message with return code -99999 may occur when using PUT() function with the FILE Adapter.

Cause

The error may occur if the File Adapter is unable to write to a specific directory path and file name due to lack of permission.

Diagnosing The Problem

Test to confirm that the user account that is running the WebSphere Transformation Extender (WTX) / Transformation Extender (TX) map has the required permission to create a file in the directory specified in the PUT() function map rule.

Resolving The Problem

Set the required directory and file permission for the user account that is running the WebSphere Transformation Extender (WTX) / Transformation Extender (TX) map.

[{"Product":{"code":"SSVSD8","label":"IBM Transformation Extender"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"8.3;8.4;8.4.1;9.0","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

More support for:
IBM Transformation Extender

Software version:
8.3, 8.4, 8.4.1, 9.0

Operating system(s):
AIX, HP-UX, Linux, Solaris, Windows, z/OS

Document number:
281179

Modified date:
16 June 2018

UID

swg21984629