About cookies on this site Our websites require some cookies to function properly (required). In addition, other cookies may be used with your consent to analyze site usage, improve the user experience and for advertising. For more information, please review your options. By visiting our website, you agree to our processing of information as described in IBM’sprivacy statement. To provide a smooth navigation, your cookie preferences will be shared across the IBM web domains listed here.
Troubleshooting
Problem
After adding a HOSTNAME specification to the PATH statement for an Enterprise Extender (EE) definition, any attempts to start that connection fail with an IST1893I message, followed with a related failure of the action being performed (VARY ACT command, LU-LU session, ...). EE paths that specify IPADDR continue to work without an issue.
Symptom
IST1893I NAME-TO-ADDRESS RESOLUTION FAILED
IST1909I REMOTE HOSTNAME value
[IST1911I value]
IST314I END
Cause
The host name resolution process for that name is failing for some reason. There are many possible causes, the primary being an incorrect configuration of the TCPIP.DATA input (such as an incorrect DNS address). However if the userid associated with the VTAM address space does not have an OMVS segment defined, the name resolution process will fail in initialization before any attempt is made to look up the name.
NOTE: The above security related references link to documentation for the z/OS Security Server (RACF) product. If using some other SAF product, consult that vendor's documentation.
Diagnosing The Problem
Use the SYSTCPRE CTRACE to collect a trace of the name resolution process being performed. Reference the following for more information:
- The IP Diagnosis Guide chapter on Diagnosing Resolver Problems.
- Information APAR II13399 for instructions on capturing the CTRACE.
- Technote 1248724 on interpreting SYSTCPRE trace records.
Resolving The Problem
Have the security administrator add the missing OMVS segment information to VTAM's userid (for RACF, this is done using the ALTUSER command).
Use the SYSTCPRE CTRACE to determine if there is some other problem occurring in the name resolution process.
Related Information
[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"All","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.6;1.7;1.8;1.9;1.10;1.11;1.12;1.13;2.1;2.2;2.3","Edition":"","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]
Was this topic helpful?
Document Information
More support for:
z/OS Communications Server
Software version:
1.6, 1.7, 1.8, 1.9, 1.10, 1.11, 1.12, 1.13, 2.1, 2.2, 2.3
Operating system(s):
z/OS
Document number:
94959
Modified date:
15 June 2018
UID
swg21293666