IBM Support

ACSLS tracing

Question & Answer


Question

How to enable tracing of the ACSLS daemons?

Cause

Communications between the Tivoli Storage Manager server and the ACSLS server occur via the Server System Interface (SSI) and Client System Interface (CSI) daemons. The SSI daemon runs on the same host as the Tivoli Storage Manager server and the CSI daemon runs on the same host as the ACSLS server. As such, when there are problems communicating between the Tivoli Storage Manager server and ACSLS server, it may be necessary to enable tracing of the SSI and/or CSI daemons to identify the source of the problem.

Answer

Tracing of the SSI and CSI daemons can be enabled and disabled dynamically by sending a SIGUSR1 signal to the process. This can be accomplished by issuing the kill command against the process id, as described below:

    1. Identify the process id associated with the SSI/CSI daemon:
      a. on the host where the Tivoli Storage Manager server is running, issue the 'ps -ef | grep ssi' command
      b. on the host where the ACSLS server is running, issue the 'ps -ef | grep csi' command

    2. Issue the following command against the SSI/CSI process id to enable tracing:
      # kill -USR1 <process id>

    3. To disable tracing, re-issue the same 'kill' command against the SSI/CSI process id:
      # kill -USR1 <process id>

The resulting trace files generated by both the SSI and CSI daemons will be named trace.log.

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Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21635255