Troubleshooting
Problem
Users may get error "Access Denied" when attempting to map a drive to IBM i NetServer shares.
Cause
Typically, "Access Denied" is caused by authentication failures as documented here:
However, sometimes the user lacks authority to the underlying IFS directory.
Diagnosing The Problem
The first step would be for the user to test an alternate IFS interface such as the Access Client Solutions "Integrated File System" functionality or WRKLNK from an IBM i command line. A lack of authority to the IFS path will generate more useful error messages than what is received when mapping a network drive.
Resolving The Problem
Use the DSPAUT command to display the authority settings for all the directories in the path being accessed.
For example, assume there is a NetServer share named "MyDirC" which points to IFS path:
'/MyDirA/MyDirB/MyDirC'
...and the user profile gets "Access Denied" when trying to map to the "MyDirC" share.
A user must have both Read and eXecute authority to all directories in the path. So, If we execute:
DSPAUT OBJ('/MyDirA') OUTPUT(*PRINT)
DSPAUT OBJ('/MyDirA/MyDirB') OUTPUT(*PRINT)
DSPAUT OBJ('/MyDirA/MyDirB/MyDirC') OUTPUT(*PRINT)
...and review the output, the user must have at least:
Data
User Authority
MyUser *RX
...to all three directories.
Authority can be changed with the CHGAUT command.
Related Information
Document Location
Worldwide
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Document Information
Modified date:
24 August 2020
UID
ibm16321277