IBM Support

7042-CR9 fails to install/upgrade with "the current system does not have a valid machine type/model"

Troubleshooting


Problem

7042-CR9 fails to install/upgrade with "the current system does not have a valid machine type/model"

Symptom

HMC Model 7042-CR9 fails to install or upgrade with the following error message.


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Cause

A 7042-CR9 which has a version of SMBIOS greater than v2.8 could encounter this failure.

Environment

7042-CR9 upgrading or installing 840 or 850 code

Diagnosing The Problem

There are two options to check the media for the refreshed image:

Option 1: Check the content inside of the HMC_Recovery_V8R8x0_1.iso image with a product such as winrar. The refreshed image will have a new marker file called .version.




Inside the file will be content with a designation -- v1.0 such as HMC850 Recovery DVD v1.0

The .version file does not exist in the original images

Option 2: Check the Recovery media sha1sum values against the refreshed images from June 2016.


Package name
Size
Checksum (sha1sum)

HMC_Recovery_V8R840_1.iso
35938119687d7a8989f69afb64db65157ebdfcd92308671f3e

Package name
Size
Checksum (sha1sum)

HMC_Recovery_V8R850_1.iso
360663654402c8cf656101ea783244194c997d790710d1ada1

Resolving The Problem

Obtain and burn a new image of the Recovery media

[{"Product":{"code":"SGGSNP","label":"Hardware Management Console V9"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"7042-CR9","Platform":[{"code":"","label":"x86"}],"Version":"8.8.4;8.8.5","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Product Synonym

7042 CR9 HMC

Document Information

Modified date:
22 September 2021

UID

nas8N1021409