IBM Support

18.0.0.1, 18.0.0.2 Release Note: IBM Business Automation Workflow Case configuration tool fails to start on AIX

Troubleshooting


Problem

After upgrading to IBM Business Automation Workflow V18.0.0.1 on AIX, the Case configuration tool fails to start.

Symptom

When you run the ./configmgr command to start the Case configuration tool, an error similar to the following one might occur in the IBM FileNet P8 Content Platform Engine Configuration Manager (CMUI) logs at /opt/ibm/Workflow/v18.0/CaseManagement/logs/.metadata/.log:

 


!ENTRY org.eclipse.osgi 4 0 2018-06-08 05:09:45.231
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons:
"/opt/ibm/Workflow/v18.0/CaseManagement/configure/configuration/org.eclipse.osgi/268/0/.cp/libswt-pi-gtk-4629.a ( 0509-022 Cannot load module /usr/lib/libglib-2.0.a(libglib-2.0.so.0).
0509-150 Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
0509-152 Member libiconv.so.2 is not found in archive
0509-022 Cannot load module "/opt/ibm/Workflow/v18.0/CaseManagement/configure/configuration/org.eclipse.osgi/268/0/.cp/libswt-pi-gtk-4629.a.
0509-150 Dependent module /usr/lib/libglib-2.0.a(libglib-2.0.so.0) could not be loaded.)
swt-pi-gtk (Not found in java.library.path)
/root/.swt/lib/aix/ppc64/libswt-pi-gtk-4629.a ( 0509-022 Cannot load module /usr/lib/libglib-2.0.a(libglib-2.0.so.0).
0509-150 Dependent module /usr/lib/libiconv.a(libiconv.so.2) could not be loaded.
0509-152 Member libiconv.so.2 is not found in archive
0509-022 Cannot load module /root/.swt/lib/aix/ppc64/libswt-pi-gtk-4629.a.
0509-150 Dependent module /usr/lib/libglib-2.0.a(libglib-2.0.so.0) could not be loaded.)
/root/.swt/lib/aix/ppc64/libswt-pi-gtk.a ( 0509-022 Cannot load module /root/.swt/lib/aix/ppc64/liblibswt-pi-gtk.a.so.
0509-026 System error: A file or directory in the path name does not exist.)

at org.eclipse.swt.internal.Library.loadLibrary(Library.java:327)
at org.eclipse.swt.internal.Library.loadLibrary(Library.java:236)
at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:28)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
at org.eclipse.swt.widgets.Display.<clinit>(Display.java:139)
at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:779)
at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:160)
at com.ibm.ecm.configmgr.app.ce.rcp.Application.start(Application.java:83)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:90)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:508)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

Cause

To run the Case configuration tool, GTK+ 2.20 or later and its dependency libraries are required. These libraries are not installed by default.

Resolving The Problem

Install the required libraries on your system before you run the Case configuration tool.

The GTK+ 2.24.30 library is available as Red Hat Package Manager (RPM) packages for the AIX platform. You can install these RPM packages in two ways:

  • Installing by using the "yum" package manager tool, which is the recommended method.
  • Installing each RPM package individually.

 

Installing by using the "yum" package manager tool

  1. Install the “yum” package manager tool on your AIX platform.
  2. Run the command: yum install gtk2. This will install GTK+ 2.x and its dependency packages.

 

Installing each RPM package individually

  1. Download the GTK+ 2.x and the dependency RPM packages from the following AIX tool box link, and run each RPM package. https://www.ibm.com/developerworks/aix/library/aix-toolbox/alpha.html The following dependency packages are required for GTK+ 2.x: libffi-3.2.1-1.aix6.1.ppc.rpm glib2-2.52.2-1.aix6.1.ppc.rpm gettext-0.19.8.1-1.aix6.1.ppc.rpm ncurses-6.1-1.aix6.1.ppc.rpm libXrender-0.9.8-1waixX11.aix6.1.ppc.rpm fontconfig-2.11.95-3.aix6.1.ppc.rpm libXft-2.3.2-3waixX11.aix6.1.ppc.rpm atk-2.20.0-3.aix6.1.ppc.rpm libpng-1.6.27-2.aix6.1.ppc.rpm freetype2-2.8-1.aix6.1.ppc.rpm lzo-2.10-1.aix6.1.ppc.rpm pixman-0.34.0-1.aix6.1.ppc.rpm cairo-1.14.6-2waixX11.aix6.1.ppc.rpm harfbuzz-1.2.7-2.aix6.1.ppc.rpm pango-1.40.1-2waixX11.aix6.1.ppc.rpm intltool-0.51.0-2.aix6.1.noarch.rpm gdk-pixbuf-2.35.1-2waixX11.aix6.1.ppc.rpm rpm -ivh shared-mime-info-1.6-2.aix6.1.ppc.rpm libxcb-1.12-2waixX11.aix6.1.ppc.rpm xcb-proto-1.12-1.aix6.1.ppc.rpm
  2. After installing the above dependency packages, install gtk2-2.24.30-2waixX11.aix6.1.ppc.rpm.

 

After the installation completes, verify that the environment variable LIBPATH contains a path to the installed libraries, for example, LIBPATH=/opt/freeware/lib:/usr/lib.

Internal Use Only

RTC 307591

[{"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Product":{"code":"SS8JB4","label":"IBM Business Automation Workflow"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"}],"Version":"18.0.0.1;18.0.0.2","Edition":""}]

Document Information

Modified date:
13 December 2018

UID

swg22017496