Troubleshooting
Problem
User runs a consolidation or a database optimise. User receives an error message.
Symptom
Example #1
When running a consolidation (Group > Consolidate with status) with BATCHMODE = OFF, users immediately get this error:
- Standard Error
Number: 5
Source: ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime. InteropServices.COMException (0x800A01B8): Automation error (Error occured within method=RunConsol in the module with progid=FrMiscBT. ConsBusinessT)
Example #2
When running a consolidation (Group > Consolidate with status) with with BATCHMODE = ON users see this error:
- Method '~' of object '~' failed
Example #3 - When running a Database Optimise, users receive the following error (at the end of the database optimisation process):
- Error occurred when deleting temporary VFP files: VFP dll missing
Cause
This IBM Technote specifically relates to the scenario where the root cause is that Controller application server has a problem reading the VFP DLL file components.
There are several potential scenarios which can explain why the application server cannot read these DLL files:
- Scenario #1 - VFP DLL component files have been accidentally manually deleted
- Scenario #2 - VFP DLL components have not been registered correctly
- Scenario #3 - VFP DLL components have not been deleted/quarantined by a virus scanner product.
- In other words, if (at first) the Controller system works OK, but then (some time later) this problem starts occurring, then there is a high probability that a Virus Scanner is causing the issue
- It has been seen with one customer using 'VIPRE Enterprise' (where it quarantined those files)
- It has also been seen with 'Fortinet' anti-virus.
TIP: This is the most likely scenario if the problem appears intermittent.
Diagnosing The Problem
There are several different potential causes for the message 'Error occurred when deleting temporary VFP files'.
- For more details, see separate IBM Technote #1365329.
In addition, there are several different potential causes for the message 'COMException (0x800A01B8): Automation error (Error occured within method=RunConsol'.
- For more details, see separate IBM Technote #1367431.
Resolving The Problem
The exact solution depends on the scenario that is causing the problem.
- See below for the steps to perform for each scenario.
Scenario #1
1. Logon to the Controller application server as a Windows administrator
2. Launch Windows Explorer, and browse to the VFP DLL folder location
- 64-bit servers (LIKELY - for example Windows 2008 R2 onwards):
This is folder is here: C:\Windows\SysWOW64\server
32-bit servers (RARE/unlikely - for example Windows 2008 32-bit and previous versions):
This is here: C:\Windows\system32\server
3. Check to make sure that this folder contains the following required files:
- vfp9r.dll
- vfp9renu.dll
- vfp9t.dll
- vfpcom.dll

Scenario #2
1. Logon to the Controller application server as a Windows administrator
2. Launch a command prompt as an administrator.
- TIP: If using Windows 2008, then you must click "Start - All Programs - Accessories" then right-click on "Command Prompt" and choose "Run as Administrator"
3. Use the command 'cd' to change directory to the VFP DLL folder.
- For example: cd C:\windows\syswow64\server
4. Register both the relevant DLL files, by running the following commands:
- regsvr32 vfp9r.dll
regsvr32 vfp9t.dll
5. As a precaution, register the other VFP DLL file, by using the following command:
- regsvr32 vfpcom.dll
6. Test.
Scenario #3
1. Logon to the Controller application server as a Windows administrator
2. Check your third party anti-virus product's log for evidence of it deleting/quarantining files.
- Search for references to the following DLL files:
- vfp9r.dll
- vfp9renu.dll
- vfp9t.dll
- vfpcom.dll
- frangovfp.dll
For example, put an exclusion to avoid scanning:
- C:\windows\syswow64\server
- C:\Program Files\IBM\cognos\ccr_64\server
==============================
TIP: If the above does not explain/solve the problem, then check that the file 'frangovfp.dll' has successfully registered inside your COM+ application ("IBMCOGNOSCONTROLLER" or "IBM Cognos Controller Consolidation" depending on the version of Controller that you are using)
- Specifically, check to see if the two components 'frangovfp.cglobvar' and 'frangovfp.main' appear here:

[TIP: See separate IBM Technote #1372678 for more details]
Then (if those two components do not appear correctly) either:
- See separate IBM Technote #1372678 for instructions on how to delete/re-register all Controller DLL objects then test
- or re-install Controller on the application server
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg21442198