Using the NIM bos_inst operation

Use the bos_inst operation to install the AIX® BOS on standalone clients.

Note: The following operation is not allowed when resources with architectures different from the client are allocated to the client.
The command line syntax for the bos_inst operation is as follows:
nim -o bos_inst -a source=Value -a Attribute=Value ... TargetName|TargetNames

The target of a bos_inst operation can be a standalone NIM client or a group of standalone NIM clients.

The following NIM resources are required attributes that can be specified for the bos_inst operation to install and customize a machine:
-a lpp_source=Value
Identifies the lpp_source resource to be used. The lpp_source resource is only required for an rte installation. The lpp_source resource specified must have the simages attribute set. However, if you are performing a bos_inst operation using a mksysb resource and an lpp_source resource, then the simages attribute is optional. The lpp_source provides software for machine customization. It also provides the BOS image for installation if the source attribute is rte.
-a source=Value
Identifies the source for BOS run-time files. Valid values are:
rte
Installs from a BOS image in the lpp_source.
mksysb
Installs the machine from a mksysb image.
spot
Installs the machine from a SPOT copy.
Note: If a SPOT copy is not complete, the installation will succeed, but the target machine might not be bootable. A SPOT copy must have the proper device support to boot the target system. While installing from a SPOT copy is the fastest installation method, using rte ormksysb is more reliable and functional.
Note: A SPOT copy will also install the file sets that are part of the BOS.autoi bundle.
-a spot=Value
Identifies the SPOT resource to be used. The SPOT provides support for network boot and operations in the boot environment.
The following NIM resources are optional attributes that can be specified for the bos_inst operation:
-a accept_licenses=Value
Specifies whether license agreements should be accepted during BOS installation. Before the installation process can complete, this attribute must be set to yes. The default value is accept_licenses=no. If the bosinst_data resource resides on the NIM master, the ACCEPT_LICENSES field in the bosinst_data resource can also be set to yes. You can also set the NIM_LICENSE_ACCEPT global environment variable to yes on the NIM master.
-a adapter_def=Value
Specifies the directory containing secondary adapter definition files. The nimadapters command parses a secondary-adapters stanza file to build the files required to add NIM secondary adapter definitions to the NIM environment as part of the adapter_def resource. The nimadapters command does not configure secondary adapters. The actual configuration takes place during a nim -o bos_inst or nim -o cust operation that references the adapter_def resource.
-a async=Value
Specifies whether NIM should perform operations on group members asynchronously and not wait for the operation to complete on one member before beginning the operation on the next. The default value is async=yes.
-a auto_expand=Value
Indicates whether to expand file systems when setting up a client for a force_push installation. The default value is auto_expand=yes.
-a boot_client=Value
Indicates whether NIM should attempt to reboot the client immediately for BOS installation. The boot_client attribute is the converse of the no_client_boot attribute. The default value is boot_client=yes, indicating that NIM should attempt to reboot the client.
-a bosinst_data=Value
Specifies the bosinst_data resource to use for nonprompted installation.
-a concurrent=Value
Specifies the maximum number of machines from the selected group that should be installing at any given time. This attribute is only valid when the target of the operation is a machine group. If specified, NIM will monitor the progress of all machines in the group and attempt to keep no more or less than the number specified installing until all machines in the group are installed.
-a filesets=Value
Specifies a list of filesets to install on the target after BOS installation.
-a force_push=Value
Indicates whether or not a force_push installation should occur. A force_push should be used for installing machines that are running, but are not configured with the NIM client fileset. See Using the force_push attribute for more information.
-a group=Value
Specifies the name of a resource group to use for installation. A resource group can be specified as an alternative to specifying multiple resources as separate attributes. If a resource group is specified, and it contains a SPOT and lpp_source, the spot and lpp_source attributes are no longer required.
-a image_data=Value
Specifies an image_data resource to describe how physical and logical data is organized on the client.
-a installp_bundle=Value
Specifies an installp_bundle resource that lists filesets to install on the target after BOS installation.
-a installp_flags=Value
Tells installp how to apply the filesets specified by the filesets or installp_bundle attributes. The default value is installp_flags=-agQX.
-a mksysb=Value
Provides the run-time files for BOS and other filesets if the source attribute is mksysb. The level of BOS run-time files in the mksysb must be equal to the level of the SPOT resource used for the installation.

If the level of the SPOT resource is greater than the level of the mksysb resource, then an lpp_source resource must be used and match the level of the SPOT resource. When this situation occurs, an update operation is performed by default.

-a no_client_boot=Value
Indicates whether the target should remain in the NIM environment after installation completes. The default value is no, indicating that the target system should remain in the NIM environment.
-a physical_loc=Value
Specifies the physical location code or AIX location code of the installation disk to the BOS installation process. This attribute allows you to specify the location code for the installation disk or disks on the command line, and allows you to have a generic bosinst.data file that does not contain location code information.
To determine a disk's physical location code, type the following:
lsdev -Cc disk -l hdisk0 -F "name physloc"

For more information about location codes, see Device Location Codes in Operating system and device management .

-a preserve_res=Value
Indicates whether resources in non-rootvg file systems should be preserved on the client system being installed. The default value is preserve_res=no.
-a resolv_conf=Value
Specifies the resolv_conf resource to use for configuring domain and name resolution on a client.
-a script=Value
Specifies the script resource to be run on the target system after all software has been installed.
-a set_bootlist=Value
Indicates whether NIM should set the bootlist of the client so that the client boots over the network on the next reboot. Usually, set_bootlist would be yes if the client is not going to be rebooted immediately for installation (no_client_boot=yes or boot_client=no). The default value is set_bootlist=no.
-a show_progress=Value
Indicates whether status should be displayed for each group member when the installation target is a group of machines. The default value is yes.
-a time_limit=Value
Specifies the maximum number of hours that should elapse before ceasing to initiate installation of additional members of the selected group of machines. This value can only be specified when limiting the number of concurrent operations on a group.
-a verbose=Value
Displays information for debugging. Valid values are 1-5. Use verbose=5 to show maximum detail. The default is to show no debugging output.

When a bos_inst operation is performed on a client, the following occurs:

On the SPOT server:

  1. A link is created in /tftpboot to a boot image matching the platform type, kernel type, and network adapter of the client.
  2. The /etc/bootptab file is updated with client information to allow the boot image to be used.
  3. A ClientName.info file is created in /tftpboot to provide client-specific installation and configuration information in the boot environment.
  4. The /etc/tftpaccess.ctl file is modified, if necessary, to allow access to the /tftpboot directory.

On the target system:

  1. The bootlist is modified so the network adapter is the default boot device for normal mode boot, unless no_client_boot=yes, set_bootlist=no, and force_push=no are specified.
  2. The client is rebooted to begin the installation, unless no_client_boot=yes, boot_client=no, and force_push=no are specified.

When the client boots over the network adapter, it obtains the boot image from the SPOT server. The boot image configures devices and sets up the machine for the BOS installation. The Client.info file is transferred to the client machine; and based on its contents, the network adapter is configured, routes are added, and NIM resources are mounted in the boot environment. Processing control is then passed to the BOS installation program.