
IBM Cognos PowerPlay Client
Version 11.0

User Guide

IBM



©

Product Information

This document applies to IBM Cognos Analytics version 11.0.0 and may also apply to subsequent releases.

Copyright

Licensed Materials - Property of IBM

© Copyright IBM Corp. 2005, 2017.

US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.

IBM, the IBM logo and ibm.com are trademarks or registered trademarks of International Business Machines Corp.,
registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other
companies. A current list of IBM trademarks is available on the Web at “Copyright and trademark information” at
www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:
v Adobe, the Adobe logo, PostScript, and the PostScript logo are either registered trademarks or trademarks of

Adobe Systems Incorporated in the United States, and/or other countries.

v Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United
States, other countries, or both.

v Intel, Intel logo, Intel Inside, Intel Inside logo, Intel Centrino, Intel Centrino logo, Celeron, Intel Xeon, Intel
SpeedStep, Itanium, and Pentium are trademarks or registered trademarks of Intel Corporation or its subsidiaries
in the United States and other countries.

v Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

v UNIX is a registered trademark of The Open Group in the United States and other countries.

v Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its
affiliates.

Microsoft product screen shot(s) used with permission from Microsoft.

http://www.ibm.com/legal/copytrade.shtml


Contents

Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . ix

Chapter 1. Getting started with PowerPlay Client . . . . . . . . . . . . . . . . . . 1
Open a Local PowerCube . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Open a Remote Package . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
Open a Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

Open local reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3
Open remote reports. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3

Replace Categories in a Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Add Nested Categories to a Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Selecting Nested Categories . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Add Intersected Categories to a Reporter Report . . . . . . . . . . . . . . . . . . . . . . . 8
Working with layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Duplicate a Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
Copy Information Between Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
Hide Categories . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
Show Summary Categories . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Swap Rows, Columns, and Layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Insert Blank Rows and Columns . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Move a Row or Column . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
Set the Prompting and PDF Properties for Published Reports . . . . . . . . . . . . . . . . . . . 12
Suppress Unnecessary Information . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Suppress Zeros . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
80/20 Suppression . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

Remove Unwanted Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14
Considerations to Improve Report Accessibility . . . . . . . . . . . . . . . . . . . . . . . 15

Chapter 2. Maintaining Standard Reports . . . . . . . . . . . . . . . . . . . . . 17
Share the Dimension Line . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
Create a Report Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Control when data is updated . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
Subset Definitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

Create a Parentage Subset Definition . . . . . . . . . . . . . . . . . . . . . . . . . . 19
Create a Find-in-Cube Subset Definition . . . . . . . . . . . . . . . . . . . . . . . . . 19
Create an Advanced Subset Definition . . . . . . . . . . . . . . . . . . . . . . . . . 21
Create an Advanced Subset Definition with Restriction by Parent . . . . . . . . . . . . . . . . 22
Create an Advanced Subset Definition with Restriction by Name or Description (Find) . . . . . . . . . 23
Create an Advanced Subset Definition with Restriction by Value . . . . . . . . . . . . . . . . 23
Open a Subset Definition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Change a Subset Definition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
Delete a Subset Definition . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
Highlight Subsets . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
Subset Calculations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
Break or Delete a Subset . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

Chapter 3. Dimensions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Drill Down . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
Drill Up . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
Drilling Down and Up on Nested Categories . . . . . . . . . . . . . . . . . . . . . . . . 30
Filter Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
Remove Filters . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Search for Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Search in a report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31
Search in a cube . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

iii



Chapter 4. Measures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Change the Measure . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
Show Multiple Measures as Rows, Columns, or Layers . . . . . . . . . . . . . . . . . . . . . 33
Change the Format for a Measure . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
Working with Currency Values . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

Chapter 5. Drill Through . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
Drill Through to PowerPlay . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

Chapter 6. Rank and Sort Data in Reports . . . . . . . . . . . . . . . . . . . . 41
Rank Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41

Rank categories using the default settings . . . . . . . . . . . . . . . . . . . . . . . . 41
Rank categories using custom settings . . . . . . . . . . . . . . . . . . . . . . . . . 42
Hide or remove ranking . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
Rank Identical Values . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
Rank Nested Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
Manually Re-Ranking in Reporter Reports . . . . . . . . . . . . . . . . . . . . . . . . 43

Sort Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
Sort using default settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
Sort using custom settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

Chapter 7. Highlight Exceptions . . . . . . . . . . . . . . . . . . . . . . . . . 45
Automatic Exception Highlighting. . . . . . . . . . . . . . . . . . . . . . . . . . . . 45

Apply automatic exception highlighting . . . . . . . . . . . . . . . . . . . . . . . . . 45
Change automatic exception sensitivity for the active report . . . . . . . . . . . . . . . . . . 45
Modify the automatic exception styles . . . . . . . . . . . . . . . . . . . . . . . . . 46

Custom Exception Definitions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Create a custom exception definition . . . . . . . . . . . . . . . . . . . . . . . . . . 46
Apply a Custom Exception Definition . . . . . . . . . . . . . . . . . . . . . . . . . 47
Shared Custom Exception Definitions. . . . . . . . . . . . . . . . . . . . . . . . . . 48

Chapter 8. Calculations . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
View Information About Calculations. . . . . . . . . . . . . . . . . . . . . . . . . . . 51
Calculate Percentage Growth . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Calculate the Percentage of a Total. . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Calculate an Average . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
Calculate a Running Total . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

Calculating running totals as numeric values . . . . . . . . . . . . . . . . . . . . . . . 53
Calculating runnings total as percentage values . . . . . . . . . . . . . . . . . . . . . . 53

Rollup Calculations. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53
Perform Calculations on Nested Categories . . . . . . . . . . . . . . . . . . . . . . . . . 54
Perform Calculations When You Add Categories . . . . . . . . . . . . . . . . . . . . . . . 55
Add Calculated Categories to a Report . . . . . . . . . . . . . . . . . . . . . . . . . . 56
Perform Group Calculations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
Setting Calculation Precedence . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57
Forecasting Methods . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58

Trend (Linear or Straight Line) . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Growth (Curved or Curved Line) . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Autoregression (Seasonal) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59
Create a Forecast . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Financial Ratios . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60

Chapter 9. Graphical Displays . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Compare Variables, Show Variance, or Track Performance . . . . . . . . . . . . . . . . . . . . 63
Compare Two Measures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63
Show the Mix in a Pie or Clustered Bar Display . . . . . . . . . . . . . . . . . . . . . . . 64
Find a Trend in a Display. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64
Show More than One Type of Display . . . . . . . . . . . . . . . . . . . . . . . . . . 65
Show Multiple Charts in One Display . . . . . . . . . . . . . . . . . . . . . . . . . . 65

iv IBM Cognos PowerPlay Client Version 11.0: User Guide



View Large Amounts of Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66
Show Values in a Display. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66

Showing values in simple or clustered bar displays . . . . . . . . . . . . . . . . . . . . . 66
Showing values in single line displays . . . . . . . . . . . . . . . . . . . . . . . . . 67

Add Statistical Lines to a Chart Display . . . . . . . . . . . . . . . . . . . . . . . . . . 67
Formatting Graphical Displays . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 68

Change the Colors and Patterns Settings. . . . . . . . . . . . . . . . . . . . . . . . . 68
Apply a Background to a Display . . . . . . . . . . . . . . . . . . . . . . . . . . . 68
Arrange Displays . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Change the Angle of a Display . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69
Rotate a Display . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Change Markers in a Display . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Change the Appearance of Pie Displays . . . . . . . . . . . . . . . . . . . . . . . . . 71
Highlight a Line in a Multiline Display . . . . . . . . . . . . . . . . . . . . . . . . . 71
Hide Report Gridlines . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Scale an Axis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71
Make Bars Transparent in a 3-D Bar Display . . . . . . . . . . . . . . . . . . . . . . . 72

Chapter 10. Formatting Reports . . . . . . . . . . . . . . . . . . . . . . . . . 73
Choose a Layout for a Crosstab Report . . . . . . . . . . . . . . . . . . . . . . . . . . 73
Show Short or Long Names for Dimensions and Categories . . . . . . . . . . . . . . . . . . . 73
Create and Apply a Style to Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73

Creating and editing styles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Applying styles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74
Removing styles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74

Apply a Background Pattern and Color to an Entire Report . . . . . . . . . . . . . . . . . . . 74
Add a Title, Header, or Footer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Formatting Labels and Values . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76

Rename Labels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 76
Format Labels and Values in Crosstabs . . . . . . . . . . . . . . . . . . . . . . . . . 76
Format Labels in Graphical Displays . . . . . . . . . . . . . . . . . . . . . . . . . . 77
Change Summary Labels . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78
Show Data as Relative Values . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78
Show Blank Cells For Zero and Missing Values . . . . . . . . . . . . . . . . . . . . . . 79

Chapter 11. Distributing Reports. . . . . . . . . . . . . . . . . . . . . . . . . 81
Save Reports in PDF Format. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Publish Reports to IBM Cognos Analytics portal . . . . . . . . . . . . . . . . . . . . . . . 81

Publishing new reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Work with previously published reports . . . . . . . . . . . . . . . . . . . . . . . . . 82

Print Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82
Attach Reports to Email . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Export a Report to a Different File Format . . . . . . . . . . . . . . . . . . . . . . . . . 83

Delimited ASCII Text Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84

Chapter 12. Customizing PowerPlay . . . . . . . . . . . . . . . . . . . . . . . 85
Setting Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85
Customize Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Set Up a Launch Menu Command. . . . . . . . . . . . . . . . . . . . . . . . . . . 86
Customize Toolbars and Buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

Show or Hide Toolbars . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87
Create a Custom Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87
Customize Toolbar Buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87
Set Up a Launch Button . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88

Distribute Custom Menus and Toolbars . . . . . . . . . . . . . . . . . . . . . . . . . . 89
Customize the Dimension Viewer Toolbox . . . . . . . . . . . . . . . . . . . . . . . . . 89

Chapter 13. Working Offline. . . . . . . . . . . . . . . . . . . . . . . . . . . 93
Turn Off Sub-Cube Refresh . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
Save a Sub-Cube . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93

Contents v



Set a Report to Use a Sub-Cube. . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93
Automatically Refresh a Sub-Cube. . . . . . . . . . . . . . . . . . . . . . . . . . . . 94

Chapter 14. Command-line Options . . . . . . . . . . . . . . . . . . . . . . . 95
No Title Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
Explorer Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95
Reporter Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Cube Name . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Remote Package Name . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96
Report Name . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96

Chapter 15. Specifications . . . . . . . . . . . . . . . . . . . . . . . . . . . 97

Chapter 16. Forecast Formulas . . . . . . . . . . . . . . . . . . . . . . . . . 99
Trend Forecast Formula . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99
Growth Forecast Formula . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100
Autoregression Forecast Formula . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100

Chapter 17. PowerPlay Samples . . . . . . . . . . . . . . . . . . . . . . . . 101

Appendix. Troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . . 103
IBM CognosScript Editor is Not Included With IBM Cognos PowerPlay Client . . . . . . . . . . . . 103
Cognos Application Firewall Error When Publishing a Report . . . . . . . . . . . . . . . . . . 103
Avoiding Blank Extra Lines in Report Titles . . . . . . . . . . . . . . . . . . . . . . . . 103
Hebrew Text Displayed in Chart Elements. . . . . . . . . . . . . . . . . . . . . . . . . 103
Calculation is Not Dynamically Updated After a Cube Update . . . . . . . . . . . . . . . . . . 103
Opening an Exported XLS File in Microsoft Excel 2007 . . . . . . . . . . . . . . . . . . . . 104
Only the First Page of a Multiple-page Report Prints . . . . . . . . . . . . . . . . . . . . . 104
Dimension Viewer Does Not Appear . . . . . . . . . . . . . . . . . . . . . . . . . . 104
Report Looks Different After the Cube is Updated . . . . . . . . . . . . . . . . . . . . . . 104
Advanced Subset Value Restriction is Not Available . . . . . . . . . . . . . . . . . . . . . 104
Categories Do Not Appear After Changing to Explorer Mode . . . . . . . . . . . . . . . . . . 105
Summary Values Appear to be Incorrect . . . . . . . . . . . . . . . . . . . . . . . . . 105
Calculated Values Appear in a Different Format . . . . . . . . . . . . . . . . . . . . . . . 105
Calculated Values Appear as /0 . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106
Labels for Calculated Categories Do Not Display Correctly . . . . . . . . . . . . . . . . . . . 106
Allocated Measures . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106
Unexpected Zeros Appear in the Report . . . . . . . . . . . . . . . . . . . . . . . . . 106
Values Appear as "error" . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
Values Appear as Number Signs (###) . . . . . . . . . . . . . . . . . . . . . . . . . . 107
Values Appear as Question Marks (???). . . . . . . . . . . . . . . . . . . . . . . . . . 107
No Values for a Measure in Some Dimensions . . . . . . . . . . . . . . . . . . . . . . . 107
Time Period Differences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107
Unable to Drill Through to a Cube or Report . . . . . . . . . . . . . . . . . . . . . . . . 108
Saved Report Looks Different . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
Unable to Move a Column or Row . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
Unable to Open the Page Setup or Print Dialog Box . . . . . . . . . . . . . . . . . . . . . 108
Report Does Not Fit on One Printed Page . . . . . . . . . . . . . . . . . . . . . . . . . 108
Unable to Print White on Black . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108
Text Prints on Top of Graphics . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
Restore the Default Toolbars and Menus . . . . . . . . . . . . . . . . . . . . . . . . . 109
Errors After Moving Reports or Cubes to a New Location . . . . . . . . . . . . . . . . . . . 109
Correct Performance Issues . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109
Unable to Email a Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
Unable to Open a Remote Report. . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
Unable to Save a Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110
Unable to Add a Launch Button for a Macro . . . . . . . . . . . . . . . . . . . . . . . . 110
Unable to Refresh a Sub-Cube . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110

vi IBM Cognos PowerPlay Client Version 11.0: User Guide



Notices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115

Contents vii



viii IBM Cognos PowerPlay Client Version 11.0: User Guide



Introduction

This document is intended for use with IBM® Cognos® PowerPlay® Client.

Audience

To use this document, you should have knowledge of business analysis concepts
and your business requirements.

Finding information

To find product documentation on the web, including all translated
documentation, access IBM Knowledge Center (http://www.ibm.com/support/
knowledgecenter).

Accessibility features

IBM Cognos PowerPlay Client does not currently support accessibility features that
help users with a physical disability, such as restricted mobility or limited vision,
to use this product.

Forward-looking statements

This documentation describes the current functionality of the product. References
to items that are not currently available may be included. No implication of any
future availability should be inferred. Any such references are not a commitment,
promise, or legal obligation to deliver any material, code, or functionality. The
development, release, and timing of features or functionality remain at the sole
discretion of IBM.

Samples disclaimer

The Sample Outdoors Company, Great Outdoors Company, GO Sales, any
variation of the Sample Outdoors or Great Outdoors names, and Planning Sample
depict fictitious business operations with sample data used to develop sample
applications for IBM and IBM customers. These fictitious records include sample
data for sales transactions, product distribution, finance, and human resources.
Any resemblance to actual names, addresses, contact numbers, or transaction
values is coincidental. Other sample files may contain fictional data manually or
machine generated, factual data compiled from academic or public sources, or data
used with permission of the copyright holder, for use as sample data to develop
sample applications. Product names referenced may be the trademarks of their
respective owners. Unauthorized duplication is prohibited.

ix
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Chapter 1. Getting started with PowerPlay Client

IBM Cognos PowerPlay Client lets you analyze critical corporate data from any
angle, in any combination. PowerPlay helps you to quickly grasp business issues,
manage performance, and focus your actions through the strength of
multidimensional analysis.

To create a new report, you connect to a data source and then select the data,
display type, and formatting that meets your business needs.

When you build the report, you can choose the information you want to show. You
can add
v categories
v nested categories
v intersected categories
v layers

You can duplicate reports and choose how you want the report information
displayed. You can hide categories, show summary categories, suppress
unnecessary information, and remove unwanted data. If you are distributing
reports to other users by publishing reports to the IBM Cognos Analytics portal,
you may also want to add prompts that let users customize the report before
opening it.

Explorer Mode and Reporter Mode

You choose to work in either Explorer mode or Reporter mode. While Explorer and
Reporter reports are similar in many respects, they have basic differences. When
you understand the differences, you can select the appropriate report type for the
task.

In an Explorer report, the row and column areas can contain multiple levels from
one dimension or, by using nesting, multiple dimensions. The category structure in
the report matches the structure in the data source.

When you create a new Explorer report, the initial display shows the categories
from the first two dimensions in the dimension line. By default, an Explorer report
includes summaries. You can choose to hide the summary information in Explorer
reports.

In a Reporter report, you have complete control over the information in a report.
You don't need to use the same dimension structure as the data source. You can
start with a blank report and then add the categories that you want.

Both Explorer mode and Reporter mode offer many options for working with the
available categories and measures. For example,
v You can filter the report by changing the dimension line.
v You can drag items from the dimension viewer to the report to change

categories or create nested categories.
v You drill up and down on categories in the report to see different levels of

detail.
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After you become familiar with IBM Cognos PowerPlay, you can change the
default preferences to match the way you work. For example, you can change the
default display type from crosstab to simple bar or choose to work in Reporter
mode instead of Explorer mode when you create a new report.

Open a Local PowerCube
You can use unsecured or password-protected PowerCubes that are located on
your own computer or in a shared network location as your data source.

This type of data source is appropriate for creating reports for your own use, for
distribution to other IBM Cognos PowerPlay Client users, or for standard reports
that you will distribute in PDF format. You cannot publish a report based on a
local cube to the IBM Cognos Analytics portal.

Procedure
1. From the File menu, click New.
2. Select Local, locate the PowerCube that you want to use, and then click Open.
3. If prompted for the PowerCube password, provide the required password.

Open a Remote Package
If available in IBM Cognos Analytics portal, you can use a package based on a
PowerCube as your data source.

You must use this type of data source if you plan to publish reports to IBM
Cognos Analytics portal or to work with a PowerCube that is secured using a
namespace.

Before you can access packages, you must specify the location of the IBM Cognos
Analytics gateway using the instance of IBM Cognos Configuration installed with
PowerPlay. You start IBM Cognos Configuration from the same Start, Programs
location as PowerPlay.

Procedure
1. From the File menu, click New.
2. Select Remote.

All available packages are displayed, even packages that use an unsupported
data source such as a relational data source. However, from PowerPlay Client,
you can only select packages that use a PowerCube data source.

3. Select the package that you want to use, and then click OK.
Some packages use data source connections to more than one PowerCube.
When you open this type of package you are prompted to select a single data
source connection to work with.

4. If prompted, provide the required authentication information.

Results

If PowerPlay uses the default startup preferences, a new Explorer report appears
that uses the first two items from the dimension line as the rows and columns. If
the PowerPlay startup preferences are set to use Reporter mode when creating new
reports, a blank report appears.
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Open a Report
You can open an existing local or remote report to refresh the data before
distributing an update to a standard report, to modify the report, or to use the
report as the starting point for the creation of a new report.

IBM Cognos PowerPlay Client can open remote reports that were created in
PowerPlay Studio. Because of feature differences between PowerPlay Studio and
PowerPlay Client, a PowerPlay Studio report may look different when you open
the report in PowerPlay Client. For example, some chart formatting applied in
PowerPlay Studio, such as patterns and gradients, axis placement, and titles, will
not appear in the report in PowerPlay Client. Percentile calculations and custom
subsets are other examples of PowerPlay Studio features that do not appear in the
report in PowerPlay Client.

When you open an existing report you can choose to be prompted to select a data
source that is different from the data source used to create the original report. This
option is useful if you know the original data source was moved or renamed, or if
you want to use a report as a template for a new report based on a data source
with a similar data structure.

Open local reports
You can open reports saved to your computer or a shared network location. If the
data source used to create the report is not available, you are prompted to select a
data source.

Procedure
1. From the File menu, click Open.
2. Click the Local button

To associate the report with a different local or remote data source, select
Prompt for a data source.

3. Locate the report and click Open.

Open remote reports
You can open reports that are available in the IBM Cognos Analytics portal.

In addition to opening reports originally created in PowerPlay Client, you can also
open reports created in PowerPlay Studio.

To access remote reports, you must configure a connection to the IBM Cognos
Analytics gateway and you must have sufficient privileges to access the reports
and associated data sources.

Procedure
1. From the File menu, click Open.
2. Click the Remote button.

To associate the report with a different local or remote data source, select
Prompt for a data source.

3. Navigate to the folder that contains the report, select the report and then click
OK.
If the data source used to create the report is not available, you are prompted
to select a data source.
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If the package used to build the report uses data source connections to more
than one PowerCube, you are prompted to select a PowerCube data source
connection to work with.

Replace Categories in a Report
In Explorer mode, new reports show categories from the first two dimension
folders on the dimension line in the rows and columns of the report. The values
are based on the first measure in the cube.

In Explorer mode, when you replace a category, child categories and a summary
level appear in the report. For example, in the following Explorer mode report,
Years and Products are the first two dimensions in the dimension line.

If you drag the dimension folder Sales regions from the dimension viewer to the
rows, its child categories (Americas, Asia Pacific, Central Europe, Northern Europe,
and Southern Europe) replace the current categories (2004, 2005, 2006, and 2007) in
the rows. Sales regions replaces Years as the summary row.

If you change the default preferences to use Reporter mode for new reports, new
reports are empty. After you open a cube, you add information from different
dimensions or from different levels of the same dimension.

You can add categories to reports in different ways.
v You select a category and then use the toolbar buttons in the dimension viewer.
v You can drag categories to a report from the dimension viewer or dimension

line.

Figure 1. Default layout for Explorer report

Figure 2. Explorer report with categories added from the dimension viewer
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v To add the next level of the selected category in a Reporter report, click the Next
Level Children button in the toolbox, and then drag the category to a drop zone
in the report.

v To add the lowest level of the selected category in a Reporter report, click the
Lowest Level Children button, and then drag the category to a drop zone in the
report. This is faster than drilling down to the lowest level and adding all
categories at that level.

v To replace existing categories in an Explorer report, drag a category from the
dimension line or dimension viewer to a row or column label.

You can switch between the long and short versions of the category names that
were set up by the administrator.

Procedure
1. From the View menu, click Dimension Viewer.
2. In the dimension viewer, select the category that you want to add to your

report.
In an Explorer report, select the parent category of the categories that you want
to add.

3. Do one of the following:
v For Explorer reports, on the dimension viewer toolbar, click the Replace

Rows or Replace Columns button.
v For Reporter reports, on the dimension viewer toolbar, click the Add As

Rows or Add As Columns button.
To remove a category or level, right-click a category, and then choose to
delete the category or level.

Add Nested Categories to a Report
You can add nested categories to a report to see another level of information about
your business.

In an Explorer or Reporter report, you can nest
v multiple levels from one dimension
v levels from different dimensions
v levels from a dimension nested with multiple measures

In Explorer reports, you can nest levels from the same dimension so that child
categories appear directly below parent categories. When you drag a child category
on a nested category, the child replaces the nested category and its siblings.

In Reporter mode, when you drag a category on a nested category, you add the
category to the report. You can also nest levels from alternate paths of the same
dimension.

To nest categories, you can drag categories from
v the dimension viewer
v the dimension line
v the rows, columns, or layers of the report
v another report

Two drop zones, long bar and short bar, govern how categories are nested.
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Long bar drop zones are available for both Explorer and Reporter reports. You can
use these drop zones to add categories to rows or columns as a higher or lower
level.

For example, an Explorer report shows Sales regions in the columns and Years in
the rows. To add the children of Years as nested categories in all the rows of the
report, you drag the Years dimension to a long bar drop zone.

In the resulting report, quarters, the children of the Years dimension, are nested in
all of the rows.

Short bar drop zones are available for only Reporter reports. You can use short bar
drop zones to add categories to individual rows or columns as lower levels.

For example, a Reporter report shows Sales regions in the columns and Years in
the rows. Using the short bar drop zone, you nest Direct Marketing in the
Americas column to quickly filter the data on a specific retailer type.

Figure 3. Drop zone for nesting categories in an Explorer report

Figure 4. Explorer report with categories nested in rows
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After you nest the category, the data in the Americas column is filtered on Direct
Marketing.

Procedure
1. In the dimension viewer, select the category you want to add.

In an Explorer report, select the parent category of the categories that you want
to add.

2. Drag the category to the appropriate drop zone in your report.

Results

Tips: In a Reporter report, you can nest a parent/child relationship in the same

row or column. Select the categories, click the Create Nesting Levels button ,
and then use the dimension viewer toolbar to add the categories as a row or
column. To delete a category or level, right-click a category, and then choose to
delete the category or level.

Selecting Nested Categories
If you add a nested category to all rows or columns in a level using a long bar
drop zone, all changes apply to all occurrences of that category.

For example, in the following report, sales regions are nested under products.
When you select a sales region, IBM Cognos PowerPlay highlights all instances of
the category.

Figure 5. Drop zone for nesting categories in a Reporter report

Figure 6. Reporter report with categories nested in columns
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Because all occurrences of the category are selected, any action you perform on one
occurrence such as moving, removing, and formatting applies to all occurrences of
that category.

If you used short bar drop zones to add more than one instance of a category, you
must select each instance separately to apply a change.

Add Intersected Categories to a Reporter Report
In Reporter reports, you can add new intersected categories.

These appear as a single, unified category instead of their component categories.

By combining categories with measures or with time-related categories, you can
create intersected categories that reveal important information about your business.

Procedure
1. From the View menu, click Dimension Viewer.
2. In the dimension viewer, Ctrl+click to select two or more categories to combine.

The categories must come from different dimensions. If you select categories
from the same dimension, IBM Cognos PowerPlay adds them as individual
categories.

3. Click the intersect button.

4. Click the add as rows button 

 

or the add as columns button .

Figure 7. Report with nested category hightlighted
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Working with layers
You can use layers to show data for each category on a separate page.

For example, a report shows how many products were sold each quarter. By
adding the Locations dimension as a layer, you can see how many products were
sold in the Americas, in Europe, and in the Far East.

When you add layers to an Explorer report, a summary layer and its child
categories are added as layers. In a Reporter report, only the selected category is
added as a layer. You can drill down on this layer to add lower-level categories.

You can change the label name for a layer, drill down a layer, or drill up a layer.

Procedure
1. To add a new layer, drag a dimension folder, or a folder from the dimension

viewer, to the layer target in the dimension line.
2. To change an existing layer, use the appropriate action for the report type:
v In Explorer reports, drag a different dimension folder to the layer target.
v In Reporter reports, remove the layer and drag a different dimension folder

to the layer target.
3. To move between layers, do one of the following:

v click one of the arrows in the layer .
v right-click the layer label and click Go To Layer. Click the layer where you

want to move and click OK.
4. To remove layers, choose whether to remove one layer from a Reporter report

or all layers from a Reporter or Explorer report:
v To remove a layer from a Reporter report, select a layer and click Delete

Current Layer.
v To remove all the layers from a report, right-click any layer and click Delete

All Layers.

Duplicate a Report
To maintain a copy of a report or take advantage of features that are offered by
one report type over another and still keep the current report type, you can
duplicate a report. You can also copy information between reports that use the
same data source.

By default, duplicated reports have a shared dimension line. You can turn this
feature off.

If an Explorer report shows values as a percentage of a total or subtotal and you
duplicate the report as a Reporter report, the Show Values As setting reverts to the
default setting, Value.

Procedure

From the File menu, click Duplicate As and select the alternative report type.
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Copy Information Between Reports
To maintain a copy of a report or take advantage of features that are offered by
one report type over another and still keep the current report type, you can copy
information between reports that use the same data source.

When you copy categories between reports, formatting applied to the category in
one report is not carried over to the other report.

Procedure
1. Open the reports between which you want to copy information.
2. From the Window menu, click one of the tile commands.
3. Select the categories to copy.
4. Drag the categories from one report to the other.

Hide Categories
You can hide categories to make it easier to focus on important information. You
can choose to hide the categories you select or the categories that are not selected.
You can hide categories in both Explorer and Reporter reports. In Reporter reports,
you can hide the rank category and delete hidden categories.

Data is hidden temporarily. For example, if you are looking at sales during 2008
for Europe, the Americas, and the Far East, you might hide the Americas. When
you drill down, you do not see data for the Americas. If you drill up to the top,
you see data for Europe, the Americas, and the Far East again.

To hide categories completely, apply the Hidden style or remove the categories if a
Reporter report is active.

If the current display includes the rank category, you can hide this category. This
option is not available if Nested Charts is selected on the Explore menu. By
default, ranked categories are hidden in scatter displays.

You cannot hide layers; you must remove them from the report.

When you unhide categories, the following categories remain hidden:
v Categories hidden by applying a custom exception definition.
v Categories hidden because of ranking. For example, if you rank the report to

show the top ten products for the past month, the Unhide command does not
show the other products.

v Categories hidden by suppressing values. For example, if you specify that
missing values should not be shown, the Unhide command does not show
missing values.

Procedure
1. Select one or more categories in your report.
2. Choose whether to hide selected or unselected categories:
v To hide selected categories, from the Format menu, click Hide, Selected

Categories.
v To hide unselected categories, from the Format menu, click Hide, Unselected

Categories.
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Results

To unhide categories, from the Format menu, click Unhide.

Tip: To quickly hide one category in Explorer crosstab displays, size a category
until it has a zero width (for a column) or zero height (for a row).

Show Summary Categories
In Explorer reports, you can hide or show the summary categories.

Procedure
1. To show summary categories for the entire report:
v From the Format menu, click Display Options.
v On the General tab, in the Summary Options box, select one of the

summary options and click OK.
2. To show the summary category for a specific level in the report, right-click a

row or column category in a crosstab, and click Show Summaries at this Level.

Swap Rows, Columns, and Layers
You can swap rows and columns, rows and layers, or columns and layers to
analyze your information differently.

For example, if the rows contain quarters of the fiscal year and the columns
contain products, you can swap them so rows contain products, and columns
contain quarters. That way, you can track trends over time more easily, particularly
in single line or multiline displays.

For example, a report with products in the rows, quarters in the columns, and
locations in the layers compares performance by region. If you swap rows and
layers, you can see how well each product sold. If you swap columns and layers
instead, you can compare quarterly sales figures.

Procedure

From the Explore menu, click Swap, and click Rows and Columns, Rows and
Layers, or Columns and Layers.
The names of the items available from the Swap command change depending on
the type of display selected. For example, in a pie display, the Rows and Columns
command is called Displays and Slices, and the Rows and Layers command is
called Displays and Layers.

Results

Tip: To swap rows and columns in Explorer reports, you can also use drag and
drop. For example, to swap a row and column, select any row category and drag it
to the column area.

Insert Blank Rows and Columns
You can add blank rows or columns to a Reporter crosstab.
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This is useful for separating groups of information. For example, you prepared a
IBM Cognos PowerPlay report that outlines the types of mutual funds that your
company sells. You want to distinguish the individual funds from the funds
summary, so you add a blank row and column before the summaries.

You can format and resize any blank row or column. For example, to add a
background pattern to a blank row or column, select the blank, and from the
Format menu, click Categories, and click Labels and Values.

You can not have a blank row or column at the beginning of a level. You can not
have blank layers. If you swap rows or columns with layers, or change to a
graphical display, the blanks do not appear.

Procedure
1. In a Reporter report, click the row above or column to the left of where you

want the blank to appear.
2. From the Insert menu, click Blank(s).

Move a Row or Column
In Reporter reports, you can move rows or columns to change the order in which
they appear.

In an Explorer report, if you drag a row to the column area, or drag a column to
the row area, you swap all rows and columns.

Procedure
1. Select the row or column label that you want to move.
2. Drag the row or column label to the new location.
v To preserve the original arrangement of a category or group of categories in

a nested crosstab display, press the Ctrl key when you drop them.
v To make the row labels appear in the middle of the report, drag the columns

to the left of the row labels.
The pointer changes and a thick black line indicates where you can drag the
row or column.

Set the Prompting and PDF Properties for Published Reports
As a report author, you can select the items that you want the report consumer to
be prompted for when they open the report in PDF format from IBM Cognos
Analytics portal. You can also limit how much data appears in the report.

By default, reports are published with no prompting. You can change the default
prompting properties prior to publishing or republishing a report to IBM Cognos
Analytics.

Procedure
1. Open the report that you want to publish to IBM Cognos Analytics.

The report must be based on a remote package, not a local cube.
2. From the File menu, click Run Options.
3. On the Prompts tab, in the Prompt Report Consumer For box, specify the

prompting options available to the consumer when opening the published
report.
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4. On the PDF Options tab, in the Save box, specify the part of the report that
you want the consumer to see when opening the published report.

5. In the Selected Display Saving Options box, specify the report properties that
you want to save with the published report.
Depending on the option you selected in the Save box, some items are not
available.

6. Click OK.

Suppress Unnecessary Information
You can suppress unnecessary information such as zeros, missing values that
appear as 'na' or zeros, and the result of dividing by zero. For example, if a row
contains all zeros, you may want to suppress that row.

The rank category doesn't interfere with value suppression when you rank data.
For example, you add a rank category and want to suppress zero values. One row
contains all zeros, except for the last cell, which contains the value from the rank
category. IBM Cognos PowerPlay ignores the rank category and suppresses the
row of zeros.

Suppress Zeros
You can control how zeros are suppressed in reports.

For best performance, suppress zero values but not computed zeros (aggregations
or calculations whose result is zero).

You can change the preferences for suppressing values to determine which values
are suppressed in new reports by default.

In Explorer reports, zero suppression is applied to the visible data. PowerPlay does
not consider hidden categories when applying zero suppression.

When you apply zero suppression to a chart that supports multiple measures, the
suppression is only applied to the first measure. You cannot apply suppression to a
second measure, such as the line of a correlation chart, or to conditions when both
measures are zero.

Procedure
1. From the File menu, click Preferences.
2. On the Suppress tab, in the Suppression Options box, do the following:
v To suppress a row or column containing all zero values, select Zero Values.
v To suppress a row or column where all cells contain values as a result of

dividing by zeros, select Division by Zero.
v To suppress a row or column where all cells contain missing values, select

Missing Values.
v To suppress a row or column where all cells contain values larger than the

measure's storage type allows, select Overflow Values.
3. From the Explore menu, click Suppress, Zeros, and click Rows and Columns,

Rows Only, or Columns Only.
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80/20 Suppression
With 80/20 suppression, you can remove the rows and columns with values that
are not significant contributors to your Explorer report.

Values are ordered largest to smallest. Those values that contribute to at least 80%
of the overall total are considered significant and appear in the report. The
remaining values that are not required to attain 80% of the overall total are
suppressed, and these categories are grouped into an "Other" category. The label of
the "Other" category is italicized.

In nested reports, each value in the report is considered individually against the
Grand Total. This can result in multiple "Other" categories appearing at different
levels.

If you swap rows and columns when you selected an 80/20 suppression option,
the suppression remains on the selected option. For example, a crosstab shows
Products as columns, and Years as rows. You apply 80/20 suppression on the
columns, and then swap rows and columns. 80/20 suppression remains on the
columns.

All "Other" categories along an axis (that is, along rows, columns, or layers) share
formatting, name, and hidden state characteristics. For example, a report has two
levels of nesting in rows, and three "Other" categories appear along the rows. If
you change the font color to red for one "Other" category, all "Other" categories in
the rows become red.

You cannot rename, rank or perform calculations on the "Other" category.

You can use the drill cursor to drill down on the "Other" category when one of the
two categories in the intersection is drillable. However, you cannot drill down on
the "Other" category from the context menu. This is because these category types

are not drillable .

If you select 80/20 suppression and then switch to Reporter mode, 80/20
suppression is no longer applied. If you then save the Reporter mode report, 80/20
suppression is not saved with the report.

Before you begin

80/20 suppression is available only if rows, columns, or layers contain only one
measure.

Procedure

From the Explore menu, click Suppress, By 80/20 Rule, and click Rows and
Columns, Rows Only, or Columns Only.

Results

To view the categories that have been grouped together in the Other category, open
the Explain dialog box.

Remove Unwanted Information
In Reporter reports, you can remove unwanted information by deleting it.
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In a crosstab, you can delete any level at any time without deleting the children of
the deleted level. For example, a crosstab shows three levels of nesting based on
Years, Quarters, and Months. You can delete the Quarters level, and the report
shows two levels of nesting: Years and Months. Removing the middle level
(Quarters) does not delete the lowest level (Months).

You can also remove information by temporarily hiding a category.

If you hide categories by ranking the top or bottom number of categories, by
applying a custom exception definition, or by suppressing zeros, you can delete
these hidden categories to speed up the performance of IBM Cognos PowerPlay.
Hidden categories are still part of the report and use up available memory. When
you delete hidden categories, PowerPlay performs more quickly.

You can't delete hidden categories when there are layers in the report, because the
criteria for ranking or suppressing values for one layer may not apply to another
layer.

Except for ranked or calculated categories, you can't remove a category from an
Explorer report. You can only hide information.

Procedure
1. To remove a category or level in a Reporter report:
v Select the category or level that you want to remove.
v From the Edit menu, click Delete, Category(s) or Level.

2. To remove hidden categories in a Reporter report:
v From the Edit menu, click Delete, Hidden Categories.
v In the Delete Hidden Categories dialog box, select one or more check boxes

that correspond to the hidden categories you want to delete and click OK.

Considerations to Improve Report Accessibility
Creating accessible reports ensures access of information to all users, with all levels
of ability.

For example, people with a visual impairment may use screen reading technology
to access the information in a report.

The following are some design considerations for creating accessible reports:
v Avoid using visual cues, such as bold text or color, to convey important

information.
v Avoid using pictures and OLE Objects in PDF documents, as these items are

tagged as artifacts and ignored by the screen reader.
v Avoid using conditional formatting to convey important information.
v Ensure that there is a table corresponding to chart types that are rendered as

images because the screen reader ignores this information.
v Ensure that the report has a title.
v Gain an understanding for screen reading technology.
v Avoid spelling and grammatical errors, as they cause the screen reading software

to misinterpret the information.
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v Avoid using features like calendar boxes and up and down selections on time
controls. Instead use prompts such as check boxes, radio buttons, combo boxes,
and multi-select boxes.

v Ensure that the target application is accessible when using embedded Web
applications or drill-through paths.

v Avoid using large, complex list or crosstab reports.
Displaying the information in multiple simple lists or crosstab reports is more
manageable for assistive technology users.
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Chapter 2. Maintaining Standard Reports

With your data sources constantly changing, it is important to maintain standard
reports. By doing so, you save time and increase your reporting capabilities.

You can
v share the dimension line between two reports
v set up and use reports as templates
v update information automatically

Every time you open an existing report, or drill up and down, the information is
updated with the most current information.

v update information manually
If you work from a large data source, updates can be time-consuming. If you
update manually, you can format your rows, columns and layers, drill down to
the levels of information that you want, and then bring in the most current data
at your convenience.

v use dynamic subsets that are updated every time there is a data source change
that affects the categories in the subset

Share the Dimension Line
A shared dimension line is useful for simultaneously exploring related information
in more than one report. When you have more than one report open, and the
reports share a dimension line, all changes to dimensions in one report
automatically appear in the other report.

For example, you create two reports based on the same data source to help you
analyze the sales performance of your product line. One report shows trends in
products for 2005 and 2006, and the other shows revenue for each customer type in
each location. When you drill down on 2006 to show revenue by quarter, the other
report is filtered to show data for the same time period.

You can use different measures in each report. If you change the measure in one
report, the other reports is not affected.

By default, all reports created from the same data source share the dimension line.
If you want to drill down and filter in one report without affecting other open
reports, change the default preference for sharing a dimension line.

Procedure
1. Open the reports you want to work with.
2. From the Window menu, select a tile option to view all reports.
3. From the File menu, ensure that Shared Dimensions is selected.
4. Use exploration options such as drill down or filtering in one report.

Results

The exploration option you apply to one report is automatically applied to the
other open reports.
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Create a Report Template
Templates allow report authors to create new reports in less time and help to
ensure data is presented in a consistent way.

For example, you are the Human Resources manager for a nationwide company
that sells camping equipment. You have three core product groups that each
operate as strategic business units, Environmental Line, GO Sports Line, and
Outdoor Products. Each unit has its own cube for analysis. You create a report
template so that the manager of each unit presents the data in the same way.

You can use a template with a different data source if the data source has the same
top-level dimensions. You administrator can provide more information about
available data sources and creating templates that can be used with more than one
data source.

Procedure
1. Set up the information to appear in the report. For example, add categories,

drill down, or filter.
2. Format the report. For example, add a title, resize rows and columns, and

change the font and style of labels and values.
3. Save the report.

Results

Other report authors can now use the report as a template for creating new
reports. You should make your template read-only so users don't overwrite it when
saving their new reports.

Control when data is updated
By default, when you open or make changes to a report, IBM Cognos PowerPlay
automatically updates the data so that you see the most current values for the
categories in your report.

There are some circumstances where you may to prefer to manually update your
reports. One example is when you work with very large cubes. In this case, if it
takes an unacceptable amount of time to refresh the data as you build a new report
or navigate to a specific location in a report, you can choose to refresh the data
manually to view the data as needed.

When automatic update is disabled, a question mark (?) appears in the report's
cells until you manually update the report.

Procedure
1. Change the default settings to disable automatic data updates:
v To turn off automatic updating for all reports, from the File menu, click

Preferences. On the Options tab, clear the Get Data Automatically check
box.

v To turn off automatic updating for a specific report, from the Explore menu,
clear Get Data, Automatically.

2. To update the data when automatic data updates is disabled, from the Explore
menu, click Get Data, Now.
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Subset Definitions
A subset definition is a query that defines a new set of categories based on
specified criteria.

Subset definitions are most useful in Reporter mode reports. For example, you
create a subset definition to show all sales representatives of a certain region in
your report. When the region hires a new sales representative, the change will
appear in the report when you refresh the data. If the Reporter mode report didn’t
include this subset, the new sales representative would not appear in the report
after you refresh the data.

In Explore mode reports, category changes are reflected in the report when you
refresh the data.

You can create three types of subset definitions:
v Parentage Subset
v Find in Cube Subset
v Advanced Subset

After you create a subset definition, it is displayed in the subset viewer of the
report.

Create a Parentage Subset Definition
You can create a subset definition based on a level or levels in a dimension.

For example, you are one of the regional managers for a company that sells
camping equipment around the world. Every year, you need to present a report
that includes the last two years revenue for all the sales representatives in the
Americas. Sales representatives are the lowest level children of America. To create
the required report, you create a parentage subset definition that includes the
lowest level children of the Americas.

Procedure
1. In the dimension viewer of a Reporter report, click the dimension folder you

want to use to create the definition.

2. Click the create parentage subset definition button in the toolbox .
3. In the Qualifier box, do one of the following:
v To use the children of the selected level, click Next Level Children.
v To use the children of the selected level as well as the children of those

categories, click Next Two Levels' Children.
v To use the lowest level children in the dimension, click Lowest Level

Children.
4. Click Save Subset and click Close.

Results

IBM Cognos PowerPlay shows the subset definition in the subset viewer.

Create a Find-in-Cube Subset Definition
You can create a subset definition based on all categories in the cube that meet
specified criteria.
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Procedure
1. In the dimension viewer toolbox of a report, click the create find-in-cube subset

definition button .
2. Specify the search settings.
3. Click the Find All button.
4. Click Save Subset and click Close.

Results

The subset definition appears in the subset viewer.

Wildcards
You can use wildcards in a find-in-cube subset definitions or for searching for data.

Table 1. Wildcard characters

Character Description

^ The beginning of a string.

For example, "^inter" finds "interesting" and "interfere", but not "splinters"

$ The end of a string.

For example, "in$" finds "in" and "within", but not "interfere"

? Any single character (except newline).

For example, "to?" finds "top" and "ton", but not "to"

~ Zero or one occurrence of the preceding character (or sub-expression).

For example, "files~" finds "file" and "files", but not "filed"

* Zero or more occurrences of any characters (except newline).

For example, "can*" finds "can" and "Canada"

# Zero or more occurrences of the preceding character (or sub-expression)

For example, "filex#" finds "file" and "filexxx"

@ One or more occurrences of the preceding character (or sub-expression).

For example, "filex@" finds "filex" and "filexxx", but not "file"

| Either the preceding character (or sub-expression) or the following one.

For example, "localis|ze" finds either "localise" or "localize"

[ ] Any character within the brackets. Ranges of characters can be specified
using a hyphen (a hyphen at the start matches itself). An exclamation point
at the beginning causes the set of characters to be inverted. For example,
[!a-m] matches everything except a through m.

For example, p[iu]ck" finds "pick" and "puck"
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Table 1. Wildcard characters (continued)

Character Description

( ) Sub-expressions, so that repetition and alternative wildcard characters can be
applied more generally.

For example, "ab(cd)#e" finds "ab" followed by zero or more "cd"
combinations followed by "e"

\ Allows wildcard characters to be treated as normal characters.

For example, "what\?" finds "what?"

Create an Advanced Subset Definition
You can define a subset that matches specified criteria. For example, you may want
to define a subset that includes only sporting good products sold in Canada and
the U.S. Like all subsets, advanced subset definitions are saved with the report so
that you can reuse them even if the cube changes.

You create an advanced subset definition by first determining the dimension that
you want to use. For example, if you want your subset to focus on the top sales
branches by revenue, you select the Locations dimension because sales branches
are contained within the Locations dimension. If you want to also include the
country or region level in your definition, you can select more than one level to
appear. You may need to choose an alternate drill-down path if the levels that you
want are not in the primary drill-down path.

You can further restrict the definition by including or excluding restrictions by
parent category, by name or description using a find-in-cube definition, or by
value. A subset definition can include one or all of these restrictions.

For example, you are in charge of Finance for a company that sells camping
equipment. Every month, you need to present a report that shows revenue for one
of your company's channels. You need to see only those products that are sold in
Canada and the U.S. and that are part of the Sports Line, so you create an
advanced subset definition that includes only these categories.

When you sort categories in an advanced subset, categories with missing values
are sorted at the end of the list regardless of the sort order.

You cannot create an advanced subset definition that includes levels or categories
from more than one dimension. Advanced subset definitions are always dimension
specific because you focus on one type of object at a time. You can apply filters
from other dimensions to limit the data returned. For example, you create a subset
definition on the products dimension and apply a filter to return only data for
products sold in Europe.

You can use Measures as the dimension only if the selected measure contains more
than one level. If you create an advanced subset using Measures as the dimension,
you cannot create an advanced subset definition with restriction by value.

If you include a level in your subset definition that is subsequently removed from
the cube, your results may be incorrect.
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Procedure

1. In a Reporter report, click the create advanced subset definition button .
2. Specify the advanced subset settings.

If there are no alternate drill-down paths, the only choice is Primary.
If you select more than one level, your subset appears as nested levels.
To see a list of some of the categories that are included in a level in the Level(s)
box, right-click the level label and click Sample Categories.

3. Click Save Subset and click Close.

Results

The subset definition appears in the subset viewer.

Create an Advanced Subset Definition with Restriction by
Parent

Restricting an advanced subset definition by parent enables you to include or
exclude specific levels in the subset.

Although a category must meet all restrictions to be returned in the results of an
advanced subset definition, if you include two restrictions from the same parent,
the results only need to meet one of these restrictions. For example, if you include
both Canada and the United States from the Americas dimension, then the
resulting categories may come from either Canada or the United States.

If you want to include the majority of your categories in the subset, you can just
exclude the few categories you do not want.

For example, you are one of the regional managers for a company that sells
camping equipment around the world. Every year, you need to present a report
that includes the last two years revenue for all sales people in Canada and the
United States, but Canada, the United States, and Mexico are all included in the
Americas category. You create an advanced subset definition with parent category
restrictions that includes only these lowest level children for Canada and the
United States and excludes the lowest level children for Mexico.

Procedure
1. In a Reporter report, click the create advanced subset definition button.
2. Specify the name, dimension, and categories settings.

If there are no alternate drill-down paths, the only choice is Primary.
If you select more than one level, your subset appears as nested levels.
To see a list of some of the categories that are included in a level in the Level(s)
box, right-click the level label and click Sample Categories.

3. On the Parent tab, click the drill-down path that contains the restrictions you
want to use.
You can qualify a subset definition using restrictions from both primary and
alternate drill-down paths. If there are no alternate drill-down paths, the only
choice is Primary.

4. Add categories to the Selected Restrictions box.
v To include a category, select it and click Include.
v To exclude a category, select it and click Exclude.
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5. Click Save Subset and click Close.

Results

IBM Cognos PowerPlay shows the subset definition in the subset viewer.

Create an Advanced Subset Definition with Restriction by
Name or Description (Find)

Restricting an advanced subset definition by name or description enables you to
include categories in the subset that contain a specific text string.

For example, you are in marketing for a company that sells many different
camping products. You need to present a report each month that contains all of the
product lines using the word GO. You create a subset definition that returns all of
the product line categories that contain this word.

Procedure
1. In a Reporter report, click the create advanced subset definition button.
2. Specify the name, dimension, and categories settings.

If there are no alternate drill-down paths, the only choice is Primary.
If you select more than one level, your subset appears as nested levels.
To see a list of some of the categories that are included in a level in the Level(s)
box, right-click the level label and click Sample Categories.

3. On the Find tab, click New.
The Restrict by Find Definition box contains only definitions that are already
defined for the dimension selected in the Dimension box.

4. Specify the search settings.
5. Click Save Subset and click Close.
6. In the Advanced Subset dialog box, click Save Subset and click Close.

Results

The subset definition appears in the subset viewer.

Create an Advanced Subset Definition with Restriction by
Value

Restricting an advanced subset definition by value enables you to include
categories in the subset that represent the largest or smallest values or values that
are greater than, less than, or between specific values in a level.

For example, you are in charge of Finance for a company that sells camping
equipment. Every month, you need to present a report that shows the ten best
selling products for one of your company's channels. You need to see only those
products that are sold through the camping chain channel, so you create an
advanced subset definition that includes only these categories.

If you select Measures as the dimension, you cannot create an advanced subset
definition with restriction by value.
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Procedure
1. In a Reporter report, click the create advanced subset definition button.
2. Specify the name, dimension, and categories settings.

If there are no alternate drill-down paths, the only choice is Primary.
If you select more than one level, your subset appears as nested levels.
To see a list of some of the categories that are included in a level in the Level(s)
box, right-click the level label and click Sample Categories.

3. On the Value tab, click New.
You can also choose an existing value restriction subset definition from the
Restrict by Value box.

4. Select the measure you want to use.
5. Specify the value restrictions.

If you are using values from a measure based on a percentage, you must use
the decimal format when entering a value. For example, if you are restricting
an advanced subset to profit margin values greater than 20 percent, enter .20.

6. To specify a category for a dimension other than the default dimensions of the
report, in the Based on the Dimension Setting box, select a dimension and
click the Edit button. Select a category and click OK.
Changing a category for a dimension applies only to the subset and does not
affect the dimension line settings for the report. You can only change the
categories for dimensions that have not yet been set. For example, the
dimensions selected in previous steps are not available in the Based on the
Dimension Setting box.

7. In the Restrict by Value box, click OK.
8. In the Advanced Subset dialog box, click Save Subset and click Close.

Results

The subset definition appears in the subset viewer.

Open a Subset Definition
To see the results of a subset definition, you can open it in the subset viewer.

Procedure

In the subset viewer, click the Expand button beside the subset definition.

Results

The items in the subset appear below the subset definition name. If the subset
definition does not retrieve any resulting categories, the expand button disappears.

Change a Subset Definition
You can edit any subset definition that appears in the subset viewer. When you
edit a subset definition that is already added to a report, the categories in the
subset are updated to meet the new results of the definition.

Procedure
1. From the subset viewer, right-click the subset definition you want to modify,

and click Edit.
2. Make the changes to the definition and click OK.
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Results

Tip: To see the details of a subset definition, right-click it, and click Explain. To
rename a subset definition, right-click it, and click Rename.

Delete a Subset Definition
When you no longer need a subset definition, you can delete it from the list of
subset definitions.

Procedure

Right-click the subset and click Delete.

Results

If the subset was used in the report, IBM Cognos PowerPlay prompts you to
choose whether to delete the categories from the report or leave the categories in
the report while breaking the association with the subset. If you chose to leave the
categories in the report, the next time the data is refreshed, the categories added
using the subset are not updated.

Highlight Subsets
If you want to see the categories that belong to a subset in a report, you can add a
background pattern to a crosstab display.

You can change the default display settings in Preferences to automatically
highlight subsets in all reports and to change the default pattern used to highlight
subsets.

Procedure
1. In a crosstab display, from the Format menu, click Display Options.
2. On the General tab, select Highlight Subsets.
3. To change the background pattern, click Subset Patterns, select a different

pattern, and click OK.
4. Click OK.

Results

You can also highlight subsets using the default pattern by clicking Highlight
Subsets from the View menu.

Subset Calculations
In order to perform a subset calculation, you must have only one entire subset
selected. If you attempt to perform a calculation on items from a subset and other
items in the report, you will receive a message indicating you are about to break
the subset.

You can perform the following non-group calculations on a subset:
v add
v multiply
v maximum
v minimum
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v average
v rollup

A subset calculation always appears directly after the subset in the report.
Although a subset calculation is not highlighted with the rest of the subset, it is
recalculated if the subset changes.

You can also perform calculations on individual categories in a subset, however the
new calculation does not become a member of the subset and is not updated if the
subset changes.

In Reporter mode, you should not use the Select Subset menu to create a
calculation while the suppress zeros option is activated. Instead, first create the
subset calculation without zero suppression, and then apply zero suppression.

Break or Delete a Subset
You can break a subset if you no longer want the subset categories to be updated.
For example, if you are preparing a report to present at the end of the Quarter, you
do not want it updated after the Quarter is over.

In addition to the steps in this procedure, other events that break a subset include:
v if an individual category in the subset is deleted
v if one or more categories are added between two categories in the subset
v if you add a nested category to only one category in a subset (using short bar

drop zones)
v if you drill down on a category in a subset
v if you rank or sort a report that results in categories being removed from or

inserted between categories in a subset

When you break a subset in one of these ways, you receive a warning to confirm
that you want the subset broken. You can choose to show this message every time
a subset is broken or you can turn the message off.

When you save a report in which a subset is broken, a list of the broken subsets
appears. If you save a report with broken subsets, the categories from the broken
subset are not updated, however the subset definition remains in the subset
viewer.

Procedure

Choose whether you want to break or delete the subset:
v Right-click the subset and click Break Subset.
v Right-click a category in the subset, click Delete, and click Subset.
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Chapter 3. Dimensions

The administrator who creates the cubes that you use as data sources in IBM
Cognos PowerPlay organizes different aspects of your business into dimensions.
Each dimension has its own folder on the dimension line, such as Years, Locations,
Products, and Channels.

PowerPlay lets you explore dimensions by slicing and dicing. You can
v drill down and up
v filter information
v search for information
v change the information appearing in rows, columns, or layers

To support specialized reporting requirements, the Transformer modeler can add
scenario dimensions to a cube. In the dimension viewer, a scenario dimension is

distinguished from other dimensions by the scenario dimension icon .
Scenario dimensions are often used when budgeting and forecasting, or for
planning-related applications. Unlike regular dimensions, scenario dimensions do
not roll up to a single root category, because that value would not be useful.

Contact your Transformer modeler for more information about using existing
scenario dimensions or to determine if new scenario dimensions would be useful
to you.

Drill Down
You drill down on a parent category to see its child categories. Drilling down has
different results in Explorer and Reporter reports.

In Explorer mode, when you drill down, you replace parent categories with the
child categories of the item you drilled down on. For example, you are working in
a report where Locations is the summary level and Americas is a child of
Locations. When you drill down on Americas, the child categories, Brazil, Canada,
Mexico, and United States appear in the report. Americas replaces Locations as the
summary level. The associated dimension line folder appears open and shows
Americas to indicate the current summary level for that dimension.
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The following considerations apply when drilling down in Explorer reports.
v When you drill down on a nested level, you preserve the number of levels until

you reach the bottom of the hierarchy. At this point, the parent level is
temporarily removed until you drill up again.

v You can drill down on a rank or calculation.
v You cannot drill down on an 'Other' category (80/20 suppression).
v If you double-click the summary category, you are drilling up to a higher level

of categories, not drilling down.

In Reporter mode, when you drill down, you add the child categories to the
report. The original parent categories remain in the report. The associated
dimension folder does not appear open and its name shows the top level of the
dimension. The following report shows the results when you drill down on
Americas in Reporter mode.

You can use alternate drill paths in both Explorer and Reporter reports if the IBM
Cognos Transformer modeler has set them up. An alternate path is another path
within the same dimension that leads to the same categories. For example, two
paths are available in the Channels dimension: the primary path is by Channel

Figure 8. Explorer report showing results of drill down

Figure 9. Reporter report showing results of drill down
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Type, and the alternate path is by Region. If you drill down the primary path, you
drill down from Channel Type to Customer. If you drill down in the alternate path,
you drill down from Region to Customer.

Alternate paths and special categories appear italicized in the dimension menu
(dimension line). Alternate paths and special categories appear with a folder with

splitting arrows in the dimension viewer .

Procedure

Where the pointer appears as a plus sign , double-click one of the following:
v a label to drill down on the row, column or layer only
v a value to drill down on both the row and the column

Tip: To drill up or down levels in a dimension, you can also use the dimension
line. Click on a dimension line folder for a dimension that appears in the report
and then click on a category.

Results

To reset all dimensions, from the Explore menu, click Reset Dimensions. In
Explorer reports, IBM Cognos PowerPlay resets the dimension line to the top level
for the current categories and removes filters. PowerPlay does not remove nested
categories. In Reporter reports, PowerPlay resets the dimension line to the top level
for the current categories and removes filters. The report still contains all the
categories that you added.

Drill Up
You can drill up in any hierarchy where you have drilled down. For example, you
can drill up to Locations from its child category Americas. Drilling up gives you a
broader perspective of your dimension.

In an Explorer report, you can drill up on the summary category.

In a Reporter report, when you drill down on a column IBM Cognos PowerPlay
adds its child categories to the right. If you double-click the column again, you
drill up and the child categories disappear. However, if you move the column after
drilling down, you can no longer drill up by double-clicking. This also applies to
drilling down on a row.

You can drill up in alternate paths. If you drill up using the right-click menu, you
drill up the path you drilled down. To drill up in an alternate path, click on the
arrow and select an alternate parent.

Procedure

Where the pointer appears as a plus sign with a caret or up arrow, double-click the

category, label, or value .
If you double-click a label, you drill up on the row or the column only. If you
double-click a value, you drill up on both the row and the column.
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Results

When you reach the top of the hierarchy in a report, the pointer changes to a plus
sign (+).

To reset all dimensions to the top level, from the Explore menu, click Reset
Dimensions. In Explorer reports, PowerPlay resets the dimension line, removes
filters, and changes the categories in the report to the top-level categories in the
current dimensions. PowerPlay does not remove nested categories. In Reporter
reports, PowerPlay resets the dimension line to the top level for the current
categories and removes filters. The report still contains all the categories that you
added.

Drilling Down and Up on Nested Categories
The same rules that govern drilling down and up in regular crosstabs apply to
nested crosstabs. Drilling down on a category in a nested Explorer report replaces
the drill category level with the child categories. Drilling down on a category in a
nested Reporter report adds the children of that category as new categories at the
same level.

Filter Data
You can use the dimension menu to quickly explore and filter data.

When you click on a dimension folder, the dimension menu appears.

The current filter category appears in bold and is separated from its parent and
child categories by horizontal lines. A down arrow identifies the parent of the
current filter category. When you move your pointer over a parent category, its
siblings appear. If a dimension contains more than ten categories, scroll bars
appear at the top and bottom of the dimension menu.

You can filter a category that is not in the report but is part of the cube. In an
Explorer report, if you filter a category that is in the report, the results are the
same as if you had drilled down on that category.

When you filter, the dimension line changes to reflect the filtered categories.

When you filter, whole rows, columns, or layers may change to zeros because you
filtered out information for these categories. You can suppress zeros in the report.

Figure 10. Dimension menu
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Procedure
1. Click the dimension folder for the dimension you want to filter.
2. Click the category you want to filter.

Results

Tips

v To see the siblings of the category you selected, move your pointer over the
dimension folder.

v To filter deeper than a single level at a time, use the dimension viewer rather
than the dimension line. If you want to filter as you select categories in the
dimension viewer, select the category to filter by, and click the Filter button.

Remove Filters
You can remove all filters in a report or only one filter. When you remove a filter,
the dimension line changes.

Procedure

Choose how you want to remove filters:
v To remove all filters, from the Explore menu, click Reset Dimensions.
v To change one filter, in the dimension viewer, select a different category in the

dimension to which the filter category belongs and click the filter button.
For example, if you filtered to show information only for 2008, select the Years
dimension because 2008 belongs to Years.

v To remove filters one level at a time, on the dimension line, click the dimension
folder to which the filter category belongs and then select the category
immediately above the current filter category.

Search for Data
You can search for data in either the report or the cube used by the report.
Related concepts:
“Wildcards” on page 20
You can use wildcards in a find-in-cube subset definitions or for searching for data.

Search in a report
When you search for data in the report, IBM Cognos PowerPlay searches the labels
as they appear in the report. If the report author renamed any of the labels from
the cube, the search includes only the renamed labels, not the original labels.

Procedure

From the Edit menu, click Find.

Search in a cube
When you search for data in the cube, you have the option to save the search
results as a find-in-cube subset. If you save the search results as a subset, the
results are the same as if you created the subset using the dimension viewer
toolbox.
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Procedure
1. From the Edit menu, click Find.
2. Specify the search settings, including the dimension and name settings on the

Cube tab.
3. Click Find All.
4. To save the results as a find-in-cube subset definition, click Save Subset.

The new subset appears in the subset definitions list in the dimension viewer.
5. Click Close.
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Chapter 4. Measures

A measure determines how well a business is operating. Examples of measures
include
v a simple summary of available information, such as number of units shipped,

revenue, expenses, inventory levels, or quotas
v a calculated value, such as forecast revenue minus actual revenue

The IBM Cognos Transformer modeler defines the order of measures when
building the cube. In PowerPlay, a new report uses the first measure in the list of
measures. You can select a different measure from the dimension line or dimension
viewer.

Most measures apply to all dimensions. However, depending on how the
Transformer modeler built the cube, some measures may not apply to the
categories you selected for a report. For example, a cube includes measures for
revenue, inventory, and head count. While revenue and inventory apply to all
dimensions, the head count measure applies only to years and locations.

If you try to use a measure in a location where it does not apply, you see na in the
report. The presentation of zeros or constant values may reflect the way that a
measure was allocated when the Transformer modeler created the cube. Also, the
modeler may have defined missing values to show as zeros.

Change the Measure
By default, a report uses the first measure in the list of measures. You can change
measures to compare data using different quantitative values. You add measure to
the report using the same techniques as you use for adding categories.

Procedure

On the dimension line, click the Measures folder and select a measure from the
list.

Show Multiple Measures as Rows, Columns, or Layers
You can show multiple measures as rows, columns, or layers.

For example, you can nest measures in a report when you need to see multiple
measures for a dimension, as shown in the following report.
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Procedure

Add additional measures to the row, column, or layer area of the report.
v To add a single measure, drag the measure from the dimension viewer into the

report.
v To add all measures, drag the measures folder from the dimension line or

dimension viewer into the report.
In Reporter reports, the Measures folder is added to the report beside or below
existing categories. Drill down to show all measures.

Related tasks:
“Add Nested Categories to a Report” on page 5
You can add nested categories to a report to see another level of information about
your business.
“Format Labels and Values in Crosstabs” on page 76
You can format labels and values in a crosstab display to make them easier to
understand.

Change the Format for a Measure
You can choose the format used to show values for measures.

You can specify a default format for your measures using the Format settings in
Preferences. If the IBM Cognos Transformer modeler defined a specific format for
values, it takes precedence over your preference settings.

Procedure
1. In the dimension viewer, select the measure.
2. Click the format measure button.
3. On the Format tab, select the format and click OK.

Working with Currency Values
The most common measures represent currency values, such as revenue, product
cost, and gross profit. IBM Cognos PowerPlay includes options that you use to
show currency values in the most appropriate way. You can
v convert values to a different currency

When you create reports that will be used in a different region or county, you
can convert values to show the most appropriate currency for the report
consumer.

v format values

Figure 11. Report with nested measures
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You can change the format of values to use a different accounting standard, or to
help reports consumers understand the data. For example, you can choose to
show the currency symbol so report consumers can accurately compare data in
different reports that may not show the same currency.

The following information will help you to understand how PowerPlay determines
which currency symbol to use. Both the cube settings defined by the Transformer
modeler and the language specified in the Microsoft Windows Regional Settings of
the computer where PowerPlay is installed can affect which currency symbol is
used by default.

If there is more than one currency symbol defined for a country or region, the
currency symbol is determined by the language specified in the Microsoft
Windows Regional Settings of the computer where PowerPlay is installed.

When the language specified on the user's system is not associated with the
country or region defined in the cube, the currency symbol for the first occurrence
of that country or region is used.

If a specific currency is not defined in the cube and you subsequently format the
data as money in your PowerPlay report, the currency symbol used is the currency
symbol defined in your Microsoft Windows Regional Settings. This can result in
misleading results if the values in the cube are, in fact, based on a different
currency. To ensure that your report shows the correct currency, ask the IBM
Cognos Transformer modeler to define the required currency in the cube, or ensure
that the Regional Setting for each PowerPlay user matches the data stored in your
cube.

Note: Not all measures represent currency values. You can not select an alternate
currency or apply currency formatting to a measure that is not a currency value.

Before you begin

The Transformer modeler defines the alternate currencies when building the cube.
If you need additional currencies, contact your Transformer modeler.

Procedure
1. From the Explore menu, click Convert Currency.
2. In the Measures box, select the measures that you want to convert.
3. In the Currency box, select an alternate currency.
4. Click Apply.
5. To format the currency, click the Format button.
6. In the Number Format dialog box, specify the format, and click OK.

If you selected multiple measures that currently use different currencies,
formatting is disabled.

7. In the Currency Conversion dialog box, click OK.
Tip: To reset a measure to its original currency setting, select the measure in the
Measures box, click Default, and click Apply.
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Chapter 5. Drill Through

You can drill through from a IBM Cognos PowerPlay report to other reports,
cubes, or working files. For example, one cube contains revenue information about
all products in the Americas and another cube contains revenue information about
all products in Europe. As the product manager for the European office, you use
the European cube most often. Occasionally you need to compare revenue in the
Americas and Europe, and this is when you drill through from one cube to
another.

Your modeler sets up drill-through access for PowerCubes in IBM Cognos
Transformer. The modeler also identifies other content, such as PowerPlay reports
and cubes for you to drill through to.

Drill Through to PowerPlay
When you want to explore information in another cube, you can either drill
through to another Explorer or Reporter report that uses a different cube or drill
through to a different cube than the one you are using in your report.

For example, one cube contains the summary sales information about all regions.
As vice-president of sales, you explore and analyze the high-level information in
that cube. Other cubes contain detailed information about each region. The
regional managers work with those cubes. You can drill through from the
summary sales information to see the details of how a particular region is doing,
perhaps to check that a new manager is having a positive effect.

Drill through to another IBM Cognos PowerPlay report when
v the other report contains data from another cube that you need to analyze and

compare to the data in your open report
v you want to link the reports for your current PowerPlay session so that you can

explore the data in one report and see the effects in the other report
When you change the dimension line in one report, the dimension line and data
change in the drill-through report when you click the drill through button.

v you are unfamiliar with the structure of data in the other cube
Since the administrator has set up the report for you, you don't need to start
from scratch with unfamiliar data.

v the administrator has performed calculations

Drill through to a cube when
v you want to explore the data in the other cube without a predefined view of the

data set up by the administrator
v the administrator has not set up reports for you to drill through to, only cubes

If you drill through to PowerPlay but the dimensions are not filtered in the target
cube or report, the dimensions in the report or cube you drilled through to may
not be compatible with the dimensions in the report you drilled from. Contact
your administrator for more information about the differences in the dimensions
and categories.
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If you open a report and later drill through to this report from another report, two
copies of the same report are open. However, only the copy of the report that you
drilled through to is linked.

For example, you open a report called Q4-Sales and a report called 2007-Sales. You
drill through from 2007-Sales to Q4-Sales. You now have two copies of the
Q4-Sales report open. Only the copy that was opened by drilling through from the
2007-Sales report is linked to 2007-Sales. When you change the dimension line in
2007-Sales and click the Drill Through button, only the copy of Q4-Sales that you
drilled through to is updated, unless shared dimensions is turned on.

If you drill through to a time-based partitioned cube that contains data that is
categorized differently among the PowerCubes that form the time-based
partitioned cube, you may receive data that appears inconsistent.

For example, you drill through to a time-based partitioned cube that contains data
on the top ten sales staff in San Francisco for 2008. Dave Mustaine, a sales
representative in San Francisco, shows total sales for 2008 of $60,000. When you
drill further to isolate Dave Mustaine without a regional context, you see total
sales of $72,000 for 2008, a value which is inconsistent with the original total sales
reported. Because Dave Mustaine joined the Denver sales office for two months
during 2008, his $12,000 in total sales for those months were not returned in the
original view which showed Dave Mustaine for San Francisco only. Isolating Dave
Mustaine with no context of San Francisco or Denver returns data for both regions
for 2008.

Procedure
1. To drill through to a report or cube associated with a measure, ensure that the

common measure appears in the report.
If you add the measure as a row, column, or layer, you must select a context
that includes the measure that you want to use for the drill-through. The names
of the intersecting categories appear in the lower left of the PowerPlay window
to show the current context. If the selected context does not use the common
measure, PowerPlay uses the measure shown in the measures folder.

2. Select the cell or category label from which you want to drill through.
PowerPlay uses the selected cell or label as the basis for the report or cube you
are drilling through. For example, if your report shows 2006, 2007, and 2008 in
the rows, and the selected cell is 2008, PowerPlay filters the drill-through report
to show 2008 data.

3. From the Explore menu, click Drill Through.
4. If the Drill Through dialog box appears, double-click the drill-through target

you want to view.
If the report or cube you need does not appear in the Drill Through dialog
box, ensure that the common measure appears in the report. If the common
measure is in the report, the name or location of the drill through target may
have changed. Contact your administrator to resolve drill through problems.
You may need to change the default report location on the Query tab in
Preferences.

Results

If you selected a report, PowerPlay opens the target report filtered to match, as
much as possible, the context and dimension line of the first report. If you selected
a cube, PowerPlay creates a new Explorer report, filtered to match, as much as
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possible, the context and dimension line of the first report. In both cases, if no
categories match, the target report shows categories in the first two dimensions
and uses the first measure in the cube.

After you drill through to a different report or cube, you can go back to the
original report, make changes, and then click the drill through button to update
the target report. To drill through to a different target from original report, use the
Drill Through option on the Explore menu to select a different target.
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Chapter 6. Rank and Sort Data in Reports

Ranking helps you compare categories. You can rank categories by their value in a
specific row or column. For example, a report outlines revenue for all your
products. When you rank this report, IBM Cognos PowerPlay adds a rank category
to identify the place each product came in, by revenue.

Sorting arranges categories in ascending or descending order. For example, a report
lists all of your salespeople. You sort this report to list the salespeople in
alphabetical order.

Rank Data
You can rank the categories in the rows or columns of a report. When you rank the
rows or columns of a report, each row or column value is assigned an ordinal that
shows how it performed in relation to the other rows or columns.

The rank ordinals appear in a new row or column. In Explorer reports, the label
and values of the rank category are italicized. The italic formatting is removed
when you switch to a Reporter report.

You choose whether the highest or lowest value in a category receives a rank
ordinal of 1, and how many of the top or bottom results to view. You can sort or
hide the rank category. By default, rank categories are hidden in scatter displays.

You can change the default rank settings in Preferences.

By default, rank categories are automatically regenerated when the report data
changes. If you clear the Automatically re-rank setting when defining a rank, you
can manually re-rank at any time after changing the report. Using manual
re-ranking can save time when working with a large data source because the
ranking is not updated with every change to the report.

The following constraints for ranking may apply to your report.
v If you hide categories, they are not ranked.
v If you nest categories, ranked categories do not appear in the chart display.
v You cannot rank the "Other" category when using 80/20 suppression.
v Summary values do not receive rank ordinals in Explorer reports.

Rank categories using the default settings
The rank settings in Preferences determines how the category is ranked when you
use the rank button.

Procedure
1. Select one row or column by which you want to rank and click the rank button

.
2. If the categories in a report change, right-click the rank category and click

Re-Rank.
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Rank categories using custom settings
You can specify custom rank settings instead of using the default settings.

Procedure
1. From the Explore menu, click Rank.
2. Specify the rank settings.
3. Select Automatically Re-Rank to update the ranking when the report changes.

If you do not select Automatically Re-Rank, to update ranking in a report,
right-click the rank category and click Re-Rank.

4. Click OK.

Hide or remove ranking
You can hide a rank category or delete it from the report.

Procedure

Choose whether you want to temporarily hide the rank category of permanently
delete it from the report:
v To hide the ranking, right-click the rank column or row and click Hide.

IBM Cognos PowerPlay hides the rank column or row. To show hidden
categories, from the Format menu, click Unhide.

v To delete the ranking, right-click the rank category label and click Delete Rank.

Rank Identical Values
Categories with the same value receive the same rank ordinal. For example, if two
categories have the same value and the value is the second highest value in the
ranked group, both categories receive a ordinal of 2. In this case the third highest
value receives an ordinal of 4.

Rank Nested Data
You can rank the lowest level categories of nested reports. If you add a lower level
of nested categories to the rows or columns where a rank category appears, the
rank category is removed.

For example, in the following report columns are ranked based on the nested
Camping Equipment category.

Figure 12. Report with columns ranked based on a nested category
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Manually Re-Ranking in Reporter Reports
In addition to improving performance when working with a large data set, you
may want to use manual re-ranking to retain the original rank ordinals after
changing the categories in a report. This ensures that values from a different level
are not included in the ranking.

For example, in a the following Reporter report, you ranked Years, clearing the
Automatically re-rank option in the Rank dialog box. When you drill down on
Camping Equipment, the children are not included in the ranking. If you did not
clear the Automatically re-rank option when adding the ranking, the children
would be ranked at the same level as the product categories, which would not be
an accurate representation of the data.

Sort Data
When you sort data, the rows or columns are arranged in ascending or descending
order. You can sort
v rows, columns, or layers in alphabetical order
v rows or columns in numerical order

If your report includes nested categories, you can not sort by value. For example,
in the following report, the nested category Retailers is sorted alphabetically. You
can not sort the rows in this report by value.

Figure 13. Report showing effect of drill down on ranking
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By default, sort categories are automatically regenerated when the report data
changes. If you clear the automatic sorting setting when defining the sort, you can
manually re-sort at any time after changing the report. Using manual re-sorting
can save time when working with a large data source because the sorting is not
updated with every change to the report.

Hidden categories are not sorted.

Sort using default settings
The sort settings in Preferences determines how the category is sorted when you
use the sort button.

Procedure
1. Select one row or column you want to sort and click the sort button on the

toolbar .
2. If the categories in a report change, from the Explore menu, click Re-Sort.

Sort using custom settings
You can specify custom sort settings instead of using the default settings.

Procedure
1. From the Explore menu, click Sort.
2. Specify the sort settings. If you do not select Automatically re-sort, to re-sort

after a report changes, from the Explore menu, click Re-Sort.

3.

4. Click OK.

Figure 14. Report with alphabetical sorting
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Chapter 7. Highlight Exceptions

You can use two types of exception highlighting to identify information that may
need further exploration.
v Automatic exception highlighting quickly shows unusually high and low values

in Explorer reports.
v Custom exception highlighting shows a specific range of data. You can create

one or more custom exception definitions that can be applied to reports or
distributed to others. You can also use a macro to apply a custom exception
definition.

For information about creating a macro to highlight exceptions, see the IBM
Cognos PowerPlayMacro Reference Guide.

Automatic Exception Highlighting
You can automatically highlight exceptions in your Explorer reports. When you
enable this feature, exceptionally low values appear in a red, bold font, and
exceptionally high values appear in a green, bold font. You can use the exceptional
values as starting points for further investigation.

You can adjust the sensitivity of the automatic exception highlighting. The higher
the sensitivity, the more data is highlighted. You can also change the styles used to
highlight high and low automatic exceptions.

You can change the default automatic exception sensitivity using the Options
preferences.

Automatic exception highlighting is not available if you are in a Reporter report.

If you use automatic exception highlighting frequently, you may want to add the
automatic exceptions button to the toolbar.
Related concepts:
“Customize Toolbars and Buttons” on page 87
You can show, hide, create, delete, and modify toolbars. For example, you can
create a toolbar that contains only the buttons you use.

Apply automatic exception highlighting
The automatic exception highlighting setting in Preferences, Options determines
default sensitivity for identifying exceptional data.

Procedure

In an Explorer report, from the Explore menu, click Automatic Exceptions,
Highlight.

Change automatic exception sensitivity for the active report
You can override the default exception sensitivity for the active report.
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Procedure
1. In an Explorer report, from the Explore menu, click Automatic Exceptions, Set

Sensitivity.
2. Drag the control bar to specify how exceptional a value has to be for IBM

Cognos PowerPlay to highlight it.
3. Click OK.

Modify the automatic exception styles
You can modify the default automatic exception styles. Changes to styles affects all
reports.

Procedure
1. From the Format menu, click Styles.
2. Select High Automatic Exceptions or Low Automatic Exceptions.
3. Click Modify and change the style definition.
4. Click OK.

Custom Exception Definitions
A custom exception definition highlights data that falls within value ranges that
you specify. After you create the custom definition, you must apply it to highlight
exceptional data. If a report uses a custom exception definition, the exception
highlighting is updated when you open the report after a cube update.

You can save the custom exception definition to share with other reports or with
other users.

When you create a shared custom exception definition, the exception definition is
saved to the Ppexcept.ini file and the styles are saved to the Ppstyles.ini file. These
files are stored in the installation_location/configuration/powerplay folder.

Create a custom exception definition
You can define up to five value ranges in one custom exception definition, and
attach a formatting style to each range. IBM Cognos PowerPlay applies
corresponding formatting styles to all data that falls within the defined ranges.

Procedure
1. From the Explore menu, click Custom Exceptions.
2. Specify the custom exception settings. To modify an existing custom exception

definition, select the custom exception definition in the Exception Name box,
make the changes, and click Add.

3. To save the custom exception definition for use in other reports or to share
with other users, select the Shared check box.

4. Click the Add button and click Close.

Delete a custom exception definition
You can delete custom exception definitions.

Procedure
1. Select a report.
2. From the Explore menu, click Custom Exceptions.
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3. In the Exception Name box, select the custom exception definition.
4. Click Delete and click Yes.
5. Click Close.

Apply a Custom Exception Definition
You can apply a custom exception definition to highlight
v exceptional values in a report

IBM Cognos PowerPlay compares each value in the report to the range of values
in the custom exception definition. If a value in the report falls in the range, it is
highlighted.

v entire rows or columns that contain exceptional values
PowerPlay compares the values in a driving category to the range of values in
the custom exception definition. If a value in the driving category falls in the
range, the entire row or column that contains the value is highlighted.
If, in a Reporter report, you created a custom exception definition based on a
particular category that doesn't apply in an Explorer report, then that category
doesn't appear in an Explorer report custom exception definition. For example, if
you base a custom exception definition on All Years and then switch to an
Explorer report, the All Years parent category doesn't exist in the custom
exception definition.

v only values in the rows and columns you selected
PowerPlay compares the values in the selected rows and columns to the range
of values in the custom exception definition. If a value in the selected rows and
columns falls in the range, it is highlighted.
For example, you create a revenue report with products in the rows and months
in the columns. You can highlight all negative values in red so you can see
which products lost money in which months. Because March is a critical month
for selling backpacks, you select the March column as the driving category. If a
product lost money in March, the entire product row is highlighted in red.

When you drill down on data after the custom exception definition is applied, data
that falls within the specified ranges is highlighted as you drill down and up.

When you apply a custom exception to the entire report, all rows, or all columns,
PowerPlay highlights any new data that is added when the cube is refreshed. This
is particularly useful for identifying subsets and new categories that are added to
the cube when the data is refreshed.

Custom exception definitions are based on the measure being used. If you applied
custom exception highlighting and then change the measure, the custom exception
highlighting is not visible. However, if you change the measure back to the one
that was used with the custom exception definition, the custom exception
highlighting is visible again.

Only one custom exception definition can be applied at a time. The one that was
applied most recently to the report is the active custom exception definition.

Before you begin

You must create a custom definition before you can apply it.
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Procedure
1. Select the report, the rows or columns, or the information in the report to

which you want to apply the custom exception definition.
You can click a value to select both a row and a column. You can click a label
to select either a row or a column.

2. From the Explore menu, click Custom Exceptions.
3. In the Exception name box, select a custom exception definition.
4. Choose where you want to apply the definition.
v To apply the definition to all the values in the report, click All.
v To apply the definition to rows or columns, click All Rows or All Columns.

If you select All Rows or All Columns, you may select a driving category in
the Based on Category box. If you apply the custom exception definition to
rows, the driving category is a column, and if you apply it to columns, the
driving category is a row.

v To apply the definition to selected information, click Selection.
5. Click Apply and click Close.

Results

Data that meets the criteria specified in the custom exception definition is
highlighted. If no data is highlighted, then none of the data fit the specified
criteria.

Clear a custom exception definition from data
You can clear data highlighting related to a custom exception definition without
deleting the definition.

Procedure
1. From the Explore menu, click Custom Exceptions.
2. In the Exception name box, select a custom exception definition.
3. Click Clear and click Close.

Shared Custom Exception Definitions
To ensure that all IBM Cognos PowerPlay users highlight exceptions in the same
way, you can distribute a custom exception definition to other users.

For example, you create a custom exception definition called Year End that shows
losses in red and profits in green. Your manager asks you to share the custom
exception definition with everyone else in the department. The custom exception
definitions are stored in the Ppexcept.ini file, and the styles are stored in the
Ppstyles.ini file. Your colleagues can either use your copies of the files, or they can
cut and paste the appropriate lines into their copies of the files if they have already
created styles and exceptions they want to keep.

Distribute custom exception definitions
IBM Cognos PowerPlay adds custom exception definition information to the
Ppexcept.ini and Ppstyles.ini files. To distribute custom expection definitions, you
share these files with other users.

Procedure
1. If necessary, create new custom exception definitions.
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Ensure the Shared check box is selected when you create the custom exception
definitions.

2. Locate the Ppexcept.ini and Ppstyles.ini files on your computer.
3. Send the files to other users or put the files in a shared network location.

Results

If you create new shared custom exception definitions after you distribute the
Ppexcept.ini and Ppstyles.ini files, you must send users updated copies of the files.

Use shared custom exception definitions
When you receive files that contain shared custom exception defintions, you can
choose to use all shared definitions or only specific shared definitions.

Procedure

Choose one of the following options to use the shared custom exception definition.
v To delete your existing definitions and use all definitions in the shared file,

replace your existing Ppexcept.ini and Ppstyles.ini files with the shared files.
v To add individual definitions from the shared files to your existing Ppexcept.ini

and Ppstyles.ini files, copy definition and style information from the shared .ini
files to your .ini files.

The following is an example of a custom exception definition in a ppexcept.ini file.
Exception3=Year End, 0, 3, 0, 0,\,

Exception3Range1=Bad News,0.,Minimum

Exception3Range2=Good News,Maximum,20000.

Exception3Range3=,0.,0.

Exception3Range4=,0.,0.

Exception3Range5=,0.,0.

The following is an example of a style definition in a ppstyles.ini file.
[Style -Good News]

numformat=9,0

numformattext=$1,000,000

font=Arial, 700, 1, 10, 0, 0, 0, 0, 0, 0, 0, 0, 0, 128,
0

pattern=0, 0, 0, 0, 255, 255, 255

alignment=0, 1, 2

Results

The shared definitions are now available for use in new and existing reports.
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Chapter 8. Calculations

IBM Cognos PowerPlay includes basic and advanced calculation options to
support data analysis. In addition to basic calculations, such as determining the
average of a row or column, you can create calculations to show standard financial
ratios such as the liquidity ratio or debt ratio. The predefined forecasting methods
offer another valuable way to analyze data in some situations.

The IBM Cognos Transformer modeler can add calculated categories to a cube to
eliminate the need for report authors to recreate common calculations in different
reports. Calculated categories appear in the dimension viewer with a calculator

icon .

The following differences exist for calculations in Explorer versus Reporter reports:
v In Explorer, you can perform all calculations except minimum, maximum and

average.
v In Reporter, you can perform all calculations except forecast.
v In Reporter, you can perform group calculations when you want to repeat the

same calculation for many categories.
v In Reporter, you can specify a precedence order for calculations.
v In Explorer, the position of the calculation is automatically determined based on

the operands. You can not change the location of the calculation.
v In Reporter, the calculation is inserted after the pointer position. You can delete

or move categories that are part of the calculation, or the calculation, without
affecting the calculation.

v In Explorer, the label and values of the calculation are italicized. The italic
formatting is removed when you switch to a Reporter report.

v In Explorer, if you drill down to the lowest level, a single category appears. You
cannot perform calculations on this category.

For both Explorer and Reporter reports, you cannot perform calculations on the
'Other' category (80/20 suppression).

The following size limits apply to values you specify when using calculations:
v maximum 1.7976931348623158e+308
v minimum 2.2250738585072014e-308

After adding calculations to reports, you may want to format the labels and values.
For example, you can change the default label.

View Information About Calculations
You can view the categories or formula that makes up a calculation in a report.

Procedure

Right-click any cell in the calculation and click Explain.
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Calculate Percentage Growth
Percentage growth is the percentage change between two categories or measures.

Procedure
1. Select the two rows or columns that you want to find the percentage growth

for.
2. From the Calculate menu, click Percent Growth.
3. In the Order box, select the order of the calculation.
4. In the Label box, type a name for the category and click OK.

Calculate the Percentage of a Total
You can convert values to a percentage of the total to analyze income statements
and other financial statements.

You cannot perform a percentage calculation on a rank category.

Procedure
1. If the report does not have a total, select the categories to sum. From the

Calculate menu, click Add.
2. Select the categories to convert to a percentage of a total.

Tip: To add child categories that show as a percentage of their parent category,
click the Share of button in the dimension viewer toolbox (Reporter mode).

3. From the Calculate menu, click Percent of Base.
4. In the Select a Base Value box, select the total to base the percentage on.

If you select a row in the report, this box lists all columns; if you select a
column, it lists all rows.

5. In the Label box, type a name for the category.
6. Click OK.

Calculate an Average
To help plan future or current events, you can calculate an average.

For example, you can calculate the average revenue of a product line for the first
quarter of the year and compare it to average revenue for the second quarter of the
same year.

Procedure
1. In a Reporter report, select one or more categories.
2. From the Calculate menu, click Average.
3. Do one of the following:
v In the Label box, type a name for the category.
v If you want to do more than one calculation of the same type at a time,

select the Group check box and select a category in the Operand box.
You can do more than one calculation only if you selected two or more
categories.

4. Click OK.
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Calculate a Running Total
You can include a column or row in your report that shows a running total. The
running total can be expressed as a numeric or percentage value. In Reporter
reports, you can calculate a running total for more than one category.

For example, you create a report that shows the revenue in each of the past four
quarters. The running total shows the total revenue by the end of each quarter. If
you add a running total as a percentage of the total sold, you can see the
percentage of the full year's sales achieved by the end of the quarter.

You can delete the category representing the base value from the report after
creating the cumulative percent of base value.

In Explorer mode, you can select only one category on which to perform a running
total as a numeric or cumulative percent of base value.

You cannot perform a cumulative percent of base calculation on a rank category.

Note: In Reporter mode, if the selected category includes an existing calculation
the calculation value is included in the running total.

Calculating running totals as numeric values
You can show running totals as a numeric values.

Procedure
1. Select one or more categories.
2. From the Calculate menu, click Accumulate.

Calculating runnings total as percentage values
You can show running totals as percentage values

Procedure
1. Select one or more categories.
2. From the Calculate menu, click Cumulative Percent of Base.
3. In the Select a Base Value box, select the total that you want to base the

percentage on.
If you select a row in the report, this box lists all columns; if you select a
column, it lists all rows.

4. In the Label box, type a name for the category and click OK.

Rollup Calculations
By rolling up calculations, you can more easily analyze groups of categories within
the same dimension. When you apply the rollup function, you create a new
calculation that applies the rollup function (either add, minimum, maximum, or
weighted average) defined for the measure used by the selected categories.

For example, the Course Pro line includes products from more than one category
in Golf Equipment. You create a report that includes only the Course Pro products
and then add a rollup calculation to determine the overall profit margin for each
quarter.
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When you drill up or drill down on one of the selected categories included in the
rollup calculation, the calculation is recalculated.

You can perform rollup calculations on subsets.

Procedure
1. Select the categories to include in the rollup calculation.

Selected categories must be from the same dimension and must all be of the
same display type (that is, all rows, all columns, or all layers).
If the selected categories involve more than one measure, the function defined
for the first measure is used in the rollup calculation.

2. From the Calculate menu, click Rollup.
3. In the Label box, type a name for the category and click OK.

Perform Calculations on Nested Categories
When you perform a calculation on nested categories, the new calculation is added
at the same level as the last selected category. If you move the calculation to a
different level in a report, the result will be different compared to the original
location. To ensure that a calculation on nested categories produces the expected
results even if you move the calculated category to a different location, include the
parent category in the calculation.

For example, the following report nests the separate product groups under
Outdoor Protection. The report also shows actual and target revenue. To create a
calculation to show the revenue variance, select Outdoor Protection, then Revenue
and Sales Target. By selecting the categories in this order, you ensure that the
calculation is specific to Outdoor Protection products. The calculation appears at
the same level as the parent, Outdoor Protection.

Figure 15. Report with rollup calculation
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When you perform calculations on nested categories that have been added using
short bar drop zones, you must follow two rules or your results may be incorrect:
v You must select the parent of the category you want to use in the calculation. If

you use categories that are nested in two different parents, you must select both
parents.

v If the last category you select is a parent, your calculation appears at the same
level as the parent. Conversely, if the last category you select is a child, your
calculation appears nested beside that child.

Perform Calculations When You Add Categories
In Reporter reports, if you know that you want to perform certain calculations on
certain data, you can have IBM Cognos PowerPlay generate the calculations when
you add categories to the report. PowerPlay adds the calculations as new
categories.

You can show
v the selected category individually and the calculation
v the sum of selected categories
v the average of selected categories
v the selected categories as a percentage of their parent categories

Procedure
1. Open a Reporter report.
2. In the dimension viewer, select two or more categories.
3. In the dimension viewer toolbox, do one of the following:
v To show the selected categories individually in addition to the calculation,

click the Each button.
v To show the sum of the selected categories as a new category, click the Sum

of button.
v To show the average of the selected categories as a new category, click the

Average button.
v To show the selected categories as a percentage of their parent categories,

click the Share of button.
4. Click the Add as Row, Add as Column, or Add as Layer toolbox button to add

the categories to your report.

Figure 16. Report with actual-planned calculation
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Add Calculated Categories to a Report
The IBM Cognos Transformer modeler may have already added pre-set
calculations to the cube. These calculations appear as categories in the dimension

viewer and are identified by the calculate icon .

For example, you want to see the growth in revenue between the current quarter
of 2008 and the same quarter of 2007 for each product. You create an Explorer
report with Quarter to Date (QTD) in the rows and Products in the columns. The
QTD Growth is a calculated category included in the Great Outdoors cube. QTD
Growth appears in the report when you select the Calculated Categories command
from the View menu.

Before you begin

You can add calculated categories to Explorer or Reporter reports.

Procedure
1. In the dimension viewer, select a calculated category.

If calculated categories do not appear in the dimension viewer, from the View
menu, click Calculated Categories. Repeat to hide the calculated categories
again. In an Explorer report, the calculated category is removed from the
report.

2. Do one of the following:
v In a Reporter report, click the Add as Rows, Add as Columns, or Add as

Layers button.

Figure 17. Report with growth calculation
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v In an Explorer report, click the Replace Rows, Replace Columns, or Replace
Layers button. If you want calculated categories in only the rows or only the
columns, you must hide the calculated categories that you don't want to see.
From the Format menu, click Hide.

Perform Group Calculations
In Reporter reports, you can perform group calculations when you want to repeat
the same calculation for many categories. Group calculations can use the following
operations: addition, subtraction, multiplication, division, percentages, maximum
or minimum value, average, and exponentiate.

For example, you want to calculate a projected 10% increase in sales for each
product line for the coming year. Instead of performing the calculation on each
product line separately, you select all product lines and use the group option when
you create the multiplication calculation. The grouped calculation adds a projected
sales category to the report for each product line.

You can also perform group calculations on subsets.

Procedure
1. In a Reporter report, select the categories that you want to include in the

calculation.
2. From the Calculate menu, select an operation.
3. Select the Group check box.
4. If required, do any of the following:
v In the Order box, select the order of the calculation.
v In the Number box, type a value to use in the group calculation.
v In the Category box, select the category to use in the group calculation.

5. Click OK.

Setting Calculation Precedence
When calculations in the rows and columns of a report intersect, IBM Cognos
PowerPlay performs the calculations in the following order:
v business functions (accumulate, percent of base, and cumulative percent of base)
v basic functions (percent, average, minimum, maximum)
v division or multiplication
v addition or subtraction

If both calculations have the same precedence (for example, if they are both
business functions), the row calculation takes precedence. You can override the
order of precedence, such as performing addition before multiplication.

Procedure
1. In a Reporter report, right-click the selected calculation that you want to grant

precedence to.
2. Click Override Precedence.

When you click a business function that intersects another calculation, the
Override Precedence command is disabled. Business functions take precedence
over all other calculations.

Chapter 8. Calculations 57



Forecasting Methods
You can make predictions about the future performance of your business based on
historic data using one of three time series forecasting methods: Trend, Growth, or
Autoregression.

Before creating a forecast, you must include the time period as either rows or
columns in your crosstab.

Forecasts do not include any rankings that were included in the crosstab.

If you convert the currency in your crosstab, IBM Cognos PowerPlay creates the
forecast on the currency-converted values.

If you nest multiple levels of time in your crosstab, PowerPlay produces the
forecast only at the highest level of time.

For example, in this report, you nest quarters within years for revenue and then
choose Forecast from the Calculate menu, PowerPlay generates the forecast only at
the years level.

To generate your forecast at the quarters level, delete the years level before you
generate the forecast.

TERMS OF USE

The forecasting methods used in the Forecasting Function are based on the
statistical analysis of historical information drawn from underlying data sources.
The accuracy of the forecasted values is subject to many variables. These variables
include the accuracy of the underlying historical data and external events which
could affect the validity of that underlying historical data for forecasting purposes.
The Forecasting Function is to be used only as a guide of the future values for the
measures being forecasted and is not intended to be used as the basis for complex
financial or business decisions.

Figure 18. Report with forecast calculation
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IBM makes no representations as to the accuracy of the actual future values and
does not guarantee any specific results. You use the Forecasting Function and the
data it generates at your own risk. The Forecasting Function may contain errors or
produce inaccurate calculations. You accept the Forecasting Function and the
documentation "AS IS". IN NO EVENT SHALL IBM BE LIABLE FOR DAMAGES
OF ANY KIND INCLUDING, WITHOUT LIMITATION, DIRECT, INDIRECT,
INCIDENTAL, PUNITIVE OR CONSEQUENTIAL DAMAGES, RESULTING FROM
THE USE OF THE FORECASTING FUNCTION OR THE INTERPRETATION OF
THE DATA RESULTING THEREFROM.

Trend (Linear or Straight Line)
The trend forecasting method is based on the linear regression technique of time
series forecasting. Trend forecasting gives the best forecasting reliability when the
driving factors of your business affect your measures in a linear fashion. For
example, when your historic revenue increases or decreases at a constant rate, you
are seeing a linear effect.

A multiline plot of historic data should look linear or close to linear for greatest
reliability. For example, if you are forecasting revenue for the next two quarters
based on revenue for the past four quarters, and if the multiline plot of past
quarterly revenue is linear or close to linear, then the Trend method gives you the
best forecasting reliability.

Use the Trend forecasting method when only two data values represent two time
periods in your historic data.

Growth (Curved or Curved Line)
The Growth forecasting method is based on the exponential regression technique of
time series forecasting. Growth forecasting gives you the best forecasting reliability
when the driving factors of your business affect your measures exponentially. For
example, when your historic revenue increases or decreases at an increasingly
higher rate, you are seeing an exponential effect.

A multi-line plot of historic data should look exponential for best accuracy. For
example, if your revenues are growing exponentially due to the introduction of a
best selling product, then Growth forecasting provide a more reliable forecast than
the Trend method. Similarly, if you hire two additional sales representatives for
your company, you can use Growth forecasting to determine which product line
has the greatest growth potential to allocate your new resources effectively.

Autoregression (Seasonal)
The Autoregression forecasting method is based on the auto-correlational approach
to time series forecasting. Autoregression forecasting detects the linear, non-linear,
and seasonal fluctuations in historic data and projects these trends into the future.
Autoregression provides the best forecasting reliability when the driving factors
underlying your business are affected by seasonal fluctuations.

A multi-line plot of time and revenue shows up-and-down fluctuations that may
reflect seasonal variations. For example, if your revenues are growing
exponentially due to the introduction of a best selling product, but sales of that
product are also seasonal, then Autoregression forecasting provides a more reliable
forecast than the Growth method.
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Use the Autoregression method when historic data represents a large number of
time periods (for example, more than 24 monthly periods) and when seasonal
variations may occur in it.

Create a Forecast
You can make predictions about the future performance of your business based on
past data by using one of these time series forecasting methods: Trend, Growth, or
Autoregression.

Your time dimension must appear as either rows or columns.

Before you begin

You must be using Explorer mode to create forecast calculations.

Procedure
1. From the Calculate menu, click Forecast.
2. Select the forecasting method you require.
3. In the Enter the Forecast Horizon box, type the number of time periods to

forecast.
The number of time periods to forecast cannot exceed the number of periods in
your data.

4. Click OK.

Financial Ratios
You can calculate financial ratios, such as liquidity ratios, debt ratios, and
profitability ratios, to determine how well a company is doing. For example, you
create a report that shows cost, the average inventory, and the liquidity of
inventory for each product.

The following table shows common financial ratios and the corresponding formula.
Because each calculation can contain only one operand, you must use two
calculations to determine some of the financial ratios.

Table 2. Financial ratios

Ratio type Ratio

Liquidity Current ratio

Current Assets / Current Liabilities

Average collection period

((Receivables * Number of Days in Year) / Annual Credit Sales)

Accounts receivable turnover

(Net Sales / Average Receivables)

Liquidity of inventories

(Cost of Goods Sold / Average Inventory)
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Table 2. Financial ratios (continued)

Ratio type Ratio

Debt Debt/equity

(Total Debt / Total Equity)

Profitability Gross profit margin percentage

((Sales - Cost of Goods Sold) / Sales)

Net profit margin percentage

(Net Income / Sales)

Pre-tax margin percentage

(Pre-tax Income / Sales)

Return on equity percentage

((Net Income - Preferred Dividends) / Average Total Common
Shareholders Equity)

Earnings per share

((Net Income - Preferred Dividends) / Number of Common shares
Outstanding)

Other Average revenue per employee

(Total Sales / Total Number of Employees)

Average revenue per salesperson

(Total Sales / Number of Salespeople)

Average profit per salesperson

(Profit / Number of Salespeople)

Chapter 8. Calculations 61



62 IBM Cognos PowerPlay Client Version 11.0: User Guide



Chapter 9. Graphical Displays

Graphical displays communicate comparisons, relationships, and trends. They
emphasize and clarify numbers. To choose the appropriate type of display, first
define the purpose of the report, and then identify the most effective display to
suit that purpose. For example, you can use a multiline display to show trends.

For some display types, the data for each row appears in a separate display. A box
appears at the bottom of the report window that shows the name of the current
row. If the report includes more than one row, this box includes an option to select
a different row. Click on the box to see a list of the available rows.

Compare Variables, Show Variance, or Track Performance
You can compare variables, show variance, or track performance by using a simple
bar, stacked bar, or 3-D bar display.

Use a
v simple bar display to show change over a specific time period and to compare

and contrast two or more variables in one time period
v stacked bar display to show the parts that contribute to the total and to compare

change over time
v 3-D bar display to show relationships between several variables and to analyze

large quantities of information that are difficult to interpret otherwise

Procedure

From the Explore menu, click Change Display, and click the Simple Bar, Stacked
Bar, or 3-D Bar button.

Compare Two Measures
You can compare two measures by using a correlation or scatter display. At least
two measures must be in the cube. By default, IBM Cognos PowerPlay uses the
first two measures in the cube for the display. You can change the measures being
compared. Use a
v correlation display to show the first measure in the cube as bars and the second

measure as lines
v scatter display to show the first measure in the Y-axis and the second measure in

the X-axis

The measures do not have to correspond to the nested measures in your crosstab.
Changing correlation and scatter measures affects the measures in your crosstab
report.

Figure 19. Row indicator
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To compare two or more measures, you can also add them as nested categories to
a crosstab report.

If the cube you are using contains only one measure, the correlation and scatter
display buttons are not available since these displays require at least two measures
in the cube.

Procedure
1. From the Explore menu, click Change Display, and click Correlation or

Scatter.
A Graph box appears at the bottom of the report window. The Graph box
shows the names of all the rows that are available for the display. Use the
Graph box to select a different row to examine.

2. Select the measures you want to compare from the Measures dimension menu.
Two measures folders are available because the correlation and scatter displays
use two measures.

Show the Mix in a Pie or Clustered Bar Display
Pie charts and clustered bar displays are useful for showing the relative
relationship between categories.

You can use
v a pie display to show the relationship of the parts to the whole, with

percentages translated into proportional sections
v a clustered bar display to show groups of related information, to compare the

groups over a period of time

To see two pie displays that show different mixes of information, create two
reports and tile the report windows. The same report can't contain two pie
displays that show different mixes.

Procedure
1. From the Explore menu, click Change Display.
2. Click Pie or Clustered Bar.

Find a Trend in a Display
A line display or a stacked bar display is useful for showing trends in data.

You can use
v a single line display to show how a single variable is performing over time
v a multiline display for time series analysis, to compare trends and cycles, and to

infer relationships between variables
v a stacked bar display to show the parts that contribute to the total and compare

change over time

Procedure

From the Explore menu, click Change Display, and click Single Line, Multiline,
or Stacked Bar.
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Show More than One Type of Display
You can look at information from the same report in different ways by showing
more than one display.

When you select a category in one display, that category is also selected in the
other displays. For example, you can see the effect in the other displays when you
select a category in a crosstab.

When you drill down to lower levels of information in one display, you also see
these levels of information in the other displays.

For example, to track how your products sold in relation to each other, and also in
relation to the previous year, use a pie display to compare product sales for 2008,
and a clustered bar display to compare 2008 sales to 2007 sales.

You can arrange multiple displays by resizing, moving, and tiling them.

Procedure

From the Insert menu, click Display, and click the display to add.

Results

The report window shows the additional display.

Tip: To add another display quickly, Ctrl+click the toolbar button for that display.
For example, Ctrl+click the pie button to add a pie display.

In a single report with multiline and crosstab displays, you can use a multiline
display to track trends over time and still see summary columns in the crosstab
display. Show both displays and click the multiline display. From the Format
menu, click Display Options. On the Display tab, clear the Show Summary
Columns check box and click OK.

To remove a display, right-click the display and click Delete Display.

Show Multiple Charts in One Display
In Explorer reports, you can show nested data in a series of single charts, or switch
to nested charts and view all of the nested data in one multiple chart display.

Nested charts are summary row based charts. If a measure is the lowest level
category in your row, the results of the first measure are shown when you select
nested charts in a vertical simple bar, single line, or correlation chart. The row
legend layout shows all measure labels.

You cannot nest a horizontal simple bar chart or a scatter chart.

Procedure
1. In an Explorer report, select a chart display.
2. From the Explore menu, click Nested Charts.
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Results

The report window shows the multiple displays.

View Large Amounts of Data
When you work with large amounts of data, it can be difficult to see all the data in
one graphical display. Too many columns can clutter the display, making accurate
interpretation difficult. To resolve this problem, a scroll bar appears by default in
any display that has more than eight columns. You can change this default at any
time.

For example, you prepare a IBM Cognos PowerPlay report using the simple bar
display that includes all the tents in your product line. Because there are several
tents, your display appears cluttered. You want to adjust the number of columns
that appear on each page so the data is more easily understood.

You can also define whether to show summary categories for nested crosstabs.

You cannot add scroll bars to a pie display, 3-D bar display, or a scatter display.

Procedure
1. Select the chart display that you want to change.
2. From the Format menu, click Display Options, and click the Scrolling tab.
3. In the Scrolling Options box, select the Use a Scrollbar If Required check box.

Tip: If you want to see all the data in one display, clear the Use a Scrollbar if
Required check box. If you reach the maximum limit of bars (500 rows or
columns) in PowerPlay, an error message appears warning that the data will be
truncated.

4. In the Maximum Columns Displayed box, specify the number of columns that
you want to appear in the display.
You can show between 5 and 52 columns on one page of a display.

5. In the Maximum Columns Printed box, specify the number of columns that
you want to print.

6. Click OK.

Show Values in a Display
You can show values on or above the bars in simple or clustered bar displays, and
above the markers in single line displays. You can also show values on or above
the bars of correlation displays, and next to the slices of a pie chart.

You can change the default show values option for new reports using the display
options in preferences.
Related tasks:
“Setting Preferences” on page 85
There are many options you can set to customize the settings for all new reports.
For example, you can specify the default directories to use for reports and cubes.

Showing values in simple or clustered bar displays
You can show values in simple or clustered bar displays.
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Procedure
1. Select a simple or clustered bar display.
2. From the Format menu, click Display Options.
3. On the Display tab, in the Values on Bars box, select the Show check box.
4. Click OK.

Results

If the bars in a bar display appear as zeros, ensure that the scale of the grid is
accurate. For example, if the largest value in the report is 37 million and you set
the maximum value in the manual scale of the primary axis to 1 billion, the scale
dwarfs the actual values and causes the bars to appear as zeros.

Showing values in single line displays
You can show values in single line displays.

Procedure
1. Select the single line display.
2. From the Format menu, click Display Options.
3. On the Display tab, in the Values Above Markers box, select the Show check

box.
4. Click OK.

Add Statistical Lines to a Chart Display
You can add up to three statistical lines to a chart display. Statistical lines can show
minimum, maximum, mean, standard deviation, logarithmic regression, and linear
regression values. You can also add custom statistical lines to a display.

For example, the regression line is useful for fitting a curve to a set of data with a
logarithmic relationship. A logarithmic regression line is not displayed if a row
contains all negative numbers.

When you select linear regression line, IBM Cognos PowerPlay displays a straight
line calculated using the least-squares method. The equation used is: y = mx + b,
where m = slope, and b is the y-axis intercept (the value of y when x is zero).

When you select logarithmic regression line, PowerPlay displays a logarithmic
curve calculated using the least-squares method. The equation used is: y = a*ln(x)
+ b, where a and b are constants, and ln is the natural logarithm function.

When you add statistical lines to a display, the statistical lines for a single selected
row are shown.

You cannot add statistical lines to pie displays, 3-D bar displays, and stacked bar
displays.

Procedure
1. Select the chart display to which you want to add statistical lines.
2. From the Format menu, click Display Options, and click the Statistics tab.
3. In the Line box, select the lines you want to show.
4. In the Settings box, change the format of the lines you want to add.
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5. Click OK.

Results

Tip: To show the statistical lines for a specific row, select the row in the Legend.

Formatting Graphical Displays
Formatting displays improves the overall appearance of a display and makes it
easier to read.

For example, you can
v change the patterns and colors
v change angles and rotations
v show or hide gridlines
v scale axes

Change the Colors and Patterns Settings
For graphical displays, you can change the palette settings to specify the order that
colors or patterns are used in a display. The palette settings ensure that the same
order of color or pattern is used in all graphical displays. For example, the first bar
in a bar chart will be blue, the second red, the third yellow, and so on based on the
way the colors are ordered in the palette settings. This predictable pattern is useful
when comparing different views of the same data. The same color represents the
same category in each view.

The palette settings also associate a color with a pattern. When you chose to show
colors as patterns, which is useful when you don't have access to a color printer,
each color is replaced by an associated pattern. You can change settings to
associate a pattern with a different color.

To change the color and pattern settings for all reports, change palette settings in
preferences.

Procedure
1. From the Format menu, click Palette.
2. To change the order of a color or pattern, or to associate a color with a different

pattern, drag a color or pattern to a new location.
3. To customize a color, select the color and then click Customize Colors.
4. To use patterns instead of colors in displays, select Show colors as patterns.
5. Click OK.

Results

The new settings are applied to the current report.

Apply a Background to a Display
To apply a background to a display, you can use
v pictures, such as a company logo
v colors and patterns
v blend options, so that there is a gradual change from the start to the end of the

background color

68 IBM Cognos PowerPlay Client Version 11.0: User Guide



The background applies to the current display, and is not applied when you
change display type.

You can also apply a background to an entire report.

Before you begin

You cannot apply a background to a pie or crosstab display.

Procedure
1. Select a display.
2. From the Format menu, click Display Options.
3. Click the Background tab.
4. Specify the background settings. There is a 126-character limit (including

backslashes and underscores) for the location and file name of the picture used
in the background.

5. Click OK.

Arrange Displays
If you are viewing more than one display at the same time, you can arrange the
position of the displays. By default, displays are tiled for best fit.

To tile separate reports, from the Windows menu click Tile Horizontally or Tile
Vertically.

If the report includes a single crosstab display, the crosstab will always appear at
the bottom.

Procedure
1. From the View menu, click Page Width or Page Layout.
2. Tile and move displays until they appear as you want.
v To arrange displays within the same report, from the Format menu, click Tile

Displays and select an option.
v To move a display, click to select the display, and grab the hash marks

border.

Change the Angle of a Display
You can change the angle of a display. For example, you can angle a simple bar
display to show bars on a vertical axis instead of the horizontal axis.

You can set the default angle for new displays using the display option in
Preferences.

Changing the angle of pie displays
You can change the angle of a pie display.

Procedure
1. From the Format menu, click Display Options.
2. On the Display tab, select the Show check box.
3. In the Angle box, type the number of degrees of tilt.
4. From the Thickness box, select a thickness for the pie and click OK.
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Changing bar charts from vertical to horizontal layout
You can change the orientation of bar charts.

Procedure
1. From the Format menu, click Display Options.
2. Click the Display tab.
3. Select the Horizontal Orientation check box.

You can also change the angle and thickness of the shadow.
4. Click OK.

Rotate a Display
You can rotate pie and 3-D displays. This option is useful for emphasizing specific
data or to improve the appearance of a display that includes many categories.

You can set the default rotation for new pie and 3-D bar displays using the
Display options in Preferences.

Rotating pie displays
You can rotate pie displays.

Procedure
1. From the Format menu, click Display Options.
2. Select the Clockwise check box.
3. In the Angle box, type a number for the start of the first pie slice, and click

OK.

Rotating 3-D bar displays
You can rotate 3-D bar displays.

Procedure
1. From the Format menu, click Display Options.
2. Click the Display tab.
3. Click the 3-D View Tool.
4. Click the arrows in the 3-D View Tool box until the display appears at the

desired angle, and click Close.
5. Click OK.

Change Markers in a Display
You can change the size and shape of the markers used in some types of graphical
displays.

Markers are optional in line, multiline, and correlation displays.

Procedure
1. From the Format menu, click Display Options.
2. On the Display tab, under the Marker box, select the Show check box.
3. Select a shape to use as the marker.
4. To set the size of the marker, type a number in the Size box.
5. Click OK.
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Change the Appearance of Pie Displays
You can change several display settings for pie displays.

For example, you can label pie slices with either values or category names. If you
label pie slices with values, the legend contains only category names. If you label
the pie slices with category names, the legend contains both category names and
values.

Tip: To highlight a category in a pie display, click a pie slice.

Procedure
1. From the Format menu, click Display Options.
2. Modify the displays options.
3. Click OK.

Highlight a Line in a Multiline Display
You can make one or more lines stand out in a multiline display by applying a
bold format. For example, in a report showing revenue for product lines over the
past three years, the Years line is represented with a bold line.

Procedure
1. Select the line that you want to apply a bold format.
2. From the Explore menu, click Change Display and click the crosstab display.
3. From the Format menu, click Categories, and click Labels and Values.
4. On the Font tab, click Bold and click OK.
5. From the Explore menu, click Change Display and click the multiline display.

Hide Report Gridlines
You can hide or show some or all of the gridlines in a crosstab report.

Procedure
1. If you have more than one crosstab in your report, click the crosstab you want

to change.
2. From the Format menu, click Display Options and click the General tab.
3. Select the Gridline Options you want to use.

The report must include nested categories to use Show Row Detail Gridlines
and Show Column Detail Gridlines.

4. Click OK.

Scale an Axis
You can scale the axis for a display by setting the highest and lowest values to
appear in the axis. If you are using a correlation or scatter display, you can scale a
secondary axis.

By default, the scale shows the full range of values in the selected data, positive
and negative. You can change the default axis scaling properties for all reports in
Preferences. If you change your axis settings, you may not be able to see some of
your data or statistical lines.
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Procedure
1. Select a display.
2. From the Format menu, click Display Options.
3. Click the Primary Axis tab.

This tab is not available for crosstab and pie displays.
4. Select the Manual check box.

To return to automatic axis scaling at a later time, clear the Manual check box.
5. Set the primary axis properties you want to use.
6. Do one of the following:
v If you are using a correlation or scatter display and you want to scale the

secondary axis, click Apply and continue with the next step.
v Click OK to complete axis scaling.

7. On the Secondary Axis tab, select the Manual check box.
Tip: To scale the secondary axis using the same settings as the primary axis,
select the Use Primary Axis Settings check box.
To return to automatic axis scaling at a later time, clear the Manual check box.

8. Set the secondary axis properties you want to use.
9. Click OK.

Make Bars Transparent in a 3-D Bar Display
You can make bars transparent in 3-D bar displays. Transparency is useful when
you want to see the background lines in the display.

Procedure
1. Select the bars that you want to make transparent.
2. From the right-click menu, click Transparency, Make Bars Transparent.

Results

To remove transparency at a later time, use the Transparency, Make Bars Opaque
or Remove all Transparency options.
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Chapter 10. Formatting Reports

Formatting reports improves the overall appearance of a report and makes it easier
to understand the data. Some of the ways you can format a report include
v changing the layout
v adding titles, headers, and footers
v applying colors, patterns, and backgrounds
v formatting labels and values

Choose a Layout for a Crosstab Report
You can choose different layout styles for nested crosstab reports.
v In standard layout, nested levels appear beside one another for rows and below

one another for columns.
v In indented layout, nested rows are distinguished by indentation. The report

does not include a summary level for the nested categories.
v In indented 2 layout, nested rows are distinguished by indentation. Summary

labels are in bold type and the lowest level is underlined. The Indented 2 Layout
is available for only Explorer reports.

Procedure

From the Format menu, click Crosstab Layout and click a layout.

Show Short or Long Names for Dimensions and Categories
If the cube modeler defined both short and long dimension or category names in
the cube, you can choose the format you want to show in the dimension line and
dimension viewer of your report. You can set short or long names for each
individual dimension.

For example, a dimension has the long name "2008 Products" and the short name
"08 Prods". You choose to show the short dimension name in your report.

To show short names when you open the report in IBM Cognos PowerPlay Studio,
you must set all dimensions to show short names before publishing the report.

Procedure

Right-click the dimension or category in the dimension line and clear or select
Long Names.

Create and Apply a Style to Data
You can create and apply styles to emphasize key information and for use in a
custom exception definition.

For example, you want to create different styles to apply to higher sales values and
lower sales values. You can create a style for the higher values that shows them in
green, and another style for the lower values that shows them in red.
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Creating and editing styles
You must create a custom style before you apply it to data in the report.

Procedure
1. From the Format menu, click Styles.
2. Choose whether to create a new style or edit an existing style:
v To create a style, type a name for the new style and click Add.
v To edit an existing style, select the style name and click Modify.

3. Select the style settings.
4. If you want to make the style available for others to use, select Shared.

The Shared check box is not available for the default styles, Hidden and
Default.

5. Click OK.

Results

The new style is available for use in the current and other reports. You can share
styles that you create with other IBM Cognos PowerPlay users.
Related concepts:
“Shared Custom Exception Definitions” on page 48
To ensure that all IBM Cognos PowerPlay users highlight exceptions in the same
way, you can distribute a custom exception definition to other users.

Applying styles
After you create a custom style you can apply it to data in the report.

Procedure
1. Select the information to format.
2. From the Format menu, click Styles.
3. In the Style Name box, select the style and click OK.

Removing styles
You can remove a custom style by applying the default style.

Procedure
1. Select the information that has a style applied.
2. From the Format menu, click Styles.
3. In the Style Name box, select Default style and click OK.

Apply a Background Pattern and Color to an Entire Report
To enhance the appearance of a report, you can apply patterns and colors to the
report background.

You can apply a different background to each display in a multi-display report.

Procedure
1. If the report includes more than one display, use Ctrl+click and select each

display.
2. From the Format menu, click Display Background.
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3. Select the foreground and background colors, and pattern.
To set the background pattern and color as a default for the active report, click
Set As Default.

4. Click OK.

Add a Title, Header, or Footer
You can make reports more meaningful by adding descriptive titles, headers, and
footers.

Within these elements, you can include text, picture objects, and variables. Add
v titles that describe the contents of the report.
v headers and footers that contain important information such as the cube name,

the report name, the names of dimensions, and page numbers. The cube name is
the name specified in IBM Cognos Transformer, which may be different from the
cube file name.

You can also make standardized reports by adding default titles, headers, and
footers that apply to all new reports.

For example, you create a standard header that appears above the report title. The
header contains the report creation date and the total number of pages in the
report, and you create a standard footer that includes the report file name and the
cube file name.

You also add the name of the report, your company logo, and the current row
label to the report title. The text in the title that shows the current row label
changes depending on what is selected in the report.

Procedure
1. From the Format menu, click Title, Header, and Footer, and click Title, Header,

or Footer.
2. Type and format the text.
3. To insert a variable, click the Insert button, and do one of the following:
v To insert the report file name, date or time, click Report.
v To insert the cube name, date, time or description, click MDC.
v To insert a variable such as the current default measure, row, column, date or

time, click Variable. When you insert a date or time variable, the Date and
Time dialog box appears. Use it to select a format for dates and times in the
title.
Most variables are dynamic and change depending on the state of the current
report.

v To insert page numbers, the current and total number of displays for the
current layer, or the current and total number of layers for the current report,
click Numbers.

v To insert an individual dimension name or the names on the dimension line,
click Dimension.

v To insert a picture, click Picture Object. Click the image you want to insert,
click Open, and then move or resize the picture as required.

4. Click OK.
5. If you cannot see the header or the footer, switch the page view or display

arrangement.
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v From the View menu, click Page Layout or Page Width.
v From the Format menu, click Tile Displays, Best Fit.

Formatting Labels and Values
Formatting labels and values makes your report easier to read. For example, you
can rename labels if they are too long. You can also format labels to include
currency or other symbols that clarify data.

Rename Labels
You can change the names of labels for rows, columns, or layers in reports. For
example, you create a calculated category by adding three categories. You change
the default label of the calculated category to a name that describe what the
category represents.

Procedure
1. Select the row, column, or layer.
2. From the Edit menu, click Rename Label.

Tip: F2 is the keyboard shortcut to rename a label.
3. Type the new name and click OK.

Tip: To restore the default label, click Reset.

Format Labels and Values in Crosstabs
You can format labels and values in a crosstab display to make them easier to
understand.

You can determine the font, alignment, and background pattern for labels and
values. You can also choose from several preset value formats, including currency
signs, commas, and percentage signs. You can apply formats to labels only, values
only, or both labels and values. You can also choose default settings for your
report.

If you want to place parentheses around negative values, in the Windows Control
Panel, set the format for negative values in Regional Settings.

You can set the default font, format, alignment, and patterns for all reports in
Preferences.

Several rules determine the number format that is applied in a crosstab cell. You
cannot format an individual cell in the crosstab. However, you can format an entire
column or an entire row, or both an entire column and an entire row. You can
select all rows and all columns or just a subset of them.

Generally, the last format applied overrides the previous format. However, this is
not always the case. If you format a column and a cell in the column contains a
row format where the number of decimals is greater than the number of decimals
in the new column format, the new number format is not be applied. The same
rule applies if you format a row where there was a previous column format. The
exception to this rule is if you are apply a percent format. Percent formats
generally always take precedence.
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Procedure
1. Select the rows and columns that you want to format.
2. From the Format menu, click Categories, and then choose the format option:
v To format the labels in your selection, click Labels Only.
v To format the values in your selection, click Values Only.
v To format your entire selection, click Labels and Values.
v To select default settings for your report, click Default.
This does not apply to previously formatted categories.

3. Specify the Font, Format, Alignment, and Patterns settings.
There is no Format tab when you click Labels Only.

4. If you want to enable word wrapping for row labels that exceed the cell width,
from the Format menu, click Display Options. In the Word wrap box, select
Standard layout or Indented layout and click OK. Increase the height of the
row label cell(s) to accommodate the additional lines of the label.
You can apply word wrap independently to either Standard or Indented
crosstab layout.
Column labels always word wrap.

5. Click OK.

Results

If you increase the size of a font in a crosstab display, or change to a font that is
larger than the one you are using, IBM Cognos PowerPlay automatically adjusts
the cell width and height to accommodate the new font size. However, if you
apply an exception definition that increases the font size or uses a larger font,
PowerPlay does not automatically adjust to the new size.

If you add underlining, you may need to increase the size of the row or column
for the underlining to be visible.

Format Labels in Graphical Displays
You format labels to determine whether word wrapping is applied or text is
truncated. You can also specify whether to autofit labels along one or both axes.

You can set the default display options for new reports using the Display
preferences.

You cannot format labels using the following procedure for a pie display.

Procedure
1. Select a display.
2. From the Format menu, click Display Options and click the Titles tab.

Depending on the display type, you can change labels for row axes, column
axes, and one or two measure axes.

3. Do one of the following:
v To set the layout of labels, select the appropriate option button in the Bar

Labels box.
The name of the box changes depending on the type of display.

v To size labels to fit automatically within the bar or measure axis, select the
appropriate Autofit Labels check box.
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To give the labels a group name, type a name in the appropriate box.
To change the font, style, size, effects, and color, click Font.

4. Click OK.
Related tasks:
“Setting Preferences” on page 85
There are many options you can set to customize the settings for all new reports.
For example, you can specify the default directories to use for reports and cubes.

Change Summary Labels
You can change the text and font of the labels for the summary rows or columns in
a nested crosstab report.

For example, you prepared IBM Cognos PowerPlay reports that contain
year-to-date earnings for each of your company's mutual funds. You want to add
the fund name to the summary label.

Procedure
1. Open your Explorer report, and click the crosstab you want to change.
2. From the Format menu, click Display Options, and click the Totals tab.
3. To rename a label, select Use row summary label or Use column summary

label and type the new label.
4. Select other label settings.
5. Click OK.

Show Data as Relative Values
By default, measures appear as the actual values from the data source. To make it
easier to compare the relative contribution of values in Explorer reports, you can
show values as a percentage of totals. For example, you are working with a report
that shows products as columns and regions as rows. To show the sales
contribution of each product by region, you change the display to show values as a
percentage of the row total.

The options for values changes depending on the type of display you are using.
The names % of Row Total, % of Row Subtotal, % of Column Total, and % of
Column Subtotal change depending on the display. For example, in a pie display,
the % of Column Subtotal command is named % of Slice Subtotal.

Procedure
1. In an Explorer report, from the Explore menu, click Show Values As.
2. Do one of the following:
v To show the actual numbers, click Value.
v To show how each value in a row contributed to the total for the row, click

% of Row Total.
v To show how each value in a row contributed to the subtotal for the row,

click % of Row Subtotal.
The report must include nested columns to show values as a percent of row
subtotal.

v To show how each value in a column contributed to the total for the column,
click % of Column Total.

v To show how each value in a column contributed to the subtotal for the
column, click % of Column Subtotal.
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The report must include nested rows to show values as a percent of column
subtotal.

v To show how each value in a layer contributed to the total for the layer, click
% of Layer Total.

v To show how each value in the report contributed to the total for the whole
report, click % of Grand Total.
The report must include layers to show values as a percent of grand total.

Results

Tip: To show data as a percentage of the total in a Reporter report, from the
Calculate menu, click Percent of Base.

Show Blank Cells For Zero and Missing Values
You can format the measures in your report to show blank cells for the following
values in crosstab displays:
v zero values
v divisions by zero
v missing values

For example, you prepared a IBM Cognos PowerPlay report that outlines the
five-year return for all your mutual funds. Because some funds are only three
years old, there is no data for the first two years. This missing data appears as
zeros, which incorrectly implies a zero return for these funds. You change these
values to blanks.

Zero and missing values appear as blanks in only crosstab displays. In all other
displays, zero values appear as n/a unless specified otherwise by your
administrator.

Procedure
1. In the dimension viewer, click the measures you want to format.

2. From the toolbox, click the Format Measures button .
3. On the Blank tab, select the Show As Blank behavior you want to use in the

report.
4. Click OK.
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Chapter 11. Distributing Reports

After you create a report, you can distribute it to others. You can
v save the report in PDF format
v publish the report to IBM Cognos Analytics portal
v print the report
v attach the report to an email message
v export a report to a different file format

Save Reports in PDF Format
You can save reports in PDF format. A PDF file is useful for distributing standard
reports to people who do not have IBM Cognos PowerPlay installed on their
computer.

Procedure
1. Open the report.
2. From the File menu, click Save As.
3. In the Save As Type box, select PDF File (*.pdf).
4. Click Options and select Save and Rows and Layers settings.

Rows and layers that are suppressed or hidden cannot be selected for saving
with the PDF.

5. Click OK and click Save.

Publish Reports to IBM Cognos Analytics portal
When you work with a remote package as your data source you can publish IBM
Cognos PowerPlay reports to IBM Cognos Analytics portal. When you publish a
report, you can specify run options, such as enabling prompting to provide report
consumers with filtering options and specifying details for the PDF format output.

Each time you open and change an existing remote report you must republish to
update the report in IBM Cognos Analytics portal. When you republish the report
you have the option to update the existing report or create a new report. To avoid
having out-of-date reports with duplicate report names, to change the location of a
report, use the move option for the report entry in IBM Cognos Analytics portal. If
you use the Publish a new report option in PowerPlay Client to chose a different
location, and use the same report name, you will have reports with the same name
in more than one location.

Before you begin

To work with reports in IBM Cognos Analytics portal, users must have read and
traverse permissions for the folder that contains the report, and execute permission
to run a report.

Publishing new reports
When you use a remote package as a data source, you can publish reports to IBM
Cognos Analytics.
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Procedure
1. Create a report based on a remote package.
2. From the File menu, click Publish.
3. On the Publish Report page, specify the name, description and run options for

the report, and then click Next.
A description or screen tip can provide valuable information for some types of
reports. For example, you create a report based on a package that uses data
source connections to more than one PowerCube. When you publish the report,
specify the PowerCube connection name in the description or screen tip so
report consumers know what connection to select when they open the report.

4. On the Save As page, select the location for the report, and then click OK.

Results

IBM Cognos PowerPlay publishes the report to IBM Cognos Analytics portal.

Work with previously published reports
When you work with existing remote reports, you can update the existing report
or create a new report.

Procedure
1. Open an existing remote report.
2. Update the report, and then from the File menu, click Publish.
v To update the existing report, click OK.
v To create a new report, select Publish a New Report, specify the name,

description and run options for the new report, and then click Next. On the
Save As page, select the location for the report, and then click OK.

Print Reports
You can print an entire report, or parts of a report. For example, if a report
contains large amounts of data, you can choose to print only selected portions of
the report.

Before you begin

Before printing reports that include a legend, position the legend so it does not
cover your data.

Procedure
1. From the File menu, click Print.
2. In the Print dialog box, do the following:
v To show colors in displays as patterns when printing in black and white,

select Colors as patterns.
v To show the report on one page, select Fit to Page.
v To specify the maximum number of pages to print, type a number in the

Threshold box.
3. Click Options.
4. On the Print tab, do the following:
v In the Print box, click the part of the report that you want to print.
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v In the Selected display printing options box, select the report properties that
you want to print.

Depending on the option you selected in the Print box, some report properties
are not available.

5. If you clicked Page Layout View or Selected Display(s) in the Print box, click
the Rows and Layers tab, and specify the rows and layers that you want to
print.
Rows and layers that are suppressed or hidden do not appear in the Rows and
Layers boxes and can't be selected for printing.

6. Click OK.

Attach Reports to Email
You can send a report as an attachment to an email message to users who have
access to the cube on which the report is based.

Procedure

From the File menu, click Send.

Results

The report appears as an attachment in your default email program.

Export a Report to a Different File Format
Another way to integrate IBM Cognos PowerPlay with other application
environments is to export your PowerPlay reports to other formats. You can export
a PowerPlay report in the following formats.
v Delimited ASCII text file
v Microsoft Excel
v PDF

When you export a report in delimited ASCII or Microsoft Excel format, the top of
the text file or the first few rows of the Microsoft Excel worksheet show the date
and time of export, the report file name, the name of the associated cube, and the
report type (Explorer or Reporter). The folder names in the dimension line and the
data appear below this information.

If your PowerPlay report includes layers, a separate Microsoft Excel worksheet is
created for each layer.

When you export a report in delimited ASCII or Microsoft Excel format, you can
export only the level of data you see in the report.

Procedure
1. From the File menu, click Save As.
2. Select a folder and type a name for the file.
3. In the Save As Type box, click the file format, and click OK.
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Delimited ASCII Text Files
Delimited text format is one of the most popular export formats, because you can
use the file as an import source in many applications. IBM Cognos PowerPlay uses
the following format conversions when creating the .asc file.

Table 3. Conversion formats for ASCII files

Format Conversion Details

Numeric data The decimal symbol for the locale is used, even if the format or pattern of
the number contains an explicit decimal that differs from the locale.

The digit grouping symbol (the symbol used to group large numbers such
as thousands in the US locale) is not used in the CSV export.

The negative sign symbol but not the format of the locale is used. This
may also be different than the explicit format used for that number. The
negative symbol is always leading.

For example, for a German locale of DE_DE, a number that was formatted
as "(765 000.45)" is exported to CSV format as "-765000,45".

Currency data Currency values follow the same rules as numbers. The currency symbol is
not exported.

For example, if the locale is EN_US, and the format of the number in a
PowerPlay report is "$123,456.00", then PowerPlay exports "123456.00".

Character data In some products, you can optionally allow quotes to be put around the
text. This technique ensures that a text field containing the list separator
(such as a comma) is not interpreted as multiple fields in the exported file.

Date and time
data

Dates are exported in ISO format, YYYY-MM-DD

Time is exported as ISO format, hh:mm:ss.The hour value (hh) uses the
24-hour clock.

In PowerPlay, the date is defined in the Transformer model and is
exported as text.
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Chapter 12. Customizing PowerPlay

You can customize IBM Cognos PowerPlay so that it suits your everyday reporting
needs. For example, you can set preferences to specify whether to create new
reports as Reporter or Explorer reports by default.

You can also customize menus, toolbars, and toolbar buttons to organize them in a
way that helps you work effectively. For example, you can create a custom toolbar
that includes the buttons you use most frequently. You can distribute custom
menus and toolbars to other users. For example, you can load menus that contain
only the commands that your department uses.

Setting Preferences
There are many options you can set to customize the settings for all new reports.
For example, you can specify the default directories to use for reports and cubes.

Procedure

From the File menu, click Preferences.

Customize Menus
You can create your own menus and add the commands you need. You can restore
all menus to the original settings at any time.

You can distribute customized menus and toolbars to other IBM Cognos
PowerPlay users.

Procedure
1. From the Tools menu, click Customize.
2. Click the Menus tab.

A list of menu commands appears in the Available Commands box. The Menu
Layout box shows the current menu structure.

3. You can do any of the following.

Table 4. Menu customization options

Goal Action

Add menus, submenus, menu separators, or
menu commands

Drag what you want to add from the
Available Commands box to the Menu
Layout box.

Show only those menu commands found on
a specific menu

In the Category box, click the name of the
menu. For example, click File to show only
those commands found on the File menu.

Rearrange menu commands In the Menu Layout box, drag menu
commands from one menu to another.
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Table 4. Menu customization options (continued)

Goal Action

Delete a menu or menu command In the Menu Layout box, click the menu or
command and click Remove.

Change the name of a menu command In the Menu Layout box, click the menu
command. Under Item Properties, in the
Name box, type a new name.

Change the shortcut key combination of a
menu command

In the Menu Layout box, click the menu
command. Under Item Properties, in the
Shortcut box, enter a new combination of
keys. If a combination of keys is currently
assigned to another menu command, a
message appears in the message pane that
the shortcut is in use.

Create a menu accelerator key In the Menu Layout box, click the menu
command. Under Item Properties, in the
Name box, type an ampersand (&) and the
name of the menu command. For example,
&New makes N the accelerator key.

4. Click OK.

Results

To reset the menus to the default settings on the Menus tab, click Reset.
Related tasks:
“Distribute Custom Menus and Toolbars” on page 89
You can distribute custom menus and toolbars to other users.

Set Up a Launch Menu Command
You can add a launch command to any menu to run an application. For example,
if you frequently copy and paste reports into a different application for
presentations, you can create a launch item that automatically copies the report to
the clipboard and launches the presentation application. After the application
opens you can paste the report into the presentation.

Procedure
1. From the Tools menu, click Customize.
2. Click the Menus tab.

To edit an existing launch menu command, click the command in the Menu
Layout box.

3. Click New.
The New Launch Item dialog box appears.

4. Select the options for the launch item.
5. Click OK.
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Customize Toolbars and Buttons
You can show, hide, create, delete, and modify toolbars. For example, you can
create a toolbar that contains only the buttons you use.

You can distribute customized menus and toolbars to other IBM Cognos
PowerPlay users.
Related tasks:
“Distribute Custom Menus and Toolbars” on page 89
You can distribute custom menus and toolbars to other users.

Show or Hide Toolbars
You can show or hide toolbars so that you see only what you need.

Procedure
1. From the Tools menu, click Customize.
2. Click the Toolbars tab.
3. Select the check box beside each toolbar that you want to appear.

Tip: To remove a toolbar from the Available Toolbars box, click the toolbar
name and click Remove.

4. If you want to show tooltips for each toolbar, select Show Tooltips.
5. Click OK.

Results

To reset the toolbars on the Toolbars tab, click Reset.

Create a Custom Toolbar
You can create a custom toolbar that contains only the tools you need.

Procedure
1. From the Tools menu, click Customize.
2. On the Toolbars tab, click New.
3. In the Toolbar Name box, type a name for the toolbar.
4. In the Initial Location box, click a default location for the toolbar and click OK.

Results

The name of the new toolbar appears in the Available Toolbars box. You can now
add buttons to the new toolbar.

Customize Toolbar Buttons
You can change the buttons on a default toolbar or add buttons to a custom
toolbar. You can also remove buttons from any toolbar.

For example, you are in charge of imports for a governmental department. You
regularly distribute reports to offices in Great Britain, which requires that you
convert your reports so that they use British pounds. You want to customize your
toolbar by creating and adding a Currency button.
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Procedure
1. From the Tools menu, click Customize.
2. Click the Toolbar Buttons tab.
3. Drag the buttons you want to add from the Available Buttons box to a toolbar.

Tips

v To learn what a button does, select its name in the Available Buttons box,
then look under Button Description.

v To change the selection of buttons, use the Category box. For example, click
File to show only those buttons found on the File toolbar.

v To add a space between buttons, add a separator button. This button is listed
under the Miscellaneous category.

4. Drag the buttons you want to remove off an existing toolbar.
5. Click OK.

Tip: To return to the original settings, click Reset on the Toolbars tab.

Set Up a Launch Button
You can add up to 64 launch buttons to a custom toolbar. You can configure each
button to run a different program.

For example, you are the manager of a government department. You keep the data
source files for your reports in Microsoft Excel spreadsheets. While reviewing your
reports, you want to look at your data source files. You customize your toolbar to
run Microsoft Excel directly from IBM Cognos PowerPlay Client.

Procedure
1. From the Tools menu, click Customize.
2. On the Toolbar Buttons tab, in the Category box, click Miscellaneous.
3. Click Toolbar Launch Button, and drag it to a toolbar.
4. Click OK to close the Customize dialog box.
5. Click the new launch button.
6. In the New Launch Item dialog box, in the Name box, type a name for the

launch button.
7. In the Description box, type a brief description of what the button does.

The tooltip appears when you pause the pointer over the button.
8. In the Command box, browse to the location of the program.
9. In the Parameters box, type any parameters you want to add to the program.

10. If you want to minimize the current window when you run the program,
select the Minimize Application Before Launching check box.

11. In the Image box, click the image you want to appear on the new launch
button.

12. In the Path box, browse to the location of the button image.
13. Click OK.

Results

The launch button is now configured. If you want to change the settings of a
launch button, ensure the Customize dialog box is closed, and Ctrl+click the
launch button and then make changes in the Modify Launch Item dialog box.
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Distribute Custom Menus and Toolbars
You can distribute custom menus and toolbars to other users.

For example, you are the director of a government department that oversees
transportation policy. You worked closely with your systems analyst to build
customized menus and toolbars that suit your departmental needs. You want to
distribute these menus and toolbars to others in your department.

Custom toolbar settings are stored in the tbinfo.ini file, and custom menu settings
are stored in the menuinfo.mnu file in the following location:

C:\Documents and Settings\user_ID\Application Data\IBM Cognos\c10dotn\
PwrPlay

Procedure
1. Place a copy of the files that contain the settings for the custom toolbars and

menus in a location that users can access.
2. From the Tools menu, click Customize.
3. Click Load.
4. Browse to the location of the tbinfo.ini file or the menuinfo.mnu file to be

imported.
5. Click OK.

Results

The custom menus or toolbars appear.

Customize the Dimension Viewer Toolbox
You can customize the buttons that appear in the dimension viewer toolbox.

For example, you can show the three buttons that you use most often. You can also
choose to position the toolbox on the left, right, top, or bottom of the pane.

The following toolbox buttons are available for only Explorer reports:

Table 5. Toolbox buttons for Explorer reports

Click To

Replace the rows with the selected categories.

Replace the columns with the selected categories.

Replace the layers with the selected categories.

The following toolbox buttons are available for only Reporter reports:
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Table 6. Toolbox buttons for Reporter reports

Click To

Add the selected categories as rows.

Add the selected categories as columns.

Add the selected categories as layers.

Show the average of the selected categories in a new category.

Show the values of the selected categories as a percentage of their
higher-level category.

Show the sum of the selected categories in a new category.

Add categories at the next level down from the selected category.

Add all categories at the lowest level from the selected category.

Show the selected categories as new individual categories in the
report.

Show the intersection between two categories.

Preserve parent/child relationship when nesting levels from a
dimension.

Open the Advanced Subset dialog box where you can create an
advanced subset definition.

Open the Parentage dialog box where you can create a level
subset definition.

The following toolbox buttons are available for both Explorer and Reporter reports:

Table 7. Toolbox buttons for Reporter and Explorer reports

Click To

Filter data using the selected category.

Switch between short and long versions of
the category names.
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Table 7. Toolbox buttons for Reporter and Explorer reports (continued)

Click To

Open the Number Format dialog box, where
you can format the measures in your report.

Open the Find In Cube dialog box where
you can create a find-in-cube subset
definition.

Procedure
1. Right-click the toolbox and click Customize.
2. Do one the following:
v To add a new button, click it in the Available Toolbar Buttons box, and click

Add.
v To remove a button, click it in the Current Toolbar Buttons box, and click

Remove.
v To reset the toolbox to the default settings, click Reset.

3. If you want to change the order of the buttons, click an enabled button, and
click the Move Up or Move Down button until the button is positioned where
you want.

4. If you want to add a space before a button in the toolbox, click an enabled
button, and then add a Separator button.

5. Click OK.
6. To chance the location of the toolbox, right-click the toolbox and click Location.
7. Click one of the four docking positions.
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Chapter 13. Working Offline

You can continue to work with IBM Cognos PowerPlay even when you are not
connected to the original cube or the network on which the cube is stored.

You can prepare a report containing a subset of the cube data and save the data for
this report as a sub-cube (.mdc). When you save only the information used to
create the report, you are limited to using the dimensions that were saved.

When you are finished working offline, you can automatically update the sub-cube
with data from the original cube.

Turn Off Sub-Cube Refresh
Sub-cubes that you create automatically refresh by default. To work offline, you
must turn off the automatic refresh option. This setting applies to all sub-cubes.

Procedure
1. From the File menu, click Preferences.
2. Click the Options tab.
3. Clear the Refresh Sub-Cubes check box.
4. Click OK.

Save a Sub-Cube
You can work offline with a IBM Cognos PowerPlay report by saving it as a
sub-cube.

This option is useful if you can not obtain a copy of the original cube, if the
original cube is very large and includes more data than you need for your offline
work, or is the original cube is secured by a namespace.

Your PowerPlay administrator must enable save as sub-cube before you can create
a sub-cube based on a remote package. Contact your administrator if the save as
.mdc option is not available.

You cannot save a sub-cube filtered on a dimension other than date if the cube you
are using is a time-based partitioned (or member) cube. If you try to do so, you
receive the following message, "The dimension line of the sub-cube is invalid
(subcube)."

Procedure
1. Prepare the report by drilling down or drilling up to the level of information

you need.
2. From the File menu, click Save As.
3. In the Save As Type box, select PowerPlay Cube (*.mdc).

Set a Report to Use a Sub-Cube
Once you save the report and the sub-cube, you must open the report using the
sub-cube, and then save the report.
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This sets the report to always access the sub-cube rather than the original cube.You
only have to set a report to use a sub-cube once.

Procedure
1. From the File menu, click Open.
2. Select the Prompt for Cube check box.
3. Locate and select the report.
4. Click Open.
5. In the Access box, click Local.
6. Locate and select the sub-cube.
7. Click Open.
8. From the File menu, click Save to set the report to use the sub-cube.

Results

When you open the report in another IBM Cognos PowerPlay session, the report
automatically connects to the sub-cube.

If you want the report to access the original cube or another cube, follow the above
procedures and select the original cube or another cube.

Automatically Refresh a Sub-Cube
When you reconnect to the network on which the original cube is stored, you can
set IBM Cognos PowerPlay to automatically refresh the sub-cube the next time you
open the report. When you want to work offline, you can turn off this option.

Procedure
1. Close the report or sub-cube that you want to refresh.
2. From the File menu, click Preferences.
3. Click the Options tab.
4. Select the Refresh sub-cubes check box.
5. Open the sub-cube or a report based on the sub-cube.

If the original cube is a secure cube, you may be prompted for authentication
information depending on the type of security specified for the cube.

Results

The sub-cube is updated with new information from the original cube.

If you see the word error in a category of a report, either this category has been
removed from the cube or you connected to the wrong cube and the categories
don't match.
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Chapter 14. Command-line Options

You can use command-line options to
v start IBM Cognos PowerPlay without showing the title screen
v create a new Explorer report using a specific cube
v create a new Reporter report using a specific cube
v create a new report using a specific cube
v open a specific report

You run commands from the bin folder of your PowerPlay installation. All of the
examples in this chapter assume you have navigated to the bin folder before
entering the command. If you used the default installation, the path to the bin
folder is C:\Program Files\IBM\Cognos\ca_location\bin.

The syntax is
PWRPLAY.EXE

[/nologo]

[/e=name.mdc]

[/r=name.mdc]

[mdc_file_name]

[report_name]

/remote=package_searchpath [/timeout=timeout_value

Command-line syntax is not case-sensitive.

You can combine command-line options. For example, the following command
starts PowerPlay, opens a new Explorer report based on the Inventory cube
(inventry.mdc), opens a new Reporter report based on the Accounts cube
(accts.mdc), opens a report called Year-End, and bypasses the title screen:
PWRPLAY.EXE /e=inventory.mdc /r=accts.mdc year-end.ppx
/nologo

No Title Screen
The /nologo option starts IBM Cognos PowerPlay without showing the title screen
or Welcome dialog box.

For example, the following command starts PowerPlay, but bypasses the title
screen:
PWRPLAY.EXE /nologo

Explorer Report
The /e=name.mdc option opens a new Explorer report.

The following command starts IBM Cognos PowerPlay and opens a new Explorer
report using the Inventory cube (inventry.mdc) in the c:\reports folder:
PWRPLAY.EXE /e=C:\reports\inventory.mdc
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Reporter Report
The /r=name.mdc command opens a new Reporter report.

The following command starts IBM Cognos PowerPlay and opens a new Reporter
report using the Inventory cube (inventry.mdc) in the c:\reports folder:
PWRPLAY.EXE /r=C:\reports\inventory.mdc

Cube Name
The mdc_file_name option opens a new report based on a specified cube.

The following command starts IBM Cognos PowerPlay and opens the Inventory
cube from the c:\reports folder:
PWRPLAY.EXE C:\reports\inventory.mdc

Remote Package Name
The /remote=package [/timeout=timeout_value] command opens a remote
package where
v /remote indicates that you want to open a remote package
v package specifies the package search path or store ID. You can obtain the search

path or store ID from the package properties in IBM Cognos Analytics portal.
v /timeout= specifies a connection timeout in seconds

This entry is optional.

For example, the following command starts IBM Cognos PowerPlay and opens the
Great Outdoors package, using the package search path, with a timeout of 60
seconds:
PWRPLAY.EXE /remote="/content/package[@name=’Great Outdoors’]" /timeout=60

Report Name
The report_name option opens the specified report.

The following command starts IBM Cognos PowerPlay and opens the Year-End
report in the c:\reports folder:
PWRPLAY.EXE C:\reports\year-end.ppx
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Chapter 15. Specifications

This table lists the specifications for IBM Cognos PowerPlay attributes, such as
minimum and maximum values.

Table 8. Specifications for PowerPlay attributes

Attribute Restrictions

Bars in a display (without scrolling) Maximum: 500

Bitmap size Limited only by available memory

Custom color settings (minimum-maximum) Red, green, blue: 0-255

Hue: 0-40

Saturation: 0-80

Luminosity: 0-240

Largest allowed negative number Defined in the cube

Largest allowed positive number Defined in the cube

Margins for the page Determined by the page setup settings in
PowerPlay

Number of categories in a report (rows,
columns, or layers)

The limit for the number of categories is
6,442,450,940. While this is possible,
depending on your computer's memory, you
may find that 100,000 is a more reasonable
limit.

Number of characters for the location and
filename of the picture added to the
background of a display

Maximum: 126

Number of characters in a category label Maximum: 255

Number of colors available Limited by the number of colors supported
by your monitor or printer

Number of digits in an operand (add,
subtract, multiply, divide, percent,
maximum, minimum, average, exponentiate)

Maximum: 11

Number of dimensions in the dimension line Maximum: 255

Number of displays in a report Limited only by available memory

Number of files in the recent file list Maximum: 9
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Table 8. Specifications for PowerPlay attributes (continued)

Attribute Restrictions

Number of fonts per report Limited by available memory and by the
number of fonts supported on your system

Number of open reports Limited only by available memory

Number of nested category levels Limited only by available memory

Number of toolbars Maximum: 20

Number of Undo Actions Maximum: 5000

Smallest allowed negative number Defined in the cube

Smallest allowed positive number Defined in the cube
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Chapter 16. Forecast Formulas

You can make predictions about the future performance of your business based on
past data by using one of these time series forecasting methods: Trend, Growth, or
Autoregression.

All IBM Cognos PowerPlay forecasting methods use univariate techniques, which
means that each category, whether a row, a column, or a summary row or column,
is treated as a separate time series.

Trend Forecast Formula
The formula for Trend forecasting is

y = at + b

where y is the dependent variable (for example, revenue), t is the independent time
variable,

and

The coefficient of determination, a measure of how closely the trend line
corresponds to your historic data, is defined by the following equation:

where

99



and

Growth Forecast Formula
The formula for Growth forecasting is

y = bat

where b is the intercept and a is the constant growth rate.

IBM Cognos PowerPlay uses a logarithmic transformed regression model to solve
this equation.

Autoregression Forecast Formula
The formula for Autoregression forecasting is

where

and

IBM Cognos PowerPlay uses Burg's algorithm and a data window (M) equal to
half the number of data points to solve these equations.
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Chapter 17. PowerPlay Samples

The IBM Cognos PowerPlay samples are included with the IBM Cognos Analytics
supplementary samples.

You download the supplementary samples from the supplementary samples
website (www.ibm.com/communities/analytics/cognos-analytics-blog/
supplementary-ibm-cognos-analytics-11-samples). For information about setting up
the PowerPlay samples, see the IBM Cognos PowerPlay Administration Guide in IBM
Cognos Analytics Knowledge Center (www.ibm.com/support/knowledgecenter/
SSEP7J_11.0.0/com.ibm.swg.ba.cognos.cbi.doc/welcome.html), Version 11.0.x,
section PowerPlay and Transformer.

The following table lists the PowerPlay samples that are available.

Table 9. PowerPlay samples

File name Description

great_outdoors_sales_en.mdc All sample reports are based on the
great_outdoors_sales_en.mdc cube. This cube was
build with IBM Cognos Transformer.

3D-multiline.ppx Explorer report showing multiple displays in a single
report: 3D bar, multiline, and crosstab.

advanced_subset.ppx Reporter report with an advanced subset definition
and find-in-cube subset definition. The advanced
subset definition is used as rows for the report.

charting options.ppx Reporter report showing a simple bar display with
statistical lines.

currency_explorer.ppx Explorer report showing a crosstab display with
nested rows and an alternate currency.

currency_reporter.ppx Reporter report showing a crosstab display with
nested rows and an alternate currency.

external_rollup.ppx Reporter report showing a crosstab display with
nested rows and an external rollup.

forecasting.ppx Explorer report showing a crosstab display with
indented 2 layout and a forecast calculation.

nested_crosstab_1.ppx Reporter report showing a crosstab with indented 1
1ayout. The report includes zero values as blanks,
blank rows and columns, and the use of variables in
the report title.

nested_crosstab_2.ppx Reporter report showing a crosstab display with
standard layout. The report includes categories from
an alternate drill-down path nested with categories
from primary drill-down path, and multiple measure
intersections.

nested_crosstab_3.ppx Explorer report showing a crosstab display with
indented 2 layout and ranking.

nested_crosstab_4.ppx Explorer report showing a crosstab display with
indented 2 layout. The report shows hidden gridlines
and formatting of the labels for the summary rows.
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Table 9. PowerPlay samples (continued)

File name Description

parentage_subset.ppx Reporter reporter showing crosstab display with a
parentage subset definition added as rows. A pattern
is used to highlight the subset.

percentage_sales.ppx Explorer report showing a crosstab display with 80/20
suppression and custom formatting of the label for the
other category.

ranking_1.ppx Reporter report showing a crosstab display with two
ranked columns, one sorted, and the other unsorted.

ranking_2.ppx Reporter report showing a crosstab display with
ranking calculation.

ranking_3.ppx Reporter report showing a crosstab display with
nested rows. The report includes a formatted rank
category.

sales_target_correlation.ppx Explorer report showing a correlation and crosstab
display.

stacked_bar.ppx Explorer report showing stacked bar and crosstab
displays and sorting by value.

top_sales_staff.ppx Reporter report showing a filter, calculation, rank, and
the use of a graphic in the report title.
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Appendix. Troubleshooting

This chapter describes some common problems you may encounter.

IBM CognosScript Editor is Not Included With IBM Cognos PowerPlay
Client

IBM Cognos PowerPlay Client does not include IBM CognosScript Editor.

You can use IBM Cognos Series 7 CognosScript Editor, or another supported tool
such as Microsoft Visual Basic, for macros in PowerPlay Client.

Cognos Application Firewall Error When Publishing a Report
If the Gateway URI setting in IBM Cognos Configuration is not the same format
for both the IBM Cognos PowerPlay Client installation and the PowerPlay Server
installation, you may receive an IBM Cognos Application Firewall (CAF) error
when you attempt to publish a report from PowerPlay Client to the IBM Cognos
Analytics portal.

To prevent this error ensure that same format is used for the Gateway URI setting
in both configurations. For example, use a fully qualified domain name in both
Gateway URI settings. Do not use a machine name in one configuration and a
fully qualified domain name in the other configuration.

Avoiding Blank Extra Lines in Report Titles
If you type a title with a first line that is longer than the width of your Report Title
window, and you insert a carriage return to start the next line, the automatic wrap
feature may insert an extra blank line between your first and second title lines
when you click OK.

To avoid this unwanted activation of the automatic wrap feature, press the Enter
key before the first line of your title reaches the end of the Report Title window.

Hebrew Text Displayed in Chart Elements
In some chart elements, bi-directional Hebrew text may be displayed in a "logical"
order rather than the expected "visual" order.

For more information, go to http://people.w3.org/rishida/scripts/bidi/

Calculation is Not Dynamically Updated After a Cube Update
After a cube update, when you open an existing report that includes a calculation
based on members of a subset, items that were not in the earlier version of the
cube are not included in the calculation. This can occur when the calculation is
created in a report where zero suppression is applied. The calculation will include
only items that are present in the report. After a cube update, the calculation will
not dynamically update to include new items.
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If the intention is to create a true sub-set calculation, which will dynamically
update, before you create a calculation based on members of a subset, ensure that
zero suppression is not activated. Apply zero suppression after you create the
calculation.

Opening an Exported XLS File in Microsoft Excel 2007
In Microsoft Excel 2007, if you open an .xls file that was exported from IBM
Cognos PowerPlay, you may see a warning that the file is of a different format
than specified in the extension. You can ignore this message and open the file
without error.

Only the First Page of a Multiple-page Report Prints
To specify the parts of the report to print, from the File menu, click Print and click
the Options button. On the Print tab, click the Selected Display(s) check box or
the Entire Report check box.

Dimension Viewer Does Not Appear
In some cases, the dimension viewer does not appear although the icon indicates
that it is active. The dimension viewer may have been resized to have a width of
zero. Place the pointer at the extreme left border of the application. When it
changes to a two-way pointer, click and drag to the right. The dimension viewer
appears beside it.

Report Looks Different After the Cube is Updated
In most cases, you can use existing reports with an updated cube. You may have
problems if
v the administrator removed a category from the cube. You can open the report,

but the category shows the word error instead of showing values. Remove the
category from your report.

v the administrator removed a dimension. You may want to recreate the report.

Advanced Subset Value Restriction is Not Available
After you create value filters and save your report, the value filters might become
invalid when the report is opened again. This results in a changed report. IBM
Cognos PowerPlay processes these value filter situations:
v Invalid Dimension

If a dimension becomes invalid because it was deleted, renamed, or became
invisible due to security restrictions, any value filters based on the dimension
are removed from the report.

v Invalid Dimension Setting
If an invalid dimension forms part of a value filter, the invalid dimension is
removed from the value filter. The filter functions based on the remaining
dimension settings. You may not notice that one or more dimensions are missing
from the dimension settings when you edit them.

v New Dimension Added
If a new dimension is added to the cube, a value filter based on the previous
cube becomes invalid. The filter has "Not Valid" appended to its name. When
you edit the filter, "<New Dimension> - Not Valid" appears in the Based on the
Dimension Setting box in the Restrict by Value dialog box. The order of the
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new dimension in the settings is the same as on the dimension line. Select the
new dimension and click Edit to choose a category available in the new
dimension. You must choose a category for each invalid dimension before you
can click OK to accept your changes.

v Invalid Category
If one or more categories in a dimension are deleted, but their corresponding
dimension remains valid, the value filter becomes invalid. The filter has "Not
Valid" appended to its name. When you edit this filter, the invalid categories
appear in the Based on the Dimension Setting box in the Restrict by Value
dialog box with "Not Valid" appended to their category names. Select the
category and click Edit to choose a valid category. You must choose a category
to replace each invalid category before you can click OK to accept your changes.

v Invalid Measure
If the measure that the value filter is based on is deleted or renamed, the value
filter becomes invalid. The filter has "Not Valid" appended to its name. When
you edit this filter, "Not Valid" is appended to the measure name in the Restrict
by Value dialog box. You can then choose a valid measure, and the invalid
measure is deleted. You must choose a measure to replace the invalid measure
before you can click OK to accept your changes.

v Invalid Value Filter
If an invalid value filter is attached to an advanced subset, that filter does not
run. Click OK to remove the invalid value filter from the subset.

Categories Do Not Appear After Changing to Explorer Mode
In a Reporter report, if you created a custom exception definition based on a
particular category that doesn't apply in an Explorer report, then that category
doesn't appear in an Explorer report custom exception definition.

For example, if you base a custom exception definition on All Years, and then
switch to an Explorer report, the All Years parent category doesn't exist in the
custom exception definition.

Summary Values Appear to be Incorrect
If measures are allocated either proportionally (based on other measures) or as
constant values, then the values shown in IBM Cognos PowerPlay do not
necessarily add up to the values shown in the summary rows, columns, or layers.

Contact your IBM Cognos Transformer modeler for more information.

Calculated Values Appear in a Different Format
Calculated values may appear as number signs (###), na, or in scientific notation
(for example, 1.7976931348623158e+308).

If the values appear as number signs (###), it is because the width of the cell is too
narrow. To see the values, increase the width of the cell.

If the values appear as na, it is because your calculation contains a category with a
null value. For forecast calculations, IBM Cognos PowerPlay does not have
appropriate values on which to base a forecast.

Appendix. Troubleshooting 105



If the values appear in scientific notation, it is because the result is larger than 15
digits.

Calculated Values Appear as /0
If you divide by 0, the values appear as backslash zero (/0). This format is the
expected behavior.

Labels for Calculated Categories Do Not Display Correctly
Resize the category label or decrease the font size.

Allocated Measures
If a measure doesn't apply to all dimensions, or to all levels and categories within
a dimension, the administrator can allocate the values of the measure to the
appropriate categories.

When the measure is allocated as a constant, the same value (or zeros) appears in
all levels and totals.

When the measure is allocated based on another measure, values appear in
proportion to the values of the other measure. For example, you can base a
regional sales forecast measure on a measure such as last year's actual sales.

For example, a report shows Revenue, Number of Employees, and Revenue per
Employee for each Quarter. The number of employees is a constant that doesn't
add up, because there are only 10 employees. The measure Number of Employees
is allocated as a constant (in this case, the number 10) in the Years dimension.

Table 10. Report showing allocated measures

Period Revenue
Number of
employees

Revenue per
employee

Q1 200k 10 20k

Q2 300k 10 30k

Q3 250k 10 25k

Q4 450k 10 45k

2007 1200k 10 120k

Unexpected Zeros Appear in the Report
You filtered out categories that appear in the report. The categories are still there,
but they show zeros. For example, three categories from the Products dimension
(Outdoor Products, Go Sports, and Environmental Line) are in the columns. Using
the dimension menus, you filter the Product dimension to Go Sports. The other
two columns remain in the report, but they show zeros.
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You filtered in a Reporter report that still shows other categories in the filtered
dimension. You can delete the categories that show zeros, or you can suppress
them. From the Explore menu, choose a Suppress option.

Values Appear as "error"
This can be for several reasons:
v You may not be connected to the right cube. See the administrator if the problem

continues.
v A category or a dimension may have been removed from the cube.
v Calculations are combined in an illogical manner.

Values Appear as Number Signs (###)
The cells are too small to show the numbers.

Select the categories and resize them, or change the number format.

Values Appear as Question Marks (???)
If IBM Cognos PowerPlay is not retrieving data automatically, then, when you drill
down, rank, or do anything that requires new data, you see question marks instead
of values.

From the Explore menu, ensure that Get Data, Automatically is selected, or select
Get Data, Now.

No Values for a Measure in Some Dimensions
Values may be missing in IBM Cognos PowerPlay because
v The source data lacks values for the measure. IBM Cognos Transformer writes

the value 0 to the cube.
v The measure applies only to a portion of a dimension. Transformer does not

allocate the measure to lower levels.

Ask the administrator to try these remedies:
v Clean the source data so that records with missing values are excluded from the

query.
v Omit the measure from the cube if it is not necessary.
v Allocate the measure values to lower levels either proportionally, based on other

measure values, or as a constant value. If you allocate as a constant, note that
the same value appears in all cells of a crosstab for the categories to which you
allocated the constant value.

Time Period Differences
You can set up a special category for a year to have 13 months.

The IBM Cognos Transformer modeler can create a model that uses your
company's fiscal year, a lunar year, industry-specific periods such as 13-week
manufacturing periods, and relative time periods such as year-to-date.
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Unable to Drill Through to a Cube or Report
IBM Cognos Transformer modelers can associate drill-through targets only with the
lower levels of a dimension, avoiding the need to deal with large, unwieldy
reports. This ensures that end users drill through only to reports that are in scope.
Frequently, because of data volume, you do not want to drill from the top levels of
a dimension.

If you require access to data in the top levels of a cube, contact your Transformer
modeler.

Saved Report Looks Different
If you saved a report with Shared Dimensions switched on, then any subsequent
report that you create using the same cube applies its filters to the saved report.

From the File menu, clear Shared Dimensions before saving a report.

To change the default settings so that all new reports do not share the dimension
line, from the File menu, click Preferences. On the Dimensions tab, clear the
Share the Dimension Line check box.

Unable to Move a Column or Row
You can't move a column or row in an Explorer report. If you try, the rows and
columns are swapped.

You can switch to a Reporter report or duplicate your report as a Reporter report.

Unable to Open the Page Setup or Print Dialog Box
IBM Cognos PowerPlay can't locate a default printer. Use Print Manager to install
and select a default printer.

Report Does Not Fit on One Printed Page
Try one or more of the following adjustments:
v From the File menu, click Print. Select the Fit to Page check box. This check box

is available only if the Print Selected Display(s) or Entire Report on the Print
Options dialog box is selected, and the Print to File check box is cleared.

v Swap rows and columns.
v Make the page margins smaller.
v Change the page orientation.
v If your report is a nested crosstab, use the an indented crosstab layout.

Unable to Print White on Black
If you use a printer with the HPPCL Level 4 driver and you use TrueType fonts,
choose Dark Blue for the background and foreground colors instead of Black. You
must choose the Print TrueType As Graphics printer option for the white text to
appear on black background.
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Text Prints on Top of Graphics
Try formatting the report with a font other than Times New Roman, Courier New,
or Arial, or try turning off the Download True Type as Bitmap Soft Fonts printer
option.

Restore the Default Toolbars and Menus
If you created custom toolbars and menus using the Customize command from the
Tools menu, you can click Reset on the Toolbars or Menus tab to get the default
toolbars or menus back.

Errors After Moving Reports or Cubes to a New Location
You can move reports and cubes without rebuilding them. Drag or copy the
reports and cubes to the new location. You cannot use the Recent File command.
From the File menu, click either Open or New.

You do not have to move both the reports and the cube that the reports use. You
can move only the reports or only the cube. If you move a report or the cube or
both, IBM Cognos PowerPlay may not be able to find the cube when it opens the
report.

When you are opening a report whose cube you moved, select the Prompt for
MDC File check box in the Open dialog box.

You cannot move the PowerPlay application itself to a new location by dragging or
copying it. If you want PowerPlay in a different location, you must re-install it.

Correct Performance Issues
To improve performance, try one or more of the following techniques:
v Switch off automatic retrieval of data until you are ready to update the

information in your report.
v Switch off automatic retrieval of data while you are drilling down, slicing and

dicing, formatting, and so on. When the report looks the way you want, from
the Explore menu, click Get Data, Now to retrieve data.

v Reduce the number of undo actions that IBM Cognos PowerPlay stores. From
the File menu, click Preferences. On the Options tab reduce the value of the
Maximum number of Undo actions option. More memory is then available.

v Switch off suppression of zeros. From the File menu, click Preferences. On the
Suppress tab, set the suppression options.

v Limit the number of categories in a Reporter report by removing unnecessary
categories.

v Delete hidden categories.
v Divide a large cube into smaller, more manageable cubes. The administrator can

do this for you, or ask the administrator about changing the ReadCacheSize
setting. Increasing the value for ReadCacheSize increases PowerPlay's
performance.

v Summarize the details and sort the remaining categories to your specifications.
The administrator can do this for you. For example, if the cube contains more
levels of detail than you need, and the categories are not sorted logically, you
may not be able to analyze your business quickly. The administrator can change
the model so that you can more quickly find the information you need.
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v Limit the number of rank calculations. Use manual ranks instead of automatic
ranks.

v Tune Windows performance in general. See your Microsoft Windows
documentation for more information.

Unable to Email a Report
Ensure that you are using a supported mail server such as Microsoft Mail or
Microsoft Exchange.

Unable to Open a Remote Report
In IBM Cognos PowerPlay Client, you can not open a remote report if the report
name includes characters that are not supported by the regional and language
options of the computer where PowerPlay Client is installed. After you select a
report that uses unsupported characters and click OK, the report does not open
and you are returned to the Select the report page.

Unable to Save a Report
Microsoft Windows does not allow the following characters in file names.

< > : " / \ | ? *

These characters are permitted for object names in IBM Cognos Analytics portal.
For example, IBM Cognos Analytics portal includes an IBM Cognos PowerPlay
report named sales:Q1.

In PowerPlay Client, you can open a remote report that includes restricted
characters in the report name, such as sales:Q1. However, if you attempt to save a
local copy of the report the Save As dialog box does not appear and you are
unable to save the report.

Unable to Add a Launch Button for a Macro
In IBM Cognos Series 7 PowerPlay, you can create a launch button to run a macro.
IBM Cognos PowerPlay Client does not have the same capability.

If you have IBM Cognos Series 7 installed on the same computer you can
configure a launch button to run a batch file that uses runmac32.exe to execute the
macro. The default installation location for the runmac32.exe file is cer5\bin.

Unable to Refresh a Sub-Cube
The default preferences setting is to automatically refresh the data from the
original cube when you open a sub-cube. There are some situations that will cause
an error when IBM Cognos PowerPlay attempts to refresh the data.
v the original cube was moved or renamed
v dimensions were removed from the original cube since the last data refresh
v PowerPlay Client is unable to connect to the IBM Cognos Analytics gateway or

the PowerPlay service

In some cases PowerPlay will notify you that the data was not refreshed and then
open the sub-cube. If the sub-cube does not open, disabling the Refresh sub-cubes
setting may allow you to continue to work with the sub-cube.
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Notices

This information was developed for products and services offered worldwide.

This material may be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service. This document may
describe products, services, or features that are not included in the Program or
license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS"
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Software Group
Attention: Licensing
3755 Riverside Dr.
Ottawa, ON
K1V 1B7
Canada

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.
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Depending upon the configurations deployed, this Software Offering may use
session and persistent cookies that collect each user's
v name
v user name
v password

for purposes of
v session management
v authentication
v enhanced user usability
v single sign-on configuration
v usage tracking or functional purposes other than session management,

authentication, enhanced user usability and single sign-on configuration

These cookies cannot be disabled.

If the configurations deployed for this Software Offering provide you as customer
the ability to collect personally identifiable information from end users via cookies
and other technologies, you should seek your own legal advice about any laws
applicable to such data collection, including any requirements for notice and
consent.

For more information about the use of various technologies, including cookies, for
these purposes, see IBM's Privacy Policy at https://www.ibm.com/privacy/us/
en/ and the “IBM Software Products and Software-as-a-Service Privacy Statement”
at http://www.ibm.com/software/info/product-privacy.
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Index

Special characters
.ini files 89
.mnu files 85, 89

Numerics
3-D bar displays

making bars transparent 72
rotating 70

80/20
suppression 13, 14

A
accessible reports 15
accumulate

calculating 53
adding

calculated categories 56
categories 5, 27
categories as layers 9
columns 55
footers 75
headers 75
layers 9, 55
nested categories 7
nested columns 7
nested rows 7
ranked categories 41
rows 55
titles 75
types of displays 65
values to graphical displays 66

advanced subset definitions
creating 19, 22

advanced subsets
creating with find-in-cube restrictions 23
creating with parent restrictions 22
creating with value restrictions 24
value restrictions 104

aligning
labels and values 77

alternate
paths 29

analyzing
scenario dimensions 27

applying
automatic exception highlighting 45
background patterns 74
backgrounds 69
custom exception definitions 47
styles 74

arranging
displays 69

ASC files 84
automatic exception highlighting

applying 45
using 45

automatically
retrieving data 107

automatically (continued)
updating reports 18

autoregression forecasting
definition 59

averages
calculating 52

B
backgrounds

applying patterns 74
applying patterns to reports 74
applying to displays 69
patterns 74

bar graphs
changing displays 69

blanks
showing zero values 79

bolding
one line in a multiline display 71

break-down of outer rows
summaries 11

breaking
subsets 26

Burg algorithm
forecasting 100

buttons
customizing 87, 88

C
calculated categories

adding 56
calculation precedence

controlling 57
calculations

accumulate 53
adding as new categories 55
appearing as formulas 105
appearing as na 105
appearing as number signs 105
average 52
controlling precedence 57
creating 51
cumulative percentage 53
divide 52
division 60
financial ratios 60
forecast 58
grouping 57
nested reports 51
on subsets 25
percent growth 52
percentage of totals 52
rollup 54
running totals 53
share of 52
showing categories as percentage of parent categories 55
showing categories individually 55
showing the average of categories 55
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calculations (continued)
showing the sum of categories 55
subtract 52
troubleshooting 105, 106
values appear as /0 106

callouts
adding lines to pie displays 71

categories 13
add intersected categories 8
adding 5, 27, 56
adding as layers 9
adding nested 7
combining 8
copying 10
drilling down 29
filtering 31
hiding 10, 11, 15
names 73
nested 7
ranking 41
removing 15
share of another 52
showing 11
sorting 41
special 107
totalling 55
troubleshooting 15
truncated labels 106
unhiding 10

category labels
troubleshooting 106

category names
labels in nested charts 71

cerlocale.xml 105
changing

angle of displays 69
colors 68
labels 77
markers in displays 70
measures 33
patterns 68
styles 74
subset definitions 24
summary labels 78

charts
adding statistical lines 67
bar 69
displaying Hebrew text 103
displaying mix 64
large amounts of data 66
nested 65
pie 69
swapping columns 11
swapping layers 11
swapping rows 11

clearing
highlighting 46

coefficient of determination 99
colors

applying to report backgrounds 74
changing 68

columns
adding 5
adding as calculations 55
copying 10
drilling down and up 29
floating 12

columns (continued)
formatting labels 77
inserting blanks 12
moving 12, 108
ranking 41
showing multiple measures as 34
showing summaries 11
sorting 41
swapping 11
totals 78

combining
categories 8

comma separated value files 84
command-line options 95

cube 96
Explorer report 95
no title screen 95
report name 96
Reporter report 96

comparing
measures 64
variables 63, 64

compound charts
see nested charts 71

conditional
formatting 46

configuring
data formats 105

controlling
calculation precedence 57

converting
currency 35
reports 104

copying
between reports 10

correlation
displays 72
scaling each measure in displays 72
showing markers in displays 70

creating
advanced subset definitions 22, 23, 24
calculations 51
custom exception definitions 46
find in cube subset definitions 20
forecasts 58
parentage subset definitions 19
report templates 18
reports 1
reports using remote cubes 2
styles 74
subset definitions 19

crosstabs
adding nested categories 7
choosing a layout 73
formatting labels and values 77
ranking 43

CSV files 84
cubes

command-line options 96
creating a find in cube subset definition 20
drilling through 38
finding data in 31
moving 109
refreshing sub-cubes 93, 94
saving a portion of 93
saving sub-cubes 93
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currency
converting 35
formatting 35

custom exception definitions
applying 47
overview 45

custom exception highlighting
using 45

custom exception highlighting,
See custom exception definitions

custom exception styles,
See custom exception definitions

customizing
buttons 87
colors and patterns 68
launch buttons 87, 88
launch menu commands 86
menus 85, 91, 109
PowerPlay 85
the content of reports 12
toolbar buttons 87, 88
toolbars 87, 109
toolbox 91

D
data

exceptions 45
formatting displays 68
graphing large amounts 66
hidden 10
highlighting 45, 46, 48
ranking 41
removing 15
retrieving automatically 107
sorting 41
suppressing 13

data formats 105
configuring 105

defaults
for custom exception definitions 48
restoring 109
setting footers 75
setting headers 75
setting titles 75

definitions
changing a subset 24

deleting
categories 15
displays 65
layers 9
subsets 26

delimited ASCII text files 84
deployment options

setting in reports 12
descriptions

finding in subsets 20
details

drilling up and down 27
differences

between categories 52
dimension viewer

closing 5
customizing the toolbox 91
opening 5
troubleshooting 104

dimensions
definition 27
folders 27
measures with no values 107
names 73
scenario 27
sharing 108
slicing and dicing 27
swapping 27
updating reports 104

displaying
summary categories 66

displays
adding statistical lines 67
applying backgrounds 69
arranging 69
changing 63
changing colors 68
changing colors and patterns 68
changing the angle 69
clustered bar graphs 64
correlation 72
finding trends 64
organizing 69
pie graphs 64
removing 65
resizing 65
rotating 70
scatter 72
showing markers 70
showing multiple charts 65
showing multiple types 65
showing values 66
tiling 69
using for comparisons 63, 64

distributing
custom menus 89
custom toolbars 89
reports 81

drill down 13
alternate paths 29
details 27
dimension folders 27

drill through
cube 38
Impromptu 37, 38
other applications 37
PowerPlay 37, 38

drill up
alternate paths 29
details 27

drilling
for details 27

drop zones 7
duplicating

reports 9

E
earnings

calculating per share 60
email

sending reports 83
errors

appearing in cells 107
updating reports 104
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exceptions
applying 45, 47
automatic highlighting 45
creating 46
custom definitions 46, 48, 105
defaults 48
highlighting 45, 47
highlighting with macros 45
troubleshooting 47, 105

Explorer mode 1
Explorer reports

adding categories 5
command-line options 95
copying 10
showing data as percentages 78

exploring
information 37

exporting
reports 83

F
feelers

showing 71
files

exporting 83
filtering

categories 31
data 27
on values 24

filters
applying to reports 108
creating 31
removing 31
using to explore information 27
values 104

financial ratios
calculating 60

find-in-cube subset definitions
using wildcards 20

finding
data in cubes 20, 23, 31
data in reports 31
exceptions 45
trends 64

fiscal years
length 107

floating
columns and rows 12

folders
dimensions 27

footers
adding 75
setting defaults 75

forecasts
autoregression (seasonal) 59
autoregression formula 100
coefficient of determination formula 99
creating 58
formulas 99
growth (curved or curved line) 59
growth formula 100
terms of use 58
trend (linear or straight line) 59
trend example 59
trend formula 99

formats
data 105

formatting 77
applying automatic exception highlighting 45
applying custom exception definitions 47
axis titles 77
column labels 77
currency 35
data 76
exceptional data 46
labels 77
reports 68, 73, 76

formulae
autoregression 100
Burg algorithm 100
growth 100
trend 99

formulas
creating 51
forecasting 99

G
getting started

create reports 1
graphs

displaying mix 64
statistical lines 67
swapping columns, layers, or rows 11

gridlines
hiding in reports 71

grouping
calculations 57

growth forecasting
definition 59

H
headers

adding 75
setting defaults 75

Hebrew text
displaying in charts 103

hidden
data 10

hiding
categories 10, 11, 15
data 10
rank category 41
report gridlines 71
toolbars 87

highlighting
automatic exceptions 45
clearing 46
custom exceptions 45, 48
exceptional data 45, 46, 47
exceptions with macros 45
subsets 25

I
Impromptu

drill through to 37
indicators

performance 33, 34
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information
removing 15
suppressing 13

inserting
blank columns or rows 12

invalid characters
PDF files 81

L
labels

changing 77, 78
formatting 77
pie displays 71
renaming 77
summary 78

launch buttons
setting up 88

launch menu commands
setting up 86

layers
adding as calculations 55
adding to a report 9
changing contents 9
copying 10
drilling down and up 9, 29
formatting labels 77
navigation 9
showing multiple measures as 34
swapping 11
totals 78

layouts
crosstabs 73

legends
pie displays 71

limits
product 97

linear
statistical lines 67

lines
adding callouts to pie displays 71

local PowerCubes
using to create reports 2

locale
settings 105

locale settings
configuring 105

logarithmic
statistical lines 67

long
dimension or category name 73

M
macros

highlighting exceptional data 45
using a menu command 86

mailing
reports 110

maintaining
standard reports 17

manual
exception highlighting 45

manually
updating reports 18

markers
displays 70

measures
changing 33, 107
changing formats 34
comparing 64
definition 33
formatting labels 77
multiple 34
nested 34
no values in dimensions 107
numbers 106
scaling 72
values 106

menus
adding commands 85
creating 85, 91
customizing 85, 109
distributing 89
resetting 85, 109

missing
values 13, 79

months
using 13 in a year 107

moving
columns or rows 12, 108
reports and cubes 109

multiline
bold lines 71
bolding 71
displays 71
showing markers in displays 70

multiple
displays 65

multiple measures
as columns 34
as layers 34
as rows 34

N
names

dimension and category 73
navigation

reports that use layers 9
nested categories

changing 7
ranking 43
sorting 44

nested charts
selecting 65
showing labels and legends 71

nested crosstabs
ranking 43
sorting 44

no title screen
command-line options 95

number signs
calculations 105
values 107

numbers
changing formats for measures 34
errors 106
zeros 107
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O
offline

working 93
opening

reports 3, 108
subset definitions 24

organizing
displays 69

P
parent restrictions

creating subsets 22
parentage subset definitions

creating 19
paths

alternate 29
drill down 29
drill up 29
primary 29

patterns
applying 74, 77
changing 68

PDFs
invalid characters 81
setting options 12

percent growth
calculate 52

percentages
of totals 52
running totals 53
showing data as 78

performance
formatting indicators 34
indicators 33, 34
of Explorer and Reporter reports 109
tracking 63
troubleshooting 109

performing
calculations 51

pie displays
showing labels and legends 71

pie graphs
adding feelers to displays 71
changing displays 69
rotating displays 70
showing labels and legends 71

PowerPlay
customizing 85
drill through to 38
product specifications 97

preferences
creating menus 91
dimension viewer toolbox 91
PowerPlay 85
setting 85

primary
paths 29

printing
fitting report on one page 108
problems 108, 109
reports 108, 109
reports with large amounts of data 82

products
showing mix 64

profits
calculating per employee 60

prompts
setting in reports 12

Q
question marks

values 107

R
ranking

categories 41
columns or rows 41
identical values 42
nested categories 43
nested crosstabs 43
reports 42
ties in a report 42

refreshing
sub-cubes 93, 94

regression
statistical lines 67

remote cubes
using to create a report 2

remote reports
unable to open 110
unable to save 110

removing
categories 15
displays 65
filters 31
information 15
layers 9
styles 74
subsets 26
unwanted information 31

renaming
labels 77

report name
command-line options 96

report titles
blank lines 103

Reporter mode 1
Reporter reports

adding categories 5
command-line options 96
copying 10
performing calculations 55
showing data as percentages 78

reports 104, 108, 109, 110
adding nested categories 7
advanced 17
applying backgrounds 74
changing types 9
creating using a local PowerCube 2
creating using a remote cube 2
differences between PowerPlay Client and PowerPlay

Studio 3
distributing 81
duplicating 9
exporting 83
filters 108
finding data in 31
fitting on one printed page 108
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reports (continued)
formatting 73, 76
getting started 1
hiding gridlines 71
improving performance 109
mailing 110
maintaining standard 17
moving 109
opening 3, 108
printing 82, 108, 109
saving 108
sending via email 83
setting deployment options 12
setting up as templates 18
settings to use a sub-cube 94
troubleshooting 110
turning off automatic updates 18
updating manually 18
upgrading 5.x to 6.x 104
using sub-cubes 94

resetting
menus 85, 109
toolbars 87, 109

resizing
displays 65

rollup
calculations 54

rows
adding 5, 41
adding as calculations 55
copying 10
drilling down and up 29
floating 12
formatting labels 77
inserting blanks 12
moving 12, 108
ranking 41
showing multiple measures as 34
showing summaries 11
sorting 41
swapping 11
totals 78

S
sample reports 101
saving

a portion of a cube 93
reports 108

scaling
measures 72

scatter
displays 72
scaling each measure in displays 72
showing markers in displays 70

scenario dimensions
analyzing 27

scrollbars
using with large amounts of data 66

sending
reports 110
via email 83

setting up
launch buttons 88
launch menu commands 86
preferences 85

settings
locale 105

Share the Dimension Line 17
sharing

custom exception definitions 48
dimensions 108

short
dimension or category name 73

showing
a mix of information 64
bold line in multiline displays 71
categories 11
data as percentages 78
feelers in pie displays 71
headers and footers 75
markers 70
multiple displays 65
toolbars 87
values in displays 66
zeros as blanks 79

single line
showing markers in displays 70

slice and dice
swapping rows, columns, layers 11

sorting
categories 41
columns 41
data 41
layers 41
nested categories 44
nested crosstabs 44
reports 44
rows 41

specifications
product 97

statistical lines
adding 67
linear 67
logarithmic 67
regression 67

styles
creating and applying 74
defining for custom exception definitions 48

sub-cubes
refreshing 93, 94
saving 93
setting a report to use 94
unable to refresh data 110

subset calculations
creating 25

subset definitions 24
creating 19
definition 19
opening a subset 24
parentage 19

subsets 24
breaking 26
changing a definition 24
creating 17
creating an advanced subset definition 22
creating find in cube subset definitions 20
deleting 26
highlighting 25
opening a subset definition 24
removing 26

summaries
troubleshooting 105
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summary
categories 11
displaying categories 66
labels 78

suppressing
by 80/20 rule 13, 14

swapping
columns 11
dimensions 27
layers 11
rows 11

T
templates

report 18
terms of use

forecasting 58
tiling

displays 69
tilting

angle of displays 69
time periods

months in a year 107
titles

adding 75
formatting 77
setting defaults 75

toolbar buttons
customizing 87

toolbars
changing buttons 87
customizing 87, 109
distributing 89
resetting 87, 109
setting up buttons 87
showing or hiding 87

toolbox
customizing 91

totals
adding to reports 11, 55
percentage of 52

tracking
performance 63

transparent
3-D bar displays 72

trend forecasting
definition 59
example 59

trends
finding 64

troubleshooting
advanced subsets 104
calculations 105, 106
categories 15, 105
category labels 106
custom exceptions 47
default menus 109
default toolbars 109
dimension viewer 104
errors 107
hiding data 10
moving columns or rows 108
numbers 106, 107
performance of reports 109
printing 108, 109
reports 108, 110

troubleshooting (continued)
summaries 105
updated cubes 104
upgrading report versions 104
value filters 104
values 107

U
unable to open a remote report 110
unable to refresh data in a sub-cube 110
unable to save a remote report 110
unhiding

categories 10
updating

reports 104
reports manually 18

Upfront
setting prompts 12

upgrading
reports 104

using
wildcards 20

V
value restrictions

advanced subsets 104
values

appearing as number signs 107
appearing as question marks 107
labels in nested charts 71
measures 106
showing as percentages 78
showing in graphical displays 66
showing zeros as blanks 79
suppressing 13

variance
analysis 52
showing 63
tracking 63

viewing
displays 69
large amounts of data in a chart display 66

W
wildcards 20

using when finding data 31
working offline

overview 93

Y
years

fiscal 107

Z
zeros

all numbers 107
showing values as blanks 79
suppressing values 13
values 79
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