Installation hangs or fails
Installation hangs or fails.
Symptoms
Installation stalls or fails with no clear explanation, warning, or error message.
Causes
Installation failures or hangs can be attributed to various reasons. To identify the root cause, obtain a detailed report during installation.
Diagnosing the problem
Rerun the deployment command with the verbose (-vvv
) option specified.
-
Standard editions:
docker run -e LICENSE=accept --net=host -v "$(pwd)":/installer/cluster ibmcom/icp-inception-$(uname -m | sed 's/x86_64/amd64/g'):3.1.1-ee install -vvv
-
Community edition:
docker run -e LICENSE=accept --net=host -v "$(pwd)":/installer/cluster ibmcom/icp-inception-$(uname -m | sed 's/x86_64/amd64/g'):3.1.1 install -vvv
You can also rerun the deployment with a timer. This timer tracks the time that is taken for each task, and this information can help you to identify the step that is causing issues.
-
Standard editions:
docker run -e LICENSE=accept -e ANSIBLE_CALLBACK_WHITELIST=profile_tasks,timer --net=host -t -v "$(pwd)":/installer/cluster ibmcom/icp-inception-$(uname -m | sed 's/x86_64/amd64/g'):3.1.1-ee install
-
Community edition:
docker run -e LICENSE=accept -e ANSIBLE_CALLBACK_WHITELIST=profile_tasks,timer --net=host -t -v "$(pwd)":/installer/cluster ibmcom/icp-inception-$(uname -m | sed 's/x86_64/amd64/g'):3.1.1 install