If a user cannot connect remotely by using the system administration
client, some parameters in the cmbicmsrvs.ini file might be incorrect.
Symptom
A user can connect remotely to
IBM® Content Manager with icmadmin and icmconct
from a DB2® command line. However,
the user cannot log on remotely using the system administration client:
DGL0394A: Error in ::DriverManager.getConnection;
[IBM][CLI Driver]
CLI0124E Invalid argument value. SQLSTATE=HY009
(STATE) : ; [SERVER =
YoumansECM, USERID = icmconct, SQL RC = -99999,
SQL STATE = HY009]
Cause
The cmbicmsrvs.ini file, which contains a list of all of the available IBM Content Manager library servers on the
client machine, has incorrect parameters.
Action
Ensure that the parameters in cmbicmsrvs.ini are correct. The parameters are all case
sensitive. Follow these steps:
- Catalog the remote database.
- Find the CMCOMMON directory containing .ini files. The directory is identified by the CMCOMMON
environment variable. The default location is Program Files\IBM\CMGMT on Windows.
- Open the cmbicmsrvrs.ini file.
- Copy the entire first block of information starting with ICMSERVER
and ending with ICMOSTYPE.
- Paste the block as a separate block after the first block, leaving
a space between it and any other blocks of text.
- Modify the variables as needed. Typically, you only need to change
ICMSERVER from ICMNLSDB to the name of the remote database that you
cataloged.
- Save and then connect using the name of the remote database. In
the system administration client, you should see the remote databases
in the list of servers to which you can connect.