Configuring a Shared Ethernet Adapter with the Virtual I/O Server command-line interface

To configure a shared Ethernet adapter (SEA) with Hardware Management Console versions before 7, Release 3.4.2, you must use the Virtual I/O Server command-line interface.

In SEA, quality of service (QoS) is provided per SEA thread. By default, SEA runs in thread mode with seven threads. When SEA receives traffic, it routes the traffic to a thread, based on source and destination information. If the QoS mode is enabled, each thread further queues the traffic, based on the VLAN tag priority, to the appropriate priority queue associated with the selected thread. Queued traffic for a particular thread is serviced in the order of higher to lower priority. All threads handle all priorities.
Note: SEA QoS does not assure bandwidth for a particular priority. The packets are prioritized by each thread locally, not across the multiple SEA threads globally.

The SEA QoS is effective when all SEA threads are handling traffic, such that when an SEA thread is scheduled to run, it services higher priority traffic before servicing the lower priority traffic. An SEA QoS is not effective when the higher and lower priority traffic is spread across different threads.

Before you can configure an SEA, you must first create the virtual Ethernet trunk adapter by using the Hardware Management Console (HMC).

You can configure an SEA with the Virtual I/O Server command-line interface.

  1. Verify that the virtual Ethernet trunk adapter is available by running the following command:
    lsdev -virtual
  2. Identify the appropriate physical Ethernet adapter that is used to create the SEA by running the following command:
    lsdev -type adapter
    Notes:
    • Ensure that TCP/IP is not configured on the interface for the physical Ethernet adapter. If TCP/IP is configured, the mkvdev command in the next step fails.
    • You can also use a Link Aggregation, or Etherchannel, device as the SEA.
    • If you plan to use the Host Ethernet Adapter or Integrated Virtual Ethernet with the SEA, ensure that you use the Logical Host Ethernet adapter to create the SEA.
  3. Configure an SEA by running the following command:
    mkvdev -sea target_device -vadapter virtual_ethernet_adapters \
    -default DefaultVirtualEthernetAdapter -defaultid SEADefaultPVID
    Where:
    DefaultVirtualEthernetAdapter
    The default virtual Ethernet adapter used to handle untagged packets. If you have only one virtual Ethernet adapter for this logical partition, use it as the default.
    SEADefaultPVID
    The PVID associated with your default virtual Ethernet adapter.
    target_device
    The physical adapter that is being used as part of the SEA device.
    virtual_ethernet_adapters
    The comma-separated list of the virtual Ethernet adapters that are used as a part of the SEA device.
    For example:
    • To create an SEAent3 with ent0 as the physical Ethernet adapter (or Link Aggregation) and ent2 as the only virtual Ethernet adapter (defined with a PVID of 1), type the following command:
      mkvdev -sea ent0 -vadapter ent2 -default ent2 -defaultid 1
    • To obtain the value for the SEADefaultPVID attribute in the mkvdev command, type the following command:
      entstat -all ent2 | grep "Port VLAN ID:"
      Output similar to the following example is displayed:
      Port VLAN ID: 1
  4. Verify that the SEA was created by running the following command:
    lsdev -virtual
  5. Do you plan to access the Virtual I/O Server from the network with the physical device used to create the SEA?
    • Yes: Go to step 6.
    • No: You are finished with this procedure and can skip the remaining steps.
  6. Do you plan to set bandwidth apportioning by defining a quality of service (QoS)?
    • Yes: Go to step 11 to enable the SEA device to prioritize traffic.
    • No: Go to step 9 to configure a TCP/IP connection.
  7. Do you plan to define IP addresses on any VLANs other than the VLAN specified by the PVID of the SEA?
    • Yes: Go to step 8 to create VLAN pseudo-devices.
    • No: Go to step 9 to configure a TCP/IP connection.
  8. To configure VLAN pseudo-devices, complete the following steps:
    1. Create a VLAN pseudo-device on the SEA by running the following command:
      mkvdev -vlan TargetAdapter -tagid TagID
      Where:
      • TargetAdapter is the SEA.
      • TagID is the VLAN ID that you defined when you created the virtual Ethernet adapter associated with the SEA.
      For example, to create a VLAN pseudo-device using the SEA ent3 that you created with a VLAN ID of 1, type the following command:
      mkvdev -vlan ent3 -tagid 1
    2. Verify that the VLAN pseudo-device was created by running the following command:
      lsdev -virtual
    3. Repeat this step for any additional VLAN pseudo-devices that you need.
  9. Run the following command to configure the first TCP/IP connection. The first connection must be on the same VLAN and logical subnet as the default gateway.
    mktcpip -hostname Hostname -inetaddr Address -interface Interface -netmask \
    SubnetMask -gateway Gateway -nsrvaddr NameServerAddress -nsrvdomain Domain
    Where:
    • Hostname is the host name of the Virtual I/O Server
    • Address is the IP address that you want to use for the TCP/IP connection
    • Interface is the interface that is associated with either the SEA device or a VLAN pseudo-device. For example, if the SEA device is ent3, the associated interface is en3.
    • Subnetmask is the subnet mask address for your subnet.
    • Gateway is the gateway address for your subnet.
    • NameServerAddress is the address of your domain name server.
    • Domain is the name of your domain.
    If you do not have more VLANs, then you are finished with this procedure and can skip the remaining steps.
  10. Run the following command to configure more TCP/IP connections:
    chdev -dev interface -perm -attr netaddr=IPaddress netmask=netmask 
    state=up
    While using this command, enter the interface (enX) associated with either the SEA device or the VLAN pseudo-device.
  11. Enable the SEA device to prioritize traffic. Client logical partitions must insert a VLAN priority value in their VLAN header. For AIX® clients, a VLAN pseudo-device must be created over the Virtual I/O Ethernet adapter, and the VLAN priority attribute must be set (the default value is 0). Do the following steps to enable traffic prioritization on an AIX client:
    Note:
    • While configuring QoS on the VLAN devices, you can also configure the QoS priority for a virtual Ethernet adapter by using the Hardware Management Console.
    • You can also configure VLANs on Linux logical partitions. For more information, see the documentation for the Linux operating system.
    1. Set the SEA qos_mode attribute to either strict or loose mode. Use one of the following commands: chdev -dev <SEA device name> -attr qos_mode=strict or chdev -dev <SEA device name> -attr qos_mode=loose. For more information about the modes, see SEA.
    2. From the HMC, create a Virtual I/O Ethernet Adapter for the AIX client with all of the tagged VLANs that are required (specified in the Additional VLAN ID list). Packets that are sent over the default VLAN ID (specified in the Adapter ID or Virtual LAN ID field) are not tagged as VLAN; therefore, a VLAN priority value cannot be assigned to them.
    3. On the AIX client, run the smitty vlan command.
    4. Select Add a VLAN.
    5. Select the name of the Virtual I/O Ethernet Adapter created in step 1.
    6. In the VLAN Tag ID attribute, specify one of the tagged VLANs that are configured on the Virtual I/O Ethernet adapter that you created in step 1.
    7. Specify an attribute value (0 - 7) in the VLAN Priority attribute, which corresponds to the importance the VIOS will give to the traffic sent over that VLAN pseudo-device.
    8. Configure the interface over the VLAN pseudo-device created in step 6.
    Traffic sent over the interface created in step 7 will be tagged as VLAN and its VLAN header will have the VLAN priority value specified in step 6. When this traffic is bridged by a SEA that has been enabled for bandwidth apportioning, the VLAN priority value is used to determine how quickly it should be sent in relation to other packets at different priorities.
The Shared Ethernet Adapter is now configured. After you configure the TCP/IP connections for the virtual adapters on the client logical partitions using the client logical partitions' operating systems, those logical partitions can communicate with the external network.



Last updated: Thu, October 15, 2020