Change Management for Rational DOORS

User’s Guide
Before using this information, read the general information under Appendix: “Notices” on page 58.

This edition applies to Change Management for Rational DOORS (product number 5724V87) and to all subsequent releases and modifications until otherwise indicated in new editions.

© Copyright IBM Corporation 2002, 2011
US Government Users Restricted Rights—Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
# Table of Contents

## Chapter 1: Introduction

Using change management for Rational DOORS ............................................. 1  
Features ........................................................................................................ 2  
Benefits ........................................................................................................ 3  
Compatible change management tools .......................................................... 3  
Interface menus ............................................................................................. 4  
Assumptions ................................................................................................... 6  
Conventions ................................................................................................... 6  
  
  Typefaces and symbols ............................................................................... 6  
  Contacting IBM Rational Software Support ............................................... 7  
  Prerequisites ............................................................................................... 7  
  Submitting problems .................................................................................. 8

## Chapter 2: Preparing Your Change Management Server

Uninstalling prior versions of the interface ..................................................... 12  
Configuring your change management server ............................................... 12  
Upgrading from a previous version ................................................................. 12  
Upgrading from the Rational Change for DOORS Interface ......................... 12

## Chapter 3: Configuring the Change Management Feature

Defining configuration templates ..................................................................... 14  
Configuring a module .................................................................................... 16  
Configuring all modules ............................................................................... 17  
Configuring modules for use with the change management feature ............... 18  
Copying module configurations ................................................................... 20
Chapter 4: Gathering Requirements  21

Defining attribute mapping ................................................................. 21
Obtaining change management data ..................................................... 22
  Obtaining requirements ................................................................. 22
Saving selected options .................................................................... 23
Loading saved options ..................................................................... 23

Chapter 5: Managing Change Requirements  25

Submitting requirements change requests ............................................. 27
Opening modules .............................................................................. 27
Selecting default requirements change requests ................................. 28
Proposing changes to Rational DOORS documents ............................. 28
Entering change comments ................................................................ 29
Undoing changes .............................................................................. 29
Sending requirements change requests to review ............................... 30
Reviewing requirements change requests ............................................ 30
Reviewing several requirements change requests simultaneously ....... 32
Reviewing requirements change requests using Rational DOORS Web Access ................................................... 33
  Rejecting proposed changes ............................................................ 33
  Read access security .................................................................... 33
Rejecting proposed changes from Rational DOORS ............................. 34
Undoing rejected proposed changes from Rational DOORS ............... 34
Generating the RCR Report ............................................................... 35
Requirements change request and module statistics ........................... 36
  Viewing requirements change request statistics .............................. 36
  Viewing module statistics .............................................................. 36
Showing requirements change requests ............................................. 37
Applying approved requirements change requests ............................ 38
Conflict detection and resolution ....................................................... 39
  Conflict examples ...................................................................... 39
  Running the RCR Conflicts Report .................................................. 40
  Resolving conflicts ....................................................................... 41
Viewing requirements change request information in Rational DOORS ...................................................... 44
Chapter 6: Implementing Requirements

Tracing requirements implementation ........................................... 48
Administering requirements implementation .................................. 49
  Customizing IR attributes ................................................................. 49
  Adding and removing attributes and changing labels ....................... 50
Using requirements implementation operations .................................. 51
  Submitting change requests to fulfill requirements ......................... 52
  Submitting change requests when requirements change management is enabled ............... 53
  Showing change requests ............................................................... 54
  Generating activity reports .............................................................. 54
  Adding one or more existing change requests .................................... 54
  Removing one or more change requests ............................................ 54
  Synchronizing change requests for one requirement ............................ 55
  Synchronizing all requirements ......................................................... 56
  Synchronizing all modules ............................................................... 56

Chapter 7: Performing periodic maintenance

Database Cleanup utility ................................................................. 57

Chapter 8: Notices

Copyright license ................................................................. 60
Trademarks ........................................................................ 60

Index ..................................................................................... 61
1 Introduction

The Change Management for Rational DOORS User's Guide is written for administrators and users. This document describes how to prepare your change management system to use Change Management for IBM® Rational® DOORS®. It also contains information about using the change management feature.

Change Management for Rational DOORS is a tool used to enforce a formal process for the modification of your requirements, track the implementation of requirements by linking them with change requests or work items, and gather requirements by importing data from change management tools to serve as the basis for a new Rational DOORS document.

Using change management for Rational DOORS

Before you can use the change management feature, you must prepare your change management server and configure the feature.

• Preparing Your Change Management Server (page 11)
• Configuring the Change Management Feature (page 13)

After your change management server has been prepared and configured, the feature is ready to use. Change Management for Rational DOORS offers capabilities that can be grouped into three categories:

• Gathering Requirements (page 21)
• Managing Change Requirements (page 25)
• Implementing Requirements (page 47)

Using the requirements change management features, users can:

• Propose a change to a system at a high level.
• Categorize a change into one or more requirements change requests (RCRs).
• Propose, review, and apply changes to requirements in association with the requests.
With requirements implementation, users can:

- Trace requirements through to implementation.
- Obtain immediate visibility when requirements are implemented.
- Determine the project status based on how many requirements are fulfilled.
- Assess the requirements changes impact on the project.

Using requirements gathering, users can import enhancement requests from their change management software into Rational DOORS to use as the basis for a new Rational DOORS document.

**Features**

Using Change Management for Rational DOORS, you can:

- Create one or more implementation requests (IRs) for a requirement.
- Associate one or more existing implementation requests with one or more requirements.
- Directly access implementation request information in Rational DOORS requirement objects.
- Run activity reports for requirements modules, showing the requirements associated with the change requests (CRs) that implement the requirement.
- Create, view, or modify CRs.
- Import CRs from your change management software into Rational DOORS.
- Propose changes to requirements and associate the proposed changes to CRs.
- Review CRs and the associated proposed requirement changes.
- Apply proposed requirement changes to Rational DOORS.
Benefits

Using Change Management for Rational DOORS, your organization can implement a requirements-driven development process with the following benefits:

• Clearly defined and communicated requirements, which improves the focus of the development team, thereby reducing rework and improving productivity.

• Automatic establishment of the relationships between requirements and related development activities, which improves process control and productivity.

• Real-time visibility of the relationships between requirements and development activities, which helps reduce feature creep and streamlines development.

• Ability to import enhancement requests and defects submitted by users to be used as a basis for new requirements, thereby providing traceability and reuse of customer-reported issues.

Compatible change management tools

• Rational Change 5.2.0.4 or higher.
• ClearQuest 7.1.2 or higher
• Rational Team Concert 3.0 or higher
Interface menus

Administrative and module-specific change management operations are available on the Change Management menu on the Formal module main menu, as shown in this figure.
Requirement-specific change management operations are available on each requirement menu, as shown in this figure.
Assumptions

Before using this document, you must have a basic understanding of how to use Rational DOORS and your change management software.

Throughout this document, CR and change request can be used interchangeably with work item.

Conventions

This section describes the conventions used in this document.

Typefaces and symbols

<table>
<thead>
<tr>
<th>Typeface</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Italic</em></td>
<td>Used for book titles and terminology. Also designates names of roles (<em>developer</em>), states (<em>working</em>), groups (<em>ccm_root</em>), and users (<em>sue</em>).</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Used for items that you can select, such as buttons, icons, menu paths, and so on. Also used for the names of dialog boxes, dialog box options, toolbars, folders, baselines, databases, releases, properties, and types. Also used for emphasis.</td>
</tr>
<tr>
<td><em>Courier</em></td>
<td>Used for commands, filenames, and directory paths. Represents command syntax to be typed verbatim. Signifies computer output that displays on-screen.</td>
</tr>
<tr>
<td><em>Courier Italic</em></td>
<td>Represents values in a command string that you supply. For example, <em>(drive:username\commands)</em>.</td>
</tr>
</tbody>
</table>

This document also uses the following conventions:

**Note** A note contains important information that must not be overlooked.

**Caution** A caution indicates potential danger to the database, the database server, or some other integral piece of the software or your system.
Contacting IBM Rational Software Support

If the self-help resources have not provided a resolution to your problem, you can contact IBM® Rational® Software Support for assistance in resolving product issues.

Note If you are a heritage Telelogic customer, a single reference site for all support resources is located at http://www.ibm.com/software/rational/support/telelogic/

Prerequisites

To submit your problem to IBM Rational Software Support, you must have an active Passport Advantage® software maintenance agreement. Passport Advantage is the IBM comprehensive software licensing and software maintenance (product upgrades and technical support) offering. You can enroll online in Passport Advantage from http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html

• To learn more about Passport Advantage, visit the Passport Advantage FAQs at http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.html.

• For further assistance, contact your IBM representative.

To submit your problem online (from the IBM website) to IBM Rational Software Support, you must additionally:

• Be a registered user on the IBM Rational Software Support website. For details about registering, go to http://www.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.
Submitting problems

To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a problem to IBM, you are asked to supply a severity level. Therefore, you need to understand and assess the business impact of the problem that you are reporting.

   Use the following table to determine the severity level.

<table>
<thead>
<tr>
<th>Severity</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>The problem has a critical business impact: You are unable to use the program, resulting in a critical impact on operations. This condition requires an immediate solution.</td>
</tr>
<tr>
<td>2</td>
<td>This problem has a significant business impact: The program is usable, but it is severely limited.</td>
</tr>
<tr>
<td>3</td>
<td>The problem has some business impact: The program is usable, but less significant features (not critical to operations) are unavailable.</td>
</tr>
<tr>
<td>4</td>
<td>The problem has minimal business impact: The problem causes little impact on operations or a reasonable circumvention to the problem was implemented.</td>
</tr>
</tbody>
</table>

2. Describe your problem and gather background information. When describing a problem to IBM, be as specific as possible. Include all relevant background information so that IBM Rational Software Support specialists can help you solve the problem efficiently. To save time, know the answers to these questions:

   - What software versions were you running when the problem occurred?
   
   To determine the exact product name and version, use the option applicable to you:
   
   - Start the IBM Installation Manager and select **File > View Installed Packages.** Expand a package group and select a package to see the package name and version number.
   
   - Start your product, and click **Help > About** to see the offering name and version number.
Contacting IBM Rational Software Support

3. Submit your problem to IBM Rational Software Support. You can submit your problem to IBM Rational Software Support in the following ways:

- **Online**: Go to the IBM Rational Software Support website at https://www.ibm.com/software/rational/support/ and in the Rational support task navigator, click **Open Service Request**. Select the electronic problem reporting tool, and open a Problem Management Record (PMR), describing the problem accurately in your own words.

  For more information about opening a service request, go to http://www.ibm.com/software/support/help.html

  You can also open an online service request using the IBM Support Assistant. For more information, go to http://www.ibm.com/software/support/isa/faq.html.

- **By phone**: For the phone number to call in your country or region, go to the IBM directory of worldwide contacts at http://www.ibm.com/planetwide/ and click the name of your country or geographic region.

- **Through your IBM Representative**: If you cannot access IBM Rational Software Support online or by phone, contact your IBM Representative. If necessary, your IBM Representative can open a service request for you. You can find complete contact information for each country at http://www.ibm.com/planetwide/.
2 Preparing Your Change Management Server

Before you can use Change Management for Rational DOORS, you need to prepare your change management server.

This section contains the following information:

• Uninstalling prior versions of the interface (page 12)
• Configuring your change management server (page 12)
•Upgrading from a previous version (page 12)
• Upgrading from the Rational Change for DOORS Interface (page 12)
Uninstalling prior versions of the interface

If you are currently using the IBM® Rational® Change for DOORS Interface, before upgrading to Change Management for Rational DOORS, you must uninstall all versions of the Rational Change for DOORS Interface. Use the Microsoft® Windows® Control Panel to uninstall the software.

Note If you are using Change Management for Rational DOORS for the first time, you do not need to perform this task.

Configuring your change management server

Change Management for Rational DOORS relies on a specific set of change management lifecycles.

For specific information about preparing your change management server to work with Rational DOORS, refer to the documentation in the information center that is specific to your change management software:

- Rational Change information center
- Rational ClearQuest information center
- Rational Team Concert information center

Upgrading from a previous version

If you are upgrading from a previous version of the software, perform the following steps:

1. Update the change management server URL.
   
   See Defining configuration templates (page 14).

2. Delete your current configuration templates.

3. Recreate your configuration templates.
   
   See Defining configuration templates (page 14).

Upgrading from the Rational Change for DOORS Interface

If you are upgrading from the Rational Change for DOORS Interface, you must also upgrade the requirement change requests (RCR) data.

See the Rational Change information center for the latest information about upgrading from Rational Change for DOORS Interface.
3 Configuring the Change Management Feature

For Change Management for Rational DOORS to work properly, the change management server and the concepts of the feature need to be configured so that they are mapped to the change request process.

During the configuration, you also select which features will be available to the users. You can configure modules individually or configure all modules in a folder or in a project.

This section contains the following information:

- Defining configuration templates (page 14)
- Configuring a module (page 16)
- Configuring all modules (page 17)
- Configuring modules for use with the change management feature (page 18)
- Copying module configurations (page 20)
Defining configuration templates

Defining a configuration template tells Change Management for Rational DOORS how to locate the change management server. It also defines how the installed change request process maps to the concepts used in the change management feature.

Refer to the customization guide for your change management system for help in defining your configuration templates.

To define a configuration template:

1. On the main menu, select Change Management > Define Configuration Templates.
2. Click Create.
   
   The Configuration Template - DOORS dialog box opens and displays the Step 1 Configure Rational Change Management Server tab.
3. In Template Name, type the template name.
4. Choose the method of authentication, either basic access authentication or Open Authorization (OAuth).
5. Based on your authentication method, do one of the following:
   
   Basic access authentication
   
   a. In URL for Change Management server, type your server URL.
      
      For example: http://server:port/change/oslc
      
      Another valid option is https.
   
   b. Click Connect.
      
      Your change management log in dialog box opens. Log on to your system to return to the Configuration Template - DOORS dialog box.

   OAuth
   
   a. Before creating a configuration template, ensure that you have added the correct Collaboration Link, using the Remote Services tab on the DOORS Database Properties dialog box.
   
   b. Under Rational Change Management Server Configuration, select the applicable service provider, and then click Next.
      
      The change management service provider log opens.
c. Log on to the change management service provider to return to the Configuration Template - DOORS dialog box.

6. Complete all applicable fields on the Configuration Template - DOORS dialog box.

7. Click Next to display the Step 2 Requirements Change Management tab.

8. In the Values section, complete all fields to set the values for the various states that are applicable to your change management process.
   Ensure that you use the name for each state as defined in the process or schema rather than the label.

9. Do one of the following:
   • If you are using Rational Change, go to the next step.
   • If you are using Rational ClearQuest, check For ClearQuest, in Apply Action Attribute, type the name of the action in ClearQuest that moves the record to the Applied state, and then type the name of the action in ClearQuest that moves the record to the Review state in Review Action Attribute. Go to the next step.
   • If you are using Rational Team concert, check For Rational Team Concert, type the name of the action in Rational Team Concert to move the work item to the Applied state in your process in Apply Action Attribute, and then type the name of the action to move the work item to the Review state in Review Action Attribute. In State Attribute, type rtc_cm:state if using one of the out-of-the-box process templates, or type the name of the attribute that contains the state if you have created your own process. Go to the next step.

10. In RCR Submit Form, select the applicable submit form in your change management process used for requirement change requests.

11. In Conflicting Proposal Behavior, select one of the following options:
   • Take no action
   • Warn user of conflict: When users try to make changes that will cause a conflict, a warning message is displayed. The user can make or cancel the change.
   • Prevent modification: Users cannot make changes that will cause conflicts.

Selecting any setting other than Take No Action causes a slight delay when you open the modules to edit them.
12. Select the **Show RCR Recording Report** option to show the RCR Recording report.

13. To enable the **Reject** button on the Rational DOORS Web Access **Requirement Change Management** page, select **Enable Reject button in DWA**.

14. Click **Next** to display the **Step 3 Requirements Implementation** tab.

15. For all fields, select those options that are applicable to your change management process used for implementation requests.

16. Click **Next** to display the **Step 4 Requirements Gathering** tab.

17. In **Default Query String**, type the Open Services for Lifecycle Collaboration (OSLC) style query string to be used during requirements gathering.
   
   Skip this step if you are not using the requirements gathering feature.

18. Click **Next** to display the **Step 5 Finish** tab.

19. In **Template Summary**, review the selections you have made, and then do one of the following:
   
   • If everything is correct, click **Finish** to save your configuration template.
   • If there is anything you need to fix, click **Back** to return to the correct tab. Then, make the necessary corrections.

**Configuring a module**

Configuring each module of the change management feature is a three step process.

1. Define a configuration template for each change management server that you will use.

   See [Defining configuration templates](page 14).

   The configuration template contains information about the change management server and the process or schema that is installed on the server. Only users with the Rational DOORS **database manager** role can perform this step.

2. Configure each module that will use the change management feature.

   See [Configuring modules for use with the change management feature](page 18).
When configuring the module, decide which configuration template to use and which components of the change management feature the module will use.

Users with either the Rational DOORS project manager or database manager role can perform this step.

3. Copy a module configuration.

See Copying module configurations (page 20).

To make it easier to configure multiple modules the same way, use the change management feature to copy the configuration from one module that has been configured to other modules in the same Rational DOORS database.

**Configuring all modules**

Configuring all modules is a two step process.

1. Define a configuration template for each change management server that you will use.

   See Defining configuration templates (page 14).

   The configuration template contains information about the change management server and the process or schema that is installed on the server. Only users with the Rational DOORS database manager role can perform this step.

2. Right-click the folder or project, and then select Change Management > Configure All Modules.

3. Click Confirm to confirm that you want to continue.

4. Configure the modules for use with the change management feature.

   See Configuring modules for use with the change management feature (page 18).
Configuring modules for use with the change management feature

After you have defined at least one configuration template, you are ready to configure your modules.

You can simultaneously configure all modules inside a folder or project by right-clicking the folder or project in the Rational DOORS Database Explorer. Then, select **Change Management > Configure All Modules**.

To configure a module:

1. In Rational DOORS, open the module you want to configure.
2. On the main menu, select **Change Management > Configure Module**.
3. In **Template Name**, select the configuration template you want to use for this module.
   
   If you have not created a configuration template, do so now. See [Defining configuration templates (page 14)](page:14).

4. In **Integration Status**, to show the change management menus, select ON to activate the change management feature for this module.

   If you do not want to use the feature for this module, select OFF.

5. To enable requirements change management for this module:
   
   a. Select **Enable Requirements Change Management**.
      
      For more information, see “Managing Change Requirements” on page 25.
   
   b. Click **DOORS Attributes Managed by RCRs**.
      
      The **Select Managed Attributes - DOORS** dialog box opens.
   
   c. Select the attribute or attributes you want to manage with requirements change management, and then click **Apply**.
   
   d. Click **Close** to close the **Select Managed Attributes - DOORS** dialog box.
   
   e. If you want changes to the links to be saved immediately rather than being attached to RCRs as proposed changes, deselect **Manage Internal DOORS Links**. Then the outlinks on newly created objects are always managed.

   If a user modifies the value of any attribute that is not selected in this dialog box, the changes are saved to the Rational DOORS document rather than being associated with an RCR.
6. To enable the requirements implementation features of the change management feature for this module:
   a. Select **Enable Requirements Implementation**.
      For more information, see “Implementing Requirements” on page 47.
   b. Enable attribute mapping for implementation request (IR) submission:
      - Click **Map Attributes for CM IR Submission**.
      - Select the attribute or attributes you want to map.
      - Click to highlight the attribute, and then click **Edit**.
      - Click to highlight the attribute, and then click **Close**.
      - Click **OK**.
      When users submit IRs, the IR Submit form displays the Rational DOORS attributes values in **CM Attribute** in the **Select Attributes for CM IR Submission - DOORS** dialog box.

7. To enable the requirements gathering feature for this module, select **Enable Requirements Gathering**.
   For more information, see “Gathering Requirements” on page 21.

8. Click **Save**.
Chapter 3: Configuring the Change Management Feature

Copying module configurations

If you have several modules that use identical configuration settings for the change management feature, you can copy the settings from one module to the others to save time. However, you must be able to modify all modules to which you are copying configuration information.

To copy the configuration of one module to other modules:

1. On the main menu, select Change Management > Copy Module Configuration.
   
The Rational Change Management Configuration Copy - DOORS dialog box opens.

2. In Copy From Module, click Browse to select a module from which to copy changes, and then click OK.

3. In To Selected Module(s), select one or more modules from which to copy the configuration.

4. Click Copy.
   
The system displays a configuration overwrite warning message.

5. Click Confirm.
   
The Copy Results - DOORS dialog box opens and reports that the module was successfully copied.

6. Click Close.

Change Management for Rational DOORS is ready to use.

See the following topics:

- Gathering Requirements (page 21)
- Managing Change Requirements (page 25)
- Implementing Requirements (page 47)
4 Gathering Requirements

This section describes how to retrieve CR data from your change management software for use in Rational DOORS. To import requirements from your change management software, the following steps must be performed in this order:

1. Defining attribute mapping (page 21)
2. Obtaining change management data (page 22)

Defining attribute mapping

The first step in retrieving requirements is to define which change management attributes you want to retrieve. Then, define the corresponding Rational DOORS attributes where the values are to be transferred.

To define attribute mappings:

1. In Rational DOORS, open the module for which you want to define attributes.
2. On the main menu, select Change Management > Retrieve Requirements from change management tool > Define Attribute Mapping.

   The Attribute Mapping - DOORS dialog box opens.
3. In DOORS Attribute, select one of the Rational DOORS attributes listed, and then click Edit.

   The Select CM Attribute to Map To - DOORS dialog box opens.
4. In CM Attributes, click to select the change request attribute you want mapped to the Rational DOORS attribute you selected.
5. Click Close.

   If you do not select a change request attribute before clicking Close, no mapping is created. This method can also be used to remove existing mappings.
6. Repeat the above steps for each Rational DOORS attribute you want to map.
7. When you have finished mapping attributes, click OK to save the changes and to close the dialog box.
Obtaining change management data

Obtaining change management data is the second step in importing requirements from your change management software into Rational DOORS.

To obtain change management data:

1. Obtain requirements from your change management software.
   See Obtaining requirements (page 22).

2. Optionally, save the selected option.
   See Saving selected options (page 23).

3. Optionally, load the previously saved options.
   See Loading saved options (page 23).

Obtaining requirements

To obtain requirements:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Retrieve Requirements from change management tool > Get Requirements.
   The Get Requirements from CM - DOORS dialog box opens.
   If you have any saved options, you can click Load Options to load them now. For steps, see Loading saved options (page 23).

3. In Query String, type the OSLC approved query string to be used during requirements gathering.

4. In Insertion Point, select one of the following options to tell the system where to insert the Rational DOORS objects that are created by the get requirements operation:
   • Top of module: Places all new objects at the top of the current module.
   • After current object: Places all new requirements after the current object at the same level of the hierarchy.
   • Below current object: Places all new requirements below the current object in the hierarchy.
5. In **Processed CR Action**, select one of the following options:
   
   - **Ignore Processed (or Existing) CRs**: Any CR that has already been imported into the current module is ignored. Change requests that have not yet been imported are retrieved.
   
   - **Update Processed (or Existing) CRs**: The Rational DOORS object representing any CR that has already been processed is updated with the current values of the CR attributes. Change requests that have not yet been imported are retrieved.

6. If you want to do an import later, click **Save Options** now to save these options.

   For steps, see **Saving selected options (page 23)**.

7. Click **Import** to begin the import process.

### Saving selected options

To save all of the options that you selected on the **Get Requirements from CM - DOORS** dialog box:

1. Click **Save Options**.

   The **Save options - DOORS** dialog box opens.

2. Type a file name, or click **Browse** to choose a path and filename.

3. Click **Save**.

### Loading saved options

To load previously saved options for the **Get Requirements from CM - DOORS** dialog box:

1. Click **Load Options**.

   The **Load options - DOORS** dialog box opens.

2. Type a file name, or click **Browse** to choose the file containing your saved options.

3. Click **Load**.
5

Managing Change Requirements

Use Change Management for Rational DOORS to manage requirement changes, such as:

- Submitting RCRs.
- Selecting a default RCR on which to work.
- Proposing changes to requirements.
- Having the requirements automatically associated with the default RCR.
- Reviewing RCRs.
- Applying RCRs.

Requirements change management using Change Management for Rational DOORS is centered around an RCR. This request contains a description of the change and other associated information such as priority, product name, reviewer comments, and the user name of the person assigned to make the requirement changes. This CR is assigned to a single requirement engineer, who then uses Rational DOORS to propose changes to one or more requirements.

Proposed changes are automatically associated with the RCR that the engineer is currently working on. After the requirement engineer completes the CR, it is reviewed by one or more people. If the CR is approved, the proposed changes can be applied to the Rational DOORS document.

You can also choose to use the system CR lifecycle that is included with Change Management for Rational DOORS to manage your requirements changes. The system CR lifecycle is designed for end users to submit requests for changes they want made to a system. The system CR is then broken down into one or more RCRs, and potentially into one or more implementation requests (IRs).

You can track the following types of changes to your Rational DOORS document:

- Adding one or more objects in any structure.
- Modifying objects.
- Adding or removing outgoing links to an object.
- Deleting objects or object hierarchies.
- Relocating objects within a module.
Chapter 5: Managing Change Requirements

To enforce that all changes made to a module are associated with an RCR, Change Management for Rational DOORS requires that the user select a default RCR whenever a module is opened for editing.

The following sections contain information about using Change Management for Rational DOORS operations:

- Submitting requirements change requests (page 27)
- Opening modules (page 27)
- Selecting default requirements change requests (page 28)
- Proposing changes to Rational DOORS documents (page 28)
- Entering change comments (page 29)
- Undoing changes (page 29)
- Sending requirements change requests to review (page 30)
- Reviewing requirements change requests (page 30)
- Reviewing several requirements change requests simultaneously (page 32)
- Reviewing requirements change requests using Rational DOORS Web Access (page 33)
- Rejecting proposed changes from Rational DOORS (page 34)
- Undoing rejected proposed changes from Rational DOORS (page 34)
- Generating the RCR Report (page 35)
- Requirements change request and module statistics (page 36)
- Showing requirements change requests (page 37)
- Applying approved requirements change requests (page 38)
- Conflict detection and resolution (page 39)
- Viewing requirements change request information in Rational DOORS (page 44)
Submitting requirements change requests

The starting point for requirements change management is to submit an RCR from Rational DOORS.

To submit an RCR from Rational DOORS:

1. In the Rational DOORS module view, on the main menu, select **Change Management** > **Requirements Change Request** > **Submit**.
   
   Your change management log in dialog box opens. Log on to your change management system.

2. Complete all applicable fields on the submit form.

3. Submit the RCR.

   For instructions, refer to the documentation in the information center that is specific to your change management software:

   - Rational Change information center
   - Rational ClearQuest information center
   - Rational Team Concert information center

Opening modules

When you open a module, you are prompted to select a default RCR. Do one of the following:

- Select an RCR from the list, and then click **OK** to propose changes to the module.

- Click **Open for Unmanaged Changes**, and then edit the attributes that are not controlled by requirements change management. The system displays a list of the modifiable attributes.

  **Caution** Any changes you make to attributes that are not on this list are discarded when you open the module in this way.

- Click **Open in Read-Only mode**, and then open the module for reading without selecting a default RCR.
Selecting default requirements change requests

All changes made to a document, with the exception of unmanaged attributes, go through a formal review and approval process. When using requirements change management, first associate all changes to the requirements with an RCR. Then, you track a set of changes made throughout this process.

When you select a default RCR, you are choosing to automatically associate any proposed changes to objects in the current Rational DOORS module with that CR.

To select a default RCR:
1. In Rational DOORS, open the applicable module.
2. On the main menu, select Change Management > Requirements Change Request > Select Default.
   The Select Default RCR - DOORS dialog box opens, and the default RCR that is already selected is highlighted.
3. In ID & Summary, click to select the RCR.
   In the default lifecycle, only RCRs that are assigned to you are included in the list. If there are no RCRs listed, then, in your change management software, assign one to yourself.
4. Click OK.
   The default requirements change management request displays in the lower right corner of the Rational DOORS module window.

Proposing changes to Rational DOORS documents

You can propose changes to a Rational DOORS document using Change Management for Rational DOORS. This process is also called recording changes.

To propose changes to a Rational DOORS document:
1. Make the changes in Rational DOORS as you normally would.
   The modifications can include modifying objects, adding new objects, deleting objects, moving objects, adding links, and deleting links.
2. When you have finished your modifications, in Rational DOORS, click Save.
   If you have IBM® Rational® DOORS® Web Access installed, the system creates a link. Click this link to review the RCR. See Reviewing requirements change requests using Rational DOORS Web Access (page 33).
Entering change comments

You can enter a comment for changes you have made to a Rational DOORS object. This operation can only be done after you have saved your changes.

To enter a change comment:

1. In Rational DOORS, open the applicable module.
2. Right click the Rational DOORS object you modified, and then select Requirements Change Request > Enter Change Comment.
   The Enter Change Comment - DOORS dialog box opens.
3. Type a comment.
4. Click OK.

Undoing changes

Sometimes you need to undo a change. For example, you changed the wrong item, and you need to resolve a conflict with another proposed change. Or you changed your mind about how something was written, and you want to start again from the original document.

To undo changes, do one of the following:

- If you have not yet typed a comment and have not clicked OK or you have not saved the Rational DOORS module, close the module. All changes that you made in that session are undone.
- If you have already saved your changes, right click the object that contains the changes you want to undo, and then select Requirements Change Request > Undo Change. Then, click Confirm to undo your change.
Chapter 5: Managing Change Requirements

Sending requirements change requests to review

Once you have finished proposing changes to fulfill an RCR, that CR is sent to review so a decision can be made as to whether the changes will be applied to the document.

To send an RCR to review:

1. In Rational DOORS, open the applicable module.
2. On the main menu, select Change Management > Requirements Change Request > Send RCR to Review.
3. Click Confirm to send the RCR to review.

All open modules that are in the edit and shared edit modes are closed. Click Yes to reopen them.

Reviewing requirements change requests

Once an RCR has been sent to review, it can be reviewed to determine whether the changes are acceptable and to identify the impact of making those changes.

The RCR review feature displays added objects as they will be displayed when the RCR is applied. As a consequence, reviewing RCRs requires the user to open the module in the exclusive edit mode.

To review an RCR:

1. In Rational DOORS, open the applicable module.
2. Select Change Management > Requirements Change Request > Review.

   The Select a RCR To Review - DOORS dialog box opens and shows a list of all modules affected by each RCR is located in the second column.
3. Determine the types of RCRs you want to include when searching for conflicts.
4. Select the RCR you want to review.

   In the default lifecycle, the list contains only those RCRs in the review state that have your user name in one of the reviewer fields.
5. Click **OK**.

6. Click **Close**.

A new view, shown below, is created in Rational DOORS. This view shows the proposed changes associated with the selected RCR and is filtered to include only those objects that are affected by the RCR. The view also contains a details column that shows any conflicts that might be present within the RCR.

For more information about conflicts, see [Conflict detection and resolution](page 39).
Chapter 5: Managing Change Requirements

Reviewing several requirements change requests simultaneously

Simultaneously reviewing several RCRs helps you determine how a group of changes will look together. You can also identify conflicts or inconsistencies.

To simultaneously review several RCRs:

1. In Rational DOORS, open the applicable module.
2. On the main menu, select Change Management > Requirements Change Request > Display multiple RCRs.
3. Select Also show assigned RCRs to select RCRs that are still being worked on, and then click Refresh CR List.
4. Select the RCRs you want to review, and then click OK.

A new view is created that shows the changes that will be made by the RCRs. Also included are details about the RCRs, such as who made the changes, when they were made, and any comments.
Reviewing requirements change requests using Rational DOORS Web Access

If you have Rational DOORS Web Access installed, the system created a link in the RCR when you saved your modifications. Go to your change management system to access this link and review RCR.

**Note** When you click this link, ensure that the link opens in Windows® Internet Explorer®. Other web browsers are not supported.

**Rejecting proposed changes**

You must log on to Rational DOORS Web Access to review the proposed changes. The first time you access this page, you are prompted to download and install IBM® Rational® DOORS® RCM Control. After the control is installed, you can review the proposed changes.

If you have the right to do so, click **Reject** to reject the selected proposed change.

The **Reject** button is enabled only when you have write access to the module.

By default, the **Reject** button is not available even when you have write access to the module. To enable the **Reject** button, edit the configuration template. See **Defining configuration templates** (page 14).

**Read access security**

The ActiveX® control enforces additional security when users try to read the data.

- If you do not have read access on an object, the object does not show in the ActiveX control.
- If you do not have read access on an attribute, the attribute values do not show in ActiveX. However, the attribute name is displayed.
- If you do not have read access in the module, the proposed changes do not show in ActiveX.

**Note** Only Internet Explorer supports ActiveX.
Rejecting proposed changes from Rational DOORS

You can use Rational DOORS to reject a proposed change.
To reject a proposed change:
1. Ensure that the RCR for which you need to reject proposed change is assigned to you.
2. Open the Rational DOORS module, and then select the RCR as the default RCR.
3. Go to the object for which you need to reject the proposed change.
4. Right click the object, and then select Requirements Change Request > Reject Change to reject the proposed change.
5. In the confirmation message box, click Yes.
6. When prompted, reopen the module.
   You can reopen the module later and continue rejecting more proposed changes.

Undoing rejected proposed changes from Rational DOORS

You can use Rational DOORS to undo a reject change action to retrieve the original proposed change.
To undo a rejected proposed change:
1. Ensure that the RCR for which you need to undo the reject proposed change is assigned to you.
2. Open the Rational DOORS module, and then select the RCR in question as the default RCR.
3. Go to the object for which you need to undo the rejected proposed change.
4. Right click the object, and then select Requirements Change Request > Undo Reject.
5. In the confirmation message box, click Yes.
6. When prompted, reopen the module.
   You can reopen the module later and continue undoing rejected proposed changes.
Generating the RCR Report

The RCR Report contains the following information from Rational DOORS.

- Changes for any modified attributes that are under change management control in all the impacted Rational DOORS modules associated with the RCR.
- The Object Heading and Object Text attribute values of Objects that were affected by the RCR. The redline differences are also shown.
- All modified, added, deleted, or moved Object IDs and their associated Rational DOORS module name.
- All changes made to the Rational DOORS links, including new and deleted links and identifiable before and after link information.
- The before and after values of object linking and embedded (OLE) objects.

To generate the RCR report:

1. In Rational DOORS, open the applicable module.

The RCRs for This Module - DOORS dialog box opens and displays all RCRs associated with the Rational DOORS module from which the report was generated.

3. Select the RCR from which you want to generate the report, and then click OK.

The Rational Publishing Engine - Results dialog box opens and displays links to the report. The report is available in the following formats: HTML, Word, PDF, or XLS.

4. Click on a link to open or save the report.
Chapter 5: Managing Change Requirements

Requirements change request and module statistics

You can analyze and monitor the number and type of changes being made to a module. Modules that have too many changes degrade the performance of the tool.

These statistics are also useful for helping you understand how quickly and in what way your requirements are changing.

Viewing requirements change request statistics

The RCR statistics show the total number of objects changed for each associated module. The statistical data includes the number of modules the RCR modified. The data also includes for each module the total number of objects modified, rejected, added, moved, purged, deleted, and the outlinks created.

To view the RCR statistics:
1. Open the module.
3. Type the RCR ID.
4. Click Show.

Viewing module statistics

The module statistics show the total number of objects changed in the module across all non-applied RCRs and the total number of non applied RCRs associated with the module. It also shows, for each RCR, the number of changed objects and rejected objects.

To view module statistics:
1. Open the module.
3. Click Show.
Showing requirements change requests

There are several ways to locate RCRs, including querying from your change management software, following a link from a related system CR, or from within Rational DOORS. This section describes how to identify RCRs that are associated with proposed changes to the current module.

To show RCRs with proposed changes to the current module:

1. In Rational DOORS, open the applicable module.
2. On the main menu, select Change Management > Requirements Change Request > Show for this Module.
   The RCRs for This Module - DOORS dialog box opens.
3. In ID & Summary, click to select the RCR you want to see.
4. Click Show, and then review the RCR.
5. Repeat the above steps to show other RCRs.
6. Click OK or Close to close the dialog box.
Applying approved requirements change requests

When proposals have been approved, use Change Management for Rational DOORS to apply the proposed changes to the Rational DOORS module.

To apply the approved requirements change requests:

1. In Rational DOORS, open the applicable module in read-only mode.
2. On the main menu, select Change Management > Requirements Change Request > Apply.
   
The Apply Requirements Change Requests - DOORS dialog box opens and displays every approved RCR for the current module.
3. To create a baseline of your Rational DOORS document after the apply has finished, select Also create baseline after apply.
4. Select individual RCRs to view or apply.
5. To apply the changes, click Apply.
6. Click to close the module.

The system automatically checks all approved RCRs for conflicts.

- If conflicts are found, the apply process is cancelled and the approved changes are not applied. The reason is written to a status log.
- If no conflicts are found, the apply process is completed. Then, the change management feature checks all non-approved RCRs associated with the modules that were affected by the applied RCR. If there are any conflicts, the change management feature marks all non-approved RCRs with conflicts as obsolete.

For example, applied RCR 1 is checked against three non-approved RCRs—RCR 2, RCR 3, and RCR 4. The system identifies a conflict with RCR 3, and RCR 3 is marked obsolete.

When you open a module associated with RCR 3 and RCR 3 is the default RCR, the Conflict Resolution for RCR - DOORS dialog box opens. Then, you resolve the conflict. See Resolving conflicts (page 41).
Conflict detection and resolution

Change Management for Rational DOORS automatically detects most conflicts during the review and apply states. During review, conflicts are detected only within the selected RCR. During apply, conflicts are detected on all approved RCRs. When Change Management for Rational DOORS checks for conflicts, one of the following situation occurs, depending on how the template was configured. See Defining configuration templates (page 14):

- Warns you when you are modifying attributes that already have outstanding proposed changes.
- Prevents approval of RCRs that conflict with already approved RCRs.
- Helps you identify and resolve conflicts when working on an RCR that is marked obsolete.

See Resolving conflicts (page 41).

Conflict examples

The following are some examples of conflicts:

- Two or more proposals were made against the same object or module. These proposals might clash with each other or be order dependent.
- Multiple RCRs were approved against the same object and the change type is delete on any of the RCRs.
- The Rational DOORS attributes were changed by the RCR overlap.
- Two RCRs were approved to change the object text of a requirement. If both were applied without revision, the second one applied would overwrite the first. Similarly, one CR might request a child object to be added to requirement X while another requests that requirement X be deleted. If the latter is applied, the former must not be applied.
- Not all changes were made using Change Management for Rational DOORS. The change management feature cannot detect manual changes. For example, an RCR might have been submitted against a requirement. Before the CR was applied, someone manually modified the requirement without using the change management feature. In this case, when the CR is applied, it might overwrite the other change because the two are unrelated.

The system, however, cannot detect all conflicts, so they need to be inspected manually to evaluate the semantics of the change. See Resolving conflicts (page 41). Use the RCR Conflicts Report to identify the conflicts the system cannot detect. See Running the RCR Conflicts Report (page 40).
Running the RCR Conflicts Report

Use Change Management for Rational DOORS to run a report, at any time, to detect conflicts for a single RCR, or for an entire module.

To run the RCR Conflicts Report:

1. In Rational DOORS, open the applicable module.
2. On the main menu, select **Change Management > Requirements Change Request > RCR Conflicts Report**.
3. Choose whether you want to see conflicts for all RCRs that affect the module, or only for a specific RCR.
4. Choose the types of RCRs you want to include when detecting conflicts.
   For example, select **All approved RCRs**.
5. Choose a report format.
   - **Grouping by object**: Shows conflicts for the same Rational DOORS objects together.
   - **Grouping by RCR**: Shows conflicts for the same RCR together.
   - **Grouping by conflict**: Shows conflicts of the same type together.
6. Click **Generate Conflicts Report**.
   The **Conflicts Report - DOORS** dialog box opens and displays the report results.
**Resolving conflicts**

When conflicts are found, they must be resolved manually. To manually resolve conflicts, reject one of the RCRs, or reject one of the proposed changes from the conflicting RCR. Usually the person who proposed the changes or the person who is responsible for the entire document resolves the conflicts.

**Caution** Be careful when rejecting individual proposed changes from an RCR. If there are interdependencies between proposals and only some of the proposals are rejected, an RCR might be rendered invalid. For example, if the RCR proposes to create a hierarchy of new Rational DOORS objects and the proposal to create the topmost object is rejected, the other objects no longer have a parent object, and the RCR is invalid.

When a module is opened in exclusive or sharable edit mode and the default RCR is marked obsolete, Change Management for Rational DOORS displays the **Conflict Resolution for RCR - DOORS** dialog box.

For more detailed information about how RCRs are marked obsolete, see [Applying approved requirements change requests](#) (page 38).
The change management feature offers several options to resolve RCR conflicts. At anytime, click **Navigate to Selected Object** to view the exact object within the module.

To resolve an RCR conflict:

1. In **Objects with Conflict**, review the objects that have conflicts.

2. In **Object Attributes with Conflicts**, individually select each attribute to view the details.

   When you click an item in this section, the conflict results display in the **Original Value**, **Current Value**, and **Proposed Value** fields. You will resolve these one at a time.

3. Review the following sections:
   - **Original Value**: Displays, before any changes, the attribute value.
   - **Current Value**: Displays the current attribute value that is in the Rational DOORS database.
   - **Proposed Value**: Displays your proposed values for that attribute.

4. In **Format**, in the **Proposed Value** section, select from the following options:
   - **Proposed Value**: Displays the proposed value as it is displayed in Rational DOORS.
   - **Difference with Original**: Displays the proposed value with redline differences against the original value.
   - **Difference with Current**: Displays the proposed value with redline differences against the current value.

5. To edit the information in **Proposed Value**:
   a. Click **Edit** to activate the **Update** and **Cancel** options so that you can make your edits.
   b. Click **Update** to update the object with the conflict.
      To undo the edits, click **Cancel**.

6. Determine how to resolve the conflict, and then do one of the following:
   - To keep the proposed edits and to permit your changes to overwrite the values in the database, click **Keep Proposed**.
     The attribute value stays as is, with your changes.
   - To discard your changes and keep the database values, click **Discard Proposed**.
The proposed values are replaced with the attribute current values.

- To override the conflict and make the RCR active, in **Objects with Conflicts**, select all objects, and then click **Finish Conflict Resolution** to clear the obsolete flag.

The **Finish Conflict Resolution** option becomes active after the resolved box is checked for each object. It also becomes active when all objects with conflicts have been resolved.

7. Click **Close**.

8. In Rational DOORS, save the module.

If you have discarded any proposed changes, the Rational DOORS module closes.
Chapter 5: Managing Change Requirements

Viewing requirements change request information in Rational DOORS

Change Management for Rational DOORS creates and maintains a view in Rational DOORS that shows information about the RCR associated with each object in a Rational DOORS module.

This view is described in the following sections:

- Customizing requirements change request attributes (page 44)
- Syncing the requirements change request Attrs View (page 45)

Customizing requirements change request attributes

When you customize the RCR attributes, you can select the RCR attributes you want to view in Rational DOORS.

To customize RCR attributes:

1. In Rational DOORS, open the applicable module.
2. On the main menu, select Change Management > Requirements Change Request > Customize RCR Attributes.
   
   The Custom CM RCR Attributes - DOORS dialog box opens and displays a list of OSLC common attributes defined in your change management process. It also displays the name of the Rational DOORS attribute that will be created if you choose to display that attribute.
3. In RCR Attribute, click to select the attributes you want to be visible inside Rational DOORS.
4. To change the name of the Rational DOORS attribute that is included in the change management data:
   a. In RCR Attribute, click the attribute row to highlight it.
   b. Click Edit DOORS Attribute Name.
   c. In DOORS Attribute Name, type the new attribute name.
   d. Click Apply.
5. To view information about previously applied RCRs, select Include Applied Requirements Change Requests.
   By default, information about previously applied RCRs is not displayed.
6. To add custom attributes that are included in your change management process:
   a. Click Add.
      The Add Custom CM Attribute Name - DOORS dialog box opens.
   b. In CM Attribute Name, type your change management attribute name.
      You must include the change management namespace prefix. For example, change:product_name
      Where change is the prefix and product_name is the name of the attribute in your change management process.
   c. In DOORS Attribute Name, type the Rational DOORS attribute name.
      For example, csint_rcr_product_name
   d. Click Apply to add the custom attribute to the list in the Custom CM Attributes - DOORS dialog box.
7. Return to the Custom CM Attributes - DOORS dialog box, and then click Apply.
   The attributes are created in your Rational DOORS module.
8. To remove an attribute, select the attribute, and then click Delete.
9. Use the Rational DOORS Insert > Column menu to add the wanted attributes to your view.
   The RCR Attrs View is created and contains a default set of attributes.

Syncing the requirements change request Attrs View

The RCR Attrs View option retrieves the current information from the change management database and refreshes the attributes you are viewing.

To sync the requirements CR Attrs View:
1. In Rational DOORS, open the applicable module.
2. On the main menu, select Change Management > Requirements Change Request > Sync Requirements Change Requests.
Implementing Requirements

Sometimes you need to trace the current status of requirements during product development. Using Change Management for Rational DOORS, you can create new CRs or associate existing CRs with requirements. Then, you can trace the module requirements through the implementation process.

You can also view the status of a requirement associated with CRs and run an activity report to view the requirements and CRs for a module.

See the following for information about Change Management for Rational DOORS traceability operations:

- Tracing requirements implementation (page 48)
- Administering requirements implementation (page 49)
- Using requirements implementation operations (page 51)

For details about using your change management software, refer to the documentation in the information center that is specific to your change management software:

- Rational Change information center
- Rational ClearQuest information center
- Rational Team Concert information center
Tracing requirements implementation

After a CR is submitted against a requirement, your change management software tracks the details of the changes made to the requirement, such as who submitted the CR and why.

You can also use your change management software to notify users when the status of the CR is modified, such as when the request is assigned, resolved, or deferred.

For more information, refer to the documentation in the information center that is specific to your change management software:

- Rational Change information center
- Rational ClearQuest information center
- Rational Team Concert information center

When you run Change Management for Rational DOORS, the system shows the CR number and the CR status for each requirement. This information is shown on a Rational DOORS view, named IR Attrs View, which the change management feature creates. By default, these attributes have the following labels:

- csint_ir_dcterms:title
- csint_ir_oslc:shortTitle
- csint_ir_dcterms:description
- csint_ir_oslc_cm:status

For information about adding and removing attributes or changing their labels, see Customizing IR attributes (page 49).

You can submit a new CR for a requirement, or you can associate one or more existing CRs with a requirement. Also, at any time, you can synchronize one or more requirements with one or more CRs to update the Rational DOORS view with the latest change management information.

The sync operation updates Rational DOORS with your change management information. Therefore, if you type a CR ID directly into the Implementation Request column, it is no longer listed after you run a sync operation.
Administering requirements implementation

The following operations are available for administering the requirements implementation portion of Change Management for Rational DOORS:

- Customizing IR attributes (page 49)
- Adding and removing attributes and changing labels (page 50)

All users can perform these operations.

Customizing IR attributes

From the Rational DOORS Formal module, choose the CR attributes that are included in the IR Attrs View. You can also change the labels used for these attributes.

For example, the dcterms:title, dcterms:shortTitle, dcterms:description, and cm:status attributes are included by default in the IR Attrs View.

The default attributes are labeled as follows:

- csint_ir_dcterms:title
- csint_ir_dcterms:shortTitle
- csint_ir_dcterms:description
- csint_ir_oslc_cm:status
Adding and removing attributes and changing labels

To add or remove an attribute, or to change its label:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Customize IR Attributes.
   
The Custom CM IR Attributes - DOORS dialog box opens.

3. To add custom attributes that are included in your change management process:
   
a. Click Add.
      
The Add Custom CM Attribute Name - DOORS dialog box opens.
   
b. In CM Attribute Name, type your change management attribute name.
      
You must include the change management namespace prefix. For example, change:product_name
      
Where change is the prefix and product_name is the name of the attribute in your change management process.
   
c. In DOORS Attribute Name, type the DOORS attribute name.
      
For example, csint_ir_product_name
   
d. Click Apply to add the custom attribute to the list in the Custom CM Attributes - DOORS dialog box.

4. To change the name of the Rational DOORS attribute that is included in the change management data:
   
a. Click the attribute row to highlight it, and then click Edit DOORS Attribute Name.
   
b. In DOORS Attribute Name, type the new attribute name, and then click Apply.

5. To remove an attribute, clear the attribute check box, and then click Delete.

6. In the Custom CM IR Attributes - DOORS dialog box, click Apply.

7. If you have added attributes, use Insert > Column to insert them into your view.

8. On the main menu, select Change Management > Sync Implementation Requests.
   
The new attributes columns are updated with the change management values.
Using requirements implementation operations

The following operations are available for tracing the requirements status.

**Note** Before performing any operations, enable the **Requirements Implementation** option from within the configuration dialog box.

The following sections explain how to use the requirement-specific traceability operations:

- Submitting change requests to fulfill requirements (page 52)
- Submitting change requests when requirements change management is enabled (page 53)
- Showing change requests (page 54)
- Generating activity reports (page 54)
- Adding one or more existing change requests (page 54)
- Removing one or more change requests (page 55)
- Synchronizing change requests for one requirement (page 55)
- Synchronizing all requirements (page 56)
- Synchronizing all modules (page 56)
Submitting change requests to fulfill requirements

You can submit a CR that will be used to fulfill a requirement.

To submit a CR to fulfill a requirement:

1. In Rational DOORS, open the applicable module.
2. Right-click the requirement.
   If you need to select more than one requirement, use shift+left-click to select multiple items. Only a single CR is submitted.
   When using this feature, be aware that all child requirements of the selected requirements are included in the CR, even if your view does not show them.
3. On the menu, select Implementation Request > Submit.
   If you have requirements change management enabled, and there has been at least one RCR applied to the selected requirement, see Submitting change requests when requirements change management is enabled (page 53).
   If you decide to cancel the submit operation, close the submit requirements dialog box.
4. In your change management submission form page, type the required information for the CR, and then submit the IR.
   The requested module is automatically saved, and in the Rational DOORS Formal module window, the Implementation Request Status column shows that the requirement status is submitting.
5. Right-click the requirement, and then select Implementation Request > Sync.
   Change Management for Rational DOORS updates the change request attribute columns for the selected requirement. Also, you can submit or add multiple change requests to a requirement.
   See Synchronizing change requests for one requirement (page 55).
Submitting change requests when requirements change management is enabled

Extra steps are required to submit a CR when requirements change management is enabled. These steps are only applicable when at least one RCR has been applied to the selected requirement.

Performing these extra steps ensures that the implementation request addresses all of the appropriate changes made by a given RCR.

To submit change requests when requirements change management is enabled:

1. Follow steps 1 and 2 in Submitting change requests to fulfill requirements (page 52).
   A dialog box listing all of the RCRs that have been applied to the selected requirement opens.

2. Select the RCR you are implementing, and then click **OK**.

3. Select one or more requirements from the list, and then click **OK**.
   The change management submit form opens and displays those requirements that were modified by the RCR selected in step 1 of this procedure.

4. Continue with step 3 in Submitting change requests to fulfill requirements (page 52).
Chapter 6: Implementing Requirements

Showing change requests

In your change management system, you can show the CRs that are related to a requirement. Use your change management show form to view all information contained in the CR.

To show a change request:

1. In Rational DOORS, open the applicable module.
2. Follow the link from the requirement to the CR.

Generating activity reports

You can generate an activity report that shows all module requirements and their associated implementation requests.

To generate an activity report:

1. In Rational DOORS, open the applicable module.
2. On the main menu, select Change Management > Show Activity Report.

Change Management for Rational DOORS generates the report in the background, and the report opens when it is completed.

Adding one or more existing change requests

You can add one or more existing CRs to one or more Rational DOORS requirements.

To add one or more CRs to one or more Rational DOORS requirements:

1. In Rational DOORS, open the applicable module.
2. Right-click the requirement, and then select Implementation Request > Add.

The Add Implementation Request - DOORS dialog box opens.

3. If you decide to cancel the add operation, close the submit requirements dialog box. Then, use the dialog box to choose an IR.

The module is automatically saved. Change Management for Rational DOORS adds the CR IDs to the requirements and updates all CR attribute columns.
**Removing one or more change requests**

You can remove one or more CRs from one or more Rational DOORS requirements by specifying their CR IDs.

To remove one or more CRs from one or more Rational DOORS requirements:

1. In Rational DOORS, open the applicable module.
2. Right-click the requirement, and then select **Implementation Request > Remove**.
   
   The **Remove Implementation Request - DOORS** dialog box opens.
3. Click to select the IR or IRs, and then click **OK**.
   
   Change Management for Rational DOORS removes the CRs from the requirements and updates all CR attribute columns.

**Synchronizing change requests for one requirement**

You can synchronize all CRs in your change management database associated with a Rational DOORS requirement in a module. This operation queries the change management database to find all CRs associated with the requirement and updates all the requirement CR attribute columns.

To synchronize the CRs for one requirement:

1. In Rational DOORS, open the applicable module, and then right-click the requirement.
2. On the menu, select **Implementation Request > Sync**.
   
   Change Management for Rational DOORS updates the values in all CR attribute columns for the selected requirement. Also, this operation synchronizes all objects that are currently selected in Rational DOORS.
**Synchronizing all requirements**

You can synchronize all CRs in your change management database with all Rational DOORS requirements in a module. This operation queries your change management database to find all CRs associated with all the module requirements, and then updates all CR attribute columns for all requirements in the module.

To synchronize all requirements in a module:
1. In Rational DOORS, open the applicable module.
2. On the main menu, select **Change Management > Sync Implementation Requests**.

   Change Management for Rational DOORS updates the values in all CR attribute columns for all requirements in the module.

**Synchronizing all modules**

You can synchronize all modules in your change management database with all Rational DOORS requirements in a module. This operation syncs all implementation requests and RCRs for all modules in the Rational DOORS database that are configured to use Change Management for Rational DOORS.

To synchronize all modules:
1. In Rational DOORS, open the applicable module.
2. On the main menu, select **Change Management > Sync All Modules**.

   Change Management for Rational DOORS updates the values in all IR and RCRs attribute columns for all requirements in all modules.
Performing periodic maintenance

The administrator can perform periodic maintenance to clean up the Rational DOORS database.

Database Cleanup utility

Use the Database Cleanup utility to remove change management data for modules that have been purged or deleted from the Rational DOORS database.

- For each module that has been purged, the change management information is automatically removed.
- For each module that has been deleted but not purged, you can choose whether to clean up the change management information.
- The information that is cleaned up includes configuration information, temporary files, and proposed data.

**Caution** The cleanup process cannot be undone.

To run the Database Cleanup utility:

1. Log on to Rational DOORS as the user *Administrator*.
2. Select **Change Management** > **Database Cleanup** to run the utility.
Notices

© Copyright IBM Corporation 2000, 2011

US Government Users Restricted Rights—Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A. IBM® may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual Property Department in your country or send written inquiries to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions. Therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new
editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice. Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk. IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you. Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

Intellectual Property Dept. for Rational® Software
IBM Corporation
5 Technology Park Drive
Westford, MA 01886
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee. The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us. Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment. Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products. This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.
If you are viewing this information softcopy, the photographs and color illustrations may not appear.

Copyright license

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs. Each copy or any portion of these sample programs or any derivative work, must include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp. (Sample Programs.) © Copyright IBM Corp. 2000 - 2011.

Trademarks


Microsoft, Windows, and/or other Microsoft products referenced herein are either trademarks or registered trademarks of Microsoft Corporation.

Other company, product or service names may be trademarks or service marks of others.
Index

A
activity reports
  generating, 54
  running, 2
  showing module requirements, 54
administrative operations, 49
apply button, 38
applying requirement change requests, 38
associating change requests to requirements, 54
attributes
  adding, 50
  csint_ir_dcterms
    title, 49
  customizing, 44, 49
  mapping, 21
  relabeling, 50
  removing, 50
attributes mappings, defining, 21
Attrs View, updating, 45

C
change comments, entering, 29
change management
  benefits, 3
  capabilities, 1
  configuration, 13, 57
  features, 2
  menus, 4
  obtaining data, 22
  obtaining requirements, 22
  uninstalling, 12
change management server, preparing, 11
change preparation, 12
change requests
  adding existing, 54
  associating to requirements, 54
  removing, 55
  selecting defaults, 28
  showing, 54
  submitting, 27, 52
  submitting, when change management is enabled, 53
configuring
  copying module configurations, 20
  defining configuration templates, 14
  modules, 18
conflicts
  defined, 39
  examples, 39
  report, 40
  resolving, 41
copying module configurations, 20
CR see change requests
csint_ir_dcterms
  description, 49
  shortTitle, 49
  title, 48
csint_ir_oslc
  shortTitle, 48
csint_ir_oslc_cm
  status, 48

D
Database Cleanup utility, 57

I
IBM Customer Support, 7
IR Attrs View
  csint_ir_dcterms
    description, 48
    customizing, 49

L
legal notices, copyright information, 58
M
mapping attributes, 21
module configurations, copying, 20
module statistics, viewing, 36
modules
  configuring, 18
  configuring all, 17
  configuring individually, 16
  identical configuration settings, 20
  opening, 27
  synchronizing all, 56

N	namespace, 45, 50

(notices, legal, 58)

O
operations
  administrative, 49
  requirements implementation, 51
oslc_cm
  status, 49

P
periodic maintenance, 57
preparing change management server, 11
proposed changes, rejecting, 34

R
Rational DOORS
  mapping attributes with CS, 21
  proposing changes, 28
Rational DOORS Web Access, 28, 33
  ActiveX control, 33
  RCRs, 33
  read access security, 33
  rejecting proposed changes, 33
  using to review CRs, 33
RCR and module statistics, 36
RCR Conflicts Report, 40

RCR see Requirements Change Requests
RCR statistics, viewing, 36
recording changes, 28
rejected proposed changes, undoing, 34
rejecting proposed changes, 34
relabeling attributes, 50
removing attributes, 50
reports
  activity, 54
  module statistics, 36
  RCR Conflicts, 40
  RCR statistics, 36
  Requirements Change Request, 35
requirements
  adding change requests, 54
  change in status, 48
  obtaining, 22
  removing change requests, 55
  showing change requests, 54
  submitting change requests, 52
  synchronizing all, 56
  synchronizing one, 56
  tracing, 48
Requirements Change Request
  apply button, 38
  applying, 38
  customizing attributes, 44
  locating, 37
  report, 35
  reviewing, 30
  selecting defaults, 28
  sending to review, 30
  showing, 37
  simultaneously reviewing, 32
  Status View, updating, 45
  submitting, 27
  viewing information about in Rational
  DOORS, 44

Requirements Change Request report
  defined, 35

requirement-specific traceability
operations, 51

S
synchronizing
  all modules, 56
  all requirements, 56
  one requirement, 55

T
templates, defining configuration, 14
tracing implementation of requirements, 48
trademarks, 60

U
undoing changes
  recorded, 29
  unrecorded, 29
undoing rejected proposed changes, 34
uninstalling, 12
upgrading from previous versions, 12