IBM TRIRIGA Anywhere
Version 10 Release 4.1

Planning, installation, and deployment

IBM
## Contents

### Chapter 1. Planning to deploy IBM TRIRIGA Anywhere
- System architecture and components ........................................ 1
- System requirements for IBM TRIRIGA Anywhere, Worklight Server, and Worklight Studio ................. 3
- Deployment topologies ............................................................... 5
  - Development environment .................................................. 6
    - Single-server deployment of IBM TRIRIGA Anywhere and Worklight Server ........................................... 7
    - Multiple-server deployment of IBM TRIRIGA Anywhere and Worklight Server ........................................... 8
- Installation overview .............................................................. 8
- Installation planning worksheet .............................................. 10

### Chapter 2. Installing the IBM TRIRIGA Anywhere components
- Installing Worklight Server .................................................... 11
  - Creating a database instance for use with Worklight Server ............................................................... 11
  - Installing Worklight Server by using the installation program .............................................................. 12
  - Installing Application Center ............................................... 13
  - Configuring Application Center after installation ............................................................... 14
  - Setting up a build server ..................................................... 15
    - Installing the Android development tools ............................................................... 16
    - Installing the iOS development tools ............................................................... 18
  - Installing an integrated development environment ............................................................... 19
- Installing IBM TRIRIGA Anywhere ........................................... 20
- Silent mode: Installing IBM TRIRIGA Anywhere ............................................................... 21
  - Recording a response file for silent installation ............................................................... 21
  - Installing Installation Manager in silent mode ............................................................... 22
    - Parameters for silent mode installation ............................................................... 22
    - Installing TRIRIGA Anywhere in silent mode ............................................................... 23
  - Upgrading IBM TRIRIGA Anywhere ........................................ 24
    - File location changes in version 10.4.1 ............................................................... 24
    - Application definition changes in version 10.4.1 ............................................................... 25
    - Upgrading the integrated development environment ............................................................... 26

### Chapter 3. Building and deploying IBM TRIRIGA Anywhere apps
- Application deployment process for IBM TRIRIGA Anywhere apps ................................................... 29
- Deploying IBM TRIRIGA Anywhere apps to Worklight Server ............................................................... 31
  - Deploying apps from the command line to WebSphere Application Server Liberty profile ............................................................... 31
  - Deploying apps from the command line to WebSphere Application Server full profile ............................................................... 33
  - Deploying apps by using Worklight Studio ............................................................... 34
    - Properties files ............................................................... 35
    - IBM TRIRIGA Anywhere directory structure ............................................................... 36
    - Adding digital signatures to IBM TRIRIGA Anywhere apps ............................................................... 37
    - Deploying apps to a secure server ............................................................... 37
    - Installing IBM TRIRIGA Anywhere apps on mobile devices ............................................................... 37
    - Testing apps ............................................................... 38
      - Setting up the Android emulator ............................................................... 39

### Chapter 4. Uninstalling IBM TRIRIGA Anywhere, Worklight Server, and Worklight Studio
- Notices ............................................................... 43
- Privacy Policy Considerations ............................................................... 44
- Trademarks ............................................................... 45
Chapter 1. Planning to deploy IBM TRIRIGA Anywhere

IBM® TRIRIGA Anywhere must be deployed with selected IBM Worklight® components to an enterprise system that includes Open Services for Lifecycle Collaboration (OSLC) provider capabilities.

Before you install IBM TRIRIGA® Anywhere, read the [IBM Worklight version 6.1.0 Knowledge Center](#). During the IBM TRIRIGA Anywhere installation, you must perform tasks that are outlined in the IBM Worklight Knowledge Center.

To access the documentation, you must have an internet connection.

System architecture and components

IBM TRIRIGA Anywhere and IBM Worklight form a mobile application platform that integrates with the IBM TRIRIGA enterprise system.

The IBM TRIRIGA Anywhere component provides the content that is required to build mobile apps for IBM TRIRIGA. The IBM Worklight components function as middleware by enabling integration with the enterprise system and by supporting the deployment of apps to mobile users.

The IBM TRIRIGA Application Platform version 3.4.1 and IBM TRIRIGA 10.4.1 contain OSLC features to support IBM TRIRIGA Anywhere 10.4.1.

The following figure shows the system architecture of IBM TRIRIGA Anywhere and highlights the relationship between key components in IBM TRIRIGA Application Platform and IBM Worklight.
The following components are deployed when you implement IBM TRIRIGA Anywhere:

**IBM Anywhere Mobile Platform version 7.5.1**
A collection of resources that is required for integration and deployment with Worklight Server. These resources include a project that is compatible with Worklight and an OSLC adapter. The OSLC adapter manages communications between Worklight Server and the provider application, IBM TRIRIGA Application Platform. Before run time, the IBM TRIRIGA Anywhere project .war file, the applications, and the OSLC adapter are deployed to Worklight Server.

**IBM TRIRIGA Anywhere Workplace Operations**
The IBM TRIRIGA Anywhere Workplace Operations product is installed on the same computer as the IBM Anywhere Mobile Platform. The mobile apps can be configured, tested, and deployed to an emulator or a mobile
device. The IBM TRIRIGA Anywhere Work Task Management app is integrated with IBM TRIRIGA to enable mobile workers to access a subset of work task data.

**IBM Worklight Server for Worklight Consumer Edition**

A runtime platform for the OSLC adapter and server-based application components. Worklight Server includes an administrative console and an app store for publishing mobile apps within the organization. Worklight Server is deployed to an application server. In a test environment, the same application server can be used to deploy IBM TRIRIGA Application Platform and Worklight Server.

**IBM Worklight Studio for Worklight Consumer Edition**

An Eclipse-based integrated development environment that can be deployed as an optional component with IBM TRIRIGA Anywhere. You use Worklight Studio to configure and test the mobile app and to manage the build and deployment process.

**Map services**

The map view in the IBM TRIRIGA Anywhere Work Task Management app uses positioning data that is provided by IBM TRIRIGA Application Platform. IBM TRIRIGA Application Platform can be configured to obtain this positioning data from ArcGIS, an external geographic information system. You must be entitled to use the appropriate service from the Esri map service provider.

---

**System requirements for IBM TRIRIGA Anywhere, Worklight Server, and Worklight Studio**

Your environment must meet all of the software and hardware requirements for IBM TRIRIGA Anywhere, Worklight Server, and Worklight Studio.

A complete list of hardware and software requirements for your product is available in the IBM TRIRIGA Application Platform 3.4 Compatibility Matrix. The Worklight system requirements are available in the IBM Support Portal.

Administrative user rights are required for all computers that are used to install IBM TRIRIGA Anywhere 10.4.1.

**Enterprise system**

IBM TRIRIGA Anywhere must be installed with IBM TRIRIGA Application Platform version 3.4.1, fix pack 3.4.1.1, and IBM TRIRIGA version 10.4.1.

The IBM TRIRIGA Application Platform solution delivers an integrated workplace management system that integrates functional models across real estate, capital projects, facilities, workplace operations, portfolio data, and environmental and energy management on a single technology platform.

IBM TRIRIGA Application Platform includes the OSLC queries that the enterprise system requires to support IBM TRIRIGA Anywhere.

**IBM TRIRIGA Anywhere version 10.4.1**

The IBM Anywhere Platform and the TRIRIGA Anywhere Workplace Operations mobile apps must be installed on the same computer.
To configure, build, and deploy the mobile apps, the following prerequisite software must be installed. Install the software for the mobile platform that you use:

- The Oracle Java Development Kit (JDK) is a prerequisite for Android development, and its subcomponent, the Java Runtime Environment (JRE), is required to run Worklight Studio.
- The Android SDK is required to build the IBM TRIRIGA Anywhere apps for Android mobile devices.
- To install mobile apps on iOS devices, a set of Apple-registered accounts is required so that you can build the iOS apps in your environment. If you are setting up a build server on a Mac OS X computer, you must install the iOS development tools first.
- Xcode IDE is required to build the IBM TRIRIGA Anywhere apps so that they can be deployed on iOS mobile devices.
- To set up an integrated development environment, you must install Eclipse IDE for Java™ EE Developers and Worklight Studio.
- To preview the deployed applications in the Worklight Studio mobile browser simulator, you must install Google Chrome.

**IBM Worklight Server version 6.1.0.2**

Worklight Server is required to deploy IBM TRIRIGA Anywhere in a production environment.

You must deploy Worklight Server on a Windows or Linux computer.

Worklight Server must be deployed to a stand-alone application server. The application server can be configured to assign a specific profile to Worklight Server.

For iOS devices that are operating at version 7.1 or later, you must configure the application server to use SSL security.

In a production environment, Worklight Server requires a production-grade database instance. You can configure an existing database server for Worklight Server by creating a database instance or database schemas.

<table>
<thead>
<tr>
<th>Application servers</th>
<th>IBM WebSphere® Application Server Liberty</th>
<th>IBM WebSphere Application Server</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Apache Tomcat</td>
<td></td>
</tr>
<tr>
<td>Databases</td>
<td>Apache Derby. Included in the installation image. Apache Derby is supplied for evaluation and testing purposes only and is not a production-grade database.</td>
<td>IBM DB2®</td>
</tr>
<tr>
<td></td>
<td>Oracle Database</td>
<td>MySQL Database</td>
</tr>
</tbody>
</table>

For compatible version numbers, see the Supported Software tab on the IBM Worklight 6.1.0 Software Product Compatibility Report.

**Restrictions:**

- The Mac OS X operating system does not support Worklight Server. You can install Worklight Studio on a Mac OS X development environment, but you must deploy Worklight Server to a computer with a different operating system.
• Worklight Server does not support Oracle WebLogic Server. If your enterprise environment runs WebLogic Server, install one of the supported application servers to host Worklight Server.

• Worklight Server does not support Microsoft SQL Server.

• IBM WebSphere Application Server and IBM WebSphere Application Server Liberty do not support MySQL Database.

**IBM Worklight Studio version 6.1.0.2**

You must install Oracle JDK before you install Worklight Studio. The Oracle JDK includes the Java Runtime Environment (JRE), which Worklight Studio requires to build the IBM TRIRIGA Anywhere applications.

To configure the mobile apps, install the required development tools in combination with Worklight Studio. For more information, see Installing an integrated development environment.

**Mobile devices**

The IBM TRIRIGA Anywhere mobile apps can be deployed to Android or iOS mobile devices. In a development environment, you can also test the apps in the Worklight Studio mobile browser simulator, the Android Emulator, or the iOS Simulator.

For a full list of operating systems and supported screen sizes, see the [IBM TRIRIGA Application Platform 3.4 Compatibility Matrix](#).

**Related information:**

- [System requirements for IBM Worklight (see version 6.1)](#)

**Deployment topologies**

A development environment is created by installing IBM TRIRIGA Anywhere and Worklight Studio on the same computer. A production environment is created by installing IBM TRIRIGA Anywhere and Worklight Server in a single-server or multiple-server deployment.

You use a development environment to configure and test the IBM TRIRIGA Anywhere mobile apps before they are deployed to the production server. A test instance or a development instance of IBM TRIRIGA Application Platform is required, either on the same computer or on a remote computer.

A single-server deployment features IBM TRIRIGA Anywhere and Worklight Server installed on the same computer. With a single-server deployment, you can set up a pre-production test environment or a small-scale production environment. A pre-production instance of IBM TRIRIGA Application Platform is also required, either on the same computer or on a remote computer. The pre-production instance of IBM TRIRIGA Application Platform must closely match the production environment so that the application configurations can be tested before you move to a production environment.

For medium and large enterprises, creating a production environment involves installing the components on more than one computer. Worklight Server must first be deployed to a standalone application server. A production instance of IBM TRIRIGA Application Platform must be available on a different computer than the IBM TRIRIGA Anywhere and Worklight components.
Worklight Studio is an optional integrated development environment. If you want to use Worklight Studio to test, configure, and build the IBM TRIRIGA Anywhere applications, you must install it on the same computer as the IBM TRIRIGA Anywhere component.

The IBM TRIRIGA Anywhere computer functions as a build server from which the application build and deployment processes are run.

**Development environment**

A development environment can be used to configure, test, and build the IBM TRIRIGA Anywhere mobile apps before they are deployed to a production environment.

To create a development environment, you install Worklight Studio and IBM TRIRIGA Anywhere on a single computer. A test instance or a development instance of IBM TRIRIGA Application Platform is also required, either on the same computer or on a remote computer.

```
+----------------+-------------------+----------------+
| IBM TRIRIGA Application Platform |
| IBM Worklight Studio               |
| IBM TRIRIGA Anywhere               |
```

*Figure 2. A IBM TRIRIGA Anywhere development environment*

Worklight Studio is an Eclipse-based integrated development environment. You must install Worklight Studio within an existing Eclipse client. Update your Eclipse environment by installing the development tools for your mobile platform.

**Example: Creating an Android development environment**

Dale is a system administrator who is responsible for implementing IBM TRIRIGA Anywhere in his enterprise. He wants to test and configure the IBM TRIRIGA Anywhere apps before he deploys them to the production environment. To do this, he designates one computer as a development environment.

Before Dale begins, he prepares the enterprise system to support IBM TRIRIGA Anywhere.

He creates a test instance or a development instance of IBM TRIRIGA Application Platform and backs up the system.

Dale installs Oracle JDK, Android SDK, and Eclipse on the target computer. He then installs Worklight Studio and uses the launchpad to install IBM TRIRIGA Anywhere.

When the installation is complete, Dale can configure and test the IBM TRIRIGA Anywhere mobile apps. He can build the apps and deploy them to the Android Emulator.
Single-server deployment of IBM TRIRIGA Anywhere and Worklight Server

For small enterprises, a single-server deployment can be used for production purposes. Larger enterprises can use a single-server deployment as a pre-production test environment.

To create a single-server deployment, you install Worklight Server and IBM TRIRIGA Anywhere on a single computer. A test instance or a production instance of IBM TRIRIGA Application Platform is also required, either on the same computer or on a remote computer.

![Diagram of IBM TRIRIGA Application Platform, Worklight Server, and IBM TRIRIGA Anywhere]

Figure 3. A single-server deployment of IBM TRIRIGA Anywhere and Worklight Server.

You can configure an instance of WebSphere Application Server, WebSphere Application Server Liberty, or Apache Tomcat for use with Worklight Server.

You can also configure an existing production database, such as DB2, Oracle Database, or MySQL Database. Worklight Server includes a test database, Apache Derby.

To configure the IBM TRIRIGA Anywhere applications for your organization, you modify the properties files and the application definitions. You can build, deploy, and preview the mobile apps in the Worklight Console. You can then deploy the apps to the Application Center where mobile workers can download them to a mobile device.

Example: Creating a single-server deployment

Ian is a system administrator who is responsible for implementing IBM TRIRIGA Anywhere in a small enterprise. He wants to create a small-scale production environment.

Ian performs any necessary backup of the system and sets up a production instance of IBM TRIRIGA Application Platform.

He creates a production database instance on the IBM TRIRIGA Application Platform database server.

On the computer where IBM TRIRIGA Application Platform is installed, he installs Worklight Server and IBM TRIRIGA Anywhere.

When the installation is complete, Ian can manually build and deploy the IBM TRIRIGA Anywhere apps to the Application Center. He can download the apps to a mobile device and test the functions of the apps.
Multiple-server deployment of IBM TRIRIGA Anywhere and Worklight Server

A multiple-server deployment is suitable for medium and large enterprises and is deployed by installing IBM TRIRIGA Anywhere and Worklight Server on separate computers. A production instance of IBM TRIRIGA Application Platform on a remote computer is also required.

If you use WebSphere Application Server as the enterprise application server, you can create a new profile for Worklight Server. You must also create a database instance or multiple database schemas on the enterprise database server.

The IBM TRIRIGA Anywhere build server is used to configure, build, and deploy the apps to Worklight Server. Mobile workers can then download the apps to their mobile devices from the Application Center.

Example: Creating a multiple-server deployment

Ian is a system administrator who is responsible for implementing IBM TRIRIGA Anywhere in a production environment.

Before he begins, he creates a database instance or multiple database schemas on the production database server. Worklight Server can be configured to share the existing database server with the enterprise system.

On a designated host computer, Ian installs Worklight Server with WebSphere Application Server Liberty or a new instance of WebSphere Application Server.

On a separate computer, he installs IBM TRIRIGA Anywhere and specifies the host name of the Worklight Server computer.

When the installation is complete, Ian can build and deploy the IBM TRIRIGA Anywhere apps to the Application Center. He can download the apps to a mobile device and test the functions of the apps.

Related information:

Typical topologies of an IBM Worklight instance

Installation overview

The IBM TRIRIGA Anywhere installation involves preparing target computers and existing middleware for installation, and installing IBM TRIRIGA Anywhere and the Worklight components.

The IBM TRIRIGA Anywhere launchpad is a centralized interface where you can start the installation programs. IBM TRIRIGA Anywhere and Worklight Server are installed by using IBM Installation Manager. Installation Manager is a tool that guides you through the installation of IBM products.

On the IBM TRIRIGA Application Platform enterprise system computer, ensure that version 3.4.1 is installed with fix pack 3.4.1.1.

Before you install IBM TRIRIGA Anywhere and Worklight Server, you must set up a stand-alone application server and a database instance.
If your enterprise environment runs IBM WebSphere Application Server, you can create a profile for Worklight Server.

You must prepare the IBM TRIRIGA Anywhere build server by installing prerequisite development tools. Worklight Studio is an optional component and can be installed as part of the Eclipse integrated development environment (IDE) workbench. For Android app development, the Android SDK and the Oracle JDK are both required to build the mobile apps. For iOS app development, XCode is required on a Mac OS X computer.

Administrative user rights are required to install all of the components that are delivered with IBM TRIRIGA Anywhere version 10.4.1. You must have root user authorization for UNIX and Linux systems.

**IBM TRIRIGA Anywhere, Worklight Server, and Worklight Studio**

Before you install IBM TRIRIGA Anywhere and the Worklight components, you must install prerequisite software and configure the database server.

In most production environments, Worklight Server is installed on a different computer than IBM TRIRIGA Anywhere. You must deploy Worklight Server to an application server before you install IBM TRIRIGA Anywhere. You can install Worklight Studio and IBM TRIRIGA Anywhere on the same target computer and streamline the configuration and testing of the mobile apps before they are deployed.

**Silent installation**

A silent installation is useful for installing IBM TRIRIGA Anywhere and Worklight Server in the following scenarios:

- You are installing the components on a group of computers that are configured in the same way.
- You are installing the components on a production server that is behind a firewall. The use of remote desktop access software can be restricted by firewalls, so system administrators can be prevented from using the launchpad to install the components.
- You are installing the components on a computer that cannot display an Eclipse user interface.

Silent installation eliminates the need to use the graphical user interface (GUI) of the installation program to collect installation data. You can run a silent installation of IBM TRIRIGA Anywhere, Worklight Server, and Installation Manager from a command line.

Silent installations that are conducted with Installation Manager are defined by an XML response file. The response file can be used to install, update, and uninstall products.

You can use the Installation Manager GUI to record installation preferences and actions in a response file. By default, a response file is not recorded, so you must enable the recording by setting the `record` environment variable to `true` before you start the launchpad.
## Installation planning worksheet

Use the planning worksheet to record the information that you need during the installation process, such as system settings, properties, and user names.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Default</th>
<th>Example</th>
<th>Your value</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM TRIRIGA Anywhere installation directory</td>
<td>Windows: <code>C:\IBM\TRIRIGAAnywhere</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>UNIX and Linux: <code>opt/ibm/TRIRIGAAnywhere</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Worklight Server installation directory</td>
<td>Windows: <code>C:\Program Files\IBM\Worklight for WL Server</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>UNIX and Linux: <code>/opt/IBM/Worklight</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Worklight Console protocol</td>
<td>On Windows: <code>http</code></td>
<td><code>hostname.yourdomain.com</code> or <code>1.234.567.89</code> or <code>localhost</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td>On Mac OS X: <code>https</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Worklight Console host name</td>
<td></td>
<td></td>
<td><code>hostname.yourdomain.com</code> or <code>1.234.567.89</code> or <code>localhost</code></td>
</tr>
<tr>
<td>Worklight Console port</td>
<td>10080</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Application Center protocol</td>
<td>On Windows: <code>http</code></td>
<td><code>hostname.yourdomain.com</code> or <code>1.234.567.89</code> or <code>localhost</code></td>
<td></td>
</tr>
<tr>
<td></td>
<td>On Mac OS X: <code>https</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Application Center host name</td>
<td></td>
<td></td>
<td><code>hostname.yourdomain.com</code> or <code>1.234.567.89</code> or <code>localhost</code></td>
</tr>
<tr>
<td>Application Center port</td>
<td>On Windows, UNIX, and Linux: 9080</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>On Mac OS X: <code>none</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Application Center user name</td>
<td><code>appcenteradmin</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Application Center password</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Android platform directory</td>
<td><code>C:\Users\Administrator\Downloads\android-sdk_r22.6.2-windows\android-sdk-windows\platforms\android-19</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Oracle JDK directory</td>
<td><code>Windows: C:\Program Files\Java</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>UNIX and Linux: <code>/usr/java</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IBM TRIRIGA Application Platform Server protocol</td>
<td><code>http</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IBM TRIRIGA Application Platform Server host name</td>
<td><code>hostname.yourdomain.com</code> or <code>1.234.567.89</code> or <code>localhost</code></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IBM TRIRIGA Application Platform Server port</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>IBM TRIRIGA Application Platform Server context root</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Chapter 2. Installing the IBM TRIRIGA Anywhere components

The combination of IBM TRIRIGA Anywhere and Worklight components that you install depends on the type of environment that you want to set up.

Installing Worklight Server

Before you install Worklight Server, decide whether to create a database instance for Worklight Server automatically or manually. You can use the installation program to automatically create a database instance for the Worklight Server environment. By using the manual method, you can also create database schemas on a single instance. You must configure the application server to add the databases that you created.

Creating a database instance for use with Worklight Server

If you want to create databases manually before you install Worklight Server, complete the following steps. Otherwise, use the installation program to set up the Worklight Server database. You can manually create a database instance or multiple database schemas for Worklight Server. The Worklight Server database instance can share the enterprise database server.

About this task

A multiple-instance database environment is one where a database server is configured with distinct database instances for connectivity and storage of data. A multiple-schema database environment is one where a single database instance is configured and database objects, such as tables and indexes, are set up under unique users or owners. In a multiple-schema configuration, there is only one database, but owners within that database have access to different objects.

Database instances can be created manually or they can be created by running Ant tasks. During installation of Worklight Server, you can select not to install Application Center. If you do not install Application Center, only the Worklight Server files and the SQL scripts are installed. The SQL scripts can be used to create database instances and schemas. When the database is configured for Worklight Server, restart the installation and install Application Center.

If you want to use Ant tasks, you must ensure that the database account can be accessed through a Secure Shell server (SSH). On Windows computers, DB2 provides IBM Secure Shell Server for Windows as part of its installation. Oracle Database customers must install cygwin and the openssh package separately. For information about setting up an SSH client, see the documentation for your database.

Worklight Server includes Apache Derby for evaluation and testing purposes only. Apache Derby is suitable only in a development environment; it is not a production-grade database.

The IBM Worklight 6.1.0 IBM Knowledge Center provides the instructions for creating a database instance or multiple database schemas.
**Procedure**

Create a database instance for Worklight Server, either automatically with Ant tasks or manually by completing the following steps:

| DB2: | 1. Create the DB2 databases  
2. Set up your DB2 databases manually  
3. Configure the application server for DB2:  
   - Configure Liberty Profile for DB2 manually  
   - Configure WebSphere Application Server for DB2 manually  
   - Configure Apache Tomcat for DB2 manually |
| MySQL Database: | 1. Create the MySQL Database  
2. Set up your MySQL Database manually  
3. Configure the application server for MySQL Database:  
   - Configure Liberty Profile for MySQL Database manually  
   - Configure WebSphere Application Server for MySQL Database manually  
   - Configure Apache Tomcat for MySQL Database manually |
| Oracle Database: | 1. Create the Oracle Database  
2. Set up your Oracle Database manually  
3. Configure the application server for Oracle Database:  
   - Configure Liberty Profile for Oracle Database manually  
   - Configure WebSphere Application Server for Oracle Database manually  
   - Configure Apache Tomcat for Oracle Database manually |

**Installing Worklight Server by using the installation program**

Worklight Server consists of two main components: Application Center and Worklight Console. You must deploy Worklight Server to a stand-alone application server.

**Before you begin**

- If your enterprise environment does not include an application server, install one of the application servers that Worklight supports.
- If you are using WebSphere Application Server in your enterprise environment, create a new profile for Worklight Server.
- To deploy Worklight Server to a stand-alone database server, either create a separate database instance or create new database schemas for Worklight Server. Configure your application server to use the database instance or schemas that you created.
- Ensure that an instance of IBM TRIRIGA Application Platform is accessible from the target computer.
About this task

During installation, you can postpone the installation of Application Center. If you choose this option, you can install the Worklight Server files and the SQL scripts that are needed to create database instances and schemas. When the database is configured for Worklight Server, restart the installation and install Application Center.

When you start Installation Manager, you can check for the latest fix packs. Your IBM login credentials are required to access the fix pack download site.

**Restriction:** Worklight Server is not supported on Mac OS X systems.

**Procedure**

1. Start the launchpad by double-clicking the launchpad file. If your computer is a 64-bit system, use the launchpad64 file.
3. Complete the installation wizard.
4. If you installed the Application Center, you can verify the installation. In the address bar, enter the Application Center URL, where the variables are the values you specified during the installation: `http://host_name:port/appcenterconsole/applications/Applications.html`

**What to do next**

In certain circumstances, you might be required to [restart the application server](#).

**Related information:**
- [Running IBM Installation Manager](#)
- [Distribution structure of Worklight Server](#)

**Installing Application Center**

You can install Application Center during Worklight Server installation or you can perform a manual installation. The database server must be configured for Application Center.

**Procedure**

1. Install Application Center either [automatically](#) or [manually](#).
2. Configure the database either [automatically with Ant tasks](#) or manually:
### What to do next

**Deploy the IBM TRIRIGA Anywhere apps to Worklight Server**

### Configuring Application Center after installation

To make the mobile client and the apps available to mobile workers, you must perform configuration tasks after you install Application Center.

**Procedure**

1. **Configure access to Application Center** for administrative users and end users. You must configure user authentication and choose an authentication method.

---

<table>
<thead>
<tr>
<th>Database Type</th>
<th>Tasks</th>
</tr>
</thead>
</table>
| **DB2**       | 1. Create the DB2 database for Application Center  
                2. Configure the database for Application Center manually:  
                • Set up your DB2 database manually for Application Center  
                • Configure Liberty Profile for DB2 manually for Application Center  
                • Configure WebSphere Application Server for DB2 manually for Application Center  
                • Configure Apache Tomcat for DB2 manually for Application Center  |
| **MySQL Database** | 1. Create the MySQL database for Application Center  
                     2. Configure the database for Application Center manually:  
                     • Set up your MySQL database manually for Application Center  
                     • Configure Liberty Profile for MySQL manually for Application Center  
                     • Configure WebSphere Application Server for MySQL manually for Application Center  
                     • Configure Apache Tomcat for MySQL manually for Application Center  |
| **Oracle Database** | 1. Create the Oracle database for Application Center  
                       2. Configure the database for Application Center manually:  
                       • Set up your Oracle database manually for Application Center  
                       • Configure Liberty Profile for Oracle manually for Application Center  
                       • Configure WebSphere Application Server for Oracle manually for Application Center  
                       • Configure Apache Tomcat for Oracle manually for Application Center  |
2. **Optional:** Manage users by using the Lightweight Directory Access Protocol (LDAP) registry.

3. If you are using WebSphere Application Server, add the mobile apps to the repository by using the administration console. When you add a mobile app from the administration console, the server component creates Uniform Resource Identifiers (URI) for the app resources (package and icons). The mobile client uses these URI to manage the apps on your device.

4. Build the IBM TRIRIGA Application Platform apps and deploy them as a Worklight project.

**Related tasks:**

- Adding a mobile application

**Application Center**

The Application Center is an enterprise app store that you can use for deploying the IBM TRIRIGA Anywhere apps to mobile devices in your organization. Application Center is automatically installed with Worklight Server. Application Center is composed of a server component, a repository, the Application Center console, and a mobile client app.

**Server component**

The server component is a Java Enterprise application that must be deployed in a web application server, such as WebSphere Application Server.

The server component consists of an administration console and a mobile client. The mobile client installs the apps that are available to the client component.

Several services compose the Application Center server component, such as a service that lists the available apps, and a service that delivers the app binary files to the mobile device.

**Repository**

The repository stores the apps that can be installed on mobile devices. The repository is a database that also stores information, such as feedback about the apps, and the amount of storage that an app uses.

**Application Center console**

The Application Center console is a web application that is used to manage the repository. You must have system administrator privileges to access the Application Center console.

**Mobile client**

The mobile client runs on mobile devices and is used to install the apps that reside in the repository.

**Related concepts:**

- The Application Center console
Setting up a build server

A build server is the computer on which the IBM TRIRIGA Anywhere mobile app build and deployment process is run. If you are not installing an integrated development environment, the build and deployment process is run by using commands.

Before you begin

On the computer where IBM TRIRIGA Application Platform version 3.4.1 is installed, apply fix pack 3.4.1.1.

About this task

To build and deploy the apps to iOS mobile devices, your build server must be a Mac OS X computer.

Restriction: Worklight Server is not supported on Mac OS X systems.

Procedure

1. Prepare the build server for building the mobile apps:

<table>
<thead>
<tr>
<th>Platform</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Android</td>
<td>Install the Android development tools</td>
</tr>
<tr>
<td>iOS</td>
<td>Install the iOS development tools</td>
</tr>
</tbody>
</table>

2. Optional: Install an integrated development environment

3. Install IBM TRIRIGA Anywhere.

<table>
<thead>
<tr>
<th>Platform</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows, Linux, or UNIX</td>
<td>Install IBM TRIRIGA Anywhere  Do not install Worklight Server.</td>
</tr>
<tr>
<td>Mac OS X</td>
<td>The launchpad program is not supported on Mac OS X. Install IBM TRIRIGA Anywhere:</td>
</tr>
<tr>
<td></td>
<td>1. From the IBM TRIRIGA Anywhere installation image, open the Install &gt; IM folder and expand the installer.macOS compressed file.</td>
</tr>
<tr>
<td></td>
<td>2. Ensure that the path to the Userinst executable file does not contain any spaces or parentheses. Double-click the Userinst executable file.</td>
</tr>
<tr>
<td></td>
<td>3. Complete the installation wizard.</td>
</tr>
</tbody>
</table>

Installing the Android development tools

Oracle JDK and Android SDK are required to build Android mobile apps.

Procedure

1. Install Oracle JDK version 7.0.
   a. From the Oracle Java SE downloads page, download the Java SE Development Kit for your operating system.
   b. Run the executable file and proceed through the installation program.
c. Set the `JAVA_HOME` environment variable and specify the path to the directory where the JDK was installed:

<table>
<thead>
<tr>
<th><strong>Windows</strong></th>
<th><strong>Linux or UNIX</strong></th>
</tr>
</thead>
</table>
| 1. Go to your computer’s Advanced System Settings.  
2. On the Advanced tab, click **Environment Variables**.  
3. Under System Variables, click **New**.  
4. Specify `JAVA_HOME` as the variable name and enter the path to the JDK installation directory as the variable value.  
   Environment variable values cannot be separated by a space. If the Java installation directory contains a space in the path name, specify the shortened path name. For example, on Windows operating systems, enter `C:\Program Files\Java\jdk1.7.0_55`  
5. Close all open windows.  
6. Verify that the `JAVA_HOME` system environment variable is defined by opening a new command prompt and running the following command:  
   ```bash
   SET JAVA_HOME
   ```  
   A value is returned such as:  
   ```bash
   JAVA_HOME=C:\Program Files\Java\jdk1.7.x
   ``` |
| 1. At a command line, run the following command:  
   ```bash
   vi ~/.bash_profile
   ```  
2. Set the variables by running the following command and replacing the `java_path` variable with the Java path that you specified:  
   ```bash
   export JAVA_HOME=java_path  
   export PATH=$JAVA_HOME/bin:$PATH
   ```  
3. Save and close the `.bash` profile, and run the following command to apply the changes:  
   ```bash
   source ~/.bash_profile
   ```  
4. Verify that the `JAVA_HOME` system environment variable is defined by opening a new command line and running the following command:  
   ```bash
   echo $JAVA_HOME
   ``` |

2. Install the Android SDK:  
   a. Go to the [Android developers’ website](https://developer.android.com) and click **Download for other platforms**.
b. In the SDK Tools Only section, download the SDK for your operating system and extract the compressed file on your computer.

c. From the extracted directory, run the SDK Manager.exe file.

d. Under Tools, select Android SDK Tools Revision 22 or later and the latest Android SDK build tools. Also select an Android package with an API of 18 or 19 and click **Install Packages**.

3. Optional: **Install an integrated development environment**.

4. If you installed Eclipse in step 3, install the Android Development Tools (ADT) plug-in:
   a. In Eclipse, select **Help > Install New Software > Add**.
   b. In the Add Repository window, specify the following URL in the **Location** field: https://dl-ssl.google.com/android/eclipse/.
   c. In the **Name** field, specify Android Development Tools and click **OK**.
   d. On the Available Software pane, click **Select All > Next > Next > Finish**.
   e. Restart Eclipse and specify a workspace directory.
   f. Open the Eclipse Preferences window and specify the Android SDK path. Click **Apply > OK** to apply the changes.
   g. On the Welcome to Android Development pane, select **Use existing SDKs** and browse to the SDK directory. Click **OK > Next > Finish**.

**Installing the iOS development tools**

For iOS app development, you use your Apple ID to enroll in a developer program.

**About this task**

You can enroll in the iOS Developer Program as an individual or a company where an individual is considered a one-person team.

You can also enroll in the iOS Developer Enterprise Program as a company, which authorizes you to create proprietary in-house iOS apps. The procedure for setting up the iOS Developer Enterprise account might include extra steps. For more information, see the installation release notes.

The person who creates the team becomes the **team agent**; the legal contact and administrator of the team who has all privileges and full access to Member Center and iTunes Connect. The team agent is required to complete steps 6-8. iOS developers might require the assistance of the team agent to complete the procedure.

**Procedure**

1. **Create an Apple ID** by registering as an Apple developer in the **Apple Registration Center**.
2. Download and install Xcode IDE, including the iOS SDK and Simulator, from the **Mac App Store**.
3. **Add your Apple ID to Xcode**.
4. In Xcode, **create a Developer Certificate**.
5. Download the Developer Certificate and **add it to the Keychain application**.
6. **Register the App IDs**
   You must register the App IDs as wildcards. When you create the App IDs, select Wildcard App ID and enter the bundle ID.
The bundle ID for WorkTaskManagement is `com.WorkTaskManagement*`.

7. **Register the Device IDs in Member Center** You can locate the unique device identifier (UDID) by connecting your device to the Mac OS X computer while Xcode or iTunes are running.

8. **Create the provisioning profiles for each app using Member Center** The provisioning profiles for the apps must contain the IDs of the devices on which the app is installed. You can register more iOS devices and add them to the provisioning profiles. You must download the provisioning profile to the build server every time the profile is updated.

9. As the developer, generate the provisioning profiles and then download the profiles to your Mac OS X computer. Open each provisioning profile in Xcode. The provisioning profiles are added to the system library at the following location: `~/Library/MobileDevice/Provisioning Profiles/*`. When you run the app build and deployment process, the provisioning profiles are collected and stored in the iOS application archive file (IPA).

---

**Installing an integrated development environment**

To create a development environment, install a set of development tools on the build server. You can use an integrated development environment to test and configure mobile apps before you deploy them to mobile devices.

**Before you begin**

- **Set up a build server** for your build environment.
- **Install the development tools for the Android or iOS mobile platform.** A provisioning profile is required to install IBM TRIRIGA Anywhere on Mac OS X computers.
- **To preview the apps in the Worklight Studio mobile browser simulator, install Google Chrome.**

**About this task**

Worklight Studio is an Eclipse-based development environment that can be used to configure the IBM TRIRIGA Anywhere apps. You install Worklight Studio from the Eclipse integrated development environment (IDE) workbench. A set of platform development tools are also required to build and deploy the mobile apps.

You can use the mobile browser simulator, the Android Emulator, or the iOS Simulator to view and test the mobile apps.

You can customize the mobile apps when they are deployed. For more information, see [Configuring IBM TRIRIGA Anywhere mobile apps](#).

**Procedure**

1. **Install Eclipse IDE:**
   a. Go to [www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/keplersr1](http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/keplersr1) and download Eclipse IDE for Java EE Developers version 4.3.2 (Kepler) for your operating system.
   b. Extract the compressed folder and run the Eclipse application to install the software.

2. **Set up your Eclipse development environment:**
a. Check whether the Eclipse JSDT plug-in is installed. The JavaScript Development Tool (JSDT) plug-in helps you navigate through the JavaScript code in Eclipse.

1) Select Help > About Eclipse and click Eclipse Web Tools Platform (WTP)

b. If the JavaScript Development Tools plug-in is not already installed, complete the following steps:

1) Select Help > Install New Software > Add.
2) In the Add Repository window, specify the following URL in the Location field: http://download.eclipse.org/webtools/repository/kepler.
3) In the Name field, specify Eclipse WTP.
4) Select Web Tools Platform (WTP) 3.5.1 (or later) > JavaScript Development Tools and install the plug-in.

c. Set Google Chrome as the default web browser by selecting Window > Preferences > General > Web Browser > Use external web browser. Select the Chrome check box and click OK to apply your changes.

3. Install Worklight Studio Consumer Edition:

   a. In Eclipse, select Help > Install New Software > Add.
   b. In the Add Repository window, click Archive.
   c. Browse to the location of the WorklightStudio.6.1.0.2-IF2.zip file in the IBM TRIRIGA Anywhere installation image and click Open > OK.
   e. Restart Eclipse to apply the changes.

4. Import the TRIRIGAAnywhere project into Worklight Studio.

   a. In Eclipse, click File > Import > General, select Existing Projects into Workspace and click Next.
   b. Click Select root directory and specify the path to \ibm\TRIRIGAAnywhere.
   c. Select the TRIRIGAAnywhere project and click Copy projects into workspace. Click Finish.
   d. In the Project Explorer pane, expand all nodes. Right-click the OSLCGenericAdapter folder and select Run As > Deploy Worklight Adapter.
   e. Right-click the application folder and click Run As > Run on Worklight Development Server.
   f. To preview the app, right-click the application folder and click Run As > Preview.

What to do next

Deploy a mobile app from the development environment to a test or production environment.

Installing IBM TRIRIGA Anywhere

The IBM TRIRIGA Anywhere component is the key component in any IBM TRIRIGA Anywhere environment.
Before you begin

- If you intend to install Worklight Server and IBM TRIRIGA Anywhere on separate computers, you must install Worklight Server first.
- If you are setting up a build server on Mac OS X, you must first install a set of development tools for the iOS mobile platform. A provisioning profile is required to install IBM TRIRIGA Anywhere on Mac OS X computers.

About this task

Restriction: The launchpad program is not supported on Mac OS X.

When you start Installation Manager, you can check for the latest fix packs. Your IBM login credentials are required to access the fix pack download site.

Procedure

1. Start the launchpad by double-clicking the launchpad file. If your computer is a 64-bit system, use the launchpad64 file.
3. If you are installing IBM TRIRIGA Anywhere as a new deployment, then click Install.
4. If you are updating an existing deployment of IBM TRIRIGA Anywhere, then click Update. On the Update Packages pane, select TRIRIGAAnywhere.
5. Complete the installation wizard to install IBM TRIRIGA Anywhere and the mobile apps.
6. Verify that IBM TRIRIGA Anywhere was successfully installed by testing the build and deployment process.
7. Log in to IBM TRIRIGA Application Platform and add mobile users to the Service Technician group.

Silent mode: Installing IBM TRIRIGA Anywhere

You can run a silent installation of IBM TRIRIGA Anywhere, Worklight Server, and Installation Manager from a command line. Silent installations that are conducted with Installation Manager are defined by an XML response file.

Recording a response file for silent installation

A response file collects data and records the selections that you make when you use the Installation Manager. If you want to run a silent installation, you must record the installation settings.

About this task

When you use the Installation Manager to install the components, an XML response file is recorded. The response file can be used for future silent installations of IBM TRIRIGA Anywhere and Worklight Server. The response file is overwritten with each subsequent use of the installation program.

To record a response file, set the record environment variable to true before you start the launchpad. Alternatively, if you want to run the installation program from a command line, use the -record parameter.
Procedure
1. Open a command line and run the following command:

<table>
<thead>
<tr>
<th>Platform</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>On Windows</td>
<td>set record=true</td>
</tr>
<tr>
<td>On UNIX or Linux</td>
<td>export record=true</td>
</tr>
</tbody>
</table>

2. Start the TRIRIGA Anywhere launchpad and proceed with the installation.
3. Click Finish. A response file is generated in the user home directory. The response file is marked with a time stamp, for example, tpaet rsp20130716105150.xml.

Installing Installation Manager in silent mode
Installation Manager is the tool that is used to install IBM TRIRIGA Anywhere and Worklight Server. Installation Manager can itself be installed in silent mode.

About this task
The Installation Manager folder includes the silent-install.ini initialization file, which contains default parameters and values that are required for silent installation. You can use the initialization file to set the values for the silent installation process. A range of parameters can be modified in the silent-install.ini file.

Procedure
1. Browse to the Install\IM folder of the IBM TRIRIGA Anywhere installation image and copy the Installation Manager folder for your system to a local directory. For example, copy the installer.win64 if your computer is running a Windows 64-bit operating system.
2. Optional: To modify the installation parameters, edit the silent-install.ini file.
3. From a command line, change to the directory where you copied the Installation Manager folder and run one of the following commands. Specify the path and the name of the log file that you want to create:

<table>
<thead>
<tr>
<th>Platform</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>installc.exe --launcher.ini silent-install.ini -log logfilename-acceptLicense</td>
</tr>
<tr>
<td>UNIX or Linux</td>
<td>./installc --launcher.ini silent-install.ini -log logfilename-acceptLicense</td>
</tr>
</tbody>
</table>

For example, run the following command for Windows:
installc.exe --launcher.ini silent-install.ini -log C:\tmp\silent_install_log.xml -acceptLicense

Related information:
- Install Installation Manager silently

Parameters for silent mode installation
You can modify the silent-install.ini initialization file by updating the parameters for your environment.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-vm</td>
<td>Specifies the Java launcher. In silent mode, always use java.exe on Windows, and java on other operating systems.</td>
</tr>
<tr>
<td>-nosplash</td>
<td>Suppresses the splash screen.</td>
</tr>
<tr>
<td>--launcher.suppressErrors</td>
<td>Suppresses the JVM error dialog.</td>
</tr>
<tr>
<td>-silent</td>
<td>Runs the Installation Manager program in silent mode.</td>
</tr>
<tr>
<td>-input</td>
<td>Specifies that an XML response is used as the input for the Installation Manager program.</td>
</tr>
<tr>
<td>-log</td>
<td>Generates a log file that records the result of the silent installation. The log file is an XML file, for example, c:\mylogfile.xml or /root/mylogs/mylogfile.xml</td>
</tr>
</tbody>
</table>

**Installing TRIRIGA Anywhere in silent mode**

You can generate a response file by completing a successful installation of IBM TRIRIGA Anywhere with the Installation Manager. Alternatively, you can use a sample response file that is provided in the samples directory of the IBM TRIRIGA Anywhere compressed folder.

**Before you begin**

Installation Manager must be installed on the target computer.

Copy a generated response file or a sample response file with the necessary changes to the target computer.

A sample response file is provided for your operating system in the samples folder of the IBM TRIRIGA Anywhere installation image.

For Mac OS X installations, use the response_install_TRIRIGA_Anywhere_Only_MAC.xml response file. For all other operating systems, use the response_install_TRIRIGA_Anywhere_Only.xml response file.

To encrypt passwords before you install IBM TRIRIGA Anywhere in silent mode, use the Installation Manager `imutilsc commands`. The encrypted password must be copied into the response file that you use to install IBM TRIRIGA Anywhere.

**About this task**

You can copy the IBM TRIRIGA Anywhere response file to multiple computers to run silent installations. However, ensure that all values in the response file are valid for the target system.

**Procedure**

1. Open the response file for editing and modify the values for your operating system. Ensure that the value for the repository location is correct.
2. Change directory to the tools directory where Installation Manager was installed and run the following command:
imcl -silent -input responsefilename -log logfilename -acceptLicense

Specify the path and name of the existing response file and log file that you want to use. The -acceptLicense parameter is used to accept the license automatically. For example, on Windows, run the following command:
imcl -silent -input C:\tmp\response_install_Worklight_and_Anywhere.xml -log C:\tmp\silent_install_log.xml -acceptLicense

---

### Upgrading IBM TRIRIGA Anywhere

To upgrade IBM TRIRIGA Anywhere to version 10.4.1 you must upgrade the server, upgrade the development environment, and migrate the artifact customizations.

#### Procedure

1. Upgrade the server.
   a. On the computer where IBM TRIRIGA Application Platform is installed, apply fix pack 3.4.1.1.
   b. Upgrade Worklight Server.
   c. Install the update for IBM TRIRIGA Anywhere.
   d. Test your environment by deploying IBM TRIRIGA Anywhere apps to Worklight Server.

2. Upgrade the development environment.
   a. Install a development environment.
   b. Test your environment by deploying IBM TRIRIGA Anywhere apps to Worklight Server.

3. Migrate artifact customizations.
   a. Back up the new IBM TRIRIGA Anywhere version 10.4.1 app.xml file that you are about to modify.
   b. Use a graphical file-comparison program to compare your modified 10.4.0 app.xml file to the 10.4.1 app.xml file. Decide whether to migrate the customizations to the 10.4.1 app.xml file.
   c. If you migrate a customization to the 10.4.1 app.xml file, check the changes in application definition files for version 10.4.1 to ensure that the 10.4.0 syntax does not need to be updated. For example, if you are migrating the line that points to the map file, you must move that line to the 10.4.1 app.xml file. You must also fix the syntax to use the 10.4.1 syntax.
   d. In the build.properties file and the worklight.properties file, ensure that the options that you want enabled are set to true.

#### File location changes in version 10.4.1

In this release, the structure of the project directory for IBM TRIRIGA Anywhere is simplified.

The following table shows the location of files.

<table>
<thead>
<tr>
<th>File</th>
<th>Version 10.4.0</th>
<th>Version 10.4.1</th>
</tr>
</thead>
<tbody>
<tr>
<td>app.xml</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\apps\application_name</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\apps\application_name\artifact</td>
</tr>
</tbody>
</table>
Additionally, you can place your customized files in the following directories:

<table>
<thead>
<tr>
<th>File</th>
<th>File path</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image files that are specific to an app</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\apps\application_name\common\images\mdpi</td>
</tr>
<tr>
<td>.css files that are specific to an app</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\apps\application_name\common\css</td>
</tr>
<tr>
<td>JavaScript business logic files</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\apps\application_name\common\js</td>
</tr>
<tr>
<td>OSLC Resource Description Framework (RDF) files</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\oslc-docs\resources\rdf\oslc</td>
</tr>
</tbody>
</table>

### Application definition changes in version 10.4.1
The UI section, the map section, and the data definition section of the application definition (app.xml) file have changes for this release.

The application definition files for the apps are in tririgaanywhere_home\TRIRIGAAnywhere\apps\application_name\artifact.

### UI section
The following changes were made to the UI section:

- The cssClass attribute is no longer required for each queryBase element. To add a separator line at the end of your queryBase elements, insert the following line of code:

  ```
  cssClass="finalQueryBaseMenuItem" />
  ```

- The path to app-specific images is changed. For any images that you add, specify `image="images\image_name"`. Place the app-specific images in the TRIRIGAAnywhere\apps\app_name\common\images\mdpi directory. Images that are shared across the entire TRIRIGA Anywhere platform are referenced by `image="imagename"`. 
Map section

To support iOS and Android environments, the localMapUrl attribute is replaced by either androidLocalMapUrl or iosLocalMapUrl. If you point to a map file using localMapUrl, you must change that line to use either androidLocalMapUrl or iosLocalMapUrl in your new app.xml file.

Data Definition section

The following changes were made to the Data Definition section:

• For each new resource that you added in version 10.4.0, you might need to define more XML elements. If your data resource supports adding records, you must specify the OSLC address that supports the creation of those records. For example:

  `<creationFactories>
   <creationFactory name="triWorkTaskCF" describedByCFUsage="http://jazz.net/ns/ism/smarter_physical_infrastructure/work#WorkTaskCreationFactory"/>
   </creationFactories>

• For the queryBase element, you must now enter a describedByQCUsage attribute to direct the OSLC layer to retrieve those records. The defaultForSearch attribute is new. The defaultForSearch attribute is used by the Search window of the app. The following examples use the describedByQCUsage attribute.

  `<queryBase name="triAllWorkTasksQC" describedByQCUsage="http://jazz.net/ns/ism/smarter_physical_infrastructure/work#AllWorkTasks" defaultForSearch="true"/>

  `<queryBase name="triMyPreventiveWorkTasksQC" describedByQCUsage="http://jazz.net/ns/ism/smarter_physical_infrastructure/work#MyPreventiveWorkTasks"/>

• Every new data resource now requires at least one default queryBase element to be defined. For example, under the triMyAssignedWorkTaskQC resource, the following lines of code are new:

  `<queryBases>
   <queryBase name="triMyAssignedWorkTasksQC" describedByQCUsage="http://jazz.net/ns/ism/smarter_physical_infrastructure/work#MyAssignedWorkTasks"/>
   </queryBases>

You define the name of the queryBase element. The naming convention is tri followed by the resource name. For example, triMyAssignedWorkTaskQC. The describedByQCUsage attribute points to the address of the OSLC object on the server that returns the data.

Upgrading the integrated development environment

After you upgrade IBM TRIRIGA Anywhere, you must upgrade Worklight Studio.

Before you begin

Ensure that Eclipse IDE for Java EE Developers version 4.3.2 (Kepler) is installed.

Procedure

1. In Eclipse, select Help > Install New Software > Add.
2. In the Add Repository window, click Archive.
3. Browse to the location of the WorklightStudio.6.1.0.2-IF2.zip file in the IBM TRIRIGA Anywhere installation image and click Open > OK.
5. Restart Eclipse to apply the changes.
Planning, installation, and deployment
Chapter 3. Building and deploying IBM TRIRIGA Anywhere apps

Before mobile users can download IBM TRIRIGA Anywhere apps, the apps must be built and deployed to Worklight Server.

Application deployment process for IBM TRIRIGA Anywhere apps

IBM TRIRIGA Anywhere apps are generated in the build server and then deployed to the runtime environment, which includes Worklight Server.

On the build server, you use the adapter and application files to generate the deployable files. You then deploy the project and the deployable files into the runtime environment. From Worklight Studio or the operating system command line, you run commands or tasks to deploy the apps to Worklight Server.

The following figure shows the relationship between the build server and the runtime environment. It also shows how the project and files are deployed to the Worklight Server so that the apps are available for download to a mobile device.
The build server contains both the adapter and the applications. When you generate deployable files, the WAR file, the ADAPTER file, the WLAPP file, and the APK or IPA file are created. When you deploy the project and these files to the runtime environment, which includes Worklight Server, the applications and adapter are available for download to a mobile device.

The deployable files are in either the \tririgaanywhere_home\TRIRIGAAnywhere\bin directory or the \tririgaanywhere_home\TRIRIGAAnywhere\apps\app_name\operating_system\native\bin directory:

**WAR file**
A web archive (WAR) file. Each IBM TRIRIGA Anywhere project includes two WAR files. The WAR files are used to package distributable application files and related project resources and to deploy them to Worklight Server.

To support servlet version 3.0 and servlet version 2.4 application servers, there are two WAR files:
- The TRIRIGAAnywhere.war file for servlet version 3.0 application servers, WebSphere Application Server 8, WebSphere Application Server 8.5, WebSphere Application Server Liberty, and Apache Tomcat
- The TRIRIGAAnywhere-2.4.war file for servlet version 2.4 application server: WebSphere Application Server 7

After you install IBM TRIRIGA Anywhere, both of these WAR files are automatically updated with the host information. When you deploy either of the WAR files to the Worklight Server and run the `build all` command, the `worklight.war` file is updated with the IBM TRIRIGA Anywhere distributable application files and related project resources.

**ADAPTER file**
A Worklight adapter that is deployed to Worklight Server. This file contains server code that does tasks such as retrieving data from a remote database. Adapter code is accessed by Worklight applications through a simple invocation API.

**WLAPP file**
Metadata and web resources of a IBM TRIRIGA Anywhere app that is deployed to Worklight Server. Worklight Server uses this file to identify mobile apps.

**APK file**
An Android mobile binary file that is ready for deployment to a mobile device.

**IPA file**
An iOS mobile binary file that is ready for deployment to a mobile device.

You can deploy apps from Worklight Studio or the operating system command line.

**Worklight Studio**
Worklight Studio includes the Mobile Browser Simulator for testing your apps, but it does not include the Application Center for downloading your apps.

**WebSphere Application Server Liberty profile**
A dynamic profile that restricts WebSphere Application Server to use only the features that are required by the applications that are deployed to the server. This profile includes the Application Center for downloading apps to mobile devices.

**WebSphere Application Server full profile**

The full profile supports advanced configurations. WebSphere Application Server includes Application Center for downloading apps to mobile devices.

If you deploy apps from Worklight Studio, you run the adapter and apps deployment tasks. The adapter and apps are deployed to Worklight Server and available for download.

With Worklight Studio, the Application Center is not available. You test your apps by using either the Run as > Android Application menu option for Android apps or the Run as > Xcode project for iOS apps.

If you deploy apps from the operating system command line, you also deploy a WAR file to Worklight Server. This WAR file is created during the IBM TRIRIGA Anywhere installation process. You deploy the WAR file with the Worklight Server Configuration tool. This WAR file contains properties that control the IBM TRIRIGA Anywhere app features, such as timeout values. Whenever you change the properties of the apps, you need to redeploy the WAR file.

After you deploy the WAR file, you run the build all command. After the apps and the WAR file are deployed to the server, mobile users can download the apps from the Application Center to their mobile devices.

**Related reference:**

- “Properties files” on page 35
- “IBM TRIRIGA Anywhere directory structure” on page 36

The process for building and deploying apps requires input from configurable properties files that belong to the application.

The IBM TRIRIGA Anywhere directory contains the files that are required to generate IBM TRIRIGA Anywhere apps. This directory includes predefined content for generating mobile apps that integrate with provider applications in the enterprise system. The application deployment process also generates a set of files.

---

**Deploying IBM TRIRIGA Anywhere apps to Worklight Server**

Apps must be deployed to the server before they can be downloaded to mobile devices. You can deploy apps from Worklight Studio or the operating system command line.

**Deploying apps from the command line to WebSphere Application Server Liberty profile**

For environments that do not include Worklight Studio but do include one of the WebSphere Application Server profiles, you can deploy apps from the operating system command line. The WebSphere Application Server Liberty profile provides a simplified runtime environment for web applications.
Before you begin

If you plan to preview the deployed apps in the Worklight Console, Google Chrome must be installed on the IBM TRIRIGA Anywhere build server. The preview function for the deployed apps does not support other web browsers.

The Worklight Server instance and the Application Center console must be running.

About this task

The project WAR file contains the Worklight Console, default configuration values for the server, and some resources for the Worklight applications and adapters.

When you use Installation Manager to install Worklight Server, Application Center is installed on the web application server that you designate.

Procedure

1. **Deploy the project WAR file** to Worklight Server by using the Server Configuration Tool.
   a. From the Server Configuration Tool, either select Create a new Worklight Server configuration for the first time you deploy the WAR file or select Update the project's WAR file of a deployed Worklight Server configuration for any subsequent redeployments of the WAR file.
   b. Complete the steps in the wizard.
2. **Deploy the Application Center WAR files** and configure the application server.
3. Deploy the distributable files to Worklight Server:
   a. On the IBM TRIRIGA Anywhere build server, in the tririgaanywhere_home\TRIRIGAAnywhere directory, open the build.properties file. Verify that the Worklight Server properties and the Application Center properties are correct for your environment.
   b. Run the build all command, build.cmd on Windows or build.sh on UNIX and Linux systems. The .apk or .ipa artifact file is generated and all distributable files for the IBM TRIRIGA Anywhere project are deployed to Worklight Server.
4. Verify deployment of the IBM TRIRIGA Anywhere apps in the Worklight Console. In Google Chrome, open the Worklight Console and select Preview as common resources for any IBM TRIRIGA Anywhere app.

What to do next

Install the Application Center mobile client on an Android mobile device or an iOS mobile device so that you can download the IBM TRIRIGA Anywhere apps.

Add digital signatures to IBM TRIRIGA Anywhere apps

Related information:

- Worklight Server Configuration Tool
- Ant tasks for deploying a WAR file
- Application Center setup information
- Mobile client setup
Deploying apps from the command line to WebSphere Application Server full profile

For environments that do not include Worklight Studio but do include one of the WebSphere Application Server profiles, you can deploy apps from the operating system command line. The runtime environment that is available with WebSphere Application Server is referred to as the full profile.

Before you begin

If you plan to preview the deployed apps in the Worklight Console, Google Chrome must be installed on the IBM TRIRIGA Anywhere build server. The preview function for the deployed apps does not support other web browsers.

About this task

The project WAR file contains the Worklight Console, default configuration values for the server, and some resources for the Worklight applications and adapters.

When you use Installation Manager to install Worklight Server, Application Center is installed on the web application server that you designate.

Procedure

1. On the IBM TRIRIGA Anywhere build server, in the tririgaanywhere_home\TRIRIGAAnywhere directory, open the build.properties file. Verify that the Worklight Server properties and the Application Center properties are correct for your environment.

2. Deploy the project WAR file with the Worklight Server Configuration Tool.
   a. From the Server Configuration Tool, either select Create a new Worklight Server configuration for the first time you deploy the WAR file or select Update the project's WAR file of a deployed Worklight Server configuration for any subsequent redeployments of the WAR file.
   b. Complete the steps in the wizard.

3. Deploy the Application Center WAR files and configure the application server.

4. Verify that both the Worklight Server instance and the Application Center console are running.

5. From the tririgaanywhere_home\TRIRIGAAnywhere directory, run the build all command, build.cmd on Windows or build.sh on UNIX and Linux systems. The .apk or .ipa artifact file is generated and all distributable files for the IBM TRIRIGA Anywhere project are deployed to Worklight Server.

6. Verify deployment of the IBM TRIRIGA Anywhere apps in the Worklight Console. In Google Chrome, open the Worklight Console and select Preview as common resources for any IBM TRIRIGA Anywhere app.

What to do next

Install the Application Center mobile client on an Android mobile device or an iOS mobile device so that you can download the IBM TRIRIGA Anywhere apps.

Add digital signatures to IBM TRIRIGA Anywhere apps

Related information:
- Worklight Server Configuration Tool
- Ant tasks for deploying a WAR file
Deploying apps by using Worklight Studio

Worklight Studio includes an embedded instance of Worklight Server, which means that you do not need to deploy the WAR file. Worklight Studio also includes the Mobile Browser Simulator for testing your apps.

Before you begin

- If you plan to preview the deployed apps in the Mobile Browser Simulator, Google Chrome must be installed in the development environment. The preview function for deployed apps does not support other web browsers.

Procedure

1. In Worklight Studio, import the IBM TRIRIGA Anywhere project.
   a. Right-click inside the Project Explorer, and select **Import**. From the Import window, select **Existing Projects into Workspace** and click **Next**.
   b. Browse to the `tririgaanywhere_home` folder, select the TRIRIGAAnywhere folder, select **Copy projects into workspace**, and click **Finish**.
2. Set the Ant file path.
   a. From the **Window** menu, select **Preferences**. Expand **Ant** and then select **Runtime**.
   b. Select **Ant Home Entry** and click **Ant Home**.
   c. In the Browse for Folder window, expand `tririgaanywhere_home > AnywhereWorkTaskManagement > build > tools > ant` and click **OK**.
3. Add the `build.xml` file to the Ant view. Select the `build.xml` file from `AnywhereWorkTaskManagement` and drag the `build.xml` file to the Ant view.
4. From the Project Explorer, deploy the adapter.
   a. Select `AnywhereWorkTaskManagement > Adapters` and right-click `OSLCGenericAdapter`.
   b. Select **Run As > Deploy Worklight Adapter**.
5. Build and deploy the IBM TRIRIGA Anywhere Work Task Management app.
   b. Select **Run As > Run on Worklight Development Server**.
6. Verify the application deployment in Worklight Console by right-clicking the app and selecting **Run As > Preview**.
7. Test your app on your mobile device, Android emulator, or iOS Simulator. To test the app on the Android emulator, you must first set up the emulator. To test the app on a mobile device, connect that device to your computer.
<table>
<thead>
<tr>
<th>Device type</th>
<th>Steps</th>
</tr>
</thead>
</table>
| **Android** | 1. In the Project Explorer, select the Android project that is under the app that you are testing and select Run as > Android Application.  
2. Select Launch a new Android Virtual Device for the Android emulator or Launch a new Android Device for an Android mobile device. The .apk artifact file is generated in the bin folder. |
| **iOS** | 1. Under AnywhereWorkTaskManagement > apps > app_name > iphone, select Run as > Xcode project.  
2. From the Xcode window, choose the simulated device or mobile device on which you want to test the app, and click the Play icon. The .ipa artifact file is generated in the bin folder. |

**Related concepts:**
- [Mobile browser simulator](#)
- [iOS Simulator](#)

**Related tasks:**
- [“Setting up the Android emulator” on page 39](#)
  The Android emulator can show you what your Android apps look like and help you test app behavior.
- [“Testing apps” on page 38](#)
  After you deploy an app, you must verify that data is exchanged between the enterprise system database and the mobile application. You can use a mobile device, the Mobile Browser Simulator, an Android emulator, or the iOS Simulator to test apps.

**Related reference:**
- [Building and deploying in Worklight Studio](#)

**Related information:**
- [Software cannot be installed in Worklight Studio](#)

### Properties files

The process for building and deploying apps requires input from configurable properties files that belong to the application.

**worklight.properties**

Contains application configuration properties:
- Worklight Server database connection
- Worklight Server security
- Map service provider authentication
- Heartbeat interval
- Timeout and wait times
- Log line limit
- Authentication method
- Download and upload of attachments
• Size of attachments
• Location of base directory for attachments

build.properties

Contains information about the application definition location, the API version, and whether an app is deployed. The build.properties file also contains information about the OSLC adapter and settings for features that you can enable during the build process:
• Maps are enabled with the map.enabled property
• GPS is enabled with the gps.enabled property
• Bar code scanning is enabled with the barcode.enabled property
• Data encryption is enabled with the enableDataEncryption property

This file also contains the properties for Worklight Server, the Application Center, the OSLC adapter, and the WAR file. The build.properties file defines the instance of Worklight Server to which the app is deployed.

During installation, the build.properties file is copied to the tririgaanywhere_home\TRIRIGAAnywhere directory and updated with values that are provided to the installer. If you change the environment after you install IBM TRIRIGA Anywhere, the build.properties file is not automatically updated. You might need to update the build.properties file in the following situations:
• If you change the enterprise server in your environment, you must change the adapter.connection properties.
• If you move the WAR file from its default location on the Worklight Server computer, you must change the project.config.war.file.name property in the build.properties file.

IBM TRIRIGA Anywhere directory structure

The IBM TRIRIGA Anywhere directory contains the files that are required to generate IBM TRIRIGA Anywhere apps. This directory includes predefined content for generating mobile apps that integrate with provider applications in the enterprise system. The application deployment process also generates a set of files.

The IBM TRIRIGA Anywhere directory includes the application definition file and a set of properties files.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
<th>Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>app.xml</td>
<td>Defines the user interface, data elements, and associated business rules for an app</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\apps\application_name\artifact</td>
</tr>
<tr>
<td>worklight.properties</td>
<td>Contains configuration parameters for apps</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\server\conf</td>
</tr>
<tr>
<td>build.properties</td>
<td>Contains the variable aspects of the build process and defines the target server to which an app is deployed</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere</td>
</tr>
<tr>
<td>worklight.war</td>
<td>Packages distributable application files and related project resources and deploys them to Worklight Server</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\bin</td>
</tr>
</tbody>
</table>
The application deployment process generates another set of files. These files are created after you run the `build all` command from the command line or you run the adapter and apps deployment tasks in Worklight Studio.

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
<th>Path</th>
</tr>
</thead>
<tbody>
<tr>
<td>OSLCGenericAdapter.adapter</td>
<td>Contains server adapter code</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\bin</td>
</tr>
<tr>
<td>application_name.wlapp</td>
<td>Contains server artifacts</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\bin</td>
</tr>
<tr>
<td>application_name.apk</td>
<td>Contains client artifacts</td>
<td>tririgaanywhere_home\TRIRIGAAnywhere\bin</td>
</tr>
<tr>
<td>application_name.ipa</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Adding digital signatures to IBM TRIRIGA Anywhere apps**

Android and iOS apps must be digitally signed to run on a device, to be distributed for testing, or to be submitted to the store.

**About this task**

For Android apps, follow the instructions in the Android documentation for signing Android APK files.

For iOS apps, follow the instructions in the iOS documentation for maintaining your signing identities and certificates.

**Related information:**

- IBM Worklight application authenticity overview

**Deploying apps to a secure server**

The Secure Socket Layer protocol ensures secure transactions between servers and clients. The Worklight platform supports SSL between Worklight Server and the enterprise server. In IBM TRIRIGA Anywhere, the enterprise server is the IBM TRIRIGA server.

To protect the communication between Worklight Server and the enterprise system, configure SSL.

**Installing IBM TRIRIGA Anywhere apps on mobile devices**

The Application Center mobile client must be installed before the apps can be installed on mobile devices.

**About this task**

The Application Center console is a web application for managing the repository of mobile apps. The Application Center mobile client is a secure catalog of available mobile apps. You must log in to the Application Center console to download the mobile client to your devices.

For Android apps, follow the instructions in the Worklight documentation for installing the client on an Android mobile device.
For Android apps, follow the instructions for building and running from the command line on the Android developers website.

For iOS apps, follow the instructions in the Worklight documentation for installing the client on an iOS mobile device.

For iOS apps, follow the instructions for launching your iOS app on a device on the iOS Developer Library website.

If you are using Worklight Studio, the Application Center is not available. Instead, under AnywhereWorkTaskManagement > apps, right-click the app and select Run As > Run on device.

Related concepts:
- The Application Center mobile client

Related tasks:
- Adding an app to the Application Center

---

### Testing apps

After you deploy an app, you must verify that data is exchanged between the enterprise system database and the mobile application. You can use a mobile device, the Mobile Browser Simulator, an Android emulator, or the iOS Simulator to test apps.

#### About this task

**Mobile device**

A mobile device is the most accurate way to test apps. To test your apps on a mobile device, you install the Application Center client on the mobile device and download the apps that you want to test.

**Mobile browser simulator**

In the Mobile Browser Simulator of Worklight Studio, you can test your apps on many different types of devices. The Mobile Browser Simulator contains settings that you can use to duplicate the look of your devices. To view the apps in the Mobile Browser Simulator in Worklight Studio, you must configure the web browser view to use Google Chrome as the external web browser.

**Android emulator**

To test your Android apps on your workstation rather than on a mobile device, you can use the emulator. The emulator is not as accurate a representation as a mobile device. The Android emulator requires that you download the APK file from the Application Center unless you are working with Worklight Studio.

**iOS Simulator**

To test your iOS apps on your workstation instead of on a mobile device, you can use the iOS Simulator. The iOS Simulator is not as accurate a representation as a mobile device.

#### Procedure

1. Log in to the Work Task Management app and search for a known work task.
2. In IBM TRIRIGA Application Platform, use the same search criteria to find the work task.

3. Compare the results to ensure that they are the same.

Related concepts:
- Mobile browser simulator
- iOS Simulator

Related tasks:
- Installing Application Center

You can install Application Center during Worklight Server installation or you can perform a manual installation. The database server must be configured for Application Center.

“Setting up the Android emulator”
The Android emulator can show you what your Android apps look like and help you test app behavior.

Setting up the Android emulator
The Android emulator can show you what your Android apps look like and help you test app behavior.

Before you begin
- Install the Oracle Java Development Kit
- Install the Android Software Development Kit

If you are testing a new instance of a previously deployed application, clear the browser cache. In Google Chrome, go to Settings > Apps, and select the app whose data you want to clear. Click Clear Data.

Procedure
1. From the AndroidSDK\adt-bundle-windows-x86_64\eclipse directory, run the SDK Manager.exe file.
2. In the SDK Manager, select Tools > AVD Manager and click New.
3. In the CPU/ABI field, select Intel Atm (x86).
4. Select the Hardware keyboard present check box and the Display a skin with hardware controls check box.
5. For SD Card Size, enter 168 and click OK.
6. Select your Android Virtual Device (AVD) and click Start.
7. Install the Application Center mobile client on the emulator.
   a. From a browser, enter the following URL: http://hostname:portnumber/appcenterconsole/installers.html where hostname is the address of the server and portnumber is the number of the port where the Application Center is installed.
   b. Enter your user name and password.
   c. Click IBM App Center and Install Now.
   d. On the Notification tab, select the downloaded APK file.
   e. At the prompt, scroll to the bottom of the window and click Install.
8. Start the Application Center and download the apps that you want to test on your emulator.
Chapter 4. Uninstalling IBM TRIRIGA Anywhere, Worklight Server, and Worklight Studio

You use Installation Manager to uninstall IBM TRIRIGA Anywhere, the mobile apps, and Worklight Server. If Worklight Studio is installed, you uninstall it from the Eclipse client.

Procedure
1. To uninstall IBM TRIRIGA Anywhere, the mobile apps, and Worklight Server:
   a. Click Start > All programs > IBM Installation Manager.
   b. Start the IBM Installation Manager program and click Uninstall.
   c. Select the packages that you want to uninstall and complete the wizard.
2. To uninstall Worklight Studio:
   a. In Eclipse, click Help > About Eclipse > Installation Details.
   b. From the Installed Software tab, select the items that you want to uninstall and complete the wizard.
3. To remove the TRIRIGAAnywhere project:
   a. In Eclipse, from the Project Explorer window, right-click the TRIRIGAAnywhere project.
   b. Select Delete.
   c. Select Delete project contents on disk and click OK.
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.
IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Corporation
2Z4A/101
11400 Burnet Road
Austin, TX 78758
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

**Privacy Policy Considerations**

IBM Software products, including software as service solutions, (“Software Offerings”) may use cookies or other technologies to collect product usage information, to help improve the end user experience, to tailor interactions with the end user or for other purposes. In many cases no personally identifiable information is collected by the Software Offerings. Some of our Software Offerings can help enable you to collect personally identifiable information. If this Software Offering uses cookies to collect personally identifiable information, specific information about this offering’s use of cookies is set forth below.

This Software Offering does not use cookies or other technologies to collect personally identifiable information.

If the configurations deployed for this Software Offering provide you as customer the ability to collect personally identifiable information from end users via cookies
and other technologies, you should seek your own legal advice about any laws applicable to such data collection, including any requirements for notice and consent.


---

**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at “Copyright and trademark information” at [www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml).

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other product and service names might be trademarks of IBM or other companies.