IBM Cloud Manager with OpenStack: deployed VM does not set the operating system install date field
Why does a deployed operating system install date not match the deployment date of the VM from IBM® Cloud Manager with OpenStack ?
Cause:
IBM Cloud
Manager with OpenStack does not attempt to force setting the
systeminfo
value "Install Date" on Windows when deployed.
Answer:
IBM Cloud Manager with OpenStack deploys through vCenter to VMware hosts.
The instances deployed have many properties set by cloud-init
post processing,
and many system values are not set by post deploy processing.
The systeminfo
value "Install Date" is not a property that can be passed to the
vCenter API. As such the install date reported by the operating system is the value in the image
deployed.
The correct deploy date is reported in the IBM Cloud Manager with OpenStack user interface for the VM.