Netcool/OMNibus
Version 7 Release 3

User's Guide

IBM
# Contents

**About this publication** ........................................ v
  Intended audience ................................................ v
  What this publication contains ................................ v
  Publications ................................................................ vi
  Accessibility ........................................................... vii
  Tivoli technical training ........................................ viii
  Support information ................................................ viii
  Conventions used in this publication .......................... viii

**Chapter 1. Desktop tools overview** ................................. 1
  Conductor ............................................................... 1
  Event list ............................................................... 1
  Filter Builder .......................................................... 2
  View Builder ........................................................... 2
  Multicultural support ................................................ 2

**Chapter 2. Accessing the desktop tools** ......................... 3
  Starting the Conductor ............................................. 3
    Windows Conductor command-line options ................... 4
    About the UNIX Conductor ....................................... 5
    About the Windows Conductor ................................... 8
  Changing your password on the ObjectServer .................. 9
  Setting global preferences for the UNIX Conductor ......... 10
  Setting global preferences for the Windows Conductor .... 12
  Accessing online help on UNIX ................................... 14
  Accessing online help on Windows ................................ 16
  Stopping the Conductor ............................................ 17

**Chapter 3. Monitoring and managing events in the event list** 19
  Starting the event list ........................................... 19
    UNIX event list command-line options ........................ 20
    Windows event list command-line options .................... 22
  About the Event List monitor box window ..................... 23
  Monitor box overview ............................................. 25
  Managing events using the event list .......................... 27
    About the event list ............................................ 27
    Event list security ............................................... 29
    Event severity levels ............................................ 29
  Setting preferences for the UNIX event list .................. 30
  Setting preferences for the Windows event list ............... 32
  Customizing the appearance of the event list ............... 35
  Displaying the severity colors configured for event lists .. 38
  Working with events .............................................. 39
  Performing collective actions on event lists ................. 53
    Refreshing all event lists ..................................... 53
    Resynchronizing all event lists ............................... 53
    Freezing all event lists ........................................ 54
    Closing all event list windows ................................ 54
  Working with event list configurations ....................... 54
    Saving local event list configurations ....................... 54
    Opening local event list configurations ..................... 55
    Opening remote event list configurations ................... 56
    Saving remote event list configurations .................... 57
    Creating and editing event list configurations on UNIX ... 57
    Creating and editing event list configurations on Windows 59
    Internet service monitors in the event list ................ 62
    Viewing services in the event list ............................ 62
    Monitoring service-affected events in the event list ..... 63
    Monitoring predictive events in the event list ............. 64
    Monitoring TADDM events in the event list ................. 65
    Running transient event lists from the
    command-line, scripts, and tools ............................ 66
    Starting the transient event list from the
    command line ..................................................... 66
    Example: Starting a transient event list from a
    command line or script ....................................... 70
    Example: Starting a transient event list from a
    tool .............................................................. 70

**Chapter 4. Using filters and views to display custom event information** 73
  Setting up filters for event list data ........................ 73
    Components of a filter .......................................... 74
    Filter metrics .................................................... 75
    Best practices for filters ....................................... 76
  Starting the Filter Builder ...................................... 76
  Creating or editing a filter on UNIX .......................... 78
  Creating or editing a filter on Windows ....................... 81
  Specifying comparison values for filter conditions .......... 84
  Specifying operators for filter conditions ................... 88
  Creating filters on UNIX by dragging and dropping ........... 90
  Opening a filter .................................................. 90
  Filter examples ................................................... 92
  Setting up views for event lists ................................ 94
  Starting the View Builder ....................................... 94
  Creating or editing a view on UNIX ............................ 96
  Creating or editing a view on Windows ......................... 100
  Dragging and dropping views on UNIX ........................ 103
  Opening a view ................................................... 103

**Chapter 5. Configuring quick access to filters, views, and event list
configurations on UNIX** ............................................. 105
  About the personal library ...................................... 105
  Working with your local system directories .................. 106
  Maintaining a personal library of frequently-used files .... 107
  Adding files to the personal library .......................... 107
  Creating symbolic links in the personal library ............. 107
  Starting an application from the personal library .......... 108
  Removing files from the personal library ..................... 108
  Automatically opening an event list configuration on startup 109

© Copyright IBM Corp. 1994, 2011
# Chapter 6. Configuring properties, server communication, and settings

- Configuring properties ........................................... 111
- Configuring server communication information ............. 113
- Configuring Tivoli Netcool/OMNIbus settings on Windows . 116
- Changing the date format in the event list on UNIX .......... 119

# Chapter 7. Monitoring accelerated events

- Starting the Accelerated Event Notification client ............ 121
  - Accelerated event notification states ..................... 122
  - About pop-up notifiers .................................... 123
- Configuring property settings for the Accelerated Event Notification client .............................................. 124
- Viewing historical information for accelerated events ........ 130
- Saving accelerated event notification details to log files .... 131
- Accelerated event notification message logging ............. 132
- Signing out of the Accelerated Event Notification client ... 132

# Appendix A. Regular expressions

- NETCOOL regular expression library ......................... 135
- TRE regular expression library ................................ 137
  - Metacharacters ............................................ 137
  - Minimal or non-greedy quantifiers ...................... 139
  - Bracket expressions ................................... 140
  - Constructs for multicultural support .................. 141
  - Backslash sequences .................................... 141

# Appendix B. SQL commands, variable expressions, and helper buttons in tools, automations, and transient event lists

- Notices ......................................................... 149
- Trademarks ..................................................... 151
- Index ......................................................... 153
About this publication

Tivoli Netcool/OMNIbus is a service level management (SLM) system that delivers real-time, centralized monitoring of complex networks and IT domains.

The *IBM Tivoli Netcool/OMNIbus User’s Guide* provides an overview of the Tivoli Netcool/OMNIbus desktop tools, and describes the operator tasks for managing events from the desktop.

Intended audience

This publication is intended for anyone who needs to use Tivoli Netcool/OMNIbus, including operators and administrators. It describes Tivoli Netcool/OMNIbus and how to use the desktop tools.

What this publication contains

This publication contains the following sections:

- **Chapter 1, “Desktop tools overview,” on page 1**
  Describes the desktop tools that can be used for event management.
- **Chapter 2, “Accessing the desktop tools,” on page 3**
  Describes how to access the desktop tools.
- **Chapter 3, “Monitoring and managing events in the event list,” on page 19**
  Describes how to monitor and manage events.
- **Chapter 4, “Using filters and views to display custom event information,” on page 73**
  Describes how to set up filters and views for event list data.
- **Chapter 5, “Configuring quick access to filters, views, and event list configurations on UNIX,” on page 105**
  Describes how to configure the desktop to obtain ready access to filter files, view files, and event list configuration files.
- **Chapter 6, “Configuring properties, server communication, and settings,” on page 111**
  Describes how to configure Tivoli Netcool/OMNIbus settings, properties, and server communication.
- **Chapter 7, “Monitoring accelerated events,” on page 121**
  Describes how to configure the Accelerated Event Notification client, and how to monitor and manage accelerated events.
- **Appendix A, “Regular expressions,” on page 135**
  Provides reference information about regular expressions.
- **Appendix B, “SQL commands, variable expressions, and helper buttons in tools, automations, and transient event lists,” on page 145**
  Provides reference information about common SQL commands, variable expressions, and helper buttons that are used in tools, automations, and transient event lists.
Publications

This section lists publications in the Tivoli Netcool/OMNibus library and related documents. This section also describes how to access Tivoli publications online and how to order Tivoli publications.

Your Tivoli Netcool/OMNibus library

The following documents are available in the Tivoli Netcool/OMNibus library:

• IBM Tivoli Netcool/OMNibus Installation and Deployment Guide, SC14-7604
  Includes installation and upgrade procedures for Tivoli Netcool/OMNibus, and describes how to configure security and component communications. The publication also includes examples of Tivoli Netcool/OMNibus architectures and describes how to implement them.

• IBM Tivoli Netcool/OMNibus Administration Guide, SC14-7605
  Describes how to perform administrative tasks using the Tivoli Netcool/OMNibus Administrator GUI, command-line tools, and process control. The publication also contains descriptions and examples of ObjectServer SQL syntax and automations.

• IBM Tivoli Netcool/OMNibus Web GUI Administration and User’s Guide, SC14-7606
  Describes how to perform administrative and event visualization tasks using the Tivoli Netcool/OMNibus Web GUI.

• IBM Tivoli Netcool/OMNibus User’s Guide, SC14-7607
  Provides an overview of the desktop tools and describes the operator tasks related to event management using these tools.

• IBM Tivoli Netcool/OMNibus Probe and Gateway Guide, SC14-7608
  Contains introductory and reference information about probes and gateways, including probe rules file syntax and gateway commands.

• IBM Tivoli Monitoring for Tivoli Netcool/OMNibus Agent User’s Guide, SC14-7610
  Describes how to install the health monitoring agent for Tivoli Netcool/OMNibus and contains reference information about the agent.

• IBM Tivoli Netcool/OMNibus Event Integration Facility Reference, SC14-7611
  Describes how to develop event adapters that are tailored to your network environment and the specific needs of your enterprise. This publication also describes how to filter events at the source.

• IBM Tivoli Netcool/OMNibus Error Messages Guide, SC14-7612
  Describes system messages in Tivoli Netcool/OMNibus and how to respond to those messages.

• IBM Tivoli Netcool/OMNibus Web GUI Administration API (WAAPI) User’s Guide, SC22-5403-00
  Shows how to administer the Tivoli Netcool/OMNibus Web GUI using the XML application programming interface named WAAPI.

Accessing terminology online

The Tivoli Software Glossary includes definitions for many of the technical terms related to Tivoli software. The Tivoli Software Glossary is available at the following Tivoli software library Web site:

http://publib.boulder.ibm.com/tividd/glossary/tivoliglossarymst.htm
The IBM Terminology Web site consolidates the terminology from IBM product libraries in one convenient location. You can access the Terminology Web site at the following Web address:

http://www.ibm.com/software/globalization/terminology

**Accessing publications online**

IBM posts publications for this and all other Tivoli products, as they become available and whenever they are updated, to the Tivoli Information Center Web site at:

http://publib.boulder.ibm.com/infocenter/tivihelp/v3r1/index.jsp

**Note:** If you print PDF documents on other than letter-sized paper, set the option in the **File > Print** window that allows Adobe Reader to print letter-sized pages on your local paper.

**Ordering publications**

You can order many Tivoli publications online at the following Web site:


You can also order by telephone by calling one of these numbers:

• In the United States: 800-879-2755
• In Canada: 800-426-4968

In other countries, contact your software account representative to order Tivoli publications. To locate the telephone number of your local representative, perform the following steps:

1. Go to the following Web site:
2. Select your country from the list and click **Go**. The Welcome to the IBM Publications Center page is displayed for your country.
3. On the left side of the page, click **About this site** to see an information page that includes the telephone number of your local representative.

---

**Accessibility**

Accessibility features help users with a physical disability, such as restricted mobility or limited vision, to use software products successfully.

With this product, you can use assistive technologies to hear and navigate the interface. You can also use the keyboard instead of the mouse to operate some features of the graphical user interface.
Tivoli technical training

For Tivoli technical training information, refer to the following IBM Tivoli Education Web site:

http://www.ibm.com/software/tivoli/education

Support information

If you have a problem with your IBM software, you want to resolve it quickly. IBM provides the following ways for you to obtain the support you need:

Online
Go to the IBM Software Support site at http://www.ibm.com/software/support/probsub.html and follow the instructions.

IBM Support Assistant
The IBM Support Assistant (ISA) is a free local software serviceability workbench that helps you resolve questions and problems with IBM software products. The ISA provides quick access to support-related information and serviceability tools for problem determination. To install the ISA software, go to http://www.ibm.com/software/support/isa

Documentation
If you have a suggestion for improving the content or organization of this guide, send it to the Tivoli Netcool/OMNibus Information Development team at:

mailto://L3MMDOCS@uk.ibm.com

Conventions used in this publication

This publication uses several conventions for special terms and actions and operating system-dependent commands and paths.

Typeface conventions

This publication uses the following typeface conventions:

Bold
- Lowercase commands and mixed case commands that are otherwise difficult to distinguish from surrounding text
- Interface controls (check boxes, push buttons, radio buttons, spin buttons, fields, folders, icons, list boxes, items inside list boxes, multicolumn lists, containers, menu choices, menu names, tabs, property sheets), labels (such as Tip: and Operating system considerations)
- Keywords and parameters in text

Italic
- Citations (examples: titles of publications, diskettes, and CDs)
- Words defined in text (example: a nonswitched line is called a point-to-point line)
- Emphasis of words and letters (words as words example: "Use the word that to introduce a restrictive clause."); letters as letters example: "The LUN address must start with the letter L.")
New terms in text (except in a definition list): a view is a frame in a workspace that contains data

Variables and values you must provide: ... where myname represents....

Monospace

Examples and code examples

File names, programming keywords, and other elements that are difficult to distinguish from surrounding text

Message text and prompts addressed to the user

Text that the user must type

Values for arguments or command options

Operating system-dependent variables and paths

This publication uses the UNIX convention for specifying environment variables and for directory notation.

When using the Windows command line, replace $variable with %variable% for environment variables, and replace each forward slash (/) with a backslash (\) in directory paths. For example, on UNIX systems, the $NCHOME environment variable specifies the path of the Netcool® home directory. On Windows systems, the %NCHOME% environment variable specifies the path of the Netcool home directory. The names of environment variables are not always the same in the Windows and UNIX environments. For example, %TEMP% in Windows environments is equivalent to $TMPDIR in UNIX environments.

If you are using the bash shell on a Windows system, you can use the UNIX conventions.

Operating system-specific directory names

Where Tivoli Netcool/OMNIbus files are identified as located within an arch directory under NCHOME, arch is a variable that represents your operating system directory, as shown in the following table.

Table 1. Directory names for the arch variable

<table>
<thead>
<tr>
<th>Directory name represented by arch</th>
<th>Operating system</th>
</tr>
</thead>
<tbody>
<tr>
<td>aix5</td>
<td>AIX® systems</td>
</tr>
<tr>
<td>hpxu11</td>
<td>HP-UX PA-RISC-based systems</td>
</tr>
<tr>
<td>hpxu11hpi1a</td>
<td>HP-UX Integrity-based systems</td>
</tr>
<tr>
<td>linux2x86</td>
<td>Red Hat Linux and SUSE systems</td>
</tr>
<tr>
<td>linux2s390</td>
<td>Linux for System z®</td>
</tr>
<tr>
<td>solaris2</td>
<td>Solaris systems</td>
</tr>
<tr>
<td>win32</td>
<td>Windows systems</td>
</tr>
</tbody>
</table>
Chapter 1. Desktop tools overview

A number of standard desktop tools are installed with Tivoli Netcool/OMNIbus to enable you to manipulate the events stored in the ObjectServer.

These desktop tools include the following applications:

- Conductor
- Event List
- Filter Builder
- View Builder

These applications retrieve information from an ObjectServer and allow you to view the current state of the database, which in turn reflects the status of the systems being managed.

Note: Desktop tools are not supported on Linux on System z or HP-UX Integrity systems. You can install and configure the Web GUI component, and then use Web GUI clients to view, manage, and configure events in a similar manner to the desktop tools.

Conductor

The Conductor is the desktop entry point for Tivoli Netcool/OMNIbus.

You can use the Conductor to open the other client applications, and to display configurations such as filter or view files for event lists.

Related concepts:

"About the UNIX Conductor" on page 5
"About the Windows Conductor" on page 8

Event list

Tivoli Netcool/OMNIbus uses event lists to present information about the event data that is forwarded to the ObjectServer.

The event list displays a filtered view of color-coded events in a scrolling list. You can set up multiple event list clients, each with different priorities and filters. You can also use the event list to reprioritize alerts, and to assign or reassign problems to other users. When an alert has been assigned to a user, the user can acknowledge it, or deacknowledge it so that it can be picked up by another user.

Related concepts:

"About the event list" on page 27
"About the Event List monitor box window" on page 23
Filter Builder

You can use filters to choose which events to display in the event list. The Filter Builder allows you to build simple or complex event filters.

Related concepts:
“Setting up filters for event list data” on page 73

View Builder

You can use the View Builder to create event list views. Views enable you to choose which fields to display in the event list.

Related concepts:
“Setting up views for event lists” on page 94

Multicultural support

Tivoli Netcool/OMNibus supports a variety of single-byte and multi-byte character encodings for use in different locales.

Note: If your user name and password are being verified against an external authentication source, you must check whether this source also supports multi-byte characters. If multi-byte characters are not supported, you must specify user names and passwords using ASCII characters.
Chapter 2. Accessing the desktop tools

You can use the Conductor to manage the Tivoli Netcool/OMNIbus desktop tools (or client applications).

You can use the Conductor to perform the following tasks:
• Run all the desktop tools without having to log in every time you start one.
• Set preferences for all of the desktop tools.
• Set up communications for the Tivoli Netcool/OMNIbus server components by using the Server Editor.
• Change your password.
• Maintain a personal library that stores frequently-used Tivoli Netcool/OMNIbus files, such as event list configurations, filters, and views.
• Browse directories to select files to add to the personal library or the Conductor button bar.
• Access tools that are defined by your system administrator for managing events in the event list.

Starting the Conductor

The Conductor provides single sign-on access to all the Tivoli Netcool/OMNIbus desktop tools that you can use to view and manage alerts.

To use the desktop tools, you must connect to a running ObjectServer by using valid authentication credentials.

Tip: You can optionally start desktop tools individually from the command line in UNIX or from the Windows Start menu. However, every time you start a desktop tool in this way, you need to enter your user name and password for authentication and connection to a selected ObjectServer.

To start the Conductor:
1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>From a command prompt, type: $NCHOME/omnibus/bin/nco &amp;</td>
</tr>
</tbody>
</table>
| Windows| • From the Windows Start menu, click Netcool Conductor.  
         • From a command prompt, enter: \$NCHOME\omnibus\desktop\NCOConductor.exe |

The Login window for the Conductor opens.
2. Complete this window as follows:

   **Username**
   Type your user name.

   **Password**
   Type your password. Asterisk (*) characters are shown in place of the text that you type.
Note: If your user name and password are being verified against an external authentication source (rather than an ObjectServer), you must check whether this source supports multi-byte characters. If multi-byte characters are not supported, you must specify the user name and password using ASCII characters.

Server
The ObjectServer name defaults to NCOMS (Netcool/OMNibus Master Server). If multiple ObjectServers have been configured for your environment, all available ObjectServers are shown in this drop-down list. Select the ObjectServer to which you want to connect.

OK
Click this button to authenticate your login details.

Note: You are allowed three attempts to log in. On each attempt, the Password field is cleared. If you fail to log in correctly at the third attempt, the program terminates.

Cancel
Click this button to cancel your login attempt.

Results
On successful login:
• The UNIX Conductor opens as a window.
• The Windows Conductor is represented as a bus icon in the Windows system tray. Right-click this icon to view the Windows Conductor menu.

You can start a Conductor for each running ObjectServer. On Windows, each Conductor is allocated an icon in the system tray.

Windows Conductor command-line options
When you use the NCOConductor.exe command to start the Conductor on Windows, you can specify a number of command-line options to modify the configuration of all the event lists that are started from that Conductor instance. You can run this command from the %NCHOME%\omnibus\desktop directory.

The following table describes the command-line options for starting the Windows Conductor.
### Table 2. Windows Conductor (NCOConductor) command-line options

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>`-config string</td>
<td>URL<code>or</code>-elc string</td>
</tr>
<tr>
<td><code>string</code></td>
<td>specifies a path to a <code>elc</code> file.</td>
</tr>
<tr>
<td><code>URL</code></td>
<td>specifies a <code>elc</code> file that is located on a remote server, which is accessible by using HTTP or FTP. Specify the <code>URL</code> by using one of the following formats:</td>
</tr>
<tr>
<td><code>http://servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td><code>http://username:password@servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td><code>ftp://servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td><code>ftp://username:password@servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td>The optional port number <code>:port</code> needs to be specified only if the server is not using the default port.</td>
<td></td>
</tr>
<tr>
<td>You can optionally specify an IPv4 or IPv6 address for the <code>servername</code> value. When specifying an IPv6 address, enclose the address within brackets <code>[]</code>; for example:</td>
<td></td>
</tr>
<tr>
<td>If using FTP, the path must be the full path from the root directory; for example, <code>'/home/user/mydir/myconfig.elc'.</code></td>
<td></td>
</tr>
<tr>
<td>For information about IPv6 requirements on Windows, see the <em>IBM Tivoli Netcool/OMNibus Installation and Deployment Guide</em>.</td>
<td></td>
</tr>
<tr>
<td><code>-help</code></td>
<td>Displays help for this command and exits.</td>
</tr>
<tr>
<td><code>-networktimeout integer</code></td>
<td>Specifies a time, in seconds, after which a login attempt or connection to the ObjectServer will time out if a network failure occurs. After the specified timeout period, the event list started from the Conductor attempts to reconnect to the ObjectServer. If the connection is unsuccessful after a second timeout period, the event list started from the Conductor will attempt to connect to a backup ObjectServer, where available. The default is 20 seconds.</td>
</tr>
<tr>
<td><code>-password string</code></td>
<td>Specifies a password to use to log in to the Conductor and event lists.</td>
</tr>
<tr>
<td><code>-server string</code></td>
<td>Specifies the name of the ObjectServer to which you are connecting.</td>
</tr>
<tr>
<td><code>-username string</code></td>
<td>Specifies the user name to use to log in to the Conductor and event lists.</td>
</tr>
<tr>
<td><code>-version</code></td>
<td>Displays version information and exits.</td>
</tr>
</tbody>
</table>

### About the UNIX Conductor

The desktop tools and options that are available to you from the UNIX Conductor will depend on the privileges granted to you by your system administrator.

The UNIX Conductor is shown in the following figure.
The Conductor window contains the following areas:

1. Button bar
2. Personal library
3. Status bar

**Button bar**

The Conductor button bar consists of one configurable button and six pre-configured buttons. These buttons represent all the desktop tools that are installed, and which are available to you based on your access privileges. The buttons in the button bar are described in the following table.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configurable button (leftmost button)</td>
<td>Use the configurable button to start a custom event list configuration automatically whenever you start the Conductor. This button requires user customization, and is shown as a dotted rectangle (with a <code>none</code> label), which acts as a placeholder if the button is not yet linked to an event list configuration. To configure this button, you must select the icon for an event list configuration file from the personal library or the Directory Browser window, and then drop the icon over this button.</td>
</tr>
<tr>
<td>Filter Builder</td>
<td>Click <strong>Filter Builder</strong> to start the Filter Builder with the default filter loaded. You can use the Filter Builder to create new filters or edit existing filters.</td>
</tr>
</tbody>
</table>
Table 3. Conductor buttons (continued)

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>View Builder</strong></td>
<td>Click <strong>View Builder</strong> to start the View Builder with the default view loaded. You can use the View Builder to create new views or edit existing views.</td>
</tr>
<tr>
<td><strong>Browser</strong></td>
<td>Click <strong>Browser</strong> to open a directory browser utility that allows you to navigate file systems, and find filter files, view files, and event list configuration files, which you can add to your personal library of frequently-used Tivoli Netcool/OMNibus files.</td>
</tr>
<tr>
<td><strong>Event List</strong></td>
<td>Click <strong>Event List</strong> to start the event list with a default configuration; that is, with a default view and default filter. If an event list has already been started from the Conductor, this button is not available, in order to prevent multiple event lists from being started.</td>
</tr>
<tr>
<td><strong>Interfaces</strong></td>
<td>Click <strong>Interfaces</strong> to start the Server Editor, which is used to set up communication details that enable Tivoli Netcool/OMNibus server components to communicate with each other.</td>
</tr>
<tr>
<td><strong>Properties</strong></td>
<td>Click <strong>Properties</strong> to start the Properties Editor, which can be used to edit the configuration information in the properties files for ObjectServers, proxy servers, process agents, the database initialization utility (<strong>nco_dbinit</strong>), probes, and gateways.</td>
</tr>
</tbody>
</table>

To run a desktop tool from the Conductor, click the relevant button. The tool starts automatically; you do not need to enter a user name or password.

**Personal library**

The personal library provides an easily-accessible location from which to open frequently-used Tivoli Netcool/OMNibus files that are held in your `.omnibus` directory. This includes event list configuration files (.elc), view files (.elv), and filter files (.elf). You can double-click icons in the personal library to open their associated applications.

The personal library also contains a **prefs** icon, which represents a preference file. You double-click this icon to specify global preferences for the Conductor, event list, and alert notifications.

**Status bar**

The status bar displays:

- The status message
- The user name used to log into the current session
- The ObjectServer to which you are currently connected and whether it is the primary (PRI) or backup (BAK) server

**Related tasks:**

“Starting the Conductor” on page 3
About the Windows Conductor

The desktop tools and options that are available to you from the Windows Conductor menu will depend on the privileges granted to you by your system administrator.

You can open the Windows Conductor by right-clicking the bus icon in the Windows system tray. The Windows Conductor is shown in the following figure.

![Windows Conductor](image)

Figure 2. Conductor on Windows

You can display information about the login details for the Conductor by moving the cursor over the bus icon to see the user name and ObjectServer details in a ToolTip. To run a tool from the Conductor, select an option from the menu. The tool starts automatically; you do not need to enter a user name or password.

Use the Conductor menu options as follows:

**Event List**
- Click this option to start the event list with a default configuration; that is, with a default view and default filter.

**Servers**
- Click this option to start the Server Editor, which is used to set up communication details that enable Tivoli Netcool/OMNIbus server components to communicate with each other.

**Properties**
- Click this option to start the Properties Editor, which you can use to edit the configuration information in the properties files for ObjectServers, proxy servers, process agents, the database initialization utility (nco_dbinit), probes, and gateways.

**Tools**
- Click this option to start tools that have been configured by your system administrator.

**Preferences**
- Click this option to configure global preferences for Tivoli Netcool/OMNIbus.

**Password**
- Click this option to change your password.

**Help**
- Click this option to access help on using the desktop tools.

**About Conductor**
- Click this option to display the Conductor version.
Changing your password on the ObjectServer

If you are authenticated against any external source other than an ObjectServer, you must always request a password change from the system administrator of the external source.

The password for the ObjectServer server user cannot start with any of the following characters: hyphen (-), forward slash (/), or double quotation mark (").

To change your password on the ObjectServer:
1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>From the Conductor window on UNIX, click File &gt; Change Password. Note: On UNIX, the Change Password menu option is not available if your organization uses external authorization. This is because externally-authenticated passwords are not stored in the ObjectServer.</td>
</tr>
<tr>
<td>Windows</td>
<td>From the Conductor menu on Windows, click Password.</td>
</tr>
</tbody>
</table>

The Change Password window opens.

2. Complete this window as follows:

   **Current® Password**
   Type your current password. Any text entered is replaced with asterisk (*) characters.

   **New Password**
   Type the new password.

   **Verify Password**
   Retype the new password.

   **OK**
   Click this button to save the new password.

   **Cancel**
   Click this button to cancel any password changes and retain your old password.

   **Note:** If you type an invalid current password, or if the entries in the New Password and Verify Password fields do not match, an error message is displayed. In both cases, you can close the error message window and correct the error.

Related tasks:

“Starting the Conductor” on page 3
Setting global preferences for the UNIX Conductor

From the UNIX Conductor, you can set global preferences for the Conductor window, event list, and event notifications.

To set global preferences:
1. From the Conductor window on UNIX, double-click the prefs icon in the personal library. The Preferences window opens.
2. From the Conductor tab, configure global settings for the Conductor. Complete the tab as follows:
   **Timed Directory Update**
   Select this check box to indicate that the Conductor directory information should be updated at regular intervals. In the adjacent field, enter a value (in seconds) for the update interval. Clear this check box if you prefer to await notification of updates from the ObjectServer.
3. From the Event List tab, configure global settings for the event list. Complete the tab as follows:
   **Show Count**
   Select this check box to display the number of alerts that match the filter on monitor boxes.
   **Show Highest Severity**
   Select this check box to display the highest severity among the alerts that match the filter on monitor boxes.
   **Show Lowest Severity**
   Select this check box to display the lowest severity among the alerts that match the filter on monitor boxes.
   **Show Metric**
   Select this check box to display the selected filter metric value on monitor boxes.
   **Show Lavalamp**
   Click this option to display the distribution indicator as a horizontal bar on monitor boxes.
   **Show Histogram**
   Click this option to display the distribution indicator as a bar graph on monitor boxes.
   **Show Event List Colors**
   Select this check box to use color to depict the severity of alerts in the event list. Clear this check box to use a grey background for all event list rows.
   **Sort Information Details**
   Select this check box to sort the detail fields in the Event Information window alphabetically by name of field. When this check box is clear, the detail fields are displayed in an order determined by the ObjectServer.
   **Timed Refresh**
   Use these fields to indicate whether alert information should be updated at a specified time interval, or whether you prefer to await notification of updates from the ObjectServer. To specify an update frequency, select the **Timed Refresh** check box and then enter a time (in seconds) in the adjacent field.
All the latest data from the ObjectServer will be sent to the event list at the specified frequency.

**Tip:** Timed Refresh forces the event list to reload all its data at a set interval. Do not set the refresh to a low value (for example, less than 60 seconds) because this has an impact on ObjectServer performance and network traffic.

**Note:** If your system administrator has set the `AllowTimedRefresh` ObjectServer property to `FALSE`, refresh timers are disabled and updates occur based on notification from the ObjectServer.

**Enable Flashing**
Select this check box to enable event list flashing. Use the **Fast/Slow** slider to indicate how quickly the event list flashes. Use the **Bright/Dark** slider to indicate the degree of brightness of the flashing.

4. From the **Notification** tab, configure global settings for alert notifications.

Complete the tab as follows:

**Notify When Iconised**
Select this check box to receive notification of new, changed, or deleted alerts when the event list is minimized. Notification is received only on desktop environments that display an icon when the event list is minimized. Use the **When** and **How** options to set the notification method.

**When** Select each check box to receive notification as follows:
- Select **New** to receive a notification when a new alert is added to the event list.
- Select **Change** to receive a notification when an existing alert changes in the event list.
- Select **Delete** to receive a notification when an existing alert is deleted from the event list.

**How** Select each check box to indicate how a notification should occur:
- Select **Ring Bell** to sound the workstation or terminal bell once.
- Select **Alert Icon** to flash an exclamation mark over the event list icon (UNIX), or flash the minimized event list (Windows).
- Select **Open Window** to open the event list on the screen. If you use a window manager with interactive placement, the event list opens as the active window.
- Select **Run External Command** to run a command. If you select this check box, you must type the command name. This function must be used only for simple desktop notification, and is not designed for handling paging applications.

5. **Apply**, **Save**, or cancel your changes as follows:

**Apply** Click this button to apply changes without saving them. This button enables you to test how your changes affect the desktop.

**Save** Click this button to save any changes made to your preferences.

**Tip:** To view any changes made to preferences in the event list, you must close and reopen any open event lists.

**Close** Click this button to close the window without saving your changes.
Undo  Click this button to undo any changes that you have made to each of the tabs.

Related concepts:
“About the personal library” on page 105

Related tasks:
“Starting the Conductor” on page 3

Setting global preferences for the Windows Conductor

From the Windows Conductor, you can set global preferences for the event list and alert notifications.

To set global preferences:
1. From the Conductor menu on Windows, select Preferences. The Preferences window opens.
2. From the Event List tab, configure global settings for the event list. Complete the tab as follows:

Monitors
Use this area to configure settings for the Event List monitor box window.

Show Number of Alerts
Select this check box to display the number of alerts that match the filter on monitor boxes.

Show Highest Severity
Select this check box to display the highest severity among the alerts that match the filter on monitor boxes.

Show Lowest Severity
Select this check box to display the lowest severity among the alerts that match the filter on monitor boxes.

Show Metric
Select this check box to display the selected filter metric value on monitor boxes.

Show Lavalamp
Click this option to display the distribution indicator as a horizontal bar on monitor boxes.

Show Histogram
Click this option to display the distribution indicator as a bar graph on monitor boxes.

You cannot select both Show Lavalamp and Show Histogram.

Event Window
Use this area to configure settings for the event list.

Show Colours
Select this check box to use color to depict the severity of alerts in the event list. Clear this check box to use a grey background for all event list rows.

Show Distribution Summary Bar
Select this check box to display the distribution summary bar in the event list. This bar displays the number of alerts that match each severity color.
**Show Toolbars**
Select this check box to make the toolbars available on the event list.

**Jump Button On By Default**
Select this check box to enable the Jump To Top feature, by default, for all event lists. The Jump to Top feature causes the event list to scroll to the top whenever new events are added, and can help you to quickly review updated events.

**Tip:** You can also enable the Jump To Top feature for individual event lists so that you can automatically view updates to an event list, or you can disable this feature for individual event lists.

**Information Dialog**
Use this area to configure settings for the Event Information window.

**Sort Information Details**
Select this check box to sort the detail fields in the Event Information window alphabetically by name of field. When this check box is clear, the detail fields are displayed in an order determined by the ObjectServer.

**Timed Refresh**
Use these fields to indicate whether alert information should be updated at a specified time interval, or whether you prefer to await notification of updates from the ObjectServer. To specify an update frequency, select the **Enabled** check box, and then specify a time (in seconds) in the **Time (secs)** field.

All the latest data from the ObjectServer will be sent to the event list at the specified frequency.

**Tip:** Timed Refresh forces the event list to reload all its data at a set interval. Do not set the refresh to a low value (for example, less than 60 seconds) because this has an impact on ObjectServer performance and network traffic.

**Note:** If your system administrator has set the **AllowTimedRefresh** ObjectServer property to FALSE, refresh timers are disabled and updates occur based on notification from the ObjectServer.

**Flashing**
Use this area to cause the event list to flash when it receives new events.

**Enabled**
Select this check box to enable event list flashing. Use the **Fast/Slow** slider to indicate how quickly the event list flashes. Use the **Bright/Dark** slider to indicate the degree of brightness of the flashing.

3. From the **Notification** tab, configure global settings for alert notifications. Complete the tab as follows:

**Notify When Iconised**
Select this check box to receive notification of new, changed, or deleted alerts when the event list is minimized. Notification is received only on
desktop environments that display an icon when the event list is minimized. Use the When and How options to set the notification method.

**When** Select each check box to receive notification as follows:
- Select **New** to receive a notification when a new alert is added to the event list.
- Select **Change** to receive a notification when an existing alert changes in the event list.
- Select **Delete** to receive a notification when an existing alert is deleted from the event list.

**How** Select each check box or option to indicate how a notification should occur:
- Select **Ring Bell** to sound the workstation or terminal bell once.
- Click **Alert Icon** to flash an exclamation mark over the event list icon (UNIX), or flash the minimized event list (Windows).
- Click **Open Window** to open the event list on the screen. If you use a window manager with interactive placement, the event list opens as the active window.

**Note:** You cannot select both **Alert Icon** and **Open Window**.
- Select **Run External Command** to run a command. If you select this check box, you must type the command name in the Command field. This function must only be used for simple desktop notification, and is not designed for handling paging applications. To run the command at the current time, click **Execute Command Now**.

4. Apply, save, or cancel your changes as follows:

**Apply** Click this button to apply changes without saving them. This button enables you to test how your changes affect the desktop.

**Save** Click this button to save any changes made to your preferences.

**Tip:** To view any changes made to preferences in the event list, you must close and reopen any open event lists.

**Close** Click this button to close the window without saving your changes.

**Related tasks:**
“Starting the Conductor” on page 3

---

**Accessing online help on UNIX**

The online help is deployed using IBM® Eclipse Help System (IEHS), which is a Web application. Based on your installation and configuration settings, you can access the online help in either standalone mode or information center mode.

To configure and access online help, proceed as described in the following table.
### Table 4. Help configuration settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
</table>
| Environment variables for browser (UNIX) | Add the directory location of your browser to the following environment variables (if not already added):  
   - PATH  
   - LD_LIBRARY_PATH (Solaris and Linux), LIBPATH (AIX) or SHLIB_PATH (HP-UX)  
   - Browser-specific environment variables; for example, MOZILLA_FIVE_HOME |

#### Standalone mode

To use the online help in standalone mode, you must have selected the *Local Help System* feature during installation of Tivoli Netcool/OMNibus.

After installation, configuration is only necessary if the default IEHS port number of 8888 is being used by another local service. If this is the case, edit the IEHS configuration file `$NCHOME/omnibus/etc/nco_IEHS.cfg` as follows:

- IEHSMode: 0  
- IEHSHost: blank  
- IEHSPort: an unused port number

**Note:** After changing the port number in the configuration file, you must shut down the local IEHS server for your changes to take effect. Run the `$NCHOME/omnibus/bin/help_end` command. (If you change your environment variable settings for the browser, you must also shut down the IEHS server for your changes to take effect.)

#### Information center mode

In information center mode, your system administrator configures the setup so that all users can share one IEHS Web server for the online help system, thus relieving the load on local hosts or workstations.

If your system administrator has informed you that your online help must be accessed in information center mode, you must configure your local IEHS configuration file `$NCHOME/omnibus/etc/nco_IEHS.cfg` as follows:

- IEHSMode: 1  
- IEHSHost: IP address or host name of the IEHS server  
- IEHSPort: port number on which the IEHS server is running

Your system administrator will provide the IEHSHost and IEHSPort settings.

When you access online help in standalone mode, your default help browser window automatically opens with the relevant text. The local IEHS server starts with the first help request and continues to run until you shut it down. To shut down the local IEHS server, run the following command:

```
$NCHOME/omnibus/bin/help_end
```

In general, run the `help_end` command only before rebooting your computer.

Before you can access online help in information center mode, your system administrator must start the designated remote IEHS server.
**Note:** In standalone mode, only the browser that is running on the local computer can display a help topic. If there is an open browser running on another host, the help system attempts to use that browser to display the online help. This results in the following error message: The connection was refused when attempting to connect to localhost: `name`
Close the window to display the help in the correct browser.

---

**Accessing online help on Windows**

The online help is deployed using IBM Eclipse Help System (IEHS), which is a Web application. Based on your installation and configuration settings, you can access the online help in either standalone or information center mode.

To configure and access online help, proceed as described in the following table.

*Table 5. Help configuration settings*

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Standalone mode</td>
<td>To use the online help in standalone mode, you must have selected the <strong>Local Help System</strong> feature during installation of Tivoli Netcool/OMNibus.</td>
</tr>
<tr>
<td></td>
<td>After installation, configuration is only necessary if the default IEHS port number of 8888 is being used by another local service. If this is the case, edit the IEHS configuration file <code>%NCHOME%\omnibus\ini\nco_IEHS.cfg</code> as follows:</td>
</tr>
<tr>
<td></td>
<td>• IEHSMode: 0</td>
</tr>
<tr>
<td></td>
<td>• IEHSHost: blank</td>
</tr>
<tr>
<td></td>
<td>• IEHSPort: an unused port number</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> After changing the port number in the configuration file, you must shut down the local IEHS server for your changes to take effect. Run the <code>%NCHOME%\omnibus\bin\help_end.bat</code> command.</td>
</tr>
<tr>
<td>Information center mode</td>
<td>In information center mode, your system administrator configures the setup so that all users can share one IEHS Web server for the online help system, thus relieving the load on local hosts or workstations.</td>
</tr>
<tr>
<td></td>
<td>If your system administrator has informed you that your online help must be accessed in information center mode, you must configure your local IEHS configuration file <code>%NCHOME%\omnibus\ini\nco_IEHS.cfg</code> as follows:</td>
</tr>
<tr>
<td></td>
<td>• IEHSMode: 1</td>
</tr>
<tr>
<td></td>
<td>• IEHSHost: IP address or host name of the IEHS server</td>
</tr>
<tr>
<td></td>
<td>• IEHSPort: port number on which the IEHS server is running</td>
</tr>
<tr>
<td></td>
<td>Your system administrator will provide the IEHSHost and IEHSPort settings.</td>
</tr>
</tbody>
</table>

When you access online help in standalone mode, your default help browser window automatically opens with the relevant text. The local IEHS server starts with the first help request and continues to run until you shut it down. To shut down the local IEHS server, run the following command:

```
%NCHOME%\omnibus\bin\help_end.bat
```
In general, run the `help_end.bat` command only before rebooting your computer.

Before you can access online help in information center mode, your system administrator must start the designated remote IEHS server.

**Note:** On Windows, some temporary files that are generated by the IEHS server are not removed if you reboot the system or stop the javaw process of IEHS (using the Task Manager), without first shutting down the IEHS server. This might result in difficulty accessing the online help. In both standalone mode and information center mode, you must run `help_end.bat` or `IC_end.bat` to shut down the IEHS server before rebooting the system, and you must not stop the IEHS javaw process manually. If you cannot access the help in standalone mode or cannot start the IEHS server in information center mode, run `help_end.bat` or `IC_end.bat` to clear the temporary files, and then try again.

### Stopping the Conductor

When you close the Conductor on UNIX or Windows, any tools that were started with the Conductor remain open. You must close all other open windows manually when no longer needed.

To exit from the Conductor on UNIX, click **File > Exit**.

To exit from the Conductor on Windows, right-click the bus icon on the system tray and click **Exit from the Conductor** pop-up menu.
Chapter 3. Monitoring and managing events in the event list

You can use the event list to monitor and manage alerts. An alert is created when the ObjectServer receives an event, alarm, message, or data item. Each alert is made up of columns (or fields) of information that are held in a row in the ObjectServer alerts.status table.

The alert information that is displayed in the event list is determined with the use of filters and views. Filters enable you to display a subset of alerts based on specific criteria. Views enable you to choose which alert fields to display.

Starting the event list

To monitor and manage alerts in the event list, you must connect to a running ObjectServer by using valid authentication credentials. You can start the event list from the Conductor, from the command line, or from the Windows Start menu.

To start an event list:
1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| UNIX   | • From the Conductor window, click Event List in the button bar.  
• From a command prompt, enter: 
  `$NCHOME/omnibus/bin/nco_event &` |
| Windows| • From the Conductor menu, select Event List.  
• From the Windows Start menu, select Programs > Netcool Suite > Event List.  
• From a command prompt, enter: 
  `%NCHOME%\omnibus\desktop\NCOEvent.exe` |

When starting the event list from the command line, you can specify additional command-line options with the `nco_event` and `NCOEvent.exe` commands.

2. If you start the event list from the command line or the Windows Start menu, and you had not previously started the Conductor, you are prompted to provide authentication details for connecting to a running ObjectServer. You must complete the Login window for the event list as follows:

**Username**
Type your user name.

**Password**
Type your password. Asterisk (*) characters are shown in place of the text that you type.

**Note:** If your user name and password are being verified against an external authentication source (rather than an ObjectServer), you must check whether this source supports multi-byte characters. If multi-byte characters are not supported, you must specify the user name and password using ASCII characters.

**Server**
The ObjectServer name defaults to NCOMS (Netcool/OMNIbus Master Server). If multiple ObjectServers have been configured for your
environment, all available ObjectServers are shown in this drop-down list. Select the ObjectServer to which you want to connect.

OK
Click this button to authenticate your login details.

Note: You are allowed three attempts to log in. On each attempt, the Password field is cleared. If you fail to log in correctly at the third attempt, the program terminates.

Cancel
Click this button to cancel your login attempt.

Results
If an instance of the event list (nco_event) is running, the nco_event command opens a new event list window. If there is no running instance of nco_event, the nco_event command starts one, and displays the monitor box window.

When you start an event list, the Event List monitor box window opens. From this window, you can monitor and manage all alerts that are generated when the ObjectServer receives an event, alarm, message, or data item.

In general, when you start the event list, the default event list configuration (default.elc) is shown within the Event List monitor box window. You can also choose to open a customized event list configuration file. Customized configurations can be specified at the command line or by using the File > Open window. These customized configurations can be on your file system or located on a remote server that is accessible by using HTTP or FTP.

Failover login: If the event list loses its connection to the primary ObjectServer and a secondary or failover ObjectServer exists, you are prompted to log in to the secondary ObjectServer. When the primary ObjectServer becomes available again, a message appears indicating that the event list is reconnecting to the primary ObjectServer. You do not need to log in again to the primary ObjectServer.

UNIX event list command-line options
When you use the nco_event command to start the event list on UNIX, you can specify a number of command-line options to modify the configuration. You can run this command from the $NCHOME/omnibus/bin directory.

The following table describes the command-line options for starting the UNIX event list.

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-cmap</td>
<td>Specifies a private color map. You cannot abbreviate this command-line option.</td>
</tr>
</tbody>
</table>
Table 6. UNIX event list (nco_event) command-line options (continued)

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>`-config string</td>
<td>URL`</td>
</tr>
<tr>
<td><code>string</code></td>
<td>specifies a path to a .elc file.</td>
</tr>
<tr>
<td><code>URL</code></td>
<td>specifies a .elc file that is located on a remote server, which is accessible by using HTTP or FTP. Specify the <code>URL</code> by using one of the following formats:</td>
</tr>
<tr>
<td><code>http://servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td><code>http://username:password@servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td><code>ftp://servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td><code>ftp://username:password@servername[:port]/path/filename.elc</code></td>
<td></td>
</tr>
<tr>
<td><code>http://[2003:13f8:206:190:204:baef:fe6a:6af0]:2880/mydir/myfile.elc</code></td>
<td>The optional port number <code>:port</code> needs to be specified only if the server is not using the default port.</td>
</tr>
<tr>
<td>You can optionally specify an IPv4 or IPv6 address for the <code>servername</code> value. When specifying an IPv6 address, enclose the address within brackets []; for example:</td>
<td></td>
</tr>
<tr>
<td><code>-diagnostic</code></td>
<td>Displays extended diagnostic messages.</td>
</tr>
<tr>
<td>This option is only useful for detecting problems with the event list. Do not use this command-line option unless you are advised by IBM Software Support.</td>
<td></td>
</tr>
<tr>
<td>`-dualwrite 0</td>
<td>1`</td>
</tr>
<tr>
<td><code>0</code></td>
<td>Disable dual-write mode</td>
</tr>
<tr>
<td><code>1</code></td>
<td>Enable dual-write mode</td>
</tr>
<tr>
<td>The <code>-dualwrite</code> command-line option overrides the DualWrite field entry in the <code>master.national</code> table of the desktop ObjectServer.</td>
<td></td>
</tr>
<tr>
<td><code>-failbackpolltime integer</code></td>
<td>If connected to a backup ObjectServer because failover occurred, the event list periodically attempts to reconnect to the primary ObjectServer. This command-line option specifies the frequency, in seconds, at which the event list polls for the return of the primary ObjectServer. If it is detected that the primary ObjectServer has restarted, the event list disconnects from the backup ObjectServer and reconnects to the primary ObjectServer. The default is 30 seconds. When set to 0, no polling occurs.</td>
</tr>
<tr>
<td><code>BackupObjectServer</code></td>
<td>property setting of the ObjectServer to which it is connecting.</td>
</tr>
<tr>
<td>Polling occurs only if this property is set to true, indicating a backup ObjectServer.</td>
<td></td>
</tr>
<tr>
<td><code>-help</code></td>
<td>Displays help for this command and exits.</td>
</tr>
<tr>
<td><code>-masterserver string</code></td>
<td>Indicates the master ObjectServer to use in a desktop ObjectServer architecture.</td>
</tr>
<tr>
<td>The <code>-masterserver</code> command-line option overrides the MasterServer field entry in the <code>master.national</code> table of the desktop ObjectServer.</td>
<td></td>
</tr>
<tr>
<td><code>-networktimeout integer</code></td>
<td>Specifies a time in seconds after which a login attempt or connection to the ObjectServer will time out, if a network failure occurs. After the specified timeout period, the event list attempts to reconnect to the ObjectServer. If the connection is unsuccessful after a second timeout period, the event list will attempt to connect to a backup ObjectServer, where available. The default is 20 seconds.</td>
</tr>
<tr>
<td><code>-password string</code></td>
<td>Specifies the password to use to log in to the event list.</td>
</tr>
<tr>
<td><code>-server string</code></td>
<td>Specifies the name of the ObjectServer to which you are connecting.</td>
</tr>
</tbody>
</table>
**Table 6. UNIX event list (nco_event) command-line options (continued)**

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-uneditable</td>
<td>Does not allow the event list configuration to be edited. When this option is used, the Filter Builder and View Builder buttons and the Save and Save As menu items are disabled.</td>
</tr>
<tr>
<td>-username string</td>
<td>Specifies the user name to use to log in to the event list.</td>
</tr>
<tr>
<td>-version</td>
<td>Displays version information and exits.</td>
</tr>
</tbody>
</table>

**Tip:** You can abbreviate the command-line options for the event list to their shortest unique abbreviation. For example, `-uneditable` can be abbreviated to `-un`.

**Related tasks:**
“Working with event list configurations” on page 54

**Windows event list command-line options**

When you use the `NCOEvent.exe` command to start the event list on Windows, you can specify a number of command-line options to modify the configuration. You can run this command from the `%NCHOME%\omnibus\desktop` directory.

The following table describes the command-line options for starting the Windows event list.

**Table 7. Windows event list (NCOEvent) command-line options**

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-config string</td>
<td>Specifies the initial configuration file to use, where:</td>
</tr>
<tr>
<td>or</td>
<td><code>string</code> specifies a path to a <code>.elc</code> file.</td>
</tr>
<tr>
<td>-elc string</td>
<td><code>URL</code> specifies a <code>.elc</code> file that is located on a remote server, which is accessible by using HTTP or FTP. Specify the <code>URL</code> by using one of the following formats:</td>
</tr>
<tr>
<td></td>
<td>• <code>http://servername[:port]/path/filename.elc</code></td>
</tr>
<tr>
<td></td>
<td>• <code>http://username:password@servername[:port]/path/filename.elc</code></td>
</tr>
<tr>
<td></td>
<td>• <code>ftp://servername[:port]/path/filename.elc</code></td>
</tr>
<tr>
<td></td>
<td>• <code>ftp://username:password@servername[:port]/path/filename.elc</code></td>
</tr>
<tr>
<td></td>
<td>The optional port number <code>:port</code> needs to be specified only if the server is not using the default port.</td>
</tr>
<tr>
<td></td>
<td>You can optionally specify an IPv4 or IPv6 address for the <code>servername</code> value. When specifying an IPv6 address, enclose the address within brackets []; for example:</td>
</tr>
<tr>
<td></td>
<td>If using FTP, the path must be the full path from the root directory; for example, <code>mydir/myfile.elc</code>.</td>
</tr>
<tr>
<td></td>
<td>For information about IPv6 requirements on Windows, see the IBM Tivoli Netcool/OMNibus Installation and Deployment Guide.</td>
</tr>
<tr>
<td>-diagnostic</td>
<td>Displays extended diagnostic messages.</td>
</tr>
<tr>
<td></td>
<td>This option is only useful for detecting problems with the event list. Do not use this command-line option unless you are advised by IBM Software Support.</td>
</tr>
</tbody>
</table>
Table 7. Windows event list (NCOEvent) command-line options (continued)

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>`-dualwrite 0</td>
<td>1`</td>
</tr>
<tr>
<td></td>
<td>• 0: Disable dual-write mode</td>
</tr>
<tr>
<td></td>
<td>• 1: Enable dual-write mode</td>
</tr>
<tr>
<td></td>
<td>The <code>-dualwrite</code> command-line option overrides the DualWrite field entry in the master.national table of the desktop ObjectServer.</td>
</tr>
<tr>
<td><code>-failbackpolltime integer</code></td>
<td>If connected to a backup ObjectServer because failover occurred, the event list periodically attempts to reconnect to the primary ObjectServer.</td>
</tr>
<tr>
<td></td>
<td>This command-line option specifies the frequency, in seconds, at which the event list polls for the return of the primary ObjectServer.</td>
</tr>
<tr>
<td></td>
<td>If it is detected that the primary ObjectServer has restarted, the event list disconnects from the backup ObjectServer and reconnects to the</td>
</tr>
<tr>
<td></td>
<td>primary ObjectServer. The default is 30 seconds. When set to 0, no polling occurs.</td>
</tr>
<tr>
<td></td>
<td>When an event list connects to an ObjectServer, the event list checks the <code>BackupObjectServer</code> property setting of the ObjectServer to which it</td>
</tr>
<tr>
<td></td>
<td>is connecting. Polling occurs only if this property is set to <code>TRUE</code>, indicating a backup ObjectServer.</td>
</tr>
<tr>
<td><code>-help</code></td>
<td>Displays help for this command and exits.</td>
</tr>
<tr>
<td><code>-masterserver string</code></td>
<td>Indicates the master ObjectServer to use in a desktop ObjectServer architecture.</td>
</tr>
<tr>
<td></td>
<td>The <code>-masterserver</code> command-line option overrides the MasterServer field entry in the master.national table of the desktop ObjectServer.</td>
</tr>
<tr>
<td><code>-networktimeout integer</code></td>
<td>Specifies a time in seconds after which a login attempt or connection to the ObjectServer will time out, if a network failure occurs. After</td>
</tr>
<tr>
<td></td>
<td>the specified timeout period, the event list attempts to reconnect to the ObjectServer. If the connection is unsuccessful after a second timeout</td>
</tr>
<tr>
<td></td>
<td>period, the event list will attempt to connect to a backup ObjectServer, where available. The default is 20 seconds.</td>
</tr>
<tr>
<td><code>-password string</code></td>
<td>Specifies a password to use to log in to the event list.</td>
</tr>
<tr>
<td><code>-server string</code></td>
<td>Specifies the name of the ObjectServer to which you are connecting.</td>
</tr>
<tr>
<td><code>-username string</code></td>
<td>Specifies the user name to use to log in to the event list.</td>
</tr>
<tr>
<td><code>-version</code></td>
<td>Displays version information and exits.</td>
</tr>
</tbody>
</table>

Related tasks:
“Working with event list configurations” on page 54

About the Event List monitor box window

Use this window to view one or more categories of alert information, as configured by your system administrator. Each alert category is depicted by a monitor box, which represents a filter and view that have been created for the event list. Filters enable you to display a subset of alerts based on specific criteria. Views enable you to choose which alert fields to display.

The Event List monitor box window is shown in the following figure.
The Event List monitor box window contains the following areas:

1. Monitor box area
2. Status bar

**Tip:** The title bar of the Event List monitor box window displays the current event list configuration name.

**Monitor box area**

This area displays the monitor boxes, which represent specific filters and a selection of views that can be applied to an associated event list. The monitor boxes that appear on your system may differ, depending on how your system administrator has configured your system. The default Event List monitor box window contains the following filter definitions for individual monitor boxes:

**Last 10 Min.**
This filter displays all alerts except ProbeWatch, TSMWatch, and ConnectionWatch alerts. The results are identical to those for the Default filter, except that the Last 10 Min. filter only displays alerts that occurred in the last 10 minutes.

**In Maintenance**
This filter displays alerts that have been indicated as being "in maintenance" by the operator.
Escalated
This filter displays alerts that have been escalated by the operator.

Information
This filter displays alerts that have been identified as Information alerts.
Information alerts are:
• Alerts that have been designated as Information alerts by probes
• Alerts that are not ProbeWatch, TSMWatch, or ConnectionWatch alerts
• Alerts for which an escalation level has been set

Task List
This filter displays alerts that have been added to the operator's task list.

Netcool Status
This filter displays only ProbeWatch, TSMWatch, and ConnectionWatch alerts.

Default
This filter displays all alerts except ProbeWatch, TSMWatch, and ConnectionWatch alerts.

All Events
This filter displays all alerts.

Status bar
The status bar displays:
• The status message
• The current user name used to log into the session
• The ObjectServer to which you are currently connected and whether it is the primary (PRI) or backup (BAK) server

Monitor box overview
A monitor box on the Event List monitor box window represents a filter and a selection of views that are created to determine which alert records and columns are displayed in an event list. A monitor box is named after its associated filter.

You can configure preferences to determine what type of information is displayed in monitor boxes.

A monitor box on UNIX is shown in the following figure. In this figure, different preferences have been configured for the monitor box.
The components of a monitor box are as follows:

1. **Filter name button**
   This button displays the name of the filter that is associated with the event list that you can access from this monitor box. You can click this button to start the Filter Builder, and view or edit the filter details.

2. **Number**
   This value represents the total number of alerts that match the filter.

3. **Highest**
   If configured as a preference, this value is displayed between **Number** and **Metric**. This value represents the highest severity among the alerts that match the filter.

4. **Lowest**
   If configured as a preference, this value is displayed between **Number** and **Metric**. This value represents the lowest severity among the alerts that match the filter.

5. **Metric**
   This value represents a calculation that is applied to the alerts that match the filter. This derived value shows the average, sum, lowest, or highest value of a selected column in the alerts database table that is being queried by the filter.

6. **Distribution indicator**
   This area uses a lavalamp or bar chart to show the severity distribution of the alerts that match the filter. The colors used in the lavalamp segments or bar chart bars are preconfigured to identify the different severity levels.

7. **View button (UNIX) or ... button (Windows)**
   Click this button to open the event list that contains alerts that match the currently-selected filter and view.

8. **Select view drop-down list**
   This drop-down list contains the names of all the views that have been set up, and displays the name of the view that is currently associated with the event list. You can select a different view from this drop-down list in order to change the selection of columns that are shown in the event list.
You can also use this list to select the X.733 view, which displays X.733-compliant alert information in the event list.

Tip: You can optionally display a colored border around the monitor box. The border color changes according to the highest severity among the alerts that match the filter.

Related tasks:
- “Setting preferences for the UNIX event list” on page 30
- “Setting preferences for the Windows event list” on page 32
- “Setting global preferences for the UNIX Conductor” on page 10
- “Setting global preferences for the Windows Conductor” on page 12
- “Creating or editing a filter on UNIX” on page 78
- “Creating or editing a filter on Windows” on page 81
- “Creating or editing a view on UNIX” on page 96
- “Creating or editing a view on Windows” on page 100

Managing events using the event list

Use the event list to manage events.

About the event list

Within the event list, each event represents a record in the alerts.status table.

You can apply filters and views to incoming alerts to define which alert records and columns are displayed in the event list.

You can set up multiple event list clients, each with different priorities and filters. You can also use the event list to reprioritize alerts, and to assign or reassign problems to other users. When an alert is assigned to a user, the user can acknowledge it, or deacknowledge it so that it can be picked up by another user. The event list is accessible from the Event List monitor box window.

The event list displays alerts in a scrollable list. An event list is shown in the following figure.
Tip: The title bar of the event list displays the names of the filter and view that are currently in use for this event list. The title bar also indicates whether you are using a dual server desktop (DSD).

The event list contains the following areas:

1 Alerts area

The alerts area is made up of rows and columns in a table:

- Each row corresponds to an alert that matches the filter that is currently selected.
- The columns are the alert fields. The selection of columns is controlled by the view that is currently selected.

2 Distribution summary bar

The distribution summary bar depicts the number of alerts that match each severity color. This is the same information as shown on the distribution indicator on the monitor box in the Event List monitor box window.

You can click one of the severity level colors to display only those alerts that match the selected severity.

3 Status bar

The status bar displays:

- Messages about the event list, such as how many items match the current filter condition or were processed by an operation
- The current date and time
• The current user name that is used to log into the session
• The name of the ObjectServer to which the event list is connected, and whether this is the primary (PRI) or backup (BAK) ObjectServer

Event list security
All Tivoli Netcool/OMNIbus users belong to one or more user groups. Each group is assigned one or more roles, which determine the permissions for that group. The desktop tools that a user can access and the tasks that a user can perform with the desktop tools depend on the group to which the user belongs and the roles that are assigned to the group.

The Normal, Administrator, and System groups provide group row level security in the event list. The AlertSecurityModel ObjectServer property determines whether group row level security is enforced in the event list.

By default, the AlertSecurityModel property is disabled, and group row level security is not enforced. In this case:
• A member of the Normal group can modify a row that is assigned to themselves or the nobody user. When an alert is received from the ObjectServer, the alert is assigned by default to the nobody user.
• A member of the Administrator group can modify a row that is assigned to themselves, the nobody user, or a member of the Normal group.

If the AlertSecurityModel property is enabled, only users in the group that owns the row can modify the row. In this case, a member of the Normal or Administrator group can modify a row that is assigned to a group of which they are a member.

A member of the System group can always modify any row.

Related tasks:
"Assigning ownership to events" on page 42
"Acknowledging and deacknowledging events" on page 40

Event severity levels
A severity level is associated with each generated alert to help you to prioritize and manage alerts in the event list. Severity levels are color coded for easy identification.

There are six default severity levels, as shown in the following table.

<table>
<thead>
<tr>
<th>Level</th>
<th>Meaning</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Clear</td>
<td>Green</td>
</tr>
<tr>
<td>1</td>
<td>Indeterminate</td>
<td>Purple</td>
</tr>
<tr>
<td>2</td>
<td>Warning</td>
<td>Blue</td>
</tr>
<tr>
<td>3</td>
<td>Minor</td>
<td>Yellow</td>
</tr>
<tr>
<td>4</td>
<td>Major</td>
<td>Orange</td>
</tr>
<tr>
<td>5</td>
<td>Critical</td>
<td>Red</td>
</tr>
</tbody>
</table>

On Windows, your system administrator can choose to configure additional severity levels.
Setting preferences for the UNIX event list

You can configure what type of information should be displayed on monitor boxes, specify the frequency at which the event list should be refreshed, and set options for alert notification when the event list is minimized. You can also set flashing and other preferences for the event list.

Tip: You can also set global preferences for event lists.

To set preferences for the UNIX event list:
1. From the Event List monitor box window, select Window > Preferences. The Event List Preferences window opens.

2. From the Monitors tab, specify the type of information to be displayed in the monitor boxes on the Event List monitor box window. Complete the tab as follows:
   - **Show Count**
     Select this check box to display the number of alerts that match the filter on monitor boxes.
   - **Show Highest Severity**
     Select this check box to display the highest severity among the alerts that match the filter on monitor boxes.
   - **Show Lowest Severity**
     Select this check box to display the lowest severity among the alerts that match the filter on monitor boxes.
   - **Show Metric**
     Select this check box to display the selected filter metric value on monitor boxes.
   - **Show Severity Border**
     Select this check box to display a colored border around monitor boxes. The border color changes according to the highest severity among the alerts that match the filter.
   - **Show Lavalamp**
     Click this option to display the distribution indicator as a horizontal bar on monitor boxes.
   - **Show Histogram**
     Click this option to display the distribution indicator as a bar graph on monitor boxes.

3. From the Refresh tab, configure an update interval for the event list. Complete the tab as follows:
   - **Timed Refresh**
     Use these fields to indicate whether alert information should be updated at a specified time interval, or whether you prefer to await notification of updates from the ObjectServer. To specify an update frequency, select the Timed Refresh check box and then enter a time (in seconds) in the adjacent field.

     All the latest data from the ObjectServer will be sent to the event list at the specified frequency.
Tip: Timed Refresh forces the event list to reload all its data at a set interval. Do not set the refresh to a low value (for example, less than 60 seconds) because this has an impact on ObjectServer performance and network traffic.

Note: If your system administrator has set the AllowTimedRefresh ObjectServer property to FALSE, refresh timers are disabled and updates occur based on notification from the ObjectServer.

4. From the Notification tab, configure preferences for alert notifications when the event list is minimized. Complete the tab as follows:

Notify When Iconised
Select this check box to receive notification of new, changed, or deleted alerts when the event list is minimized. Notification is received only on desktop environments that display an icon when the event list is minimized. Use the When and How options to set the notification method.

When
Select each check box to receive notification as follows:
- Select New to receive a notification when a new alert is added to the event list.
- Select Change to receive a notification when an existing alert changes in the event list.
- Select Delete to receive a notification when an existing alert is deleted from the event list.

How
Select each check box to indicate how a notification should occur:
- Select Ring Bell to sound the workstation or terminal bell once.
- Select Alert Icon to flash an exclamation mark over the event list icon (UNIX), or flash the minimized event list (Windows).
- Select Open Window to open the event list on the screen. If you use a window manager with interactive placement, the event list opens as the active window.
- Select Run External Command to run a command. If you select this check box, you must type the command name. This function must be used only for simple desktop notification, and is not designed for handling paging applications.

5. From the Flashing tab, specify event list preferences for flashing. Complete the tab as follows:

Enable Flashing
Select this check box to enable event list flashing. Use the Fast/Slow slider to indicate how quickly the event list flashes. Use the Bright/Dark slider to indicate the degree of brightness of the flashing.

6. From the Misc tab, set other event list preferences. Complete the tab as follows:

Show Event List Colors
Select this check box to use color to depict the severity of alerts in the event list. Clear this check box to use a grey background for all event list rows.

Show Distribution Summary
Select this check box to display the distribution summary bar in the event list. This bar displays the number of alerts that match each severity color.
Show Toolbars
Select this check box to make the toolbars available on the event list.

Jump Button On By Default
Select this check box to enable the Jump To Top feature, by default, for all event lists. The Jump to Top feature causes the event list to scroll to the top whenever new events are added, and can help you to quickly review updated events.

Tip: You can also enable the Jump To Top feature for individual event lists so that you can automatically view updates to an event list, or you can disable this feature for individual event lists.

Sort Information Details
Select this check box to sort the detail fields in the Event Information window alphabetically by name of field. When this check box is clear, the detail fields are displayed in an order determined by the ObjectServer.

7. Apply, save, or cancel your changes as follows:

Apply Click this button to apply changes without saving them. This button enables you to test how your changes affect the desktop.

Save Click this button to save any changes made to your preferences.

Tip: To view any changes made to preferences in the event list, you must close and reopen any open event lists.

Close Click this button to close the window without saving your changes.

Undo Click this button to undo any changes that you have made to each of the tabs.

Related tasks:
“Starting the event list” on page 19

Setting preferences for the Windows event list
You can configure what type of information should be displayed on monitor boxes, specify the frequency at which the event list should be refreshed, and set options for alert notification when the event list is minimized. You can also set flashing and other preferences for the event list.

Tip: You can also set global preferences for event lists.

To set preferences for the Windows event list:
1. From the Event List monitor box window, select Window > Preferences. The Event List Preferences window opens.
2. From the Monitor Boxes tab, specify the type of information to be displayed in the monitor boxes on the Event List monitor box window. Complete the tab as follows:

Show Number of Alerts
Select this check box to display the number of alerts that match the filter on monitor boxes.

Show Highest Severity
Select this check box to display the highest severity among the alerts that match the filter on monitor boxes.
Show Lowest Severity
Select this check box to display the lowest severity among the alerts that match the filter on monitor boxes.

Show Metric
Select this check box to display the selected filter metric value on monitor boxes.

Show Severity Border
Select this check box to display a colored border around monitor boxes. The border color changes according to the highest severity among the alerts that match the filter.

Show Lavalamp
Click this option to display the distribution indicator as a horizontal bar on monitor boxes.

Show Histogram
Click this option to display the distribution indicator as a bar graph on monitor boxes.

3. From the Refresh tab, configure an update interval for the event list. Complete the tab as follows:

Timed Refresh
Use these fields to indicate whether alert information should be updated at a specified time interval, or whether you prefer to await notification of updates from the ObjectServer. To specify an update frequency, select the Enabled check box, and then specify a time (in seconds) in the Time (secs) field.

All the latest data from the ObjectServer will be sent to the event list at the specified frequency.

Tip: Timed Refresh forces the event list to reload all its data at a set interval. Do not set the refresh to a low value (for example, less than 60 seconds) because this has an impact on ObjectServer performance and network traffic.

Note: If your system administrator has set the AllowTimedRefresh ObjectServer property to FALSE, refresh timers are disabled and updates occur based on notification from the ObjectServer.

4. From the Notification tab, configure preferences for alert notifications when the event list is minimized. Complete the tab as follows:

Notify When Iconised
Select this check box to receive notification of new, changed, or deleted alerts when the event list is minimized. Notification is received only on desktop environments that display an icon when the event list is minimized. Use the When and How options to set the notification method.

When Select each check box to receive notification as follows:
  • Select New to receive a notification when a new alert is added to the event list.
  • Select Change to receive a notification when an existing alert changes in the event list.
  • Select Delete to receive a notification when an existing alert is deleted from the event list.
How

Select each check box or option to indicate how a notification should occur:

- Select **Ring Bell** to sound the workstation or terminal bell once.
- Click **Alert Icon** to flash an exclamation mark over the event list icon (UNIX), or flash the minimized event list (Windows).
- Click **Open Window** to open the event list on the screen. If you use a window manager with interactive placement, the event list opens as the active window.

**Note:** You cannot select both **Alert Icon** and **Open Window**.
- Select **Run External Command** to run a command. If you select this check box, you must type the command name in the **Command** field. This function must only be used for simple desktop notification, and is not designed for handling paging applications. To run the command at the current time, click **Execute Command Now**.

5. From the **Flashing** tab, specify event list preferences for flashing. Complete the tab as follows:

**Enabled**

Select this check box to enable event list flashing. Use the **Fast/Slow** slider to indicate how quickly the event list flashes. Use the **Bright/Dark** slider to indicate the degree of brightness of the flashing.

6. From the **Misc** tab, set other event list preferences. Complete the tab as follows:

**Show Colours**

Select this check box to use color to depict the severity of alerts in the event list. Clear this check box to use a grey background for all event list rows.

**Show Distribution Summary Bar**

Select this check box to display the distribution summary bar in the event list. This bar displays the number of alerts that match each severity color.

**Show Toolbars**

Select this check box to make the toolbars available on the event list.

**Jump Button On By Default**

Select this check box to enable the Jump To Top feature, by default, for all event lists. The Jump to Top feature causes the event list to scroll to the top whenever new events are added, and can help you to quickly review updated events.

**Tip:** You can also enable the Jump To Top feature for individual event lists so that you can automatically view updates to an event list, or you can disable this feature for individual event lists.

**Sort Information Details**

Select this check box to sort the detail fields in the Event Information window alphabetically by name of field. When this check box is clear, the detail fields are displayed in an order determined by the ObjectServer.

7. Apply, save, or cancel your changes as follows:

**Apply** Click this button to apply changes without saving them. This button enables you to test how your changes affect the desktop.

**Save** Click this button to save any changes made to your preferences.
Tip: To view any changes made to preferences in the event list, you must close and reopen any open event lists.

**Close** Click this button to close the window without saving your changes.

**Undo** Click this button to undo any changes that you have made to each of the tabs.

Related tasks:
- “Starting the event list” on page 19

**Customizing the appearance of the event list**

You can customize the appearance of the event list.

**Resizing columns in the event list**

You can resize the columns in the UNIX and Windows event lists.

To resize the columns in the event list:
1. On UNIX only, press and hold down Shift+Ctrl.
2. Click the mouse button on a column divider.
3. Drag the mouse inwards or outwards to change the width of the column.

Related tasks:
- “Starting the event list” on page 19

**Sorting columns in the event list**

You can sort the data in the columns of the event list in ascending or descending order, and apply secondary sorting to columns.

To sort all events by that column in ascending order, click the column header. To clear the sorting on that column, click the column header again.

To set a column to be sorted in descending order:
1. On UNIX only, press the Shift key.
2. Click the column header to select the sorting column.

**Results**

Any column being used in a sort is marked with a plus (+) or minus (-) symbol. Plus indicates ascending order; and minus indicates descending order. The sorting created is temporary and is not retained in the saved view.

To make a column a secondary sort, click the column header of that column after sorting the first column. For example, if you click the column header for **Severity**, followed by the column header for **Node**, the event list is sorted by ascending severity and then ascending node name.

Related tasks:
- “Starting the event list” on page 19
**Depicting severity using text color on UNIX**

By default, the severity of an event in the event list is indicated by the background color of its row. On UNIX operating systems only, you can configure the event list to use a single background color, and instead use the alert text color to depict severity.

To depict severity using text color:

1. Back up the event list resource definition file $NCHOME/omnibus/desktop/app-defaults/arch/NCOEvent, where arch is your operating system. This step is advisable in case you need to revert to the original file.
2. Edit the NCOEvent file by adding the following X resource lines to define the background and text colors for the event list:

   ```
   NCOEvent*inverseVideo:True
   NCOEvent*clearColour: Black
   NCOEvent*indetColour: Black
   NCOEvent*warnColour: Black
   NCOEvent*minorColour: Black
   NCOEvent*majorColour: Black
   NCOEvent*critColour: Black
   NCOEvent*ackClearColour: Black
   NCOEvent*ackIndetColour: Black
   NCOEvent*ackWarnColour: Black
   NCOEvent*ackMinorColour: Black
   NCOEvent*ackMajorColour: Black
   NCOEvent*ackCritColour: Black
   NCOEvent*caclearTextColour: green3
   NCOEvent*indetTextColour: DarkOrchid2
   NCOEvent*warnTextColour: SteelBlue1
   NCOEvent*minorTextColour: yellow1
   NCOEvent*majorTextColour: #ffffff
   NCOEvent*critTextColour: red1
   NCOEvent*ackclearTextColour: #008000
   NCOEvent*ackIndetTextColour: DarkOrchid4
   NCOEvent*ackWarnTextColour: SteelBlue3
   NCOEvent*ackMinorTextColour: yellow3
   NCOEvent*ackMajorTextColour: #b5ab63bd0000
   NCOEvent*ackCritTextColour: red3
   ```

   **Tip:** In this sample text, the background color is set to Black, but you can specify another color with a good contrast to the text colors specified. If you want to use a different set of colors to depict severity, you might find it useful to verify the selection of colors that are available for use. These colors are listed in the file /usr/openwin/lib/rgb.txt.

3. Save your changes to the file.
4. To ensure that the defined color settings are loaded into your environment, set the XAPPLRESDIR environment variable to the location where the updated resource definition file NCOEvent is stored.

   ```
   NCHOME/omnibus/desktop/app-defaults/arch/
   ```

   Where arch is your operating system directory.

   **Tip:** Set the XAPPLRESDIR environment variable in the .login or .profile initialization file for your shell to make your color settings permanent.

5. Merge the colors with the system colors by entering the following command:
The new colors become available when you open an event list.

**Configuring font sizes for the UNIX event list windows**

The NCOEvent resource file contains definitions for the user interface elements of the event list windows.

You can use this resource file to change the font size of the menus, toolbar buttons, field labels and entries, push buttons, status bar, column headers, and event data in the following event list windows:

- Login window for the event list
- Event List monitor box window
- Event list
- All other windows that are accessible from the monitor box window and event list. These windows include the Filter Builder, the View Builder, and other windows that you open by clicking a menu option.

You can also use the NCOEvent resource file to change other attributes for the event list windows; for example, font types, string values, and colors.

If you use the Conductor ($NCHOME/omnibus/bin/nco &) to provide single sign-on access to the desktop tools, the font changes that you make in the NCOEvent resource file are reflected in the monitor box window, the event list, and the associated windows. If you start the event list from a command prompt ($NCHOME/omnibus/bin/nco_event &), the font changes are reflected in the Login window, the monitor box window, the event list, and associated windows.

To configure font sizes for the UNIX event list windows:

1. Go to the following location:
   
   ```
   $NCHOME/omnibus/desktop/locale/arch/locale_name/app-defaults
   ```
   
   Where `arch` is the operating system directory and `locale_name` is the full locale name; for example en_GB.ISO8859-1. Note that some locale names in this directory might be symbolic links.

   **Tip:** For your changes to be visible, the `locale_name` value must match your current locale. You can run the `locale` command (without any arguments) to list the current locale.

2. Edit the NCOEvent resource file to change the font sizes for the event list resources as required:

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCOEvent*fontList</td>
<td>Affects most of the text on all the windows; for example, menus, toolbar buttons, most field labels, and push buttons.</td>
</tr>
<tr>
<td>NCOEvent*XmText.fontList</td>
<td>Affects descriptive text items such as journal entries.</td>
</tr>
<tr>
<td>NCOEvent*XmTextField.fontList</td>
<td>Affects editable text; for example, the <strong>Username</strong> and <strong>Password</strong> entries in the Login window for the event list.</td>
</tr>
</tbody>
</table>
### Resource Description

<table>
<thead>
<tr>
<th>Resource</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NCOEvent*XmLabel.fontList</td>
<td>Affects non-editable labels; for example, the Username and Password field labels in the Login window for the event list, or the Number and Metric labels on monitor boxes.</td>
</tr>
<tr>
<td>NCOEvent*main_status_line.fontList</td>
<td>Affects the status message that is displayed in the status bar of the monitor box window after login; for example, Ready.</td>
</tr>
<tr>
<td>NCOEvent*main_user_field.fontList</td>
<td>Affects the name of the logged-in user, which is displayed in the status bar of the monitor box window after login.</td>
</tr>
<tr>
<td>NCOEvent*main_server_field.fontList</td>
<td>Affects the ObjectServer name that is displayed in the status bar of the monitor box window after login.</td>
</tr>
<tr>
<td>NCOEvent*sub_status_line.fontList</td>
<td>Affects the status message that is displayed in the status bar of an event list; for example, No rows modified.</td>
</tr>
<tr>
<td>NCOEvent*sub_clock.fontList</td>
<td>Affects the date and time displayed in the status bar of an event list.</td>
</tr>
<tr>
<td>NCOEvent*sub_user_field.fontList</td>
<td>Affects the name of the logged-in user, which is displayed in the status bar of an event list.</td>
</tr>
<tr>
<td>NCOEvent*sub_server_field.fontList</td>
<td>Affects the ObjectServer name that is displayed in the status bar of an event list.</td>
</tr>
<tr>
<td>NCOEvent*sub_matrix.labelFont</td>
<td>Affects the column headers in an event list table.</td>
</tr>
<tr>
<td>NCOEvent*sub_matrix.fontList</td>
<td>Affects the text for the event data in an event list table. <strong>Note:</strong> This resource is not listed in the NCOEvent resource file, but can be added if you want to change the font for the event data. You can copy and paste the NCOEvent<em>sub_matrix.labelFont line, so that it is duplicated within the file. Then amend the pasted line by changing the NCOEvent</em>sub_matrix.labelFont portion to NCOEvent*sub_matrix.fontList</td>
</tr>
</tbody>
</table>

For example, to increase the font size of any of these resources from 12 to 24, you can change `-adobe-helvetica-bold-r-normal--12-**-75-75-**-iso**` to `-adobe-helvetica-bold-r-normal--24-**-75-75-**-iso**`

3. Save your changes.
4. For the changes to take effect, close all open monitor box and event list windows, and then reopen them.

**Related tasks:**
- “Starting the event list” on page 19
- “Starting the Conductor” on page 3

### Displaying the severity colors configured for event lists

The Event List Colors window provides a reference for the severity colors that are configured by your system administrator.

To display the Event List Colors window, select Windows > Colors from the Event List monitor box window. You can keep this window open for reference while you use the event list.
Working with events

To manipulate an event in the event list, you must first select it.

You can use the event list to perform the following tasks:

- Acknowledge, deacknowledge, prioritize, delete, and resolve one or more selected events
- Assign ownership to one or more selected events
- Refresh, freeze, and print the event list
- Search the event list for specific events
- Apply filters and views
- Start the Filter Builder and edit a filter, or start the View Builder and edit a view
- Restrict the number of rows displayed

Selecting and deselecting events

To work with one or more events in the event list, you must first select the events. You can then use the options in the Alerts menu to manipulate the events. You can also deselect one or more events from a list of selected events.

Note: You can right-click an event to access an Alerts pop-up menu. The Alerts menu is configured by your system administrator.

You can select single or multiple events in the following ways:

- To select one event and deselect all other events, click the event row.
- To select multiple, nonsequential events, hold down the Ctrl key and click each event.
- To select multiple, sequential events on UNIX, click to select the first event, hold down the mouse button, and drag the cursor up or down the list. To select multiple, sequential events on Windows, hold down the Shift key and then click to select the first event. Then hold down the mouse button and drag the cursor up or down the list.
- To select all events, click Edit > Select All.
- To select all events that match the value in a particular field (also known as smart matching) on UNIX, hold down the Shift key and click the left mouse button over the field to be matched. To select all events that match the value in a particular field on Windows, hold down Ctrl+Alt and click the left mouse button over the field to be matched. For example, to select all events in the UNIX event list, where the Status field is closed, find an event that displays the Status field as closed. Move the cursor over that field, hold down the Shift key and click the left mouse button over the field.

What to do next

You can deselect single or multiple events in the following ways:

- To deselect all events in the event list, click Edit > Deselect All.
- To deselect an event in a selection of multiple rows, hold down the Ctrl key and click the event.

Related tasks:

“Starting the event list” on page 19
Acknowledging and deacknowledging events

You can acknowledge and deacknowledge events in the event list only if you have permission to do so.

**Note:** You can acknowledge and deacknowledge only the events that are assigned to you, your group, or the nobody user.

To acknowledge all selected events, click **Alerts > Acknowledge**. The status line displays the number of acknowledged events, and the number of events that could not be acknowledged because they are not assigned to you.

If configured by your system administrator, you are required to enter a journal entry whenever you acknowledge an event in the event list. If this is the case, the Journal Entry window opens whenever you acknowledge an event. Complete this window as follows:

*Journal list box*

- If configured by your system administrator, this list box displays existing journal text entered by your system administrator. Complete the journal entry.
- If configured by your system administrator, a prompt window or a pop-up menu might be displayed for you to enter or select information. There is a limit of 4096 characters for each journal entry.

**OK**  
Click this button to save the text entry to the journal and acknowledge the alert. This text is appended to the journal of the selected alert or alerts when the tool is used. Your user name, and the date and time, are automatically added.

**Close**  
Click this button to close this window without saving your entry.

To deacknowledge all selected events, click **Alerts > Deacknowledge**. The status line displays the number of deacknowledged events, and the number of events that could not be deacknowledged because they are not assigned to you.

**Related tasks:**
- “Starting the event list” on page 19
- “Selecting and deseleting events” on page 39

Prioritizing events

You can prioritize events in the event list by changing the event severity, escalating or de-escalating the event, suppressing the event, hiding the event, and indicating that the event is “in maintenance”.

**Changing the severity of events:**

Each event in the event list has an associated severity, which is indicated by the color in the display. You can change the severity of events only if you have permission to do so, and you can change only the severity of events that are assigned to you, your group, or the nobody user.

To change the severity of selected events, click **Alerts > Prioritize > Change Severity**, and then select a priority setting from the submenu. The status line displays the number of events that have had their severity set, and the number of events whose severity could not be set because they are not assigned to you.
Related tasks:
“Starting the event list” on page 19
“Selecting and deselecting events” on page 39

Escalating and de-escalating events:

You can escalate events in the event list if, for example, you need to call attention to the events so that different levels of support staff can manage them. Escalating and de-escalating events works in conjunction with the Escalated event list filter.

You can escalate and de-escalate events only if you have permission to do so.

The escalation levels are:
• Normal
• Escalated
• Escalated-Level 2
• Escalated-Level 3

To escalate or de-escalate selected events, click Alerts > Prioritize > Suppress/Escalate, and then select an escalation level from the submenu. Escalated events appear in the Escalated monitor box.

To remove the escalated status from selected events, click Alerts > Prioritize > Suppress/Eescalate > Normal.

Related tasks:
“Starting the event list” on page 19
“Selecting and deselecting events” on page 39

Suppressing events:

From the event list, you can suppress events that do not require you to take any direct action. You can suppress events only if you have permission to do so.

For example, you might receive secondary events that are related to the actual event that needs to be dealt with.

When you suppress an event, it is suppressed in all operator event lists.

To suppress selected events, click Alerts > Prioritize > Suppress/Escalate > Suppress.

To remove the suppressed status from selected events, click Alerts > Prioritize > Suppress/Escalate > Normal.

Related tasks:
“Starting the event list” on page 19
“Selecting and deselecting events” on page 39
Hiding events:

You can hide events that you no longer want to view in the event list. Typically, hidden events are not displayed in any monitor boxes or event lists, except for those using the All Events filter.

You can hide events only if you have permission to do so.

To hide selected events in the event list, click Alerts > Prioritize > Suppress/Escalate > Hidden. This sets the value of the SuppressEscl field to 5 in the alerts.status table. When you hide an event, it is hidden in all operator event lists except those where the filter allows for a match of SuppressEscl=5.

To remove the hidden status from events, open an event list that uses the All Events filter, select the alerts, and then click Alerts > Prioritize > Suppress/Escalate > Normal.

Related tasks:
- “Starting the event list” on page 19
- “Selecting and deselecting events” on page 39

Indicating that an event is "in maintenance":

If the problem that caused an event is being dealt with, you can indicate that the event is "in maintenance", in the event list. The Maintenance priority works in conjunction with the Maintenance event list filter.

You can indicate that an event is in maintenance only if you have permission to do so.

To indicate that selected events in the event list are "in maintenance", click Alerts > Prioritize > Suppress/Escalate > Maintenance. The events are displayed in the In Maintenance monitor box.

To remove the "in maintenance" status from selected events, click Alerts > Prioritize > Suppress/Escalate > Normal.

Related tasks:
- “Starting the event list” on page 19
- “Selecting and deselecting events” on page 39

Assigning ownership to events

When an event arrives from a probe, the event is owned by the nobody user unless ownership of the event has been assigned to a specific user. Users with appropriate privileges can take ownership of events throughout the problem lifecycle, or assign events to a specific user or group.

The OwnerUID and OwnerGID columns provide this capability to work as an individual or as a member of a team. (The OwnerUID column holds the Tivoli Netcool/OMNibus user ID of the owner of the event, and the OwnerGID column holds the group ID.)

As soon as an event is owned by a user, only that person or a user with higher privileges can modify the event. If an event is assigned to a group, the OwnerUID is reassigned to the nobody user. After an event is assigned to a group, only a member of that group or a user with higher privileges can modify the event.
Note: The users or groups to which you can assign events depends on your security permissions. If you are a normal user, you can assign only the events assigned to you, your group, or the nobody user.

To assign ownership of events:
1. From the event list, select one or more events.
2. Assign the events to another user, another group, or yourself, as follows:
   - To assign selected events to another user, click Alerts > Ownership > Assign to User, and then select a user from the submenu.
   - To assign selected events to another group, click Alerts > Ownership > Assign to Group, and then select a group from the submenu. When you assign an event to another group, the event is owned by the nobody user in that group.
   - To assign selected events to yourself, click Alerts > Ownership > Assign to User, and then select your name from the submenu. Alternatively, click Alerts > Ownership > Take Ownership.

Related tasks:
- “Starting the event list” on page 19
- “Selecting and deselecting events” on page 39

Refreshing an event list
The event list refreshes automatically at regular intervals to show all incoming alerts. You can choose to refresh the event list between the configured intervals to view all the latest alerts at the current point in time.

To refresh any open event list, click View > Refresh from that event list window.

Tip: You can also update all the information in all open event list windows at any time, by clicking View > Refresh All from the Event List monitor box window.

Freezing an event list
You can freeze any open event list so that updates from the ObjectServer are not displayed.

To freeze an event list, click View > Freeze from that event list window.

To restart automatic updates from the ObjectServer, click View > Freeze again.

Tip: You can also freeze and unfreeze all open event lists, by clicking View > Freeze All from the Event List monitor box window.

Resolving events
From the event list, you can display a list of known resolutions, which are determined by the class of the event.

To resolve events, click Alerts > Resolve. This option is normally not available because of the dynamic nature of the Alerts menu.

Related tasks:
- “Starting the event list” on page 19
Deleting events
You can delete an event only if you have permission to do so.

To delete one or more events in the event list, select the events to be deleted and then click Alerts > Delete.

Related tasks:
“Starting the event list” on page 19
“Selecting and deselecting events” on page 39

Displaying event information in full
From the event list, you can view full details of any selected events. Event information that is stored in the alerts.status, alerts.details, and alerts.journal database tables is shown.

To display full information about one or more events:
1. From the event list, perform one of the following actions:
   - To view information for a single event, double-click the event, or select the event and then click Alerts > Information.
   - To view information for multiple events, select the events and then click Alerts > Information.

   The Event Information window opens.

2. Use this window as follows:
   
   Alert Fields
   Click this tab to view a list of all the columns and their corresponding values for a selected event. This information is stored in the ObjectServer alerts.status table. You can click any column in the list to see the complete text for its value in the field below the list of columns. The full value of the Summary column is shown by default.

   Alert Details
   Click this tab to view alert details that are stored in the ObjectServer alerts.details table.

   Journal
   Click this tab to view the journal entries for the event, as stored in the ObjectServer alerts.journal table.

   You can enter additional journal entries by clicking Add To Journal to open the full Journal window for the event that is currently selected. On completion, close this window to return to the Event Information window.

   Tip: While within any of the tabs, you can copy alert information from the Event Information window to the clipboard. Select the information that you want to copy, right-click the selected text, and then click Copy to Clipboard (UNIX) or Copy (Windows) from the pop-up menu. You can then paste this information into another application.

Previous
   If you selected multiple events from the event list, click this button to display detailed information for the previous event in your selection.
   This action can fail if events have been deleted elsewhere in the system.

Next
   If you selected multiple events from the event list, click this button to display detailed information for the next event in your selection. This action can fail if events have been deleted elsewhere in the system.
Adding events to the task list

You can use the task list to identify events that require special attention. Adding events to the task list works in conjunction with the Task List event list filter.

To add events to the task list, select the events in the event list, and then click Alerts > Task List > Add to Task List. The events are shown in the Task List monitor box.

You can also remove events from the task list. Select the events and then click Alerts > Task List > Remove from Task List.

Viewing related events

The event list contains tools that can help you to locate related events on the network. You can view various types of events that are related to a selected event.

To view events that are related to an event:

1. Select the event in the event list.
2. Perform any of the following actions depending on the type of related events that you want to see:
   - To view events that are on the same node as the node indicated by the selected event, click Alerts > Related Events > Near-End Events > Entire Node.
   - To view events that are on the same node and for the same local root object indicated by the selected event, click Alerts > Related Events > Near-End Events > Managed Object Instance.
   - To view events for a node that is indicated as the remote node by the selected event, click Alerts > Related Events > Far-End Events > Entire Node.
   - To view all events that indicate the node from the selected event as a remote node, click Alerts > Related Events > Far-End Events > Entire Node.
   - To view events for a node that is indicated as the remote node by the selected event and for which its local root object matches the remote root object of the selected event, click Alerts > Related Events > Far-End Events > Managed Object Instance.
   - To view all events that indicate the node from the selected event as a remote node, and indicate a remote root object that matches the local root object of the selected event, click Alerts > Related Events > Far-End Events > Managed Object Instance.

Results

A separate event list window opens for each set of related events.


Related tasks:
“Starting the event list” on page 19

Restricting the number of rows displayed
Your system administrator can restrict the number of rows that you can see in the event list, and give you the ability to change the number of rows that are displayed, within a defined range. These permissions are configured in the View Builder.

The following figure shows an event list where the system administrator has permitted the user to display between 10 and 30 events, as indicated by the Top [10-30] field label. In the adjacent field, the user has chosen to display 20 events.

![Figure 6. Top [Min-Max] field for restricting event list rows](image)

To change the number of rows that are displayed, enter the required number in the Top [Min - Max] field. This number must fall within the limits specified by the minimum-to-maximum range.

If the field label reads Top [FIXED], you cannot change the number of events displayed.

If the field label reads Top [OFF], there is no restriction on the number of events displayed.

Related tasks:
“Starting the event list” on page 19

Maintaining a journal for an event
Tivoli Netcool/OMNibus provides a journal facility within which you can enter and store event history information. You can maintain a journal for any event in the event list.

To open and maintain a journal for an event:
1. From the event list, select the event, and then click Alerts > Journal. The Journal window opens.

   Tip: You can also access the Journal window while within the Event Information window for a selected event. From the Journal tab, click the Add to Journal button.

2. Complete this window as follows:

   Journal information list boxes
   The upper list box is read-only and displays the existing journal history text. For each entry, the name of the user who entered the information, and the date and time when they entered this information, are shown. You can use the Alerts menu while within this window by right-clicking within this list box.
Use the lower list box to add a text entry to the journal. There is a limit of 4096 characters for each journal entry. When you have completed the text entry, click Apply to save the text within the upper list box. The new text is saved as the last entry, and your user name, and the date and time, are automatically added.

Apply to All Selected
Select this check box if you want to add the newly-entered text to all events that are selected in the event list, and not just to the event whose serial number is displayed at the top of the window. To save the text entry to the journal for each selected event, click Apply.

OK  
Click this button to save newly-entered text and close the window.

Previous
If you selected multiple events in the event list, click this button to move to the journal entry for the previous event in your selection.

Next
If you selected multiple events in the event list, click this button to move to the journal entry for the next event in your selection.

Apply
Click this button to save newly-entered text to the journal. The Journal window remains open for further entries. This button is useful if you have selected multiple events and want to add different journal entries for them.

Close
Click this button to close this window. You are prompted to save any unsaved changes before the window closes.

Related tasks:
“Starting the event list” on page 19

Searching for event list data
You can search for event list data in a number of ways. You can enter specific text to search for, use a filtering facility to quickly find matching occurrences of data, and filter event list data by severity.

Searching for text in the event list:
You can search the event list for event data that matches a specific value that you enter. You can search for data within a specific column and specify options to narrow down the search.

To search for text in the event list:
1. From the event list, click View > Find. The Find window opens.
2. Complete this window as follows:

   Column list/Column
   Select the column on which you want to search.

   Value  Type the search value that you want to match. You can enter an exact value to search for, or enter a regular expression.

   Options
   Specify the type of match required:
   • Select Case Sensitive if you want to find only occurrences that exactly match the case of the search value. This option is available only on Windows.
   • Click Exact Match to find rows where the data in the selected column exactly matches the specified search value.
• Click **Regular Expression** to find rows where the data in the selected column matches the specified regular expression.

• Click **Sub String** to find rows where the data in the selected column contains the specified value somewhere in it.

You can choose only a single option from **Exact Match**, **Regular Expression**, and **Sub String**.

**Find**  
Click this button to find the first matching occurrence. If a matching row is found in the event list, any currently-selected rows are deselected, and the matching row is selected. The Find window remains open so that you can view any additional matching occurrences.

**Next**  
Click this button to show the next match, and subsequent matches, in the event list.

**Close**  
Click this button to close this window.

**Related tasks:**

**“Starting the event list” on page 19**

**Quickly filtering events:**

You can use the quick filtering facility as a fast way of displaying events that match a selected criteria. For example, you can quickly display only those events that occurred at the same time as, or before, the selected event.

To quickly filter events:

1. From the event list, select a cell that contains a value on which to base the quick filter.

2. Click **Alerts > Quick Filter**, and then select one of the following options from the submenu:
   - **Equals**
   - **Not Equals**
   - **Greater Than**
   - **Greater Than or Equals**
   - **Less Than**
   - **Less Than or Equals**
   - **Like**
   - **Not Like**

The event list refreshes to display only those events that match the specified filter criteria.

**What to do next**

To remove quick filtering and restore the event list to its original view of all events, click **Alerts > Quick Filter > Off**. Alternatively, click the **All Events** button on the distribution status bar, which is shown in the following figure.

![Figure 7. All Events button on the distribution status bar](image)
Note: The All Events button on the distribution status bar is only available when using quick filtering or severity filtering. On UNIX, this button flashes to indicate that filtering is active.

Related tasks:
“Starting the event list” on page 19

Filtering events by severity:

You can filter the event list data to display only those events that match a particular severity.

To filter by a particular severity, click the required severity color on the event list distribution status bar. For example, to see only those events with a severity level of minor (associated with the color yellow), click the yellow button on the distribution status bar.

The event list refreshes to display only alerts with a severity level of minor.

To remove severity filtering and restore the event list to its original view of all events, click the All Events button on the distribution status bar. Alternatively, click the severity color on the distribution status bar again.

Figure 8. All Events button on the distribution status bar

Note: The All Events button on the distribution status bar is available only when using quick filtering or severity filtering. On UNIX, this button flashes to indicate that filtering is active.

Related tasks:
“Starting the event list” on page 19

Automatically viewing updates to the event list

You can control how the event list scrolls when an update occurs. The Jump to Top feature can help you to quickly review updated events.

When the Jump to Top feature is enabled, the event list automatically scrolls to the top row whenever new events are added to the event list. If you disable the Jump to Top feature, the event list retains its current state when updates occur.

To enable the Jump to Top feature, click View > Jump To Top. This menu option has a toggle effect, so that if you click the Jump To Top option again, the Jump to Top feature becomes disabled.

Tip: You can ensure that the Jump to Top feature is enabled every time you open an event list. From the Event List monitor box window, click Windows > Preferences to open the Event List Preferences window. On the Misc tab of this window, select the Jump Button on By Default option.

Related tasks:
“Starting the event list” on page 19
Copy data from the event list
You can copy event data from the event list to the clipboard for use in other applications.

To copy data:
1. From the event list, select an event field. A black box surrounds the field.
2. Click Edit > Copy to Clipboard.

What to do next
You can then paste this information into another application.

Tip: You can also copy alert information from the Event Information window.

Related tasks:
“Starting the event list” on page 19
“Displaying event information in full” on page 44

Changing the event information displayed
You can change the columns that are displayed within the current event list by editing the event list view, or by selecting a different view. You can also edit the filter criteria that is used by the current event list, or select a different filter for the event list.

From the event list, perform any of the following actions:
• To edit the current view, click Edit > Edit View. The View Builder opens, which you can use to edit the view.
• To select a different view, click the view drop-down list on the toolbar and select from the list of available views.
• To edit the current filter, click Edit > Edit Filter. The Filter Builder opens, which you can use to edit the filter.
• To select a different filter, click the filter drop-down list on the toolbar and select from the list of available filters.

Related tasks:
“Starting the event list” on page 19
“Creating or editing a filter on UNIX” on page 78
“Creating or editing a filter on Windows” on page 81
“Creating or editing a view on UNIX” on page 96
“Creating or editing a view on Windows” on page 100

Printing the contents of an event list
You can print the current view of an event list. Different print options are available for UNIX and Windows. On UNIX, you can control the formatting of the output.

You can choose to print all alerts or a selection of alerts. If you want to print a selection of alerts, you can select the alerts by clicking across to the event list and making your selections while the Print window is still open.

To print an event list on Windows:
1. From the event list, click File > Print. The standard Windows Print window opens.
2. Complete the window options and click OK to print.
To print an event list on UNIX:

1. From the event list, click File > Print. The Print window opens.
2. Complete this window as follows:

   **Printer**
   
   Click the Printer option to send the print output to a printer.

   **File**
   
   Click the File option to send the print output to a file.

   **Printer**
   
   If you selected the Printer option, type the name of the printer.

   **File**
   
   If you selected the File option, type the path and name of the file to which you want to send the output.

   Alternatively, click the File button to display a file selection window, and navigate to the directory and file name. From the Print to File window, specify a file name and then click OK to return to the Print window.

   **All Alerts In View**
   
   Select this option to print all the alerts in the current event list.

   **Selected Alerts**
   
   Select this option to print only selected alerts.

   **Row Separators**
   
   Select this check box to insert row separators into the output; for example, a dashed line between each row.

   **Row Numbers**
   
   Select this check box to add the row number to each row output.

   **Column Separators**
   
   Select this check box to insert column separators into the output; for example, a pipe ( | ) character at the start and end of fields.

   **Column Headings**
   
   Select this check box to add the column headings to the top of the output file.

   **OK**
   
   Click this button to print the event list by using your selected print settings.

   **Cancel**
   
   Click this button to cancel the print action.

**Related tasks:**

- “Starting the event list” on page 19
- “Selecting and deselecting events” on page 39

**Using tools to manage events**

Your system administrator can define tools to be used for manipulating events in the event list, and add these tools to the Tivoli Netcool/OMNIbus desktop menus for your use. You can use such tools to run SQL commands on the ObjectServer, and to run external commands such as a local application batch file, or script.

A number of standard tools are provided with event list. These include the Ping and Telnet tools. These can be run independently of events.
Issuing Ping commands:

The Ping tool runs the Ping command on the value in the Node column of the alerts.status table.

To issue a Ping command, perform either of the following actions from the event list:

- Select the required row that contains the node that you want to ping. Then click Alerts > Tools > Ping, or right-click and then click Tools > Ping. The status of the node is returned within the Tool Output window.
- Click Tools > Ping to issue a ping command to any host. The Tool Parameter window (UNIX) or Internal Command Parameters window (Windows) opens. Complete this window as follows:

  Name of the host
  Type the IP address or host name of the workstation that you want to access.

  OK
  Click this button to run the command.

  If you ran the Ping tool, it returns the status of the node within the Tool Output window. If you ran the Telnet tool, it connects to the remote host workstation.

  Cancel
  Click this button to close this window without issuing the command.

Related tasks:
“Starting the event list” on page 19

Issuing Telnet commands:

The Telnet tool runs a Telnet session to the value held in the Node column of the alerts.status table.

To run the Telnet tool:
1. From the event list, click Tools > Telnet. The Tool Parameter window opens.
2. Complete this window as follows:

  Name of the host
  Type the IP address or host name of the workstation that you want to access.

  OK
  Click this button to run the command.

  If you ran the Ping tool, it returns the status of the node within the Tool Output window. If you ran the Telnet tool, it connects to the remote host workstation.

  Cancel
  Click this button to close this window without issuing the command.

Related tasks:
“Starting the event list” on page 19
Running tools configured by your system administrator:

If your system administrator has created tools to use in event management, you can run these tools on events in the event list.

If configured, you can run tools in a number of ways:

- From the Conductor window on UNIX, click the tool in the Tools menu.
- From the Conductor menu on Windows, click Tools and then click the tool in the submenu.
- From the Event List monitor box window, click the tool in the Tools menu.
- From the event list, click Alerts > Tools and then click the required tool in the submenu. Alternatively, you can right-click and then click Alerts > Tools in the pop-up menu.

Performing collective actions on event lists

On the Event List monitor box window, each monitor box represents an event list containing events that match a specific configuration of filters and views. You can access each event list separately and manage the events. You can also perform a number of collective actions on all of the event lists.

These actions include refreshing and resynchronizing events in the event lists, freezing updates to the event lists, and closing all open event lists.

Refreshing all event lists

The event list refreshes automatically at regular intervals to show all incoming events. You can choose to refresh the event list between the configured intervals to view all the latest events at the current point in time.

To update all information in the event list windows at any time, click View > Refresh All from the Event List monitor box window.

Tip: You can also individually refresh any open event list, by clicking View > Refresh from that event list window.

Resynchronizing all event lists

If your system administrator makes any configuration changes, you must resynchronize the event list. You can resynchronize the event lists with configurations for all objects, or you can choose individual objects such as column visuals, alert classes, users, groups, menus, or services.

To resynchronize the event lists that are available from the Event List monitor box window, click File > Resync and then select the required resync option.

The resynchronization process works differently on UNIX and Windows event lists. On UNIX event lists, views that are currently selected are not resynchronized; however, any columns added to the selected views by using the View Builder reflect resynchronized values.

On Windows event lists, only the views that are currently selected in monitor boxes are resynchronized. If you use a monitor box to select a different view after resynchronizing, it will not be resynchronized.
Freezing all event lists
You can freeze all open event lists so that updates from the ObjectServer are not displayed.

To freeze all open event lists, click View > Freeze All from the Event List monitor box window.

To restart automatic updates from the ObjectServer, click View > Freeze All again.

Tip: You can also individually freeze and unfreeze any open event list, by clicking View > Freeze from that event list window.

Closing all event list windows
When multiple event lists are open, you can close them all in a single action.

To close all open event list windows, click Windows > Close All Event Windows from the Event List monitor box window.

Working with event list configurations
You can save the filter, view, and other event configurations that are defined for all the monitor boxes on the Event List monitor box window. This information is saved within an event list configuration (.elc) file.

You can create as many different configuration files as you need and you can load a different configuration file into the Event List monitor box window at any time.

You can open event list configurations that are saved locally or that are held on a remote server. You can also save event list configurations locally, or to a remote server that is accessible by using HTTP or FTP.

Related reference:
“UNIX event list command-line options” on page 20

Saving local event list configurations
From the Event List monitor box window, you can save the filter, view, and other alert configurations that are defined for the current group of monitor boxes, and later apply this configuration to event lists. You might find it useful to save if you have modified any of the filters that are configured for the current monitor boxes.

You can save configuration changes to the same file or to a different file. The title bar of the Event List monitor box window generally includes the file name of the current event list configuration. If the title bar of the Event List monitor box window displays [None] in place of a file name, this means that the configuration is as yet unsaved. You must save event list configuration files with a .elc extension.

To save your changes to the event list configuration file that is shown in the title bar of the Event List monitor box window, click File > Save. The Save Configuration window opens. Click OK to overwrite the file with your changes.

To save an unsaved event list configuration or to save the current event list configuration with another file name, click File > Save As. The Save Configuration
window opens. Select another directory and file name, and click OK. The Event List monitor box window refreshes to show the configuration file name in the title bar of the event list.

Related tasks:

- “Starting the event list” on page 19

Opening local event list configurations

If you had previously saved one or more event list configurations locally, you can open any of the associated event list configuration files in order to monitor and manage events that match the defined filters and views.

Tip: Event list configuration file names have a .elc extension.

To open a local event list configuration file:
1. From the Event List monitor box window, click File > Open. The Save Configuration window opens.
2. Complete this window as follows:
   - **Filter**
     Use this field to specify a search query for the type of file that you want to open. This field works in conjunction with the Filter button and the Files list. Enter the current directory path and file type in the Filter field, and then click Filter. All matching files are displayed in the Files list.
     For example, to display all the filter files in the /myfiles/filters directory, enter /myfiles/filters/*.elf and click Filter to view all matching files.
   - **Directories**
     This list displays all of the subdirectories in the current directory. To refresh the directory, double-click the '.' entry. To move up the directory tree by one directory, double-click the '..' entry.
   - **Files**
     This list displays the files in the current directory, which match the selection in the Filter field. Select the name of the file that you want to open. You can also select an existing file that you want to overwrite.
   - **Selection**
     The path and name of the file that you are saving or opening are shown here. You can edit the path and file name to open a different file, to save a file to another location, or to save a file by using a different file name.
     If you are saving a view, use a .elv extension in the file name. If you are saving a filter, use a .elf extension in the file name. If you are saving an event list configuration, use a .elc extension in the file name.
   - **Backup Existing Files (UNIX only)**
     Select this check box to create a backup of an existing view file if the file name that you are saving already exists. This check box is displayed only if you are saving a filter, view, or event list configuration.
   - **OK**
     Click this button to open or save the file.
   - **Filter**
     This button works in conjunction with the Filter field and the Files list. Click this button to display files in the current directory based on your selection in the Filter field. The files appear in the Files list.
Opening remote event list configurations

You can open a remote event list configuration file in order to open one or more event lists that are located on a remote server. The server must be accessible using HTTP or FTP.

To open a remote event list configuration file:

1. From the Event List monitor box window, click File > Open. The Open Configuration window opens.

2. Complete this window as follows: In the File name field, type a Web address for the remote file and click OK. You must use one of the following formats for the Web address:
   - http://servername[:port]/path/filename.elc
   - http://username:password@servername[:port]/path/filename.elc
   - ftp://servername[:port]/path/filename.elc
   - ftp://username:password@servername[:port]/path/filename.elc

   The optional port number :port needs to be specified only if the server is not using the default port. For HTTP, a Web server must be running on the remote host.

   You can optionally specify an IPv4 or IPv6 address for the servername value. When specifying an IPv6 address, enclose the address within brackets []; for example:

   For FTP, the path is the relative path from the home directory; for example, /mydir/myconfig.elc.

   A copy of the remote file is written to a local cache. On Windows systems, when you specify a remote file that you have previously opened, the cached copy is used. If the remote file cannot be retrieved, an error message is displayed.

   For information about IPv6 requirements on Windows, see the IBM Tivoli Netcool/OMNIbus Installation and Deployment Guide.

Results

If the retrieval was successful, the Event List monitor box window refreshes to show the monitor boxes within that configuration, and the selected configuration file name is displayed in the title bar of the event list.

Related tasks:

“Starting the event list” on page 19
Saving remote event list configurations

If you have opened an event list configuration from a remote server on the network, you are not permitted to save it onto that server. You must save the file to a different location. The server must be accessible by using HTTP or FTP.

To save a remote event list configuration:
1. From the Event List monitor box window, click File > Save As. The Save Configuration window opens.
2. Specify the location where you want to save the event list configuration file and then save the file with a .elc file extension. The default location to save the file is as follows:
   - UNIX: The working directory from which you started the event list
   - Windows: Your temporary internet files folder

What to do next

Note: If you attempt to use File > Save to save the event list configuration file, an error message is displayed. Then the Save Configuration window opens, allowing you to save a local copy.

Creating and editing event list configurations on UNIX

You can create or edit event list configurations that hold your filter and view definitions for the monitor boxes that appear within the Event List monitor box window.

You can specify how many monitor box columns should be displayed on the Event List monitor box window, specify which filters and views should be applied to the associated event lists, and specify the order in which the filters and views should be displayed.

To create or edit an event list configuration on UNIX:
1. From the Event List monitor box window, perform either of the following actions:
   - If you are creating a new event list configuration, clear the current event list configuration and set the configuration to the default settings. To do this, click File > New.
   - If you are editing an existing event list configuration that is on display in the Event List monitor box window, go to step 2.
2. Click Windows > Configuration. The Event List Configuration window opens.
3. Complete this window as follows:
   - Name: If you are creating a new event list configuration, type a unique name for the event list configuration.
   - Columns: Use the slider box to specify the number of monitor box columns that are allowed in the Event List monitor box window.
   - Filters/Views: Click this button to switch between the filters and views that are part of this event list configuration. The filters or views appear in the list below this button.
**Note:** The order in which filters and views appear in the Event List Configuration window determines the order in which the event list pop-up menus and drop-down lists display the filter and view lists. You can use the **Top**, **Up**, **Down**, and **Bottom** buttons to change this order.

**New**  To create a new filter or view, click this button to open the Filter Builder or View Builder.

**Attention:** While within the Filter Builder or View Builder, if you specify a filter or view name that already exists in the event list configuration, the existing filter or view is replaced.

**Edit**  To edit a filter or view, select the relevant filter or view from the adjacent list, and then click this button to open the Filter Builder or View Builder for the selected filter or view. If you change the name of the filter or view to a name that does not exist in the event list configuration, a new filter or view is created. If you change the name to one that already exists, the new filter or view replaces the existing filter or view in the event list configuration.

**Load**  To load an existing filter or view into the event list configuration, click this button. From the Filter Load window, navigate to the location where the filter or view is stored, select it, and then click **OK**. The filter or view is added to the list in the Event List Configuration window.

**Tip:** Filters have a `.elf` extension. Views have a `.elv` extension.

**Delete**  To delete a filter or view from the event list configuration, select the relevant filter or view from the adjacent list, and then click this button to delete the selected filter or view. You are not prompted to confirm the deletion, so ensure that you have selected the appropriate filter or view before clicking **Delete**.

**Top**  To move a filter or view to the top of the list, select the relevant filter or view from the adjacent list, and then click this button.

**Up**  To move a filter or view one position up in the list, select the relevant filter or view from the adjacent list, and then click this button.

**Down**  To move a filter or view one position down in the list, select the relevant filter or view from the adjacent list, and then click this button.

**Bottom**  To move a filter or view to the bottom of the list, select the relevant filter or view from the adjacent list, and then click this button.

**Close**  Click this button to close the Event List Configuration window and apply the event list configuration to the current event list.

4. To save the event list configuration, click **File > Save As** from the monitor box window. The Save Configuration window opens.

5. Complete this window as follows:

**Filter**  Use this field to specify a search query for the type of file that you want to open. This field works in conjunction with the **Filter** button and the **Files** list. Enter the current directory path and file type in the **Filter** field, and then click **Filter**. All matching files are displayed in the **Files** list.
For example, to display all the filter files in the /myfiles/filters directory, enter /myfiles/filters/*.elf and click Filter to view all matching files.

Directories
This list displays all of the subdirectories in the current directory. To refresh the directory, double-click the '.' entry. To move up the directory tree by one directory, double-click the '..' entry.

Files
This list displays the files in the current directory, which match the selection in the Filter field. Select the name of the file that you want to open. You can also select an existing file that you want to overwrite.

Selection
The path and name of the file that you are saving or opening are shown here. You can edit the path and file name to open a different file, to save a file to another location, or to save a file by using a different file name.

If you are saving a view, use a .elv extension in the file name. If you are saving a filter, use a .elf extension in the file name. If you are saving an event list configuration, use a .elc extension in the file name.

Backup Existing Files (UNIX only)
Select this check box to create a backup of an existing view file if the file name that you are saving already exists. This check box is displayed only if you are saving a filter, view, or event list configuration.

OK
Click this button to open or save the file.

Filter
This button works in conjunction with the Filter field and the Files list. Click this button to display files in the current directory based on your selection in the Filter field. The files appear in the Files list.

Cancel
Click this button to close this window without opening or saving a file.

Related tasks:
“Starting the event list” on page 19

Creating and editing event list configurations on Windows
You can create or edit event list configurations that hold your filter and view definitions for the monitor boxes that appear within the Event List monitor box window.

You can specify how many monitor box columns should be displayed on the Event List monitor box window, specify which filters and views should be applied to the associated event lists, and specify the order in which the filters and views should be displayed.

To create or edit an event list configuration on Windows:
1. From the Event List monitor box window, perform either of the following actions:
   • If you are creating a new event list configuration, clear the current event list configuration and set the configuration to the default settings. To do this, click File > New.
   • If you are editing an existing event list configuration that is on display in the Event List monitor box window, go to step 2 on page 60.
2. Click **Window > Configuration**. The Event List Configuration window opens.

3. Complete this window as follows:

   **Name**  If you are creating a new event list configuration, type a unique name for the event list configuration.

   **Tip:** Use the spin box in the toolbar to specify the number of monitor box columns that are allowed in the Event List monitor box window.

   **Filters tab**
   Click this tab to specify which filters are part of this event list configuration. The selected filters are displayed in the list on this tab. You can use the **New** button to add a new filter to the event list configuration, the **Open** button to load an existing filter into the event list configuration, or the **Edit** button to edit an existing filter in the event list configuration. You can also use the **Delete** button to remove a filter.

   **Note:** The order in which filters appear in the tab determines the order in which the event list pop-up menus and drop-down lists display the filter lists. You can use the **Top**, **Up**, **Down**, and **Bottom** arrow buttons to change this order.

   **Views tab**
   Click this tab to specify which views are part of this event list configuration. The selected views appear in the list on this tab. You can use the **New** button to add a new view to the event list configuration, the **Open** button to load an existing view into the event list configuration, or the **Edit** button to edit an existing view in the event list configuration. You can also use the **Delete** button to remove a view.

   **Note:** The order in which views appear in the tab determines the order in which the event list pop-up menus and drop-down lists display the view lists. You can use the **Top**, **Up**, **Down**, and **Bottom** arrow buttons to change this order.

   **New**  To create a new filter or view, go to the toolbar and click this button to open the Filter Builder or View Builder.

   **Attention:** While within the Filter Builder or View Builder, if you specify a filter or view name that already exists in the event list configuration, the existing filter or view is replaced.

   **Open**  To load an existing filter or view into the event list configuration, go to the toolbar and click this button. From the resulting window, navigate to the location where the filter or view is stored, select it, and then click **OK**. The filter or view is added to the relevant tab in the Event List Configuration window.

   **Tip:** Filters have a .elf extension. Views have a .elv extension.

   **Edit**  To edit a filter or view, select the relevant filter or view from the tab list, and then go to the toolbar and click this button to open the Filter Builder or View Builder for the selected filter or view. If you change the name of the filter or view to a name that does not exist in the event list configuration, a new filter or view is created. If you change the name to one that already exists, the new filter or view replaces the existing filter or view in the event list configuration.
**Delete**
To delete a filter or view from the event list configuration, select the relevant filter or view from the tab list, and then click this button to delete the selected filter or view. You are not prompted to confirm the deletion, so ensure that you have selected the appropriate filter or view before clicking **Delete**.

**Top**
To move a filter or view to the top of the list, select the relevant filter or view from the adjacent list, and then click this button.

**Up**
To move a filter or view up one position in the list, select the relevant filter or view from the adjacent list, and then click this button.

**Down**
To move a filter or view down one position in the list, select the relevant filter or view from the adjacent list, and then click this button.

**Bottom**
To move a filter or view to the bottom of the list, select the relevant filter or view from the adjacent list, and then click this button.

**Close**
Click this button to close the Event List Configuration window, and apply the event list configuration to the current event list.

4. To save the event list configuration, click **File > Save As** from the monitor box window. The Save Configuration window opens.

5. Complete this window as follows:

**Filter**
Use this field to specify a search query for the type of file that you want to open. This field works in conjunction with the **Filter** button and the **Files** list. Enter the current directory path and file type in the **Filter** field, and then click **Filter**. All matching files are displayed in the **Files** list.

For example, to display all the filter files in the `/myfiles/filters` directory, enter `/myfiles/filters/*.elf` and click **Filter** to view all matching files.

**Directories**
This list displays all of the subdirectories in the current directory. To refresh the directory, double-click the `.` entry. To move up the directory tree by one directory, double-click the `..` entry.

**Files**
This list displays the files in the current directory, which match the selection in the **Filter** field. Select the name of the file that you want to open. You can also select an existing file that you want to overwrite.

**Selection**
The path and name of the file that you are saving or opening are shown here. You can edit the path and file name to open a different file, to save a file to another location, or to save a file by using a different file name.

If you are saving a view, use a `.elv` extension in the file name. If you are saving a filter, use a `.elf` extension in the file name. If you are saving an event list configuration, use a `.elc` extension in the file name.

**Backup Existing Files (UNIX only)**
Select this check box to create a backup of an existing view file if the file name that you are saving already exists. This check box is displayed only if you are saving a filter, view, or event list configuration.

**OK**
Click this button to open or save the file.
Filter  This button works in conjunction with the Filter field and the Files list. Click this button to display files in the current directory based on your selection in the Filter field. The files appear in the Files list.

Cancel  Click this button to close this window without opening or saving a file.

Related tasks:
“Starting the event list” on page 19

Internet service monitors in the event list

IBM Tivoli Composite Application Manager for Internet Service Monitoring works in conjunction with the rest of the Tivoli Netcool/OMNibus product suite. Events generated by both monitors and probes can be forwarded to the same ObjectServer and you can manipulate these events using the same desktop.

When Composite Application Manager for Internet Service Monitoring is installed, two new buttons and a drop-down list are added to the event list. You can use the buttons and drop-down list as follows:

- Click the Services View button to display service alerts in the event list. You can change the service type by using the Services drop-down list.
- Click the Show Services button to start the Services window from the event list.
- Use the Services drop-down list to change the type of service status events that are displayed in the event list. For example, selecting a monitor type from the list displays all the service status events from that type of monitor.

Viewing services in the event list

If you have IBM Tivoli Composite Application Manager for Internet Service Monitoring installed, you can view and manipulate service alerts from Internet service monitors.

To view services information, perform any of the following actions:

- From the Conductor, open the event list. When Composite Application Manager for Internet Service Monitoring is installed, the Services window opens automatically whenever you access the monitor box window from the Conductor.
- From the Event List monitor box window, click Window > Services.
- From the event list, click Show Services Window in the toolbar.

Results

The Services window opens.

Each row in the Services window indicates a different service with the following information:

Colored symbols
The colored symbols to the left of each row indicate the status of the last alert that the ObjectServer received from that service. The symbols are color-coded, as follows:

- Red: The service level agreement is not being met.
- Amber: There are some problems with the service.
Green: There are no problems with the service.
Black: The status of the service is unknown.

**Service**
This column shows the name of the service that is being monitored.

**Last Change**
This column shows the last date and time when the service status changed.

**Last Good**
This column shows the last date and time when the service was good.

**Last Bad**
This column shows the last date and time when the service was bad.

**Last Marginal**
This column shows the last date and time when the service was marginal.

**Last Reported**
This column shows the last date and time when a report was generated for the service.

Double-click any row to open an event list window that contains a list of alerts for that service type. You can manipulate the service alerts in the event list in the same way as alerts that are received from probes.

Click Close to close the Services window.

**Related tasks:**
- “Starting the event list” on page 19
- “Starting the Conductor” on page 3

---

**Monitoring service-affected events in the event list**

A service-affected event (SAE) is an alert that warns operators that a critical customer service has been affected by one or more network events. Service-affected events are generated within IBM Tivoli Network Manager IP Edition.

You can monitor service-affected events from the Tivoli Netcool/OMNIbus event list if your system is configured to support this feature.

From the Tivoli Netcool/OMNIbus event list, you can monitor service-affected events as follows:

- To show the underlying events (for example, linkDowns) that are associated with a service-affected event, select the service-affected event, right-click it and then click **Show SAE Related Events** from the pop-up menu. All the events that are associated with the selected event are displayed in a new window.

- To show the service-affected events to which an event (for example, a linkDown) is related, select the event, right-click it and then click **Show SAE Related Services** from the pop-up menu. A list of all related service-affected events is displayed in a new window. For example, if you selected a linkDown event in the event list, this window displays all the services that are affected by that linkDown event.
Monitoring predictive events in the event list

A predictive event represents a prediction of an impending threshold violation. These events differ from other events that are forwarded to Tivoli Netcool/OMNibus because they represent an occurrence, fault, or situation that has not yet occurred, but which has a significant probability of occurring in the near future.

Predictive events are generated within IBM Tivoli Monitoring based on linear trending of historical data. You can monitor predictive events from the Tivoli Netcool/OMNibus event list if your system is configured to support this feature. For more information about predictive events, see the IBM Tivoli Netcool/OMNibus Installation and Deployment Guide. If configured also, a Predictions monitor box will be available in the Event List monitor box window, and a Predictions filter and Predictions view will be available in your event lists. The Predictions view contains the following default columns, which are displayed as follows, from left to right: Node, TrendDirection, Summary, FirstOccurrence, LastOccurrence, Count, PredictionTime.

The sort priority and sort order of the columns is as follows:
1. Severity in descending order
2. LastOccurrence in ascending order
3. PredictionTime in ascending order

When your event list shows both actual and predictive events, you can use the Predictions filter and Predictions view to filter and sort predictive events. You can also identify predictive events as follows:

- Check the text in the Summary column. The summary text is typically in one of the following formats (the severity of critical predictive events is always 5, the severity of warning predictive events is always 3):
  - For linear trending events:
    Predicted event rate on Node will hit threshold within PredictionTime days.
  - For baselining events:
    EventType event rate baseline situation has fired for node Node, the event count is EventCount for node situation_name.
  - For predictive events:
    Critical threshold for resource on Node will be breached in PredictionTime day(s). (Situation: situation_name).
    Warning threshold for resource on Node will be breached in PredictionTime day(s). (Situation: situation_name).

- If you have a Class column in your current view, check the text in this column. By default, the entry is Predictive Events, although this value can be changed by your system administrator.

From the event list, you can perform the following operations on predictive events:

- Determine the confidence level of the predictions. To display predictive events that meet a certain prediction confidence level:
  1. Right-click any event in the event list, and then click Show Prediction Confidence from the pop-up menu.
  2. From the Internal Command Parameters window, specify a percentage value between 0 and 100 only, in the Minimal Confidence percentage field. The
prediction confidence indicates how accurate the approximated trended value is, where 0 is no confidence and 100 is a perfect approximation. The default is 50.

3. Click OK. A separate event list opens displaying predictive events with the specified, or higher, confidence level. This event list shows all the fields in the Default view. You can additionally double-click any event to view its complete set of details in the Event Information window.

- List all predictive events and actual events (if available) that originated from the host for which a prediction was made. You can use the results displayed to help you identify a possible cause for the prediction trend towards a warning or critical threshold.

To display the events, right-click the predictive event that you want to investigate, and then click Show Predictive Events Threshold from the pop-up menu. A separate event list opens showing all events that are on the same host as the selected predictive event, and which occurred from the time the prediction was made, to the time the prediction is calculated to occur. (The Default view is applied to this event list.)

You can double-click each event to view its complete set of details in the Event Information window.

---

**Monitoring TADDM events in the event list**

TADDM events are generated within IBM Tivoli Application Dependency Discovery Manager when a configuration change is detected in your IT environment. You can monitor TADDM events from the Tivoli Netcool/OMNibus event list if your system is configured to support this feature.

If configured, a TADDM filter will be available in your event lists for filtering TADDM events. You can also identify TADDM events in the event list by sorting on the Class column, if this column is available in your current view. By default, the entry is Tivoli Application Dependency Discovery Manager, although this value can be changed by your system administrator.

TADDM events have an Indeterminate severity level by default.

From the event list, you can launch across to the TADDM Java™ console or Web client to view further details about the configuration items for which alerts have been raised:

- To view all the attribute details for a configuration item from within the TADDM Java console, right-click a TADDM event in the event list, and then click TADDM > Config Item Details (console) from the pop-up menu.
- To view all the attribute details for a configuration item from within the TADDM Web client, right-click a TADDM event in the event list, and then click TADDM > Config Item Details (web) from the pop-up menu.
- To view a change history report for a configuration item from within the TADDM Java console, right-click a TADDM event in the event list, and then click TADDM > Change History (console) from the pop-up menu.
- To view a change history report for a configuration item from within the TADDM Web client, right-click a TADDM event in the event list, and then click TADDM > Change History (web) from the pop-up menu.

You can double-click an event to view its complete set of details in the Event Information window.
Running transient event lists from the command-line, scripts, and tools

You can run customized, transient event lists directly from the command line, in a script, or as part of an event list tool.

For example, you can open an event list that applies a filter to view all critical alerts from a particular ObjectServer.

Starting the transient event list from the command line

Use the `nco_elct` command to open the transient event list from the UNIX command line, and use the `NCOelct.exe` command to open the transient event list from the Windows command line.

To start the transient event list:

Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>From a command prompt, enter:</td>
</tr>
<tr>
<td></td>
<td><code>$NCHOME/omnibus/bin/nco_elct option</code></td>
</tr>
<tr>
<td>Windows</td>
<td>From a command prompt, enter:</td>
</tr>
<tr>
<td></td>
<td><code>%NCHOME%\omnibus\desktop\NCOelct.exe option</code></td>
</tr>
</tbody>
</table>

In the UNIX and Windows commands shown in the preceding table, `option` represents one or more command-line options.

Results

If an instance of the event list (`nco_event`) is running, the `nco_elct` utility opens a new event list window. If there is no running instance of `nco_event`, the `nco_elct` utility starts one, and displays the Event List monitor box window and an event list window using the filter specified at the command line.

Related concepts:

"About the Event List monitor box window" on page 23

UNIX command-line options for the transient event list

When you run the `nco_elct` command to start the transient event list on UNIX, you must specify a number of command-line options to customize the event list. You can run this command from the `$NCHOME/omnibus/bin` directory.

The following table describes the command-line options for starting the transient event list on UNIX.

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-cmap</td>
<td>Specifies a private color map. You cannot abbreviate this command-line option.</td>
</tr>
<tr>
<td>-diagnostic</td>
<td>Displays extended diagnostic messages.</td>
</tr>
</tbody>
</table>
Table 9. UNIX transient event list (nco_elct) command-line options (continued)

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
</table>
| **-dualwrite** 1 | Indicates whether to enable or disable dual-write mode when operating in a desktop ObjectServer architecture. Valid options are as follows:  
- 0: Disable dual-write mode  
- 1: Enable dual-write mode  
  The -dualwrite command-line option overrides the DualWrite field entry in the master.national table of the desktop ObjectServer. |
| **-ffile** string | Specifies the filter file to use for the transient event list. Event list filters have a .elf extension.  
  **Note:** You can also retrieve remote .elf files by using HTTP and FTP. You do this by specifying the -config command-line option when running the nco_event command to start a UNIX event list. |
| **-fmetric** string | Specifies a filter metric for the transient event list. This setting is ignored if you have specified an existing event list filter file by using the -ffile command-line option. |
| **-fname** string | Specifies a name for the filter. This setting is ignored if you have specified an existing event list filter file by using the -ffile command-line option. |
| **-ftext** string | Specifies the SQL statement to use for filtering events. This setting is ignored if you have specified an existing event list filter file by using the -ffile command-line option. |
| **-help** | Displays help for this command and exits. |
| **-masterserver** string | Indicates the master ObjectServer to use in a desktop ObjectServer architecture.  
  The -masterserver command-line option overrides the MasterServer field entry in the master.national table of the desktop ObjectServer. |
| **-networktimeout** integer | Specifies a time in seconds after which a login attempt or connection to the ObjectServer will time out, if a network failure occurs. After the specified timeout period, the event list attempts to reconnect to the ObjectServer. If the connection is unsuccessful after a second timeout period, the event list will attempt to connect to a backup ObjectServer, where available. The default is 20 seconds. |
| **-password** string | Specifies the password for the selected user name. The nco_elct utility only accepts alphanumeric characters in the password. Special characters such as #, /, >, @, and ! are not permitted in the password. |
| **-server** string | Specifies the name of the ObjectServer to which you are connecting. |
| **-username** string | Specifies the user name to use to log in to the event list. |
| **-version** | Displays version information and exits. |
| **-vfile** string | Opens a transient event list by using a specified event list view. Event list views have a .elv file extension.  
  **Note:** You can also retrieve remote .elv files by using HTTP and FTP. You do this by specifying the -config command-line option when running the nco_event command to start a UNIX event list. |
Tip: You can abbreviate the command-line options for the transient event list to their shortest unique abbreviation. For example, -ffile can be abbreviated to -ff.

Related reference:
“UNIX event list command-line options” on page 20

Windows command-line options for the transient event list
When you run the NCOelct.exe command to start the transient event list on Windows, you must specify a number of command-line options to customize the event list. You can run this command from the %NCHOME%\omnibus\desktop directory.

The following table describes the command-line options for starting the transient event list on Windows.

Table 10. Windows transient event list (NCOelct.exe) command-line options

<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-diagnostic</td>
<td>Displays extended diagnostic messages.</td>
</tr>
</tbody>
</table>
| -dualwrite 0 | 1 | Indicates whether to enable or disable dual-write mode when operating in a desktop ObjectServer architecture. Valid options are as follows:  
  - 0: Disable dual-write mode  
  - 1: Enable dual-write mode  
  The -dualwrite command-line option overrides the DualWrite field entry in the master.national table of the desktop ObjectServer. |
| -elf string | URL | This is a required option. Specifies the filter file to use for the transient event list, where:  
  - string specifies a path to a .elf file.  
  - URL specifies a .elf file on a remote server that is accessible by using HTTP or FTP. Specify the URL by using one of the following formats:  
    - http://servername[:port]/path/filename.elf  
    - http://username:password@servername[:port]/path/  
      filename.elf  
    - ftp://servername[:port]/path/filename.elf  
    - ftp://username:password@servername[:port]/path/filename.elf  
  The optional port number :port needs to be specified only if the server is not using the default port.  
  If using FTP, the path must be the full path from the root directory; for example, /home/user/mydir/myfilter.elf.  
  You can use the -params command-line option to specify filter parameters in addition to those specified in the .elf file. For usage details, see the -params description, in this table. |
<table>
<thead>
<tr>
<th>Command-line option</th>
<th>Description</th>
</tr>
</thead>
</table>
| `-elv string | URL` | Specifies the event list view file to use for the transient event list, where:  
  `string` specifies a path to a `.elv` file.  
  `URL` specifies a `.elv` file on a remote server that is accessible by using HTTP or FTP. Specify the `URL` by using one of the following formats:  
  - `http://servername[:port]/path/filename.elv`  
  - `http://username:password@servername[:port]/path/filename.elv`  
  - `ftp://servername[:port]/path/filename.elv`  
  - `ftp://username:password@servername[:port]/path/filename.elv`  
  The optional port number `:port` needs to be specified only if the server is not using the default port.  
  If using FTP, the path must be the full path from the root directory; for example, `/home/user/mydir/myview.elv`. |
| `-help` | Displays help for this command and exits. |
| `-masterserver string` | Indicates the master ObjectServer to use in a desktop ObjectServer architecture.  
  The `-masterserver` command-line option overrides the MasterServer field entry in the master.national table of the desktop ObjectServer. |
| `-networktimeout integer` | Specifies a time in seconds after which a login attempt or connection to the ObjectServer will time out, if a network failure occurs. After the specified timeout period, the event list attempts to reconnect to the ObjectServer. If the connection is unsuccessful after a second timeout period, the event list will attempt to connect to a backup ObjectServer, where available. The default is 20 seconds. |
| `-params string` | Specifies a string to use to replace a single placeholder in the `filter_text` parameter of the filter file. This placeholder must begin with the `@` symbol (for example, `@FilterText`). |
| `-password string` | Specifies the password for the selected user name. The `NCOelct` utility accepts only alphanumeric characters in the password. Special characters such as `#`, `/`, `>`, `@`, and `!` are not permitted in the password. |
| `-server string` | Specifies the name of the ObjectServer to which you are connecting. |
| `-username string` | Specifies the user name to use to log in to the event list. |
| `-version` | Displays version information and exits. |

Related reference:  
“UNIX event list command-line options” on page 20
Example: Starting a transient event list from a command line or script

These examples show how to run the transient event list directly from the command line, or from a script, on both UNIX and Windows.

Example: nco_elct command on UNIX

The following command creates a transient event list from the NCOMS ObjectServer by using the default.elv view file. Only events from the node wombat will appear in the event list.

```
$NCHOME/omnibus/bin/nco_elct -server NCOMS -username root -password "" -vfile "$NCHOME/omnibus/desktop/default.elv" -ftext "( Node = \'wombat\' )"
```

Example: NCOelct command on Windows

The following command creates a transient event list from the NYC ObjectServer by using the lview.elv view file and the tool.elf filter file.

```
%NCHOME%\omnibus\desktop\NCOelct.exe -server NYC -username root -password ""
-elv "%NCHOME%\omnibus\ini\lview.elv" -elf "%NCHOME%\omnibus\ini\tool.elf"
-params "wombat"
```

The tool.elf file, which is referenced in the preceding NCOelct command, has the following content:

```
filter_name = 'ToolFilter';
filter_text = ' ( Node = \'@NodeName\' )';
filter_metric = 'avg(Severity)';
# End of file
```

When you run the command or script, the string wombat that follows the -params option replaces the @NodeName placeholder in the tool.elf file, so that only events from the node wombat are shown in the event list.

Example: Starting a transient event list from a tool

These examples show how to run the transient event list from a tool, on both UNIX and Windows.

Tip: In a dual server desktop (DSD) configuration, use the %desktopserver internal value in place of the %server value that is shown in the following example commands. This is to ensure that the ObjectServer sends its message to the correct client. For information about creating tools, see the IBM Tivoli Netcool/OMNIbus Administration Guide.

Example: nco_elct command on UNIX

The following example shows how to use the nco_elct utility in the Show Related FE Node tool that is shipped with Tivoli Netcool/OMNIbus.

```
$NCHOME/omnibus/bin/nco_elct -server "%server" -username "%username"
-password "%password" -vfile "$NCHOME/omnibus/desktop/default.elv"
-ftext "( RemoteNodeAlias != '' and RemoteNodeAlias = '@LocalNodeAlias' )
or ( LocalNodeAlias != '' and LocalNodeAlias = '@RemoteNodeAlias' )
or Node = '@RemoteNodeAlias' or RemoteNodeAlias = '@Node'"
```

Example: NCOelct command on Windows

The following example shows how to use the NCOelct.exe utility in the Show Related FE Node (Windows) tool that is shipped with Tivoli Netcool/OMNIbus.
The tool.elf file, which is referenced in the preceding NCOelct command, has the following content:

```python
filter_name = 'ToolFilter';
filter_text = '@FilterText';
filter_metric = 'avg(Severity)';
# End of file
```

The NCHOME environment variable for Windows is expressed differently in a tool than the normal usage (%NCHOME%). This difference occurs because the variable is interpreted and resolved by the built-in tools parser and not by the Windows operating system.

When you run the tool from the event list, the entire string that follows the -params option replaces the @FilterText placeholder in the tool.elf file. The @LocalNodeAlias, @RemoteNodeAlias, and @Node placeholders are replaced in the -params string by values from the event that is currently selected in the event list.
Chapter 4. Using filters and views to display custom event information

The alerts database tables hold event information that is forwarded to the ObjectServer. You can use filters and views to define which of this event information is displayed in your event lists.

A filter controls which alerts (or database records) can be seen, and a view controls which columns (or database fields) are visible for those alerts. You can perform information requests on the database tables using Structured Query Language (SQL).

To display alerts within the event list, it is necessary to perform a SELECT statement on the alerts.status table. The SQL statements can be separated into three conceptual parts:

- Select which columns in the alerts.status table you want to view, by using views created in the View Builder.
- Select the events that contain specific data values in one or more of those columns, by using filters created in the Filter Builder.
- Select the order for displaying the events, by using views created in the View Builder.

The following example shows a SELECT statement that is performed on the alerts.status table:

```sql
select Node as NODE, Summary as Detail from alerts.status
where Node = 'link1'
```

The SELECT clause is constructed within the View Builder, which is used to create and edit views. The WHERE clause is constructed within the Filter Builder, which is used to create and edit filters.

Setting up filters for event list data

Filters are used to build SQL queries that can be run on the ObjectServer alerts database tables, in order to display custom alert information in monitor boxes and event lists.

Filters define which alerts are displayed in the event list:

- Where a certain field has a certain value
- Where a certain field has a value similar to something
- Where the events occurred within two fixed points in time
- Where the events occurred up to a certain number of minutes ago

A number of default filters are provided with Tivoli Netcool/OMNibus. These filters are as follows:

**Last 10 Min.**

This filter displays all alerts except ProbeWatch, TSMWatch, and ConnectionWatch alerts. The results are identical to those for the **Default** filter, except that the **Last 10 Min.** filter only displays alerts that occurred in the last 10 minutes.
In Maintenance
This filter displays alerts that have been indicated as being “in maintenance” by the operator.

Escalated
This filter displays alerts that have been escalated by the operator.

Information
This filter displays alerts that have been identified as Information alerts. Information alerts are:
- Alerts that have been designated as Information alerts by probes
- Alerts that are not ProbeWatch, TSMWatch, or ConnectionWatch alerts
- Alerts for which an escalation level has been set

Task List
This filter displays alerts that have been added to the operator's task list.

Netcool Status
This filter displays only ProbeWatch, TSMWatch, and ConnectionWatch alerts.

Default
This filter displays all alerts except ProbeWatch, TSMWatch, and ConnectionWatch alerts.

All Events
This filter displays all alerts.

In addition, you can build custom filters. Filters are saved as .elf files. You use the Filter Builder to create and edit filters.

Components of a filter
A filter is made up of a collection of elements. The available element types include condition, logical, and subquery elements.

Condition elements
When constructing a filter, you can use a condition element to make a comparison between database columns and values. On UNIX, you can also specify more advanced conditions.

There are three condition types:
- Simple: This is used for simple comparisons and generally uses a single condition element.
- Complex: This is used for more complex comparisons and generally uses two or more condition elements that are linked with logical elements, and subqueries.
- FreeForm: This is used for an arbitrary set of conditions that are not restricted to column name and operator expressions. The FreeForm condition allows the advanced features of the ObjectServer SQL to be used. This condition type is available on UNIX only.
Logical elements
When you use a single condition element in a filter, you are limited to simple comparisons. Logical elements allow two elements to be combined for more complex comparisons.

A logical element has one of the following Boolean operators:
- AND
- OR
- NOT

You can use these operators to build filters with multiple conditions. The AND and OR operators can be used as leading or trailing operators when combining conditions. The negate operator (NOT) can only have one parent and one child. The negate operator inverts the result of the SQL that follows it. Although a negate element has only one child in the tree, it can generally be manipulated as a logical element.

Subquery elements
When constructing a filter, you can use a subquery element to make a query in a condition.

The subquery element can be used to query and return results of data that is stored in the following ObjectServer alerts database tables:
- alerts.details: This table holds event details, and is linked to the alerts.status table by the Identifier column.
- alerts.journal: This table holds a history of work performed on events, and is linked to the alerts.status table by the Serial column.
- alerts.status: This table holds status information about problems that have been detected by probes.

For example, you might want to look for events that have journal entries in the alerts.journal table, or look for events that have a particular detail attribute in the alerts.details table.

A subquery element can be followed by condition, logical, and other subquery elements. These elements allow you to specify selection criteria for the information from another table.

Filter metrics
All filters can have a metric associated with them. A metric is a measurement that you can apply to a filter so that it calculates a useful figure.

For example, a metric could be an average, count, or sum of all the alerts. When you are creating a filter, you can select the type of metric to use. Metrics are displayed in monitor boxes.

Related concepts:
“Monitor box overview” on page 25

Related tasks:
“Creating or editing a filter on UNIX” on page 78
“Creating or editing a filter on Windows” on page 81
Best practices for filters

When building a filter, perform the least-intensive tests first.

Perform comparisons in the following order:

1. Integers
2. Dates and times
3. Character strings
4. Regular expressions

Note: When comparing events against a filter, the ObjectServer stops as soon as it finds a field that does not match.

Starting the Filter Builder

The Filter Builder provides a graphical interface within which you can build and test the SQL statements that comprise a filter.

You can start the Filter Builder in any of the following ways:

- From the Event List monitor box window, click Launch Filter Builder on the toolbar and select a previously-defined filter.
- From a monitor box, click the filter name button.
- From the event list, click Filter Builder on the toolbar, or select Edit > Edit Filter.
- From the Event List Configuration window, click the New or Edit button.
- From the UNIX Conductor, click Filter Builder in the button bar, or double-click a saved filter (.elf) file in the personal library.

Filter Builder overview

Use the Filter Builder to construct filters for event lists.

The following figure shows the UNIX Filter Builder.
The Filter Builder contains the following areas:

1. **Filter setup area**
   Use this area to define a name and to set permissions for the filter.

2. **Button bar**
   Use these buttons to define filter elements.

3. **Graphical display area**
   This area displays the element definitions for the current filter in a graphical tree structure that shows how the elements relate. You can add elements to the tree by using the buttons in the button bar. The element that is currently selected is shown with a red border around it. Editing is relative to the current element. When you select an element within this area, its details are shown and can be edited in the element definition area.

4. **SQL display area**
   The SQL display area shows the SQL as you build the filter. You can click Edit SQL in the button bar to edit the SQL directly within a Filter SQL Edit window.

5. **Element definition area**
   This area displays the details of the element that is currently selected, and enables you to specify a different set of values. Your selections are reflected in the graphical display area and the SQL display area.

6. **Metric area**
   Use the metric buttons to apply a measurement to the filter so that it
Calculates a useful figure. For example, a sum of tally metric gives the total number of deduplicated alerts in the ObjectServer.

Creating or editing a filter on UNIX

Use the UNIX Filter Builder to build filters for event list data.

To create or edit a filter:
1. Start the Filter Builder.
2. Complete the filter setup area as follows:
   - **Name**: If you are creating a new filter, overwrite the current name with a unique name for the filter. This name is used to select the filter in event list menus. If you are editing an existing filter, you do not need to make an entry in this field.
   - **Editable**: If you have the relevant administrator permissions, select this check box to allow other users to edit this filter, or clear the check box to protect the filter from modification.

   **Restriction**: This setting applies only if the filter is saved as part of an event list configuration (.elc file).

You can now build the filter by using a combination of condition, logical, and subquery filter elements. You can also define a filter metric, and copy, paste, and delete elements.

3. Create condition elements as follows:
   a. From the button bar, click **Condition**.
   b. From the element definition area, complete the fields as follows:
      - **Expression Type**: Select one of the following options from this list:
        - **Simple**: Select this option to use simple expressions in the condition element.
        - **Complex**: Select this option to use complex expressions that allow two database columns or two expressions to be compared.
        - **FreeForm**: Select this option to specify expressions that allow the use of the advanced features of the ObjectServer SQL.

      - **Column**: From this list, select a database column that you want to use in the comparison.

      By default, the list contains the names of the columns in the alerts.status database table. The Filter Builder automatically determines which columns are available. There are situations where this list will be different.

      **Note**: The Column list is not displayed if you selected the FreeForm option from the Expression Type list.

      - **Operator**: Select a comparison operator from this list.

      The range of comparisons available is determined by your selection from the Column drop-down list. Some comparisons are unavailable for certain columns. For example, it is not possible to have a LIKE operation on a numeric column such as Severity.
Note: The **Operator** list is not displayed if you selected the FreeForm option from the **Expression Type** list.

**Value data type fields**

The fields that appear here are dependent on the option that you selected in the **Expression Type** list.

If the **Expression Type** is **Simple**, then the value fields that appear depend on whether the database column selected in the **Column** list is of type string, integer, or time.

If the **Expression Type** is **Complex** or **FreeForm**, then an **Edit** button is provided to allow you to edit the SQL directly within the Filter SQL Edit window. When you click **OK** to save and return to the Filter Builder, the SQL expression is automatically parsed and added to the condition element in the graphical display area. If you enter invalid SQL text in the Filter SQL Edit window, you are required to correct the syntax before exiting the window.

4. If required, construct multiple conditions by inserting logical **AND** or **OR** elements as follows:
   a. From the graphical display area, select an existing element for which you want to create a logical comparison. You can create a logical comparison to a condition element, another logical element, or no element.
   b. From the button bar, click either **Leading Logical** or **Trailing Logical**.
   c. From the element definition area, choose the relevant option:
      - **Logical AND**
        Select this option to add an AND operator to a filter definition. This is the default option.
      - **Logical OR**
        Select this option to add an OR operator to a filter definition.
   d. From the button bar, click **Condition** to add another condition branch.

   The following table shows what happens if you select either a condition or logical element and then click one of the logical buttons.

<table>
<thead>
<tr>
<th>Element</th>
<th>Leading Logical button used</th>
<th>Trailing Logical button used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition element</td>
<td>Creates a logical element as the child of the parent of the condition element. The condition element becomes the child of the logical element.</td>
<td>The <strong>Trailing Logical</strong> button is not available because condition elements cannot have children.</td>
</tr>
<tr>
<td>Logical element</td>
<td>Creates a logical element as the child of the parent of the logical element. The condition element becomes the child of the logical element.</td>
<td>The logical element is added as a child of the existing logical element. If the insertion point already has two children, this button is disabled.</td>
</tr>
<tr>
<td>No element selected</td>
<td>Creates a single logical element.</td>
<td>Creates a single logical element.</td>
</tr>
</tbody>
</table>

5. If required, negate a condition as follows:
   a. From the graphical display area, select the condition element.
   b. From the button bar, click **Negate**.

   The negate element is always inserted **before** the current insertion point in the tree, and can only have one parent and one child.
Note: It is not possible to insert a negate logical element before an existing negate logical element. However, when editing a filter, it is possible to delete a section of a tree to leave two negate elements one after another. You must delete one of these to create a valid filter.

6. If required, create subquery elements as follows:
   a. From the button bar, click Sub Query.
   b. From the element definition area, complete the fields as follows:
      
      Column
      From this list, select the database column to be used in the search.

      Operator
      Select either of the following options from the list:
      • In: Use this option to search for the contents of the column.
      • Not In: Use this option to search for the absence of the contents of the field.

      Select
      Select the column to be used when building the list, against which the In or Not In operation is to be performed. The options in this list are determined by the option that is selected in the from list.

      from
      Select the database table from which to derive the information. This can be alerts.details, alerts.journal, or alerts.status.

7. If required, set the filter metric as follows:
   
   Metric
   Use the first list to choose the measurement to be used:
   • Select Average to return the average value of the selected field for all alerts that match the filter.
   • Select Count to return a count of all the alerts that match the filter.
   • Select Sum to return the sum of the selected field for all alerts that match the filter.
   • Select Minimum to return the lowest value of the selected field in alerts that match the filter.
   • Select Maximum to return the highest value of the selected field in alerts that match the filter.

   Use the second list to select a field to which the measurement is applied. Only the integer and time fields in an alert are available for the metric calculation.

   Tip: The metric value will be displayed in monitor boxes in the Event List monitor box window.

8. If required, copy and paste elements as follows:
   a. From the graphical display area, select the element to be copied, and select Edit > Copy.
   b. Paste the element elsewhere into the filter by selecting Edit > Paste. The Filter Builder attempts to insert the element relative to the element that is currently selected.

9. If required, delete single elements, or parent elements and their children, as follows:
   • From the graphical display area, select the single element to be deleted, and then click Delete Element in the button bar, or select Edit > Cut.
When you delete filter elements, the Filter Builder attempts to link the child elements into the filter. This does not work if you try to remove a logical element with two children, or a subquery that has children.

- From the graphical display area, select the parent element to be deleted and click **Delete Tree** in the button bar. This removes the currently-selected element and all child elements.

10. After defining the filter, save the filter or cancel your changes as follows:

   - **Apply** Click this button to apply changes to the filter without saving it.
   - **Close** Click this button to close the window and discard the changes.

You must save filters with a `.elf` file extension.

**Note:** On UNIX, when the Filter Builder is run from the Conductor, the **Apply** button does not appear. In this case, you must save all filters by selecting **File > Save** or **File > Save As** from the UNIX Filter Builder.

**Related tasks:**
[“Starting the Filter Builder” on page 76](#)

### Creating or editing a filter on Windows

Use the Windows Filter Builder to build filters for event list data.

To create or edit a filter:
1. Start the Filter Builder.
2. Complete the filter setup area as follows:
   - **Name** If you are creating a new filter, overwrite the current name with a unique name for the filter. This name is used to select the filter in event list menus. If you are editing an existing filter, you do not need to make an entry in this field.
   - **Editable** If you have the relevant administrator permissions, select this check box to allow other users to edit this filter, or clear the check box to protect the filter from being modified.

**Restriction:** This setting applies only if the filter is saved as part of an event list configuration (.elc file).

You can now build the filter using a combination of condition, logical, and subquery filter elements. You can also define a filter metric, and copy, paste, and delete elements.

3. Create condition elements as follows:
   a. From the button bar, click **Condition**.
   b. From the element definition area, complete the fields as follows:

      - **Type** Select either of the following options from this list:
        - **Simple**: Select this option to use simple expressions in the condition element.
        - **Complex**: Select this option to use complex expressions that allow two database columns or two expressions to be compared.

      - **Column** From this list, select a database column that you want to use in the comparison.
By default, the list contains the names of the columns in the alerts.status database table. The Filter Builder automatically determines which columns are available. There are situations where this list will be different.

**Operator**
Select a comparison operator from this list.

The range of comparisons available is determined by your selection from the **Column** drop-down list. Some comparisons are unavailable for certain columns. For example, it is not possible to have a `LIKE` operation on a numeric column such as Severity.

**Value**
The fields that appear here are dependent on the options that are selected in the **Type**, **Column**, and **Operator** lists.

If the **Type** is **Simple**, then the value fields that appear will depend on whether the database column selected in the **Column** list is of type string, integer, or time.

If the **Type** is **Complex**, then an **Edit** button is provided to allow you to edit the SQL directly within the Filter SQL Edit window. When you click **OK** to save and return to the Filter Builder, the SQL expression is automatically parsed and added to the condition element in the graphical display area. If you enter invalid SQL text in the Filter SQL Edit window, you are required to correct the syntax before exiting the window.

4. If required, construct multiple conditions by inserting logical AND or OR elements as follows:
   a. From the graphical display area, select an existing element for which you want to create a logical comparison. You can create a logical comparison to a condition element, another logical element, or no element.
   b. Select either the **And** condition button or the **Or** condition button.
   c. Change the condition attributes on the new condition.
   d. Click the **Apply** button to save the changes.

   The following table shows what happens if you select either a condition or logical element, and then click one of the logical buttons.

   **Table 12. Results obtained with the Leading Logical and Trailing Logical buttons**

<table>
<thead>
<tr>
<th>Element</th>
<th>Leading Logical button used</th>
<th>Trailing Logical button used</th>
</tr>
</thead>
<tbody>
<tr>
<td>Condition element</td>
<td>Creates a logical element as the child of the parent of the condition element. The condition element becomes the child of the logical element.</td>
<td>The Trailing Logical button is not available because condition elements cannot have children.</td>
</tr>
<tr>
<td>Logical element</td>
<td>Creates a logical element as the child of the parent of the logical element. The condition element becomes the child of the logical element.</td>
<td>The logical element is added as a child of the existing logical element. If the insertion point already has two children, this button is disabled.</td>
</tr>
<tr>
<td>No element selected</td>
<td>Creates a single logical element.</td>
<td>Creates a single logical element.</td>
</tr>
</tbody>
</table>

5. If required, negate a condition as follows:
   a. From the graphical display area, select the condition element.
   b. From the button bar, click **Negate**.
The negate element is always inserted before the current insertion point in the tree, and can have only one parent and one child.

Note: It is not possible to insert a negate logical element before an existing negate logical element. However, when editing a filter, it is possible to delete a section of a tree to leave two negate elements one after another. You must delete one of these to create a valid filter.

6. If required, create subquery elements as follows:
   a. From the button bar, click **Sub Query**.
   b. From the element definition area, complete the fields as follows:
      - **Column**
        * From this list, select the database column to be used in the search.
      - **Operator**
        * Select either of the following options from the list:
          - **In**:
            * Use this option to search for the contents of the column.
          - **Not In**:
            * Use this option to search for the absence of the contents of the field.
      - **Select**
        * Select the column to be used when building the list, against which the In or Not In operation is to be performed. The options in this list are determined by the option that is selected in the **From** list.
      - **From**
        * Select the database table from which to derive the information. This can be alerts.details, alerts.journal, or alerts.status.

7. If required, set the filter metric as follows:
   - **Metric**
     * Use the first list to choose the measurement to be used:
       - Select **Average** to return the average value of the selected field for all alerts that match the filter.
       - Select **Count** to return a count of all the alerts that match the filter. The selected field is not used for this calculation.
       - Select **Sum** to return the sum of the selected field for all alerts that match the filter.
       - Select **Minimum** to return the lowest value of the selected field in alerts that match the filter.
       - Select **Maximum** to return the highest value of the selected field in alerts that match the filter.
     * Use the second list to select a field to which the measurement is applied. Only the integer and time fields in an alert are available for the metric calculation.
     * **Tip:** The metric value will be displayed in monitor boxes in the Event List monitor box window.

8. If required, copy and paste elements as follows:
   a. From the graphical display area, select the element to be copied, and select **Edit > Copy**.
   b. Paste the element elsewhere into the filter by selecting **Edit > Paste**. The Filter Builder attempts to insert the element relative to the element that is currently selected.

9. Delete single elements, or parent elements and their children, as follows:
   * From the graphical display area, select the single element to be deleted, and then click **Delete Element** in the button bar, or select **Edit > Cut**.
When you delete filter elements, the Filter Builder attempts to link the child elements into the filter. This does not work if you try to remove a logical element with two children, or a subquery that has children.

- From the graphical display area, select the parent element to be deleted and click **Delete Tree** in the button bar. This action removes the currently-selected element and all child elements.

10. After defining the filter, save the filter or cancel your changes as follows:

   **Apply**  Click this button to apply changes to the filter without saving it.

   **Close**  Click this button to close the window and discard the changes.

**Related tasks:**

"Starting the Filter Builder" on page 76

### Specifying comparison values for filter conditions

When defining simple or complex conditions within the Filter Builder, you are required to select a database column to be used in the comparison, a comparison operator, and one or more comparison values.

For example:

**Severity=Critical**

The database columns used in the comparison can be associated with one of three data types:

- **String**
- **Integer**
- **Time**

Each of these data types requires a different set of entries for the comparison values.

These entries are required when constructing simple conditions.

**Specifying string values**

String values are required if you are filtering on text columns (of type CHAR or VARCHAR) in the alerts.status table.

The following figure shows the type of fields that are displayed for string values in the element definition area of the Filter Builder.

![Element definition area for string values on UNIX](image)

*Figure 10. Element definition area for string values on UNIX*

To specify a string value, enter a string into the value field below the **Operator** field; surrounding quotation marks are not required. Some characters in the string can be escaped with a back slash (\) in the SQL text where they would otherwise have unintended effects on the operation of the filter. For example, single and double quotation marks are automatically escaped.
Specifying integer values on UNIX

Integer values are required if filtering on numeric columns (of type INTEGER or INCR) in the alerts.status table.

The following figure shows the type of fields that are displayed for integer values in the element definition area of the UNIX Filter Builder. The value fields below the Operator field include a value drop-down list, a numeric value field, and arrow buttons.

![Figure 11. Element definition area for integer values on UNIX](image)

The drop-down list is only available where a numeric column has conversions set up for it.

To specify an integer value, select an entry from the drop-down list. The corresponding numeric value is shown in the adjacent value field. For example, if you are setting a comparison with Severity and select Major from the drop-down list, 4 is entered into the numeric field. You can also type a numeric value directly into the value field.

Specifying integer values on Windows

Integer values are required if you are filtering on numeric columns (of type INTEGER or INCR) in the alerts.status table.

The following figure shows the type of fields that are displayed for integer values in the element definition area of the Windows Filter Builder.

![Figure 12. Element definition area for integer values on Windows](image)

The Value drop-down list is only available where a numeric column has conversions set up for it. In the above example, the values for the Severity column are stored internally as integer values, but have a set of conversions to map those numbers to various severity strings; for example, 0 means Closed, and 5 means Critical. Where conversions like this exist for a column, the string names are displayed in the Value drop-down list.

To specify an integer value, select an entry from the Value drop-down list.
Specifying time values

Time values are required if you are filtering on time columns (of type TIME) in the alerts.status table.

There are two types of comparison when creating time-based filters:

- **Absolute**: This defines an exact moment in time that is being referenced. For example, events that first occurred at precisely 10 am on 20 July 2006, or events that occurred before 10 am on 20 July 2006, or events that have occurred since 10 am on 20 July 2006.
- **Relative**: This defines a point in time that is relative to the current time. For example, events that first occurred within the last 20 minutes.

Specifying absolute time comparisons on UNIX:

When you specify an absolute time comparison, the date and time displayed are always initialized to the current date when an element is created.

The following figure shows the type of fields that are displayed for absolute time values in the element definition area of the UNIX Filter Builder. When you select a time column (for example, FirstOccurrence), a drop-down list and six fields are provided (below the Operator field) for you to specify values.

![Figure 13. Element definition area for absolute time values on UNIX](image)

To specify a precise moment in time, select **Absolute** from the drop-down list.

The six fields adjacent to the drop-down list represent:

- Day, month, and year (top row)
- Hour, minutes, and seconds (bottom row)

You can type a date and time directly into these fields, or use the arrow buttons to the right of each field to increase or decrease the values.

Specifying absolute time comparisons on Windows:

When you specify an absolute time comparison, the date and time displayed are always initialized to the current date when an element is created.

The following figure shows the type of fields that are displayed for absolute time values in the element definition area of the Windows Filter Builder. When you select a time column (for example, FirstOccurrence), a Value field and check box are provided (below the Operator field) for you to specify values.
To specify a precise moment in time:

- In the **Value** field, specify the date and time in the format DD/MM/YYYY HH:MM:SS, where DD represents the day, MM represents the month, YYYY represents the year, HH represents the hour, MM represents the minutes, and SS represents the seconds.
- Clear the **Relative** check box.

### Specifying relative time comparisons on UNIX:

The `getdate` function is an ObjectServer SQL function that returns the current date and time. You can use this function in a calculation to establish a time relative to the present.

The calculation is made in seconds, so 300 represents 300 seconds or 5 minutes. For example, to retrieve events that occurred within the last 10 minutes, you can type:

```
getdate - 600
```

Note that spaces are required on either side of the minus (-) sign.

The following figure shows the type of fields that are displayed for relative time values in the element definition area of the UNIX Filter Builder. To specify a time that is relative to the current time, select **Relative** from the drop-down list (below the **Operator** field), and then type the appropriate `getdate` calculation in the adjacent field.

![Element definition area for relative time values on UNIX](image)
Specifying relative time comparisons on Windows:

The `getdate` function is an ObjectServer SQL function that returns the current date and time. You can use this function in a calculation to establish a time that is relative to the present.

The calculation is made in seconds, so 300 represents 300 seconds or 5 minutes. For example, to retrieve events that occurred within the last 10 minutes, you can type:

```
getdate - 600
```

Note that spaces are required on either side of the minus (-) sign.

The following figure shows the type of fields that are displayed for relative time values in the element definition area of the Windows Filter Builder. To specify a time that is relative to the current time, type the appropriate `getdate` calculation in the **Value** field, and select the **Relative** check box.

![Figure 16. Element definition area for relative time values on Windows](image)

Specifying operators for filter conditions

When defining simple or complex conditions within the Filter Builder, you use operators to define comparisons.

The list of available operators includes:

- Equal To
- Not Equal To
- Greater Than
- Less Than
- Greater Than Or Equal To
- Less Than Or Equal To
- Like
- Not Like
- In
- Not In

All of these operators, apart from In and Not In, are used to make a comparison to a single value.

The Like and Not Like operators accept regular expressions if required, and perform a substring comparison.
Using the In and Not In operators on UNIX

You can use the In and Not In operators to include or exclude multiple values in the search criteria for a column. These operators are used in place of multiple OR operators, and can be used with integers or strings.

The following figure shows the type of fields that are displayed for the In and Not In operators in the element definition area of the UNIX Filter Builder. An entry field, two buttons, and a values list are displayed below the Operator field.

![Figure 17. Value fields for the In and Not In operators on UNIX](image)

To add a value to the values list, type the value in the entry field, and then click Add or press Enter. To remove a value from the values list, select the value in the list and click Remove.

Using the In and Not In operators on Windows

You can use the In and Not In operators to include or exclude multiple values in the search criteria for a column. These operators are used in place of multiple OR operators, and can be used with integers or strings.

The following figure shows the type of fields that are displayed for the In and Not In operators in the element definition area of the Windows Filter Builder. A Value field, two buttons, and a values list are displayed below the Operator field.

![Figure 18. Value fields for the In and Not In operators on Windows](image)
To add a value to the values list, type the value in the **Value** field, and then click the + button or press Enter. To remove a value from the values list, select the value in the list and click the - button.

**Creating filters on UNIX by dragging and dropping**

On UNIX, you can create filters by using the drag-and-drop feature.

You can drag and drop from:
- One Filter Builder to another
- An event list window into the Filter Builder

**Dragging and dropping from one Filter Builder to another**

A quick way to create a filter on UNIX is to drag and drop elements from one open Filter Builder to another open Filter Builder.

To drag and drop from one Filter Builder to another:
1. Move the cursor over the drag point icon, which is located to the right of the Editable check box.
2. Click and hold down the middle mouse button over the icon.
3. Drag the mouse to another Filter Builder. When the cursor is over a valid drop area, it changes color to green.
4. Release the mouse button to drop the filter.
   - If the filter is not valid or is incomplete, a red cross is shown on the drag point icon, and you cannot drag and drop.

**Dragging and dropping from the event list to the Filter Builder**

You can create condition elements in filters by dragging and dropping alert information from the event list into the Filter Builder. The condition element is created using the value of the column from where the drag-and-drop action was started.

For example, if you click the middle mouse button over the event list in the Severity column on an event that has a **Critical** value, and then drop this into the Filter Builder, a condition element is created and set to **Severity=Critical(5)**.

Repeat this process to create more condition elements that are joined to the existing tree with logical elements.

**Related concepts:**
- “Logical elements” on page 75

**Opening a filter**

You can open a saved filter in order to view or edit its definition.

To open a filter:
1. Start the Filter Builder.
2. Select File > Open. The Open Filter window opens. Note that this window is associated with saving or opening filters, views, and event list configurations. Therefore, not all of the fields might be applicable to your current action.
3. Complete the window as follows:
   - **Filter** Use this field to specify a search query for the type of file that you
want to open. This field works in conjunction with the Filter button and the Files list. Enter the current directory path and file type in the Filter field, and then click Filter. All matching files are displayed in the Files list.

For example, to display all the filter files in the /myfiles/filters directory, enter /myfiles/filters/*.elf and click Filter to view all matching files.

**Directories**

This list displays all of the subdirectories in the current directory. To refresh the directory, double-click the '.' entry. To move up the directory tree by one directory, double-click the '..' entry.

**Files**

This list displays the files in the current directory, which match the selection in the Filter field. Select the name of the file that you want to open. You can also select an existing file that you want to overwrite.

**Selection**

The path and name of the file that you are saving or opening are shown here. You can edit the path and file name to open a different file, to save a file to another location, or to save a file by using a different file name.

If you are saving a view, use a .elv extension in the file name. If you are saving a filter, use a .elf extension in the file name. If you are saving an event list configuration, use a .elc extension in the file name.

**Backup Existing Files (UNIX only)**

Select this check box to create a backup of an existing view file if the file name that you are saving already exists. This check box is displayed only if you are saving a filter, view, or event list configuration.

**OK**

Click this button to open or save the file.

**Filter**

This button works in conjunction with the Filter field and the Files list. Click this button to display files in the current directory based on your selection in the Filter field. The files appear in the Files list.

**Cancel**

Click this button to close this window without opening or saving a file.

**Results**

The filter opens within the Filter Builder.

**Related tasks:**

"Starting the Filter Builder" on page 76
**Filter examples**

These examples show how you can use logical comparisons, negate conditions, and subquery elements in filters.

- "Example: Logical comparison"
- "Example: Negate on UNIX"
- "Example: Negate on Windows” on page 93
- "Example: Subquery element” on page 93
- "Example: Using subquery elements with other elements” on page 93

**Example: Logical comparison**

This example uses the logical AND element. To find all alerts that have been acknowledged, and which are greater than major severity, use two condition elements: Acknowledged = Yes and Severity > Major.

These elements translate to the SQL condition:

\[(\text{Acknowledged} = 1) \land (\text{Severity} > 4)\]

Acknowledged is an integer value for which 0 equates to No and 1 equates to Yes. Severity names map to integer numbers 0-5. Integers are used rather than string values because the Filter Builder manages the translations between names and values.

When a logical element is selected, the element definition area displays two buttons: **And** and **Or**. Logical elements are created by default as AND elements. To use an OR element, select the element in the graphical display area and then select **Or** in the element definition area.

The following figure shows this example, as displayed in the UNIX Filter Builder.

![Logical comparison](image)

*Figure 19. Example logical comparison in the UNIX Filter Builder*

**Example: Negate on UNIX**

You can enter a conditional element that finds all the alerts that have a severity of warning, as shown in the following figure.

![Severity = Warning](image)

*Figure 20. Example Negate filter condition on UNIX (Part 1)*
To negate the condition, select the element; then, click the **Negate** button to obtain the following result.

![Example Negate filter condition on UNIX (Part 2)](image)

**Example: Negate on Windows**

To negate a condition, select the element and then click the **Negate** button (!). For example, you can enter a conditional element that finds all the events that have a severity of **Warning**, as shown in the following figure.

![Severity = 2](image)

**Figure 22. Example Negate filter condition on Windows (Part 1)**

To negate the condition, click the **Negate** button (!) to obtain the following result.

![Severity = 2](image)

**Figure 23. Example Negate filter condition on Windows (Part 2)**

**Example: Subquery element**

The following figure shows a subquery element that compares the Identifier fields of the alerts.status table and the alerts.details table.

![Example subquery element on UNIX](image)

**Figure 24. Example subquery element on UNIX**

**Example: Using subquery elements with other elements**

This example element compares the Identifier fields in the alerts.status table and the alerts.details table, where the records in the alerts.details table also contain a Name field with the value **SpecialValueAlert**. The elements that follow the subquery element also refer to the same table as the subquery.

The following figure shows how the subquery element is displayed in the UNIX Filter Builder.

![Identifier in (select Identifier from details) Name = SpecialValueAlert](image)

**Figure 25. Example subquery element with other elements on UNIX**

The following figure shows how this subquery element is displayed in the Windows Filter Builder.
Setting up views for event lists

Views define the selection of columns that are shown in the event list, and the formatting of information within these columns.

For each view, you can specify the following settings:
- Columns to include in the event list and the order in which they should be displayed
- Alternative titles or aliases for the columns
- Column formatting, including column widths, and alignment of the column headers and data
- Whether certain columns should remain in view at all times when scrolling horizontally across the event list
- Sort orders and the sort priority of the columns
- Whether to restrict the number of rows that are displayed in the event list

You can use the View Builder to create and edit views.

Starting the View Builder

The View Builder provides an interface within which you can configure a view.

You can start the View Builder in the following ways:
- From the event list, click View Builder on the toolbar, or select Edit > Edit View.
- From the UNIX Conductor, click View Builder on the button bar, or double-click a saved view (.e1v) file in the personal library.
- From the Event List Configuration window, click the New or Edit button.

View Builder overview

Use the View Builder to define which fields are displayed in the event list.

The following figure shows the layout of the UNIX View Builder.
The View Builder contains the following areas:

1. **View setup area**
   Use this area to define a name and to set permissions for the view.

2. **Display Columns area**
   Use this area to select the alerts.status columns that you want to display in the event list, and to specify the order and format of the columns.

3. **Sort Columns area**
   Use this area to configure sort orders and priorities for the rows in the event list. You can specify zero or more columns by which the data can be sorted, and define the sort priorities for the columns.
Restrict Rows area

To enhance performance, you can restrict the number of rows that are read from the ObjectServer. Use this area to restrict the number of rows that are displayed in the event list.

Creating or editing a view on UNIX

Use the View Builder to define which columns to display in the event list.

To create or edit a view:
1. Start the View Builder.
2. Complete the view setup area as follows:

   **View Name**
   If you are creating a new view, overwrite the current name with a unique name for the view. This name is used in the event list. If you are editing an existing view, you do not need to make an entry in this field.

   **Editable**
   If you have the relevant administrator permissions, select this check box to allow other users to edit this view, or clear the check box to protect the view from being modified.

   **Restriction**: This setting applies only if the view is saved as part of an event list configuration (.elc file).

You can now define the view by choosing which columns to include, and specifying their order and format in the event list. You can also configure the sort orders and priorities of rows in the event list, and restrict the number of rows displayed.

3. From the **Display Columns** area, add, remove, and reposition columns as follows:

   **Event list matrix**
   This matrix shows all the columns that are selected to appear in the event list view, and the order in which they will appear. The actual column names are shown at the top, and the row below shows the data type of each column. In the row, the word *Dummy* is used to identify string columns, the number 1 identifies integer columns, and 01/01/70 01:00:01 identifies time columns.

   The event list matrix is used in conjunction with the **Remove**, **First**, **Left**, **Right**, and **Last** buttons. To perform an action on any column in this matrix, you must first click the cell that is associated with that column. When you select a column in this way, the details that are currently defined for that column are also shown in the **Column Details** area.

   **Available columns list**
   This list, which is adjacent to the **Column Details** area, displays all of the columns that can still be added to the event list. The available columns list is used in conjunction with the **Add** button.

   Select any column that you want to add to the event list.

   **Tip**: Column names in this list are shown in alphabetical order.

   **Add** Click this button to add a column that is currently selected in the
available columns list, to the event list. The column is added as the rightmost item in the event list matrix.

Tip: You can add a column using a drag-and-drop technique. From the available columns list, select the column that you want to add. Press and hold down the middle mouse button over this column, and then drag it into the event list matrix. The cursor changes to display a green tick when you are within the area where you can drop the column. Release the mouse button. The column is added as the rightmost item in the event list matrix.

Remove
Click this button to move the currently-selected column in the event list matrix back to the available columns list. This column will no longer appear in the event list.

Tip: You can remove a column using a drag-and-drop technique. From the event list matrix, select the cell of the column that you want to remove. Press and hold down the middle mouse button over this cell, and then drag the cursor into the available columns list. The cursor changes to display a green tick when you are within the area where you can drop the column. Release the mouse button. The column is added to the available columns list.

First
Click this button to reposition the currently-selected column in the event list matrix as the first (leftmost) column in the event list.

Left
Click this button to move the currently-selected column in the event list matrix one position to the left.

Right
Click this button to move the currently-selected column in the event list matrix one position to the right.

Last
Click this button to reposition the currently-selected column in the event list matrix as the last (rightmost) column in the event list.

4. From the Display Columns area, format the columns as follows:

Column Details
Use this area to format the column that is currently selected in the event list matrix:

Column/Justify
The system-defined column name appears in the Column field as a read-only value. From the adjacent Justify list, select Left, Centre, or Right to set the alignment of the column data in the event list.

Title/Justify
If you want the column to appear with a different title other than its system-defined name, type this title in the Title field. From the adjacent Justify list, select Left, Centre, or Right to set the alignment of the column title in the event list.

Width
Drag the slider box to the left or right to set the width of the column in the event list.

Fixed Columns
You can have a number of fixed columns on the left-hand side of the event list. Fixed columns do not move off the screen if you scroll across the columns in the view. Use this slider to fix up to one less than the total number of columns in the view.
5. From the **Sort Columns** area, specify sort orders and sort priorities of the event list columns as follows:

**Available sort list**
This list (on the left) displays all the available columns by which you can sort event data. The available sort list is used in conjunction with the **Add** button.

Select any column by which the event list rows are to be sorted.

**Tip:** Column names in this list are shown in alphabetical order.

**Add**  
Click this button to add the column selected in the available sort list to the adjacent sort order definition list. The column is added to the bottom of the sort list.

**Tip:** You can add a column using a drag-and-drop technique. From the available sort list, select the column that you want to add to the sort order definition list. Press and hold down the middle mouse button over this column name, and then drag the cursor into the sort order definition list. The cursor changes to display a green tick when you are within the area where you can drop the column. Release the mouse button. The column is added to the bottom of the sort order definition list.

**Sort order definition list**
This list (on the right) shows all the columns that will be used to sort event data. Use this list to specify your sort definitions for event data as follows:

- Define a sort order for each column: An arrow is shown to the left of each column name in the list. By default, this arrow points upwards, indicating that the column will be sorted in ascending alphabetic order. To change to descending order, double-click the arrow. To change the sort direction, you can also right-click over the selected column name and then select **Change** from the pop-up menu.

- Define a sort priority for all columns: The field at the top of the sort list has the highest priority when sorting. If the first field contains identical values for a number of entries, the second field in the list is used to sort those entries. To raise or lower the sort priority of a column, select the column name and then use the **Top**, **Up**, **Down**, and **Bottom** buttons, as described below.

You can also use the sort order definition list in conjunction with the **Remove** button.

**Remove**  
Click this button to remove a currently-selected sort column from the sort order definition list, back to the available sort list. You can also right-click over the selected column name and then select **Remove** from the pop-up menu.

**Tip:** You can remove a column using a drag-and-drop technique. From the sort order definition list, select the column that you want to remove. Press and hold down the middle mouse button over this column name, and then drag the cursor into the available sort list. The cursor should change to display a green tick when you are within the area where you can drop the column. Release the mouse button. The column is added to the available sort list.
Top  Click this button to move the selected column to the top of the list. You can also right-click over the selected column name and then click Top from the pop-up menu.

Up  Click this button to move the selected column up one place in the list. You can also right-click over the selected column name and then click Up from the pop-up menu.

Down  Click this button to move the selected column down one place in the list. You can also right-click over the selected column name and then click Down from the pop-up menu.

Bottom  Click this button to move the selected column to the bottom of the list. You can also right-click over the selected column name and then click Bottom from the pop-up menu.

6. From the Restrict Rows area, restrict the number of rows on display in the event list as follows:

Restrict rows [1-100]
Select this check box if you want to restrict the number of rows that are shown in the event list, to between 1 and 100. The Minimum, Maximum, and Default fields become available.

Note: If you select the Restrict rows [1-100] check box, and save the configuration as a .elv file, the .elv file is not compatible with Netcool/OMNIbus V3.6.

Minimum  Type the minimum number of rows to be displayed, or use the arrows to increase or decrease the value.

Maximum  Type the maximum number of rows to be displayed, or use the arrows to increase or decrease the value.

Default  Type the default number of rows to be displayed, or use the arrows to increase or decrease the value.

Set from Event List  Select this check box if you want event list users to be able to choose the number of events to display in their event list view. If you select this check box, the number of events that users can choose to view by using the event list controls is constrained by the Minimum and Maximum values specified in the View Builder. If this check box is clear, the number of events that are displayed will always be the specified Default value.

7. After defining the view, save the view or cancel your changes as follows:

Apply  Click this button to apply changes to the view without saving it.

Close  Click this button to close the window and discard the changes.

Results
You must save views with a .elv file extension.
Note: When you run the UNIX View Builder from the Conductor, the **Apply** button does not appear. In this case, you must save all views by selecting **File > Save** or **File > Save As** from the UNIX View Builder.

**Related tasks:**

“Starting the View Builder” on page 94

**Creating or editing a view on Windows**

Use the View Builder to define which columns to display in the event list.

To create or edit a view:
1. Start the View Builder.
2. Complete the view setup area as follows:

   - **Name**  
     If you are creating a new view, overwrite the current name with a unique name for the view. This name is used in the event list. If you are editing an existing view, you do not need to make an entry in this field.

   - **Editable**  
     If you have the relevant administrator permissions, select this check box to allow other users to edit this view, or clear the check box to protect the view from being modified.

   - **Restriction:** This setting applies only if the view is saved as part of an event list configuration (.elc file).

You can now define the view by choosing which columns to include, and specifying their order and format in the event list. You can also configure the sort orders and priorities of rows in the event list, and restrict the number of rows displayed.

3. From the **Display Columns** area, add, remove, reposition, and format columns as follows:

   - **Available Fields**  
     This list displays all of the columns that can still be added to the event list. Column names in this list are shown in alphabetical order. The **Available Fields** list works in conjunction with the **Event List View** list, which holds columns that you have chosen to add to the event list.

     Use the buttons described in the following table to move columns between the two lists.

     **Table 13. Column selection buttons**

     | Button | Description |
     |--------|-------------|
     | →      | Click this button to move a selected column from the list of available fields on the left, to the list on the right. |
     | ←      | Click this button to move all columns from the list of available fields on the left, to the list on the right. |
     | ←      | Click this button to move a selected column from the list on the right, to the list of available fields on the left. |
     | ←      | Click this button to move all columns from the list on the right, to the list of available fields on the left. |

   - **Event List View**  
     This list shows all the columns that are selected to appear in the event list view, and the order in which they will be displayed.
You can change the order of the columns by using the buttons described in the following table.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>↑</td>
<td>Click this button to move the selected column to the top of the list, making it the first column shown in the event list.</td>
</tr>
<tr>
<td>↑</td>
<td>Click this button to move the selected column up one place in the list (or one position to the left in the event list).</td>
</tr>
<tr>
<td>↓</td>
<td>Click this button to move the selected column down one place in the list (or one position to the right in the event list).</td>
</tr>
<tr>
<td>↓</td>
<td>Click this button to move the selected column to the bottom of the list, making it the last column shown in the event list.</td>
</tr>
</tbody>
</table>

Field Name/Justify
When you select a column in the Event List View list, the system-defined column name is shown in the Field Name field as a read-only value. From the adjacent Justify list, select Left, Centre, or Right to set the alignment of the column data in the event list.

Column Title/Justify
If you want the selected column in the Event List View list to appear with a different title other than its system-defined name, type this title in the Column Title field. From the adjacent Justify list, select Left, Centre, or Right to set the alignment of the column title in the event list.

Column Width
Specify the width of the column in the event list.

4. From the Sort Columns area, specify sort orders and sort priorities of the event list columns as follows:

Available Sort Fields
This list displays all the available columns by which you can sort event data. Column names in this list are shown in alphabetical order. The Available Sort Fields list is used in conjunction with the Sorted By list.

Use the buttons that are described in the preceding Column selection buttons table to move columns between the two lists.

Sorted By
This list shows the columns for sorting event data. Use this list to specify your sort definitions for event data as follows:

- Define a sort order for each column: An arrow is shown to the left of each column name in the list. By default, this arrow points upwards, indicating that the column will be sorted in ascending alphabetic order. To change to descending order, double-click the arrow. To change the sort direction, you can also right-click over the selected column name and then select Change from the pop-up menu.
- Define a sort priority for all columns: The field at the top of the sort list has the highest priority when sorting. If you add a second field to the list, and the first field is identical for a number of entries, the second field is used to sort those entries. To raise or lower the sort priority of a column, select the column name and then use the arrow buttons, as described in the following table.
Table 15. Column sort order buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="↑" /></td>
<td>Click this button to move the selected column to the top of the list.</td>
</tr>
<tr>
<td><img src="image" alt="↑" /></td>
<td>Click this button to move the selected column up one place in the list.</td>
</tr>
<tr>
<td><img src="image" alt="↓" /></td>
<td>Click this button to move the selected column down one place in the list.</td>
</tr>
<tr>
<td><img src="image" alt="↓" /></td>
<td>Click this button to move the selected column to the bottom of the list.</td>
</tr>
</tbody>
</table>

5. From the **Restrict Rows** area, restrict the number of rows on display in the event list as follows:

   **Restrict rows [1-100]**
   Select this check box if you want to restrict the number of rows that are shown in the event list, to between 1 and 100. The **Minimum**, **Maximum**, and **Default** fields become available.

   **Note:** If you select the **Restrict rows [1-100]** check box, and save the configuration as a .elv file, the .elv file is not compatible with Netcool/OMNibus V3.6.

   **Minimum**
   Type the minimum number of rows to be displayed, or use the arrows to increase or decrease the value.

   **Maximum**
   Type the maximum number of rows to be displayed, or use the arrows to increase or decrease the value.

   **Default**
   Type the default number of rows to be displayed, or use the arrows to increase or decrease the value.

   **Set from Event List**
   Select this check box if you want event list users to be able to choose the number of events to display in their event list view. If you select this check box, the number of events that users can choose to view by using the event list controls is constrained by the **Minimum** and **Maximum** values specified in the View Builder. If this check box is clear, the number of events displayed will always be the specified **Default** value.

6. After defining the view, save the view or cancel your changes as follows:

   **Apply**  Click this button to apply changes to the view without saving it.

   **Close**  Click this button to close the window and discard the changes.

   You must save views with a .elv file extension. Click **File > Save** or **File > Save As**.

**Related tasks:**

["Starting the View Builder" on page 94]
Dragging and dropping views on UNIX

You can use the drag-and-drop feature with views on UNIX.

You can drag and drop from:
- One View Builder to another
- The View Builder to an Event List Configuration window

To drag and drop a view:
1. From the View Builder, move the cursor over the drag point icon (to the right of the Editable check box).
2. Click and hold the middle mouse button.
3. Drag the mouse to another View Builder or an Event List Configuration window. When the cursor is over a valid drop area, its color changes to green.
4. Release the mouse button to drop the view.

Opening a view

You can open a saved view in order to view or edit its definition.

To open a view:
1. Start the View Builder.
2. Select File > Open. The Open View window opens. Note that this window is associated with saving or opening filters, views, and event list configurations. Therefore, not all of the fields might be applicable to your current action.
3. Complete this window as follows:
   - **Filter** Use this field to specify a search query for the type of file that you want to open. This field works in conjunction with the Filter button and the Files list. Enter the current directory path and file type in the Filter field, and then click Filter. All matching files are displayed in the Files list.
     For example, to display all the filter files in the /myfiles/filters directory, enter /myfiles/filters/*.elf and click Filter to view all matching files.
   - **Directories** This list displays all of the subdirectories in the current directory. To refresh the directory, double-click the '..' entry. To move up the directory tree by one directory, double-click the '...' entry.
   - **Files** This list displays the files in the current directory, which match the selection in the Filter field. Select the name of the file that you want to open. You can also select an existing file that you want to overwrite.
   - **Selection** The path and name of the file that you are saving or opening are shown here. You can edit the path and file name to open a different file, to save a file to another location, or to save a file by using a different file name.
     If you are saving a view, use a .elv extension in the file name. If you are saving a filter, use a .elf extension in the file name. If you are saving an event list configuration, use a .elc extension in the file name.
Backup Existing Files (UNIX only)
Select this check box to create a backup of an existing view file if the file name that you are saving already exists. This check box is displayed only if you are saving a filter, view, or event list configuration.

OK  Click this button to open or save the file.

Filter  This button works in conjunction with the Filter field and the Files list. Click this button to display files in the current directory based on your selection in the Filter field. The files appear in the Files list.

Cancel  Click this button to close this window without opening or saving a file.

Results
The view opens within the View Builder.

Related tasks:
“Starting the View Builder” on page 94
Chapter 5. Configuring quick access to filters, views, and event list configurations on UNIX

From the UNIX Conductor, you can view the contents of your local UNIX system directories, and easily access filter files, view files, and event list configuration files for use in the management of alerts.

You can use a browser utility to view the files on your UNIX system, and then set up a personal library of files that you use frequently.

You can also configure your system to automatically open an event list configuration whenever you start the Conductor.

Related tasks:
“Starting the Conductor” on page 3

About the personal library

Each UNIX user on a particular server has a .omnibus directory, and the personal library acts as a graphical browser for that directory. From the UNIX Conductor, you can customize your personal library to include views, filters, and event list configurations that you use frequently.

By default, the personal library also contains a prefs icon that you can use to set global preferences for the Tivoli Netcool/OMNIbus desktop.

A number of icons are used to represent the different file types in the personal library. These icons are described in the following table.

<table>
<thead>
<tr>
<th>Icon example</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>prefs</td>
<td>This icon represents the repository of your Tivoli Netcool/OMNIbus desktop preferences. When you change your tool preferences, the changes are made in this file.</td>
</tr>
<tr>
<td></td>
<td>This icon represents an event list configuration. Event list configurations are stored as .elc files.</td>
</tr>
<tr>
<td></td>
<td>This icon represents an event list filter. Filters are stored as .elf files.</td>
</tr>
<tr>
<td></td>
<td>This icon represents an event list view. Views are stored as .elv files.</td>
</tr>
<tr>
<td></td>
<td>The event list configuration, filter, and view icons may appear covered by a chain link. This indicates that a symbolic link to the file has been created in the personal library. The icon to the left shows an example of a linked filter file.</td>
</tr>
</tbody>
</table>
Related tasks:
“Setting global preferences for the UNIX Conductor” on page 10
“Removing files from the personal library” on page 108
“Starting an application from the personal library” on page 108
“Viewing the full contents of the personal library” on page 109
“Creating symbolic links in the personal library” on page 107

Working with your local system directories

Tivoli Netcool/OMNibus provides a directory browser utility that operates in a similar manner to any UNIX file system browser.

You can use this directory browser to view the contents of your local UNIX system directories, and to move and copy view files, filter files, and event list configuration files between the directory browser and your personal library, which holds frequently-used files. You can also use the browser to directly open views, filters, and event list configurations.

To view the contents of your local UNIX system directories and work with the Tivoli Netcool/OMNibus files:

1. From the Conductor, click Browser in the button bar. The Directory Browser window opens.
2. Complete this window as follows:

   **Directory**
   This field displays the full path name of the current directory. To change the directory, perform either of the following actions:
   - Type the full directory path in the field and press Enter.
   - Double-click any directory icon in the directory display area.

   **Directory display area**
   This area displays the subdirectories that exist within the current directory. A parent directory is depicted as an icon with two periods (..) that represent the directory name. To move to a directory above the current directory, double-click the parent directory icon.

   You can drag and drop files from this area of the directory browser into your personal library in the Conductor:
   - Use the middle mouse button to move files. (This is equivalent to using the `mv` command.)
   - Use the Ctrl key and middle mouse button simultaneously to copy files. (This is equivalent to using the `cp` command.)

   **Note:** You can drag and drop all icons except those representing directories.

   You can similarly drag and drop all icons (except the `prefs` icon) in the personal library into this directory display area.

   You can also directly open views, filters, and event list configurations by double-clicking the relevant icons. Double-click a `.elf` icon to open the defined filter within the Filter Builder. Double-click a `.elv` icon to open the defined view within the View Builder. Double-click a `.elc` icon to open the defined event list configuration within the Event List monitor box window.
Maintaining a personal library of frequently-used files

The personal library in the UNIX Conductor provides an easily-accessible location from which to open frequently-used filter files, view files, and event list configuration files. You can add Tivoli Netcool/OMNIbus files to the personal library and quickly open their associated applications, and you can remove files that are no longer needed.

Adding files to the personal library

You can use the personal library in conjunction with the directory browser utility to build up your library of frequently-used files.

To add files to your personal library:

1. Open the directory browser to view the contents of your local UNIX system directories.
2. Drag and drop icons representing your required files from the directory browser into the personal library in either of the following ways:
   • Use the middle mouse button to move files. (This is equivalent to using the `mv` command.)
   • Use the Ctrl key and middle mouse button simultaneously to copy files. (This is equivalent to using the `cp` command.)

   Note: You can drag and drop all icons except those representing directories.

What to do next

Tip: You can also copy files from the personal library into the directory browser. Note that you can move or copy all files except the `prefs` icon.

Related tasks:
  “Working with your local system directories” on page 106

Creating symbolic links in the personal library

You can create a symbolic link in your personal library, to a file in your local UNIX system.

To create symbolic links:

From the Directory Browser window, press Shift+Ctrl and then simultaneously use the middle mouse button to drag the file for which you want to create a symbolic link, to the personal library. (This is equivalent to using the `ln -s` command.) A symbolic link is created within the personal library. The icon for the symbolic link is shown with a chain over the icon image.
What to do next

Tip: You can also copy files from the personal library into the directory browser. You can move or copy all files except the `prefs` icon.

**Related concepts:**

“About the personal library” on page 105

Starting an application from the personal library

You can start the Filter Builder, View Builder, and event list from your personal library. You can also work with files that are represented by symbolic links.

Start an application in any of the following ways:

- To start the Filter Builder with a filter loaded, double-click a filter icon (.elf file) in the personal library, or right-click the icon and click **Start Filter Builder** from the pop-up menu.
- To start the View Builder with a view loaded, double-click a view icon (.elv file) in the personal library, or right-click the icon and click **Start View Builder** from the pop-up menu.
- To start an event list with a specific configuration, double-click an event list configuration icon (.elc file) in the personal library, or right-click the icon and click **Start Event List** from the pop-up menu.
- To start and work with the file that is represented by a symbolic link, double-click the symbolic link.

**Related concepts:**

“About the personal library” on page 105

Removing files from the personal library

If you no longer require a file to be in the personal library, you can move it from the personal library back into the directory browser by using the drag-and-drop technique with the middle mouse button. You can also delete files from the personal library.

From the Conductor, perform any of the following actions:

- To delete a filter from the personal library, right-click the icon and click **Delete** from the pop-up menu.
- To delete a view from the personal library, right-click the icon and click **Delete** from the pop-up menu.
- To delete an event list configuration from the personal library, right-click the icon and click **Delete** from the pop-up menu.
- When you no longer require a symbolic link in the personal library, right-click the icon and click **Delete** from the pop-up menu. The reference to the file is removed, but the file itself is not deleted.

**Related concepts:**

“About the personal library” on page 105
Viewing the full contents of the personal library

On occasion, you might want to refresh or update the personal library to show certain files that are currently held in this location, but which are, by default, not shown.

From the Conductor, perform any of the following actions:

- To refresh the contents of the personal library, click View > Refresh.
- To view hidden files, which have names beginning with a period, click View > Show Hidden Files.
- To view backup files, which have names ending in .bak, click View > Show Backup Files.

Related concepts:

“About the personal library” on page 105

Automatically opening an event list configuration on startup

You can configure an event list configuration file (.elc) to open automatically whenever you start the UNIX Conductor. You can open only one event list configuration at a time in this way.

You can choose to start up an event list configuration file that is located in the personal library, or you can choose a file using the directory browser utility. You must then customize the configurable button (leftmost button) in the button bar of the Conductor. If the button is not yet linked to an event list configuration, it is represented by a dotted rectangle and acts as a file placeholder.

From the Conductor, use the middle mouse button to drag an event list configuration (.elc) icon from the personal library or Directory Browser window. When the icon is over the configurable button in the button bar, and the cursor has a tick next to it, release the mouse button. The next time you start the Conductor, the event list configuration opens.
Chapter 6. Configuring properties, server communication, and settings

You can configure properties for Tivoli Netcool/OMNIbus components, and communication information for the server components from the UNIX and Windows Conductors. On Windows, you can perform these two functions in a combined task within a settings window. On UNIX, you can also change the date format in event lists.

Configuring properties

You can edit the information contained in the properties files for ObjectServers, proxy servers, the database initialization utility (nco_dbinit), the Conffpack utility (nco_conffpack), Netcool/OMNIbus Administrator (nco_config), probes, and gateways. A properties file has a .props extension.

To edit properties:
1. Perform either of the following actions:
   - From the Conductor window on UNIX, click Properties in the button bar.
   - From the Conductor menu on Windows, click Properties.
   The Properties Editor window opens.
2. Complete this window as follows:
   - **Type**: On UNIX, select either of the following options:
     - Select Generic to edit the properties files of components other than probes. The File drop-down list becomes populated with these files.
     - Select Probe to edit probe properties files. The File drop-down list becomes populated with these files.
   - On Windows, select any of the following options:
     - Select ObjectServer to edit the properties files of components such as ObjectServers and proxy servers. The Name drop-down list becomes populated with these files. These files are typically stored in the %NCHOME%/omnibus/etc directory.
     - Select Probe to edit probe properties files. The Name drop-down list becomes populated with these files. These files are typically stored in the %NCHOME%/omnibus/probes/win32 directory.
     - Select Server to add a new properties file. These files are saved to the %NCHOME%/omnibus/ini directory. The Name drop-down list becomes populated with the text <New File>.

   - **File (UNIX)/Name (Windows)**
     Select the properties file that you want to edit from this drop-down list. This list is populated based on your selection from the Type drop-down list. The default values are:
     - nco_dbinit.props: Properties file to be read when database initialization starts (You run nco_dbinit to initialize the database.)
     - NCO_PROXY.props: Proxy server properties file (A proxy server can be used to reduce the number of probe connections to an ObjectServer.)
     - nco_conffpack.props: Conffpack properties file (nco_conffpack is used for importing and exporting ObjectServer configurations.)
- nco_config.props: Netcool/OMNIbus Administrator properties file
- NCOMS.props: ObjectServer properties file

On Windows, the .props file extension is not shown, and the property list is automatically populated with the available properties when you select a file in the Name list.

Open (UNIX only)
On UNIX, after selecting the type and file name, click this button to open the properties file.

Property list
This matrix shows details of any properties that you have added to the properties file. You can select a property in this list if you want to change it. There is a default set of properties that are already defined for probe properties files and these cannot be removed. These properties are shown in gray in the property list.

Name
This field shows the name of the property that you have selected for editing from the property list. You cannot change the name of existing properties. On Windows, you can also use the drop-down list to select the property to edit.

If you want to add a new property to the selected properties file, type the name of the property here.

If you selected Server from the Type list in order to create a new properties file, type the name of a new property here.

Value
If you are working with an existing, selected properties file, edit the value of the selected property, or type the value for the new property that you are adding.

If you selected Server from the Type list in order to create a new properties file, type the value of a new property.

Add/Update
This button changes depending on whether you are adding or editing an existing property. If you enter a new property name and value, click Add to add the value to the property list. If you change the value of a property that is selected in the property list, click Update to update the value in the property list.

If you selected Server from the Type list in order to create a new properties file, click Add to add the new property.

Remove
Click this button to remove the selected property from the properties file. The button is unavailable if you select a default property.

Save
Click this button to save the changes to the properties file.

If you selected Server from the Type list in order to create a new properties file, click Save after adding a new property to the property list. From the Save New Properties window, type a name for the properties file, but omit the .props extension; this is automatically added for you. Click Save to save the file to the %NCHOME%/omnibus/ini directory. The properties file name is shown in the Name field that is adjacent to the Type field, and you can continue to add properties to this file. Note that you will be required to edit this file in order to add quotation marks to string values that you specify for the properties.
Configuring server communication information

You must maintain server communication information for the Tivoli Netcool/OMNIbus server components. You can use the Server Editor to create and modify communication details for the server components, test server activity, and add backup (or failover) servers and listeners.

To configure server communication information:
1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
</table>
| UNIX             | Perform either of the following actions:  
                      • Click the Interfaces button on the UNIX Conductor.  
                      • Enter \$NCHOME/omnibus/bin/nco_xigen on the command line. |
| Windows          | Perform either of the following actions:  
                      • Click Start > Programs > Netcool Suite > System Utilities > Servers Editor.  
                      • Open the Conductor menu by right-clicking the bus icon in the desktop tray, and then click Servers. |

The Server Editor opens.

2. Complete this window as follows:

   **Server list**
   The server list shows existing server components and their settings:

   **Server** This column displays the name of each server that is defined for this workstation. The default server names are:
   • NCOMS: The default name for ObjectServers
   • NCO_PROXY: The default name for proxy servers
   • NCO_GATE: The default name for gateways
   • NCO_PA: The default name for process agents

   On Windows, the host workstation for the server must have a listener entry, and the host workstation and any other workstation that connects to that server must have a client entry.

   Backup ObjectServers appear below the primary ObjectServer in the Server Editor. To hide the list of backup ObjectServers, double-click the primary ObjectServer name or server icon. The backup ObjectServers are hidden and the letter C appears in the...
server icon. Double-click again to display the backup ObjectServers. The server icon returns to normal.

Hostname
This column displays the host name or IP address of the workstation on which the server component is installed.

Note: After installation, the host is set to omnihost for all servers (on UNIX). You must change this to the name of the server host workstation. On Windows, the default is the host name.

Port
This column displays the port on which the server component listens for unencrypted connections.

SSL
On UNIX, this column displays the port on which the server component listens for encrypted connections. On UNIX systems, a server component can have a standard port, an SSL port, or both, defined.

On Windows, this column displays the word yes for encrypted connections. On Windows systems, the same port number is used for both encrypted and unencrypted connections.

Server entry fields
Use the server entry fields to enter or edit the details of each server component. If you are editing the details of an existing server component, you must first select the relevant row in the server list, so that the details are shown within the server entry fields.

Name
Type the name of a new server component or edit the name of an existing component. On Windows, you can also use the drop-down list to select a name. Use the following suffixes when naming components: _PROXY for proxy servers, _GATE for gateways, and _PA for process agents.

Note: The name of a server entry must consist of 29 or fewer uppercase letters and cannot begin with an integer.

Host
Type or edit the host name or IP address of the workstation on which the server component is installed. (For new server components on UNIX, the name is set to omnihost by default, and must be changed to the actual host name or IP address.)

If you type an IP address, you can specify an IPv4 or IPv6 address. For example:
• 192.168.0.1
• 2094:82a:2a6e:123:503:badd:fe43:f552

Port
On UNIX, if you want clients using unencrypted connections to be able to connect to the server, type a valid, unused port number in this field. To disallow unencrypted connections, do not set the port.

On Windows, type a valid, unused port number in this field.

SSL
On UNIX, type a valid, unused port number in this field if you want clients using encrypted connections to be able to connect to the server. To disallow encrypted connections, do not set the port.
On Windows, select this check box to indicate that the port accepts encrypted connections from clients that use SSL.

Note: On UNIX systems, a server component can have a standard port, an SSL port, or both ports defined. On Windows systems, the same port number is used for either type of connection.

Listener (Windows only)
Select this check box if this is a listener entry on the host workstation for the server. Clear the Listener check box if this is a client entry.

Add  Click this button to add new (and unique) server details to the server list.

Remove/Update
This button changes based on whether you have made any changes to the server component that is currently selected. Click Remove if you want to remove the server component that is currently selected from the server list. Click Update to refresh the server list with updated details of an existing server component.

Test  Click this button to test that you can connect to the server that is selected in the server list. The Server Editor attempts to contact the server on the specified host and port. A window shows the result of the test command.

Priority fields
The server priority fields enable you to raise or lower the priority of server components that are configured as failover systems. For example, suppose an ObjectServer called NCOMS_PRI is configured with a backup called NCOMS_BAK. Using the Raise or Lower buttons, you can raise the priority of NCOMS_BAK to be the primary ObjectServer and NCOMS_PRI to be the backup.

Raise  Click this button to raise the priority of the selected server component by one level.

Lower  Click this button to lower the priority of the selected server component by one level.

Generate All (UNIX only)
Click this button to generate interfaces files for all UNIX operating systems. When you apply your changes (using the Apply button), this generates interfaces files named $NCHOME/etc/interfaces.arch, where arch represents individual UNIX platform names; for example, interfaces.hpux11 and interfaces.solaris2.

Show Groups (Windows only)
On Windows, select this check box to group each server by name within the server list, with backup servers and listeners identified following the client entry.

Apply (UNIX only)
Click this button to apply the changes to the interfaces file. Any server components that were added to the server list, removed from the server list, or edited, will be saved to this file.
Configuring Tivoli Netcool/OMNIbus settings on Windows

You can configure properties and server communication information for Tivoli Netcool/OMNIbus on Windows, in a single task.

To configure settings on Windows:

   **Tip:** If you make any changes to one of the tabs and then try to access another tab without saving your changes, you are prompted to save or cancel your changes. At any point in time, you can also click the OK button to save all of your changes and close the window, or click the Cancel button to close the window without saving your changes. If you want to save the changes made to any tab without closing the window, click the Apply button.

2. Use the Overview tab to view information about the location and properties of the Tivoli Netcool/OMNIbus server components.

3. From the Servers tab, create and modify communication details for the server components, test server activity, and add backup (or failover) servers and listeners. Complete this tab as follows:

   **Server list**
   
The server list shows existing server components and their settings:

   **Server** This column displays the name of each server that is defined for this workstation. The default server names are:
   - NCOMS: The default name for ObjectServers
   - NCO_PROXY: The default name for proxy servers
   - NCO_GATE: The default name for gateways
   - NCO_PA: The default name for process agents

   The host workstation for the server must have a **listener** entry, and the host workstation and any other workstation that connects to that server must have a **client** entry.

   Backup ObjectServers appear below the primary ObjectServer in the Server Editor. To hide the list of backup ObjectServers, double-click the primary ObjectServer name or server icon. The backup ObjectServers are hidden and the letter C appears in the server icon. Double-click again to display the backup ObjectServers. The server icon returns to normal.

   **Host** This column displays the host name or IP address of the workstation on which the server component is installed. The default is the host name.
Port  This column displays the port on which the server component
    listens for unencrypted connections.
SSL   This column displays the word yes for encrypted connections.
    The same port number is used for both encrypted and
    unencrypted connections.

Server entry fields
Use the server entry fields to enter or edit the details of each server
component. If you are editing the details of an existing server
component, you must first select the relevant row in the server list, so
that the details are shown within the server entry fields.
Name  Type the name of a new server component or edit the name of
    an existing component. You can also use the drop-down list to
    select a name. Use the following suffixes when naming
    components: _PROXY for proxy servers, _GATE for gateways,
    and _PA for process control agents.

Note: The name of a server entry must consist of 29 or fewer
    uppercase letters and cannot begin with an integer.
Host  Type or edit the host name or IP address of the workstation on
    which the server component is installed.
    If you type an IP address, you can specify an IPv4 or IPv6
    address. For example:
    • 192.168.0.1
    • 2001:0db8:0582:80dc:0003:0000:0000:0125
Port  Type a valid, unused port number.
Listener
Select this check box if this is a listener entry on the host
workstation for the server. Clear the Listener check box if this
is a client entry.
SSL   Select this check box to indicate that the port accepts encrypted
    connections from clients that use SSL. The same port number is
    used for encrypted and unencrypted connections.
Add   Click this button to add new (and unique) server details to the
    server list.
Remove/Update
This button changes based on whether you have made any
changes to the server component that is currently selected.
Click Remove if you want to remove the server component that
is currently selected from the server list. Click Update to
refresh the server list with updated details of an existing server
component.
Test  Click this button to test that you can connect to the server that
    is selected in the server list. The Server Editor attempts to
    contact the server on the specified host and port. A window
    shows the result of the test command.
Priority
The server priority fields enable you to raise or lower the priority of
server components that are configured as failover systems. For
example, suppose an ObjectServer called NCOMS_PRI is configured
with a backup called NCOMS_BAK. Using the **Raise** or **Lower** buttons, you can raise the priority of NCOMS_BAK to be the primary ObjectServer and NCOMS_PRI to be the backup.

**Raise**  Click this button to raise the priority of the selected server component by one level.

**Lower**  Click this button to lower the priority of the selected server component by one level.

**Show Groups**  
Select this check box to group each server by name within the server list, with backup servers and listeners identified following the client entry.

4. From the **Properties** tab, edit the information contained in the properties files for each ObjectServer, proxy server, process agent, probe, and gateway. Complete this tab as follows:

**Type**  Select any of the following options:
- Select **ObjectServer** to edit the properties files of components such as ObjectServers and proxy servers. The **Name** drop-down list becomes populated with these files. These files are typically stored in the `%NCHOME%\omnibus\etc` directory.
- Select **Probe** to edit probe properties files. The **Name** drop-down list becomes populated with these files. These files are typically stored in the `%NCHOME%\omnibus\probes\win32` directory.
- Select **Server** to add a new properties file. These files are saved to the `%NCHOME%\omnibus\ini` directory. The **Name** drop-down list becomes populated with the text `<New File>`.

**Name**  Select the properties file that you want to edit from this drop-down list. This list is populated based on your selection from the **Type** drop-down list. The default values are:
- `nco_dbinit`: Properties file to be read when database initialization starts (You run `nco_dbinit` to initialize the database.)
- `NCO_PROXY`: Proxy server properties file (A proxy server can be used to reduce the number of probe connections to an ObjectServer.)
- `nco_confpack`: Confpack properties file (`nco_confpack` is used for importing and exporting ObjectServer configurations.)
- `nco_config`: Netcool/OMNIbus Administrator properties file
- `NCOMS`: ObjectServer properties file

Note that the `.props` file extension is not shown, and the property list is automatically populated with the available properties when you select a file in the **Name** list.

**Property list**  
This matrix shows details of any properties that you have added to the properties file. You can select a property in this list if you want to change it. There is a default set of properties that are already defined for probe properties files and these cannot be removed. These properties are shown in gray in the property list.

**Name**  This field shows the name of the property that you have selected for editing from the property list. You cannot change the name of existing properties. You can also use the drop-down list to select the property to edit.
If you want to add a new property to the selected properties file, type the name of the property here.

If you selected Server from the Type list in order to create a new properties file, type the name of a new property here.

**Value**

If you are working with an existing, selected properties file, edit the value of the selected property, or type the value for the new property that you are adding.

If you selected Server from the Type list in order to create a new properties file, type the value of a new property.

**Add/Update**

This button changes depending on whether you are adding or editing an existing property. If you enter a new property name and value, click Add to add the value to the property list. If you change the value of a property that is selected in the property list, click Update to update the value in the property list.

If you selected Server from the Type list in order to create a new properties file, click Add to add the new property.

**Remove**

Click this button to remove the selected property from the properties file. The button is unavailable if you select a default property.

**Save**

Click this button to save the changes to the properties file.

If you selected Server from the Type list in order to create a new properties file, click Save after adding a new property to the property list. From the Save New Properties window, type a name for the properties file, but omit the .props extension; this will be automatically added for you. Click Save to save the file to the %NCHOME%\omnibus\ini directory. The properties file name is shown in the Name field that is adjacent to the Type field, and you can continue to add properties to this file. Note that you will be required to edit this file in order to add quotation marks to string values that you specify for the properties.

**What to do next**

**Tip:** You can also configure properties files by using the Properties Editor, and configure server communication with the Server Editor.

**Changing the date format in the event list on UNIX**

The date format in the event list is defined by the NCO_TIME environment variable. The default format is mm/dd/yy hh:mm:ss; for example, 11/12/03 20:13:36. This format is determined by the POSIX strftime function.

To set the default format, using csh, enter the following command:

```
setenv NCO_TIME %m/%d/%y %H:%M:%S
```

To set the default format, using ksh or sh, enter the following command:

```
NCO_TIME=%m/%d/%y %H:%M:%S;export NCO_TIME
```

See the man page for strftime for details of the conversion specifiers that are available.
**Note:** Changing the date format in the event list does not affect the alert timestamp.
Chapter 7. Monitoring accelerated events

Tivoli Netcool/OMNIbus can handle millions of events a day, with all events being treated with equal importance. However, operators might have key systems or events that have tightly-controlled latency requirements. To accommodate such requirements, the Accelerated Event Notification (AEN) application provides a means of accelerating high-priority events to help ensure that systems can continue to run without interruption.

To configure accelerated event notification, system administrators define conditions that identify key events for acceleration, and use channels to propagate these events to specific recipients for action. A channel defines which type (or columns) of event data to broadcast for accelerated events, and the recipients (typically operators) of this data.

Recipients of the accelerated event data manage the events from the Accelerated Event Notification client. All events that are identified for acceleration are directly sent to the client as pop-up notifications. These notifications contain event data that maps to the columns defined for the channel that is currently in use.

Recipients can additionally configure settings for the pop-up notifications, and can click across to the desktop event list or the Web GUI Active Event List to obtain full details for the event and manage the event.

Prerequisites:
- The Accelerated Event Notification client must be installed in order to receive accelerated event notifications, and you must have the relevant permissions.
- The Web GUI must be running and configured in order to view events within the Active Event List.
- The Desktop feature of Tivoli Netcool/OMNIbus must be installed in order to view events within the event list.

Starting the Accelerated Event Notification client

You must start the Accelerated Event Notification client in order to receive and manage accelerated events.

To start the Accelerated Event Notification client:
1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
</table>
| UNIX             | Enter the following command at the command line:  
|                  | $NCHOME/omnibus/bin/nco_aen |
| Windows          | Perform either of the following actions:  
|                  | • Click Start > Programs > Netcool Suite > Notifier.  
|                  | • Enter the following command at the command line:  
|                  | %NCHOME%\omnibus\bin\nco_aen.vbs |

The Accelerated Event Notifier login window opens.
2. Complete this window as follows:

**User ID**
Type your user ID for logging in to the ObjectServer that holds channel definition information, and from which you want to receive accelerated event notifications.

If you are signing in to the Accelerated Event Notification client (after previously signing out), your previously-specified user ID is displayed. You can type a different user ID if required.

**Password**
Type the password for the specified user ID.

**Log In**
Click this button to log in to the ObjectServer.

**Cancel**
Click this button to cancel the login process and close this window.

**Results**
When you click **Log In**, you are connected to the ObjectServer, and the state of the Accelerated Event Notification client is shown in a floating notifier panel on UNIX, or in the Windows system tray.

**Related concepts:**
"Accelerated event notification states"  
"About pop-up notifiers" on page 123

### Accelerated event notification states
The Accelerated Event Notification client can have one of three possible states, and uses icons to depict its state.

The possible states and associated icons are as follows:

**Table 17. Accelerated event notification icons and states**

<table>
<thead>
<tr>
<th>Icon</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>📤</td>
<td>Connected</td>
</tr>
<tr>
<td>📩</td>
<td>You have Messages</td>
</tr>
<tr>
<td>🔄</td>
<td>Not Connected</td>
</tr>
</tbody>
</table>

The following table shows examples of how these icons are represented on your screen.

**UNIX**

![Icon shown in a floating notifier panel](image)
About pop-up notifiers

The Accelerated Event Notification client uses pop-up notifiers for the display of channel information. A pop-up notifier provides summary information about an accelerated event and allows you to click across to the desktop event list or the Web GUI Active Event List for further investigation and action.

Whenever an accelerated event notification is received from the notification ObjectServer, a pop-up notifier is displayed on the screen. Pop-up notifiers form a vertical stack on the screen.

A sample pop-up notifier is shown in the following figure. Note that the type of event data and the position of the data in your pop-up notifiers will vary according to your configuration settings.

![Figure 28. Sections of a pop-up notifier](image)

A pop-up notifier typically contains the following sections:

1. **Link To button**
   Click this button to view and manage the event in either the event list or the Active Event List.

2. **Heading**
   A single line of text is shown here in bold font with a black font color. A white shadow effect is applied to the text to identify this as the most recent accelerated event notification. Long strings in the heading are truncated with an ellipsis (...).

3. **Drag bar**
   Click over this bar and then drag the mouse to move the stack of pop-up notifiers to a different location on the screen. The location of the stack is remembered between sessions.

4. **Close button**
   Click this button to remove a pop-up notifier from the pop-up stack.

5. **Line 1**
   A single line of text in bold font is shown. Long strings are truncated with an ellipsis (...).
Configuring property settings for the Accelerated Event Notification client

You can configure the Accelerated Event Notification client to specify which ObjectServer you want the client to receive notifications from, how notifications are displayed, the type of information displayed, and retention settings for this information. You can also specify where the associated events are managed.

You need to be signed on to the Accelerated Event Notification client to configure channel properties. You can configure application and message properties when the client is in one of three states: Connected, Not Connected, or You have Messages.

To configure properties for the Accelerated Event Notification client:
1. Perform the appropriate action for your operating system:
<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>Right-click over the floating notifier panel showing the connection state, and click <strong>Properties</strong> from the pop-up menu.</td>
</tr>
<tr>
<td>Windows</td>
<td>From the Windows system tray, right-click over the icon depicting the connection state, and click <strong>Properties</strong> from the pop-up menu.</td>
</tr>
</tbody>
</table>

The Accelerated Event Notifier Properties window opens.

2. From the **Application** tab, specify which ObjectServer you want to receive accelerated event notifications from, the type of event list within which you want to manage the accelerated events, and the Web browser for viewing online help.

![Figure 29. Properties window: Application tab](image)

Complete the tab as follows:

**Notification Settings**

Use these fields to specify whether operators can view additional details for accelerated events in the desktop event list or the Web GUI Active Event List. Based on your selection, operators can use one or the other of these event lists to manage accelerated events.

- **Server** Select the name of the ObjectServer from which accelerated event notifications should be received. This list is populated with ObjectServer entries from the Server Editor.

  **Note**: In a failover configuration, connection to the name of a virtual pair is not supported. You must select either the **(primary)** or **(backup)** server name.

- **View In** Select **Netcool Event list** to use the desktop event list to
manage accelerated events. Select Web GUI to use the Active Event List to manage accelerated events.

Launch In Context Settings: Netcool Event list tab
If you selected the Netcool Event list option in the Notification Settings area, you must use this tab to configure connection settings, and views, for the event list. Complete this tab as follows:

Server Select the ObjectServer from which accelerated event notifications are received. This list is populated with ObjectServer entries from the Server Editor.

View Specify the view that you want to apply to the event list. Either type the path to the .elv file, or click the ellipses (...) button to navigate to the .elv file.

Launch In Context Settings: Web GUI tab
If you selected the Web GUI option in the Notification Settings area, you must use this tab to configure connection settings, and views, for the Active Event List. Complete this tab as follows:

Server Type the host name or IP address of the Web GUI server. The host name can be a short name or a fully-qualified name.

If you type an IP address, you can specify an IPv4 or IPv6 address for the server. For IPv6 addresses, use brackets [ ] as delimiters. For example, for a literal IPv6 address of FEDC:BA12:3456:7890:FEDC:BA12:3456:7890, type:


Port Specify the port number on which the Web GUI server listens. The range is from 1 to 65536.

SSL Select this check box to specify that page requests to the Web GUI server should be made by using the Hypertext Transfer Protocol over Secure Socket Layer (HTTPS).

Version Specify the Web GUI server version.

View Type the name of a view within the Web GUI server, which must be applied to the Active Event List.

Browser Settings
Use this area to specify a Web browser for displaying online help.

Application
Either type the path to the executable file, or click the ellipses (...) button to navigate to the file. If you manually type a path to the file name, the system checks whether it is valid.

If you do not specify a browser for Windows, the default Windows browser is automatically used. On UNIX, you are prompted that you need to specify a browser.

3. From the Messages tab, configure settings for the history buffer and the pop-up notifier.
Complete the tab as follows:

History Settings
Inbound event notifications are stored in a history buffer, which is automatically cleared at the end of each application session. You can view this information in the Historical Data Viewer window. Use these fields to configure the size of the history buffer.

Remove Messages Older Than
Specify how long messages should remain in the history buffer before being automatically removed. The range is from 0 to 10080 minutes. (10080 minutes equates to the number of minutes in a week.) A value of 0 indicates that this field is to be ignored, in which case the automatic removal of messages from the history buffer is controlled by the value of the Number of Messages to Keep field.

Number of Messages to Keep
Specify the maximum number of messages that the history buffer can store during a session. When this maximum number is attained, the oldest message will be removed to make way for a new incoming message. The number of messages can range from 1 to 1000.

Note: If you reduce the size of the history buffer during the current session, the oldest messages that are over and above the new limit are lost.

Clear History
Click this button to clear the history buffer. This action causes all the information in the Historical Data Viewer window to be deleted.
Pop-up Settings
Accelerated events are displayed using pop-up notifiers. Use these fields to configure the number and behavior of the pop-up notifiers that are visible on the screen.

Display No More Than
Specify the maximum number of pop-up notifiers that can be visible on the screen at any time. The range is from 1 to 10. If the maximum number of pop-up notifiers is currently visible on the screen and another notification is received, the oldest event is removed from the stack of pop-up notifiers, and replaced with the new event. Intermediate alerts are repositioned to maintain the order in which they were received.

Popups Expire After
Specify how long a pop-up notifier remains on the screen before it is automatically removed from the screen. The range is from 0 to 10 minutes. (You can also manually close pop-up notifiers.)

Custom Settings: Visual tab
Use these fields to specify whether to include details of the channel name and the ObjectServer from which notifications are received, within the pop-up notifier. You can also specify the point of insertion of new pop-up notifiers.

Display Channel Name
Select this check box to add the name of the channel on which an accelerated event notification was broadcast.

Display Server Name
Select this check box to add the name of the ObjectServer that forwarded the notification to the Accelerated Event Notification client.

Insert New Messages At The
Select Top if you want new pop-up notifiers to be added at the top of the pop-up stack. Select Bottom if you want new pop-up notifiers to be added at the bottom of the pop-up stack. This setting also controls the insertion point for entries in the history buffer and consequently, the Historical Data Viewer window.

Custom Settings: System tab
Use this tab to configure settings for data retention, logging, and sound.

Maintain History
Select this check box if you want to save the contents of the history buffer when you sign out or exit. When you sign in again, saved historical data that falls within the specified expiration limits for notifications can be viewed in the Historical Data Viewer window. Clear this check box (the default) if you do not want the contents of the history buffer to be reloaded when you next sign in.

Log Notifications
Select this check box to save the notification details to text log files that are maintained in your userhome/.netcool/nco_aen_settings/logs directory on UNIX, where userhome represents your home directory. On Windows, these files are stored in userhome\.netcool\nco_aen_settings\logs.
Play Sound
Select this check box to play an audio sound whenever notifications are received. The sound is muted by default if multiple notifications are received in rapid succession. Clear this check box (the default) to stop the sound from playing. Note that you cannot change the sound, and the workstation must have the relevant hardware for playing sounds.

Default Settings
Click this button to restore the default settings.

4. From the Channels tab, specify which of the defined channel columns are shown in the pop-up notifier, and the position of the data.

Figure 31. Properties window: Channels tab

Complete the tab as follows:

Channel list
This list shows all the channels over which you can receive accelerated event notifications. These channels are created by your system administrator, who also grants access rights to channels. From this list, select a channel that you want to configure. The columns configured for the channel, and their position within the pop-up notifier, are shown to the right.

Note: Click-across functionality to the event list or the Active Event List is available only for events in the alerts.status table.

Column data
Each column that is configured for the selected channel is listed here.

Filter
Use these check boxes to construct a dynamic AND logic filter for the event list or Active Event List that is accessible from the pop-up notifier.
and the Historical Data Viewer window. Select the Filter check box for each column on which you want to filter.

**Position in Popup**
Use these fields to reposition column data within the pop-up notifier and the Historical Data Viewer window.

**Default Positions**
Click this button to reset the channel columns to their default position in the pop-up notifier.

5. From the Information tab, view version and build information about the Accelerated Event Notification client.
6. From the About tab, view the name and version of the product, together with copyright and trademark information.
7. Save or cancel your changes as follows:
   - **OK** Click this button to save the property settings and close the window.
   - **Cancel** Click this button to close the window without saving your changes.

**Related concepts:**
“About pop-up notifiers” on page 123

**Related tasks:**
“Viewing historical information for accelerated events”

---

**Viewing historical information for accelerated events**

Inbound notifications for accelerated events are maintained within a history buffer. You can view this information within the Historical Data Viewer window, and access further details about these events from the desktop event list or the Web GUI Active Event List.

If national language characters are not displayed in the Historical Data Viewer window, you need to change the font setting.

To view historical information about accelerated events:
1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>Right-click over the floating notifier panel, and click History from the pop-up menu.</td>
</tr>
<tr>
<td>Windows</td>
<td>From the Windows system tray, right-click over the Connected icon or the You have Messages icon, and click History from the pop-up menu.</td>
</tr>
</tbody>
</table>

The Historical Data Viewer window opens.

Within this window, summary information for each accelerated event is shown on separate lines, and the total number of entries is shown at the bottom of the window. The summary information is collated from the data displayed in the pop-up notifier for each event. The format for each line is as follows:

`@ receipt_time summary_information`

where:

- `@` is color-coded to depict the severity of the event. If the Severity column is not part of the channel definition or there is no valid color mapping, the `@` symbol appears in black text on a white background.
- receipt_time is the date and time when the notification was received by the Accelerated Event Notification client.
- summary_information contains column data that is configured to appear in pop-up notifiers. This information is shown in a concatenated format.

2. Double-click any line entry to view the event in the event list or the Active Event List. You can also use the up and down arrow keys to move through the list of entries in the Historical Data Viewer window and then press Enter to view the event in the relevant event list. Note that you cannot select multiple entries in the Historical Data Viewer window.

3. To delete the entries in the Historical Data Viewer window, click Clear History. When asked if you want to reset the history, click Yes to remove all the entries from the window. You are then asked whether you want to reset pop-ups. Click Yes to close all pop-up notifiers, or No to leave them open.

4. To close the Historical Data Viewer window, click Close. Alternatively, press Esc.

Related tasks:
- “Configuring property settings for the Accelerated Event Notification client” on page 124

---

**Saving accelerated event notification details to log files**

You can choose to save details of the accelerated event notifications that you receive, to log files.

To save notification details to file:

1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>Right-click over the floating notifier panel and click Properties from the pop-up menu.</td>
</tr>
<tr>
<td>Windows</td>
<td>From the Windows system tray, right-click over the icon depicting the connection state, and click Properties from the pop-up menu.</td>
</tr>
</tbody>
</table>

The Accelerated Event Notifier Properties window opens.

2. From the Messages tab, go to the Custom Settings area, and click the System tab.

3. Select the Log notifications check box and then click OK to save and close the Properties window.

**Results**

Notification details are stored in text format in the following locations:
- UNIX: userhome/.netcool/nco_aen_settings/logs
- Windows: userhome\netcool\nco_aen_settings\logs

The variable userhome represents your home directory. You cannot change the location of these log files.

A rolling log mechanism is used, with a name format of notification_x.log, where x is the log file number, which has a maximum value of 31. You can change this number by using the system.history.log.count property.
You can also change the default log file size by using the `system.history.log.size` property. You can change these properties in the following file:

- UNIX: `userhome/.netcool/nco_aen_settings/aen.properties`
- Windows: `userhome\netcool\nco_aen_settings\aen.properties`

The variable `userhome` represents your home directory.

---

**Accelerated event notification message logging**

The Accelerated Event Notification client logs its internal messages to disk.

This information is stored in a rolling log with a root file name of `nco_aen_system.log` within the `NCHOME/omnibus/log` directory.

You can modify the accelerated event notification properties file to configure logging properties. The location of this file is:

- UNIX: `userhome/.netcool/nco_aen_settings/aen.properties`
- Windows: `userhome\netcool\nco_aen_settings\aen.properties`

The variable `userhome` represents your home directory.

The following table describes the logging properties that you can modify.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>message.level</code></td>
<td>Sets the message logging level. The options are SEVERE (the default), WARNING, and INFO.</td>
</tr>
<tr>
<td><code>log.file.max.size</code></td>
<td>Specify the maximum file size before rollover occurs, and the next file is written to. The default size is 10000 bytes.</td>
</tr>
<tr>
<td><code>log.file.max.count</code></td>
<td>Sets the number of rollover files. The default is 4.</td>
</tr>
<tr>
<td><code>log.file.name</code></td>
<td>Specifies the logging file name. The default is <code>nco_aen_system.log</code>.</td>
</tr>
</tbody>
</table>

---

**Signing out of the Accelerated Event Notification client**

You can sign out of the Accelerated Event Notification client if you want to connect to a different ObjectServer, or if you want to temporarily log off the client.

To sign out:

1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>Right-click over the floating notifier panel, and click <strong>Sign Out</strong> from the pop-up menu.</td>
</tr>
<tr>
<td>Windows</td>
<td>From the Windows system tray, right-click over the <strong>Connected</strong> icon or the <strong>You have Messages</strong> icon, and click <strong>Sign Out</strong> from the pop-up menu.</td>
</tr>
</tbody>
</table>

2. When prompted to confirm that you want to sign out from the server, click **Yes**.
Results

You are disconnected from the ObjectServer, and the status of the notifier icon changes to **Not Connected.** All pop-up notifiers are closed and the contents of the Historical Data Viewer window are cleared.

When you sign out, the Accelerated Event Notification client continues to run in the background.

**Related tasks:**

“Signing in to the Accelerated Event Notification client”

---

**Signing in to the Accelerated Event Notification client**

You must sign in to a notification ObjectServer in order to receive accelerated events.

To start the Accelerated Event Notification client:

1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>Right-click over the floating notifier panel, and click <strong>Sign In</strong> from the pop-up menu.</td>
</tr>
<tr>
<td>Windows</td>
<td>Right-click over the <strong>Not Connected</strong> icon in the Windows system tray and click <strong>Sign In</strong> from the pop-up menu.</td>
</tr>
</tbody>
</table>

The Accelerated Event Notifier login window opens.

2. Complete this window as follows:

   **User ID**
   Type your user ID for logging in to the ObjectServer that holds channel definition information, and from which you want to receive accelerated event notifications.

   If you are signing in to the Accelerated Event Notification client (after previously signing out), your previously-specified user ID is displayed. You can type a different user ID if required.

   **Password**
   Type the password for the specified user ID.

   **Log In**
   Click this button to log in to the ObjectServer.

   **Cancel**
   Click this button to cancel the login process and close this window.

**Results**

On successful login, you are connected to the ObjectServer, and the **Connected** icon is shown in the floating notifier panel on UNIX, or in the Windows system tray.

**Related tasks:**

“Signing out of the Accelerated Event Notification client” on page 132
Exiting the Accelerated Event Notification client

You can exit from the Accelerated Event Notification client when you are in any of the three states: Connected, Not Connected, or You have Messages.

To exit the Accelerated Event Notification client:
1. Perform the appropriate action for your operating system:

<table>
<thead>
<tr>
<th>Operating system</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIX</td>
<td>Right-click over the floating notifier panel showing the connection state, and select Exit from the pop-up menu.</td>
</tr>
<tr>
<td>Windows</td>
<td>From the Windows system tray, right-click over the icon depicting the connection state, and select Exit from the pop-up menu.</td>
</tr>
</tbody>
</table>

2. If you are connected to the ObjectServer, you are prompted to confirm that you want to close the connection and exit the Accelerated Event Notification client. If you are currently signed out, you are prompted to confirm that you want to exit the client. In either case, click Yes to confirm.

Results

The Accelerated Event Notification client stops running and you are disconnected from the ObjectServer (if previously connected). All open pop-up notifiers automatically close.
Appendix A. Regular expressions

Tivoli Netcool/OMNIbus supports the use of regular expressions in search queries that you perform on ObjectServer data. Regular expressions are sequences of *atoms* that are made up of normal characters and metacharacters.

An atom is a single character or a pattern of one or more characters in parentheses. Normal characters include uppercase and lowercase letters, and numbers. Metacharacters are non-alphabetic characters that possess special meanings in regular expressions.

Two types of regular expression libraries are available for use with the ObjectServer:
- **NETCOOL**: This library is useful for single-byte character processing.
- **TRE**: This library enables use of the POSIX 1003.2 extended regular expression syntax, and provides support for both single-byte and multi-byte character languages. When the UTF-8 encoding is enabled on Windows, only the characters within Unicode plane 0, the Basic Multilingual Plane (BMP), are supported in regular expression patterns. Any character outside of the BMP, which is found in the pattern, will result in an error. The matching strings for the regular expression pattern can contain any UTF-8 character.

**Note**: Use of the TRE library can lead to a marked decrease in system performance. Optimal system performance is achieved with the NETCOOL library.

You can use the ObjectServer property `RegexpLibrary` to specify which library should be used for regular expression matching. The NETCOOL regular expression library is enabled by default.

**NETCOOL regular expression library**

If your system supports single-byte character languages, you can use the NETCOOL regular expression library to run search queries on your data. The NETCOOL library provides better system performance than the TRE regular expression library.

**Note**: When a regular expression is written in SQL, the SQL parser first processes string literals before passing them to the regular expression library. The SQL parser processes backslash sequences, so single backslashes will not subsequently be seen by the regular expression library. Therefore, when you write a regular expression in SQL, use double backslashes to escape reserved characters.

For example, to escape the parentheses in the string '1_(22)', use this expression: '1\_(22)'.

The NETCOOL regular expression library supports the use of normal characters and metacharacters. The following table describes the set of metacharacters supported by the NETCOOL regular expression library.
Table 19. Metacharacters

<table>
<thead>
<tr>
<th>Metacharacter</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Matches zero or more instances of the preceding atom. Matches as many instances as possible.</td>
<td>goo* matches my godness, my goodness, and my gooodness, but not my gdness.</td>
</tr>
<tr>
<td>+</td>
<td>Matches one or more instances of the preceding atom. Matches as many instances as possible.</td>
<td>goo+ matches my goodness and my goodness, but not my godness.</td>
</tr>
<tr>
<td>?</td>
<td>Matches zero or more instances of the preceding atom.</td>
<td>goo? matches my godness, my goodness, and my gooodness, but not my gdness.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>colour? matches color and colour.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>end?-user matches enduser and end-user.</td>
</tr>
<tr>
<td>$</td>
<td>Matches the end of the string.</td>
<td>end$ matches the end, but not the ending.</td>
</tr>
<tr>
<td>^</td>
<td>Matches the beginning of the string.</td>
<td>^severity matches severity level 5, but not The severity is 5.</td>
</tr>
<tr>
<td>.</td>
<td>Matches any single character.</td>
<td>b.at matches baat, b8at, and b4at, but not bat or b4at.</td>
</tr>
<tr>
<td>[abcd]</td>
<td>Matches any character in the square brackets.</td>
<td>[nN] [00] matches no, n0, No, and NO.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>gr[ae]y matches both spellings of the word ‘grey’; that is, gray and grey.</td>
</tr>
<tr>
<td>[a-d]</td>
<td>Matches any character in the range of characters separated by a hyphen (-).</td>
<td>[0-9] matches any decimal digit.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[ab3-5] matches a, b, 3, 4, and 5.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>^[A-Za-z]+$ matches any string that contains only upper or lowercase characters.</td>
</tr>
<tr>
<td>[^abcd]</td>
<td>Matches any character except those in the square brackets or in the range of characters separated by a hyphen (-).</td>
<td>[^0-9] matches any string that does not contain any numeric characters.</td>
</tr>
<tr>
<td>[^a-d]</td>
<td>Indicates that the characters within the parentheses should be treated as a character pattern.</td>
<td>A(boo)+Z matches AbooZ, AboobooZ, and AbooboooboobooZ, but not AboZ or AbooOZ.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>January? matches Jan and January.</td>
</tr>
<tr>
<td>()</td>
<td>Indicates that the characters within the parentheses should be treated as a character pattern.</td>
<td>A(boo)+Z matches AbooZ, AboobooZ, and AbooboooboobooZ, but not AboZ or AbooOZ.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>January? matches Jan and January.</td>
</tr>
<tr>
<td></td>
<td>Matches one of the atoms on either side of the pipe character.</td>
<td>A(B</td>
</tr>
<tr>
<td>\</td>
<td>Indicates that the metacharacter following should be treated as a regular character. The metacharacters listed in this table require a backslash escape character as a prefix to switch off their special meaning.</td>
<td>\ matches the \ character.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>\ matches the \ character.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>. matches the . character.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>[[^0-9] ] matches an opening square bracket, followed by any digits or spaces, followed by a closed bracket.</td>
</tr>
</tbody>
</table>
TRE regular expression library

Use the TRE regular expression library to run search queries on both single-byte and multi-byte character languages.

The TRE regular expression library supports usage of the POSIX 1003.2 extended regular expression syntax in the form of:

- Metacharacters
- Minimal or non-greedy quantifiers
- Bracket expressions
- Constructs for multicultural support
- Backslash sequences

Restriction: A marked decrease in system performance might be observed when using this library.

Related reference:
“NETCOOL regular expression library” on page 135

Metacharacters

Metacharacters are non-alphabetic characters that possess special meanings in regular expressions.

The set of metacharacters that can be used in extended regular expression syntax is as follows:

* + ? $ ^ . ( ) \ { } [ ]

The following table describes all of these metacharacters except the square bracket [ metacharacter. You can use the [ metacharacter to construct bracket expressions.

Table 20. Metacharacters

<table>
<thead>
<tr>
<th>Metacharacter</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>Matches zero or more instances of the preceding atom. Matches as many instances as possible.</td>
<td>goo* matches my godness, my goodness, and my goodness, but not my gdness.</td>
</tr>
<tr>
<td>+</td>
<td>Matches one or more instances of the preceding atom. Matches as many instances as possible.</td>
<td>goo+ matches my goodness and my goodness, but not my godness.</td>
</tr>
<tr>
<td>?</td>
<td>Matches zero or more instances of the preceding atom.</td>
<td>goo? matches my godness, my goodness, and my goodness, but not my godness.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>colour? matches color and colour.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>end?-user matches enduser and end-user.</td>
</tr>
<tr>
<td>$</td>
<td>Matches the end of the string.</td>
<td>end$ matches the end, but not the ending.</td>
</tr>
<tr>
<td>Metacharacter</td>
<td>Description</td>
<td>Examples</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
<td>----------</td>
</tr>
<tr>
<td>^</td>
<td>Matches the beginning of the string. The ^ metacharacter can also be used in bracket expressions.</td>
<td>^severity matches severity level 5, but not The severity is 5.</td>
</tr>
<tr>
<td>.</td>
<td>Matches any single character.</td>
<td>b.at matches bats, bats, and b4ats, but not bat or bB4ats.</td>
</tr>
<tr>
<td>(</td>
<td>Indicates that the characters within the parentheses should be treated as a character pattern.</td>
<td>A(boo)+Z matches AbooZ, AboobooZ, and AboobooobooZ, but not AboZ or AboooZ.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>[</td>
<td>Matches one of the atoms on either side of the pipe character.</td>
<td>A(B</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>\</td>
<td>Indicates that the metacharacter following should be treated as a regular character. The metacharacters listed in this section require a backslash escape character as a prefix to switch off their special meaning. The \ metacharacter can also be used to construct backslash sequences.</td>
<td>* matches the * character.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>{m, n}</td>
<td>Matches from m to n instances of the preceding atom, where m is the minimum and n is the maximum. Matches as many instances as possible. Note: m and n are unsigned decimal integers between 0 and 255.</td>
<td>f{1,2}ord matches for and fford.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>{m,}</td>
<td>Matches m or more instances of the preceding atom.</td>
<td>Z{2,} matches two or more repititions of Z.</td>
</tr>
<tr>
<td>{m}</td>
<td>Matches exactly m instances of the preceding atom.</td>
<td>a{3} matches aaa.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1{2} matches 11.</td>
</tr>
</tbody>
</table>

Related reference:
- "Bracket expressions" on page 140
- "Backslash sequences" on page 141
Minimal or non-greedy quantifiers

Regular expressions are generally considered greedy because an expression with repetitions will attempt to match as many characters as possible. The asterisk (*), plus (+), question mark (?), and curly braces ({})) metacharacters exhibit 'repetitious' behavior, and attempt to match as many instances as possible.

To make a subexpression match as few characters as possible, a question mark (?) can be appended to these metacharacters to make them minimal or non-greedy. The following table describes the non-greedy quantifiers.

<table>
<thead>
<tr>
<th>Quantifier</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
</table>
| *?         | Matches zero or more instances of the preceding atom. Matches as few instances as possible. | Given an input string of Netcool Tool Library:  
• The first group in ^(.*1).*$ matches Netcool Tool.  
• The first group in ^(.*?1).*$ matches Netcool. |
| +?         | Matches one or more instances of the preceding atom. Matches as few instances as possible. | Given an input string of little:  
• .*?1 matches l.  
• ^.*?1 matches littl. |
| ??         | Matches zero or one instance of the preceding atom. Matches as few instances as possible. | .??b matches ab in abc, and b in bbb.  
.?? matches ab in abc, and bb in bbb. |
| {m ,n} ?   | Matches from m to n instances of the preceding atom, where m is the minimum and n is the maximum. Matches as few instances as possible.  
**Note:** m and n are unsigned decimal integers between 0 and 255. | Given an input string of Netcool Tool Cool Fool Library:  
• ^((.*?ool)*)+.*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool)+).*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool)+?).*$ matches Netcool.  
• ^((.*?ool){2,5}).*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool){2,5}?).*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool){2,5}) [FL].*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool){2,5}?) [FL].*$ matches Netcool Tool Cool Fool. |
| {m ,} ?    | Matches m or more instances of the preceding atom. Matches as few instances as possible. | Given an input string of Netcool Tool Cool Fool Library:  
• ^((.*?ool){2,}).*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool){2,}?).*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool){2,}) [FL].*$ matches Netcool Tool Cool Fool.  
• ^((.*?ool){2,}?) [FL].*$ matches Netcool Tool Cool Fool. |
Bracket expressions

Bracket expressions can be used to match a single character or collating element.

The following table describes how to use bracket expressions.

Table 22. Bracket expressions

<table>
<thead>
<tr>
<th>Expression</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>[abcd]</td>
<td>Matches any character in the square brackets.</td>
<td>[nN][oO] matches no, n0, No, and N0. gr[ae]y matches both spellings of the word 'grey'; that is, gray and grey.</td>
</tr>
<tr>
<td>[a-d]</td>
<td>Matches any character in the range of characters separated by a hyphen (-).</td>
<td>[0-9] matches any decimal digit. [ab3-5] matches a, b, 3, 4, and 5. [0-9]{4} matches any four-digit string. ^[A-Za-z]+$ matches any string that contains only upper or lowercase characters. ([[0-9 ]*) matches an opening square bracket, followed by any digits or spaces, followed by a closed bracket.</td>
</tr>
<tr>
<td>^[abcd]</td>
<td>Matches any character except those in the square brackets or in the range of characters separated by a hyphen (-).</td>
<td>^0-9 matches any string that does not contain any numeric characters.</td>
</tr>
<tr>
<td>^[a-d]</td>
<td>Matches a multi-character collating element.</td>
<td>[.ch.] matches the multi-character collating sequence ch (if the current language supports that collating sequence).</td>
</tr>
<tr>
<td>[.ab.]</td>
<td>Matches all collating elements with the same primary sort order as that element, including the element itself.</td>
<td>[.e=] matches e and all the variants of e in the current locale.</td>
</tr>
</tbody>
</table>

Note the following points:

- The caret character (^) only has a special meaning when included as the first character after the open bracket ([). Otherwise, it is treated as a normal character.
- The hyphen character (-) is treated as a normal character only under either of the following conditions:
  - The hyphen character is the first or last character within the square brackets, for example, [ab-] or [-xy].
  - The hyphen character is the only (both first and last) character; that is, [-].
- To match a closing square bracket within a bracketed expression, the closing bracket must be the first character within the enclosing brackets; for example, [ ] [xy] matches ], [, x, and y.
- Other metacharacters are treated as normal characters within square brackets, and do not need to be escaped; for example, [ca$] will match c, a, or $.
Related reference:
“Metacharacters” on page 137

Constructs for multicultural support
The sort order of characters (and any of their variants) is locale-dependent, so different regular expressions are generally required to match characters of the same class, in different locales. To facilitate multicultural support, a set of predefined names enclosed in [: and :]] can be used to represent characters of the same class.

The set of valid names depends on the value of the LC_CTYPE environment variable of the current locale, but the names shown in the following table are valid in all locales.

Table 23. Multicultural constructs

<table>
<thead>
<tr>
<th>Construct</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[:alnum:]</td>
<td>Matches any alphanumeric character.</td>
</tr>
<tr>
<td>[:alpha:]</td>
<td>Matches any alphabetic character.</td>
</tr>
<tr>
<td>[:blank:]</td>
<td>Matches any blank character - that is, space and TAB.</td>
</tr>
<tr>
<td>[:cntrl:]</td>
<td>Matches any control characters; these are non-printable.</td>
</tr>
<tr>
<td>[:digit:]</td>
<td>Matches any decimal digits.</td>
</tr>
<tr>
<td>[:graph:]</td>
<td>Matches any printable character except space.</td>
</tr>
<tr>
<td>[:lower:]</td>
<td>Matches any lowercase alphabetic character.</td>
</tr>
<tr>
<td>[:print:]</td>
<td>Matches any printable character including space.</td>
</tr>
<tr>
<td>[:punct:]</td>
<td>Matches any printable character that is not a space or alphanumeric; that is, punctuation.</td>
</tr>
<tr>
<td>[:space:]</td>
<td>Matches any whitespace character.</td>
</tr>
<tr>
<td>[:upper:]</td>
<td>Matches any uppercase alphabetic character.</td>
</tr>
<tr>
<td>[:xdigit:]</td>
<td>Matches any hexadecimal digit.</td>
</tr>
</tbody>
</table>

Example: Multicultural constructs

[[:lower:]AB] matches the lowercase letters and uppercase A and B.

[[:space:][:alpha:]] matches any character that is either whitespace or alphabetic.

[[:alpha:]] matches to [A-Za-z] in the English locale (en), but would include accented or additional letters in another locale.

Backslash sequences
When constructing regular expressions, the backslash character can be used in a variety of ways.

The backslash character (\) can be used to:
• Turn off the special meaning of metacharacters so they can be treated as normal characters.
• Include non-printable characters in a regular expression.
• Give special meaning to some normal characters.
• Specify backreferences. Backreferences are used to specify that an earlier matching subexpression is matched again later.
Note: The backslash character cannot be the last character in a regular expression.

When a regular expression is written in SQL, the SQL parser first processes string literals before passing them to the regular expression library. The SQL parser processes backslash sequences, so single backslashes will not subsequently be seen by the regular expression library. Therefore, when you write a regular expression in SQL, use double backslashes to escape reserved characters.

For example, to escape the parentheses in the string '1_(22)', use this expression: '1_\(22\)'.

The following table describes how to specify backslash sequences for non-printable characters and backreferences. This table also shows how to use backslash sequences to apply special meaning to some normal characters.

Table 24. Backslash sequences

<table>
<thead>
<tr>
<th>Backslash sequence</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\a</td>
<td>Matches the bell character (ASCII code 7).</td>
</tr>
<tr>
<td>\e</td>
<td>Matches the escape character (ASCII code 27).</td>
</tr>
<tr>
<td>\f</td>
<td>Matches the form-feed character (ASCII code 12).</td>
</tr>
<tr>
<td>\n</td>
<td>Matches the new-line or line-feed character (ASCII code 10).</td>
</tr>
<tr>
<td>\r</td>
<td>Matches the carriage return character (ASCII code 13).</td>
</tr>
<tr>
<td>\t</td>
<td>Matches the horizontal tab character (ASCII code 9).</td>
</tr>
<tr>
<td>\v</td>
<td>Matches the vertical tab character.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Matches the beginning of a word, or the beginning of an identifier, defined as the boundary between non-alphanumerics and alphanumerics (including underscore). This matches no characters, only the context.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Matches the end of a word or identifier.</td>
</tr>
<tr>
<td>\b</td>
<td>Matches a word boundary; that is, matches the empty string at the beginning or end of an alphanumeric sequence. Enables a 'whole words only' search.</td>
</tr>
<tr>
<td>\B</td>
<td>Matches a non-word boundary; that is, matches the empty string not at the beginning or end of a word.</td>
</tr>
<tr>
<td>\d</td>
<td>Matches any decimal digit. Equivalent to [0-9] and [[:digit:]].</td>
</tr>
<tr>
<td>\D</td>
<td>Matches any non-digit character. Equivalent to [^0-9] or [^[:digit:]].</td>
</tr>
<tr>
<td>\s</td>
<td>Matches any whitespace character. Equivalent to [ \t\n\r\f\v] or [[:space:]].</td>
</tr>
<tr>
<td>\S</td>
<td>Matches any non-whitespace character. Equivalent to [^ \t\n\r\f\v] or [^[:space:]].</td>
</tr>
<tr>
<td>\w</td>
<td>Matches a word character; that is, any alphanumeric character or underscore. Equivalent to [a-zA-Z0-9_] or [[:alnum:]].</td>
</tr>
</tbody>
</table>
Table 24. Backslash sequences (continued)

<table>
<thead>
<tr>
<th>Backslash sequence</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>\W</td>
<td>Matches any non-alphanumeric character. Equivalent to [^a-zA-Z0-9_] or [^[:alnum:][:_]].</td>
</tr>
<tr>
<td>[1-9]</td>
<td>A backslash followed by a single non-zero decimal digit n is termed a backreference. Matches the same set of characters matched by the nth parenthesized subexpression.</td>
</tr>
</tbody>
</table>

Example backslash constructs

`\bcat\b` matches `cat` but not `cats` or `bobcat`.

`\d\s` matches a digit followed by a whitespace character.

`[^d\s]` matches any digit or whitespace character.

`.([XY]).([XY])` matches `aXbXc` and `aYbYc`, but also `aXbYc` and `aYbXc`. However, `.([XY]).\1` will only match `aXbXc` and `aYbYc`.

Related reference:

"Metacharacters" on page 137
Appendix B. SQL commands, variable expressions, and helper buttons in tools, automations, and transient event lists

You can use a number of SQL commands, variable expressions, and helper buttons to retrieve information from a running event list, the current event, or the operating system environment. You can use these expressions when creating a tool, trigger, or SQL procedure, or in parameters passed to a transient event list.

The following table lists the SQL commands, variable expressions, and helper buttons.

Table 25. SQL commands, variable expressions, and helper buttons in tools, triggers, procedures, and the transient event list

<table>
<thead>
<tr>
<th>Command/variable expression</th>
<th>Button</th>
<th>Usage</th>
</tr>
</thead>
</table>
| select_command              | ![button](image) | Click this button to select an SQL command from the pop-up menu. Based on the command that you select, complete the resulting window as follows:
  - **Select**: Select the database and table on which to run the SELECT command. Then, choose the table columns to select.
  - **Insert**: Select the database and table on which to run the INSERT command. Then, select the table columns in which to insert values. For each selected column, enter the value to insert. For insert statements, you must include the primary key. Primary keys are indicated with an asterisk (*).
  - **Update**: Select the database and table on which to run the UPDATE command. Then, select the table columns to update. For each selected column, enter the new value. For update statements, you must exclude the primary key. Primary keys are indicated with an asterisk (*).
  - **Delete**: Select the table to delete.
  - **Use**: Select the database to use.
  - **Service**: Select a service name and a value. Values can be Good, Marginal, or Bad.

| insert_command              | ![button](image) | Click this button to select the database and table on which to run the INSERT command. Then, select the table columns in which to insert values. For each selected column, enter the value to insert. For insert statements, you must include the primary key. Primary keys are indicated with an asterisk (*).

| update_command              | ![button](image) | Click this button to select the database and table on which to run the UPDATE command. Then, select the table columns to update. For each selected column, enter the new value. For update statements, you must exclude the primary key. Primary keys are indicated with an asterisk (*).

| delete_command              | ![button](image) | Click this button to select the table to delete.

| use_command                 | ![button](image) | Click this button to select the database to use.

| service_command             | ![button](image) | Click this button to select a service name and a value. Values can be Good, Marginal, or Bad.

| column_name                 | ![button](image) | Click this button to select a table column name to add to the command. The column name is substituted for the corresponding event list row value when the tool runs.

When prefaced with the @ symbol, the column name is substituted with the corresponding event list row value during execution. This can be used in an SQL query or restriction filter, such as: `RemoteNodeAlias = '0LocalNodeAlias'

| conversion_name             | ![button](image) | Click this button to select from a list of available conversions.

| N/A                         | ![button](image) | Click this button to bring up a list of keywords that complete the entered SQL.

| N/A                         | ![button](image) | Click this button to check the validity of the entered SQL syntax.
### Table 25. SQL commands, variable expressions, and helper buttons in tools, triggers, procedures, and the transient event list (continued)

<table>
<thead>
<tr>
<th>Command/variable expression</th>
<th>Button</th>
<th>Usage</th>
</tr>
</thead>
</table>
| %internal_value             |        | Click this button to select from a list of internal values known to the current instance of the event list. For example, to run the transient event list and specify the ObjectServer to connect to using the `-server` command-line option, specify: `-server '%server'`

The following internal values are available for tools and as a parameter to the transient event list:

- **%display**: The current display running the application (UNIX only).
- **%password**: The password of the user running the application.
- **%encrypted_password**: The encrypted password of the user running the application (UNIX only). In FIPS 140-2 mode, the password is passed as plain text when used in tools, but is hidden when specified as a parameter from the command line.
- **%server**: The name of the ObjectServer to which the tool is currently connected.
- **%desktopserver**: The name of the desktop ObjectServer to which the tool is currently connected.
- **%uid**: The ObjectServer user identifier of the user running the application.
- **%username**: The ObjectServer user name of the user running the application.

The following internal value is available for procedures and triggers:

- **%user**: Used to specify user variables and access information about connected users.

The following internal value is available for triggers only:

- **%trigger**: Used to specify trigger variables and access information about the current and previous executions of triggers.

The following internal value is additionally available for signal triggers only:

- **%signal**: Used to specify signal variables and access information about signals raised.

| $prompt. prompt_name       |        | Click this button to select the name of the prompt to use when querying the user. For example, to run the transient event list and prompt the user to enter their password using the Password prompt, specify: `-password $prompt.Password`

You can use prompts in tools and as a parameter to the transient event list.

| $selected_rows. column_name | N/A | List of values of `column_name` for all selected alerts. For example:

```sql
update alerts.status set TaskList = 0 where Serial in ($selected_rows.serial)
```

Do not use this syntax if you select the **Execute for each selected row** check box. Instead, select the check box if the change is different for each alert.
### Table 25. SQL commands, variable expressions, and helper buttons in tools, triggers, procedures, and the transient event list (continued)

<table>
<thead>
<tr>
<th>Command/variable expression</th>
<th>Button</th>
<th>Usage</th>
</tr>
</thead>
</table>
| $(environment_variable)     | N/A    | Indicates an environment variable. For example, when you run a transient event list, you can specify the filter file by using the -elf command-line option, such as: 

```
-elf "$(NCHOME)/omnibus/ini/tool.elf
```

To run the tool on Windows, enclose the environment variable, such as $(NCHOME), in double quotation marks. If there is a space in the path name, it will not be interpreted correctly. |

**Tip:**
- When typing SQL commands within the Tivoli Netcool/OMNibus SQL editor panels, you can type one or more characters and then press Ctrl+F1 to obtain a dialog box with a list of keywords that might match your entry. Select the required keyword and click **OK** to complete your entry. If only one keyword matches your typed characters, the keyword is automatically completed for you. If you press Ctrl+F1 after typing a database-related keyword, the dialog box provides a list of possible ObjectServer databases from which you can select. If you press Ctrl+F1 after typing a database name followed by a dot (for example: alerts.), you can press Ctrl+F1 again to view and select from a list of tables in the database.

- You can click the **To Clipboard** button to copy the command in a text format to the clipboard.
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.
Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Corporation
958/NH04
IBM Centre, St Leonards
601 Pacific Hwy
St Leonards, NSW, 2069
Australia

IBM Corporation
896471/H128B
76 Upper Ground
London SE1 9PZ
United Kingdom

IBM Corporation
JBF1/SOM1
294 Route 100
Somers, NY, 10589-0100
United States of America

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.
COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these programs.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.

Trademarks

AIX, IBM, the IBM logo, ibm.com®, Netcool, System z, and Tivoli® are trademarks or registered trademarks of International Business Machines Corporation in the United States, other countries, or both.

Adobe, Acrobat, Portable Document Format (PDF), PostScript, and all Adobe-based trademarks are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States, other countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other company, product, or service names may be trademarks or service marks of others.
Index

A
absolute time comparisons 86
accelerated event notification
channels 121
overview 121
Accelerated Event Notification client
configuring property settings 124
exiting 134
historical information 130
pop-up notifiers 123
saving details to log files 131
signing in 133
signing out 132
starting 121
states 122
viewing historical information 130
accessibility vii
accessing
online help 14, 16
acknowledging
events 40
adding
events to task list 45
files to personal library 107
AlertSecurityModel property 29
arch
operating system directory viii
assigning ownership
events 42
atoms
description 135
audience v
backslash sequences
regular expressions 141
best practices
filters 76
bracket expressions
regular expressions 140
button bar 5
changing
event list date format 119
passwords 9
changing severity
events 40
closing
event lists 54
command-line options
transient event lists 66, 68
UNIX event lists 20
Windows Conductor 4
Windows event lists 22
comparison values
filters 84
components
filters 74
condition elements
filters 74
Conductor
description 5, 8
functions 3
global preferences 10, 12
menu 8
overview 1
starting 3
stopping 17
UNIX 5
Windows 8
Windows command-line options 4
configuring
Accelerated Event Notification
client 124
properties 111, 116
server communication
information 113, 116
settings 116
configuring font sizes
event list 37
conventions, typeface viii
copying data
event lists 50
creating
event list configurations 57, 59
filters 78, 81
symbolic links 107
views 96, 100
event lists
"in maintenance" events 42
acknowledging events 40
adding events to task list 45
assigning ownership to events 42
changing filter 50
changing severity of events 40
depicting severity 36
deselecting events 39
displaying event information 44
displaying severity colors 38
distribution summary bar 27
event list
font sizes 37
event list configurations
creating 57, 59
local 54, 55
opening 55, 56
opening on startup 109
remote 56, 57
saving 54, 57
de-escalating
events 41
de-escalating events 41
deacknowledging events 40
deleting events 44
de-acknowledging events 40
depicting severity 36
deselecting events 39
displaying event information 44
displaying severity colors 38
distribution summary bar 27
event list
font sizes 37
date format
changing in event list 119
de-escalating
events 41
deacknowledging
events 40
deleting
events 44
deselecting
events 39
desktop tools
accessing 3
overview 1
directory browser 106
displaying
event information 44
severity colors 38
distribution summary bar 27
drag and drop
filters 90
views 103
editing
filters 78, 81
properties files 111, 116
views 96, 100
education
see Tivoli technical training viii
ELC files 105
ELF files 105
ELV files 105
environment variables, notation viii
escalating
events 41
event list
font sizes 37
event list configurations
creating 57, 59
local 54, 55
opening 55, 56
opening on startup 109
remote 56, 57
saving 54, 57
educating
see Tivoli technical training viii
ELC files 105
ELF files 105
ELV files 105
environment variables, notation viii
escalating
events 41
event lists (continued)
  restricting rows displayed 46
  resynchronizing 53
  searching for text 47
  security 29
  selecting events 39
  service alerts 62
  service-affected events 63
  severity by text color 36
  severity colors 38
  severity filtering 49
  severity levels 29
  sorting columns 35
  sorting data 35
  starting 19
  starting transient 66
  suppressing events 41
  Telnet tool 52
  tools 51
  transient 66
  UNIX command-line options 20
  UNIX preferences 30
  viewing related events 45
  viewing services 62
  viewing updates 49
  Windows command-line options 22
  Windows preferences 32

events
  "in maintenance" 42
  acknowledging 40
  adding to task list 45
  assigning ownership 42
  changing severity 40
  de-escalating 41
  deacknowledging 40
  deleting 44
  deseleting 39
  escalating 41
  filtering by severity 49
  hiding 42
  journals 46
  maintaining journals 46
  ownership 42
  prioritizing 40
  quick filtering 48
  related 45
  resolving 43
  selecting 39
  suppressing 41
  examples
    filters 92
  exiting
    Accelerated Event Notification client 134

F
  files
    ELC 105
    ELF 105
    ELV 105
    removing from personal library 108
  Filter Builder
    overview 2, 76
    starting 76
    filtering
      events 48, 49

filters
  absolute time comparisons 86
  best practices 76
  comparison values 84
  components 74
  condition elements 74
  creating 78, 81
  description 73
  drag and drop 90
  editing 78, 81
  examples 92
  In and Not In operators 89
  integer values 85
  logical elements 75
  metrics 75
  opening 90
  operators 88
  overview 73
  relative time comparisons 87, 88
  string values 84
  subquery elements 75
  time values 86
  freezing
    event lists 54
    events 43

events
  in maintenance" 42
  acknowledging 40
  adding to task list 45
  assigning ownership 42
  changing severity 40
  de-escalating 41
  deacknowledging 40
  deleting 44
  deseleting 39
  escalating 41
  filtering by severity 49
  hiding 42
  journals 46
  maintaining journals 46
  ownership 42
  prioritizing 40
  quick filtering 48
  related 45
  resolving 43
  selecting 39
  suppressing 41
  examples
    filters 92
  exiting
    Accelerated Event Notification client 134

G
  global preferences
    setting 10, 12

H
  helper buttons 145
  hiding
    events 42
  historical information
    Accelerated Event Notification client 130

I
  IBM Eclipse Help System (IEHS) 14, 16
  IEHS
    shutting down server 14, 16
  IEHS (IBM Eclipse Help System) 14, 16
  In and Not In operators 89
  integer values
    14, 16
    filters 85
  Internet service monitors 62

J
  journals
    maintaining 46
  Jump to Top 49

K
  local system directories
    viewing 106
  log files
    Accelerated Event Notification client 131

L
  logical elements
    filters 75

M
  manuals vi
  message logs
    Accelerated Event Notification client 132
  metacharacters
    regular expressions 137
  metrics
    filters 75
  minimal quantifiers
    regular expressions 139
  monitor box
    overview 25
  monitor box window 23
  monitoring
    TADDM events 65
  multicultural constructs
    regular expressions 141
    multicultural support 2

N
  NETCOOL regular expression library 135
  non-greedy quantifiers
    regular expressions 139

O
  ObjectServer properties
    AlertSecurityModel property 29
  online help
    accessing 14, 16
    configuring 14, 16
    information center mode 14, 16
    standalone mode 14, 16
  online publications vi
  opening
    event list configurations 55, 56
    filters 90
    views 103
  operating system directory
    arch viii
  operators
    filters 88
    In and Not In 89
  ordering publications vi
  ownership
    events 42

P
  passwords
    changing 9
  personal library
    adding files 107
    backup files 109
    creating symbolic links 107
    hidden files 109
    overview 5, 105
    prefs icon 105
Index
155