cl_ezupdate command

Purpose

Manages PowerHA® SystemMirror® and AIX® software updates across the entire cluster, often without interrupting workloads that are currently running.

Syntax

cl_ezupdate [-v] -h
cl_ezupdate [-v] -Q {cluster|node|nim|lpp} [-N <node1,node2,...>]
cl_ezupdate [-v] {-Q {lpp|all} |-A|-R} 
[-U -N <node1:"hdisk1 hdisk2 hdisk3",node2:hdisk2,...>]
cl_ezupdate [-v] {-Q {lpp|all} |-A|-R} 
[-U -N <node1:"hdisk1 hdisk2 hdisk3",node2:hdisk2,...>]
cl_ezupdate [-v] {-Q {lpp|all} |-A|-R} 
[-U <Multiple –N instances, each giving a “node:hdisk” pair> ...>]
 –s <repository> [-F]

Description

You can use the cl_ezupdate command to query information about the current cluster configuration and available software updates such as AIX and PowerHA SystemMirror service packs, interim fixes, and technology levels. You can also use the cl_ezupdate command to preview the installation of updates and to apply or reject updates.

To use the cl_ezupdate tool, each node must have access to updates that you want to install. The updates can be located on a Network Installation Management (NIM) server or in a shared file system.

The cl_ezupdate tool provides an automatic comparison of the available updates on each of the nodes. If using NIM, all nodes must be configured to access the same lpp_source resource and contents. If the repository is a local file system directory, the local node is the reference node. The cl_ezupdate tool provides an automatic copy of the local file system when the file system does not exist or is empty on any of the nodes.

If you run the cl_ezupdate tool and if an error occurs in a node during an installation or uninstallation process, you can use the rollback feature of the cl_ezupdate tool to return the node to the previous state. When you use the rollback feature, you can choose to roll back only the node that encountered the error or roll back all nodes that were updated.

The rollback process creates a copy of the rootvg volume group on each node by using the alt_disk_copy command and reboots the copy of the rootvg volume group when an error occurs during the installation or removal of service images. For the rollback process, one hdisk must be present on each node that can contain a copy of the rootvg volume group.

Flags

-A
Applies the updates that are available in the location that is specified by the –S flag.
-C
Commits software updates to the latest installed version of PowerHA SystemMirror or the AIX operating system.
-F
Forces installation of the service pack. If an interim fix has locked a fileset and if the updates are halted from installation, this flag removes the lock and installs the service pack.
Note: This flag must always be used with the –A flag.
-H
Displays the help information for the cl_ezupdate command.
-Q
Queries the status of the Network Installation Management (NIM) setup, cluster software, or available updates. The value option is cluster, node, nim, or lpp.
-N
Specifies the node names where you want to install updates. If you specify multiple node names, you must separate each node name with a comma. By default, updates are installed on all nodes in a cluster. If the -U or -u flag is specified to enable the rollback feature, the -N flag specifies a <node name>:hdisk pair. If a node has multiple hdisks for rootvg volume group, multiple –N arguments are required to map the node to each of the hdisks. An example follows:
-N node1:hdisk1 –N node1:hdisk2 –N node1:hdisk3 –N node2:hdisk1
-P
Runs the cluster installation in preview mode. When you use preview mode, all of the installation prerequisites are checked, but updates are not installed on the system.
-R
Rejects non-committed service pack that is installed and stored in the location that is specified by the -S flag.
-S
Specifies location of the update image that are to be installed. If you specify a file system name, the path must begin with a Forward Slash key (/). If you do not specify a Forward Slash key (/), the lpp_source location of the NIM server will be used for installing updates.
-V
Displays extended help information.
-I
Specifies an interactive mode. If you specify the value as yes, you must specify whether the rollback feature must continue to run when an error is shown. The interactive mode is active by default. If you specify the value as no, the interactive mode is turned off and you are not prompted before you start the rollback operation.
-U
Enables rollback of all modified nodes when an error occurs during an Apply or Reject operation.
-u
Enables rollback of only the node that encountered an error during an Apply or Reject operation.
start of change-Xend of change
start of changeExits after creating a copy of rootvg volume group by using the alt_disk_copy command on each node. You must use the -x argument to use the alternative copies of rootvg volume group for rollback operation on subsequent runs.end of change
-x
Specifies not to create the copy of rootvg volume group by using the alt_disk_copy command on each node for rollback operation. If the rootvg volume group fails, you can use disks that are specified in the -N argument for the rollback operation.
-T
Specifies the timeout value for the backup operation of the rootvg volume group in minutes. If the rootvg volume group was not copied before the specified timeout value, the operation exits. The default value of this flag is infinite.

Output File

Output from the cl_ezupdate command is captured in the /var/hacmp/EZUpdate/EZUpdate.log file.

Examples

  1. To display information about the NIM server, enter the following command:
    cl_ezupdate -Q nim
  2. To check and display contents of updates that are available, enter the following command:
    cl_ezupdate -Q lpp -S /tmp/lppsource/inst.images
  3. To install an update in an apply mode, enter the following command:
    cl_ezupdate -A -S HA_v720_SP1
  4. To force an installation of PowerHA SystemMirror or AIX updates that are located on a NIM server and the affected filesets are locked by an interim fix, enter the following command:
    cl_ezupdate –A –F –S HA_v720_SP1
  5. To install an update on all nodes of a three-node cluster that is on a NIM server in apply mode with the rollback feature enabled, so that all nodes that are altered are rolled back to the previous rootvg state, enter the following command:
    cl_ezupdate -A -U Multiple –N arguments are given,node2:hdisk5,node3:hdisk2 -S HA_v720_SP1
  6. To install an update on all nodes of a three-node cluster that is on a NIM server in apply mode with the rollback feature enabled, so that all nodes that are altered are rolled back to the previous rootvg state and if an error occurs during the installation process, roll back the error node without prompting the user, enter the following command:
    cl_ezupdate -A –X No –U  -N node1:hdisk3,node2:hdisk5,node3:hdisk2 -S HA_v720_SP1