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Preface

IBM Tivoli Storage Productivity Center is a suite of storage infrastructure
management software that can centralize, automate, and simplify the management
of complex and heterogeneous storage environments. IBM Tivoli Storage
Productivity Center can help to improve storage capacity utilization and
administrative efficiency. It is an agile storage infrastructure that can respond to on
demand storage needs.

Who should read this guide
This publication is intended for administrators or users who are using IBM®

Tivoli® Storage Productivity Center and IBM Tivoli Provisioning Manager (or
alternatively IBM Tivoli Intelligent Orchestrator). It presents the use of storage
provisioning workflows. To perform the tasks described here, you may need to
refer to the user guides for IBM Tivoli Storage Productivity Center and IBM Tivoli
Provisioning Manager. See “Publications” for the installation manual titles and
order numbers.

What this guide contains
This guide contains the following chapters:
v Chapter 1, “Introduction,” on page 1

Introduces workflows and the entities involved in the provisioning process.
v Chapter 2, “Installing and configuring Tivoli Storage Productivity Center storage

workflows,” on page 3
Describes a sample installation.

v Chapter 3, “Automating storage provisioning with IBM Tivoli Storage
Productivity Center workflows,” on page 9
Describes how to use the storage provisioning workflows with the graphical
user interface.

v Chapter 4, “IBM Tivoli Storage Productivity Center workflows as building
blocks,” on page 15
This chapter gives development information and lists workflows and
sub-workflows by type.

v Chapter 5, “Workflow scenario,” on page 21
A scenario is provided to walk you through the process of using workflows with
the graphical user interface.

v Chapter 6, “Troubleshooting,” on page 25
Lists log file names and describes common problems.

Publications
This section lists publications in the IBM Tivoli Storage Productivity Center library
and other related publications. It also describes how to access publications online,
how to order publications, and how to submit comments on publications.

© Copyright IBM Corp. 2009 v



IBM Tivoli Storage Productivity Center publications
The following table lists IBM Tivoli Storage Productivity Center publications.

Publication Title Order Number

IBM Tivoli Storage Productivity Center Installation and Configuration
Guide

GC32-1774

IBM Tivoli Storage Productivity Center User’s Guide GC32-1775

IBM Tivoli Storage Productivity Center Messages GC32-1776

IBM Tivoli Storage Productivity Center Command-line Interface Reference GC32-1777

IBM Tivoli Storage Productivity Center Problem Determination Guide GC32-1778

IBM Tivoli Provisioning Manager publications
The following table lists IBM Tivoli Provisioning Manager publications.

Publication Title Order Number

Tivoli Provisioning Manager Release Notes GI11-4706

Tivoli Provisioning Manager Installation Guide for Windows GC32-1654

Tivoli Provisioning Manager Installation Guide for Linux GC32-1655

Tivoli Provisioning Manager Installation Guide for AIX GC32-1656

Tivoli Provisioning Manager Installation Guide for Solaris GC32-1666

Tivoli Provisioning Manager Migration Guide for Windows GC32-1657

Tivoli Provisioning Manager Migration Guide for Linux GC32-1658

Tivoli Provisioning Manager Migration Guide for Unix GC32-1659

Tivoli Provisioning Manager Problem Determination and Troubleshooting
Guide

GC32-1660

IBM Tivoli Intelligent Orchestrator publications
The following table lists IBM Tivoli Intelligent Orchestrator publications:

Publication Title Order Number

Tivoli Intelligent Orchestrator Problem Determination and Troubleshooting
Guide

GC32-1650

IBM International Technical Support Center publications
(Redbooks and Redpapers)

The International Technical Support Center (ITSC) publishes Redbooks® and
Redpapers, which provide information on specialized topics. You can order
publications through your IBM representative or the IBM branch office serving
your locality. You can also search for and order books of interest to you by visiting
the IBM Redbooks home page at: http://www.redbooks.ibm.com/redbooks.

The following Redpaper contains information on how Tivoli Provisioning Manager
models storage components and how those components are managed using Tivoli
Storage Productivity Center workflows:
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Title Order Number

An Introduction to Storage Provisioning with Tivoli Provisioning Manager and
Tivoli Storage Productivity Center

REDP 3900-00

Translations
Selected publications have been translated into languages other than American
English. Contact your IBM representative for more information about the
translated publications and whether these translations are available in your
country.

Accessing publications online
You can access all IBM Tivoli Storage Productivity Center publications in the IBM
Tivoli Storage Productivity Center Information Center. The following Web site
includes a link to the Information Center:

http://www.ibm.com/servers/storage/software/center/index.html

The Information Center contains the most recent version of the books in the
product library in PDF or HTML formats, or both. Translated documents are also
available for some products.

You can access the Developing automation packages guide from the Tivoli
Provisioning Manager Information Center at the following web site:

http://publib.boulder.ibm.com/infocenter/tivihelp/v13r1/topic/
com.ibm.tivoli.tpm.wkf.doc/workflows/cwkf_wkfovw.html

Note: If you print PDF documents on other than letter-sized paper, select the Fit
to page check box in the Adobe® Acrobat Print dialog. This option is available
when you click File → Print. Fit to page ensures that the full dimensions of a
letter-sized page print on the paper that you are using.

Ordering publications
You can order many IBM Tivoli Storage Productivity Center publications online at
the following Web site: [Wrong site]
http://www.ibm.com/shop/publications/order

You can also order by telephone by calling one of these numbers:
v In the United States: 800-879-2755
v In Canada: 800-426-4968

Providing feedback about publications
If you have comments or suggestions about the product and documentation,
provide your feedback at the following Web site: http://www.ibm.com/systems/
support/storage/software/tpc/

Contacting customer support
For support for this product, you can contact IBM customer support in one of the
following ways:
v Go to the technical support Web site by starting at http://www.ibm.com/

servers/storage/support/software/tpc/.
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v Customers in the United States can also call 1-800-IBM-SERV (1-800-426-7378).
v International customers should consult the Web site for customer support

telephone numbers.

You can also review the IBM Software Support Handbook, which is available on our
Web site at http://techsupport.services.ibm.com/guides/handbook.html.

When you contact customer support, be prepared to provide identification
information for your company so that support personnel can readily assist you.
Company identification information may also be needed to access various online
services available on the Web site. See “Reporting a problem” for details.

The support Web site offers extensive information, including a guide to support
services (the IBM Software Support Handbook); frequently asked questions (FAQs);
and documentation for all IBM Software products, including Release Notes®,
Redbooks, and white papers. The documentation for some product releases is
available in both PDF and HTML formats. Translated documents are also available
for some product releases.

Reporting a problem
Please have the following information ready when you report a problem:
v The Fabric Manager version, release, modification, and service level number.
v The communication protocol (for example, TCP/IP), version, and release number

you are using.
v The activity you were doing when the problem occurred, listing the steps you

followed before the problem occurred.
v The exact text of any error messages.

Depending on the problem, you may also want to provide the following
information:
v The switch vendor, model, and firmware level
v The HBA vendor, model, driver level, OS platform it is running with
v The storage device vendor, model, and code
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Chapter 1. Introduction

A workflow is a series of steps that can be run sequentially on IBM Tivoli
Provisioning Manager or IBM Tivoli Intelligent Orchestrator to provision your
environment automatically. Using the storage workflows provided by IBM Tivoli
Storage Productivity Center, you can automate most of the steps of what today is
the manual process of storage provisioning to compensate for the increasing
demand and complexity of storage. These workflows provide control and
configuration of IBM and major vendors’ products and can be run consistently and
without error by any level of administrator or operator.

The following tasks apply specifically to storage management through IBM Tivoli
Storage Productivity Center:
v Run the workflows provided to perform zone management and storage volume

management operations
v Use the Java™ helpers to create customized workflows or customize the

workflows that are provided to meet your needs (rather than starting from
scratch to create your own workflows).

For details about performing the two tasks described above, refer to the following
information, which is available in the Tivoli Provisioning Manager online
Information Center:
v The online help
v Developing automation packages

A detailed example of using storage workflows is presented in Chapter 5,
“Workflow scenario,” on page 21.

Tivoli Provisioning Manager represents systems and their components by Data
Center Model (DCM) objects, which are instances of DCM logical devices. For each
DCM logical device, a set of attributes and a set of logical device operations are
defined. Each operation can be a basic operation on a device, an invocation of a
workflow, or an invocation of another logical device operation on the same or on
another device. The workflows translate the logical device operations into
commands that are specific to the underlying physical device.

The following descriptions summarize the entities involved in the provisioning
process:

logical device operation
A logical device operation (LDO) provides a layer of abstraction from the
physical operations defined by specific device drivers or workflows.
Different device drivers can implement device-specific operations for the
same set of logical device operations. A logical device operation is not
device-specific, but the workflows called by a logical device operation are
device-specific. For example, creating a volume on an IBM storage device
is different from creating a volume on an EMC storage device. A different
set of workflows are used for different storage devices. Therefore, you
invoke the logical device operation rather than directly invoking the
workflows.

workflow
A workflow is a representation of the steps that are performed in a data
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center environment in order to complete a provisioning operation. A
workflow can be called from other workflows. In this way, workflows
make it possible to create a library of processes and best practices that can
meet any data center process requirement.

Java helper
Java helpers, which are used in workflows, provide the interface
interaction with data center devices. Java helpers are simply another
method by which you can interact with data center components. They
allow you to accomplish tasks that otherwise cannot be accomplished via
the native workflow language (like invoking web services, or parsing XML
documents, and so forth).

Chapter 4, “IBM Tivoli Storage Productivity Center workflows as building blocks,”
on page 15 describes the workflows and logical device operations supported by
Tivoli Storage Productivity Center. For additional details, see the automation
package README file.
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Chapter 2. Installing and configuring Tivoli Storage
Productivity Center storage workflows

To use the storage provisioning workflows, you will need to use two machines:
one running IBM Tivoli Storage Productivity Center and one running IBM Tivoli
Provisioning Manager. All components of IBM Tivoli Storage Productivity Center
must be installed on the same machine. You must have a license for Tivoli Storage
Productivity Center Standard Edition. For more information about licenses, see the
IBM Tivoli Storage Productivity Center Installation and Configuration Guide.

Note: Either Tivoli Provisioning Manager or Tivoli Intelligent Orchestrator may be
installed. Tivoli Provisioning Manager is a subset of Tivoli Intelligent Orchestrator.
The instructions and documentation are available at http://www.ibm.com/
software/tivoli/products/prov-mgr/ (for Tivoli Provisioning Manager) and
http://www.ibm.com/software/tivoli/products/intell-orch/ (for Tivoli Intelligent
Orchestrator). This installation assumes that Tivoli Provisioning Manager is being
used. In the context of this manual, Tivoli Provisioning Manager and Tivoli
Intelligent Orchestrator may be considered synonymous.

Agent Coexistence
What do we mean by ″coexistence″? Coexistence refers to the ability for the Tivoli
Provisioning Manager and Tivoli Storage Productivity Center agents to reside on
the same endpoint (managed server) at the same time.

Tivoli Provisioning Manager and Tivoli Storage Productivity Center both rely on
the Tivoli Common Agent Services to provide any necessary agent management
infrastructure. In order for the Tivoli Provisioning Manager and Tivoli Storage
Productivity Center Common Agents to coexist on the same endpoint at the same
time, they must be installed in unique directories and listen on unique ports.

By default, the Common Agent listens (binds) on three TCP ports: 9510, 9514 and
9515. There are three scenarios that must be considered when planning for
Common Agent coexistence between Tivoli Provisioning Manager and Tivoli
Storage Productivity Center.

Scenario 1: Tivoli Provisioning Manager is already deployed to the data center
(before Tivoli Storage Productivity Center is installed).

If Tivoli Provisioning Manager has already been deployed to the data center, it is
likely that the agents will have already been deployed to all of the endpoints, thus
these default ports will already be bound to the Tivoli Provisioning Manager
Common Agent. In this situation, it is necessary to specify a different port (other
than 9510) when performing the installation of the Tivoli Storage Productivity
Center Common Agent. The Tivoli Storage Productivity Center Common Agent
installer will take the base port specified by the user, add four and five to that
number and occupy the resulting port numbers. For example, if you specify port
9540 during the Tivoli Storage Productivity Center agent installation wizard, the
agent will occupy ports 9540, 9544 and 9545 upon successful installation. Also note
that the Tivoli Storage Productivity Center Common Agent must be installed to a
different directory than the Tivoli Provisioning Manager Common Agent which is
already installed.
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If you are performing a silent installation of the Tivoli Storage Productivity Center
Common Agent, these are the parameters in the setup_agents.iss response file that
must be modified to accomodate these changes:

-P installLocation=″<insert_some_unique_location>″
-V varCAPort=″9540″

Scenario 2: Tivoli Storage Productivity Center is already deployed to the data
center (before Tivoli Provisioning Manager is installed).

If Tivoli Storage Productivity Center has already been deployed to the data center,
it is likely that the agents will have already been deployed to all of the endpoints,
thus these default ports will already be bound to the Tivoli Storage Productivity
Center Common Agent. In this situation, it is necessary to specify a different port
(other than 9510) and install-path when performing the installation of the Tivoli
Provisioning Manager Common Agent.

In order to modify these two installation parameters, you must set two parameters
on the Configuration Template before deploying the Software Stack TCA_Stack in
Tivoli Provisioning Manager. The two parameters that must be set are:

install-path
CA-Listening-Port

As seen in the following diagram (for example):
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Note: The diagram, the CA-Listening-Port is set to 9510. If Tivoli Storage
Productivity Center is already occupying this port, the template will need to be set
to an alternate value, as we have previously described.

Scenario 3: Neither Tivoli Provisioning Manager nor Tivoli Storage Productivity
Center are already installed.

In this particular scenario, you have a choice of installing Tivoli Provisioning
Manager or Tivoli Storage Productivity Center first. The recommended practice is
to allow the Tivoli Provisioning Manager Common Agent to listen on the default
ports, while the Tivoli Storage Productivity Center Common Agent listens on some
unique range of ports (Scenario 1, if Tivoli Storage Productivity Center is not
already installed in the data center).

Installing storage workflows
The installation described in this chapter assumes that Tivoli Provisioning Manager
(or Tivoli Intelligent Orchestrator, whichever is chosen) has not been previously
installed.

The storage workflows are installed on the machine running Tivoli Provisioning
Manager. They should be installed after you have installed IBM Tivoli Storage
Productivity Center version 3.3.1 on a separate machine.

The helpers and workflows are included in an automation package, which you can
download from the following Web site: http://www.ibm.com/software/
ondemandcatalog/automation. Search for tpc automation package. Click Go.

Download the following:
v IBM Tivoli Storage Productivity Center Automation Package, version 3.3.1.

This package will contain the README file, the setup and initialization/
discovery/DCM synchronization workflows, fabric and disk building block
workflows, and the relevant Java helpers to support these workflows.
1. On the machine where you have installed Tivoli Storage Productivity Center,

create a user ID TPCUser as a system user ID with administrator privileges.
Note the host, Tivoli Storage Productivity Center Device Server port, user
name, and operating system password of TPCUser. This information must be
provided to the TPC_Configure workflow in step 1 on page 6.

Note: The rest of this procedure is done on the machine where you will install
Tivoli Provisioning Manager.

2. Install the Tivoli Provisioning Manager Version 5.1 following the instructions in
the Tivoli Provisioning Manager Installation Guide for your operating system.

3. Shut down Tivoli Provisioning Manager.
4. Install the tcdriver. If you have not previously done so, download the tpc

automation package from the following Web site:
http://www.ibm.com/software/ondemandcatalog/automation

Follow the instructions in the README file for the tcdriver
(IBMTPC_language_v331.html), where language indicates the language:

en – English
cs – Czech
de – German
es – Spanish
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fr – French
hu – Hungarian
it – Italian
ja – Japanese
ko – Korean
pl – Polish
ru – Russian
pt_BR – Brazilian Portuguese
zh_CN – Simplified Chinese
zh_TW – Traditional Chinese

To install the tcdriver, do the following:
a. Place the tcdriver file in the %TIO_HOME%/drivers directory.
b. Run the following command:

%TIO_HOME%/tools/tc-driver-manager.cmd InstallDriver IBMTPC

To uninstall the tcdriver, shut down the Tivoli Provisioning Manager server and
run the following command:
%TIO_HOME%/tools/tc-driver-manager.cmd uninstallDriver IBMTPC

Note: If some DCM objects are associated with the Device models specified in
the TPC automation package, the forceuninstallDriver command should be
used to uninstall the tcdriver.
To reinstall the tcdriver, stop Tivoli Provisioning Manager, place the tcdriver file
in the %TIO_HOME%/drivers directory, and run the following command:
%TIO_HOME%/tools/tc-driver-manager.cmd forceInstallDriver IBMTPC
-overwrite=true

5. Restart Tivoli Provisioning Manager.

Configuring and initializing workflows
Setting up storage provisioning workflows consists of running the TPC_Configure
and TPC_Initialize workflows.

Tivoli Storage Productivity Center storage provisioning workflows are run in the
Tivoli Provisioning Manager GUI.

The TPC_Configure and then TPC_Initialize workflows are run in that order for
the first time. TPC_Configure can also be run any time you want to point to a
new Tivoli Storage Productivity Center install. TPC_Initialize can be run at any
time to update the DCM storage components to reflect the current environment in
Tivoli Storage Productivity Center, although it should be run with care because
user-defined information associated with Tivoli Storage Productivity Center SAN
objects might be lost.
1. Run the TPC_Configure workflow.

a. Open the Tivoli Provisioning Manager console.
b. In the left pane, expand Configuration → Workflow.
c. The TPC workflows will be listed. Choose TPC_Configure.
d. Select Execute → Run to run the TPC_Configure workflow.
e. Enter the host (either an IP address or a resolvable DNS name for the host),

TPC DEVICE SERVER port, user name, and password of the machine where
IBM Tivoli Storage Productivity Center is installed. The default user name
and port are:

User name — TPCUser
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Port — 9550

f. Click Run.
2. Using the Tivoli Storage Productivity Center GUI, run the necessary device

discoveries, scans, and probes to ensure that Tivoli Storage Productivity Center
is aware of all SAN elements. See IBM Tivoli Storage Productivity Center User’s
Guide for information on running discoveries, scans, and probes.

3. Run the TPC_Initialize workflow to initialize the Tivoli Provisioning Manager
data center model with SAN information. This workflow loads the SAN Fabric
and Volume information into Tivoli Provisioning Manager.

Note: If you have run TPC_Initialize earlier, you may already have some SAN
entities populated in your DCM. Ensure these existing entities are associated
with the correct device model before running TPC_Initialize again. This is
necessary for the correct operation of TPC_Initialize and TPC_Clear_DCM. To
ensure this, follow the instructions in step 4. Once you have all existing DCM
entities associated with the correct device model, proceed to run TPC_Initialize,
and then go through step 4 again for the newly discovered entities.
a. In the Tivoli Provisioning Manager console, expand Configuration →

Workflow.
b. The TPC workflows will be listed. Choose TPC_Initialize.
c. Select Execute → Run to run the TPC_Initialize workflow.
d. Click Run.

Note: When IBM Tivoli Storage Productivity Center is installed on AIX®, you
must apply the WebSphere® Application Express™ (embedded) Cumulative Fix
12 to the embedded IBM WebSphere Application Server server in your Tivoli
Storage Productivity Center installation. By default, this server is located in
/opt/IBM/TPC/device/apps/was

You can download 5.1.1 CF12 at http://www-1.ibm.com/support/
docview.wss?rs=180&amp;uid=swg24013498

Also be sure to apply the Java SDK SR5 at http://www-1.ibm.com/support/
docview.wss?rs=180&amp;uid=swg24010272

4. Verify that storage subsystems, storage pools, and fabrics are associated with
the required workflows.
For each storage subsystem, do the following:
a. Expand Inventory → Manage Inventory → Storage Subsystem and click a

storage subsystem name.
b. Select the Workflows tab and verify that the following storage subsystem

workflows are associated with the subsystem.
TPC_SS_AttachVolHostWWPN
TPC_SS_CreateStorageVolume
TPC_SS_CreateStorageVolumeWithName
TPC_SS_DetachVolHostWWPN
TPC_SS_GetStorageVolumes
TPC_SS_RemoveStorageVolume

c. If the storage subsystem workflows are not associated with the subsystem,
follow these steps.
1) In the Workflows tab, Click Edit → Assign Device Driver. A list of

device drivers is displayed.
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2) Select TPC StorageSubsystem from the list and click Change Device
Driver. Do not select the Use Logical Operation check box.

For each storage pool object, do the following:
a. In the left panel, expand Inventory → Manage Inventory → Storage Pools

and click a storage pool name.
b. Select the Workflows tab and verify that the following volume workflows

are associated with the storage pool:
TPC_SP_CreateStorageVolume
TPC_SP_CreateStorageVolumeWithName
TPC_SP_GetStorageVolumes
TPC_SP_RemoveStorageVolume

c. If the workflows are not associated with the storage pool, follow these steps:
1) In the Workflows tab, click Edit → Assign Device Driver. A list of

device drivers is displayed.
2) Select TPC StoragePool from the list and click Change Device Driver.

Do not select the Use Logical Operation check box.
For each Fabric do the following:
a. Expand Inventory → Manage Inventory → Storage Area Networks →

TPC_SAN and click the fabric name.
b. Select the Workflows tab and verify that the following workflows are

associated with the fabric.
v TPC_Add_Zone_Members
v TPC_Create_Zone
v TPC_Remove_Zone
v TPC_Remove_Zone_Members

c. If the fabric workflows are not associated with the fabric, follow these steps:
1) In the Workflows tab, click Edit → Assign Device Driver. A list of

device drivers is displayed.
2) Select TPC SANFabric from the list and click Change Device Driver.

Do not select the Use Logical Operation check box.
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Chapter 3. Automating storage provisioning with IBM Tivoli
Storage Productivity Center workflows

Storage provisioning workflows are grouped into the following three types:
v Setup and DCM synchronization workflows
v Fabric workflows
v Disk workflows

Storage workflows, and hence the LDOs, can be invoked from the GUI to perform
the following tasks:

For Fabric (SANFabric.xxx LDOs):

v Create a zone
v Add zone members
v Remove a zone
v Remove zone members

For Storage Subsystems (StorageSubsystem.xxx LDOs):

v Create a storage volume
v LUN mapping
v Remove a storage volume
v LUN unmapping

For Storage Allocation Pools (StoragePool.xxx LDOs):

v Create a storage volume
v Remove a storage volume

Setup and DCM synchronization workflows
The setup and DCM synchronization workflows TPC_Configure and TPC_Initialize
are unique in that they are not associated with LDOs. These are high level
workflows designed to set up storage provisioning workflows. They are run after
installation of the TPC automation package. For more information on running
TPC_Configure and TPC_Initialize, see “Configuring and initializing workflows”
on page 6.

The setup and DCM synchronization workflows perform the following functions:

Setup and DCM Synchronization
Workflows Descriptions

TPC_Configure

(HostName, Port, Username,
Password)

This workflow is used to configure a Tivoli
Provisioning Manager install to point to a specific
Tivoli Storage Productivity Center install for the
purposes of discovery and storage provisioning
actions.

Run this workflow before any other storage
workflows. See “Configuring and initializing
workflows” on page 6 for details about running the
configuration workflow.
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Setup and DCM Synchronization
Workflows Descriptions

TPC_Initialize The initialization workflow initializes the
storage-specific sections of the Tivoli Provisioning
Manager DCM. Note that all SAN discoveries, probes
and scans (such as CIMOM discovery, subsystem
probe, outband discovery, and so forth) on the Tivoli
Storage Productivity Center server configured during
TPC_Configure should be completed before the
initialization workflow is run.

See “Configuring and initializing workflows” on page
6 for details about running the initialization workflow.
Run TPC_Initialize immediately after running a device
discovery, scan, and probe on the machine where
Tivoli Storage Productivity Center is installed. This
workflow should be run right after the discovery and
before running any other workflows. It can also be
run at any time to synchronize Tivoli Provisioning
Manager’s DCM with the “real” view of the SAN as
seen by Tivoli Storage Productivity Center.

Where variables are:

HostName
Host name of the machine where IBM Tivoli Storage Productivity Center is
installed. This can be either an IP address or a resolvable host name. See
Chapter 2, “Installing and configuring Tivoli Storage Productivity Center
storage workflows,” on page 3 for more information.

Port Port number of the machine where IBM Tivoli Storage Productivity Center
Device Server is installed (default is 9550). See Chapter 2, “Installing and
configuring Tivoli Storage Productivity Center storage workflows,” on
page 3 for more information.

Username
User ID with administrative privileges on the machine where IBM Tivoli
Storage Productivity Center is installed. This should be created on the
Tivoli Storage Productivity Center server as part of Tivoli Storage
Productivity Center workflows installation. The recommendation is to
create a new user called TPCUser (see Chapter 2, “Installing and
configuring Tivoli Storage Productivity Center storage workflows,” on
page 3).

Password
Administrative password set during installation on the machine where IBM
Tivoli Storage Productivity Center is installed (see Chapter 2, “Installing
and configuring Tivoli Storage Productivity Center storage workflows,” on
page 3).

Setup and DCM synchronization workflows do not use or implement any logical
device operations. For further details, see the README for the IBMTPC.tcdriver
automation package.

The configuration workflow takes as input the host, port, user name and password
for the machine where Tivoli Storage Productivity Center is installed. These are
stored in an encrypted configuration properties file and used by other Java helpers
to authenticate with the functions.
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The initialization workflow populates the storage-specific sections of the Tivoli
Provisioning Manager Data Center Model.

The following SAN entities are discovered by the DCM synchronization and
initialization workflow and populated in the Tivoli Provisioning Manager DCM:

Servers

v Newly discovered servers are put in TPC_Server_Pool. Existing servers
also managed by Tivoli Storage Productivity Center are shown by the
″DISCOVERED_BY″ property, which has value ″TPC.″

v Server ports (associated to default HBA)
v Server port connections to fabrics
v Other server properties (such as server IP interface and IP address)

Storage subsystems

v Storage pools
v Storage volumes
v Subsystem fibre adapter ports (associated with default FA)
v Subsystem fabric connections

SAN fabrics

v Switch
v Discovers all ports of discovered switches, as well as their WWPNs.
v Fabric WWN
v Zones and active zoneset
v Fabric connections

Note: If the storage environment is manipulated outside Tivoli Provisioning
Manager, it is possible that the DCM will go out of synchronization with the real
view of the SAN. We strongly recommend that you operate exclusively through the
Tivoli Provisioning Manager console to avoid this situation. You can run
TPC_Initialize to resynchronize the DCM, however user-defined relationships (such
as file systems defined on volumes provisioned by Tivoli Storage Productivity
Center workflows) may be lost during initialization.

Using storage provisioning workflows
Using the Tivoli Provisioning Manager console, you can complete the following
tasks:

SAN Fabric What to do

CreateZone v Expand Inventory → Manage Inventory → Storage Area
Networks → TPC_SAN and find your fabric.

v In the right pane, click on the Zones tab.

v Click Edit → Add Zone.

v In the input parameter window, input a zone name and
select the appropriate information for the first zone
member of the zone.

v Select Use Logical Device Operation and click Save.

Note that it is not possible to create zones without initial
members since such zones are invalid on some switches.
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SAN Fabric What to do

AddZoneMembers 1. Expand Inventory → Manage Inventory → Storage Area
Networks → TPC_SAN and find your fabric.

2. In the right pane, click the Zones tab.

3. Click Edit Zone → Add Zone Member.

4. In the input parameter window, enter the necessary
information. Check Use logical operation.

5. Click Run.

RemoveZone 1. Expand Inventory → Manage Inventory → Storage Area
Networks → TPC_SAN and find your fabric.

2. In the right pane, click the Zones tab.

3. Click Edit Zone → Delete Zone Using Workflow.

4. In the input parameter window, enter the necessary
information.

5. Click Run.

RemoveZoneMembers
This workflow deletes zone members one at a time.

1. Expand Inventory → Manage Inventory → Storage Area
Networks → TPC_SAN and find your fabric.

2. In the right pane, click the Zones tab.

3. Click Edit Zone Member → Delete Zone Member Using
Workflow.

4. In the input parameter window, enter the necessary
information.

5. Click Run.

Storage subsystem What to do

CreateStorageVolume 1. Expand Inventory → Manage Inventory → Storage
Subsystems and click on the storage subsystem.

2. Click Edit → Add Storage Volume.

3. In the input parameter window, enter the necessary
information. Check Use Logical Operation.

4. Click Run.

This will pick a storage pool in the given subsystem
matching the RAID level required. If such a storage pool
does not exist, the user is informed. Note that the storage
pool specified by the user is not used.
Note: The Tivoli Provisioning Manager UI prompts for
Volume Name and Volume ID. Enter the same information
in both fields. For example, to create a volume labeled
mystorage, enter mystorage in both text boxes.

LunMapping 1. Expand Inventory → Manage Inventory → Storage
Subsystems and click on the storage subsystem.

2. For the storage volume, go to the icon in the far right
column. Click the icon and choose Associate to HBA
Port.

3. In the input parameter window, enter the necessary
information. Check Use logical operation.

4. Click Run.
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Storage subsystem What to do

RemoveStorageVolume 1. Expand Inventory → Manage Inventory → Storage
Subsystems and click on the storage subsystem.

2. For the storage volume, go to the icon in the far right
column. Click the icon and choose Remove Storage
Volume Using Workflow.

3. In the input parameter window, enter the necessary
information.

4. Click Run.

LunUnmapping 1. Expand Inventory → Manage Inventory → Storage
subsystems and click on the storage subsystem.

2. Go to the Fibre Channel Port column for the given
volume. Click on the associated host port.

3. Click Remove Fibre Channel Port Association Using
Workflow.

4. In the input parameter window, enter the necessary
information.

5. Click Run.

GetStorageVolumes 1. Get storage subsystem and storage capabilities
requirement IDs.

2. Go to Automation → Logical Device Operations →
Storage Subsystem.

3. Click the StorageSubsystem.GetStorageVolume LDO.

4. Click Execute → Run.

5. In the input parameter window, enter the necessary
information.

6. Click Run.

Storage Allocation Pool What to do

CreateStorageVolume Note: Invoking Manage Inventory → Storage Pools, clicking
on a pool, and, in the right pane, selecting Edit → Add
Storage Volume does not invoke this LDO.

Create storage capabilities:

v Expand Manage Inventory → Storage Template → Create
New Template.

v Select Edit This Template → Add Volume Container
Settings.

– For volume container settings, add logical volume
settings. Specify RAID and expected volume size.

– For logical volume settings, hover over the Capabilities
column to get the storage capabilities ID.

v Note the pool ID by hovering over it.

Create storage volume:

1. Expand Automation → Logical Device Operations →
Storage Pools.

2. Click the StoragePool.CreateStorageVolume LDO.

3. Click Execute → Run.
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Storage Allocation Pool What to do

RemoveStorageVolume
Note: Invoking Manage Inventory → Storage Pools, clicking
on a pool, and, in the right pane, selecting Edit → Add
Storage Volume does not invoke this LDO.

1. Go to Automation → Logical Device Operations →
Storage Pool.

2. Click on the StoragePool.RemoveStorageVolumes LDO.

3. Click Execute → Run.

GetStorageVolumes 1. Get storage pool and storage capabilities requirements
IDs.

2. Go to Automation → Logical Device Operations →
Storage Pool.

3. Click on the StoragePool.GetStorageVolumes LDO.

4. Click Execute → Run.

Fabric device support
The fabric workflows can operate against all the fabric devices and environments
supported by the IBM Tivoli Storage Productivity Center.

For a current listing of supported fabric devices, go to the following Web site:
http://www-1.ibm.com/support/docview.wss?rs=1134&uid=swg21230797

Disk device support
For a current list of supported disk devices, go to the following Web site:
http://www-1.ibm.com/support/docview.wss?rs=597&context=SYCRL4
&context=SSMMUP&dc-500&uid=ssg1S1002800&loc=en_US&cs=utf-8&lang=en
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Chapter 4. IBM Tivoli Storage Productivity Center workflows
as building blocks

This chapter provides listings of workflows and sub-workflows by type. It is of
interest primarily to developers who will be writing their own workflows based on
the Tivoli Storage Productivity Center workflows. See the Developing automation
packages guide provided by Tivoli Provisioning Manager and the Redpaper REDP
3900-00 ″An Introduction to Storage Provisioning with Tivoli Provisioning Manager
and Tivoli Storage Productivity Center″ for more information on developing
workflows.

Tivoli Storage Productivity Center storage provisioning workflows provide
building-block workflows that help automate SAN discovery and basic storage
provisioning tasks. High level storage provisioning workflows are created from
other workflows. Workflows themselves are composed of low-level workflows,
Java helpers, and simple commands. You do not call low-level workflows and Java
helpers directly when you are developing workflows.

Note: Sometimes the terms workflow and LDO seem synonymous. There is a
difference. An LDO is a wrapper mechanism through which you execute the
correct workflow for the device you are working with. The workflow implements
this LDO and extends the LDO’s functionality or provides specific functionality.
When the LDO is invoked, it does some generic actions, invokes the appropriate
workflow (based on the device driver associated with the entity on which the LDO
is invoked), and then does some post-workflow actions. One of the post actions is
committing the changes to DCM. All operations, such as CreateVolume and
RemoveZoneMember, should only be invoked through the LDO wrapper
mechanism. If they are not invoked via an LDO, Tivoli Provisioning Manager does
not know to update the records showing that a workflow ran and what the results
were.

Storage provisioning workflows are grouped into the following three types:
v Setup and DCM synchronization workflows
v Fabric workflows
v Disk workflows

Setup and DCM synchronization workflows
In addition to the workflow information covered in “Setup and DCM
synchronization workflows,” setup and DCM synchronization workflows include
the following functions:

Integration Workflows Descriptions

TPC_Initialize Previously, the TPC_Initialize workflow only updated
current information and added new information to the
database. In this release, however, the TPC_Initialize
workflow is a high-level workflow that calls two more
specific workflows in sequence: the TPC_Clear_DCM
workflow and the TPC_Update_DCM workflow.
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Integration Workflows Descriptions

TPC_Clear_DCM This workflow removes all discovered objects related
to IBM Tivoli Storage Productivity Center from the
Tivoli Provisioning Manager database. User-created
variables and objects that might contain user-created
variables are not removed. This workflow should not
be invoked directly.

TPC_Update_DCM This workflow updates, as necessary, the objects
discovered by IBM Tivoli Storage Productivity Center
in the Tivoli Provisioning Manager database and adds
any new objects. This workflow should not be
invoked directly.

TPC_Update_StorageVolume
_Assignments

(StorageSubsystemID, PoolID)

This workflow gets the assignments for all volumes in
a given storage subsystem. This workflow can be run
after TPC_Initialize has been run. The workflow for
storage volume assignments can be slow depending
on the number of volumes that are assigned. Other
storage logical device operations can be run while this
workflow is running. This workflow should not be
invoked directly.

Where variables are:

StorageSubsystemID
The Tivoli Storage Productivity Center ID of a storage subsystem.

PoolID
The Tivoli Storage Productivity Center ID of a pool.

The setup and DCM synchronization workflows do not use or implement any
logical device operations. For further details, see the README for the
IBMTPC.tcdriver automation package.

The configuration workflow takes as input the host, port, user name and password
for the machine where Tivoli Storage Productivity Center is installed. These are
stored in an encrypted configuration properties file and used by other Java helpers
to authenticate with the functions.

The initialization workflow populates the storage-specific sections of the Tivoli
Provisioning Manager Data Center Model. The initialization workflow discovers
SAN fabric objects only if they contain both initiator and target ports. That is, only
if both servers and storage are connected to the fabric, with the servers being
monitored by fabric functions and storage being monitored by disk. This is done to
ensure that these SAN fabrics are usable by higher level workflows that need
access to both servers and storage.

A number of associated sub-workflows are invoked by the initialization, update,
and clear workflows and listed below.

Attention: Do not invoke these sub-workflows directly.
v TPC_Clear_Fabrics
v TPC_Clear_Servers
v TPC_Clear_StorageSubsystems
v TPC_Clear_Switches
v TPC_Clear_Subsystems
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v TPC_CreateStoragePool
v TPC_CreateSan
v TPC_Update_Servers
v TPC_Update_ServerInterface
v TPC_Update_ServerPorts
v TPC_Update_StorageSubsystems
v TPC_Update_StorageSubsystemInterface
v TPC_Update_StorageSubsystemPorts
v TPC_Update_StoragePool
v TPC_Update_StorageVolumes
v TPC_Update_StorageVolume_Assignments
v TPC_Update_Fabrics
v TPC_Update_Switches
v TPC_Update_Zones

Fabric workflows
SANFabric objects are created in DCM when the initialization workflow (present in
the Integration Automation Package) is run. The following logical device
operations are defined for SANFabric objects.

Fabric Workflows

(and parameters) Implement these Fabric logical device operations

TPC_Fabric_CreateZone

(SANFabricID, ZoneName,
SANPortIDs)

SANFabric.CreateZone

Create a zone with a given zone name, and create new
zone members in it.

TPC_Fabric_AddZoneMembers

(SANFabricID, ZoneID,
SANPortIDs)

SANFabric.AddZoneMembers

Add new zone members to an existing zone. The zone
has to be created using TPC_Fabric_CreateZone
beforehand.

TPC_Fabric_RemoveZone

(SANFabricID, ZoneID)

SANFabric.RemoveZone

Remove a zone and all zone members in it.

TPC_Fabric_RemoveZoneMembers

(SANFabricID, ZoneID,
SANPortIDs)

SANFabric.RemoveZoneMembers

Remove zone members from the zone. If the last zone
member is removed, the DCM object for the zone will
also be removed.

Where variables are:

SANFabricID
The DCM ID of the SAN Fabric. Obtained by moving the cursor over a
SAN Fabric object.

SANPortIDs
An array of SANPort IDs. These can be host port IDs or subsystem port
IDs. Obtained by moving the cursor over the HBA ports on server pages or
over fibre-adapter ports on subsystem pages.
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ZoneName
The name to be given to the new zone.

ZoneID
The DCM ID of the zone. Obtained as output of a CreateZone operation or
by moving the cursor over a zone on the Zones tab of a SAN Fabric.

The Fabric workflows invoke the following associated sub-workflows:

Attention: Do not invoke these sub-workflows directly.
v TPC_Valid_PortIDs_List
v TPC_PortIDs_To_WWN_List

For further details, see the README for the IBMTPC.tcdriver automation package.

Note: Do not invoke workflows directly. Run the logical device operations, which
will invoke the correct workflow based on the SANFabric ID.

Disk workflows

Disk Workflows

(and parameters) Implement these Volume logical devices operations

TPC_SS_GetStorageVolumes

(StorageSubsystemID,
StorageCapabilitiesRequirementIDs)

StorageSubsystem.GetStorageVolumes

Get a list of available storage volumes with the
specified storage requirements. One volume is
returned for each input storage capability setting.

TPC_SS_AttachVolHostWWPN

(StorageSubsystemID,
StorageVolumeIDs, HBAPortID,
LUN)

StorageSubsystem.LunMapping

Map a host port to a storage volume. This workflow
does both mapping and masking.

TPC_SS_DetachVolHostWWPN

(StorageSubsystemID,
StorageVolumeIDs, HBAPortID)

StorageSubsystem.LunUnmapping

Unmap a storage volume from a host port. This
workflow does both unmapping and unmasking.

TPC_SS_CreateStorageVolume

(StorageSubsystemID,
StorageCapabilitiesRequirementID)

StorageSubsystem.CreateStorageVolume

Create a new storage volume on the storage
subsystem.

TPC_SS_CreateStorageVolume
WithName

StorageSubsystemID,
StorageCapabilitiesRequirementID)

StorageSubsystem.CreateStorageVolumeWithName

Create a new storage volume on the storage
subsystem using the desired volume name.

TPC_SS_RemoveStorageVolume

(StoragePoolID,
StorageCapabilitiesRequirementIDs)

StorageSubsystem.RemoveStorageVolume

Remove the storage volume on the storage subsystem.

TPC_SP_GetStorageVolumes

(StorageSubsystemID,
StorageVolumeID)

StoragePool.GetStorageVolumes

Get a list of available storage volumes in a storage
pool with the listed storage requirements. One volume
is returned for each input storage capability setting.
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Disk Workflows

(and parameters) Implement these Volume logical devices operations

TPC_SP_CreateStorageVolume

(StoragePoolID,
StorageCapabilitiesRequirementID)

StoragePool.CreateStorageVolume

Create a new storage volume (using the given storage
capability setting) in the storage subsystem that is
linked to this storage pool.

TPC_SP_CreateStorageVolume
WithName

(StoragePoolID,
StorageCapabilitiesRequirementID,
StorageVolumeName)

StoragePool.CreateStorageVolumeWithName

Create a new storage volume (using the given storage
capability setting) in the storage subsystem that is
linked to this storage pool, using the desired volume
name.

TPC_SP_RemoveStorageVolume

(StoragePoolID, StorageVolumeID)

StoragePool.RemoveStorageVolume

Remove a storage volume from the storage subsystem
that is linked to this storage pool.

Where variables are:

StorageSubsystemID
ID of a storage subsystem. Obtained by moving the cursor over a storage
subsystem object.

StoragePoolID
ID of a storage pool. Obtained by moving the cursor over a storage pool
object.

StorageCapabilitiesRequirementIDs
For Get workflows: An array of storage capabilities IDs. Obtained from the
Storage Needs page.

For Create workflows: The storage capabilities ID. Obtained from the
Storage Needs tab.

StorageVolumeID
The ID of StorageVolume. Obtained as output of CreateStorageVolume
operation or by moving the cursor over a volume on any storage
subsystem or storage pool page.

VolumeID
A device-specific, unique ID for a volume. Optional when input.

SANPortID
The ID of a SANPort. Only a host port ID. Obtained by moving the cursor
over HBA ports on server pages.

LUN The 1 to 4 digit number of the desired LUN in hexadecimal notation.
(optional).

AssignedLUN
An assigned LUN.

For further details, see the README for the IBMTPC.tcdriver automation package.

Note: Do not invoke workflows directly. Run the logical device operations, which
will invoke the correct workflow based on the storage subsystem ID or storage
pool ID.
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Disk states
The disk states change depending on the operations performed. The following
table displays the various states.

Original State
TPM
LogicalDeviceOperation New State

— CreateStorageVolume Available

Available GetStorageVolume Reserved

Available, Reserved (not
assigned to a port), or
Assigned (assigned to a port)

LunMapping Assigned

Assigned LunUnmapping Assigned (still maps to some
port) or Available (does not
map to any port)

Assigned, Available,
Reserved

RemoveStorageVolume —
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Chapter 5. Workflow scenario

This chapter provides a detailed scenario that walks you through the process of
adding storage to a server and setting up a zone with the IBM Tivoli Provisioning
Manager graphical user interface (GUI), building upon the storage workflows
provided by Tivoli Storage Productivity Center.

Adding storage to a server and setting up a zone
This section describes how to map a storage volume to a host bus adapter (HBA)
and add it to a zone by using the Tivoli Provisioning Manager GUI to execute
logical device operations in sequence. The operations are creating a storage
volume, creating a zone, mapping the volume to a server, and adding the volume
to a zone. All these operations invoke functionality on the Tivoli Storage
Productivity Center server to do storage provisioning tasks.
1. Create a storage volume (see CreateStorageVolume).
2. Create a zone (see CreateZone).
3. Expand Inventory → Manage Inventory → Storage Subsystems and click the

name of the subsystem.
4. Storage volumes are shown in the left pane. Go to the storage volume created

in Step 1. Click the options menu icon to the far right of the storage volume
row and click Associate to HBA Port.

5. In the Input Parameter Workflow window, enter the following information. (See
Figure 1 on page 22.)

StorageSubsystemID: Select the HBA for this server
Port number: Select the port number on this HBA.
Logical Unit Number: Input a valid LUN number to assign to the volume.
Note that this is not considered by TPC workflows since various storage
devices have their own ways of assigning LUN IDs. This means this value
is ignored, although it must be filled in.

Check the Use Logical Operation box.
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Click OK.
6. After the LDO is complete, get the assigned LUN number from the workflow

output. Click the arrow on the far left of the workflow row to expand. The
LUN number will be listed in the output column.

7. Verify that the LunMapping LDO has completed successfully. (See Figure 2 on
page 23.)
a. Expand Inventory → Manage Inventory → Storage Subsystems and click the

name of the subsystem.
b. In the General tab, verify that the LUN number matches the LUN number

from the logical device operation output. The listing is in hexadecimal.

Figure 1. Providing information for logical device operation
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8. Add a member to a zone:
a. Expand Inventory → Manage Inventory → Storage Area Networks →

TPC_SAN and click on the name of the fabric. Click on the Zones tab.
b. Click the options menu icon to the far right of the zone row and click Add

Zone Member.
c. In the Input Parameter for Workflow window, type the following

information. (See Figure 3 on page 24.)
Connected System: System representing the first zone member to add to
the newly created zone.
Connected Adapter: Adapter on this system that has the port to add as
a zone member.
Connected Port: Port on the system to add as the first zone member to
this new zone.

Check the Use logical operation box.

Figure 2. Checking the LUN entry
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d. Click Save.

Figure 3. Running the logical device operation
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Chapter 6. Troubleshooting

For general information about automation packages, how they work, and
troubleshooting information, see Developing automation packages at the following
Web site: http://publib.boulder.ibm.com/infocenter/tivihelp/v13r1/topic/
com.ibm.tivoli.tpm.wkf.doc/workflows/cwkf_wkfovw.html

For general problem determination, troubleshooting, and error messages, go to the
following Web site: http://publib.boulder.ibm.com/infocenter/tivihelp/v13r1/
topic/com.ibm.tivoli.tpm.doc/pubs/TPM51ProblemDeterminationGuide.pdf

To troubleshoot many of the Tivoli Storage Productivity Center workflows you will
need the logs on the Tivoli Storage Productivity Center server. For information
about Tivoli Storage Productivity Center log files, see the following publications
Web site: http://publib.boulder.ibm.com/infocenter/tivihelp/v4r1/
index.jsp?topic=/com.ibm.itpc.doc/tpcpdg31.htm

Expand Problem Determination Guide for information on how to enable logging.
IBM will need these logs for most Tivoli Storage Productivity Center workflows
troubleshooting.

Some Tivoli Storage Productivity Center workflows troubleshooting will also
require CIMOM logs and agent logs. Refer to the respective documentation for
instructions on how to enable such logging.

Log files for workflow troubleshooting
For errors during the install of the tcdrivers, refer to the following log files in
%TIO_LOGS%/tcdrivermanager:

trace.log
This log contains entries for all errors encountered. The entries are marked
FATAL and prefixed with TPC Invocation error. There also is a stack trace
which is similar to what is shown in the Error Detail section of the GUI.

console.log
This log contains all the information in trace.log as well as other
information necessary for debugging. For each call made to the enablement
layer function, there is an entry in the console.log.

objectDump.xml
For objects that were not loaded into the database.

For errors that occur while running the workflows, refer to the console.log and
trace.log files in %TIO_LOGS%/deploymentengine.

By default, debug messages are not copied to the log files. To get more log file
information, change the setting on %TC_HOME%/config/log4j.prop to:
v log4j.appender.errorfile.threshold=debug
v log4j.appender.consolefile.threshold=debug

For Java helper errors, refer to %TIO_LOGS%\deploymentengine\
tpcWorkflowPlugins.log
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When a problem occurs, check the log files in the following areas:
v Tivoli Storage Productivity Center Device server logs in <TPC install

location>/device/log

v CIMOM logs in documented locations on CIMOM machines
v Agent logs in documented locations on agent machines
v Tivoli Provisioning Manager logs on the Tivoli Provisioning Manager server
v Tivoli Storage Productivity Center Java helper logs on the Tivoli Provisioning

Manager machine

Troubleshooting workflow problems
Some general guidelines include the following:
v For SAN modifications, ensure that appropriate discoveries, probes, and scans

are run with the Tivoli Storage Productivity Center GUI against the Tivoli
Storage Productivity Center server. Also ensure that TPC_Initialize is run at this
point to resynchronize the Tivoli Provisioning Manager DCM with the Tivoli
Storage Productivity Center view of the SAN.

v Ensure that the Tivoli Storage Productivity Center server (common agent service,
Data server, and Device server) is up.

v Ensure that agents and CIMOMs are up.
v Ensure that switches and subsystems are accessible from the Tivoli Storage

Productivity Center server.
v Ensure that there are no firewalls blocking access to and from the Tivoli Storage

Productivity Center and Tivoli Provisioning Manager servers.
v Some errors are seen because of running Tivoli Storage Productivity Center

provisioning workflows instead of the corresponding LDOs. Remember that, for
all tasks except TPC_Initialize and TPC_Configure, you must run Tivoli
Provisioning Manager LDOs (see http://www.ibm.com/software/tivoli/
products/prov-mgr/).

The indicators of a problem can be one of the following:
v Failed workflows
v Error messages in the logs or GUI
v Inconsistencies or unexpected data at various levels: Tivoli Provisioning

Manager, Tivoli Storage Productivity Center, or the CIMOMs.

Depending on the error code, trace through the logs: Tivoli Provisioning Manager,
Tivoli Storage Productivity Center, and auxiliary (CIMOM, agents, and so forth).

Problem descriptions and solutions
For error messages or error codes, refer to the IBM Tivoli Storage Productivity Center
Problem Determination Guide.

These are error situations you may encounter when working with storage
workflows. The symptom and recovery actions are provided here.

Problem
The workflow fails with error message COPCOM140E.

Solution
WebSphere(R) cannot be started properly on Tivoli Provisioning Manager
because of bad transactions. This situation occurs very infrequently. To
resolve this problem, follow this procedure:
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1. Stop Tivoli Provisioning Manager through Windows® Services.
2. Stop WebSphere TPM through Windows Services.
3. Delete all files and folders located in the following directory:

<WAS_home>\logs\server1\*

Note: If you encounter an error message informing you that the file is
in use, reboot your machine. Then follow steps 1, 2, and 3 again.

4. Delete all files and folders in the following directory:
<WAS_home>\tranlog\*

5. Delete all files and folders in the following directory:
<WAS_home>\10M\*

6. Check the SystemOut log to make sure there are no error messages
listed in the log.

Note: The SystemOut log is located in the following directory:
<WAS_home>\logs\server1

7. Start WebSphere TPM through Windows Services.
8. Check the SystemOut log again to make sure there are no error

messages listed in the log.
9. Start Tivoli Provisioning Manager through Windows Services.

10. Log in to Tivoli Provisioning Manager.
11. Check the SystemOut log again to make sure there are no error

messages listed in the log.
12. Check the Tivoli Provisioning Manager logs for any error messages:

deploymentengine\consolellog
policyengine.log

13. If there are no error messages, then you can run your workflows.

__________________________________________________

Problem
Cannot get volume information when running the Initialize workflow.

Solution
A user ID of TPCUser should have been created with administrator
authority on the Tivoli Storage Productivity Center machine. This user ID
should be used when running the TPC_Configure workflow.

__________________________________________________

Problem
Cannot get volume assignments for the SAN Volume Controller using the
TPC_GetStorageVolume_Assignments workflow.

Solution
Use the SAN Volume Controller CIMOM supported by Tivoli Storage
Productivity Center.

__________________________________________________

Problem
Received a ″500 Internal error″ message on the console log during the
running of the TPC_Initialize workflow.

Solution
Ensure that the appropriate WebSphere application version is used during
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Tivoli Provisioning Manager install. (See the installation instructions, step 2
on page 5.) Refer to the Tivoli Provisioning Manager Installation Guide for
your operating system.

__________________________________________________

Problem
The DCM is not being updated after running the workflows.

Solution
Run the corresponding LDO and not the workflow. For example, run the
StorageSubsystem.createStorageVolume LDO and not the
TPC_SS_CreateStorageVolume workflow. All DCM updates are done by the
LDOs.

__________________________________________________

Problem
The workflow or LDO fails with error message COPDEX002E. WebSphere
cannot be started properly on Tivoli Provisioning Manager because of bad
transactions. This error also occurs when the log size has not been
configured correctly while installing the Tivoli Provisioning Manager fix
pack.

Solution
First, follow these steps to recover from the problem:
1. Stop Tivoli Provisioning Manager through Windows Services.
2. Stop WebSphere TPM through Windows Services.
3. Delete all files and folders located in the following directory:

<WAS_home>\logs\server1\*

If you encounter an error message informing you that the file is in
use, reboot your machine. Then follow steps 1, 2, and 3 again.

4. Delete all files and folders in the following directory:
<WAS_home>\tranlog\*

5. Delete all files and folders in the following directory:
<WAS_home>\10M\*

6. Check the SystemOut log to make sure there are no error messages
listed in the log.
The SystemOut log is located in the following directory:
<WAS_home>\logs\server1

7. Start WebSphere TPM through Windows Services.
8. Check the SystemOut log again to make sure there are no error

messages listed in the log.
9. Start Tivoli Provisioning Manager through Windows Services.

10. Log in to Tivoli Provisioning Manager.
11. Check the SystemOut log again to make sure there are no error

messages listed in the log.
12. Check the Tivoli Provisioning Manager logs for any error messages.

deploymentengine\consolellog
policyengine.log

To configure the transaction log size in the WebSphere Application Server,
follow these steps:
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1. Start the WebSphere Application Server. Log onto the Administrative
console from your browser by entering:
http://<your_hostname>:9090/admin

Replace the variable <your_hostname> with the host name of the
application server.

2. Click Servers → Application Servers → Server1 → Transaction Service.
3. Select the Configuration tab to display the transaction-related

configuration properties.
4. Change the Transaction Log directory field to ;10M.

Note: Ensure that there is a semicolon before the number 10M.
5. Click OK.
6. Click Apply → Save.
7. Stop and then restart the application server.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte character set (DBCS) information,
contact the IBM Intellectual Property Department in your country or send
inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION ″AS IS″ WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Software Interoperability Coordinator, Department YBWA
3605 Highway 52 N
11400 Burnet Road
Rochester, MN 55901
U.S.A

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.
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Trademarks
The following terms are trademarks of the International Business Machines
Corporation in the United States or other countries or both:

AIX
AIX 5L
Database 2
DB2
DB2 Universal Database
Enterprise Storage Server
ESCON
HACMP
IBM
IBMLink
iSeries
Lotus
NetView

POWER5
pSeries
Redbooks
RISC System/6000
RS/6000
Tivoli
Tivoli Enterprise
Tivoli Enterprise Console
Tivoli Storage
WebSphere
xSeries
z/OS
zSeries

Intel® and Pentium® are trademarks or registered trademarks of Intel Corporation
in the United States, other countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc., in the United States, other countries, or
both.

Linux® is a trademark of Linus Torvalds in the United States, other countries, or
both.

Lotus®, Lotus Notes®, and Domino® are trademarks or registered trademarks of
International Business Machines Corporation and Lotus Development Corporation
in the United States, other countries, or both.

Microsoft®, Windows, and the Windows logo are trademarks of Microsoft
Corporation in the United States, other countries, or both.

UNIX® is a registered trademark of the Open Group in the United States, other
countries, or both.

Other company, product, and service names may be trademarks or service marks
of others.
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