Installing a new Guardium patch does not complete

If you cannot complete the installation of a new Guardium patch, stop the interfering process and reinstall the patch.

Symptoms

When you install a new patch it does not complete. The status column in the CLI command show system patch installed shows one of the following messages.

STEP: Setting “java” off
STEP: Setting “amei” off
STEP: Setting “sqlw” off 

Causes

Tomcat, the inspection core, or another process on the machine interfered with the patch installation.

Environment

The Collector, Aggregator, and Central Manager are affected.

Resolving the problem

To install the new Guardium patch, stop any processes from interfering with the installation.

  1. Delete the patch that is stuck by using the command delete scheduled-patch.
  2. Restart the system by using the command restart system.
  3. After the system restarts, stop the GUI and inspection core by using the commands stop gui and stop inspection-core.
  4. Reinstall the patch and restart the GUI and inspection core by using the commands restart gui and start inspection-core.