Before using this information and the product it supports, read the information in "Notices" on page 35.
Chapter 1. Managing reservations and reservable resources

You use the IBM® TRIRIGA® Workplace Reservation Manager application to manage the reservations of shared rooms such as meeting spaces and workspaces, shared equipment such as projectors, and shared vehicles. You can request a reservation as a self service user, create a reservation as a help desk agent, and process requests as an event center coordinator. You can incorporate service providers such as food service vendors, and work tasks such as room setup, room breakdown, equipment delivery, and equipment pickup. For added flexibility in reserving rooms, you can also integrate the application with Microsoft Exchange and Microsoft Outlook.
Chapter 2. Overview of reservation management

To manage your reservations and reservable resources with the IBM TRIRIGA Workplace Reservation Manager application, you must understand the reservation types in your company practices. You must also understand the application portals that are available to your company role.

Reservation types

From setting up the application to creating a reservation, there are many types of reservation request classifications, reservation classes, and reservation forms. The reservation request class defines which work tasks are generated for a reservation. The reservation class defines which spaces require approval, and which roles can reserve them. The reservation form defines which tabs, sections, and fields are necessary for the request or resource.

Reservation request classes

During the reservations setup, the application contains several main reservation request classifications to drive the work task process. For each request class, the service plan is defined. Then, for each service plan, the work task templates are defined. The work task templates contain the task details that are applied when work tasks are created for a reservation. The reservation request classes include the following types:

<table>
<thead>
<tr>
<th>Reservation request class</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meeting space reservation</td>
<td>This request class drives the work task templates for room setup, room breakdown, and room cleanup.</td>
</tr>
<tr>
<td>Workspace reservation</td>
<td>Unlike the request class for the meeting space, this request class does not drive the room setup, room breakdown, and room cleanup.</td>
</tr>
<tr>
<td>Asset reservation</td>
<td>This request class drives the work task templates for equipment delivery and equipment pickup.</td>
</tr>
<tr>
<td>Vehicle reservation</td>
<td>This request class drives the work task templates for vehicle delivery and vehicle pickup.</td>
</tr>
</tbody>
</table>

Reservation classes

Also, during the reservations setup, the Space form is used to identify the class of the reservable space. The reservation classes include the following types:

<table>
<thead>
<tr>
<th>Reservation class</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Private space</td>
<td>This space can be reserved by the Reservation Coordinator through the Concierge Reservation form only.</td>
</tr>
<tr>
<td>Requestable space</td>
<td>This space can be reserved by any role, but the reservation requires approval by the Resource Owner.</td>
</tr>
<tr>
<td>Reservable space</td>
<td>This space can be reserved by any role, but the reservation does not require approval by the Resource Owner.</td>
</tr>
</tbody>
</table>
Reservation forms

Creating a reservation involves several similar forms, but each form is specific to a particular request or resource. Depending on your role, the reservation forms include the following types:

<table>
<thead>
<tr>
<th>Form</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Request for Reservation</td>
<td>This form serves a particular self-service scenario. If your role is required to submit requests to a Reservation Coordinator, you can request to reserve available meeting spaces, workspaces, equipment, and vehicles.</td>
</tr>
<tr>
<td>Concierge Reservation</td>
<td>This form serves the concierge scenario. If you want to reserve a private space, you can call the Reservation Coordinator. Then, the Reservation Coordinator can submit a private space reservation through this form.</td>
</tr>
<tr>
<td>Room Reservation</td>
<td>This form serves a typical self-service scenario for many roles. You can select one or more rooms for the reservation. If a food or equipment service provider is associated with the meeting space, you can add a food or equipment order with the room reservation.</td>
</tr>
<tr>
<td>Equipment Reservation</td>
<td>This form serves a typical self-service scenario for many roles. You can select one or more equipment items for each equipment order.</td>
</tr>
<tr>
<td>Vehicle Reservation</td>
<td>This form serves a typical self-service scenario for many roles. You can select one or more vehicles for each vehicle order.</td>
</tr>
</tbody>
</table>

Reservation roles

When you sign into the application, you are taken to your home page. Your home page is your entrance into the application. From your home page, you can review your home portal or use the menu system to open the process portals available to your role. Use your menu bar to open other available portals. Based on your role, your application might consist of one or many portals.

The setting of the IBM TRIRIGA home page is set in the Default Portal section of your profile record. Your home portal or process portals might vary, based on your role in the company and your security and license access. However, your portals contain a combination of the components and section types described in this discussion.

In turn, each portal consists of portal sections. Each portal section serves a specific function and shows the information that applies to your business role. The portal sections in your portal are configured by your application administrator for your role in the system.

Application administrator

The application administrator is the user role that typically sets up and configures the application.

The primary responsibility of the application administrator is to manage the IBM TRIRIGA application for the company. This responsibility includes creating and managing licenses and security groups, setting up user access, and maintaining system-level and application-level standards such as classification and list values.
When you sign in as an Application Administrator role, the home portal is the Application Administrator portal. An example of the Application Administrator portal includes the following portal sections:
- Reminders – Application Administrator
- Last Visited
- Application Administration
- License and Security
- Application Administration - Utilities

**Request central role**

The self-service requestor is the user role that typically submits and monitors requests in the application.

The primary responsibility of the self-service requestor is to submit requests as needed with the IBM TRIRIGA application. This responsibility includes locating the spaces that are affected by service requests, viewing the calendar to request reservations, and monitoring the status of active requests. In the application, the Request Central role is tailored for the self-service requestor.

When you sign in as a Request Central role, the home portal is the Request Central portal. An example of the Request Central portal includes the following portal sections:
- Request Central
- Related Links - Request Central
- Last Visited
- Reminders – Request Central
- My Active Requests
- My Calendar
- My Reservations
- Locate Space

**Contact center agent**

The contact center agent is the user role that typically takes help-desk calls from employees, and specifies the call details in the application.

The primary responsibility of the contact center agent is to take help-desk calls from company employees. This responsibility includes specifying the call details in the IBM TRIRIGA application, and attempting to resolve issues during the call so that service requests can be avoided. Other responsibilities include updating the callers with the status of the service requests.

When you sign in as a Contact Center Agent role, the home portal is the Contact Center portal. An example of the Contact Center portal includes the following portal sections:
- Reminders – Contact Center
- Related Links – Contact Center
- Last Visited
- Follow-Up Tasks
- My Call Records
Reservation coordinator

The reservation coordinator is the user role that typically manages reservable rooms and their related services in the application.

The primary responsibility of the reservation coordinator is to manage a portfolio of reservable rooms in the IBM TRIRIGA application. This responsibility includes setting up the reservable room types, room layout options, and service contracts, and monitoring the delivery and pickup of food and equipment orders. Other responsibilities include serving as a concierge for private rooms, taking caller requests for reservations, and analyzing utilization metrics to optimize reservable space and equipment.

When you sign in as a Reservation Coordinator role, the home portal is the Reservation Coordinator portal. An example of the Reservation Coordinator portal includes the following portal sections:

- Reminders – Reservation Coordinator
- Performance Metrics – Reservation Coordinator
- Related Links – Reservation Coordinator
- My Meeting Spaces
- My Hoteling Spaces
- Reservation – Room Utilization
- Reservation – Equipment Utilization

© Copyright IBM Corp. 2011, 2014
Chapter 3. Setting up reservations

Before the reservation process begins, certain activities are necessary to prepare the application for your room reservations, equipment reservations, and vehicle reservations. These setup activities include editing the details of a reservable room, such as its name, layout, reservation type, calendar, group, and room services. The reservation type determines whether the room is a private, requestable, or reservable room. The reservation calendar defines the working hours and non-working events for the room. The reservation group defines the members who can manage the room.

Reservation Space Groups

A reservation space group combines two or more individual spaces to make one larger space, which can have a greater capacity than the individual spaces.

The following information applies to reservation space groups:
- Reservation space groups can be used only for single reservations, not for series reservations.
- Reservation space groups can be used only for reservations that are created in IBM TRIRIGA, not for reservations that are created in Microsoft Outlook.
- Reservation space groups are not available in IBM TRIRIGA CAD Integrator/Publisher.
- The spaces that are included in a reservation space group are called dependent spaces.
- When a reservation space group is booked for a reservation, the dependent spaces are also booked. The dependent spaces are managed by IBM TRIRIGA and are not visible to the person who makes the reservation.
- When a space that belongs to a reservation space group is booked, all of the reservation space groups that the space belongs to are also booked. The additional bookings are managed by IBM TRIRIGA and are not visible to the person who makes the reservation.
- Reservation space groups are not included in utilization metrics.
- After reservation space groups are created, they can be managed in the Location hierarchy or in the Reservation Space Groups form.

Setting up application settings

Use your application settings to specify the service activation durations, tentative booking durations, and projector specification classes. You can also specify the colors to use in calendar views for declined and dependent resource reservations. If the IBM TRIRIGA Workplace Reservation Manager application is integrated with Microsoft Exchange, specify the Microsoft Exchange properties.

Before you begin

You must sign in as an Application Administrator or Reservation Coordinator.
**Procedure**

1. Select **Tools > System Setup > General > Application Settings**.
2. In the **Reservation Settings** tab, specify the settings.
3. Save the record.

---

### Setting up reservation calendars

Use your reservation calendars to specify the working hours and non-working events for your reservable resources. After you activate your calendars, open each reservable resource to select its calendar.

**Before you begin**

You must sign in as an Application Administrator or Reservation Coordinator.

**Procedure**

1. Select **Tools > System Setup > General > Calendars**.
2. Click the **Add** action and select the **Reservation Calendar** option.
3. Specify the details.
4. Create the draft.
5. Activate the record.

---

### Setting up work task templates

Use your work task templates to specify the task details that are applied when work tasks are created for a reservation. The application contains several main reservation request classifications: meeting space, workspace, asset, and vehicle. For each request class, define the service plan. Then, for each service plan, define the work task templates.

**Before you begin**

You must sign in as an Application Administrator or Reservation Coordinator.

**Procedure**

1. Select **Tools > Administration > Classifications**.
2. In the classification hierarchy, select **Request Class > Reservations**.
3. Open the reservation request class.
4. Open the service plan.
5. Add or edit the work task template.
6. Specify the details.
7. Save the template.

---

### Setting up blanket purchase orders

Use your blanket purchase orders to specify the food services for your reservable spaces. After you activate your blanket purchase orders, open each reservable space to select its food service contracts.

**Before you begin**

You must sign in as an Application Administrator or Reservation Coordinator.
Procedure
1. Select Contracts > Contracts > Blanket Purchase Orders.
2. Click the Add action.
3. Specify the details, including the details for each product and service.
4. Create the draft.
5. Activate the record.

Setting up resource entitlements
Use your resource entitlements to specify the functional role of each user, and the reservable resources that each role is entitled to reserve. For each person, define the functional role. For each reservable resource, define the resource specification. Then, for each resource specification, define the functional roles that have entitlements.

Before you begin
You must sign in as an Application Administrator or Reservation Coordinator.

Procedure
1. Select Portfolio > People, then select a people type. The people type can be employees, consultants, or external contacts.
2. Open the people record.
3. Specify the functional role.
4. Activate the people record.
5. Open the resource record.

<table>
<thead>
<tr>
<th>Resource</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workspace</td>
<td>Select Portfolio &gt; Locations &gt; Spaces. Open the space record. In the Reserve tab, verify that the workspace is selected for the Room Type field. Select the space standard specification for the Work Space Entitlement field. Open the linked space standard specification.</td>
</tr>
<tr>
<td>Equipment item or vehicle</td>
<td>Select Portfolio &gt; Assets, then select an asset type. Open the asset record. In the General tab, open the linked specification.</td>
</tr>
</tbody>
</table>

6. In the specification record, specify the entitlements.
7. Activate the specification record.
8. Activate the resource record.

Setting up inventory items
Use your inventory items to create the reservable assets when the items are received in inventory. To set up inventory, define the primary locations with their equipment and buildings. For each primary location, define the storage areas. For each inventory item, define the equipment specification, primary location, and storage area. Then, receive the items into inventory to create the assets. Finally, open each asset to define it as reservable.

Before you begin
You must sign in as an Application Administrator or Inventory Manager.
Procedure

1. Select Inventory > Manage Inventory > Inventory Locations.
2. In the inventory locations hierarchy, create or open a primary location.
3. In the Service Locations tab, specify the equipment and buildings.
4. Activate the record.
5. In the inventory locations hierarchy, create or open a storage area under a primary location.
6. Activate the record.
7. Select Inventory > Manage Inventory > Items.
8. Click the Add action.
9. Specify the equipment specification, primary location, and storage area.
10. In the Inventory Type field, select the reservable asset.
11. Select the Create Asset on Receipt check box.
12. Click the Order/Receipt action.
13. In the Transaction Type field, select the inventory received.
14. Confirm that the Create Asset on Receipt check box is still selected.
15. Click the Post action.
16. In the Asset Details tab, open each asset record.
17. In the General tab, select the Reservable check box.
18. In the Reserve tab, specify the details.
19. Activate the record.

Setting up assets

Use the Reserve tab of the Asset form to specify the reservation details for the equipment item, vehicle, or other asset.

Before you begin

You must sign in as an Application Administrator or Reservation Coordinator.

Procedure

1. Select Portfolio > Assets, then select an asset type.
2. Open the asset record.
3. In the General tab, select the Reservable check box.
4. In the Reserve tab, specify the details.
5. Activate the record.

Setting up spaces

Use the Reserve tab of the Space form to specify the room name, room layout, reservation type, room services, and other reservation details for the space.

Before you begin

You must sign in as an Application Administrator or Reservation Coordinator.
Procedure
1. Select Portfolio > Locations > Spaces.
2. Open the space record.
3. In the General tab, select the Reservable check box.
4. In the Reserve tab, specify the details.
5. Activate the record.

Setting up reserve bulk updates
Use the bulk update process to update the reservation details for multiple reservable resources at a time, without leaving the process form. These reservable resources can include rooms, equipment, or vehicles.

Before you begin
You must sign in as an Application Administrator or Reservation Coordinator.

Procedure
1. Select Requests > Set Up > Reserve Bulk Update.
2. In the Rooms tab, specify the details.
3. Select the reservable rooms, and click the Update action.
4. In the Assets tab, specify the details.
5. Select the reservable equipment or vehicles, and click the Update action.

Setting up reservation groups
Use your reservation groups to specify the rooms that the group manages, and members of the group. After you save your groups, each reservable room shows its selected group.

Before you begin
You must sign in as an Application Administrator or Reservation Coordinator.

Procedure
1. Select Requests > Set Up > Reservation Group.
2. Click the Add action.
3. Specify the details.
4. Create the record.

Setting up reservation space groups
To create a reservation space group, you specify the reservable spaces that are part of the reservation space group.

Before you begin
You must sign in as an Application Administrator or Reservation Coordinator.
About this task

Procedure
1. In the Location hierarchy, select a building and floor for the reservation space group.
2. In the Hierarchy menu, select New > Reservation Space Group.
3. In the General tab, name the reservation space group, select Reservable, and select the spaces for the reservation space group.
4. In the Reserve tab, specify the details and click Create Draft.
5. Click Activate.

Setting up resource downtime

Use your resource downtime records to specify the reason, duration, and resources that are going offline. After you activate your records, edit any affected reservations.

Before you begin

You must sign in as an Application Administrator or Reservation Coordinator.

Procedure
1. Select Requests > Manage Reservations.
2. In the Related Links portal section, select Administration > Resource Downtime.
3. Click the Add action.
4. Specify the details.
5. Create the draft.
6. Activate the record.

Setting up reservation policies

Use your reservation policies to specify how far in the future a set of rooms can be reserved, and which users can make the future reservations. For example, a company can use reservation policy records to allow advance booking by selected administrative assistants before the rooms are opened for booking by general users. Reservation policy records can also be used to designate specific rooms for specific users such as to secure a block of rooms for the use of a specific product team. After the policy time period ends, the rooms are available for other users to reserve.

Before you begin

You must sign in as an application administrator or reservation coordinator.

About this task

Reservation policy records for a specific room cannot have overlapping times. Only the specified users can make reservations within the policy time period. In the Available Rooms section, other users can see the rooms with effective reservation policies. However, when they try to book a room with an effective reservation policy, a notification informs them that the room is restricted. If no users are specified, the rooms are available to all users during the policy time period.
Reservation policies that are in an Active or Revision in Process status are in effect; reservation policies in a Draft status are not in effect.

**Procedure**

1. Select Requests > Set Up > Reservation Policies.
2. Click the Add action.
3. Specify the details.
4. Create the record.

---

**Implementing a defined search for a reservation query**

The number of results from a reservation query can be limited. For example, you can specify that the reservation query stops processing after returning 10 results. Limiting the number of results reduces the time that is required to run a reservation query.

**About this task**

To set up the defined search, you modify the related business object and the form to include a triAvailabilityResultsLimitNU field. If the value of the triAvailabilityResultsLimitNU field is zero or less, or if the field does not exist, the defined search feature is disabled. The specified number of results are returned in random order.

**Procedure**

1. Add a triAvailabilityResultsLimitNU field to the contextual business object of the reservation query and publish the business object.
2. Add the triAvailabilityResultsLimitNU field to the form and publish the form.
3. To define the result set of a reservation query, specify the maximum number of results in the field on the form.
Chapter 4. Reserving rooms, equipment, and vehicles

You can create reservations for yourself or for someone else. Alternatively, you can request that someone else create reservations for you. To save time, you can set your preferences for payment method, meeting spaces, workspaces, and vehicles.

Reservations

There are several different methods of creating reservations that depend on your role. These roles include the Request Central role, Contact Center Agent, Reservation Coordinator, and Microsoft Outlook user. Regardless of the method that you use, these different reservation methods trigger the same set of business rules for the booking status and work tasks.

Reservation creation process flow

Figure 1. Flow diagram for creating the different types of reservations

Reservation roles and scenarios

Although the different methods of creating reservations are similar, the differences come from the varying portals and processes that the reservation roles use.

<table>
<thead>
<tr>
<th>Role</th>
<th>Scenario</th>
</tr>
</thead>
<tbody>
<tr>
<td>Request Central role</td>
<td>This role signs into the Request Central portal. In this self-service scenario, the Request Central role creates a reservation, specifies the details, and submits the reservation. The active request becomes visible to all of the Reservation Coordinators who manage the reservable spaces within the requested building.</td>
</tr>
<tr>
<td>Role</td>
<td>Scenario</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Contact Center Agent</td>
<td>This role signs into the Contact Center Agent portal and processes caller requests to reserve non-private rooms. In this help-desk scenario, the Contact Center Agent answers a call, creates a reservation, specifies the call details, and submits the reservation for the caller.</td>
</tr>
</tbody>
</table>
| Reservation Coordinator | This role signs into the Reservation Coordinator portal.  
  • The first scenario processes online requests for reservations. In this request scenario, the Reservation Coordinator receives a request, creates a reservation, specifies the request details, and submits the reservation for the requestor.  
  • The second scenario processes caller requests to reserve private rooms. In this concierge scenario, the Reservation Coordinator answers a call, creates a reservation, specifies the call details, and submits the reservation for the caller. |
| Microsoft Outlook user | If the IBM TRIRIGA Workplace Reservation Manager application is integrated with Microsoft Exchange, this user opens Microsoft Outlook. In this self-service scenario, the user creates a reservation, specifies the details, and submits the reservation. |

**Reservation creation**

Creating a reservation triggers the following business rules:

- When you add rooms to the reservation before you submit the reservation, the booking status of each added room changes to Tentative. If the added rooms are still available after you submit the reservation, the booking status of each added room changes from Tentative to Accepted.
- If a room layout includes a setup time and breakdown time, these times are blocked off as busy periods before and after the reservation duration. Work tasks are also created for room setup and room breakdown.
- If you order food services, a purchase order record is created.
- If you reserve equipment or order equipment services, the equipment is reserved for the same reservation duration. Work tasks are also created for equipment delivery and equipment pickup.
- If you reserve vehicles, the vehicles are reserved for the same reservation duration. Work tasks are also created for vehicle delivery and vehicle pickup.

**Reservation change**

Changing a reservation triggers the following business rules:

- When you add rooms to the reservation before you submit the reservation, the booking status of each added room changes to Tentative. If the added rooms are still available after you submit the reservation, the booking status of each added room changes from Tentative to Accepted.
- If a room layout includes a setup time and breakdown time, these times are blocked off as busy periods before and after the edited reservation duration. The original work tasks are also retired and different work tasks are created for room setup and room breakdown.
- If you order food services, the original purchase order record is retired and a different purchase order record is created.
• If you reserve equipment or order equipment services, the equipment is reserved for the edited reservation duration. The original work tasks are also retired and different work tasks are created for equipment delivery and equipment pickup.
• If you reserve vehicles, the vehicles are reserved for the edited reservation duration. The original work tasks are also retired and different work tasks are created for vehicle delivery and vehicle pickup.

**Reservation cancellation**

Canceling a reservation triggers the following business rules:
• If a room layout includes a setup time and breakdown time, the work tasks are retired for room setup and room breakdown.
• If you cancel food services, the purchase order record is retired.
• If you cancel equipment or equipment services, the work tasks are retired for equipment delivery and equipment pickup.
• If you cancel vehicles, the work tasks are retired for vehicle delivery and vehicle pickup.

**Creating reservations**

Use your calendar to reserve available meeting spaces, workspaces, equipment, and vehicles. If a food or equipment service provider is associated with the meeting space, you can add a food or equipment order with the room reservation.

**Before you begin**

You must sign in as a Request Central role, Contact Center Agent, or Reservation Coordinator. If you are a Microsoft Outlook user, the IBM TRIRIGA Workplace Reservation Manager application must be integrated with Microsoft Exchange.

**Procedure**

1. Create the reservation.

<table>
<thead>
<tr>
<th>Role</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Request Central role</td>
<td>In the Request Central portal section, select <strong>Reservations &gt; My Calendar</strong>. In the Calendar section, select the day to create the reservation.</td>
</tr>
<tr>
<td>Contact Center Agent</td>
<td>Select <strong>Requests &gt; Contact Center</strong>. In the Calendar section, click the <strong>Create Reservation</strong> action.</td>
</tr>
<tr>
<td>Reservation Coordinator (request scenario)</td>
<td>Select <strong>Requests &gt; Manage Reservations</strong>. In the Requested For section, select the requestor. In the Calendar section, select the day to create the reservation.</td>
</tr>
<tr>
<td>Reservation Coordinator (concierge scenario)</td>
<td>Select <strong>Requests &gt; Manage Reservations &gt; Concierge</strong>.</td>
</tr>
<tr>
<td>Microsoft Outlook user</td>
<td>In a new appointment or meeting, select the <strong>IBM TRIRIGA Reserve</strong> option.</td>
</tr>
</tbody>
</table>

2. Specify the details.
<table>
<thead>
<tr>
<th>Section</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reservation For</td>
<td>Select the requestor who is making the reservation request, such as yourself or someone else. If you select the latter option, the form shows the Requested For section and Requested By section. The form shows this Reservation For section if you are selected by another user to be a reservation delegate for that user.</td>
</tr>
<tr>
<td>Requested For</td>
<td>Select the name of the indirect requestor for the reservation.</td>
</tr>
<tr>
<td>Requested By</td>
<td>Select the name of the direct requestor for the reservation.</td>
</tr>
<tr>
<td>Reservation Details</td>
<td>Specify the subject, duration, and recurrence for the reservation.</td>
</tr>
<tr>
<td>Search Criteria</td>
<td>For room and concierge reservations, identify the criteria for the room search.</td>
</tr>
<tr>
<td>Select Pickup Location</td>
<td>For equipment and vehicle reservations, identify the city, site, and building for pickup.</td>
</tr>
</tbody>
</table>

3. View the available rooms, equipment items, or vehicles.
4. Add one or more rooms, equipment items, or vehicles.
5. Save the reservation.
6. Submit the reservation.

### Creating recurring reservations

Recurring reservations can reserve spaces, equipment, and food services for a series of meetings. If the selected space is not available for every occurrence of the series, the selected space is placed on hold for the available times, and the exceptions are displayed. You can assign available alternate spaces to the exceptions.

### About this task

You can manually assign an available room to an exception or have IBM TRIRIGA automatically assign available rooms to any or all of the exceptions. For the automatic assignment, if no rooms are available on the same floor as the room that is on hold, the search expands to spaces in the same building. If there are no available rooms in the same building, the search expands to spaces in the same property.

By default, up to two months of exceptions are displayed. You can change the search duration in the Exception Check Duration field that is in the Reservation Settings tab in the Application Settings form.

### Procedure

1. In the Request Central portal section, select My Calendar.
2. In the Calendar section, select the day to start the recurring reservation and click Create.
3. In the Reservation Details section of the Room Reservations form, specify the reservation type and the subject.
4. Click Recurrence.
5. In the Recurrence tab, specify the details about the recurrence and click Save Recurrence.
6. In the Search Criteria, specify the room search criteria.
7. Select a room and click **Book Selected Room(s)**.
8. If the room you selected is not available for all of the occurrences, in the
   Exceptions section, assign the room exceptions to alternate rooms and click
   **Accept Assignments**.
9. Review the reservation details and click **Submit**.

**What to do next**

If the recurring reservation has exceptions, and if food services or equipment is
needed for the exceptions, you reserve those items manually. In the calendar view,
open each exception and make the food services or equipment reservations for
each exception.

### Requesting reservations

If your role is required to submit requests to a Reservation Coordinator, you can
request to reserve available meeting spaces, workspaces, equipment, and vehicles.

**Before you begin**

You must sign in as a Request Central role.

**Procedure**

1. Go to the Request Central portal section.
2. Select **Reservations > Request for Reservation**.
3. Specify the details.
4. Create the draft.
5. Submit the request.

### Setting reservation preferences

To save time, you can set your preferences for payment method, meeting spaces,
workspaces, vehicles, and delegates in your profile record. When you reserve
rooms, equipment, and vehicles, these preferred settings are displayed by default.
When you select delegates, these people can create reservations in their calendars
for you.

**Before you begin**

You must sign in as a Request Central role, Contact Center Agent, or Reservation
Coordinator.

**Procedure**

1. Click the **Welcome, User Name** link.
2. In the **Preferences** tab, specify your preferences.
3. Save the record.

### Examples of reserving resources in Microsoft Outlook

In Company ABC, IBM TRIRIGA Workplace Reservation Manager is integrated
with Microsoft Exchange and Microsoft Outlook. In Microsoft Outlook, users can
create appointments and use IBM TRIRIGA forms to reserve company resources.
Company resources can include rooms, workspaces, catering, and equipment such
as projectors and video conferencing. Depending on their IBM TRIRIGA user role, users can make and manage reservations of common or private resources for themselves or for other company employees.

Creating a quick meet reservation in Microsoft Outlook

Microsoft Outlook users who need to reserve a room on short notice can quickly set up an appointment, select the attendees, reserve the room, and send the reservation information to the attendees. Typically, the users know which room to reserve, and there are no requirements for other resources such as food or equipment.

Background

Anita is a Microsoft Outlook user who is asked by her manager to find a room for an immediate staff meeting. She is familiar with the rooms in the Grand Avenue building, and she wants to book the Green Room for a one-hour meeting.

Step 1: Create the appointment

Anita opens the Microsoft Outlook application, opens a new appointment, and specifies the appointment time. In the Scheduling Assistant, she specifies the attendees and includes the Green Room as an attendee. The Microsoft Outlook appointment process searches for the Green Room availability information in the IBM TRIRIGA environment.

Step 2: Select the room

Anita checks the availability view to see when the Green Room is available. She can view the room availability as either a GANTT chart or as a graphic interface. If the Green Room is available at the specified appointment time, she selects the room. If the Green Room is not available, she slides the start and end bars to an available time and selects the room.

Step 3: Send the appointment

Anita sends the appointment invitation. If there are room charges, she specifies the payment information for the charges and submits the information. Microsoft Outlook adds the appointment to Anita’s Microsoft Outlook calendar and sends the invitations to the attendees. TRIRIGA Workplace Reservation Manager creates a reservation record in the IBM TRIRIGA environment and adds the reservation to Anita’s My Calendar portal. She does not need to interact with the IBM TRIRIGA reservation. She can continue to manage the appointment in Microsoft Outlook.

Reserving rooms and services in Microsoft Outlook

A meeting at an international company might require the reservation of multiple conference rooms at different geographical locations. Each location might have requirements for other company resources such as food services and equipment for the selected rooms. In Microsoft Outlook, authorized users can search for and reserve available resources that are based on their specified criteria by using the IBM TRIRIGA reservation form. Typically, the users are not familiar with the available rooms and need to compare the rooms to know which rooms to select.
Background

Anita is a Microsoft Outlook user who wants to create a reservation for two rooms that require food and equipment services. She wants to make arrangements for a four-hour meeting to occur next week. The meeting includes 10 people in the Dallas office and 5 people in the London office. The meeting requires computer projection equipment and a catered meal at both locations, plus a dial-in number and a video conference URL. The administrative rights that the system administrator set for Anita allow Anita to view and create appointments for every employee in the department.

Step 1: Create the appointment

Anita opens Microsoft Outlook to check the schedules of the required attendees. She creates an appointment for the meeting, and she attaches a Microsoft Word file of the agenda to the appointment.

Step 2: Search for the rooms

Anita selects the IBM TRIRIGA Reserve option to open the IBM TRIRIGA reservation form in the Microsoft Outlook appointment. She selects the main corporate campus in Dallas. She begins a search that includes the room and the services criteria:

- Meeting date, which is populated from the Microsoft Outlook appointment
- Meeting time period
- Number of attendees: 10
- Room layout: Round table
- Catering available: Yes
- Network connection: Yes
- Telephone conference: Yes
- Video conference: Yes
- Whiteboard: Yes

Step 3: Review the room results

After Anita specifies the criteria for the Dallas office, the search results include three rooms in the list view. She is familiar with the Orange Room conference room, but she checks the other two rooms to make sure that they are appropriate for the meeting. She selects the Green Room conference room, and she views images of the room. She sees a graphic view of the Green Room conference room in the floor plan view.

Step 4: Compare the room results

Anita thinks that the Green Room conference room might be too small for the meeting, so she reviews the Blue Room conference room. To help her decide, she selects the comparison view so that she can look at the characteristics of all three rooms at the same time.

Step 5: Select the room for the first location

Anita decides to reserve the Orange Room conference room because she is familiar with it. When she books the Orange Room conference room, TRIRIGA Workplace Reservation Manager tentatively reserves the room while she completes the rest of the reservation process.
the meeting appointment. The tentative reservation prevents other employees from
reserving the same room for the same time. TRIRIGA Workplace Reservation
Manager also adds the selected room to the Microsoft Outlook availability view.

Step 6: Select the room for the second location

Anita searches for, reviews, compares, and selects a room for the London office.
TRIRIGA Workplace Reservation Manager adds the selected room to the Microsoft
Outlook availability view.

Step 7: Add resources to the first room

Anita notices that more equipment is needed for the Orange Room conference
room because a computer projector is not standard equipment for that room. She
opens the equipment order view in the Orange Room reservation, and she selects
an available projector. Anita also needs food service for lunch and snacks in the
Orange Room conference room. She opens the food order view that displays the
available catering options. She selects the food service provider and menu items,
and she reviews the service times and costs.

Step 8: Add resources to the second room

Anita adds a computer projector and food services to the reservation for the room
in the London office. TRIRIGA Workplace Reservation Manager manages the time
zone difference.

Step 9: Send the appointment

Anita sends the Microsoft Outlook appointment invitation. She reviews the costs of
the room usage fees, equipment usage fees, food orders, and any alternate room
layout costs. She specifies the account code to use to pay the costs. TRIRIGA
Workplace Reservation Manager processes the Microsoft Outlook appointment:
• The tentatively reserved status of the resources is changed to a permanently
  accepted status
• The work tasks for the room setup and the room breakdown are created
• The work tasks for equipment delivery and equipment pickup are created
• The purchase orders for food services are created

Step 10: Confirm the reservation

At a predefined time before the meeting appointment, Anita receives an email
request to confirm that the appointment is still valid. The email contains the
actions that she uses to respond directly from the email. The actions include
buttons to confirm or cancel the reservation. Anita confirms the reservation.

Step 11: Free the rooms when the meeting ends early

The meeting does not last the scheduled four hours, so Anita opens the Microsoft
Outlook reservation and clicks a button in the IBM TRIRIGA Reserve option to
end the reservation early. The early checkout frees the room for other employees to
reserve.
Step 12: Receive the survey

After the meeting concludes, Anita receives a satisfaction survey about the reservation process and the reservation experience.

Reserving a workspace in Microsoft Outlook

Employees who travel to a different company location might need to reserve a workspace to use while they are in the alternate location. In Microsoft Outlook, users can search for and reserve an available workspace that is based on their specified criteria by using the IBM TRIRIGA reservation form.

Background

Sam plans to travel to the Dallas office for an important meeting in the Grand Avenue building. Sam wants to reserve a workspace so that he can work from the Grand Avenue building while he is there. Sam knows that workspaces must be reserved and that employees can reserve only the workspaces that match their functional role.

Step 1: Create the appointment

Sam opens the Microsoft Outlook application and opens a new appointment. Sam specifies the appointment information and the dates that he plans to be in the Grand Avenue building.

Step 2: Search for a workspace

Sam opens the IBM TRIRIGA reservation form in the Microsoft Outlook appointment and specifies that the search is for a workspace.

Step 3: Select the workspace

Sam selects the Grand Avenue building location. Sam views the workspaces that are available for the specified time frame and for his functional role. Sam selects and reserves a workspace. TRIRIGA Workplace Reservation Manager adds the selected workspace to the Microsoft Outlook availability view.

Step 4: Check in to the workspace

The TRIRIGA administrator configured the workspace that Sam reserved with a requirement that a user must check in to the workspace before the reservation start time. Sam receives an email reminder about the check-in policy before the start time of the reservation. He clicks the link in the email to trigger the check-in action.

Step 5: Check out of the workspace

When Sam finishes using the workspace, he opens the reservation in Microsoft Outlook and selects the checkout action. If Sam does not check out, the checkout action occurs at the end time of the reservation.
Examples of reserving resources in IBM TRIRIGA

In Company ABC, IBM TRIRIGA Workplace Reservation Manager is integrated with Microsoft Exchange and Microsoft Outlook. Depending on their user role, users can make and manage reservations of common or private company resources for themselves or for other company employees. Company resources can include rooms, workspaces, catering, vehicles, and equipment such as projectors and video conferencing.

Reserving common resources in IBM TRIRIGA

IBM TRIRIGA Request Central users who need to reserve common company resources can use IBM TRIRIGA Workplace Reservation Manager to reserve the resources. The reservation process generates an email notification with the reservation information to the person for whom the reservation was made.

Background

Betty is an administrative assistant for a business unit in Company ABC. She needs a meeting room for one hour to interview a potential new hire.

Step 1: Create the appointment

From the Request Central portal in IBM TRIRIGA, Betty opens her My Calendar portal, selects the meeting date, and selects Create.

Step 2: Search for the rooms

Betty specifies the information for the meeting:

- Reservation type: Location
- Subject: Interview new hire
- Start and end date and time
- Room type: Meeting space
- Room layout: Conference

Step 3: Reserve the room

The search results include three rooms in the list view. Betty prefers to schedule interviews close to the elevator lobby, so she switches to the floor plan view. Betty selects a meeting room close to the lobby and reserves the room.

Step 4: Add a food order

Betty reviews the reservation summary and decides to add a food order to the reservation. Catering services are available for the reserved room. She selects the food order view, reviews the available menu items, selects bottled water, saves the food order, and returns to the reservation summary.

Step 5: Submit the reservation

Betty submits the room reservation. If there are estimated charges for this reservation, Betty reviews the charges, specifies the credit card information to use, and submits the payment information.
TRIRIGA Workplace Reservation Manager adds the reservation to Betty’s My Calendar portal and sends an email to Betty with an iCalendar (iCal) event attached. The .iCal attachment includes the information from the IBM TRIRIGA reservation. When Betty opens and saves the attachment, the reservation is added to her Microsoft Outlook calendar.

**Optional: Step 6**

If the reservation needs to be modified or deleted, the changes must be made in the IBM TRIRIGA environment.

**Reserving private resources in IBM TRIRIGA**

Private rooms can be reserved only by IBM TRIRIGA Request Central Concierge user types who own the rooms. Concierge users reserve private resources on the behalf of other employees.

**Background**

Kathy manages a group of private spaces in the North Carroll building of Company ABC. A company executive calls to request that Kathy book a private room with equipment and food services for a recurring meeting.

**Step 1: Create the appointment**

Kathy opens the Concierge form from her IBM TRIRIGA home page, and she specifies the caller’s general information and the reservation details. She opens the Recurrence view, specifies the details for the recurring meeting, and saves the recurrence.

**Step 2: Search for the room**

Kathy specifies the North Carroll building and the meeting space criteria that is based on the caller’s needs:
- Number of attendees: 5
- Room layout: Round table
- Catering available: Yes
- Network connection: Yes
- Video conference: Yes

**Step 3: Select the room**

Kathy selects and books an available private room from the list view of the rooms that she is responsible for. The room is tentatively reserved while she completes the reservation.

**Step 4: Add a food order**

Kathy opens the food order view, selects the food service provider and menu items, and reviews the service times and costs. Kathy saves the food order and returns to the reservation summary.
Step 5: Submit the reservation

Kathy submits the reservation. If there are room, equipment, or food service charges, Kathy specifies the caller’s account code, and submits the payment information. TRIRIGA Workplace Reservation Manager creates a reservation record, changes the resource status to accepted, and generates an email to the caller who requested the reservation. The email includes an iCalendar (iCal) event that contains the reservation information. When the user opens the .iCal attachment in Microsoft Outlook, the reservation is placed on the user’s Microsoft Outlook calendar.

Step 6: Modify the reservation

Kathy receives a request to ensure that a projector is available for the second meeting in the series. In the IBM TRIRIGA environment, Kathy opens the Concierge form, specifies the name of the person for whom the reservation was made, clicks the Calendar tab, and views a list of the requester’s reservations. Kathy left-clicks the reservation record for the second occurrence of the series and opens that occurrence. In the room reservation record, Kathy selects the equipment order view, selects an available projector, and saves the equipment order. She provides the caller’s payment information for the projector charges and saves the reservation. TRIRIGA Workplace Reservation Manager sends an email with an .iCal event attachment to the caller who requested the reservation.
Chapter 5. Integrating IBM TRIRIGA with Microsoft Exchange

To integrate the IBM TRIRIGA Workplace Reservation Manager application with Microsoft Exchange, you must configure connections in Microsoft Exchange and properties in IBM TRIRIGA.

**Microsoft Exchange configuration**

To forward mail from the Microsoft Exchange room resources to the IBM TRIRIGA application server, several different connections must be configured. After configuration, the mail is forwarded from the room resources to the room resource delegates, to the server hub transport, and finally to the application server.

**Server hub transport**

The Microsoft Exchange server hub transport must be configured. After the server hub transport is configured, its send connector routes the mail from the mail contact to the IBM TRIRIGA application server. The send connector must specify the following information:

- The fully qualified domain name (FQDN) that includes the preferred subdomain, for example, reserve.tririga.abc.tririga includes reserve.tririga; the IBM TRIRIGA administrator must define this subdomain in the TRIRIGA_RESERVE_SUB_DOMAIN property of the TRIRIGAWEB.properties file.
- The simple mail transfer protocol (SMTP) address space for the preferred subdomain, for example, *.reserve.tririga.abc.tririga.
- The mail-routing smart host with the IP address of the IBM TRIRIGA application server that runs the SMTP endpoint.

**Mail contacts**

The Microsoft Exchange mailbox must be configured for each mail contact. After the contact mailbox is configured, the mail is forwarded from the room resource delegates to the server hub transport. The mail contact must specify the email address that corresponds to the simple mail transfer protocol (SMTP) address space of the server hub transport.

To use the automated procedure, you can generate Windows PowerShell scripts in IBM TRIRIGA for Microsoft Exchange.

**Room resource delegates**

The Microsoft Exchange mailbox must be configured for each room resource delegate. After the delegate mailbox is configured, the delegate can be assigned to a room resource. Only one Microsoft Exchange mailbox is required for the delegate to be assigned to every room resource. This mailbox is used for the Exchange User Name field in the IBM TRIRIGA application settings.

**Room resources**

The Microsoft Exchange mailbox must be configured for each room resource. After the resource mailbox is configured, the resource can accept a delegate assignment.
With a delegate assignment, the free-busy information is synchronized between the Microsoft Exchange room resource and IBM TRIRIGA room. The room resource must specify the following information:

- The mail contact for the forwarding address.
- The selection to forward meeting requests to the delegate mailbox.
- The selection to give full-access permission to the delegate mailbox.

To use the automated procedure, you can generate Windows PowerShell scripts in IBM TRIRIGA for Microsoft Exchange.

### Configuring Microsoft Exchange

To integrate the IBM TRIRIGA Workplace Reservation Manager application with Microsoft Exchange, you must specify the settings for the Microsoft Exchange send connector, mail contact, and room resource delegates.

**Before you begin**

You must be a Microsoft Exchange administrator.

**Procedure**

1. Configure the server hub transport so that the send connector is set to route the mail from the mail contact to the IBM TRIRIGA application server.
2. For each mail contact, configure the mailbox so that mail is forwarded from the room resource delegates to the server hub transport.
3. For each room resource delegate, configure the mailbox so that the delegate can be assigned to a room resource.
4. For each room resource, configure the mailbox and assign the delegate so that the free-busy information is synchronized between the Microsoft Exchange room resources and IBM TRIRIGA rooms.

### Generating scripts in IBM TRIRIGA for Microsoft Exchange

If you add, update, or remove many reservable rooms in IBM TRIRIGA, then configuring the corresponding room resources in Microsoft Exchange can be time-consuming. To simplify the transfer of room changes, you can generate the Windows PowerShell scripts to create, update, or remove the corresponding room resources in Microsoft Exchange.

**Before you begin**

You must sign into IBM TRIRIGA as an Application Administrator or Reservation Coordinator.

**Procedure**

1. Select **Requests > Set Up > Exchange Resource Admin**.
2. Select the reservable spaces that you want to add, update, or remove.

<table>
<thead>
<tr>
<th>Section</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exchange Spaces</td>
<td>Select the reservable spaces that you want to add or update as room resources in Microsoft Exchange. If you do not select any reservable spaces, then all of the spaces are automatically included.</td>
</tr>
<tr>
<td>Section</td>
<td>Action</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Removed Exchange Spaces</td>
<td>Select the reservable spaces that you want to remove as room resources in Microsoft Exchange.</td>
</tr>
</tbody>
</table>

3. In the General section, generate the script file that creates, removes, or updates room resources.
4. Click the icon to download the script file.

**What to do next**

After you download the script file, the Microsoft Exchange administrator must process the script file to create, update, or remove the corresponding room resources.

**Creating room resources with multibyte characters**

You can generate a Windows PowerShell script to create room resources in Microsoft Exchange. However, if the room resource name and corresponding mailbox name have multibyte characters, the "create" script causes a parser error in the Exchange Management Shell. To correct this error, you must convert the script file format to UTF-8 encoding.

**Before you begin**

You must be a Microsoft Exchange administrator.

**Procedure**

1. Open the Windows PowerShell "create" script in a text editor such as Microsoft Notepad.
2. Go to File > Save As. Verify that the encoding is set to UTF-8.
3. Save and overwrite the same script file.
4. Run the script file again in the Exchange Management Shell. Although the multibyte characters are shown as question marks, the script runs successfully.

**Configuring IBM TRIRIGA**

To integrate the IBM TRIRIGA Workplace Reservation Manager application with Microsoft Exchange, you must specify the values for the IBM TRIRIGA domain, subdomain, and simple mail transfer protocol (SMTP) properties.

**Before you begin**

You must be an IBM TRIRIGA administrator.

**Procedure**

1. Verify that the incoming SMTP directory exists and the IBM TRIRIGA process has write access to the directory.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Example Directory</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>C:\tririga\install\userfiles\smtp\in\</td>
</tr>
<tr>
<td>UNIX</td>
<td>/tririga/install/userfiles/smtp/in/</td>
</tr>
</tbody>
</table>

2. Configure the following properties of the TRIRIGAWEB.properties file:
### Property Description

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TRIRIGA_RESERVE_SUB_DOMAIN</td>
<td>The subdomain for the Microsoft Exchange server, for example, reserve.tririga.</td>
</tr>
<tr>
<td>EXCHANGE_DOMAIN</td>
<td>The domain for the Microsoft Exchange server, for example, abc.tririga.</td>
</tr>
<tr>
<td>TRIRIGA_RESERVE_SMTP_ROOT</td>
<td>The simple mail transfer protocol (SMTP) root directory that is created when the reserve SMTP agent is started. For example, a Windows directory might be <code>C:\tririga\install\userfiles\smtp\in\</code>. A UNIX directory might be <code>/tririga/install/userfiles/smtp/in/</code>.</td>
</tr>
<tr>
<td>TRIRIGA_reserve_OUTLOOK_TAB_LABEL</td>
<td>The label that is displayed when a user connects the Microsoft Outlook client to the IBM TRIRIGA application server.</td>
</tr>
<tr>
<td>SMTP_CLIENT_TIMEOUT</td>
<td>The timeout of the SMTP endpoint in minutes.</td>
</tr>
<tr>
<td>SMTP_KEEP_EMAIL</td>
<td>The flag that determines whether to keep the email after SMTP processing. A value of Y (yes) keeps the email. A value of N (no) discards the email.</td>
</tr>
<tr>
<td>SMTP_PORT</td>
<td>The port number that is used by the reserve SMTP agent for incoming SMTP traffic, for example, 25.</td>
</tr>
</tbody>
</table>

3. From the IBM TRIRIGA administrator console, start the application server and start the reserve SMTP agent.

### What to do next

After you configure the TRIRIGAWEB.properties file, the Microsoft Exchange administrator creates the room resources with these properties. After the room resources are created, do not change the domain, subdomain, and SMTP values in the TRIRIGAWEB.properties file. Changing these values after the room resources are created might yield unexpected behavior.

### Configuring the SMTP port in Linux

Linux does not allow root users to bind port traffic to ports 1024 and below. However, the simple mail transfer protocol (SMTP) port property of the TRIRIGAWEB.properties file has a default value of port 25. If you are running Linux, you must configure the reserve SMTP agent to listen to a custom port instead of the default port 25.

### Before you begin

You must be an IBM TRIRIGA administrator. Run the commands in the following procedure as a root user.

### Procedure

1. Update your firewall to open the port above port 1024 by adding the following lines to your `/.../sysconfig/iptables file:
   ```
   -A OUTPUT -p tcp -s serverIP -d 0/0 --dport Port_Above_1024
   -m state --state ESTABLISHED -j ACCEPT
   -A INPUT -s 0/0 -d serverIP -m state --state NEW,ESTABLISHED
   -p tcp --dport Port_Above_1024 -i eth0 -j ACCEPT
   ```
2. Restart your firewall:
   ```
   /.../init.d/iptables restart
   ```
3. Open port 25 for forwarding:
   ```
   /sbin/iptables -A FORWARD -p tcp --destination-port 25 -j ACCEPT;
   ```
4. Forward port 25 to your custom port above 1024:
   
   ```
   /sbin/iptables -t nat -A PREROUTING -j REDIRECT
   -p tcp --destination-port 25 --to-port Port_Above_1024
   ```

5. To verify that port 25 is forwarding, start the IBM TRIRIGA application server so that it binds to your custom port, and run a telnet command:
   
   ```
   telnet yourServer 25
   ```

6. If you do not receive a successful response, forward port 25 to a different custom port (step 4).

**What to do next**

This task does not permanently configure the port. If the Linux server is restarted or the IP tables service is reset from a firewall modification, then the configuration is dropped. To reconfigure the port, you must forward port 25 to your custom port (step 4) again.

---

**Installing the IBM TRIRIGA reservation add in in Microsoft Outlook**

The reservation features in the IBM TRIRIGA Workplace Reservation Manager application can be installed as an IBM TRIRIGA reservation add-in for Microsoft Outlook as an attended installation or in silent mode.

### Attended mode: Installing the IBM TRIRIGA reservation add-in in Microsoft Outlook

To use the reservation features in the IBM TRIRIGA Workplace Reservation Manager application, you can install the IBM TRIRIGA reservation add-in for Microsoft Outlook. When the add-in is installed, you can reserve available meeting spaces, workspaces, equipment, and vehicles.

### Before you begin

Review the [IBM TRIRIGA Support Matrix](https://www.ibm.com/developerworks/community/wikis/home?lang=en#/wiki/IBM+TRIRIGA1/page/Support+Matrix) to verify that your version of Microsoft Outlook includes the prerequisite software. The installer also gives you an opportunity to identify the correct prerequisites.

The IBM TRIRIGA application server and IBM TRIRIGA reservation add-in client must be the same version.

If IBM TRIRIGA runs on an Oracle WebLogic Server, the IBM TRIRIGA administrator must configure the `config.xml` file with the `<enforce-valid-basic-auth-credentials>` element. Typically, the `config.xml` file is in the `weblogic_install_path/user_projects/domains/domain_name/config/` directory. The `<enforce-valid-basic-auth-credentials>` element must be added inside the `<security-configuration>` element, with the `<enforce-valid-basic-auth-credentials>` element set to false. Then, all of the servers in the domain must be restarted.

### Procedure

1. Close all Microsoft Outlook windows.
2. Download the IBM TRIRIGA `.exe` installation file.
3. Install the IBM TRIRIGA reservation add-in and Microsoft Outlook prerequisites.
a. Run the IBM TRIRIGA .exe installation file.
b. Follow the installation instructions.
c. If the installer identifies any missing Microsoft Outlook prerequisite software, install the correct prerequisites from the IBM TRIRIGA Support Matrix (https://www.ibm.com/developerworks/community/wikis/home?lang=en#/wiki/IBM+TRIRIGA1/page/Support+Matrix), and restart the IBM TRIRIGA .exe installation file.

4. Configure the Microsoft Exchange server with the IBM TRIRIGA application server information.
   a. Open Microsoft Outlook, select the profile for this account, and click OK.
   b. Sign in to the Microsoft Exchange server.
   c. Open the IBM TRIRIGA options.

<table>
<thead>
<tr>
<th>Version</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Outlook 2007</td>
<td>Select Tools &gt; Options. Select the IBM TRIRIGA tab.</td>
</tr>
<tr>
<td>Microsoft Outlook 2010</td>
<td>Select File &gt; Options. In the add-ins section, select the IBM TRIRIGA add-in and launch the options.</td>
</tr>
</tbody>
</table>

d. Specify the URL to the IBM TRIRIGA application server.
e. Specify the IBM TRIRIGA user name and password for this account, and click OK.

What to do next

Ensure that Microsoft Outlook and your IBM TRIRIGA profile are set to the same time zone and the same language.

Creating a response file for a silent installation

A silent installation of the reservation features in the IBM TRIRIGA Workplace Reservation Manager application as an add-in for Microsoft Outlook requires a response file. The properties that you specify in the response file provide the responses that a user would provide in an attended installation. A silent installation might be used for a mass implementation or a remote installation.

Procedure

1. Create an install.properties response file. You can use the example response file.
2. Edit the file with the values for each response.
4. Use a software distributor application to distribute the add-in application.

Example

You can edit the following response file with the responses for your installation.

```
#Indicate whether the license agreement been accepted
#-----------------------------------------------
LICENSE_ACCEPTED=TRUE

#Choose Install Folder
#---------------------
USER_INSTALL_DIR=C:\installPath

#Install
```

© Copyright IBM Corp. 2011, 2014
Silent mode: Installing the IBM TRIRIGA reservation add-in in Microsoft Outlook

The reservation features in the IBM TRIRIGA Workplace Reservation Manager application can be installed silently as an IBM TRIRIGA reservation add-in for Microsoft Outlook. The silent installation integrates with the IBM TRIRIGA Workplace Reservation Manager installation program by using a command prompt and a response file.

Before you begin

Review the [IBM TRIRIGA Support Matrix](https://www.ibm.com/developerworks/community/wikis/home?lang=en#/wiki/IBM+TRIRIGA1/page/Support+Matrix) to verify that your version of Microsoft Outlook includes the prerequisite software.

The IBM TRIRIGA application server and IBM TRIRIGA reservation add-in client must be the same version.

If IBM TRIRIGA runs on an Oracle WebLogic Server, the IBM TRIRIGA administrator must configure the config.xml file with the <enforce-valid-basic-auth-credentials> element. Typically, the config.xml file is in the weblogic_install_path/user_projects/domains/domain_name/config/ directory. The <enforce-valid-basic-auth-credentials> element must be added inside the <security-configuration> element, with the <enforce-valid-basic-auth-credentials> element set to false. Then, all of the servers in the domain must be restarted.

Create an install.properties response file.

Procedure

1. Close all Microsoft Outlook windows.
2. Download the IBM TRIRIGA .exe installation file.
3. Run the silent installation by entering `install.exe -i silent -f install.properties` on the command line.
4. Configure the Microsoft Exchange server with the IBM TRIRIGA application server information.
   a. Open Microsoft Outlook, select the profile for this account, and click OK.
   b. Sign in to the Microsoft Exchange server.
   c. Open the IBM TRIRIGA options.

<table>
<thead>
<tr>
<th>Version</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Outlook 2007</td>
<td>Select <strong>Tools &gt; Options</strong>. Select the IBM TRIRIGA tab.</td>
</tr>
<tr>
<td>Microsoft Outlook 2010</td>
<td>Select <strong>File &gt; Options</strong>. In the add-ins section, select the IBM TRIRIGA add-in and launch the options.</td>
</tr>
</tbody>
</table>
d. Specify the URL to the IBM TRIRIGA application server.

e. Specify the IBM TRIRIGA user name and password for this account, and click **OK**.

**What to do next**

Ensure that Microsoft Outlook and your IBM TRIRIGA profile are set to the same time zone and the same language.

**Note:** To uninstall a silent mode installation of the reservation add-in, use the Microsoft Windows Control Panel.
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashı-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.
IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Corporation
2Z4A/101
11400 Burnet Road
Austin, TX 78758
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

**Privacy Policy Considerations**

IBM Software products, including software as service solutions, (“Software Offerings”) may use cookies or other technologies to collect product usage information, to help improve the end user experience, to tailor interactions with the end user or for other purposes. In many cases no personally identifiable information is collected by the Software Offerings. Some of our Software Offerings can help enable you to collect personally identifiable information. If this Software Offering uses cookies to collect personally identifiable information, specific information about this offering’s use of cookies is set forth below.

This Software Offering does not use cookies or other technologies to collect personally identifiable information.

If the configurations deployed for this Software Offering provide you as customer the ability to collect personally identifiable information from end users via cookies
and other technologies, you should seek your own legal advice about any laws applicable to such data collection, including any requirements for notice and consent.


**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at “Copyright and trademark information” at www.ibm.com/legal/copytrade.shtml.

Java™ and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other product and service names might be trademarks of IBM or other companies.