Incorrect Customer Root Key (CRK) ID causes creation of secrets to fail

Failure to create secrets that use CLI or IBM® Cloud Private console UI. The following error message is displayed:

Internal error occurred: rpc error: code = Unavailable desc = grpc: the connection is unavailable

Cause

The Customer Root Key (CRK) ID is incorrect.

Resolving the problem

Make sure the correct CRK_ID is specified in the /etc/cfc/conf/kmsplugin-config.yaml file. Restart the Key Management Service (KMS) plug-in container after you update the file.