Creation of secrets fail because KMS did not respond

Failure to create secrets that use CLI or IBM® Cloud Private console UI. The following error message is displayed:

Error from server (InternalError): Internal error occurred: rpc error: code = Unknown desc = Post https://kms-api.kube-system:28674/api/v2/keys/3ecbc3be-3534-41cd-9898-a224134fbb55?action=wrap: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

Cause

The Key Management Service (KMS) did not respond.

Resolving the problem

Complete the following steps from the IBM Cloud Private console UI.

  1. Click Workload > Deployments and select key-management-api.
  2. Scroll down to Pods. Move the mouse pointer over the only row listed under Pods. Click
  3. Click Remove to remove the current pod and create a new pod.