Catalog is empty after the master node restarts
After you restart the master node, the Catalog is empty.
Symptoms
Cannot view the available applications in the Catalog after a master node restart.
Causes
If the helm-api
service starts before the MongoDB
service starts, the initial synchronization of the Catalog fails.
Resolving the problem
You can resolve this problem by running a manual synchronization of your Helm repositories to repopulate the Catalog. Complete the following procedure to run a manual synchronization:
-
In the navigation, select Manage > Helm repositories.
-
Select Sync repositories on the Helm repositories main page.
After the Helm repositories finish synchronizing, you can view the featured applications in the Catalog.