IBM Cognos Controller
Version 10.4.0

Getting Started with Controller
Note
Before using this information and the product it supports, read the information in “Notices” on page 17.

Product Information
This document applies to IBM® Cognos Controller version 10.4.0 and may also apply to subsequent releases.

Licensed Materials - Property of IBM

US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
Contents

Chapter 1. Introduction............................................................................................................. 1

Chapter 2. Setting up the environment................................................................................. 3
  Review supported environments .......................................................................................... 3
  Cognos Analytics or Cognos Business Intelligence ....................................................... 3
  Create a database ............................................................................................................. 3
  Verify that Microsoft .NET Framework is installed ...................................................... 4
  Verify that Microsoft Visual C++ 2005 Redistributable is installed ........................... 4
  Enable Access to the COM+ Server ............................................................................... 4
  Monitoring license usage ............................................................................................... 4

Chapter 3. Installing and configuring Cognos Controller on one computer .................. 7
  Install the server components ...................................................................................... 7
  Install Framework Manager ......................................................................................... 7
  Configure the web server ............................................................................................. 7

Chapter 4. Configure Cognos Controller ........................................................................ 11
  Configure Microsoft ASP.NET ...................................................................................... 11
  Install a database driver .............................................................................................. 11
  Configure the Cognos Controller database ................................................................ 11
  Configure your web browser ....................................................................................... 12
  Import the Cognos Controller Standard Reports Package ......................................... 13

Appendix A. Accessibility features .................................................................................. 15
  Keyboard Shortcuts for the Installation Wizard ......................................................... 15

Notices ............................................................................................................................... 17

Index ................................................................................................................................. 19
Chapter 1. Introduction

IBM Cognos® Controller is a web-based financial consolidation tool that provides standard reports to support both statutory and management reporting.

This document is intended for use with IBM Cognos Controller. It provides the information you need to install and configure IBM Cognos Controller on a Microsoft Windows 2016 server using default settings. This type of installation is suitable for a test or evaluation environment or for a small production environment.

This document helps you to install IBM Cognos Controller
- On a single computer running Microsoft Windows 2016 Server
- Using Microsoft SQL Server for the IBM Cognos Controller databases
- Using Microsoft Internet Information Services (IIS) as your web server
- Without extra security

For more information about customizing the installation, distributing the components, using other databases, or upgrading an existing installation, see the *IBM Cognos Controller Installation and Configuration Guide*.

**Audience**

To install Cognos Controller, you must be familiar with:
- Database administration
- Basic Microsoft Windows operating system administration
- Web server configuration, specifically Microsoft IIS version 7 or later

**Finding information**

To find product documentation on the web, including all translated documentation, access IBM Knowledge Center (http://www.ibm.com/support/knowledgecenter).

**Accessibility features**

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products. This product has accessibility features. For more information, see Appendix A, “Accessibility features,” on page 15.

**Forward-looking statements**

This documentation describes the current functionality of the product. References to items that are not currently available may be included. No implication of any future availability should be inferred. Any such references are not a commitment, promise, or legal obligation to deliver any material, code, or functionality. The development, release, and timing of features or functionality remain at the sole discretion of IBM.
Chapter 2. Setting up the environment

This section guides you through setting up your environment so that you can install IBM Cognos Controller.

Review supported environments

To ensure your product works properly, apply all required operating system patches and use only the versions of other software that are supported for IBM Cognos Controller.

To review an up-to-date list of environments supported by IBM Cognos Controller, such as operating systems, patches, browsers, web servers, directory servers, database servers, and application servers, see the Cognos Controller 10.4.0 Product Compatibility Report (http://www.ibm.com/software/reports/compatibility/clarity-reports/report/html/prereqsForProduct?deliverableId=B34564E09BDC11E88A70560C75A2DCDE).

Cognos Analytics or Cognos Business Intelligence

You must have a working instance of IBM Cognos Analytics or IBM Cognos Business Intelligence deployed in your environment.

Create a database

Use the following checklist to help you create a database in Microsoft SQL Server.

- Ensure that the collation sequence is case-insensitive.
  
  In a custom installation, you choose a collation, which includes character sets and sort order, during the SQL Server setup. In a typical installation, the installation uses the locale identified by the installation program for the collation. You cannot change this setting later.
- For Microsoft SQL Server, grant EXECUTE permission to the user account that accesses the database.
  
  Under Security for the new database, create a schema and assign a name to it.
  
  Under Security for the new database, create a user with the following settings:
    - For Login name, specify the new login that you created for the user account.
    - For Default schema, specify the new schema.
    - For Owned Schemas, select the new schema.
    - For Role Members, select db_datareader, db_datawriter, and db_ddladmin.

Procedure

1. If you performed a typical installation of Microsoft SQL Server, after you install you must change the authentication mode to SQL Server and Windows.
2. Create the database.
   
   This database is used when you configure the Cognos Controller components in Chapter 4, “Configure Cognos Controller,” on page 11.
Verify that Microsoft .NET Framework is installed

To use IBM Cognos Controller, Microsoft .NET Framework must be installed.

**Important:** Perform this task on each computer where you access the IBM Cognos Controller client.

**Procedure**
1. Click **Start > Control Panel > Programs and Features**.
2. Click **Turn Windows features on or off**.
3. If you are working on a computer that has Microsoft Windows Server installed, do the following steps:
   a) Click **Server Manager > Roles**.
   b) Under **Role Services**, verify that **.NET Extensibility** appears in the list of installed programs.
4. If you are working on a computer that has Microsoft Windows Client installed, if the .NET Framework has a check mark beside it, then it is installed.
5. If you do not have the Microsoft .NET Framework installed, go to the Microsoft website (http://www.microsoft.com). Open the downloads page and search for Microsoft .NET Framework. Follow the download and installation instructions.

Verify that Microsoft Visual C++ 2005 Redistributable is installed

Microsoft Visual C++ 2005 Redistributable must be installed on the computer where you install the Controller server components.

**Procedure**
1. Click **Start > Control Panel > Programs and Features**.
2. Verify that Microsoft Visual C++ 2005 Redistributable appears in the list of installed programs.
3. If you do not have it installed, go to the Microsoft website (http://www.microsoft.com) and open the download page. Search for Microsoft Visual C++ 2005 Redistributable. Follow the download and installation instructions.

Enable Access to the COM+ Server

When you install IBM Cognos Controller, a Controller COM+ application is created. After you install IBM Cognos Controller, you must confirm that network access to the COM+ Server is enabled.

By default, installations of Windows Server 2008 restrict the functionality of network and communication components. You must enable the COM+ Server before IBM Cognos Controller can operate.

**Procedure**
1. In the Windows **Control Panel**, click **Add or Remove Programs**, and then click **Add/Remove Windows Components**.
2. Click **Application Server**, and then click **Details**.
3. Click **Enable network COM+ Access**, and then click **OK**.
4. Click **Next**, and then click **Finish**.

Monitoring license usage

IBM Cognos Controller generates IBM Software License Metric Tag (SLMT) files. Versions of IBM License Metric Tool that support SLMT files can generate License Consumption Reports that provide information
about license usage for Cognos Controller. This information applies only to local installations of Cognos Controller.

For information about installing and using IBM License Metric Tool, see IBM License Metric Tool on IBM Knowledge Center.

The initial generation of SLMT files is determined by the settings in the Web.config file at C:\Program Files\IBM\cognos\ccr_64\ControllerProxyServer. The following table describes the configuration parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Default value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLMTag_Enable</td>
<td>True</td>
<td>Generate the SLMT file. The logger runs on the master server in a master-slave configuration.</td>
</tr>
<tr>
<td>SLMTag_Exception</td>
<td>False</td>
<td>Exception logging. If set to True, the exceptions are stored in the error_log.txt file.</td>
</tr>
<tr>
<td>SLMTag_OutputDirPath</td>
<td>&quot;..\SLMTagData&quot;</td>
<td>Specify the path relative to the ControllerProxyServer folder that is loaded by IIS</td>
</tr>
<tr>
<td>SLMTag_PeriodMinuteLength</td>
<td>1440</td>
<td>Frequency of logging SLMT information (StartTime, EndTime interval). Defaults to 24 hours (1440 minutes).</td>
</tr>
<tr>
<td>SLMTag_MetricCountPerFile</td>
<td>2880</td>
<td>Maximum number of metric tags generated in the same file</td>
</tr>
<tr>
<td>SLMTag_FileKeepNumber</td>
<td>100</td>
<td>Keep the last 100 files generated. Older files are deleted.</td>
</tr>
</tbody>
</table>

To change the default value of a parameter, you must add the parameter to the appSettings section in the Web.config file. Use the following format:

```
<add key="parameter_name" value="parameter_value" />
```

**Note:** If a parameter is not specified in the Web.config file, then its default value as described in the previous table is used.

The AUTHORIZED_USER metric

The AUTHORIZED_USER metric has the following subtypes:

**IBM Cognos Controller administrator**

User that has the administrator role in Cognos Controller.

**IBM Cognos Controller standard user**

User that is not an administrator in Cognos Controller

For each of these subtypes, the AUTHORIZED_USER metric records the number of active administrator and standard users.

You can see a list of administrator and standard users by generating the License Management Report. For more information, see Generate User Rights Reports in Using Controller (rich client).

**Location of Software License Metric Tag files**

On all operating systems, the SLMT files are created in the slmtag directory at the same level as the ccr_64 directory in the Cognos Controller install location. For example, C:\Program Files\IBM\cognos\ccr_64\SLMTagData. All SLMT files use the .slmtag file extension. You can change the location of the SLMT files by changing the SLMTag_OutputDirPath parameter in the Web.config file.

By default, the SLMT information is logged every 24 hours.
Chapter 3. Installing and configuring Cognos Controller on one computer

This chapter provides the information you need to install and configure IBM Cognos Controller on one computer using default settings. This type of installation is suitable for a test or evaluation environment or for a small production environment. This installation is the quickest and easiest way to get started using the product.

Install the server components

The installation wizard for IBM Cognos Controller is provided in the download of the product from Passport Advantage®.

Procedure

1. Launch the Cognos Controller installation wizard by double-clicking the /Controller installer package download location/winx64h/issetup.exe file. The Welcome page of the installation wizard displays.
2. Select the language to use for the installation wizard, and click Next.
3. Accept the license agreement, and click Next.
4. Enter the directory into which you want to install the product, and click Next.
5. Click Next on the Component Selection page to install all the components.
6. Click Next on the Shortcut Folder page.
7. Click Next on the Installation Summary page to start the installation.
8. In the Finish page of the installation wizard, click Finish.

Install Framework Manager

To deploy the Publish to Data Mart Framework Manager model that is provided with IBM Cognos Controller, you must install Framework Manager.

About this task
Framework Manager is a component of IBM Cognos Analytics or IBM Cognos Business Intelligence. To install it, refer to the IBM Cognos Analytics or IBM Cognos Business Intelligence documentation.

Configure the web server

You must set up virtual directories, also known as web aliases, for the directories that contain the HTML and web files for IBM Cognos Controller.

Before you begin
You must use Microsoft Internet Information Services (IIS) version 7 or later. To enable the required permissions for the cgi-bin directory, you must first enable CGI applications for your web server.

Procedure

1. Click Start > Control Panel > Programs and Features.
2. Click Turn Windows features on or off.
3. Click Server Manager > Roles > Web Server (IIS).
4. In **Role Services**, if **HTTP Redirection** is set to **Not installed**, select **HTTP Redirection** and click **Add Role Service**.

5. If **CGI** is set to **Not installed**, select **CGI** and click **Add Role Service**.

6. In the **Internet Information Services (IIS) Manager**, select your server name.

7. Double-click **ISAPI and CGI Restrictions**, and click **Add**.

8. Enter the path to the cognos.cgi file. The file is located in the `ccr_location\cgi-bin` directory.

   **Note:** The variable `ccr_location/` refers to the installation location of IBM Cognos Controller. The default Controller installation location is `C:\Program Files\IBM\Cognos\ccr_64`. You must enter the full path including the filename. If the path includes spaces, ensure that the path is enclosed in quotation marks; for example, use quotation marks as shown in the following path: "C:\Program Files\IBM\Cognos\ccr_64\cgi-bin\cognos.cgi"

9. Select **Allow extension path to execute**, and click **OK**.

10. Select **Application Pools**.

11. Select **Add Application Pool**.

12. Set the **.Net Framework Version** value to **v2.0.50727**.

13. Enter a name for the application pool and click **OK**.

14. Click **Advanced Settings**.

15. Ensure that the **.Net Framework Version** value to **v2.0**.

16. Ensure that the **Enable 32-Bit Applications** value is set to **False** (the default setting).

17. Set the **Identity** value to **LocalSystem**.

18. Click **OK**.

19. Expand **Sites** and, under your web site, create the following virtual directories as shown in the table.

   **Table 1: Required virtual directories**

<table>
<thead>
<tr>
<th>Alias</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>ibmcognos</td>
<td><code>ccr_location/webcontent</code></td>
</tr>
<tr>
<td>ibmcognos/cgi-bin</td>
<td><code>ccr_location/cgi-bin</code></td>
</tr>
<tr>
<td>ibmcognos/controller</td>
<td><code>ccr_location/ccrvdir</code></td>
</tr>
<tr>
<td>ibmcognos/controllerbin</td>
<td><code>ccr_location/webcontent/ccr</code></td>
</tr>
<tr>
<td>ibmcognos/controllerhelp</td>
<td><code>ccr_location/webcontent</code></td>
</tr>
</tbody>
</table>

   You can use a name other than ibmcognos in the aliases. However, you must use cgi-bin as the second part of the alias, including the virtual directory in the **Gateway URI** property to match the new Cognos alias.

   **Remember:** If you use ibmcognos in the web aliases and embed the aliases within other applications, such as Microsoft Excel reports, should you upgrade to a future version of IBM Cognos Controller, you must also update the embedded aliases.

20. Select the cgi-bin virtual directory you created.

21. Double-click **Handler Mappings**.

22. Under **Actions**, click **Add Module Mapping**.

   a) In **Request Path**, type `cognos.cgi`.

   b) In **Module**, type `CgiModule`.

   c) Leave **Executable (optional)** blank.

   d) In **Name**, enter a name for the entry, such as `CognosCGI`.
e) Click OK.

23. Right-click the ibmcognos virtual directory, and click Add Application.
   a) In the Alias box, type controllerserver.
   b) In the Physical path box, enter ccr_location/ControllerProxyServer

24. Select the controller virtual directory.
   a) Double-click HTTP Redirect.
   b) Select Redirect requests to this destination, and enter the following path:
      /ibmcognos/controllerbin/ccr.exe

25. Click Apply and click OK.
Chapter 4. Configure Cognos Controller

To configure the IBM Cognos Controller components, you configure your Cognos Controller database, the Microsoft .Net Framework, and COM+ Server components.

Configure Microsoft ASP.NET

Microsoft ASP.NET is a Microsoft Internet Information Services (IIS) extension that is bundled with the Microsoft .NET Framework. You must configure ASP.NET on all computers running Controller components.

Procedure
1. In a command window, go to the c:/Windows/Microsoft.NET/Framework64/v2.0.50727 directory.
2. Enter the following command:
   aspnet_regiis.exe /i

Install a database driver

The IBM Cognos Controller Database Conversion Utility requires a database driver. For Microsoft SQL Server, the driver is sqljdbc4.jar. The driver file must be in same location as the Database Conversion Utility (dbconv.exe).

Procedure
1. In a Web browser, go to the Microsoft website (http://microsoft.com) and open the download page.
   Search for Microsoft JDBC Driver for SQL Server and download the driver.
   The driver is provided in a self extracting archive.
2. Double-click the archive to uncompress it, and locate the sqljdbc4.jar file in the uncompressed folder.
3. Copy the sqljdbc4.jar file to the root c10_location.

Configure the Cognos Controller database

Before you can run IBM Cognos Controller, you must configure the Cognos Controller database.

You configure the Cognos Controller database using Controller Configuration.

Important: Controller Configuration is not the same tool as was used to configure and start the server components. Ensure that you start Controller Configuration rather than IBM Cognos Configuration.

Procedure
1. From the Start menu, start Controller Configuration.
   If you are using a Microsoft Windows operating system with User Account Control (UAC) turned on and installed the product to the Program Files directory, IBM Cognos Controller Configuration is identified as an administrative application. You must run it with elevated administrative privileges. To save the configuration settings, the UAC prompts for credentials if you are using a standard account.
2. In the Explorer window, click Database Connections, and then click File > New.
3. In the Properties window, click the Database type box, and then use the drop-down arrow to select the database type.
You can choose **DB2**, **Oracle** or **SQL Server**.

4. In the **Name** box, type a name for the database connection.
5. In the **Provider** box, type the name of the database provider.

   To obtain the database provider information, see the DB2®, Oracle or SQL Server documentation.

6. In the **User ID** and **Password** boxes, type the user name and password for the Controller database.
7. In the **Initial catalog** box, type the Controller database name.
8. In the **Data source** box, type the database server computer name.

   Do not use localhost.

9. Click **File > Save**.

10. In the **Explorer** window, expand **Database Connections**.

11. Select the database you want to upgrade.

12. Click **Actions > Run**.

13. If no Java™ is found, browse to and select the Java 8 JRE in the C:\Program Files\ibm\cognos\ccr_64\bin64\jre\8.0 directory.

14. If you have more than one Oracle version installed a message appears, select the same Oracle version that you are using with Controller.

15. If this is an empty Controller database, in the **Database Conversion Utility** window, click **Create Db**.

   The Database Conversion Utility initializes the database.

   **Note:** When you create a new database, by default the database version is 813. You then need to perform database upgrade to the latest version of IBM Cognos Controller.

16. In the **Database Conversion Utility** dialog box, click **Connect** and then click **Upgrade**.

   The Database Conversion Utility upgrades the existing database.

   **Note:** To upgrade database versions lower than 789 use the old Database Conversion Utility tool in the c10\legacy directory.

17. Click **Close**.

18. From the **Actions** menu, click **Check**.

   If the database connection validation fails, review the database connection properties and fix any errors.

19. From the **File** menu, click **Save**.

20. In the **Explorer** window, under **Web Services Server**, click **Report Server**.


   The new database is now configured as a data source for Report Server, and is listed as a data source in IBM Cognos Connection.

---

**Configure your web browser**

To allow you to access Controller from your web browser, you must add your Controller server as a Trusted Site.

**Important:** You must perform this task on each computer from where you will access the IBM Cognos Controller client.

**Procedure**

1. Open Microsoft Internet Explorer.
2. Click **Tools > Internet options**.
3. Click the **Security** tab.
4. Select **Trusted Sites**, and click **Sites**.
5. Clear the **Require server verification (https:) for all sites in this zone** check box.

6. Enter the root URL of your Controller server, and click **Add**.
   
   For example, enter `http://servername`.

7. Click **Close**.

8. Set the security level for the Trusted Sites to **Medium-low**.

9. Click **OK**.

---

**Import the Cognos Controller Standard Reports Package**

Before you can run IBM Cognos Controller and view reports in Cognos Viewer, you must import the Cognos Controller standard reports package into Content Manager.

**Procedure**

1. Launch IBM Cognos Administration.

2. Click the **Configuration** tab, and then click **Content Administration**.

3. On the toolbar, click the **New Import** button. The **New Import** wizard appears.

4. In the **Deployment archive** box, click the **Controller** package, and then click **Next**.

5. Type the name and an optional description and screen tip for the deployment specification, select the folder where you want to save it, and then click **Next**.

6. Select the content that you want to include in the import.

7. Select the options you want, along with your conflict resolution choice for options that you select.

8. In the **Specify the general options** page, select whether to include access permissions and references to external namespaces, and who should own the entries after they are imported in the target environment.

9. Click **Next**.

   The summary information appears.

10. Review the summary information and click **Next**.

11. In the **Select an action** page, select **Save and run once**, and then click **Finish**.

**Results**

After you run the import, the Cognos Controller reports package appears in your IBM Cognos Connection content.
Appendix A. Accessibility features

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, to use information technology products.

See the IBM Accessibility Center (http://www.ibm.com/able) for more information about the commitment that IBM has to accessibility.

Keyboard Shortcuts for the Installation Wizard

Keyboard shortcuts, or shortcut keys, provide you with an easier and often faster method of navigating and using software. The installation wizard uses standard Microsoft Windows operating system navigation keys in addition to application-specific keys.

**Note:** The following keyboard shortcuts are based in US standard keyboards. The following table lists the keyboard shortcuts that you can use to perform some of the main tasks in the installation wizard on the Windows operating system.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next field on a page</td>
<td>Tab</td>
</tr>
<tr>
<td>Return to the previous field on a page</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Close the installation wizard</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Move to the next configuration step</td>
<td>Alt+N</td>
</tr>
<tr>
<td>Return to the previous configuration step</td>
<td>Alt+B</td>
</tr>
<tr>
<td>Move to the next selection in a list</td>
<td>Down arrow</td>
</tr>
<tr>
<td>Move to the previous selection in a list</td>
<td>Up arrow</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts you can use to perform some of the main tasks in the installation wizard on the UNIX or Linux operating system.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to the next field on a page</td>
<td>Tab</td>
</tr>
<tr>
<td>Return to the previous field on a page</td>
<td>Shift+Tab</td>
</tr>
<tr>
<td>Close the installation wizard</td>
<td>Alt+F4</td>
</tr>
<tr>
<td>Move to the next selection in a list</td>
<td>Down arrow</td>
</tr>
<tr>
<td>Move to the previous selection in a list</td>
<td>Up arrow</td>
</tr>
</tbody>
</table>

The following table lists the keyboard shortcuts you can use to perform some of the main tasks in the License Agreement page of the installation wizard.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accept the license agreement</td>
<td>Alt+A</td>
</tr>
<tr>
<td>To do this</td>
<td>Press</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------</td>
</tr>
<tr>
<td>Decline the license agreement</td>
<td>Alt+D</td>
</tr>
<tr>
<td>Quit the installation wizard</td>
<td>Alt+x</td>
</tr>
</tbody>
</table>
Notices

This information was developed for products and services offered worldwide.

This material may be available from IBM in other languages. However, you may be required to own a copy of the product or product version in that language in order to access it.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service. This document may describe products, services, or features that are not included in the Program or license entitlement that you have purchased.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:
Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.

This Software Offering does not use cookies or other technologies to collect personally identifiable information.

**Trademarks**

IBM, the IBM logo and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at "Copyright and trademark information " at www.ibm.com/legal/copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:

- Microsoft, Windows, Windows NT, and the Windows logo are trademarks of Microsoft Corporation in the United States, other countries, or both.
- Linux is a registered trademark of Linus Torvalds in the United States, other countries, or both.
- UNIX is a registered trademark of The Open Group in the United States and other countries.
- Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.
A
accessibility features 15
aliases
  configuring on web servers 7
application servers
  enabling network COM+ access 4
ASP.NET
  installing 11

C
COM+ Server
  enabling 4
  configuring
    Controller database connections 11
    web servers 7
connections
  Controller database 11
Controller database connections
  configuring 11
Controller databases
  creating Microsoft SQL Server 3

E
enabling
  COM+ Server 4
environments
  supported 3

F
Framework Manager
  installing 7

I
IBM Cognos Controller
  standard reports package 13
  importing
    Controller standard reports package 13
installing
  ASP.NET 11
  Framework Manager 7
  Microsoft .NET Framework 4
  Microsoft Visual C++ 2005 Redistributable 4
  server components 7

M
Microsoft .NET Framework
  installing 4
Microsoft SQL Server
  creating Controller databases 3
Microsoft Visual C++ 2005 Redistributable (continued)
  installing 4

N
network COM+ access
  enabling 4

R
reporting package
  importing 13

S
server components
  installing 7
software license management
  tags 4
SQL Server databases
  creating Controller databases 3
standard reports package
  importing 13
  supported environments 3

V
virtual directories
  setting up 7

W
web aliases
  setting up 7
web server
  configuring 7