File not displayed in the Studio Explorer view

You add a file to the workspace, but it is not displayed in the Studio Explorer view.

Symptoms

When you view your project files in the Studio Explorer view, one or more files that you added to the workspace are not displayed.

Causes

Content Analytics Studio maintains an internal list of the files that are stored in the workspace. This list is automatically updated when you add or import files in Content Analytics Studio. However, if you add or copy a file into the workspace by using another application, such as copying and pasting a file in Windows Explorer, the internal list of workspace files must be manually refreshed before the file is displayed in the Studio Explorer view.

The Studio Explorer view displays only supported file types, such as TXT files. If you copy a file with an unrecognized file type into the workspace or you create a text file in Content Analytics Studio but do not include the .txt extension when you specify the file name, the file is not displayed in the Studio Explorer view.

Resolving the problem

To update the list of workspace files that are displayed in the Studio Explorer view, right-click your project in the Studio Explorer view and click Refresh.

If a file is still not displayed in the Studio Explorer view, check whether its file type is supported. To see all files in the workspace, open the Project Explorer view by clicking Windows > Show View > Other and clicking Project Explorer. If its file type is not supported, take one of the following actions to enable the file to be displayed in the Studio Explorer view:

  • Rename the file to assign it a file type that is supported by Content Analytics Studio, such as by adding the .txt file extension.
  • Add the file type as a recognized file type. From the menu, click Window > Preferences. In the Preferences window, click General > Content Types and associate the file type with an Content Analytics Studio content type.