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"Invalid login response" with Single Signon

Troubleshooting


Problem

SSO has been set up but, every time a user tries to reach the site, there is an error message "Invalid Login Response" although no credentials have been entered.

Symptom

Unable to login to Cognos with SSO enabled.

Cause

The Application name does not match the name used within the URL rewrite rules.

Diagnosing The Problem

Ensure URL rewrite rules contain the correct application name.

Resolving The Problem

In IIS under the default website, there is the name of the application which was created in order to run SSO. In this example, this will be referred to as ibmcognos1

Click on the application name, ibmcognos1, select the' bi' folder and select the 'URL Rewrite' option.

For each of the following rules:

SSO Login, Legacy SSO, Event Studio and/or Report Viewer

go into the details, they should all contain a rewrite rule.

For example, in the case the SSO Login, the rewrite should be:

/ibmcognos1/sso/cisapi/bi/v1/login

All the rewrite rules must include the correct application name.

[{"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.10;11.0.9;11.0.8;11.0.7;11.0.6;11.0.5;11.0.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22012485