Troubleshooting
Problem
An administrator is trying to deploy changes from the user interface; however, a message is displayed saying that another deploy is currently in progress.
Symptom
Error: There is another deployment currently in progress, please try again later. Click here to continue.
Cause
This issue might be caused by to a previous deploy changes that has failed on one or more managed hosts.
Environment
QRadar v7.2 or higher
Diagnosing The Problem
To determine the status of a deploy changes, the support representative can look at the information in /store/tmp/status.
Procedure
- Log in to the Console using the root account.
- To view a list of hosts, type ls -latr /store/tmp/status | grep deployment
- To view the current status of the last deploy, type cat /store/tmp/status/deployment."IP"
Where "IP" represent the IP address of the managed host. For example:
or
- If the status is "In Progress", then that managed host needs to be reviewed.
- Using SSH, log in to the managed host that dispalyed "In Progress" and perform a get_logs from either the user interface or from the command line to complete a more in-depth analysis.
Resolving The Problem
A potential workaround for a deploy in progress is to attempt to repair a host. To do this, the support representative can attempt to move the files and restart hostcontext on the managed host.
Procedure
- Using SSH, log in to the Console appliance as the root user.
- Open an SSH session from the Console to the Managed host.
- Move the /store/tmp/status/deployment."IP" file(s) to a temporary directory.
For example, mv /store/tmp/status/deployment."172.16.77.35" /tmp
Warning: Restarting hostcontext on an managed host stops a number of services and impact event collection capability of the managed host until services are restarted. This process should only be done during a maintenance window or at the request of a QRadar Support Representative. - To restart hostcontext on the Managed host(s), type service hostcontext restart (7.2 and lower), systemctl restart hostcontext (7.3 and above).
- Log in to the QRadar Console.
- Click the Admin tab.
- From the toolbar, click Deploy Changes.
Results
The deploy changes should complete without an error message.
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Document Information
Modified date:
31 March 2020
UID
swg21684707