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Error "XQE-DS-0006 Unable to logon to data source" testing a JDBC connection to SQL Server 2008

Question & Answer


Question

Attempting to make a datasource connection to SQL Server 2008 using JDBC optiona results in XQE-DS-0006 Unable to logon to data source in Cognos 10.1.x Full error... XQE-DS-0006 Unable to logon to the data source The TCP/IP connection to the host , port 1433 has failed. Error: "Connection refused: connect. Verify the connection properties. make sure that an instance of SQL server is running on the host and accepting TCP/IP connections at the port. Make sure the TCP connection to the port are not blocked by a firewall."

Cause

By default, a dynamic port different from 1433 is set for the instance of SQLServer

Answer

Open SQL Server Configuration Manager
Expand SQL Server Network configuration
Click on Protocols for <Instance_name>
On the right pane, select TCP/IP
Scroll down to the bottom of TCP/IP properties window: You may see a port number set for TCP Dynamic Ports, different from 1433
Cut and Paste this port number to TCP Port: it becomes a static port

Make sure this port number is accessible for Cognos (you may use Telnet)

Back to the Cognos datasource connection, specify:
- Server name
- Instance name
- database name
- new static port number
This should works.


Notice: From version 10.2 you can let the SQL Server port to dynamic and let the port blank within Cognos datasource connection

If the dynamic port is not the cause of this error XQE-DS-0006, refer to Related Information section

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Administration","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1.1;10.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21640719