Question & Answer
Question
What debug, and logs should I send to IBM support to help troubleshoot why my adapter request failed?
Cause
The following settings and procedure will assist in capturing debug data from both
ITIM server, and ITIM adapter.
ITIM server, and ITIM adapter.
Answer
a.) Enable debug on the ITIM server, by editing <ITIM_HOME>/data/enRoleLogging.properties
from:
# logger.trace.com.ibm.itim.remoteservices.level=DEBUG_MIN
to:
logger.trace.com.ibm.itim.remoteservices.level=DEBUG_MAX
If the problem is during a reconciliation request, increase the size, and number of logs to:
# The maximum number of trace log files
handler.file.trace.maxFiles=20
# The maximum log file size in KB
handler.file.maxFileSize=10240
You'll need to wait 5 minutes after above change to take place.
(as that is default value for refreshInterval, in enRoleLogging.properties)
# Logging properties refresh interval in milliseconds
logger.refreshInterval=300000
or stop/start ITIM application in WebSphere, or stop/start WebSphere. On Windows you must restart WebSphere itself or the logs will not roll correctly.
from:
# logger.trace.com.ibm.itim.remoteservices.level=DEBUG_MIN
to:
logger.trace.com.ibm.itim.remoteservices.level=DEBUG_MAX
If the problem is during a reconciliation request, increase the size, and number of logs to:
# The maximum number of trace log files
handler.file.trace.maxFiles=20
# The maximum log file size in KB
handler.file.maxFileSize=10240
You'll need to wait 5 minutes after above change to take place.
(as that is default value for refreshInterval, in enRoleLogging.properties)
# Logging properties refresh interval in milliseconds
logger.refreshInterval=300000
or stop/start ITIM application in WebSphere, or stop/start WebSphere. On Windows you must restart WebSphere itself or the logs will not roll correctly.
If using the ISIM Virtual Appliance, 7.0, do enable enable Maximum for 'remoteservices' in LMI console ->
Manage -> Log Retrieval and Configuration -> Configure -> Identity Manager -> * <drop down> com.ibm.itim.remoteservices
b.) Enable debug for TDI Adapter Dispatcher, by editing <TIMSOL>/etc/log4j.properties
from:
log4j.rootCategory=INFO, Default
to:
log4j.rootCategory=DEBUG, Default
note: In Windows, the dispatcher's log4j.properties is located in <TIMSOL>
You'll need to restart adapter for changes to take place.
c.) Test the TDI based adapter service in ITIM.
d.) Recreate the problem by submitting the request that is failing.
e.) After failure, send to IBM support:
msg.log, and trace*.log from ITIM server.
(from the location configured for "handler.file.fileDir", in enRoleLogging.properties)
Manage -> Log Retrieval and Configuration -> Configure -> Identity Manager -> * <drop down> com.ibm.itim.remoteservices
b.) Enable debug for TDI Adapter Dispatcher, by editing <TIMSOL>/etc/log4j.properties
from:
log4j.rootCategory=INFO, Default
to:
log4j.rootCategory=DEBUG, Default
note: In Windows, the dispatcher's log4j.properties is located in <TIMSOL>
You'll need to restart adapter for changes to take place.
c.) Test the TDI based adapter service in ITIM.
d.) Recreate the problem by submitting the request that is failing.
e.) After failure, send to IBM support:
msg.log, and trace*.log from ITIM server.
(from the location configured for "handler.file.fileDir", in enRoleLogging.properties)
If using the ISIM Virtual Appliance, 7.0, do download the logs from LMI console ->
Manage -> Log Retrieval and Configuration -> Identity -> Application message and trace
ibmdi.log from TDI adapter server.
(from <TIMSOL>/logs/ location)
Manage -> Log Retrieval and Configuration -> Identity -> Application message and trace
ibmdi.log from TDI adapter server.
(from <TIMSOL>/logs/ location)
[{"Product":{"code":"SSRMWJ","label":"IBM Security Identity Manager"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Adapters","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.0;5.1;7.0","Edition":"Enterprise","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Product Synonym
ITIM;TIM;ISIM;SIM;TDI;ITDI;isim;enrole
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Document Information
Modified date:
05 February 2019
UID
swg21614948