Troubleshooting
Problem
IBM INFORMIX ODBC DRIVER cannot be loaded due to system error code 126
Symptom
When creating an ODBC Data Source using Microsoft's ODBC Administrator, the following error is encountered:
The setup routines for the IBM INFORMIX ODBC DRIVER ODBC driver could not be loaded due to system error code 126.
After clicking the OK button, the following message will appear:
Could not load the setup or translator library
Cause
Incorrect Driver or Setup registry entries for the IBM Informix ODBC driver.
Environment
Windows
Resolving The Problem
To resolve the problem, run regedit and examine the setting for the IBM Informix ODBC driver. The settings for the IBM INFORMIX ODBC DRIVER are located under
- HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI.
The Driver and Setup entries should look like this dependant upon where the product is installed:
Driver = C:\Program Files\IBM\Informix\Client-SDK\bin\iclit09b.dll
Setup = C:\Program Files\IBM\Informix\Client-SDK\bin\iclit09b.dll
If there is a typographical error in the above settings, make the appropriate correction and try to create the ODBC Data Source again.
Related Information
[{"Product":{"code":"SSVT2J","label":"Informix Tools"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Informix Client Software Development Kit (CSDK)","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.5","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
20 January 2022
UID
swg21424392