Troubleshooting
Problem
This technote identifies how to resolve the error, Unable to logon to ClearQuest user dbName, which might occur when attempting to set to an activity from a check-in or check-out, or to add to source control when using an UCM enabled IBM® Rational® ClearQuest and IBM Rational ClearCase® integration.
Cause
The full error message is as follows:
Unable to logon to ClearQuest user database "dbName".
The logs might also have recorded the following error:
SQUID_AD COM exception: [../squid_adsession.cxx/line 746]:
Server execution failed.
One possible causes for this issue is the Microsoft® Windows® environment variables might not contain entries for theses Rational products.
Resolving The Problem
To check to see if the environment variables are correct you will need to run the command set from a command prompt.
For example:
- Navigate to Start, Run and type in cmd
- Type in set
The output will be similar to the following:
ATRIAHOME=C:\Program Files\Rational\ClearCase
IBMLDAP_ALTHOME=C:\Program Files\Rational\common\codeset
Path=C:\WINDOWS\system32;<...>C:\Program files\Rational\ClearCase\bin;C:\Program Files\Rational\common;
If the above environment variables are not set correctly, you will need to run a repair on the installation for both ClearCase and ClearQuest.
- Navigate to Start > Settings > Control Panel > Add or Remove Programs.
- Once Add or Remove Programs opens, in the list you should see ClearQuest and ClearCase.
Note: If you installed ClearQuest using the IBM Rational Suite® Install, then you may see Rational Suite in the Add/Remove programs list instead. - Select Change and then Repair.
Note: You will need to perform this repair for both ClearCase and ClearQuest. - Once both ClearCase and ClearQuest are repaired, the missing environment paths should now be present. Verify this by running the set command again.
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Document Information
Modified date:
16 June 2018
UID
swg21267128