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Checkin to a locked activity fails with Internal Error detected

Troubleshooting


Problem

This technote explains why the error, []Internal Error detected in "../vob_act.c" line 1225. Unexpected error[], occurs after checking in a locked activity when using IBM® Rational® ClearCase® UCM on Microsoft® Windows®, and provides steps on how to resolve the issue.

Symptom

The following scenario can produce unexpected results for ClearCase versions 2003.06.xx :

  1. Create an activity, act1

  2. Checkout a file on that activity, act1

  3. Create a new activity, actlock

  4. Lock the new activity, actlock

  5. Try to checkin the file on the locked activity, actlock. This will fail, as is expected.

  6. Try to check in the file on another, non-locked activity, act1. This will also fail, resulting in the following error:
  • At the command line:
    cleartool: Error: INTERNAL ERROR detected and logged with the NT Event Service.
    See the Event Viewer for the error message.
    cleartool: Error: Unable to check in "<file name>".

  • From the GUI:
    Error checking in '<path to file>'
    INTERNAL ERROR detected and logged with the NT Event Service.
    See the Event Viewer for the error message.
    Internal Error detected in "../vob_act.c" line 1225.
    Unexpected error.

The problem persists even if the locked activity is unlocked or if the activity is reset on the command line.

The locked activity shows no change sets, but does show a hyperlink when cleartool describe -long -ahlink -all activity:<activity>@\PVOB-tag is run against it. This indicates that a checkin was started against the locked activity, even though it could not complete.

The activity that the element was originally checked out from, act1, in this example, will also show a hyperlink.

Cause

This behavior, where a lock on an activity leads to Internal Error if one activity is locked, has been reported as defect APAR IC39157.

Resolving The Problem


This defect has been resolved in Rational ClearCase 7.0.

Note: The fix in ClearCase 7.0 will prevent this problem from occurring going forward, but it cannot resolve existing instances. A workaround will need to be applied in these instances. Contact Rational Client Support for assistance.

IMPORTANT: Due to the nature of the code changes, the fix will not be added in a patch or service release for ClearCase 2003.06.00 or prior versions.

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Document Information

Modified date:
16 June 2018

UID

swg21233248