IBM Support

"IBM Cognos Controller has stopped working" error launching Controller, caused by Microsoft patch KB4507460

Troubleshooting


Problem

User launches Controller client. An error appears.
A similar problem occurs if the administrator performs the following:
  • Launches 'Controller Configuration'
  • Opens 'Report Server'
  • Clicks 'Tick' button (to test the connection).

Symptom

Client screen:
image-20190715065902-1
IBM Cognos Controller has stopped working
Client device - More Information:
Application: CCR.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: exception code 80004005, exception address 00007FFF7D714C48
Stack:
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG ByRef)
   at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG ByRef)
   at System.Windows.Forms.Application+ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr, Int32, Int32)
   at System.Windows.Forms.Application+ThreadContext.RunMessageLoopInner(Int32, System.Windows.Forms.ApplicationContext)
   at System.Windows.Forms.Application+ThreadContext.RunMessageLoop(Int32, System.Windows.Forms.ApplicationContext)
   at Cognos.Controller.Common.cdkhelper.PopupBrowser.execute(System.String)
   at Cognos.Controller.Common.cdkhelper.PopupBrowser.logon()
   at Cognos.Controller.Common.cdkhelper.LogonHelper.logon()
   at Cognos.Controller.Forms.Common.Main.DoLoginCognos8(System.Windows.Forms.Form ByRef)
   at CCR.AppContext.DoLogin()
   at CCR.AppContext.Login()
   at CCR.MainModule.Login()
   at CCR.MainModule.LoadMain()
   at CCR.MainModule.main()

Cause

Microsoft patch KB4507460 installed.

Environment

In one real-life customer example, the system had been working OK for a long time (many weeks). The problem suddenly started occuring after installing Microsoft Windows patches.

Resolving The Problem

In one real-life customer case, there were two different possible solutions:
 
Method #1
Uninstall Microsoft patch KB4507460:
  • from the Controller application server (to fix the Controller Configuration problem).
  • from the client device (for example Terminal / Citrix servers) to fix them.
 
Method #2
Install the 2019-08 Cumulative Windows Update
  • The issue was resolved after installing the  2019-08 Cumulative Update (KB4512517) over KB4507460.

Document Location

Worldwide

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Document Information

Modified date:
16 August 2019

UID

ibm10959251