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Problems with Brocade fabric probe and switch performance monitors

Troubleshooting


Problem

Fabrics and switches visible within Brocade Network Advisor might not be shown in IBM Spectrum Control or might not allow performance monitoring. Switches show warnings in Network Advisor Discover Fabrics panel.

Symptom

Switches shown in Network Advisor are not shown in Spectrum Control or encounter failures when trying to run a probe or performance monitor against them. Those switches are typically shown in Network Advisor with a discovery status of warning on the Discover Fabrics panel.

Cause

The switch discovery status in Network Advisor indicates a communication error and the switch data is not sent from Network Advisor to Spectrum Control as expected and required.

Diagnosing The Problem

If the switches are not found during a test connection or probe in Spectrum Control, look to the Network Advisor configuration.

  1. Open up the Discover Fabrics panel in Network Advisor.
  2. Look for any switches showing with a warning or error.
    1. Discovered: Not reachable
    2. Discovered- Authentication Failure : SNMP communication failed. SNMP credentials may be invalid.
    3. Discovered: Current seed switch is not recommended.
    4. And others...

Resolving The Problem

Make changes to Network Advisor and the switches as needed to resolve the warnings and errors such that all switches can be shown with a green checkmark in the Discover Fabrics panel in Network Advisor.

  1. If a switch has Not Reachable status, try running "haReboot" from the switch CLI.
  2. If the switch shows SNMP communication warnings, select the switch in the Discover Fabrics panel and choose Edit to modify the credentials.  The user or password might be different than the seed switch or might have been changed since it was added.
  3. Specify a different seed switch if needed and one is available.  The Network Advisor release notes list out seed switch requirements by release level.
  4. Other configuration settings for SNMP users and protocols might affect the communication between the switch and Network Advisor and should be reviewed.

 

Once any issues are cleared up in Network Advisor, go back to Spectrum Control and run a test connection and a fabric probe again for the Brocade switches. If those are successful, continue on to any performance monitoring jobs.

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Document Information

Modified date:
22 February 2022

UID

ibm10738269