IBM Support

Invalid Login Response when attempting to access an IBM Cognos Analytics environment

Troubleshooting


Problem

When attempting to access an IBM Cognos Anlaytics environment via the gateway or dispatcher Uniform Resource Identifier(URI) the user is presented with an "INVALID LOGIN RESPONSE" message.

Cause

This situation may be caused by an invalid Cookie Domain property value entry within IBM Cognos Configuration.

Environment

IBM Cognos Analytics

Resolving The Problem

To resolve this issue:

1.  Open IBM Cognos Configuration.
2.  Click on "Action" menu from menu tab.
3.  Click on "Edit Global Configuration..".
4.  Check the value of the "Domain" for the Cookie Setting.

  •     For the Domain value, use the computer or server name alone. Specify this name without any dots. For example, mycompany
  •     The Domain value can also specify a suffix. Suffixes include .com, .edu, .gov, .int, .mil, .net, or .org. Include a prefix dot. For example, .mycompany.com
  •     Other levels can be used in a Domain value. Include a prefix dot. For example .accounts.mycompany.com
  •     A Path value can further restrict cookies. The most general path is /. A path of /payables restricts the cookie to all paths beginning with "payable" (and all subdirectories). A path of /payables/ restricts the cookie to the "payables" directory (and all sub directories).


5.  Restart the IBM Cognos services and attempt to access the IBM Cognos Analytics environment via the gateway or dispatcher URI.

Related Information

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSTSF6","label":"IBM Cognos Analytics"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
31 October 2018

UID

ibm10737715