What's new in Watson Studio Desktop

Check out what's new for Watson Studio Desktop! The available features correspond to the latest update available for your offering.

March 2021 (Subscription)

Changes for macOS operating system support
  • 11.2 (Big Sur) support added: Watson Studio Desktop Subscription is supported on macOS 11.01 for both new installations and for in-app updates.
  • 10.14 (Mojave) support discontinued: Watson Studio Desktop Subscription is no longer supported on macOS 10.14.
Minimum RAM increased from 8 GB to 16 GB
The minimum RAM for both Windows and macOS is now 16 GB. For the updated list of all system requirements, see System requirements (Subscription).
Security update for Python
This security update includes an upgrade from Python 3.6 to Python 3.7.

For notebooks, Python 3.6 is discontinued. You must install this version in order to continue to run notebooks.


In addition, the following features and changes from the September 2020 (Version 2.0) release are included:

SPSS Modeler

Data Refinery

Notebooks

User interface

January 2021 (Version 2.0.0-1)

Security update for Python
This security update includes an upgrade from Python 3.6 to Python 3.7.

For notebooks, Python 3.6 is discontinued. You must install Watson Studio Desktop 2.0.0-1 in order to continue to run notebooks.

On Watson Machine Learning Server, Python 3.6 frameworks are deprecated and some are discontinued. If a framework is deprecated, you cannot train new models but you can run existing deployments. If a framework is discontinued, you must retrain and redeploy your asset. For details, see the Supported frameworks topic in the Watson Machine Learning Server documentation.

October 2020 (Subscription)

Update for the auto-update feature (macOS only)
This update contains an important change for the macOS certification process. You must install this update as soon as possible to ensure that you will have access to future Watson Studio Desktop Subscription updates and fixes. New installations will include this update.

September 2020 (Version 2.0)

Updates to installation
New icon
You'll see a new icon for Watson Studio Desktop when you install the application.
Figure 1. Watson Studio Desktop icon
Watson Studio Desktop icon.
Choices for Windows installation
You now have a choice of a per-user installation or a per-machine (all users) installation. The per-user installation is for a single user using Watson Studio Desktop on the computer and is the default installation. The per-machine installation is for multiple users.
Figure 2. Windows installation choices
.Windows installation choices

Faster and more efficient installation
Watson Studio Desktop 2.0.0-1 has a new user interface to install the application. You can choose which add-ons (Modeler or Notebooks) to install and when.
Figure 3. Installation for Watson Studio Desktop 2.0.0-1
Installation for Watson Studio Desktop 2.0

Choose the steps for your operating system: Installing Watson Studio Desktop 2.0.0-1.


Only one instance of Watson Studio can be installed on a computer
You can install only one instance of Watson Studio Desktop or Watson Studio Desktop Subscription on a computer.

Minimum RAM increased from 8 GB to 16 GB
The minimum RAM for both Windows and macOS is now 16 GB. For the updated list of all system requirements, see System requirements (Version 2.0.0-1).
What's new in Watson Machine Learning Server
Build machine learning models with AutoAI
The AutoAI graphical tool in Watson Studio automatically analyzes your structured data and generates candidate model pipelines customized for your predictive modeling problem. These model pipelines are created iteratively as AutoAI analyzes your data set and discovers data transformations, algorithms, and parameter settings that work best for your problem setting.
Figure 4. AutoAI trained pipelines
AutoAI trained pipelines
This feature requires Watson Machine Learning Server. See AutoAI for more information.
Save an AutoAI model as a notebook

After training an AutoAI experiment, you can save a pipeline to your project as an automatically generated notebook. Use the notebook to review the data transformations applied to generate the model. You can also run the model from the notebook, and deploy the model to score it and generate predictions. This feature requires Watson Machine Learning Server. See AutoAI notebook for more information.

Schedule batch deployment jobs

Schedule batch deployment jobs on Watson Machine Learning Server. From a deployment space, specify input data and write predictions to an output file. Run the deployment job and view the resulting batch predictions. See Managing deployment jobs for more information.

Watson Machine Learning Server supports more input data assets
Promote or add data sources to a deployment space to use with batch deployment jobs. Data can be:
  • A data file such as a .csv file
  • A connection to data that resides in a repository such as a Db2 database
  • Connected data that resides in a storage bucket, such as a data file in a Cloud Object Storage bucket.
Import or export a Watson Machine Learning Server deployment space

With Watson Machine Learning Server, you can export the contents of a deployment space to a file. You can also create a new space by importing a space from a file. This provides an efficient way to archive a space, use a space as a template, or share a space. See Deployment spaces for more information.

Deploy Python scripts on Watson Machine Learning Server

Deploy Python scripts on Watson Machine Learning Server. Scripts are not a supported project asset, so you must store and deploy them using the Watson Machine Learning Python client. See Deploying scripts for more information.

Watson Machine Learning Python client installed by default

The latest version of the Watson Machine Learning Python client is installed by default when you create a notebook in Watson Studio Desktop. You no longer need to install the client library. See Deploying using the Python client for more information.

Export Watson Machine Learning Server assets from a project

With Watson Studio Desktop, you can export the contents of a project to a file. The exportable assets now include your machine learning models and Python functions saved in notebooks. You can also import machine learning assets when you create a new project from a saved project file. This provides an efficient way to archive a project, use a project as a template, or share a project.

What's new in SPSS Modeler
New SPSS Modeler nodes
  • With the new CPLEX Optimization node in SPSS Modeler, you can use complex mathematical (CPLEX) based optimization via an Optimization Programming Language (OPL) model file. See CPLEX Optimization node.
    Figure 5. CPLEX Optimization node
    CPLEX Optimization node
  • The new Kernel Density Estimation (KDE)© Simulation node uses the Ball Tree or KD Tree algorithms for efficient queries, and walks the line between unsupervised learning, feature engineering, and data modeling. See KDE Simulation node.
    Figure 6. KDE Simulation node
    KDE Simulation node
  • The Data Asset Export node has been redesigned. Use the node to write to remote data sources using connections, write to a data file on your local computer, or write data to your project. See Data Asset Export node.

Database functions supported in SPSS Modeler desktop streams
You can now run an SPSS Modeler desktop stream file (.str) that contains database functions. But they aren't yet available in the Expression Builder user interface.

Write to any directory
Previously, you could only write to your projects directory. Now you can write to any directory on your system that you have access to.

New Restart session button
In some cases, a task may fail to complete in SPSS Modeler and you'll be prompted to continue running or restart your session. You can also force your session to restart at any time by clicking the Restart session button (Shows the Restart session icon) in the right-hand Information panel.

Deploy Text Analytics models
You can now deploy Text Analytics models to a Watson Machine Learning Server as you can with other model types. See Deploying assets for more information.

Profile right-click option
The Profile right-click option for SPSS Modeler nodes has been removed. To launch the chart builder and create advanced visualizations, you can use the Charts node.
New visualization charts for Data Refinery and SPSS Modeler
To access the charts in Data Refinery, click the Visualizations tab and then select the columns to visualize. The chart automatically updates as you refine the data.

To access the charts in SPSS Modeler, use a Charts node. The Charts node is available under the Graphs section on the node palette. Double-click the Charts node to open the properties pane. Then click Launch Chart Builder to create one or more chart definitions to associate with the node.

For the full list of available charts, see Visualizing your data.

  • Bubble charts display each category in the groups as a bubble.
    Figure 7. Bubble chart
    Bubble chart
  • Circle packing charts display hierarchical data as a set of nested areas.
    Figure 8. Circle packing chart
    Circle packing chart
  • Evaluation charts are combination charts that measure the quality of a binary classifier. You need three columns for input: actual (target) value, predict value, and confidence (0 or 1). Move the slider in the Cutoff chart to dynamically update the other charts. The ROC and other charts are standard measurements of the classifier.
    Figure 9. Evaluation chart
    Evaluation chart
  • Math curve charts display a group of curves based on equations that you enter. You do not use a data set with this chart. Instead, you use it to compare the results with the data set in another chart, like the scatter plot chart.
    Figure 10. Math curve chart
    Math curve chart
  • Multi-charts display up to four combinations of Bar, Line, Pie, and Scatter plot charts. You can show the same kind of chart more than once with different data. For example, two pie charts with data from different columns.
    Figure 11. Multi-chart
    Multi-chart
  • Radar charts integrate three or more quantitative variables that are represented on axes (radii) into a single radial figure. Data is plotted on each axis and joined to adjacent axes by connecting lines. Radar charts are useful to show correlations and compare categorized data.
    Figure 12. Radar chart
    Radar chart
  • Sunburst charts display different depths of hierarchical groups. The Sunburst chart was formerly an option in the Treemap chart.
    Figure 13. Sunburst chart
    Sunburst chart
  • Tree charts represent a hierarchy in a tree-like structure. The Tree chart consists of a root node, line connections called branches that represent the relationships and connections between the members, and leaf nodes that do not have child nodes. The Tree chart was formerly an option in the Treemap chart.
    Figure 14. Tree chart
    Tree chart
  • Theme river charts use a specialized flow graph that shows changes over time.
    Figure 15. Theme river chart
    Theme river chart
  • Time plot charts illustrate data points at successive intervals of time.
    Figure 16. Time plot chart
    Time plot chart
New operations and enhancements for Data Refinery
New Data Refinery GUI operations
These operations are in the ORGANIZE category:
Join operation
The Join operation can join two data sets in a variety of ways. You can perform a full join, inner join, left join, right join, semi join, or anti join. You can also select the columns you want to see in the result set, and if there are same-named columns between the two data sets, you can specify unique suffixes to differentiate them.
Figure 17. Data Refinery Join operation
Data Refinery Join operation
Union operation
Use the Union operation to combine the rows from two data sets that share the same schema.
Figure 18. Data Refinery Union operation
Data Refinery Union operation
For the complete list of operations, see GUI operations in Data Refinery.

Enhancements to Data Refinery operations
Perform aggregate calculations on multiple columns
Now you can select multiple columns in the Aggregate GUI operation. Previously all aggregate calculations applied to one column.
Figure 19. Data Refinery Aggregate operation with two columns selected
Data Refinery Aggregate operation with two columns selected.
The Aggregate operation is in the ORGANIZE category.

Automatically detect and convert date and timestamp data types
When you open a file in Data Refinery, the Convert column type GUI operation is automatically applied as the first step if it detects any non-string data types in the data. Now date and timestamp data are detected and are automatically converted to inferred data types. You can change the automatic conversion for selected columns or undo the step. For information about the supported inferred date and timestamp formats see Convert column type in GUI operations in Data Refinery, under the FREQUENTLY USED category.

Filter values in a Boolean column
You can now use these operators in the Filter GUI operation to filter Boolean (logical) data:
  • Is false
  • Is true
Figure 20. Data Refinery Filter operation with Boolean selection
Data Refinery Filter operation with Boolean selection
The Filter operation is in the FREQUENTLY USED category.
In addition, a new template for filtering by Boolean values has been added to the filter coding operation.
filter(`<column>`== <logical>)
For more information about the filter templates, see Interactive code templates in Data Refinery.
Load data from local files to your notebook
You can now load a file directly from within a notebook and access the data by using the Insert to code function. The generated code to access the data serves as a quick start to begin working with the data in a file.
Figure 21. Insert to code function choices
Insert to code function choices

See Loading and accessing data in a notebook for more information.

View Watson Studio Desktop in your own language
To change the language, from the menu go to View > Language.

You can view the Watson Studio Desktop user interface in the following languages:

  • Simplified Chinese
  • Traditional Chinese
  • English
  • French
  • German
  • Italian
  • Japanese
  • Brazilian Portuguese
  • Russian
  • Spanish

In addition, the following features and changes from the 29 May 2020 (Subscription) release are included:

29 May 2020 (Subscription)

New name for the Subscription offering
The Subscription offering name is changed from "IBM Watson Studio" to "IBM Watson Studio Desktop Subscription."
New icon
Watson Studio Desktop Subscription has a new icon.
Figure 22. Watson Studio Desktop Subscription icon
Watson Studio Desktop Subscription.
Save your example projects if you modified them
The Example Project installed with the product has been replaced to fix an issue with one of the flows. Note that the flows included are intended to be for demonstration purposes only. They'll be replaced periodically when the product is updated. If you modified any of the examples and want to preserve your work, you should export and import the resources as desired to avoid them being replaced. For details about the example projects, see Example projects.
New connections
Watson Studio Desktop now supports connections to the following data sources:
Name changes for four connections
These connections have new names:
  • "BigInsights HDFS" is renamed to "Analytics Engine HDFS"
  • "Compose for PostgreSQL" is renamed to "Databases for PostgreSQL"
  • “Hortonworks HDFS” is renamed to “Apache HDFS”
  • "PureData System for Analytics" is renamed to "Netezza (PureData System for Analytics)"
Your previous settings for the connections remain the same. Only the connection names have changed.
SAV file support
You can now import or export SPSS Statistics.sav data files in SPSS Modeler. You can refine .sav files in Data Refinery.
SPSS Modeler Extension nodes
To complement SPSS Modeler and its data mining abilities, several Extension nodes are now available to enable expert users to input their own R scripts or Python for Spark scripts to carry out data processing, model building, and model scoring. See Extension nodes.
SPSS Modeler flow properties
You can set flow properties. See Setting properties for flows.
SPSS Modeler node tooltips
New tooltips are available in the nodes palette. You can hover over any node to see a helpful description before adding it to your flow canvas.
SPSS Modeler Type node icons
New icons in the Type node properties quickly indicate the data type of each field, such as string, date, double integer, or hashtag.
Figure 23. New Type node icons
New Type node icons
New options for the SPSS Modeler Auto Classifier and Auto Numeric nodes
New cross-validation options are available for testing the effectiveness of machine learning models or evaluating a model if you have limited data. See Auto Classifier node or Auto Numeric node.
Figure 24. New cross-validation options
Shows the new cross-validation node properties
New SQL icon
When running a flow, nodes that push back to your database used to be highlighted with a small purple icon beside the node. Now a new small SQL icon is used instead.
Figure 25. New SQL icon
Shows the new SQL icon
Maximum file size restriction removed for Data Refinery
Previously, the maximum file size for Data Refinery depended on the amount of RAM in your computer.
Specify format options for your data in Data Refinery
You can now modify the format options in Data Refinery such as the encoding, the field delimiter, and the quote and escape characters. You can also specify if the first row contains the column headers. Use this feature to fix problems when the data does not display in a tabular form.
Figure 26. Format options in Data Refinery
Format options in Data Refinery with "First row contains the headers", Encoding, Field delimiter, Quote character, and Escape character.

To access the format options in Data Refinery, go to the Data tab, scroll down to the SOURCE FILE information at the bottom of the page, and click the "Specify data format" icon Specify data format icon. For more information, see Specifying the format of your data in Data Refinery.

Data Refinery automatically detects and converts data types
Previously, you had to manually apply the Convert column type GUI operation to detect and convert the data types. Now the Convert column type GUI operation is automatically applied as the first step in the Data Refinery flow. The operation automatically detects and converts the data types to inferred data types (for example, to Integer, Boolean, etc.) as needed. This enhancement will save you a lot of time, particularly if the data has many columns. It is easy to undo the automatic conversion or to edit the operation for selected columns.
Figure 27. Automatic detection and conversion of data type
Automatic detection and conversion of data type

For more information, see Convert column type in GUI operations in Data Refinery, under the FREQUENTLY USED category.

New visualization charts in Data Refinery

Data Refinery introduces six new charts. To access the charts, click the Visualizations tab in Data Refinery, and then select the columns to visualize. The chart automatically updates as you refine the data.

  • Bubble charts display each category in the groups as a bubble.
    Figure 28. Bubble chart
    Bubble chart
  • Circle packing charts display hierarchical data as a set of nested areas.
    Figure 29. Circle packing chart
    Circle packing chart
  • Multi-charts display up to four combinations of Bar, Line, Pie, and Scatter plot charts. You can show the same kind of chart more than once with different data. For example, two pie charts with data from different columns.
    Figure 30. Multi-chart
    Multi-chart
  • Radar charts integrate three or more quantitative variables that are represented on axes (radii) into a single radial figure. Data is plotted on each axis and joined to adjacent axes by connecting lines. Radar charts are useful to show correlations and compare categorized data.
    Figure 31. Radar chart
    Radar chart
  • Theme river charts use a specialized flow graph that shows changes over time.
    Figure 32. Theme river chart
    Theme river chart
  • Time plot charts illustrate data points at successive intervals of time.
    Figure 33. Time plot chart
    Time plot chart
New SPSS Modeler tutorials
The following two new tutorials are available to accompany the thirteenth and fourteenth flows in the example project that's installed with the product. See SPSS Modeler tutorials.

In addition, the following features and changes from the 31 January 2020 (Version 1.1) release are included:

31 January 2020 (Version 1.1)

What's new in Watson Machine Learning Server
Saving models
Previously, you saved models to a deployment space. Now you save models to your projects where you can then access your model and create deployments from the Models section under Assets. (You can still save models to a space with the Python client.) For more information, see Saving and running models on Watson Machine Learning Server, Deploying assets, and Deployment spaces.
Improved support for deployment types
Previously, you had to create batch and virtual deployments programmatically. You can now create them from a deployment space. Additionally, you can promote the data assets required for a batch deployment from a project to a deployment space, or upload them directly to the space.
Figure 36. Online and Batch deployment types
Online and Batch deployment types panel

For more information, see Deploying models.

Access control for deployment spaces
Invite users with Watson Machine Learning Server accounts to collaborate in a deployment space.
Figure 37. Add collaborators
Add collaborators panel

For more information, see Deployment spaces.

Support for self-signed certificates
A self-signed certificate provides a certificate to enable SSL sessions between clients and the server. If you have a certificate, you can enter it when you connect to the Watson Machine Learning Server. For more information, see Connecting to IBM Watson Machine Learning Server.
Support for macOS 10.15 (Catalina) operating system for Watson Studio Desktop 1.1
You can install Watson Studio Desktop 1.1 on macOS 10.15.
Support for Google BigQuery SQL pushback for Watson Studio Desktop
SQL pushback is now supported for the Google BigQuery database on Windows and Mac, for flows running on your local computer and not on a remote Watson Machine Learning Server. You must install a specific ODBC driver. See SQL optimization.
New right-click options for nodes in SPSS Modeler flows
You can disable a node so it's ignored when the flow runs. And you can set up a cache on a node. For details, see Disabling nodes in a flow and Caching options for nodes.
Figure 38. Node with empty cache vs. node with full cache
Shows a node with an empty cache and a node with a full cache
New SPSS Modeler documentation
SQL optimization
New documentation is available related to SQL pushback. See the new subsections under SQL optimization.
Type node
New documentation is available for the Type node – one of the most frequently used nodes in SPSS Modeler. See the new subsections under Type node.

In addition, the following features and changes from the 17 December 2019 (Subscription) release are included:

17 December 2019 (Subscription)

Faster and more efficient installation for Subscription
Watson Studio Desktop Subscription introduces a new user interface to install the application. You can choose which add-ons (Modeler or Notebooks) to install and when.
Figure 39. Installation for Subscription offering
Installation for Subscription offering

Choose the steps for your operating system: Installing Watson Studio Desktop (Subscription).

Project export and import
You can now share your project assets with others by exporting your project. You export a project by clicking the Export project icon from the project toolbar.
Figure 40. Export project icon
Shows the export project icon
The project assets that you select are downloaded as a project ZIP file to your desktop. You can then share this ZIP file with other IBM Watson Studio Desktop users who can import your ZIP file and use your assets in their new project.

Currently, you can only import projects that are exported from IBM Watson Studio Desktop. For example, you can't import a project in IBM Watson Studio Desktop that was exported from IBM Watson Studio Cloud. Also note that SPSS Modeler flows aren't currently included. See Exporting a project.

New Text Analytics example project and tutorial
A new example project for Text Analytics is now installed with the product. Go to your projects, open the Example Project for Text Analytics, and open the HotelSatisfaction flow. For details about the flow, see the new Hotel satisfaction example for Text Analytics tutorial.
Figure 41. Text Analytics example
Text Analytics example
Use a SQL SELECT statement to import data
In the Data Asset import node properties, you can now use SQL to import data from your database. See Data Asset node.
Figure 42. Custom SQL
Custom SQL
New SPSS Modeler nodes
The following nodes have been added for SPSS Modeler flows:
Use Data Refinery to change the decimal and thousands grouping symbols in all applicable columns
When you use the Convert column type GUI operation to detect and convert the data types for all the columns in a data asset, you can now also choose the decimal symbol and the thousands grouping symbol if the data is converted to an Integer or to a Decimal data type. Previously you had to select individual columns to specify the symbols.
Figure 43. Automatic conversion for all applicable columns.
Automatic conversion for all applicable columns
Change the source of a Data Refinery flow
To change the source of a Data Refinery flow, click the Edit icon next to Data Source in the Steps panel.
Figure 44. Change the data source in Data Refinery.
Edit data source in Steps panel

For best results, the new data set should have a schema that is compatible to the original data set (for example, column names, number of columns, and data types). If the new data set has a different schema, operations that won’t work with the schema will show errors. You can edit or delete the operations, or change the source to one that has a more compatible schema.

Support for macOS 10.15 (Catalina) operating system for Watson Studio Desktop Subscription
Watson Studio Desktop Subscription is supported on macOS 10.15 for both new installations and for in-app updates.
Previous macOS and Windows operating system versions no longer supported
Watson Studio Desktop (both Subscription and Watson Studio Desktop 1.#) is no longer supported on these operating systems:
  • macOS High Sierra 10.13
  • macOS Sierra 10.12
  • Windows 7
"Object Storage OpenStack Swift (Infrastructure)" connection is discontinued
Support for the Object Storage OpenStack Swift (Infrastructure) connection is discontinued. For information, see Object Storage OpenStack Swift - End of Support.
New SPSS Modeler tutorial
A new Making offers to customers (self-learning) tutorial is available to accompany the twelfth flow in the example project that's installed with the product. As they become available, more tutorials will be added for the rest of the example flows. See SPSS Modeler tutorials.
Figure 45. Example flow for making offers to customers (self-learning)
Example flow for making offers to customers (self-learning)
New SPSS Modeler documentation
New documentation is available that may be helpful in handling missing values in your data. See Missing data values.

14 November 2019 (Version 1.0.1 and Subscription)

Use SPSS Modeler to change the field delimiter and decimal symbols in your source data
Different countries use different symbols to separate the integer part from the fractional part of a number and to separate fields in data. For example, you might use a comma instead of a period to separate the integer part from the fractional part of numbers. And, rather than using commas to separate fields in your data, you might use colons or tabs. Now you can use the new properties of the Data Asset import node and the Data Asset Export node to specify these symbols for field delimiter and decimal symbol. Available delimiters are comma, tab, or colon. Or you can specify your own custom delimiter.
Figure 46. New Data Asset node properties.
New Data Asset node properties
Use Data Refinery to change the decimal and thousands grouping symbols in your source data
Different countries use different symbols to separate the integer part from the fractional part of a number and to group the thousands of a number. Now you can use the Convert column type GUI operation to specify these symbols for Decimal and Integer data types.
Figure 47. Decimal and thousands grouping symbols.
Decimal and thousands grouping symbols in "Convert column type" operation.

For more information, see Convert column type in GUI operations in Data Refinery, under the FREQUENTLY USED category.

Data Refinery detects and converts data types
When you open a file in Data Refinery, for most file types all the columns are interpreted as the String data type. Now you can use the Convert column type GUI operation to detect and convert the data types for all the columns in a data asset.
Figure 48. Automatically detect and convert data types.
Automatically detect and convert data types in the "Convert column type" operation.

For more information, see Convert column type in GUI operations in Data Refinery, under the FREQUENTLY USED category.

New videos

Watch the new videos for a time series modeling example and a visual classification modeling example in SPSS Modeler and how to use visualization charts in Data Refinery.

30 September 2019 (Version 1.0 and Subscription)

New IBM Watson Studio Desktop offering
If you prefer to purchase software instead of subscribing, you now have the choice to purchase Watson Studio Desktop at a one-time fee. Like the Subscription offering, Watson Studio Desktop 1.0 includes all the major SPSS Modeler features, Python notebooks, and Data Refinery. For descriptions of the two offerings, see Watson Studio Desktop offerings.
Connect to Watson Machine Learning Server
IBM Watson Machine Learning Server is available as a separate offering that integrates with Watson Studio Desktop 1.0. When you connect to a Watson Machine Learning Server on your private network, you can use its processing power to run model flows. After you create and train a model in SPSS Modeler or in a Python notebook, you can promote the model from Watson Studio Desktop to a deployment space on the Watson Machine Learning Server, where you can configure, monitor, and deploy the model.
Figure 49. Add machine learning service from the Add-ons and services menu.
Add machine learning service from the Add-ons and services menu.

See Saving and running models on Watson Machine Learning Server and Deploying using the Python client.

New SPSS Modeler nodes
The following nodes have been added for SPSS Modeler flows:
Text Analytics
Advanced text analysis functionality is now available for SPSS Modeler flows. See Text Analytics.
Figure 50. New Text Analytics nodes
New Text Analytics nodes
SQL pushback
You can now push many data preparation and mining operations directly in the database. See SQL optimization.
Flow and SuperNode parameters
You can now set flow parameters in a flow script or in a flow's properties dialog box. You can also set parameters for SuperNodes, in which case they're visible only to nodes encapsulated within that SuperNode. See Flow and SuperNode parameters.
Run Data Refinery flows from Excel files that have the `.xlsx` format
Previously, Watson Studio Desktop supported creating Data Refinery flows only from Excel files with the .xls format. Now Excel files with the .xlsx format are supported. As before, only the first Excel sheet is read.
Set a log level to troubleshoot problems
You can now run a command to set a log level so that you can see different amounts of diagnostic information. See Setting the log level at runtime.
New SPSS Modeler tutorials
Two new tutorials are available to accompany the tenth and eleventh flows in the example project that's installed with the product. As they become available, more tutorials will be added for the rest of the example flows. See SPSS Modeler tutorials.
New Data Refinery tutorial
The Data Refinery tutorial shows you how to build a Data Refinery flow to prepare data. See Data Refinery tutorial: Shape raw data.

11 June 2019 (Subscription)

New SPSS Modeler nodes
The following nodes have been added for SPSS Modeler flows:
New right-click options for SPSS Modeler nodes
Previously, when you right-clicked a node and selected Preview, a Data tab, Profile tab, and Visualizations tab opened—allowing you to examine your flow's data in various ways. Now when you select Preview, you get a snapshot of your data that loads more quickly. Use the new right-click option called Profile to work with the full features such as the Visualizations tab.
Figure 53. Right-click options
Shows the new Profile and Preview right-click options
Export node conversion
Previously, when you imported a stream (.str) that was created in SPSS Modeler Subscription or SPSS Modeler client, Watson Studio Desktop converted your import nodes. Now you can also convert your export nodes. For details about configuring export nodes to export to your project or to a connection, see Importing an SPSS Modeler stream.
Figure 54. Converting export nodes from a stream (.str)
Converting export nodes from a stream (.str)
New SPSS Modeler tutorials
Two new tutorials are available to accompany the eighth and ninth flows in the example project that's installed with the product. As they become available, more tutorials will be added for the rest of the example flows. See SPSS Modeler tutorials.

15 April 2019 (Subscription)

Notebooks
You can now use Jupyter notebooks to analyze your data and form business insights that you share with collaborators. The first time you add a notebook to a project, you are prompted to install the environments for running notebooks. After you have installed the environments, you can start creating your own notebooks.
Figure 57. Notebook
Shows a small piece of code in a notebook and the results of the computation

Learn about working with notebooks.

Analyze data from remote data sources
You can now access data from a remote data source to build your models. Connect to the internet, and then click Add to project > Connection and enter the connection details. The connection is then stored in your project as a data asset.
For Data Refinery
Select the data asset as a source from Connections when you create the Data Refinery flow.
For SPSS Modeler
Select the data asset from Connections when you pull in data with the Data Asset import node or when you write data with the Data Asset export node.
Figure 58. Data sources for connections
Shows list of connection data sources.

See Connection types for the list of on-prem databases and cloud services that you can connect to.

Add scripting to your SPSS Modeler flows
With the new scripting capability in SPSS Modeler flows, you can use scripts to customize operations within your flow. For example, you might want to specify a particular run order for terminal nodes. You can write scripts in Python or in the legacy SPSS scripting language, and a script editor is available to help you with script authoring and syntax. The scripts are saved with the flow.
Figure 59. Scripting in SPSS Modeler flows
Shows scripting in SPSS Modeler flows

See Flow scripting.

Watch this short video for a demo of these features.

Figure 60. Video that introduces notebooks, connections, and scripting.
  
http://ibm.biz/wsd-whats-new
New SPSS Modeler tutorials
Three new tutorials are available to accompany the fifth, sixth, and seventh flows in the example project that's installed with the product. As they become available, more tutorials will be added for the rest of the example flows. See SPSS Modeler tutorials.

27 February 2019 (Subscription)

New SPSS Modeler tutorial
A new Automated data preparation tutorial is available to accompany the fourth flow in the example project that's installed with the product. As they become available, more tutorials will be added for the rest of the example flows. See SPSS Modeler tutorials.

05 February 2019 (Subscription)

Link to data assets
Now you can link to a file instead of loading it into a project. Unlike loading a file, you can reference the file from a directory path on your computer. Linking to a file saves disk space, and you can link to the same file from multiple projects. To link to a file click Add to project > Link to file.
Figure 61. Link to file
Link to file
Work with Microsoft Excel files
  • Refine data from a Microsoft Excel file. Excel files must have the .xls file extension. Only the first sheet is read.
  • Pull Excel data (.xls or .xlsx) into your SPSS Modeler flows by using a Data Asset import node. Only the first sheet is imported.
New SPSS Modeler tutorial
A new Automated modeling for a continuous target tutorial is available to accompany the third flow in the example project that's installed with the product. As they become available, more tutorials will be added for the rest of the example flows. See SPSS Modeler tutorials.
Give us your feedback!
Let us know what you think of Watson Studio Desktop. Click the new Give Feedback link from the Support menu.
Figure 62. Give Feedback
Give Feedback

24 January 2019 (Subscription)

Submit your ideas!
Do you have an idea for a feature or product improvement? Click the new Submit an Idea link from the Support menu.
Figure 63. Submit an Idea
Submit an idea
New nodes
The following nodes have been added for SPSS Modeler flows.
SPSS Modeler tutorials
Two new tutorials have been added to the documentation to accompany the first two flows in the example project that's installed with the product. As they become available, more tutorials will be added for the rest of the example flows. See SPSS Modeler tutorials.

11 December 2018 (Subscription)

Watson Studio Desktop is generally available
Watson Studio Desktop gives you desktop data analysis using the features of the Watson Studio platform. Get started quickly by dropping your data files onto the project's Load pane. Refine your data to remove outliers and shape it for analysis. Then use the fully integrated SPSS Modeler to blend, graph, and develop predictive models. Export to deploy them into business operations to improve decision making.

Start your subscription today. See Purchasing or starting a trial of Watson Studio Desktop (Subscription).