This feature combines the Liberty features that support the Jakarta EE 10.0 Web Profile.

Enabling this feature

To enable the Jakarta EE Web Profile 10.0 feature, add the following element declaration into your server.xml file, inside the featureManager element:

<feature>webProfile-10.0</feature>

Feature configuration elements

Features that this feature enables

Supported Java versions

  • JavaSE-11.0

  • JavaSE-17.0

  • JavaSE-21.0

  • JavaSE-22.0

Developing a feature that depends on this feature

If you are developing a feature that depends on this feature, include the following item in the Subsystem-Content header in your feature manifest file.

io.openliberty.webProfile-10.0; type="osgi.subsystem.feature"