Removal notices

Removal details

Table 1. Removal notices
Fix pack when eligible to be removed Category Item to be removed Strategic alternative
17.0.0.1 Operating systems Support for all versions of Inspur K-UX. Move to a supported operating system as listed in the WebSphere® Application Server detailed system requirements.
17.0.0.3 Java™ Java SE 6

Removal of Java 6 support aligns with the announced end of service date for the IBM® SDK and JRE for Java 6. For more information, see IBM developer kits lifecycle dates.

In this fix pack, the Liberty kernel is recompiled and can no longer run with Java SE 6.

Use a more recent Java software development kit (SDK) or Java runtime environment (JRE). Liberty can run with any supported and compliant Java SDK or JRE, including IBM Java SDKs.

For IBM i platformsFor distributed platformsFor information about installing Liberty from a ZIP file with Java, see Installing Liberty by extracting a ZIP archive file.

18.0.0.2 Installation Packaging for the Liberty runtime environment, extended programming models, and extras in the following Java archive (JAR) files:
  • wlp-<edition>-runtime-<fix_pack>.jar
  • wlp-<edition>-extended-<fix_pack>.jar
  • wlp-<edition>-extras-<fix_pack>.jar

Installation Manager installable Embeddable EJB container and JPA client feature (embeddablecontainer). The embeddable container feature is the Installation Manager equivalent packaging of the wlp-<edition>-extras-<fix_pack>.jar file.

Instead of the runtime environment and extended programming models JARs, install Liberty from the JAR files that contain the runtime environment and all features that apply to the edition.

The names of these JAR files have the following format:

wlp-<edition>-all-<fix_pack>.jar

For example, wlp-nd-all-16.0.0.2.jar

For more information about installation JAR files, see List of installation Java archive files.

There are no alternatives for the Installation Manager embeddable container feature and extras JAR file.

18.0.0.3 Operating systems Support for all versions of the following operating systems:
  • HP-UX
  • Red Hat Enterprise Linux® (RHEL) on POWER® Systems - Big Endian
  • SUSE Linux Enterprise Server (SLES) on POWER Systems - Big Endian
  • Solaris
Move to a supported operating system as listed in the WebSphere Application Server detailed system requirements.
19.0.0.3 Tools The Liberty Ant plug-in that is packaged with Liberty at wlp/dev/tools/ant/wlp-anttasks.jar, as described in Using Ant to automate tasks for Liberty. Use the open source Liberty Ant plug-in, which provides more Ant tasks and the latest capability. For information about configuring the plug-in, see the WASdev/ci.ant repository on GitHub.
19.0.0.4 Tools OpenShift cartridge for Liberty As of OpenShift V3, cartridges are no longer supported. Instead, use WebSphere Liberty Docker Hub images or IBM® Cloud Pak for Applications to enable the Liberty server to be available on OpenShift.
19.0.0.9 Java Java SE 7

The Liberty end of support date for Java SE 7 is September 2019.

In the 19.0.0.9 fix pack, the Liberty kernel is recompiled and can no longer run with Java SE 7.

Use a more recent Java software development kit (SDK) or Java runtime environment (JRE). Liberty can run with any supported and compliant Java SDK or JRE, including IBM Java SDKs.

For IBM i platformsFor distributed platformsFor information about installing Liberty from a ZIP file with Java, see Installing Liberty by extracting a ZIP archive file.

23.0.0.10 Installation The WAS Liberty with OSGi Applications package, wlp-osgi-<fix_pack>.zip, as described in List of installation ZIP archive files. Install Liberty with one of the other installation ZIP archive files and then use the installUtility command to add the OSGi features.