IBM Web Server Plug-in Analyzer (WSPA) for WebSphere Application Server

 

IBM Web Server Plug-in Analyzer Creator/Architect/Developer

Jinwoo Hwang

jinwoo@us.ibm.com

 

Welcome to IBM Web Server Plug-in Analyzer for WebSphere Application Server. IBM Web Server Plug-in Analyzer for WebSphere Application Server allows you to find request/response delays, configuration issue, errors, statistics and HTTP return codes from WebSphere trace files.

Acknowledgement

I appreciate the technical advice and requirement analysis from Robert Hill, Robert Boretti and other colleagues and support from WebSphere Application Server Technical Support management team.

 

Prerequisite

Features

 

History

·      V3.5 : Fixed defects in cluster filter

·      V3.4 : Fixed defects in request view

·      V3.3 : Fixed defects in session view

·      V3.2 : Fixed defects in trace view

·      V3.1 : Improved Analysis Window Interface

·      V3.0 : Supports Session Analysis

·      V2.7 : Fixed defects in request parser

·      V2.5 : Fixed parser of WebSphere Application Server V6.1 Plug-in

·      V2.1 : Added file type recognition engine

·      V2.0 : Plug-in connection analysis

·      V1.5 : Fixed analysis window problem

·      V1.1 : Fixed DOM parser error

·      V1.0 : First release at alphaWorks (http://www.alphaworks.ibm.com/tech/wspa)

 

How to enable traces for WebSphere Application Server

Please refer to the following document for detailed instruction on how to enable Plug-in traces for WebSphere Application Server:

MustGather: Read first for all WebSphere Application Server products

http://www-1.ibm.com/support/docview.wss?uid=swg21145599

 

How to run IBM Web Server Plug-in Analyzer for WebSphere Application Server

You need to use the Java 2 Platform, Standard Edition version 1.4.1 or higher Java Runtime Environment (JRE) to run IBM Thread and Monitor Dump Analyzer for Java Technology.

Usage <Java path>java –Xmx[heapsize] –jar wspa<IBM Web Server Plug-in Analyzer version>.jar

For example,

C:\java\bin\java –Xmx200m –jar wspa11.jar

=> Starts IBM Web Server Plug-in Analyzer for WebSphere Application Server

 

If there’s java.lang.OutOfMemoryError while you are processing trace files, please try increasing the maximum heap size (-Xmx) value to give the JVM more memory.

Maximum heap size should not be larger than the size of available physical memory size for this tool due to performance issue.

 

1. Start IBM Web Server Plug-in Analyzer for WebSphere Application Server

The following screen is a snapshot of the initial screen. 

2. Select File-> Open Configuration File to analyze Plug-in configuration parameters:


 

3.  Select configuration file(s) that you want to analyze to display configuration analysis.

 

4. Select File->Open Trace File to open Plug-in trace file

 

5. Select trace file(s) that you want to check Plug-in build date and other information:

 

 

6. Select Analysis-> Plug-in Trace Analysis to start analysis:

 

7. Analysis dialog box is displayed with available clusters and members from configuration file:

8. Select “All servers” or specific servers/clusters, HTTP response Code, URI, start/end time and analysis filter and click on Analysis button to start analysis.

The following is the screenshot of Stats Analysis. The table has list of stats and lower panel has associated actual trace lines.

 

9. The following is the screenshot of Error Analysis. The table has list of errors and lower panel has associated actual trace lines.

 

 

10. The following is the screenshot of Request Analysis. The table has list of requests, middle pane has request informaion and lower panel has associated actual trace lines.

 

 

11. The following is the screenshot of HTTP response code Analysis. The table has list of response code, middle pane has response informaion and lower panel has associated actual trace lines.

 

You can select “STATS Analysis” for clusters or servers

The following is connection analysis chart:

 

 

 

12. Select configuration file(s) and Analysis-> Cluster Topology View to review configuration details:

13. Cluster Topology view has cluster/member structure and associated property/value:

 

14. Select View -> Options to change options



15. The following options can be changed:

·        Default directory for opening files

·        Number of lines to display : Number of trace entries before and after each line in lower half of the screen as seen at step 15.

·        Verbose : Prints out more information in Console

·        Save option : Options will be saved automatically

·        Look and feel : User interface configuration



16. You can clear console, hide/show Statusbar and Console from View menu:


17. Product information and Help can be found by selecting Help->About and Help->Help Topics


Copyrights and Notices

 

(C) Copyright IBM Corporation 2006-2008. All Rights Reserved. Note to U.S. Government Users Restricted Rights -- Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

 

AIX, Cloudscape, DB2, IBM, iSeries, OS/390, WebSphere, and z/OS are trademarks or registered trademarks of IBM Corporation in the United States and/or other countries.

 

Java and all Java-based trademarks and logos are trademarks of Sun Microsystems, Inc. in the United States and/or other countries.

 

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the United States and/or other countries.

 

UNIX is a registered trademark of The Open Group.

 

Other company, product, and service names may be trademarks or service marks of others.

 

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:

 

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS TOOLS "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OR CONDITIONS OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you. This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the tool. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this tools at any time without notices.