New features in IBM SPSS Modeler 18.2

IBM® SPSS® Modeler adds the following features in this release.

  • New look and feel. A new modern interface theme is available via Tools > User Options > Display. For instructions on switching to the new theme, see Setting display options.
  • New data views. You can now right-click a data node and select View Data to examine and refine your data in new ways with advanced data visualizations. For more information, see Working with data. Note that this new feature uses port 28900 by default. If you need to use a different port, change the value for the data_view_port_number configuration setting in your options.cfg file.
  • IBM Data Warehouse. Database modeling with IBM Netezza Analytics now supports IBM Data Warehouse. To enable the nodes on the Database Modeling tab in the nodes palette, go to Tools > Options > Helper Applications and enable IBM Data Warehouse integration on the IBM Data Warehouse tab. When you run one of the available Netezza nodes, the built model will now be written to your IBM DB2 Data Warehouse. AIX isn't supported.
  • Gaussian Mixture node. A new Gaussian Mixture node is available on the Python tab and the Modeling tab of the Nodes palette. For details, see Gaussian Mixture node.
  • Kernel Density Estimation (KDE) nodes. A new KDE Modeling node is available on the Python tab and the Modeling tab of the Nodes palette. A new KDE Simulation node is available on the Python tab and the Output tab. For details, see KDE nodes.
  • Hierarchical Density-Based Spatial Clustering (HDBSCAN) node. A new HDBSCAN node is available on the Python tab and the Modeling tab of the Nodes palette. For details, see HDBSCAN node.
  • JSON nodes. New JSON nodes are available for importing and exporting data in JSON format. For details, see JSON Source node and JSON Export node.
  • AIX. AIX is a supported platform for 18.2. For more information about supported environments, see the software product compatibility reports.
  • IBM SPSS Modeler Text Analytics enhancements. The following enhancements have been made. Most of these enhancements are similar to functionality found in IBM SPSS Text Analytics for Surveys .
    • You can now import SPSS Text Analytics for Surveys projects (.tas) in the same way you can import resources from text analysis packages (.tap). When configuring a text mining modeling node, you must specify the resources that will be used during extraction. Instead of choosing a resource template, you can select a .tap or a .tas (new) in order to copy not only its resources but also a category set into the node.
    • Flags are now available in the Data pane. You can flag documents with a "complete" flag or an "important" flag. A new column shows any flags you may be using, and you can click inside the column to change the flag type. This is useful for reviewing the completeness of a category model. See Flagging responses.
    • Extracted concept results have been improved (they're now similar to extracted concept results in SPSS Text Analytics for Surveys )
    • Empty records are now handled the same was as they are in SPSS Text Analytics for Surveys . For example, with an Excel source file, empty records are now kept as part of the text.
    • New Force In and Force Out options are available in the Data pane to force records into or out of a category. This is useful in the case of empty records or records with no extracted concepts, and also when no concept or TLA output enables you to find the appropriate category. See Forcing Responses into Categories.
    • Type Reassignment Rules (TRRs) are now available. TRRs transform a sequence of types, macros, and/or tokens into a new concept with a specific type. They can be used in Opinions templates to catch opinions with a change in polarity. For details, see Type Reassignment Rules.
    • A new option called Score only lowest-level matching category is available for generated text nuggets. Use this option to output a category only on one single line (for example, if the category is GeneralSatisfaction/Pos, selecting this option results in GeneralSatisfaction/Pos. Without this option, you would get two lines: GeneralSatisfaction and GeneralSatisfaction/Pos).