Operating system support

LSF supports various operating systems.

Table 1. Supported operating systems
Operating system Version CPU or hardware Package name Support
HP-UX 11.31 (IA64) HP Integrity Servers (Itanium2) lsf10.1_hpuxia64.tar.Z Supported
IBM AIX 7.x IBM Power 7, IBM Power 8, and IBM Power 9 lsf10.1_aix-64.tar.Z Supported
SUN Solaris on SPARC 10 SPARC 64bit (T2)SPARC 64bit (T2) lsf10.1_sparc-sol10-64.tar.Z Supported
11 Supported
SUN Solaris on x86-64 10 x86-64 lsf10.1_x86-64-sol10.tar.Z Supported
11 Supported
Linux x64 kernel RHEL 6.x, kernel 2.6, glibc 2.11 (including RHEL 6.8 and 6.9) x86 lsf10.1_linux2.6-glibc2.3-x86_64.tar.Zlsf10.1_lnx310-lib217-x86_64.tar.Z (for kernels above 3.10) Supported
RHEL 7.x, kernel 3.10, glibc 2.17 Certified
RHEL 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, or 8.6 kernel 4.18, glibc 2.28 Certified
RHEL 9.0 kernel 5.14, glibc 2.34 Certified
SLES 11.x, kernel 3.0, glibc 2.11 Supported
SLES 12.x, kernel 3.11, glibc 2.18 Certified
SLES 15, kernel 4.16, glibc 2.26 Certified
SLES 15.2, kernel 5.3.18, glibc 2.26 Certified
CentOS 7.x, kernel 3.10, glibc 2.17 Certified
CentOS 8.0, 8.1, 8.2, or 8.3, kernel 4.18, glibc 2.28 Certified
Ubuntu 16.04 LTS, kernel 4.4, glibc 2.23 Certified
Ubuntu 18.04 LTS, kernel 4.15, glibc 2.27 Certified
Ubuntu 20.04 LTS, kernel 5.4, glibc 2.31 Certified
SGI Performance Suite Kernel 2.6, glibc 2.3 Supported
Generic Linux: Debian, Ubuntu, and OEL Kernel 2.6 or 3.0, glibc 2.3 or later. Supported
Linux kernel on IBM Power LE (Little Endian) Ubuntu 14.04, kernel 3.13, glibc 2.19 IBM Power 8 LE, IBM Power 9 LE, and IBM Power 10 LE lsf10.1_lnx310-lib217-ppc64le.tar.Z Supported
Ubuntu 16.04 LTS, kernel 4.4, glibc 2.23 Certified
RHEL 7.x, kernel 3.10, glibc 2.17 Certified
RHEL 8.0, 8.1, 8.2, 8.3, 8.5, or 8.6 kernel 4.18, glibc 2.28 Certified
RHEL 9.0 kernel 5.14, glibc 2.34 Supported
CentOS 8.0, 8.1, 8.2, or 8.3, kernel 4.18, glibc 2.28 Certified
SLES 12.x, kernel 3.11, glibc 2.18 Certified
Ubuntu 16.04 LTS, kernel 4.4, glibc 2.23 Supported
Ubuntu 18.04 LTS, kernel 4.15, glibc 2.27 Certified
SLES 12.x, kernel 3.11, glibc 2.18 Supported
RHEL 7.x, kernel 3.10, glibc 2.17 Certified
RHEL 7.5, kernel 4.14, glibc 2.17 Certified
Apple OS X (compute host only) 10.8 x86-64 lsf10.1_macosx.tar.Z Supported
10.9 Supported
10.15 x86-64 lsf10.1_macos-x86_64.tar.Z Supported
Linux ARM ARMv7 x1_358 lsf10.1_lnx36-lib215-armv7.tar.Z Supported
ARMv8 AArch64 lsf10.1_linux3.12-glibc2.17-armv8.tar.Z Supported
Cray XE6, XT6, or XC30 Kernel 2.6, glibc 2.3 x86-64 lsf10.1_lnx26-lib23-x64-cray.tar.Z Certified
Microsoft Windows Windows 2008 x64 x86-64 lsf10.1_win-x64.msi Supported
Windows 7 x64 Supported
Windows 8.1 x64 Supported
Windows 2008 R2 x64 Supported
Windows HPC Server 2008 Supported
Windows 2012 x64 Supported
Windows 2012 R2 x64 Certified
Windows 10 x64 Supported
Windows Server 2016 TP4 x64 Certified
Windows Server 2019 x64 Certified

End of life (EOL) notice

When a specific release or version of an operating system reaches end of life (EOL) or its end of support date, the operating system vendor no longer supports and releases updates for the product, including automatic fixes, updates, and online technical assistance.

IBM Spectrum LSF (LSF), in turn, no longer provides support for products that reached their end of support dates. Running LSF on a non-supported operating system, or one that is no longer supported by the vendor, is at your own risk.