Supported environments

This release is supported on certain hardware platforms and operating systems, and is tested on specific virtualization environments.

Any new updates to these support statements can be found in the Current news technote.

There are a number of distributions provided for the Linux operating system.

For Linux on x86, the following platform architectures are supported:
  • x86-32
  • x86-64
For Linux on IBM® POWER®, the following hardware is supported:
  • IBM POWER 6
  • IBM POWER 7
  • IBM POWER8®
Note: IBM POWER8 systems can operate in both Big Endian (BE) or Little Endian (LE) format. An LE version of the SDK is available for 64-bit Power® Systems to support those operating systems that are available in LE format. For example, SUSE Linux Enterprise Server (SLES) 12 or Ubuntu 14.04 LTS.
For Linux on IBM Z, the following hardware is supported:
  • IBM z14
  • IBM z13® 1
  • IBM zEnterprise® EC12
  • IBM zEnterprise BC12
  • IBM zEnterprise 196
  • IBM zEnterprise 114
  • IBM System z10™
  • IBM System z9® 2
Notes:
  1. If you are migrating from EC12, z196, z10, or z9 systems to a z13 system, you must update to service refresh 2 fix pack 10 to avoid a performance degradation.
  2. This product is withdrawn from marketing.
The following table shows the operating systems supported for each platform architecture. The table also indicates whether support for an operating system release was included at the "general availability" (GA) date for the release, or at a later date in a service refresh (SR) or fix pack (FP):
Table 1. Supported Linux environments
Hardware x86 systems POWER systems IBM Z
Release address space 32-bit 64-bit 32-bit 64-bit 31-bit 64-bit
SLES 11 service pack 2 GA GA GA (see note 1) GA GA GA
SLES 12 SR2 SR2 - SR2 (see note 2) SR2 SR2
RHEL 6 Update 4 GA GA GA GA GA GA
RHEL 7 SR1 FP1 SR1 FP1 SR1 FP1 SR1 FP1 SR1 FP1 SR1 FP1
RHEL 7.1 SR3 SR3 SR3 SR3 (see note 3) SR3 SR3
RHEL 7.2 SR3 FP20 SR3 FP20 SR3 FP20 SR3 FP20 (see note 3) SR3 FP20 SR3 FP20
RHEL 7.3 SR4 FP1 SR4 FP1 SR4 FP1 SR4 FP1 (see note 3) SR4 FP1 SR4 FP1
RHEL 7.4 SR4 FP10 SR4 FP10 SR4 FP10 SR4 FP10 SR4 FP10 SR10 FP1
Ubuntu 12.04 LTS GA GA - - - -
Ubuntu 14.04 LTS SR1 SR1 - SR1 (see note 2) - -
Ubuntu 16.04 LTS SR3 FP40 SR3 FP40 - SR3 FP40 (see note 2) - SR3 FP40
Notes:
  1. An issue is identified when running on SLES 11 SP2 with kernel levels before 3.0.31-0.9.1. For more information about this issue, see Runtime crash when running on SUSE Linux Enterpriser Server (SLES) 11 service pack 2.
  2. Supported only on POWER 8 systems with the LE version of the SDK.
  3. Supported on POWER systems with the BE version of the SDK, and on POWER 8 systems with the LE version of the SDK.
  4. The following operating systems are no longer supported:
    • SLES 10
    • RHEL 5
    • Ubuntu 8.04
    • Ubuntu 10.04

Specialized hardware features

The following hardware features have additional prerequisites to those listed in this topic:

Virtualization software

For information about the virtualization software tested, see Support for virtualization software.