Software requirements (disconnected scenario)

Ensure that all prerequisite software is installed on the computers in your infrastructure.

Server requirements

For information about operating systems on which DB2® and MS SQL Server are supported, see: Supported operating systems.

Table 1. Requirements for the License Metric Tool server
  Version Description
DB2
  • DB2 11.1 with Fix Pack 1 or higher
  • DB2 11.5
Availability

DB2 is delivered with License Metric Tool free of charge. However, according to the license agreement, it can be used only by License Metric Tool.

Operating system requirements

To use DB2 as a database, License Metric Tool must be installed on Linux®.

DB2 Fix Packs
For the list of available Fix Packs, see the following links.
DB2 requirements
For information about the database requirements, see the following links.
DB2 edition
Any of the supported DB2 editions is sufficient to work with License Metric Tool regardless of the number of endpoints. However, some editions (for example, Advanced Server Edition) give you access to advanced features of DB2.

For the list of DB2 editions supported by License Metric Tool, see: IBM License Metric Tool 9.2 - supported operating systems.

DB2 settings
  • Use a DB2 instance with default settings. Other required database settings are configured by License Metric Tool installer.
  • Make sure that the file system where the DB2 instance directory resides is not mounted as NOSUID or NOEXEC (or both).
Restriction: If you specify non-default DB2 settings, License Metric Tool might not work properly.
ksh for DB2

The License Metric Tool server and DB2 can work without ksh which is not installed by default in new distributions of Red Hat Enterprise Linux. However, DB2 might require ksh for some troubleshooting procedures. If you need to use DB2 tools such as db2cos or db2fodc, you might need to additionally install ksh. You can do this at any point of time after installing License Metric Tool.

MS SQL Server
  • 2012 SP 2 with CU 5 or higher
  • 2012 Express® SP 2 with CU 5 or higher
  • 2014
  • 2014 Express
  • 2016
  • 2016 Express SP2 or higher
  • 2017 with CU15 or higher
  • 2017 Express with CU15 or higher
  • 2019
  • 2019 Express
Availability
MS SQL Server is not delivered as part of License Metric Tool.
Operating system requirements

To use MS SQL Server as a database, License Metric Tool must be installed on Windows.

MS SQL Server Express edition

To use MS SQL Server Express Edition, additional configuration is required to use MS SQL Server Express. For more information, see: Configuring SQL Server Express.

MS SQL Server settings
  • Ensure that snapshot isolation is enabled in the MS SQL Server. For information about the requirements, see the MS SQL Server documentation.
  • The support for AlwaysOn solution has not been tested.
  • The AUTO_UPDATE_STATISTICS feature is by default enabled on the MS SQL Server database. If you disable this feature, performance of the import might be considerably degraded.
Important: If you use MS SQL Server 2012, install at least cumulative update 5 for MS SQL Server 2012 SP2 to prevent possible corruption of the database. For the list of cumulative updates, see: MS SQL Server® 2012 SP2 Latest Cumulative Update.
Permissions and roles
For more information about permissions and roles of MS SQL Server user, see: Permissions and roles.
Linux icon X server
  • X11R7.x
The X server is required if you want to install or uninstall the License Metric Tool server in interactive mode on Red Hat Enterprise Linux. It is also required if you want to complete the server configuration by using a browser that is available on the computer where the License Metric Tool server is installed.
Restriction: XMing X Server for Windows is not supported.

Browser requirements

Table 2. Browser requirements
Browser Browser-specific information General information
Chrome 35 or higher You can experience problems with checking the detailed information about the metric quantity on the Metric Quantity History and Maximal Trend Value History graphs on License Metrics reports. Once you hover over the graph, the information about metric quantity might not be properly displayed, or might not appear at all.  
Firefox 17 Extended Support Release (ESR) or higher ESR editions To use TLS 1.2, check whether your version of the browser supports it and whether it is enabled. Otherwise, use TLS 1.0 for secure communication with SSL.
Requirements
  • JavaScript must be enabled in the browser.
  • Minimal supported screen resolution is 1360x768 pixels.
  • Recommended screen resolution is 1920x1080 pixels.
Proxies
Proxies are supported and depend on the server configuration. With the default configuration, use SSL proxies. If you disabled SSL on the server, then use HTTP proxies. In big environments, the connections might time out with time-consuming operations (downloading extensive reports). In such a case, increase the timeout limit for communication between the proxy and License Metric Tool.
9.2.14 Microsoft Edge
  • In reports where IP Address column is enabled, the IP address is a link that is activated by an external plug-in, such as Skype. To remove the link, disable the plug-in.
  • You can experience problems with checking the detailed information about the metric quantity on the Metric Quantity History and Maximal Trend Value History graphs on License Metrics reports. Once you hover over the graph, the information about metric quantity might not be properly displayed, or might not appear at all.

Red Hat packages

The following packages are required if you install the components on Red Hat Enterprise Linux.

Table 3. Red Hat packages that are required for the installation
Component Required packages
All-in-One installation
  • All packages required for DB2 (listed below)
  • glibc.x86_64 in version 2.7 or higher
DB2
  • libaio.x86_64
  • libstdc++.i686
  • mksh.x86_64
  • numactl.x86_64
  • pam.i686 and all dependencies
  • psmisc.x86_64
  • Red Hat binutils