Installing language packs for the IBM Integration Toolkit

You can install one or more language packs for the IBM® Integration Toolkit. If your operating system locale is configured for one of the languages that is supported by the language packs that you install, the IBM Integration Toolkit automatically uses that language.

Before you begin

From the IBM Integration Toolkit menu, you can verify whether any language packs are installed by clicking Help > About IBM Integration Toolkit > Installation Details.
Obtain the IBM Integration Toolkit Language Pack feature from one of the following sources:
  • If you have the IBM Integration Bus product on DVD, the language pack is stored in the nls folder on the DVD.
  • If you do not have the IBM Integration Bus product on DVD, you can download the IBM Integration Toolkit Language Pack feature from the following URL: ftp://public.dhe.ibm.com/software/integration/integrationbus/nl.

    Make sure that you download the version of the IBM Integration Toolkit Language Pack feature that matches your version of IBM Integration Bus.

Note: You do not need to extract the files from the .zip file.

About this task

The IBM Integration Toolkit Language Pack feature contains language packs for the following languages:
  • German, Spanish, French, Italian, Japanese, Korean, Portuguese Brazilian, Simplified Chinese, Traditional Chinese (Language Pack 1)
  • Polish, Russian (Language Pack 2)
  • Turkish (Language Pack 2a)

Installing language packs by using the IBM Integration Toolkit

Procedure

  1. Start the IBM Integration Toolkit.
  2. From the menu, click Help > Install New Software. The Available Software dialog is displayed.
  3. Click Add and enter a name for the repository. For example: Language Packs.
  4. Click Archive, navigate to where you downloaded the IBM Integration Toolkit Language Pack feature, and click OK. The IBM Integration Toolkit Language Pack feature is displayed.
  5. Expand the IBM Integration Toolkit Language Pack feature to display the individual language packs, select the check boxes for the language packs that you want to install, and click Next.
  6. Click Next again, click to accept the license, and then click Finish. The selected language packs are installed and you are prompted to restart the IBM Integration Toolkit.
  7. Click Yes to restart the IBM Integration Toolkit. If your operating system locale is configured for one of the languages that is supported by the language packs that you installed, the IBM Integration Toolkit user interface is displayed in that language.
    Note: If any of the perspective names or view names are still displayed in English, complete the following steps:
    1. If a perspective name is displayed in English, complete the following steps:
      1. Close the perspective by selecting the perspective and clicking Window > Close Perspective.
      2. Reopen the perspective by clicking Window > Open Perspective > Other, selecting the perspective name, and clicking OK.
    2. If a view name is displayed in English, complete the following steps:
      1. Close the view by clicking the cross on the view tab.
      2. Reopen the view by clicking Window > Show View, selecting the view name, and clicking OK.
    3. If view names or perspective names are still displayed in English, complete the following steps to create a new workspace:
      1. Click File > Switch Workspace > Other, enter a new workspace directory, and click OK. The new workspace opens and all view names and perspective names are displayed in the expected language.
      2. To import the projects from your original workspace, complete the following steps:
        1. Click File > Import > General > Existing Projects into Workspace, and click Next.
        2. In Select root directory, browse to the location of your original workspace, click OK, and then click Finish.
        Any projects from your original workspace are added to your new workspace.

Results

You have installed one or more language packs by using the IBM Integration Toolkit.

Installing language packs by using the command line

Procedure

  1. Extract the contents of the IBM Integration Toolkit Language Pack feature to a folder on your computer.
  2. At the command line, type the following command on a single line:
    • On Windows:
      InstallPath\common\jdk\jre\bin\java 
      -jar InstallPath\tools\plugins\org.eclipse.equinox.launcher_1.3.0.v20130327-1446.jar 
      -launcher InstallPath\tools\eclipse 
      -application org.eclipse.equinox.p2.director 
      -repository file:FeatureDirectory 
      -installIU LanguagePack
    • On Linux:
      InstallPath/common/jdk/jre/bin/java 
      -jar InstallPath/tools/plugins/org.eclipse.equinox.launcher_1.3.0.v20130327-1446.jar 
      -launcher InstallPath/tools/eclipse 
      -application org.eclipse.equinox.p2.director 
      -repository file:FeatureDirectory 
      -installIU LanguagePack
    where:
    InstallPath
    Specifies the directory where IBM Integration Bus is installed.
    FeatureDirectory
    Specifies the directory where you extracted the IBM Integration Toolkit Language Pack feature. For example, C:\Downloads\iit.nl.p2repo.10.0.0.0
    LanguagePack
    Specifies the language pack or language packs that you want to install:
    • To install all language packs, type com.ibm.etools.iib.toolkit.nl.feature.group
    • To install Language Pack 1 only, type com.ibm.etools.iib.toolkit.nl1.feature.group
    • To install Language Pack 2 only, type com.ibm.etools.iib.toolkit.nl2.feature.group
    • To install Language Pack 2a only, type com.ibm.etools.iib.toolkit.nl2a.feature.group
    • To install more than one language pack, separate the entries with a comma.

    For example, to install Language Pack 1 and Language Pack 2 on Windows, where IBM Integration Bus is installed in the default location, and the IBM Integration Toolkit Language Pack feature is extracted to the folder C:\Downloads\iit.nl.p2repo.10.0.0.0, type the following command on a single line:

    "C:\Program Files\IBM\IIB\10.0.0.0\common\jdk\jre\bin\java" 
    -jar "C:\Program Files\IBM\IIB\10.0.0.0\tools\plugins\org.eclipse.equinox.launcher_1.3.0.v20130327-1446.jar" 
    -launcher "C:\Program Files\IBM\IIB\10.0.0.0\tools\eclipse" 
    -application org.eclipse.equinox.p2.director 
    -repository file:C:\Downloads\iit.nl.p2repo.10.0.0.0 
    -installIU com.ibm.etools.iib.toolkit.nl1.feature.group,com.ibm.etools.iib.toolkit.nl2.feature.group
    A message is displayed listing the language packs that are being installed. When the installation is complete, a message is displayed that details how long the installation took. For example:
    Installing com.ibm.etools.iib.toolkit.nl1.feature.group 10.0.0.0.
    Installing com.ibm.etools.iib.toolkit.nl2.feature.group 10.0.0.0.
    Operation completed in 65037 ms.

    If your operating system locale is configured for one of the languages that is supported by the language packs that you installed, the next time that you start the IBM Integration Toolkit, the user interface is displayed in that language.

    Note: If any of the perspective names or view names are still displayed in English, complete the following steps:
    1. If a perspective name is displayed in English, complete the following steps:
      1. Close the perspective by selecting the perspective and clicking Window > Close Perspective.
      2. Reopen the perspective by clicking Window > Open Perspective > Other, selecting the perspective name, and clicking OK.
    2. If a view name is displayed in English, complete the following steps:
      1. Close the view by clicking the cross on the view tab.
      2. Reopen the view by clicking Window > Show View, selecting the view name, and clicking OK.
    3. If view names or perspective names are still displayed in English, complete the following steps to create a new workspace:
      1. Click File > Switch Workspace > Other, enter a new workspace directory, and click OK. The new workspace opens and all view names and perspective names are displayed in the expected language.
      2. To import the projects from your original workspace, complete the following steps:
        1. Click File > Import > General > Existing Projects into Workspace, and click Next.
        2. In Select root directory, browse to the location of your original workspace, click OK, and then click Finish.
        Any projects from your original workspace are added to your new workspace.

Results

You have installed one or more language packs by using the command line.