Supported NGINX versions and platforms

NGINX sensor and NGINX tracing have different version and platform requirements. See the following sections:

Supported NGINX versions and platforms for NGINX sensor

NGINX sensor supports metrics and configuration data for all NGINX, NGINX Plus, and OpenResty versions, which are installed in the operating systems that are supported by NGINX, NGINX Plus, or OpenResty.

Note: NGINX on Windows is not supported.

Supported NGINX versions and platforms for NGINX tracing

Instana provides tracing support for the following NGINX, NGINX Plus, and OpenResty versions and operating systems:

  • NGINX Plus R30 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R29 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R28 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R27 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R26 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R25 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R24 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R23 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R22 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R21 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R20 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R19 for Glibc-based Linux and Alpine Linux
  • NGINX Plus R18 for Glibc-based Linux and Alpine Linux
  • NGINX 1.24.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.23.4 for Glibc-based Linux and Alpine Linux
  • NGINX 1.23.3 for Glibc-based Linux and Alpine Linux
  • NGINX 1.23.2 for Glibc-based Linux and Alpine Linux
  • NGINX 1.23.1 for Glibc-based Linux and Alpine Linux
  • NGINX 1.23.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.22.1 for Glibc-based Linux and Alpine Linux
  • NGINX 1.22.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.21.6 for Glibc-based Linux and Alpine Linux
  • NGINX 1.21.5 for Glibc-based Linux and Alpine Linux
  • NGINX 1.21.4 for Glibc-based Linux and Alpine Linux
  • NGINX 1.21.3 for Glibc-based Linux and Alpine Linux
  • NGINX 1.21.2 for Glibc-based Linux and Alpine Linux
  • NGINX 1.21.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.20.2 for Glibc-based Linux and Alpine Linux
  • NGINX 1.20.1 for Glibc-based Linux and Alpine Linux
  • NGINX 1.20.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.10 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.9 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.8 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.7 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.6 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.5 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.4 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.3 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.2 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.1 for Glibc-based Linux and Alpine Linux
  • NGINX 1.19.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.18.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.10 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.9 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.8 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.7 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.6 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.5 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.4 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.3 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.2 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.1 for Glibc-based Linux and Alpine Linux
  • NGINX 1.17.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.16.1 for Glibc based Linux, Alpine Linux, Alpine Linux 3.11/3.10, CentOS/RHEL 7
  • NGINX 1.15.12 for Glibc-based Linux and Alpine Linux
  • NGINX 1.15.10 for Glibc-based Linux and Alpine Linux
  • NGINX 1.15.0 for Glibc-based Linux and Alpine Linux
  • NGINX 1.14.2 for Glibc-based Linux, Alpine Linux, Alpine Linux 3.9/3.8, and Debian 10/9
  • NGINX 1.14.1 for Glibc-based Linux and Alpine Linux
  • NGINX 1.14.0 for Glibc-based Linux, Alpine Linux, and Ubuntu 18.04