[OpenShift Container Platform][CP4I Long Term Support][Continuous Delivery][IBM Cloud Pak for Integration]

Release history for Queue Manager Container images for use with IBM MQ Operator

Note: For information about earlier Queue Manager Container images, see Release history for IBM® MQ Operator in the IBM MQ 9.2 documentation.
[Continuous Delivery]

9.3.5.1-r2

Required operator version
3.1.3 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.5.1-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.5.1-r2
  • icr.io/ibm-messaging/mq:9.3.5.1-r2
What's new
What's changed
[Continuous Delivery]

9.3.5.1-r1

Required operator version
3.1.2 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.5.1-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.5.1-r1
  • icr.io/ibm-messaging/mq:9.3.5.1-r1
What's new
What's changed
[Continuous Delivery]

9.3.5.0-r2

Required operator version
3.1.1 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.5.0-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.5.0-r2
  • icr.io/ibm-messaging/mq:9.3.5.0-r2
What's new
What's changed
[Continuous Delivery]

9.3.5.0-r1

Required operator version
3.1.0 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.5.0-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.5.0-r1
  • icr.io/ibm-messaging/mq:9.3.5.0-r1
What's new
What's changed
  • What's changed in IBM MQ 9.3.5
  • Based on Red Hat Universal Base Image 8.9-1137
  • A symbolic link is provided to /var/mam where unencrypted credentials in mqwebuser.xml would be copied.
  • golang.org/x/crypto library has been upgraded to remediate CVE-2023-48795 vulnerability.
  • More secure SHA512 algorithm used instead of SHA256 to create self-signed certificate in the web keystore.
  • PKCS#12 key store for use with the IBM MQ web server is now generated using the Pkcs12.Modern.Encode function, which uses SHA-2 encryption (previously generated using a legacy SHA-1 encryption).
  • Vulnerability reported on PathTraversal method usages is fixed.
[Continuous Delivery]

9.3.4.1-r1

Required operator version
3.0.1 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.4.1-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.4.1-r1
  • icr.io/ibm-messaging/mq:9.3.4.1-r1
What's new
What's changed
[Continuous Delivery]

9.3.4.0-r1

Required operator version
3.0.0 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.4.0-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.4.0-r1
  • icr.io/ibm-messaging/mq:9.3.4.0-r1
What's new
What's changed
  • What's changed in IBM MQ 9.3.4
  • Based on Red Hat Universal Base Image 8.9-1029
  • Improved support for the IBM MQ web server — The IBM MQ web server log now appears by default in the container log. The web server's messages.log file is now automatically mirrored to the container log output. As part of this change, the messages.log file written to disk is now always in JSON format, though the container log continues to be available as either JSON or the human-readable "basic" format.
  • Fixed the signal handling inside the queue manager container image, so that it correctly processes control signals if the container is terminated by Red Hat® OpenShift® Container Platform before startup is complete.

9.3.3.3-r2

Required operator version
2.4.8 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.3-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.3-r2
  • icr.io/ibm-messaging/mq:9.3.3.3-r2
What's new
What's changed
  • What's changed in IBM MQ 9.3.3
  • Based on Red Hat Universal Base Image 8.9-1137
  • golang.org/x/crypto library has been upgraded to remediate CVE-2023-48795 vulnerability.
  • More secure SHA512 algorithm used instead of SHA256 to create self-signed certificate in the web keystore.
  • PKCS#12 key store for use with the IBM MQ web server is now generated using the Pkcs12.Modern.Encode function, which uses SHA-2 encryption (previously generated using a legacy SHA-1 encryption).
  • Vulnerability reported on PathTraversal method usages is fixed.

9.3.3.3-r1

Required operator version
2.4.7 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.3-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.3-r1
  • icr.io/ibm-messaging/mq:9.3.3.3-r1
What's new
What's changed
IBM MQ APARs included
  • IT44961
  • IT44821
  • IT44954
[Continuous Delivery]

9.3.3.2-r3

Required operator version
2.4.6 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.2-r3
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.2-r3
  • icr.io/ibm-messaging/mq:9.3.3.2-r3
What's new
What's changed
[Continuous Delivery]

9.3.3.2-r2

Required operator version
2.4.5 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.2-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.2-r2
  • icr.io/ibm-messaging/mq:9.3.3.2-r2
What's new
What's changed
[Continuous Delivery]

9.3.3.2-r1

Required operator version
2.4.4 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.2-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.2-r1
  • icr.io/ibm-messaging/mq:9.3.3.2-r1
What's new
What's changed
1
IBM MQ APARs included
  • IT41871
  • IT44585
  • IT44623
  • IT44762
[Continuous Delivery]

9.3.3.1-r2

Required operator version
2.4.3 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.1-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.1-r2
  • icr.io/ibm-messaging/mq:9.3.3.1-r2
What's new
What's changed
[Continuous Delivery]

9.3.3.1-r1

Required operator version
2.4.2 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.1-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.1-r1
  • icr.io/ibm-messaging/mq:9.3.3.1-r1
What's new
What's changed
[Continuous Delivery]

9.3.3.0-r2

Required operator version
2.4.1 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.0-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.0-r2
  • icr.io/ibm-messaging/mq:9.3.3.0-r2
What's new
What's changed
[Continuous Delivery]

9.3.3.0-r1

Required operator version
2.4.0 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.3.0-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.3.0-r1
  • icr.io/ibm-messaging/mq:9.3.3.0-r1
What's new
What's changed
[Continuous Delivery]

9.3.2.1-r2

Required operator version
2.3.3 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.2.1-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.2.1-r2
  • icr.io/ibm-messaging/mq:9.3.2.1-r2
What's new
What's changed
[Continuous Delivery]

9.3.2.1-r1

Required operator version
2.3.2 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.2.1-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.2.1-r1
  • icr.io/ibm-messaging/mq:9.3.2.1-r1
What's new
What's changed
[Continuous Delivery]

9.3.2.0-r2

Required operator version
2.3.1 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.2.0-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.2.0-r2
  • icr.io/ibm-messaging/mq:9.3.2.0-r2
What's new
What's changed
[Continuous Delivery]

9.3.2.0-r1

Required operator version
2.3.0 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.2.0-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.2.0-r1
  • icr.io/ibm-messaging/mq:9.3.2.0-r1
What's new
  • What's new in IBM MQ 9.3.2
  • The environment variable MQ_LOGGING_CONSOLE_FORMAT is now set, which replaces the deprecated LOG_FORMAT variable.
What's changed
[Continuous Delivery]

9.3.1.1-r1

Required operator version
2.2.2 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.1.1-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.1.1-r1
  • icr.io/ibm-messaging/mq:9.3.1.1-r1
What's new
What's changed
[Continuous Delivery]

9.3.1.0-r3

Required operator version
2.2.1 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.1.0-r3
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.1.0-r3
  • icr.io/ibm-messaging/mq:9.3.1.0-r3
What's new
What's changed
[Continuous Delivery]

9.3.1.0-r2

Required operator version
2.2.0 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.1.0-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.1.0-r2
  • icr.io/ibm-messaging/mq:9.3.1.0-r2
What's new
What's changed
[Continuous Delivery]

9.3.1.0-r1

Required operator version
2.1.0 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.1.0-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.1.0-r1
  • icr.io/ibm-messaging/mq:9.3.1.0-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.17-r2

Required operator version
2.0.22 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.17-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.17-r2
  • icr.io/ibm-messaging/mq:9.3.0.17-r2
What's new
What's changed
[CP4I Long Term Support]

9.3.0.17-r1

Required operator version
2.0.21 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.17-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.17-r1
  • icr.io/ibm-messaging/mq:9.3.0.17-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.16-r2

Required operator version
2.0.20 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.16-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.16-r2
  • icr.io/ibm-messaging/mq:9.3.0.16-r2
What's new
What's changed
[CP4I Long Term Support]

9.3.0.16-r1

Required operator version
2.0.19 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.16-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.16-r1
  • icr.io/ibm-messaging/mq:9.3.0.16-r1
What's new
What's changed
  • What's changed in IBM MQ 9.3.0
  • Security update built on IBM MQ 9.3.0.0-r1
  • Based on Red Hat Universal Base Image 8.9-1137
  • golang.org/x/crypto library has been upgraded to remediate CVE-2023-48795 vulnerability.
  • More secure SHA512 algorithm used instead of SHA256 to create self-signed certificate in the web keystore.
  • PKCS#12 key store for use with the IBM MQ web server is now generated using the Pkcs12.Modern.Encode function, which uses SHA-2 encryption (previously generated using a legacy SHA-1 encryption).
  • Vulnerability reported on PathTraversal method usages is fixed.
[CP4I Long Term Support]

9.3.0.15-r1

Required operator version
2.0.18 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.15-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.15-r1
  • icr.io/ibm-messaging/mq:9.3.0.15-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.11-r2

Required operator version
2.0.17 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.11-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.11-r2
  • icr.io/ibm-messaging/mq:9.3.0.11-r2
What's new
What's changed
[CP4I Long Term Support]

9.3.0.11-r1

Required operator version
2.0.16 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.11-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.11-r1
  • icr.io/ibm-messaging/mq:9.3.0.11-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.10-r2

Required operator version
2.0.15 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.10-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.10-r2
  • icr.io/ibm-messaging/mq:9.3.0.10-r2
What's new
What's changed
[CP4I Long Term Support]

9.3.0.10-r1

Required operator version
2.0.14 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.10-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.10-r1
  • icr.io/ibm-messaging/mq:9.3.0.10-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.6-r1

Required operator version
2.0.13 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.6-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.6-r1
  • icr.io/ibm-messaging/mq:9.3.0.6-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.5-r3

Required operator version
2.0.12 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.5-r3
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.5-r3
  • icr.io/ibm-messaging/mq:9.3.0.5-r3
What's new
What's changed
[CP4I Long Term Support]

9.3.0.5-r2

Required operator version
2.0.11 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.5-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.5-r2
  • icr.io/ibm-messaging/mq:9.3.0.5-r2
What's new
What's changed
Important: For users of Operations Dashboard on IBM MQ LTS Queue Manager Container Image 9.3.0.5-r2

When Operations Dashboard is enabled, IBM MQ LTS Queue Manager Container Image 9.3.0.5-r2 deploys Operations Dashboard Agent and Collector images that do not contain the latest security fixes available at the time of their General Availability.

Mitigation: Upgrade to at least 9.3.0.5-r3 all IBM MQ LTS Queue Manager Container 9.3.0.5-r2 images with Operations Dashboard enabled. See Upgrading an IBM MQ queue manager using Red Hat OpenShift.

[CP4I Long Term Support]

9.3.0.5-r1

Required operator version
2.0.10 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.5-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.5-r1
  • icr.io/ibm-messaging/mq:9.3.0.5-r1
What's new
What's changed
Important: For users of Operations Dashboard on IBM MQ LTS Queue Manager Container Image 9.3.0.5-r1

When Operations Dashboard is enabled, IBM MQ LTS Queue Manager Container Image 9.3.0.5-r1 deploys Operations Dashboard Agent and Collector images that do not contain the latest security fixes available at the time of their General Availability.

Mitigation: Upgrade to at least 9.3.0.5-r3 all IBM MQ LTS Queue Manager Container 9.3.0.5-r1 images with Operations Dashboard enabled. See Upgrading an IBM MQ queue manager using Red Hat OpenShift.

[CP4I Long Term Support]

9.3.0.4-r2

Required operator version
2.0.9 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.4-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.4-r2
  • icr.io/ibm-messaging/mq:9.3.0.4-r2
What's new
What's changed
[CP4I Long Term Support]

9.3.0.4-r1

Required operator version
2.0.8 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.4-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.4-r1
  • icr.io/ibm-messaging/mq:9.3.0.4-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.3-r1

Required operator version
2.0.7 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.3-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.3-r1
  • icr.io/ibm-messaging/mq:9.3.0.3-r1
What's new
What's changed
[CP4I Long Term Support]

9.3.0.1-r4

Required operator version
2.0.6 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.1-r4
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.1-r4
  • icr.io/ibm-messaging/mq:9.3.0.1-r4
What's new
What's changed
[CP4I Long Term Support]

9.3.0.1-r3

Required operator version
2.0.5 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.1-r3
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.1-r3
  • icr.io/ibm-messaging/mq:9.3.0.1-r3
What's new
What's changed
[CP4I Long Term Support]

9.3.0.1-r2

Required operator version
2.0.4 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.1-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.1-r2
  • icr.io/ibm-messaging/mq:9.3.0.1-r2
What's new
What's changed
[CP4I Long Term Support][Continuous Delivery]

9.3.0.1-r1

Required operator version
2.0.3 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.1-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.1-r1
  • icr.io/ibm-messaging/mq:9.3.0.1-r1
What's new
What's changed
[CP4I Long Term Support][Continuous Delivery]

9.3.0.0-r3

Required operator version
2.0.2 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.0-r3
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.0-r3
  • icr.io/ibm-messaging/mq:9.3.0.0-r3
What's new
What's changed
[CP4I Long Term Support][Continuous Delivery]

9.3.0.0-r2

Required operator version
2.0.1 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.0-r2
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.0-r2
  • icr.io/ibm-messaging/mq:9.3.0.0-r2
What's new
What's changed
[CP4I Long Term Support][Continuous Delivery]

9.3.0.0-r1

Required operator version
2.0.0 or higher
Supported architectures
amd64, s390x, ppc64le
Images
  • cp.icr.io/cp/ibm-mqadvanced-server-integration:9.3.0.0-r1
  • cp.icr.io/cp/ibm-mqadvanced-server:9.3.0.0-r1
  • icr.io/ibm-messaging/mq:9.3.0.0-r1
What's new
What's changed
1 A previous version of this topic incorrectly stated that IBM MQ Queue Manager Container image 9.3.3.2-r1 includes version 3.1.7 (2023.4.0) of the Instana MQ Exit.